Autodesk.Interop.ConnectionPoint Namespace

[image]

Autodesk Connection Point
Autodesk.Interop.ConnectionPoint Namespace
Send Feedback
Autodesk Connection Point (C) Copyright 2010 by Autodesk, Inc.

Classes

 | Class | Description
Public class | ConnectionPointManager |
Public class | ConnectionPointReferenceUtil |


ConnectionPointManager Class

[image]

Autodesk Connection Point
ConnectionPointManager Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Autodesk.Interop.ConnectionPoint.ConnectionPointManager"]

Namespace: Autodesk.Interop.ConnectionPoint
Assembly: AdskConnectionPoint (in AdskConnectionPoint.dll) Version: 0.0.0.0

Syntax

C#
public class ConnectionPointManager
Visual Basic
Public Class ConnectionPointManager
Visual C++
public ref class ConnectionPointManager

Inheritance Hierarchy

System..::..Object
Autodesk.Interop.ConnectionPoint..::..ConnectionPointManager

See Also

ConnectionPointManager Members
Autodesk.Interop.ConnectionPoint Namespace


ConnectionPointManager Members

[image] [image]

Autodesk Connection Point
ConnectionPointManager Members
ConnectionPointManager Class Constructors Methods Fields Properties See Also Send Feedback

The ConnectionPointManager type exposes the following members.

Constructors

 | Name | Description
Public method | ConnectionPointManager | Initializes a new instance of the ConnectionPointManager class

Methods

 | Name | Description
 | Connect(BlockReference, BlockReference) |
 | Connect(ObjectId, ObjectId) |
 | Connect(Transaction, ObjectId, ObjectId) |
 | CreateBlockReference |
 | CreateBlockTableRecord(Database) |
 | CreateBlockTableRecord(Transaction, Database) |
 | Disconnect(BlockReference) |
 | Disconnect(ObjectId) |
 | Disconnect(Transaction, ObjectId) |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBlockTableRecordId(Database) |
 | GetBlockTableRecordId(Transaction, Database) |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsBlockTableRecordDefined |
 | IsConnectionPoint |
 | LoadProperties |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SaveProperties |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
strBlockName |
strFileName |

Properties

Name | Description
BlockName |

See Also

ConnectionPointManager Class


ConnectionPointManager Constructor

[image]

Autodesk Connection Point
ConnectionPointManager Constructor
ConnectionPointManager Class See Also Send Feedback
Initializes a new instance of the ConnectionPointManager class

Namespace: Autodesk.Interop.ConnectionPoint
Assembly: AdskConnectionPoint (in AdskConnectionPoint.dll) Version: 0.0.0.0

Syntax

C#
public ConnectionPointManager()
Visual Basic
Public Sub New
Visual C++
public:
ConnectionPointManager()

See Also

ConnectionPointManager Class


ConnectionPointManager Fields

[image] [image]

Autodesk Connection Point
ConnectionPointManager Fields
ConnectionPointManager Class See Also Send Feedback

The ConnectionPointManager type exposes the following members.

Fields

Name | Description
strBlockName |
strFileName |

See Also

ConnectionPointManager Class


strBlockName Field

[image]

Autodesk Connection Point
ConnectionPointManager..::..strBlockName Field
ConnectionPointManager Class See Also Send Feedback

[Missing <summary> documentation for "F:Autodesk.Interop.ConnectionPoint.ConnectionPointManager.strBlockName"]

Namespace: Autodesk.Interop.ConnectionPoint
Assembly: AdskConnectionPoint (in AdskConnectionPoint.dll) Version: 0.0.0.0

Syntax

C#
public static string strBlockName
Visual Basic
Public Shared strBlockName As String
Visual C++
public:
static String^ strBlockName

See Also

ConnectionPointManager Class


strFileName Field

[image]

Autodesk Connection Point
ConnectionPointManager..::..strFileName Field
ConnectionPointManager Class See Also Send Feedback

[Missing <summary> documentation for "F:Autodesk.Interop.ConnectionPoint.ConnectionPointManager.strFileName"]

Namespace: Autodesk.Interop.ConnectionPoint
Assembly: AdskConnectionPoint (in AdskConnectionPoint.dll) Version: 0.0.0.0

Syntax

C#
public static string strFileName
Visual Basic
Public Shared strFileName As String
Visual C++
public:
static String^ strFileName

See Also

ConnectionPointManager Class


ConnectionPointManager Methods

[image] [image]

Autodesk Connection Point
ConnectionPointManager Methods
ConnectionPointManager Class See Also Send Feedback

The ConnectionPointManager type exposes the following members.

Methods

 | Name | Description
 | Connect(BlockReference, BlockReference) |
 | Connect(ObjectId, ObjectId) |
 | Connect(Transaction, ObjectId, ObjectId) |
 | CreateBlockReference |
 | CreateBlockTableRecord(Database) |
 | CreateBlockTableRecord(Transaction, Database) |
 | Disconnect(BlockReference) |
 | Disconnect(ObjectId) |
 | Disconnect(Transaction, ObjectId) |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBlockTableRecordId(Database) |
 | GetBlockTableRecordId(Transaction, Database) |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsBlockTableRecordDefined |
 | IsConnectionPoint |
 | LoadProperties |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SaveProperties |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ConnectionPointManager Class


Connect Method

[image] [image]

Autodesk Connection Point
ConnectionPointManager..::..Connect Method
ConnectionPointManager Class See Also Send Feedback

Overload List

Name | Description
Connect(BlockReference, BlockReference) |
Connect(ObjectId, ObjectId) |
Connect(Transaction, ObjectId, ObjectId) |

See Also

ConnectionPointManager Class
ConnectionPointManager Members


Connect Method (, )

[image]

Autodesk Connection Point
ConnectionPointManager..::..Connect Method (, )
ConnectionPointManager Class See Also Send Feedback

[Missing <summary> documentation for "M:Autodesk.Interop.ConnectionPoint.ConnectionPointManager.Connect(Autodesk.AutoCAD.DatabaseServices.BlockReference,Autodesk.AutoCAD.DatabaseServices.BlockReference)"]

Namespace: Autodesk.Interop.ConnectionPoint
Assembly: AdskConnectionPoint (in AdskConnectionPoint.dll) Version: 0.0.0.0

Syntax

C#
public static void Connect(
    BlockReference br1,
    BlockReference br2
)
Visual Basic
Public Shared Sub Connect ( _
    br1 As BlockReference, _
    br2 As BlockReference _
)
Visual C++
public:
static void Connect(
    BlockReference^ br1,
    BlockReference^ br2
)

Parameters

br1
Type: BlockReference

[Missing <param name="br1"/> documentation for "M:Autodesk.Interop.ConnectionPoint.ConnectionPointManager.Connect(Autodesk.AutoCAD.DatabaseServices.BlockReference,Autodesk.AutoCAD.DatabaseServices.BlockReference)"]

br2
Type: BlockReference

[Missing <param name="br2"/> documentation for "M:Autodesk.Interop.ConnectionPoint.ConnectionPointManager.Connect(Autodesk.AutoCAD.DatabaseServices.BlockReference,Autodesk.AutoCAD.DatabaseServices.BlockReference)"]

See Also

ConnectionPointManager Class
Connect Overload


Connect Method (, )

[image]

Autodesk Connection Point
ConnectionPointManager..::..Connect Method (, )
ConnectionPointManager Class See Also Send Feedback

[Missing <summary> documentation for "M:Autodesk.Interop.ConnectionPoint.ConnectionPointManager.Connect(Autodesk.AutoCAD.DatabaseServices.ObjectId,Autodesk.AutoCAD.DatabaseServices.ObjectId)"]

Namespace: Autodesk.Interop.ConnectionPoint
Assembly: AdskConnectionPoint (in AdskConnectionPoint.dll) Version: 0.0.0.0

Syntax

C#
public static void Connect(
    ObjectId brId1,
    ObjectId brId2
)
Visual Basic
Public Shared Sub Connect ( _
    brId1 As ObjectId, _
    brId2 As ObjectId _
)
Visual C++
public:
static void Connect(
    ObjectId brId1,
    ObjectId brId2
)

Parameters

brId1
Type: ObjectId

[Missing <param name="brId1"/> documentation for "M:Autodesk.Interop.ConnectionPoint.ConnectionPointManager.Connect(Autodesk.AutoCAD.DatabaseServices.ObjectId,Autodesk.AutoCAD.DatabaseServices.ObjectId)"]

brId2
Type: ObjectId

[Missing <param name="brId2"/> documentation for "M:Autodesk.Interop.ConnectionPoint.ConnectionPointManager.Connect(Autodesk.AutoCAD.DatabaseServices.ObjectId,Autodesk.AutoCAD.DatabaseServices.ObjectId)"]

See Also

ConnectionPointManager Class
Connect Overload


Connect Method (, , )

[image]

Autodesk Connection Point
ConnectionPointManager..::..Connect Method (, , )
ConnectionPointManager Class See Also Send Feedback

[Missing <summary> documentation for "M:Autodesk.Interop.ConnectionPoint.ConnectionPointManager.Connect(Autodesk.AutoCAD.DatabaseServices.Transaction,Autodesk.AutoCAD.DatabaseServices.ObjectId,Autodesk.AutoCAD.DatabaseServices.ObjectId)"]

Namespace: Autodesk.Interop.ConnectionPoint
Assembly: AdskConnectionPoint (in AdskConnectionPoint.dll) Version: 0.0.0.0

Syntax

C#
public static void Connect(
    Transaction tr,
    ObjectId brId1,
    ObjectId brId2
)
Visual Basic
Public Shared Sub Connect ( _
    tr As Transaction, _
    brId1 As ObjectId, _
    brId2 As ObjectId _
)
Visual C++
public:
static void Connect(
    Transaction^ tr,
    ObjectId brId1,
    ObjectId brId2
)

Parameters

tr
Type: Transaction

[Missing <param name="tr"/> documentation for "M:Autodesk.Interop.ConnectionPoint.ConnectionPointManager.Connect(Autodesk.AutoCAD.DatabaseServices.Transaction,Autodesk.AutoCAD.DatabaseServices.ObjectId,Autodesk.AutoCAD.DatabaseServices.ObjectId)"]

brId1
Type: ObjectId

[Missing <param name="brId1"/> documentation for "M:Autodesk.Interop.ConnectionPoint.ConnectionPointManager.Connect(Autodesk.AutoCAD.DatabaseServices.Transaction,Autodesk.AutoCAD.DatabaseServices.ObjectId,Autodesk.AutoCAD.DatabaseServices.ObjectId)"]

brId2
Type: ObjectId

[Missing <param name="brId2"/> documentation for "M:Autodesk.Interop.ConnectionPoint.ConnectionPointManager.Connect(Autodesk.AutoCAD.DatabaseServices.Transaction,Autodesk.AutoCAD.DatabaseServices.ObjectId,Autodesk.AutoCAD.DatabaseServices.ObjectId)"]

See Also

ConnectionPointManager Class
Connect Overload


CreateBlockReference Method

[image]

Autodesk Connection Point
ConnectionPointManager..::..CreateBlockReference Method
ConnectionPointManager Class See Also Send Feedback

[Missing <summary> documentation for "M:Autodesk.Interop.ConnectionPoint.ConnectionPointManager.CreateBlockReference(Autodesk.AutoCAD.DatabaseServices.Transaction,Autodesk.AutoCAD.DatabaseServices.BlockTableRecord)"]

Namespace: Autodesk.Interop.ConnectionPoint
Assembly: AdskConnectionPoint (in AdskConnectionPoint.dll) Version: 0.0.0.0

Syntax

C#
public static BlockReference CreateBlockReference(
    Transaction tr,
    BlockTableRecord btr
)
Visual Basic
Public Shared Function CreateBlockReference ( _
    tr As Transaction, _
    btr As BlockTableRecord _
) As BlockReference
Visual C++
public:
static BlockReference^ CreateBlockReference(
    Transaction^ tr,
    BlockTableRecord^ btr
)

Parameters

tr
Type: Transaction

[Missing <param name="tr"/> documentation for "M:Autodesk.Interop.ConnectionPoint.ConnectionPointManager.CreateBlockReference(Autodesk.AutoCAD.DatabaseServices.Transaction,Autodesk.AutoCAD.DatabaseServices.BlockTableRecord)"]

btr
Type: BlockTableRecord

[Missing <param name="btr"/> documentation for "M:Autodesk.Interop.ConnectionPoint.ConnectionPointManager.CreateBlockReference(Autodesk.AutoCAD.DatabaseServices.Transaction,Autodesk.AutoCAD.DatabaseServices.BlockTableRecord)"]

Return Value

[Missing <returns> documentation for "M:Autodesk.Interop.ConnectionPoint.ConnectionPointManager.CreateBlockReference(Autodesk.AutoCAD.DatabaseServices.Transaction,Autodesk.AutoCAD.DatabaseServices.BlockTableRecord)"]

See Also

ConnectionPointManager Class


CreateBlockTableRecord Method

[image] [image]

Autodesk Connection Point
ConnectionPointManager..::..CreateBlockTableRecord Method
ConnectionPointManager Class See Also Send Feedback

Overload List

Name | Description
CreateBlockTableRecord(Database) |
CreateBlockTableRecord(Transaction, Database) |

See Also

ConnectionPointManager Class
ConnectionPointManager Members


CreateBlockTableRecord Method ()

[image]

Autodesk Connection Point
ConnectionPointManager..::..CreateBlockTableRecord Method ()
ConnectionPointManager Class See Also Send Feedback

[Missing <summary> documentation for "M:Autodesk.Interop.ConnectionPoint.ConnectionPointManager.CreateBlockTableRecord(Autodesk.AutoCAD.DatabaseServices.Database)"]

Namespace: Autodesk.Interop.ConnectionPoint
Assembly: AdskConnectionPoint (in AdskConnectionPoint.dll) Version: 0.0.0.0

Syntax

C#
public static ObjectId CreateBlockTableRecord(
    Database dwg
)
Visual Basic
Public Shared Function CreateBlockTableRecord ( _
    dwg As Database _
) As ObjectId
Visual C++
public:
static ObjectId CreateBlockTableRecord(
    Database^ dwg
)

Parameters

dwg
Type: Database

[Missing <param name="dwg"/> documentation for "M:Autodesk.Interop.ConnectionPoint.ConnectionPointManager.CreateBlockTableRecord(Autodesk.AutoCAD.DatabaseServices.Database)"]

Return Value

[Missing <returns> documentation for "M:Autodesk.Interop.ConnectionPoint.ConnectionPointManager.CreateBlockTableRecord(Autodesk.AutoCAD.DatabaseServices.Database)"]

See Also

ConnectionPointManager Class
CreateBlockTableRecord Overload


CreateBlockTableRecord Method (, )

[image]

Autodesk Connection Point
ConnectionPointManager..::..CreateBlockTableRecord Method (, )
ConnectionPointManager Class See Also Send Feedback

[Missing <summary> documentation for "M:Autodesk.Interop.ConnectionPoint.ConnectionPointManager.CreateBlockTableRecord(Autodesk.AutoCAD.DatabaseServices.Transaction,Autodesk.AutoCAD.DatabaseServices.Database)"]

Namespace: Autodesk.Interop.ConnectionPoint
Assembly: AdskConnectionPoint (in AdskConnectionPoint.dll) Version: 0.0.0.0

Syntax

C#
public static ObjectId CreateBlockTableRecord(
    Transaction tr,
    Database dwg
)
Visual Basic
Public Shared Function CreateBlockTableRecord ( _
    tr As Transaction, _
    dwg As Database _
) As ObjectId
Visual C++
public:
static ObjectId CreateBlockTableRecord(
    Transaction^ tr,
    Database^ dwg
)

Parameters

tr
Type: Transaction

[Missing <param name="tr"/> documentation for "M:Autodesk.Interop.ConnectionPoint.ConnectionPointManager.CreateBlockTableRecord(Autodesk.AutoCAD.DatabaseServices.Transaction,Autodesk.AutoCAD.DatabaseServices.Database)"]

dwg
Type: Database

[Missing <param name="dwg"/> documentation for "M:Autodesk.Interop.ConnectionPoint.ConnectionPointManager.CreateBlockTableRecord(Autodesk.AutoCAD.DatabaseServices.Transaction,Autodesk.AutoCAD.DatabaseServices.Database)"]

Return Value

[Missing <returns> documentation for "M:Autodesk.Interop.ConnectionPoint.ConnectionPointManager.CreateBlockTableRecord(Autodesk.AutoCAD.DatabaseServices.Transaction,Autodesk.AutoCAD.DatabaseServices.Database)"]

See Also

ConnectionPointManager Class
CreateBlockTableRecord Overload


Disconnect Method

[image] [image]

Autodesk Connection Point
ConnectionPointManager..::..Disconnect Method
ConnectionPointManager Class See Also Send Feedback

Overload List

Name | Description
Disconnect(BlockReference) |
Disconnect(ObjectId) |
Disconnect(Transaction, ObjectId) |

See Also

ConnectionPointManager Class
ConnectionPointManager Members


Disconnect Method ()

[image]

Autodesk Connection Point
ConnectionPointManager..::..Disconnect Method ()
ConnectionPointManager Class See Also Send Feedback

[Missing <summary> documentation for "M:Autodesk.Interop.ConnectionPoint.ConnectionPointManager.Disconnect(Autodesk.AutoCAD.DatabaseServices.BlockReference)"]

Namespace: Autodesk.Interop.ConnectionPoint
Assembly: AdskConnectionPoint (in AdskConnectionPoint.dll) Version: 0.0.0.0

Syntax

C#
public static void Disconnect(
    BlockReference br
)
Visual Basic
Public Shared Sub Disconnect ( _
    br As BlockReference _
)
Visual C++
public:
static void Disconnect(
    BlockReference^ br
)

Parameters

br
Type: BlockReference

[Missing <param name="br"/> documentation for "M:Autodesk.Interop.ConnectionPoint.ConnectionPointManager.Disconnect(Autodesk.AutoCAD.DatabaseServices.BlockReference)"]

See Also

ConnectionPointManager Class
Disconnect Overload


Disconnect Method ()

[image]

Autodesk Connection Point
ConnectionPointManager..::..Disconnect Method ()
ConnectionPointManager Class See Also Send Feedback

[Missing <summary> documentation for "M:Autodesk.Interop.ConnectionPoint.ConnectionPointManager.Disconnect(Autodesk.AutoCAD.DatabaseServices.ObjectId)"]

Namespace: Autodesk.Interop.ConnectionPoint
Assembly: AdskConnectionPoint (in AdskConnectionPoint.dll) Version: 0.0.0.0

Syntax

C#
public static void Disconnect(
    ObjectId brId
)
Visual Basic
Public Shared Sub Disconnect ( _
    brId As ObjectId _
)
Visual C++
public:
static void Disconnect(
    ObjectId brId
)

Parameters

brId
Type: ObjectId

[Missing <param name="brId"/> documentation for "M:Autodesk.Interop.ConnectionPoint.ConnectionPointManager.Disconnect(Autodesk.AutoCAD.DatabaseServices.ObjectId)"]

See Also

ConnectionPointManager Class
Disconnect Overload


Disconnect Method (, )

[image]

Autodesk Connection Point
ConnectionPointManager..::..Disconnect Method (, )
ConnectionPointManager Class See Also Send Feedback

[Missing <summary> documentation for "M:Autodesk.Interop.ConnectionPoint.ConnectionPointManager.Disconnect(Autodesk.AutoCAD.DatabaseServices.Transaction,Autodesk.AutoCAD.DatabaseServices.ObjectId)"]

Namespace: Autodesk.Interop.ConnectionPoint
Assembly: AdskConnectionPoint (in AdskConnectionPoint.dll) Version: 0.0.0.0

Syntax

C#
public static void Disconnect(
    Transaction tr,
    ObjectId brId
)
Visual Basic
Public Shared Sub Disconnect ( _
    tr As Transaction, _
    brId As ObjectId _
)
Visual C++
public:
static void Disconnect(
    Transaction^ tr,
    ObjectId brId
)

Parameters

tr
Type: Transaction

[Missing <param name="tr"/> documentation for "M:Autodesk.Interop.ConnectionPoint.ConnectionPointManager.Disconnect(Autodesk.AutoCAD.DatabaseServices.Transaction,Autodesk.AutoCAD.DatabaseServices.ObjectId)"]

brId
Type: ObjectId

[Missing <param name="brId"/> documentation for "M:Autodesk.Interop.ConnectionPoint.ConnectionPointManager.Disconnect(Autodesk.AutoCAD.DatabaseServices.Transaction,Autodesk.AutoCAD.DatabaseServices.ObjectId)"]

See Also

ConnectionPointManager Class
Disconnect Overload


GetBlockTableRecordId Method

[image] [image]

Autodesk Connection Point
ConnectionPointManager..::..GetBlockTableRecordId Method
ConnectionPointManager Class See Also Send Feedback

Overload List

Name | Description
GetBlockTableRecordId(Database) |
GetBlockTableRecordId(Transaction, Database) |

See Also

ConnectionPointManager Class
ConnectionPointManager Members


GetBlockTableRecordId Method ()

[image]

Autodesk Connection Point
ConnectionPointManager..::..GetBlockTableRecordId Method ()
ConnectionPointManager Class See Also Send Feedback

[Missing <summary> documentation for "M:Autodesk.Interop.ConnectionPoint.ConnectionPointManager.GetBlockTableRecordId(Autodesk.AutoCAD.DatabaseServices.Database)"]

Namespace: Autodesk.Interop.ConnectionPoint
Assembly: AdskConnectionPoint (in AdskConnectionPoint.dll) Version: 0.0.0.0

Syntax

C#
public static ObjectId GetBlockTableRecordId(
    Database dwg
)
Visual Basic
Public Shared Function GetBlockTableRecordId ( _
    dwg As Database _
) As ObjectId
Visual C++
public:
static ObjectId GetBlockTableRecordId(
    Database^ dwg
)

Parameters

dwg
Type: Database

[Missing <param name="dwg"/> documentation for "M:Autodesk.Interop.ConnectionPoint.ConnectionPointManager.GetBlockTableRecordId(Autodesk.AutoCAD.DatabaseServices.Database)"]

Return Value

[Missing <returns> documentation for "M:Autodesk.Interop.ConnectionPoint.ConnectionPointManager.GetBlockTableRecordId(Autodesk.AutoCAD.DatabaseServices.Database)"]

See Also

ConnectionPointManager Class
GetBlockTableRecordId Overload


GetBlockTableRecordId Method (, )

[image]

Autodesk Connection Point
ConnectionPointManager..::..GetBlockTableRecordId Method (, )
ConnectionPointManager Class See Also Send Feedback

[Missing <summary> documentation for "M:Autodesk.Interop.ConnectionPoint.ConnectionPointManager.GetBlockTableRecordId(Autodesk.AutoCAD.DatabaseServices.Transaction,Autodesk.AutoCAD.DatabaseServices.Database)"]

Namespace: Autodesk.Interop.ConnectionPoint
Assembly: AdskConnectionPoint (in AdskConnectionPoint.dll) Version: 0.0.0.0

Syntax

C#
public static ObjectId GetBlockTableRecordId(
    Transaction tr,
    Database dwg
)
Visual Basic
Public Shared Function GetBlockTableRecordId ( _
    tr As Transaction, _
    dwg As Database _
) As ObjectId
Visual C++
public:
static ObjectId GetBlockTableRecordId(
    Transaction^ tr,
    Database^ dwg
)

Parameters

tr
Type: Transaction

[Missing <param name="tr"/> documentation for "M:Autodesk.Interop.ConnectionPoint.ConnectionPointManager.GetBlockTableRecordId(Autodesk.AutoCAD.DatabaseServices.Transaction,Autodesk.AutoCAD.DatabaseServices.Database)"]

dwg
Type: Database

[Missing <param name="dwg"/> documentation for "M:Autodesk.Interop.ConnectionPoint.ConnectionPointManager.GetBlockTableRecordId(Autodesk.AutoCAD.DatabaseServices.Transaction,Autodesk.AutoCAD.DatabaseServices.Database)"]

Return Value

[Missing <returns> documentation for "M:Autodesk.Interop.ConnectionPoint.ConnectionPointManager.GetBlockTableRecordId(Autodesk.AutoCAD.DatabaseServices.Transaction,Autodesk.AutoCAD.DatabaseServices.Database)"]

See Also

ConnectionPointManager Class
GetBlockTableRecordId Overload


IsBlockTableRecordDefined Method

[image]

Autodesk Connection Point
ConnectionPointManager..::..IsBlockTableRecordDefined Method
ConnectionPointManager Class See Also Send Feedback

[Missing <summary> documentation for "M:Autodesk.Interop.ConnectionPoint.ConnectionPointManager.IsBlockTableRecordDefined(Autodesk.AutoCAD.DatabaseServices.Database)"]

Namespace: Autodesk.Interop.ConnectionPoint
Assembly: AdskConnectionPoint (in AdskConnectionPoint.dll) Version: 0.0.0.0

Syntax

C#
public static bool IsBlockTableRecordDefined(
    Database dwg
)
Visual Basic
Public Shared Function IsBlockTableRecordDefined ( _
    dwg As Database _
) As Boolean
Visual C++
public:
static bool IsBlockTableRecordDefined(
    Database^ dwg
)

Parameters

dwg
Type: Database

[Missing <param name="dwg"/> documentation for "M:Autodesk.Interop.ConnectionPoint.ConnectionPointManager.IsBlockTableRecordDefined(Autodesk.AutoCAD.DatabaseServices.Database)"]

Return Value

[Missing <returns> documentation for "M:Autodesk.Interop.ConnectionPoint.ConnectionPointManager.IsBlockTableRecordDefined(Autodesk.AutoCAD.DatabaseServices.Database)"]

See Also

ConnectionPointManager Class


IsConnectionPoint Method

[image]

Autodesk Connection Point
ConnectionPointManager..::..IsConnectionPoint Method
ConnectionPointManager Class See Also Send Feedback

[Missing <summary> documentation for "M:Autodesk.Interop.ConnectionPoint.ConnectionPointManager.IsConnectionPoint(Autodesk.AutoCAD.DatabaseServices.BlockReference)"]

Namespace: Autodesk.Interop.ConnectionPoint
Assembly: AdskConnectionPoint (in AdskConnectionPoint.dll) Version: 0.0.0.0

Syntax

C#
public static bool IsConnectionPoint(
    BlockReference blkRef
)
Visual Basic
Public Shared Function IsConnectionPoint ( _
    blkRef As BlockReference _
) As Boolean
Visual C++
public:
static bool IsConnectionPoint(
    BlockReference^ blkRef
)

Parameters

blkRef
Type: BlockReference

[Missing <param name="blkRef"/> documentation for "M:Autodesk.Interop.ConnectionPoint.ConnectionPointManager.IsConnectionPoint(Autodesk.AutoCAD.DatabaseServices.BlockReference)"]

Return Value

[Missing <returns> documentation for "M:Autodesk.Interop.ConnectionPoint.ConnectionPointManager.IsConnectionPoint(Autodesk.AutoCAD.DatabaseServices.BlockReference)"]

See Also

ConnectionPointManager Class


LoadProperties Method

[image]

Autodesk Connection Point
ConnectionPointManager..::..LoadProperties Method
ConnectionPointManager Class See Also Send Feedback

[Missing <summary> documentation for "M:Autodesk.Interop.ConnectionPoint.ConnectionPointManager.LoadProperties(System.String)"]

Namespace: Autodesk.Interop.ConnectionPoint
Assembly: AdskConnectionPoint (in AdskConnectionPoint.dll) Version: 0.0.0.0

Syntax

C#
public static Dictionary<string, string> LoadProperties(
    string strXmlFileName
)
Visual Basic
Public Shared Function LoadProperties ( _
    strXmlFileName As String _
) As Dictionary(Of String, String)
Visual C++
public:
static Dictionary<String^, String^>^ LoadProperties(
    String^ strXmlFileName
)

Parameters

strXmlFileName
Type: System..::..String

[Missing <param name="strXmlFileName"/> documentation for "M:Autodesk.Interop.ConnectionPoint.ConnectionPointManager.LoadProperties(System.String)"]

Return Value

[Missing <returns> documentation for "M:Autodesk.Interop.ConnectionPoint.ConnectionPointManager.LoadProperties(System.String)"]

See Also

ConnectionPointManager Class


SaveProperties Method

[image]

Autodesk Connection Point
ConnectionPointManager..::..SaveProperties Method
ConnectionPointManager Class See Also Send Feedback

[Missing <summary> documentation for "M:Autodesk.Interop.ConnectionPoint.ConnectionPointManager.SaveProperties(System.String,System.Collections.Generic.Dictionary{System.String,System.String})"]

Namespace: Autodesk.Interop.ConnectionPoint
Assembly: AdskConnectionPoint (in AdskConnectionPoint.dll) Version: 0.0.0.0

Syntax

C#
public static void SaveProperties(
    string strXmlFileName,
    Dictionary<string, string> props
)
Visual Basic
Public Shared Sub SaveProperties ( _
    strXmlFileName As String, _
    props As Dictionary(Of String, String) _
)
Visual C++
public:
static void SaveProperties(
    String^ strXmlFileName,
    Dictionary<String^, String^>^ props
)

Parameters

strXmlFileName
Type: System..::..String

[Missing <param name="strXmlFileName"/> documentation for "M:Autodesk.Interop.ConnectionPoint.ConnectionPointManager.SaveProperties(System.String,System.Collections.Generic.Dictionary{System.String,System.String})"]

props
Type: System.Collections.Generic..::..Dictionary <(Of <(<' String, String >)>)>

[Missing <param name="props"/> documentation for "M:Autodesk.Interop.ConnectionPoint.ConnectionPointManager.SaveProperties(System.String,System.Collections.Generic.Dictionary{System.String,System.String})"]

See Also

ConnectionPointManager Class


ConnectionPointManager Properties

[image] [image]

Autodesk Connection Point
ConnectionPointManager Properties
ConnectionPointManager Class See Also Send Feedback

The ConnectionPointManager type exposes the following members.

Properties

Name | Description
BlockName |

See Also

ConnectionPointManager Class


BlockName Property

[image]

Autodesk Connection Point
ConnectionPointManager..::..BlockName Property
ConnectionPointManager Class See Also Send Feedback

[Missing <summary> documentation for "P:Autodesk.Interop.ConnectionPoint.ConnectionPointManager.BlockName"]

Namespace: Autodesk.Interop.ConnectionPoint
Assembly: AdskConnectionPoint (in AdskConnectionPoint.dll) Version: 0.0.0.0

Syntax

C#
public static string BlockName { get; }
Visual Basic
Public Shared ReadOnly Property BlockName As String
    Get
Visual C++
public:
static property String^ BlockName {
    String^ get ();
}

See Also

ConnectionPointManager Class


ConnectionPointReferenceUtil Class

[image]

Autodesk Connection Point
ConnectionPointReferenceUtil Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Autodesk.Interop.ConnectionPoint.ConnectionPointReferenceUtil"]

Namespace: Autodesk.Interop.ConnectionPoint
Assembly: AdskConnectionPoint (in AdskConnectionPoint.dll) Version: 0.0.0.0

Syntax

C#
public class ConnectionPointReferenceUtil
Visual Basic
Public Class ConnectionPointReferenceUtil
Visual C++
public ref class ConnectionPointReferenceUtil

Inheritance Hierarchy

System..::..Object
Autodesk.Interop.ConnectionPoint..::..ConnectionPointReferenceUtil

See Also

ConnectionPointReferenceUtil Members


ConnectionPointReferenceUtil Members

[image] [image]

Autodesk Connection Point
ConnectionPointReferenceUtil Members
ConnectionPointReferenceUtil Class Constructors Methods Fields Properties See Also Send Feedback

The ConnectionPointReferenceUtil type exposes the following members.

Constructors

 | Name | Description
Public method | ConnectionPointReferenceUtil | Initializes a new instance of the ConnectionPointReferenceUtil class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperties |
Public method | GetProperty |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SaveToXml |
Public method | SetProperties |
Public method | SetProperty |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | m_blkRef |

Properties

 | Name | Description
Public property | AttachedTo |
Public property | BlockReference |
Public property | Direction |
Public property | Guid |
Public property | IsValid |
Public property | Name |
Public property | Position |

See Also

ConnectionPointReferenceUtil Class


ConnectionPointReferenceUtil Constructor

[image]

Autodesk Connection Point
ConnectionPointReferenceUtil Constructor
ConnectionPointReferenceUtil Class See Also Send Feedback
Initializes a new instance of the ConnectionPointReferenceUtil class

Namespace: Autodesk.Interop.ConnectionPoint
Assembly: AdskConnectionPoint (in AdskConnectionPoint.dll) Version: 0.0.0.0

Syntax

C#
public ConnectionPointReferenceUtil(
    BlockReference blkRef
)
Visual Basic
Public Sub New ( _
    blkRef As BlockReference _
)
Visual C++
public:
ConnectionPointReferenceUtil(
    BlockReference^ blkRef
)

Parameters

blkRef
Type: BlockReference

[Missing <param name="blkRef"/> documentation for "M:Autodesk.Interop.ConnectionPoint.ConnectionPointReferenceUtil.#ctor(Autodesk.AutoCAD.DatabaseServices.BlockReference)"]

See Also

ConnectionPointReferenceUtil Class


ConnectionPointReferenceUtil Fields

[image] [image]

Autodesk Connection Point
ConnectionPointReferenceUtil Fields
ConnectionPointReferenceUtil Class See Also Send Feedback

The ConnectionPointReferenceUtil type exposes the following members.

Fields

 | Name | Description
Protected field | m_blkRef |

See Also

ConnectionPointReferenceUtil Class


m_blkRef Field

[image]

Autodesk Connection Point
ConnectionPointReferenceUtil..::..m_blkRef Field
ConnectionPointReferenceUtil Class See Also Send Feedback

[Missing <summary> documentation for "F:Autodesk.Interop.ConnectionPoint.ConnectionPointReferenceUtil.m_blkRef"]

Namespace: Autodesk.Interop.ConnectionPoint
Assembly: AdskConnectionPoint (in AdskConnectionPoint.dll) Version: 0.0.0.0

Syntax

C#
protected BlockReference m_blkRef
Visual Basic
Protected m_blkRef As BlockReference
Visual C++
protected:
BlockReference^ m_blkRef

See Also

ConnectionPointReferenceUtil Class


ConnectionPointReferenceUtil Methods

[image] [image]

Autodesk Connection Point
ConnectionPointReferenceUtil Methods
ConnectionPointReferenceUtil Class See Also Send Feedback

The ConnectionPointReferenceUtil type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperties |
Public method | GetProperty |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SaveToXml |
Public method | SetProperties |
Public method | SetProperty |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ConnectionPointReferenceUtil Class


GetProperties Method

[image]

Autodesk Connection Point
ConnectionPointReferenceUtil..::..GetProperties Method
ConnectionPointReferenceUtil Class See Also Send Feedback

[Missing <summary> documentation for "M:Autodesk.Interop.ConnectionPoint.ConnectionPointReferenceUtil.GetProperties"]

Namespace: Autodesk.Interop.ConnectionPoint
Assembly: AdskConnectionPoint (in AdskConnectionPoint.dll) Version: 0.0.0.0

Syntax

C#
public Dictionary<string, string> GetProperties()
Visual Basic
Public Function GetProperties As Dictionary(Of String, String)
Visual C++
public:
Dictionary<String^, String^>^ GetProperties()

Return Value

[Missing <returns> documentation for "M:Autodesk.Interop.ConnectionPoint.ConnectionPointReferenceUtil.GetProperties"]

See Also

ConnectionPointReferenceUtil Class


GetProperty Method

[image]

Autodesk Connection Point
ConnectionPointReferenceUtil..::..GetProperty Method
ConnectionPointReferenceUtil Class See Also Send Feedback

[Missing <summary> documentation for "M:Autodesk.Interop.ConnectionPoint.ConnectionPointReferenceUtil.GetProperty(System.String)"]

Namespace: Autodesk.Interop.ConnectionPoint
Assembly: AdskConnectionPoint (in AdskConnectionPoint.dll) Version: 0.0.0.0

Syntax

C#
public string GetProperty(
    string propName
)
Visual Basic
Public Function GetProperty ( _
    propName As String _
) As String
Visual C++
public:
String^ GetProperty(
    String^ propName
)

Parameters

propName
Type: System..::..String

[Missing <param name="propName"/> documentation for "M:Autodesk.Interop.ConnectionPoint.ConnectionPointReferenceUtil.GetProperty(System.String)"]

Return Value

[Missing <returns> documentation for "M:Autodesk.Interop.ConnectionPoint.ConnectionPointReferenceUtil.GetProperty(System.String)"]

See Also

ConnectionPointReferenceUtil Class


SaveToXml Method

[image]

Autodesk Connection Point
ConnectionPointReferenceUtil..::..SaveToXml Method
ConnectionPointReferenceUtil Class See Also Send Feedback

[Missing <summary> documentation for "M:Autodesk.Interop.ConnectionPoint.ConnectionPointReferenceUtil.SaveToXml(System.String)"]

Namespace: Autodesk.Interop.ConnectionPoint
Assembly: AdskConnectionPoint (in AdskConnectionPoint.dll) Version: 0.0.0.0

Syntax

C#
public void SaveToXml(
    string strXmlFileName
)
Visual Basic
Public Sub SaveToXml ( _
    strXmlFileName As String _
)
Visual C++
public:
void SaveToXml(
    String^ strXmlFileName
)

Parameters

strXmlFileName
Type: System..::..String

[Missing <param name="strXmlFileName"/> documentation for "M:Autodesk.Interop.ConnectionPoint.ConnectionPointReferenceUtil.SaveToXml(System.String)"]

See Also

ConnectionPointReferenceUtil Class


SetProperties Method

[image]

Autodesk Connection Point
ConnectionPointReferenceUtil..::..SetProperties Method
ConnectionPointReferenceUtil Class See Also Send Feedback

[Missing <summary> documentation for "M:Autodesk.Interop.ConnectionPoint.ConnectionPointReferenceUtil.SetProperties(System.Collections.Generic.Dictionary{System.String,System.String})"]

Namespace: Autodesk.Interop.ConnectionPoint
Assembly: AdskConnectionPoint (in AdskConnectionPoint.dll) Version: 0.0.0.0

Syntax

C#
public void SetProperties(
    Dictionary<string, string> props
)
Visual Basic
Public Sub SetProperties ( _
    props As Dictionary(Of String, String) _
)
Visual C++
public:
void SetProperties(
    Dictionary<String^, String^>^ props
)

Parameters

props
Type: System.Collections.Generic..::..Dictionary <(Of <(<' String, String >)>)>

[Missing <param name="props"/> documentation for "M:Autodesk.Interop.ConnectionPoint.ConnectionPointReferenceUtil.SetProperties(System.Collections.Generic.Dictionary{System.String,System.String})"]

See Also

ConnectionPointReferenceUtil Class


SetProperty Method

[image]

Autodesk Connection Point
ConnectionPointReferenceUtil..::..SetProperty Method
ConnectionPointReferenceUtil Class See Also Send Feedback

[Missing <summary> documentation for "M:Autodesk.Interop.ConnectionPoint.ConnectionPointReferenceUtil.SetProperty(System.String,System.String)"]

Namespace: Autodesk.Interop.ConnectionPoint
Assembly: AdskConnectionPoint (in AdskConnectionPoint.dll) Version: 0.0.0.0

Syntax

C#
public void SetProperty(
    string propName,
    string propValue
)
Visual Basic
Public Sub SetProperty ( _
    propName As String, _
    propValue As String _
)
Visual C++
public:
void SetProperty(
    String^ propName,
    String^ propValue
)

Parameters

propName
Type: System..::..String

[Missing <param name="propName"/> documentation for "M:Autodesk.Interop.ConnectionPoint.ConnectionPointReferenceUtil.SetProperty(System.String,System.String)"]

propValue
Type: System..::..String

[Missing <param name="propValue"/> documentation for "M:Autodesk.Interop.ConnectionPoint.ConnectionPointReferenceUtil.SetProperty(System.String,System.String)"]

See Also

ConnectionPointReferenceUtil Class


ConnectionPointReferenceUtil Properties

[image] [image]

Autodesk Connection Point
ConnectionPointReferenceUtil Properties
ConnectionPointReferenceUtil Class See Also Send Feedback

The ConnectionPointReferenceUtil type exposes the following members.

Properties

 | Name | Description
Public property | AttachedTo |
Public property | BlockReference |
Public property | Direction |
Public property | Guid |
Public property | IsValid |
Public property | Name |
Public property | Position |

See Also

ConnectionPointReferenceUtil Class


AttachedTo Property

[image]

Autodesk Connection Point
ConnectionPointReferenceUtil..::..AttachedTo Property
ConnectionPointReferenceUtil Class See Also Send Feedback

[Missing <summary> documentation for "P:Autodesk.Interop.ConnectionPoint.ConnectionPointReferenceUtil.AttachedTo"]

Namespace: Autodesk.Interop.ConnectionPoint
Assembly: AdskConnectionPoint (in AdskConnectionPoint.dll) Version: 0.0.0.0

Syntax

C#
public Handle AttachedTo { get; set; }
Visual Basic
Public Property AttachedTo As Handle
    Get
    Set
Visual C++
public:
property Handle AttachedTo {
    Handle get ();
    void set (Handle value);
}

See Also

ConnectionPointReferenceUtil Class


BlockReference Property

[image]

Autodesk Connection Point
ConnectionPointReferenceUtil..::..BlockReference Property
ConnectionPointReferenceUtil Class See Also Send Feedback

[Missing <summary> documentation for "P:Autodesk.Interop.ConnectionPoint.ConnectionPointReferenceUtil.BlockReference"]

Namespace: Autodesk.Interop.ConnectionPoint
Assembly: AdskConnectionPoint (in AdskConnectionPoint.dll) Version: 0.0.0.0

Syntax

C#
public BlockReference BlockReference { get; }
Visual Basic
Public ReadOnly Property BlockReference As BlockReference
    Get
Visual C++
public:
property BlockReference^ BlockReference {
    BlockReference^ get ();
}

See Also

ConnectionPointReferenceUtil Class


Direction Property

[image]

Autodesk Connection Point
ConnectionPointReferenceUtil..::..Direction Property
ConnectionPointReferenceUtil Class See Also Send Feedback

[Missing <summary> documentation for "P:Autodesk.Interop.ConnectionPoint.ConnectionPointReferenceUtil.Direction"]

Namespace: Autodesk.Interop.ConnectionPoint
Assembly: AdskConnectionPoint (in AdskConnectionPoint.dll) Version: 0.0.0.0

Syntax

C#
public Vector3d Direction { get; set; }
Visual Basic
Public Property Direction As Vector3d
    Get
    Set
Visual C++
public:
property Vector3d Direction {
    Vector3d get ();
    void set (Vector3d value);
}

See Also

ConnectionPointReferenceUtil Class


Guid Property

[image]

Autodesk Connection Point
ConnectionPointReferenceUtil..::..Guid Property
ConnectionPointReferenceUtil Class See Also Send Feedback

[Missing <summary> documentation for "P:Autodesk.Interop.ConnectionPoint.ConnectionPointReferenceUtil.Guid"]

Namespace: Autodesk.Interop.ConnectionPoint
Assembly: AdskConnectionPoint (in AdskConnectionPoint.dll) Version: 0.0.0.0

Syntax

C#
public Guid Guid { get; set; }
Visual Basic
Public Property Guid As Guid
    Get
    Set
Visual C++
public:
property Guid Guid {
    Guid get ();
    void set (Guid value);
}

See Also

ConnectionPointReferenceUtil Class


IsValid Property

[image]

Autodesk Connection Point
ConnectionPointReferenceUtil..::..IsValid Property
ConnectionPointReferenceUtil Class See Also Send Feedback

[Missing <summary> documentation for "P:Autodesk.Interop.ConnectionPoint.ConnectionPointReferenceUtil.IsValid"]

Namespace: Autodesk.Interop.ConnectionPoint
Assembly: AdskConnectionPoint (in AdskConnectionPoint.dll) Version: 0.0.0.0

Syntax

C#
public bool IsValid { get; }
Visual Basic
Public ReadOnly Property IsValid As Boolean
    Get
Visual C++
public:
property bool IsValid {
    bool get ();
}

See Also

ConnectionPointReferenceUtil Class


Name Property

[image]

Autodesk Connection Point
ConnectionPointReferenceUtil..::..Name Property
ConnectionPointReferenceUtil Class See Also Send Feedback

[Missing <summary> documentation for "P:Autodesk.Interop.ConnectionPoint.ConnectionPointReferenceUtil.Name"]

Namespace: Autodesk.Interop.ConnectionPoint
Assembly: AdskConnectionPoint (in AdskConnectionPoint.dll) Version: 0.0.0.0

Syntax

C#
public string Name { get; }
Visual Basic
Public ReadOnly Property Name As String
    Get
Visual C++
public:
property String^ Name {
    String^ get ();
}

See Also

ConnectionPointReferenceUtil Class


Position Property

[image]

Autodesk Connection Point
ConnectionPointReferenceUtil..::..Position Property
ConnectionPointReferenceUtil Class See Also Send Feedback

[Missing <summary> documentation for "P:Autodesk.Interop.ConnectionPoint.ConnectionPointReferenceUtil.Position"]

Namespace: Autodesk.Interop.ConnectionPoint
Assembly: AdskConnectionPoint (in AdskConnectionPoint.dll) Version: 0.0.0.0

Syntax

C#
public Point3d Position { get; set; }
Visual Basic
Public Property Position As Point3d
    Get
    Set
Visual C++
public:
property Point3d Position {
    Point3d get ();
    void set (Point3d value);
}

See Also

ConnectionPointReferenceUtil Class