AutoCAD 2010 개발자 도움말

AutoCAD 2010 개발자 도움말 시작

AutoCAD 개발자 도움말은 AutoCAD를 사용자화하고 확장하기 위한 모든 정보를 제공합니다. 오른쪽에 있는 링크를 클릭하거나 목차 탭을 사용하여 도움말 항목을 찾아 보십시오.

일반 정보

도움말 파일

사용자화 안내서

AutoLISP 참조서

AutoLISP 개발자 안내서

AutoLISP 튜토리얼

DXF 참조서

ActiveX/VBA 개발자 안내서

ActiveX and VBA Reference

시트 세트 객체 참조서

연결성 자동화 참조서

ObjectARX
온라인 리소스


AutoCAD 2010

사용자화 안내서

사용자화 안내서는 경험이 풍부한 사용자를 위해 AutoCAD 사용자화 방법을 설명합니다. 사용자화 안내서를 찾아보려면 도움말 윈도우 왼쪽에 있는 목차 탭을 사용하십시오.

  • 기본 사용자화
  • 사용자 선종류
  • 사용자 해치 패턴
  • 사용자 인터페이스 사용자화
  • DIESEL
  • 슬라이드 및 명령 스크립트
  • 프로그래밍 인터페이스 소개
  • 쉐이프 및 쉐이프 글꼴
일반 정보

도움말 파일

사용자화 안내서

AutoLISP 참조서

AutoLISP 개발자 안내서

AutoLISP 튜토리얼

DXF 참조서

ActiveX/VBA 개발자 안내서


AutoLISP 참조서

AutoLISP Reference는 AutoCAD 명령, 시스템 변수 및 대화상자를 호출하기 위한 모든 기능이 갖춰진 해석 프로그래밍 언어인 AutoLISP®에 대한 포괄적인 참조서입니다. AutoLISP Reference에는 다음과 같은 주제가 포함되어 있습니다.

  • AutoLISP 함수: 연산자, A, B, C, D, E, F, G, H, I, J, K, L, M, N, O, P, Q, R, S, T, U, V, W, X, Y, Z.
  • 외부 정의 명령어
일반 정보

도움말 파일

사용자화 안내서

AutoLISP 참조서

AutoLISP 개발자 안내서

AutoLISP 튜토리얼


AutoLISP 개발자 안내서

AutoLISP 개발자 안내서는 대화식 Visual LISP® 개발 환경을 사용하여 AutoLISP® 프로그램을 개발하고 테스트하기 위한 정보를 제공합니다. 본 안내서는 또한 Visual LISP와 함께 제공되는 확장기능을 사용하여 ActiveX® 자동화를 작성하는 방법을 설명합니다. AutoLISP 개발자 안내서에는 다음과 같은 주제가 포함되어 있습니다.

  • 소개
  • Visual LISP 환경 사용
  • AutoLISP 언어 사용
  • 프로그래밍할 수 있는 대화상자로 작업
  • 부록
일반 정보

도움말 파일

사용자화 안내서

AutoLISP 참조서

AutoLISP 개발자 안내서

AutoLISP 튜토리얼


AutoLISP 튜토리얼

AutoLISP 튜토리얼은 Visual LISP™를 사용하여 AutoLISP® 응용프로그램을 개발하는 방법을 가르쳐 주는 단계별 학습서입니다. AutoLISP 튜토리얼에는 다음과 같은 주제가 포함되어 있습니다.

  • 소개
  • 프로그램 설계 및 시작
  • Visual LISP 디버깅 도구 사용
  • 경로 경계 그리기
  • 프로젝트 작성 및 인터페이스 추가
  • 타일 그리기
  • 리액터로 작업
  • 모두 결합
일반 정보

도움말 파일

사용자화 안내서

AutoLISP 참조서

AutoLISP 개발자 안내서

AutoLISP 튜토리얼


DXF 참조서

DXF 참조서는 DXF™ 파일 형식에 대한 포괄적인 참조서입니다. DXF 참조서에는 다음과 같은 주제가 포함되어 있습니다.

  • DXF 형식
  • HEADER 섹션
  • CLASSES 섹션
  • TABLES 섹션
  • BLOCKS 섹션
  • ENTITIES 섹션
  • OBJECTS 섹션
  • THUMBNAILIMAGE 섹션
  • 도면 교환 파일 형식
  • DXF 고급 정보
일반 정보

도움말 파일

사용자화 안내서

AutoLISP 참조서

AutoLISP 개발자 안내서

AutoLISP 튜토리얼


ActiveX/VBA 개발자 안내서

ActiveX/VBA 개발자 안내서는 ActiveX와 VBA를 사용하여 AutoCAD를 사용자화하는 프로그램을 개발하는 방법을 설명합니다. 이 안내서에는 샘플 코드와 단계별 절차도 수록되어 있습니다. ActiveX/VBA 개발자 안내서에는 다음과 같은 주제가 포함되어 있습니다.

  • 소개
  • VBA 시작
  • ActiveX Automation 기본 개념
  • AutoCAD 환경 제어
  • AutoCAD 도면요소 작성 및 편집
  • 치수 및 공차
  • 도구막대 및 메뉴 사용자화
  • 이벤트 사용
  • 3차원 공간에서 작업
  • 배치 및 플롯 정의
  • 고급 도면 및 구성 기법
  • VBA를 사용한 응용프로그램 개발
  • 기타 응용프로그램 및 Windows API와 상호작용
  • ActiveX/VBA 튜토리얼:정원 경로 설계
  • Visual LISP와 ActiveX/VBA 비교
일반 정보

도움말 파일

사용자화 안내서

AutoLISP 참조서

AutoLISP 개발자 안내서

AutoLISP 튜토리얼


ActiveX and VBA Reference

ActiveX and VBA Reference는 ActiveX 객체 모델 및 연관된 인터페이스 구성요소에 대한 참조서입니다. ActiveX and VBA Reference에는 다음과 같은 주제가 포함되어 있습니다.

  • 객체 모델
  • 이벤트
  • 메서드
  • 특성
  • 객체
  • 코드 예제
일반 정보

도움말 파일

사용자화 안내서

AutoLISP 참조서

AutoLISP 개발자 안내서

AutoLISP 튜토리얼


시트 세트 객체 참조서

시트 세트 객체 참조서는 시트 세트 관리자의 객체에 대한 참조서입니다. 시트 세트 객체 참조서에는 다음과 같은 주제가 포함되어 있습니다.

  • 시트 세트 관리자 객체 개요
  • 객체
  • 메서드
  • 특성
  • 이넘
일반 정보

도움말 파일

사용자화 안내서

AutoLISP 참조서

AutoLISP 개발자 안내서

AutoLISP 튜토리얼


연결성 자동화 참조서

연결성 자동화 참조서는 연결 자동화 객체 모델 및 연관된 인터페이스 구성요소에 대한 참조를 제공합니다. 연결성 자동화 참조서에는 다음과 같은 주제가 포함되어 있습니다.

  • 연결 자동화 객체
  • 객체 모델
  • 객체
  • 메서드
  • 특성
  • 이벤트
일반 정보

도움말 파일

사용자화 안내서

AutoLISP 참조서

AutoLISP 개발자 안내서

AutoLISP 튜토리얼


ObjectARX

AutoCAD® 런타임 확장 프로그래밍 환경인 ObjectARX®에는 AutoCAD 응용프로그램을 개발하고 AutoCAD 클래스와 프로토콜을 확장하고 내장된 AutoCAD 명령과 같은 방식으로 작동하는 새 명령을 작성하는 데 사용할 수 있는 구성 블록인 C++ 라이브러리가 포함되어 있습니다.

이 도움말 항목이 페이지 아이콘( [image])으로 목차 탭에 표시되면 도움말 시스템에서 ObjectARX 문서를 사용할 수 없습니다.

AutoCAD ObjectARX 문서는 Autodesk 웹 사이트의 Developer Center 섹션에서 다운로드할 수 있습니다. ObjectARX 문서를 AutoCAD 문서에 통합하려면 ObjectARX의 도움말 파일을 AutoCAD ₩HELP₩ 폴더로 복사합니다.
일반 정보

도움말 파일

사용자화 안내서

AutoLISP 참조서

AutoLISP 개발자 안내서

AutoLISP 튜토리얼


내 도움말 설정

내 도움말을 설정하려면 HTML 형식으로 도움말 항목을 작성한 다음 Microsoft HTML Help Workshop으로 컴파일하여 myhelp.chm이라는 이름의 컴파일된 도움말 파일을 작성해야 합니다. 이 파일을 AutoCAD&#8361;Help 폴더로 복사합니다.

하이퍼링크된 항목의 제목을 기본 내 도움말 항목에 표시하려면

  • 해당 항목의 제목이 나열되어 있는 파일을 CHM 파일에 포함시킵니다. 포함된 파일을 myhelp_toc.html로 명명합니다.

항목의 제목을 목차 탭에 표시하려면

  • 해당 항목의 제목이 나열되어 있는 HHC(도움말 목차) 파일을 CHM 파일에 포함시킵니다.

도움말 항목에 추가된 모든 색인 항목을 표시하려면

  • HHK(도움말 색인) 파일을 CHM 파일에 포함시킵니다.

myhelp_toc.html 파일이나 HHC 또는 HHK 파일을 포함시키지 않았더라도 검색 탭에서 CHM 파일의 내용을 볼 수 있습니다.