Autodesk 네트워크 라이센싱의 빠른 시작

Network License Manager 설치 방법
Autodesk 네트워크 라이센스 안내서 >
Autodesk 네트워크 라이센싱의 빠른 시작

Autodesk 제품에 대한 네트워크 라이센스 설정은 신중하게 계획하고 실행해야 합니다. 이 섹션에서는 네트워크 라이센스 환경을 설정하는 법을 간단히 단계별로 설명하며 사용자가 네트워크에서 실행할 Autodesk 제품을 올바로 설치하기 위해 필요한 용어와 절차에 익숙하다고 가정합니다. 네트워크 라이센싱에 익숙하지 않은 경우, 네트워크 라이센스 서버를 설정하기 전에 자세한 내용을 보려면 네트워크 라이센싱 안내서를 읽으십시오.

이 단원의 항목

  • Network License Manager 설치 방법
  • 네트워크 라이센스 활성화 유틸리티 설치 및 사용 방법
  • 라이센스 서버 구성 방법
  • SAMreport-Lite 설치 및 사용 방법(선택사항)
이 페이지에 대한 의견을 보내주십시오


Network License Manager 설치 방법

Autodesk 네트워크 라이센싱의 빠른 시작
Autodesk 네트워크 라이센싱의 빠른 시작
네트워크 라이센스 활성화 유틸리티 설치 및 사용 방법
Autodesk 네트워크 라이센스 안내서 > Autodesk 네트워크 라이센싱의 빠른 시작 >
Network License Manager 설치 방법

Network License Manager를 사용하여 라이센스 서버를 구성하고 관리합니다.

Network License Manager를 설치하려면

  1. AutoCAD 2008 설치 마법사에서 도구 및 유틸리티 설치를 클릭합니다.
  2. [AutoCAD 2008 설치 마법사 사용을 환영합니다] 페이지에서 다음을 클릭합니다.
  3. 해당 국가 또는 지역의 Autodesk 소프트웨어 라이센스 계약서를 검토합니다. 설치를 계속하려면 이 계약서에 동의해야 합니다. 해당 국가 또는 지역을 선택하고 동의함을 클릭하고 다음을 클릭합니다.
    주라이센스 항목에 동의하지 않고 설치를 종료하려면 취소를 클릭합니다.
  4. 설치할 항목 선택 페이지에서 Network License Manager가 선택되었는지 확인하고 다음을 클릭합니다.
  5. 검토 - 구성 - 설치 페이지에서 구성을 클릭합니다.
  6. Network License Manager 탭을 클릭합니다.
  7. 설치 위치 선택 페이지에서 기본 설치 경로(C:\Program Files\Autodesk\Network License Manager\)를 사용하거나 찾아보기를 클릭하여 다른 위치를 지정합니다. 입력한 경로가 존재하지 않으면 제공된 이름과 위치를 사용하여 새 폴더가 작성됩니다. [다음]을 클릭합니다.
    경고Network License Manager를 원격 드라이브에 설치하지 마십시오. Network License Manager 파일을 설치할 때 로컬 드라이브 경로를 제공해야 합니다. 드라이브 문자를 지정해야 합니다. UNC(범용 명명 규칙)는 지원되지 않습니다.
  8. 구성 완료 페이지에서 구성 완료를 클릭하여 검토 - 구성 - 설치 페이지로 되돌아갑니다. 설치를 클릭합니다.

    Network License Manager와 함께 사용자가 선택한 기타 모든 도구 및 유틸리티가 설치됩니다.

  9. 설치 완료 페이지가 표시되면 마침을 클릭합니다.


네트워크 라이센스 활성화 유틸리티 설치 및 사용 방법

Network License Manager 설치 방법
Autodesk 네트워크 라이센싱의 빠른 시작
라이센스 서버 구성 방법
Autodesk 네트워크 라이센스 안내서 > Autodesk 네트워크 라이센싱의 빠른 시작 >
네트워크 라이센스 활성화 유틸리티 설치 및 사용 방법

네트워크 라이센스 활성화 유틸리티를 사용하면 인터넷을 통해 라이센스를 받을 수 있으므로 프로그램의 네트워크 라이센스 버전을 설정하는 데 걸리는 시간과 노력을 줄일 수 있습니다. 또한 제품을 등록할 수 있으며, 인터넷으로 라이센스를 받을 수 없는 경우 전자 우편을 통한 자동 지원을 받을 수 있고, 라이센스 파일을 자동으로 저장하거나 마이그레이션할 수 있습니다.

네트워크 라이센스 활성화 유틸리티를 설치하려면

  1. AutoCAD 2008 설치 마법사에서 도구 및 유틸리티 설치를 클릭합니다.
  2. [AutoCAD 2008 설치 마법사 사용을 환영합니다] 페이지에서 다음을 클릭합니다.
  3. 해당 국가 또는 지역의 Autodesk 소프트웨어 라이센스 계약서를 검토합니다. 설치를 계속하려면 이 계약서에 동의해야 합니다. 해당 국가 또는 지역을 선택하고 동의함을 클릭하고 다음을 클릭합니다.
    주라이센스 항목에 동의하지 않고 설치를 종료하려면 취소를 클릭합니다.
  4. 설치할 항목 선택 페이지에서 네트워크 라이센스 활성화 유틸리티가 선택되었는지 확인하고 다음을 클릭합니다.
  5. 검토 - 구성 - 설치 페이지에서 구성을 클릭합니다.
  6. 네트워크 라이센스 활성화 유틸리티 탭을 클릭합니다.
  7. 설치 위치 선택 페이지에서 기본 설치 경로(C:\Program Files\Autodesk Network License Manager\Network License Activation Utility\)를 사용하거나 찾아보기를 클릭하여 다른 위치를 지정합니다. 입력한 경로가 존재하지 않으면 제공된 이름과 위치를 사용하여 새 폴더가 작성됩니다. [다음]을 클릭합니다.
  8. 구성 완료 페이지에서 구성 완료를 클릭하여 검토 - 구성 - 설치 페이지로 되돌아갑니다. 설치를 클릭합니다.

    네트워크 라이센스 활성화 유틸리티와 함께 사용자가 선택한 기타 모든 도구 및 유틸리티가 설치됩니다.

  9. 설치 완료 페이지가 표시되면 마침을 클릭합니다.

네트워크 라이센스 활성화 유틸리티를 사용하려면(온라인 요청)

  1. Windows의 시작 메뉴에서 모든 프로그램(또는 프로그램) [image] Autodesk [image] Network License Manager [image] AutoCAD 2008 네트워크 라이센스 활성화 유틸리티를 클릭합니다.
  2. 네트워크 라이센스 받기 페이지에서 직접 연결(인터넷 상에서)이 활성화되어 있는지 확인한 후 다음을 클릭합니다.
  3. 서버 정보 페이지에서 다음 데이터를 입력합니다.
    • 제품 일련 번호 또는 그룹 ID
      주기존 라이센스 파일을 수정하거나 기존 제품의 새 라이센스를 받으려는 경우 이전에 입력한 정보가 표시될 수 있습니다. 표시된 일련 번호가 라이센스할 번호인지 확인합니다. 아니면, 정확한 제품 일련 번호를 입력합니다.
    • 라이센스 서버 모델

      각 라이센스 서버 모델에 대한 자세한 정보를 보려면 ? 버튼을 클릭합니다.

    • 서버 호스트 이름

      호스트 이름을 모르는 경우에는 [...] 버튼을 클릭하여 사용하려는 각 서버의 이름을 찾습니다.

      주분산 서버 모델에서 최대 서버 수는 20개로 제한됩니다. 제한된 서버 수인 20개에 도달하면 추가 버튼이 사라집니다.
    • 사용자가 입력한 각 서버 호스트 이름의 호스트 ID

      호스트 ID를 찾을 수 없는 경우에는 찾기를 클릭하여 유틸리티가 자동으로 서버의 호스트 ID를 찾도록 합니다.

      주서버에 하나 이상의 네트워크 어댑터가 있으면 물리적 네트워크 어댑터에 해당되는 것을 선택하십시오. 물리적 어댑터를 확인하려면 Windows 명령 프롬프트에 ipconfig /all을 입력하고 각 물리적 주소 위의 설명 필드를 봅니다. 두 개 이상의 물리적 네트워크 어댑터가 있는 경우, ipconfig /all을 실행할 때 해당 네트워크 어댑터가 나열되어 있기만 하면 임의의 하나를 사용할 수 있습니다. VPN 어댑터, PPP 어댑터 및 모뎀과 같은 논리적 장치가 나열될 수는 있지만 라이센스 대상이 아닙니다.
    • 각 라이센스 서버의 시트 수

      분산 서버 모델을 선택하면 시트 상자가 표시됩니다. 각 라이센스 서버의 시트 수를 입력합니다.

    [다음]을 클릭합니다.

  4. 서버 정보 확인 페이지에서 입력한 서버 정보를 검토하고, 다음을 클릭합니다.
  5. 로그인 페이지에서 사용자 ID 및 암호를 입력한 다음 로그인을 클릭합니다.

    사용자 계정이 없는 경우에는 지금 사용자 ID 작성 링크를 클릭하고 지시사항을 따라 사용자 계정을 새로 작성합니다.

  6. 사용자 정보 확인 페이지에서 프로파일을 선택하고 다음을 클릭합니다.
  7. 라이센스 받음 페이지의 [컴퓨터 이름]에 대한 라이센스 파일 저장 필드에서 라이센스 파일을 저장할 위치를 입력하거나 찾아보기를 클릭하여 위치를 검색합니다.
    주Network License Manager를 설치한 위치에 라이센스 파일을 저장하는 것이 좋습니다.

    이 페이지의 내용은 선택한 서버 모델에 따라 다를 수 있습니다.

    [다음]을 클릭합니다.

  8. 라이센스 활성화 성공 페이지에서 [인쇄]를 클릭하여 라이센스 정보의 인쇄본을 저장하거나, [완료]를 클릭하여 트랜잭션을 완료한 후 네트워크 활성화 유틸리티를 종료합니다.

라이센스 파일을 받고 로컬로 저장한 후에 라이센스 서버 구성 방법을 참고하여 라이센스 관리자를 구성합니다.

네트워크 라이센스 활성화 유틸리티를 사용하려면 (오프라인 요청)

  1. Windows의 시작 메뉴에서 모든 프로그램(또는 프로그램) [image] Autodesk [image] Network License Manager [image] AutoCAD 2008 네트워크 라이센스 활성화 유틸리티를 클릭합니다.
  2. 네트워크 라이센스 받기 페이지에서 직접 연결(인터넷 상에서)이 활성화되어 있는지 확인한 후 다음을 클릭합니다.
  3. 서버 정보 페이지에서 다음 데이터를 입력합니다.
    • 제품 일련 번호 또는 그룹 ID
      주기존 라이센스 파일을 수정하거나 기존 제품의 새 라이센스를 받으려는 경우 이전에 입력한 정보가 표시될 수 있습니다. 표시된 일련 번호가 라이센스할 번호인지 확인합니다. 아니면, 정확한 제품 일련 번호를 입력합니다.
    • 라이센스 서버 모델

      각 라이센스 서버 모델에 대한 자세한 정보를 보려면 ? 버튼을 클릭합니다.

    • 서버 호스트 이름

      호스트 이름을 모르면 […] 버튼을 클릭하여 사용하려는 각 서버 이름을 찾습니다.

      주분산 서버 모델에서 최대 서버 수는 20개로 제한됩니다. 제한된 서버 수인 20개에 도달하면 추가 버튼이 사라집니다.
    • 사용자가 입력한 각 서버 호스트 이름의 호스트 ID

      호스트 ID를 찾을 수 없는 경우에는 찾기를 클릭하여 유틸리티가 자동으로 서버의 호스트 ID를 찾도록 합니다.

      주서버에 하나 이상의 네트워크 어댑터가 있으면 물리적 네트워크 어댑터에 해당되는 것을 선택하십시오. 물리적 어댑터를 확인하려면 Windows 명령 프롬프트에 ipconfig /all을 입력하고 각 물리적 주소 위의 설명 필드를 봅니다. 두 개 이상의 물리적 네트워크 어댑터가 있는 경우, ipconfig /all을 실행할 때 해당 네트워크 어댑터가 나열되어 있기만 하면 임의의 하나를 사용할 수 있습니다. VPN 어댑터, PPP 어댑터 및 모뎀과 같은 논리적 장치가 나열될 수는 있지만 라이센스 대상이 아닙니다.
    • 각 라이센스 서버의 시트 수

      분산 서버 모델을 선택하면 시트 상자가 표시됩니다. 각 라이센스 서버의 시트 수를 입력합니다.

    [다음]을 클릭합니다.

  4. 서버 정보 확인 페이지에서 입력한 서버 정보를 검토하고, 다음을 클릭합니다.
  5. 제품 등록 페이지가 표시되면 다음을 모두 수행합니다.
    • 제품을 회사로 등록할지 아니면 개인으로 등록할지 선택합니다.
    • 사용자가 거주하는 국가 또는 지역을 선택합니다.
    • 제품 업그레이드인지 여부를 지정합니다.

    [다음]을 클릭합니다.

  6. 고객 정보 페이지에 개인화 데이터를 입력하고 활성화 코드를 받을 방법을 선택합니다. [다음]을 클릭합니다.
  7. 정보 확인 페이지에 개인화 데이터를 검토하고 요청을 제출하는 데 사용할 방법을 선택합니다. 닫기를 클릭합니다.
    • 전자 우편으로 요청을 제출하는 경우 고객 정보 페이지에 지정한 방법으로 활성화 코드를 받게 됩니다.
    • 팩스, 전화 또는 우편으로 요청을 제출하는 경우에는 Autodesk 팩스 번호, 전화 번호 및 주소가 포함된 Autodesk 연락처 페이지가 표시됩니다. 활성화 요청 양식을 인쇄할 수도 있습니다.

라이센스 파일을 받고 로컬로 저장한 후에 라이센스 서버 구성 방법을 참고하여 라이센스 관리자를 구성합니다.

주Network License Manager를 설치한 위치에 라이센스 파일을 저장하는 것이 좋습니다.


라이센스 서버 구성 방법

네트워크 라이센스 활성화 유틸리티 설치 및 사용 방법
Autodesk 네트워크 라이센싱의 빠른 시작
SAMreport-Lite 설치 및 사용 방법(선택사항)
Autodesk 네트워크 라이센스 안내서 > Autodesk 네트워크 라이센싱의 빠른 시작 >
라이센스 서버 구성 방법

네트워크 라이센스 활성화 유틸리티를 실행했을 때 받은 Autodesk 제품 라이센스를 관리할 수 있도록 라이센스 서버를 구성합니다. lmtools.exe 유틸리티로 라이센스 서버를 구성합니다.

라이센스 서버를 구성하려면

LMTOOLS 유틸리티를 사용하는 경우에는 관리자 권한으로 로그인해야 합니다.

  1. 다음 중 하나를 수행합니다.:
    • 시작 메뉴(Windows XP & 2000) [image] 모든 프로그램(또는 프로그램) [image] Autodesk [image] Network License Manager [image] LMTOOLS를 클릭합니다.
    • 바탕 화면에서 LMTOOLS 아이콘(Windows Vista)을 마우스 오른쪽 버튼으로 클릭하고 [관리자로 실행]을 선택합니다.
  2. Lmtools 프로그램의 서비스/라이센스 파일 탭에서 사용하는 서비스 구성 옵션이 활성화되어 있는지 확인합니다.
  3. 서비스 구성 탭을 클릭합니다.
  4. 서비스 이름 리스트에서 다음 중 하나를 수행합니다.:
    • 서비스 이름이 선택되면 해당 서비스가 라이센스를 관리하는 데 사용할 서비스인지 확인합니다.
    • 서비스 이름이 없으면 라이센스를 관리하는 데 사용할 서비스 이름을 입력합니다.

    기본적으로 서비스 이름은 Flexlm Service 1입니다. 서비스 이름은 다를 수 있습니다.

    주라이센스 관리에 대해 FLEXlm®을 사용하는 공급업체가 둘 이상인 경우 서비스 이름 리스트에 둘 이상의 옵션이 포함됩니다. Autodesk 서비스가 하나만 나열되어 있는지 확인합니다.
  5. Lmgrd.exe 파일 경로 필드에 Network License Manager 데몬(lmgrd.exe)의 경로를 입력하거나, 찾아보기를 클릭하여 해당 파일을 찾습니다.

    기본적으로 이 데몬은 \Program Files\Autodesk Network License Manager\License 폴더에 설치되어 있습니다.

  6. 라이센스 파일 경로 상자에 사용자 라이센스 파일의 경로를 입력하거나, [찾아보기]를 클릭하여 파일을 찾습니다.

    이 경로는 네트워크 라이센스 활성화 유틸리티를 통해 얻은 라이센스 파일의 경로이거나 오프라인으로 라이센스 파일을 가져온 경우에는 이 파일을 저장한 위치입니다.

  7. 디버그 로그 파일 경로 상자에 디버그 로그를 작성할 경로를 입력하거나, [찾아보기]를 클릭하여 기존 로그 파일을 찾습니다.

    \Program Files\Autodesk Network License Manager 폴더에 저장하는 것이 좋습니다. 로그 파일의 파일 확장자는 .log여야 합니다. 새 로그 파일의 경우 .log 확장자를 수동으로 입력해야 합니다.

  8. lmgrd.exe를 서비스로 실행하려면 [서비스 사용]을 선택합니다.
  9. 시스템이 시작될 때 lmgrd.exe를 자동으로 시작하려면 전원 켜기에서 [서버 시작]을 선택합니다.
  10. [서비스 저장]을 클릭하여 4단계에서 선택한 서비스 이름으로 새 구성을 저장합니다. 서비스 설정을 저장할지 여부를 묻는 프롬프트가 표시되면 예를 클릭합니다.
  11. 시작/정지/다시 읽기 탭을 클릭하고 다음 중 하나를 수행합니다.
    • Autodesk 서비스가 아직 정의되지 않은 경우, [서버 시작]을 클릭하여 라이센스 서버를 시작합니다.
    • Autodesk 서비스가 이미 정의되고 실행 중인 경우, 라이센스 파일 다시 읽기를 클릭하여 Network License Manager를 라이센스 파일 또는 옵션 파일 변경사항으로 갱신합니다.

      라이센스 서버가 실행되고 클라이언트 요청에 응답할 준비가 되어 있습니다.

  12. lmtools.exe를 닫습니다.


SAMreport-Lite 설치 및 사용 방법(선택사항)

라이센스 서버 구성 방법
Autodesk 네트워크 라이센싱의 빠른 시작
Autodesk 네트워크 라이센스 개요
Autodesk 네트워크 라이센스 안내서 > Autodesk 네트워크 라이센싱의 빠른 시작 >
SAMreport-Lite 설치 및 사용 방법(선택사항)

SAMreport-Lite는 네트워크 라이센스 사용을 추적하는 데 유용한 보고 도구입니다. Macrovision Corporation의 SAMreport-Lite 기술을 통해, FLEXlm®을 사용하여 네트워크 라이센스를 관리하는 모든 소프트웨어의 클라이언트 사용 현황을 모니터링할 수 있습니다.

SAMreport-Lite 설치 및 사용에 관한 자세한 정보를 확인하려면 SAMreport-Lite User's Guide에서 설치 마법사의 왼쪽 아래 구석 및 Autodesk 제품의 도움말 시스템에 있는 문서 링크를 클릭합니다.


Autodesk 네트워크 라이센스 개요

SAMreport-Lite 설치 및 사용 방법(선택사항)
Network License Manager
Autodesk 네트워크 라이센스 안내서 >
Autodesk 네트워크 라이센스 개요

Autodesk 네트워크 라이센스 도구에는 Network License Manager, 네트워크 라이센스 활성화 유틸리티, FLEXlm 구성 도구 및 SAMreport-Lite를 포함합니다. 각 도구 뒤에 따르는 섹션에서 해당 도구가 설명됩니다.

이 단원의 항목

  • Network License Manager
  • 네트워크 라이센스 활성화 유틸리티
  • FLEXlm 구성 도구
  • SAMreport-Lite 라이센스 보고 도구


Network License Manager

Autodesk 네트워크 라이센스 개요
Autodesk 네트워크 라이센스 개요
Network License Manager의 시스템 요구사항
Autodesk 네트워크 라이센스 안내서 > Autodesk 네트워크 라이센스 개요 >
Network License Manager

네트워크 설치의 일부 및 Autodesk® 제품의 배치로 Network License Manager를 사용합니다. Network License Manager를 사용하여 라이센스 서버를 구성하고 관리합니다. 배치 시 설치 마법사는 라이센스 서버 모델 및 서버 이름과 같이 라이센스 관리자에 대한 정보를 요구합니다.

네트워크 위치에서 Autodesk 제품을 배치하는 방법에 대한 자세한 정보는 설치 마법사의 왼쪽 아래 구석 및 도움말 시스템에 있는 문서 링크를 클릭하여 네트워크 관리자 안내서를 참고하십시오.

이 단원의 항목

  • Network License Manager의 시스템 요구사항


Network License Manager의 시스템 요구사항

Network License Manager
Network License Manager
네트워크 라이센스 활성화 유틸리티
Autodesk 네트워크 라이센스 안내서 > Autodesk 네트워크 라이센스 개요 > Network License Manager >
Network License Manager의 시스템 요구사항

네크워크 라이센스 서버가 최소의 권장 요구사항을 갖추도록 확인합니다. 하드웨어 및 소프트웨어 요구사항에 대해서는 다음 테이블을 참고하십시오.

작성자 주석: Windows Vista 및 64비트 내용과 관련된 모든 테이블을 업데이트합니다.

네트워크 라이센스 서버에 대한 하드웨어 및 소프트웨어 요구사항
하드웨어/소프트웨어 | 요구사항 | 주
운영 체제 | Windows 2003 Server Edition Windows XP Professional, 서비스 팩 2 Windows 2000 Server Edition Windows 2000, 서비스 팩 4 | Network License Manager는 이더넷 네트워크 구성만 지원합니다. 중복 라이센스 서버 모델은 Windows 2000 Server Edition 및 Windows 2003 Server에서만 지원됩니다.
컴퓨터/프로세서 | Pentium III 이상 450Mhz(최소) |
네트워크 인터페이스 카드 | 기존 이더넷 네트워크 하부 구조와 호환 가능 | Network License Manager는 복수 네트워크 인터페이스 카드를 지원합니다.
통신 프로토콜 | TCP/IP | Network License Manager는 TCP 패킷 유형을 사용합니다.


네트워크 라이센스 활성화 유틸리티

Network License Manager의 시스템 요구사항
Autodesk 네트워크 라이센스 개요
FLEXlm 구성 도구
Autodesk 네트워크 라이센스 안내서 > Autodesk 네트워크 라이센스 개요 >
네트워크 라이센스 활성화 유틸리티

네트워크 라이센스 활성화 유틸리티를 사용하면 인터넷을 통해 라이센스를 받을 수 있으므로, 네트워크 라이센스 Autodesk 제품을 설정하는 데 걸리는 시간과 노력을 줄일 수 있습니다. 이 유틸리티를 사용하면 Autodesk 제품의 이전 버전에서 수동으로 수행해야 했던 작업이 간단해지거나 자동화됩니다.

또한 유틸리티를 통해 제품을 등록하고, 인터넷으로 라이센스를 받을 수 없는 경우 전자 우편 자동 지원을 받고, 라이센스 파일을 자동으로 저장하거나 마이그레이션할 수도 있습니다.

주네트워크 라이센스 활성화 유틸리티를 사용하여 라이센스 파일을 받는 것이 좋습니다. 그러나 인터넷에 연결하여 라이센스 파일을 받을 수 없는 경우 서버 호스트 이름 및 호스트 ID를 수동으로 얻기를 참고하십시오.


FLEXlm 구성 도구

네트워크 라이센스 활성화 유틸리티
Autodesk 네트워크 라이센스 개요
이전 버전에서 FLEXlm 업데이트
Autodesk 네트워크 라이센스 안내서 > Autodesk 네트워크 라이센스 개요 >
FLEXlm 구성 도구

Network License Manager는 Macrovision Corporation에서 개발한 FLEXlm® 라이센스 관리 기술을 사용합니다. FLEXlm은 네트워크 라이센스 관리를 단순화하는 관리 도구를 제공합니다. FLEXlm 도구를 사용하여 네트워크 라이센스 상태를 모니터링하고, 시스템 오류로 인해 손실된 라이센스를 다시 설정하고, 라이센스 서버의 문제를 해결하고, 기존 라이센스를 곧바로 업데이트할 수 있습니다.

이 단원의 항목

  • 이전 버전에서 FLEXlm 업데이트
  • 라이센스 서버 관리를 위한 유틸리티
  • 옵션 파일


이전 버전에서 FLEXlm 업데이트

FLEXlm 구성 도구
FLEXlm 구성 도구
라이센스 서버 관리를 위한 유틸리티
Autodesk 네트워크 라이센스 안내서 > Autodesk 네트워크 라이센스 개요 > FLEXlm 구성 도구 >
이전 버전에서 FLEXlm 업데이트

AutoCAD 2008 기반 제품을 사용하려면 FLEXlm 버전 10.8 이상이 필요합니다. 현재 10.8 이전의 FLEXlm 버전을 사용하는 경우 10.8 이상 버전으로 업그레이드해야 합니다.

설치된 FLEXlm 버전을 확인하려면 다음 네 파일의 버전을 확인해야 합니다.

  • lmgrd.exe
  • lmtools.exe
  • lmutil.exe
  • adskflex.exe
주Autodesk Network License Manager를 설치할 서버에 다른 제품용으로 FLEXlm이 설치된 경우 lmgrd.exe의 버전은 최신 버전이어야 합니다.

lmutil.exe, lmtools.exe 또는 adskflex.exe의 버전을 확인하려면

LMTOOLS 유틸리티를 사용하는 경우에는 관리자 권한으로 로그인해야 합니다.

  1. 다음 중 하나를 수행합니다.
    • 시작 메뉴(Windows XP & 2000) [image] 모든 프로그램(또는 프로그램) [image] Autodesk [image] Network License Manager [image] LMTOOLS를 클릭합니다.
    • 바탕 화면에서 LMTOOLS 아이콘(Windows Vista)을 마우스 오른쪽 버튼으로 클릭하고 [관리자로 실행]을 선택합니다.
  2. lmtools.exe에서 유틸리티 탭을 클릭하십시오.
  3. 유틸리티 탭에 파일의 위치를 입력하거나, [찾아보기] 버튼을 클릭하여 파일을 찾은 다음, [열기]를 클릭합니다. 파일 위치는 다음과 같습니다.

    C:\Program Files\Autodesk Network License Manager\lmutil.exe

  4. 유틸리티 탭에서 [버전 찾기]를 클릭합니다.

    선택한 파일의 버전 번호가 표시됩니다. 필요한 경우 다음 절차를 따라 FLEXlm 버전을 업데이트하십시오.

FLEXlm을 업데이트하려면

LMTOOLS 유틸리티를 사용하는 경우에는 관리자 권한으로 로그인해야 합니다.

  1. 라이센스 파일을 백업합니다.
  2. 다음 중 하나를 수행합니다.
    • 시작 메뉴(Windows XP & 2000) [image] 모든 프로그램(또는 프로그램) [image] Autodesk [image] Network License Manager [image] LMTOOLS를 클릭합니다.
    • 바탕 화면에서 LMTOOLS 아이콘(Windows Vista)을 마우스 오른쪽 버튼으로 클릭하고 [관리자로 실행]을 선택합니다.
  3. LMTOOLS 프로그램에서 시작/정지/다시 읽기 탭을 클릭합니다.
  4. 시작/정지/다시 읽기 탭에서 [서버 정지]를 클릭합니다.
  5. lmtools.exe를 닫습니다.
  6. Network License Manager를 설치제거합니다. Network License Manager 설치제거에 대한 자세한 정보는 Network License Manager 설치제거를 참고하십시오.
  7. Network License Manager를 설치합니다. Network License Manager 설치에 대한 자세한 정보는 Autodesk Network License Manager 설치를 참고하십시오.
주AutoCAD 2008 기반 제품과 함께 제공된 10.8 버전의 FLEXlm 라이센스 관리자는 이전 버전과 호환 가능하며 Autodesk 2006, 2005, 및 2004 및 2002 기반 제품에 대한 라이센스를 관리합니다.


라이센스 서버 관리를 위한 유틸리티

이전 버전에서 FLEXlm 업데이트
FLEXlm 구성 도구
옵션 파일
Autodesk 네트워크 라이센스 안내서 > Autodesk 네트워크 라이센스 개요 > FLEXlm 구성 도구 >
라이센스 서버 관리를 위한 유틸리티

FLEXlm은 라이센스 서버를 관리하는 두 가지 유틸리티를 제공합니다. 이 도구는 [Autodesk 제품 이름]\ Program Files\Autodesk Network License Manager 폴더에 있습니다.

lmtools.exe

라이센스 서버를 관리하기 위한 Microsoft® Windows 그래픽 사용자 인터페이스를 제공합니다.

lmutil.exe

라이센스 서버를 관리하기 위한 명령행 옵션 세트를 제공합니다.

lmtools.exe 또는 lmutil.exe를 사용하여 다음 서버 관리 작업을 수행할 수 있습니다.

  • 서버를 시작, 정지, 다시 시작합니다.
  • 라이센스 파일을 구성, 업데이트 및 다시 읽습니다.
  • 시스템 또는 라이센스 문제를 진단합니다.
  • 활성 라이센스 상태를 포함한 서버 상태를 봅니다.


옵션 파일

라이센스 서버 관리를 위한 유틸리티
FLEXlm 구성 도구
SAMreport-Lite 라이센스 보고 도구
Autodesk 네트워크 라이센스 안내서 > Autodesk 네트워크 라이센스 개요 > FLEXlm 구성 도구 >
옵션 파일

FLEXlm의 또 다른 구성요소는 옵션 파일입니다. 이 파일을 작성하여 특정 구성 옵션을 설정합니다. 옵션 파일 작성 및 사용에 대한 정보는 옵션 파일 설정 및 사용을 참고하십시오.

옵션 파일을 사용하여 다음 서버 관련 기능의 매개변수를 설정할 수 있습니다.

보고서 로그 파일

SAMreport-Lite에서 사용할 수 있는 라이센스 활동의 정확한 사용에 대한 보고서를 생성하는 암호화된 압축 파일을 작성합니다. SAMreport-Lite에 대한 자세한 정보는 미디어 브라우저의 문서 탭에서 액세스할 수 있는 SAMreport-Lite 사용자 안내서를 참고하십시오.

라이센스 대여

Autodesk 제품이 라이센스 대여 기능을 지원하는 경우 네트워크 라이센스 서버에서 Autodesk 제품의 라이센스를 대여할 수 있게 하여 라이센스 서버에 연결하지 않아도 제품을 사용할 수 있도록 합니다. 라이센스는 제한된 기간 동안 대여할 수 있습니다.

라이센스 시간 종료

라이센스 시간 종료를 통해 라이센스 서버에 대한 시간 종료 기간을 설정할 수 있습니다. 이 기능을 설정하면 워크스테이션과의 연결이 끊어지거나 또는 라이센스가 체크 아웃되었지만 Autodesk 제품이 정의된 시간 종료 기간보다 더 오랫동안 워크스테이션에서 유휴 상태로 있을 경우 라이센스 시간 종료는 라이센스 서버로 라이센스를 반환합니다.

구성 옵션에 대한 자세한 정보는 라이센스 서버 구성을 참고하십시오.

FLEXlm 구성 도구 사용에 대한 특정 정보는 C:\Program Files\Autodesk Network License Manager\Docs\FlexUser\TOC.htm으로 이동하여 FLEXlm 문서를 참고하십시오.


SAMreport-Lite 라이센스 보고 도구

옵션 파일
Autodesk 네트워크 라이센스 개요
네트워크 라이센스 계획
Autodesk 네트워크 라이센스 안내서 > Autodesk 네트워크 라이센스 개요 >
SAMreport-Lite 라이센스 보고 도구

네트워크 설치의 일부는 아니지만 SAMreport-Lite라는 SAMreport 버전을 사용하여 네트워크 라이센스 사용 현황을 추적할 수 있습니다. Macrovision Corporation의 SAMreport-Lite 기술을 통해, FLEXlm을 사용하여 네트워크 라이센스를 관리하는 모든 소프트웨어의 클라이언트 사용 현황을 모니터링할 수 있습니다.

SAMreport-Lite는 HTML, 텍스트, 보고서 교환 형식을 비롯한 다양한 출력 형식으로 사용 현황 보고서를 생성합니다. SAMreport-Lite 기능에 대한 자세한 정보 및 SAMreport-Lite 설치 지침은 SAMreport-Lite 사용자 안내서를 참고하십시오.

주Autodesk 제품 미디어 브라우저에서 SAMreport-Lite를 설치하고 SAMreport-Lite 사용자 안내서를 확인할 수 있습니다.

SAMreport-Lite에 대한 자세한 정보 및 이 기능의 업데이트나 수정 사항을 보려면 아래의 Autodesk 웹 사이트를 방문하십시오.

www.autodesk.com/samreportlite


네트워크 라이센스 계획

SAMreport-Lite 라이센스 보고 도구
라이센스 서버 구성 계획
Autodesk 네트워크 라이센스 안내서 >
네트워크 라이센스 계획

이 섹션에서는 네트워크 라이센스 서버를 설치하기 전에 알아두어야 할 정보가 들어 있습니다. 또한 이 섹션에는 지원되는 라이센스 서버 모델, 라이센스 작업 및 가용성, 네트워크 라이센스 파일 정의 및 매개변수, 라이센스 파일 예제, 라이센스 유형 및 동작, 라이센스 서버 하트비트 신호에 대한 정보가 있습니다.

이 단원의 항목

  • 라이센스 서버 구성 계획
  • 라이센스에 대해 알아보기


라이센스 서버 구성 계획

네트워크 라이센스 계획
네트워크 라이센스 계획
단일 라이센스 서버 모델
Autodesk 네트워크 라이센스 안내서 > 네트워크 라이센스 계획 >
라이센스 서버 구성 계획

서버에서 Autodesk® 제품 라이센스를 관리하는 데 사용할 라이센스 서버 모델을 결정해야 합니다. Autodesk는 다음의 네트워크 라이센스 서버 모델을 지원합니다.

  • 단일 라이센스 서버 모델
  • 분산 라이센스 서버 모델
  • 중복 라이센스 서버 모델

이 단원의 항목

  • 단일 라이센스 서버 모델
  • 분산 라이센스 서버 모델
  • 중복 라이센스 서버 모델


단일 라이센스 서버 모델

라이센스 서버 구성 계획
라이센스 서버 구성 계획
분산 라이센스 서버 모델
Autodesk 네트워크 라이센스 안내서 > 네트워크 라이센스 계획 > 라이센스 서버 구성 계획 >
단일 라이센스 서버 모델

단일 라이센스 서버 모델에서는 Network License Manager가 단일 서버에 설치되므로 라이센스 관리 및 작업 영역이 이 서버로 제한됩니다. 단일 라이센스 파일은 서버에서 사용할 수 있는 라이센스의 총수를 나타냅니다.

단일 라이센스 서버 모델의 이점

  • 모든 라이센스 관리가 단일 서버에서 이루어지므로 각각 한 곳에서만 관리와 오류를 처리하면 됩니다.
  • 3개의 라이센스 서버 모델 중 이 구성은 가장 적은 유지 관리를 수요합니다.

단일 라이센스 서버 모델의 단점

  • 단일 라이센스 서버가 중단되면 서버가 다시 온라인 상태로 될 때까지 Autodesk 제품을 실행할 수 없습니다.


분산 라이센스 서버 모델

단일 라이센스 서버 모델
라이센스 서버 구성 계획
중복 라이센스 서버 모델
Autodesk 네트워크 라이센스 안내서 > 네트워크 라이센스 계획 > 라이센스 서버 구성 계획 >
분산 라이센스 서버 모델

분산 라이센스 서버 모델에서는 라이센스가 2개 이상의 서버에 걸쳐 분산됩니다. 각 서버마다 고유의 라이센스 파일이 필요합니다. 분산 라이센스 서버를 만들려면 분산 서버 풀을 구성하는 각 서버에서 Network License Manager를 실행해야 합니다.

분산 라이센스 서버 모델의 이점

  • WAN에 서버를 분산할 수 있으며 서버가 동일한 서브넷에 있지 않아도 됩니다.
  • 분산 서버 풀의 서버 하나가 실패해도 나머지 서버의 라이센스를 계속 사용할 수 있습니다.
  • 분산 라이센스 서버 모델은 Windows XP® Professional과 Windows® 2000 및 Windows 2003 Server의 워크스테이션 및 서버 개정판에서 모두 지원됩니다.
  • 분산 서버 풀의 서버를 바꿔야 할 경우 전체 풀을 재생성할 필요가 없습니다.
  • 서버 대치 작업은 전체 풀을 다시 활성화해야 하는 중복 서버 풀에서 보다 쉽습니다.

분산 라이센스 서버 모델의 단점

  • 분산 서버 풀의 서버 하나가 실패하면 해당 서버의 라이센스는 사용할 수 없습니다.


중복 라이센스 서버 모델

분산 라이센스 서버 모델
라이센스 서버 구성 계획
라이센스에 대해 알아보기
Autodesk 네트워크 라이센스 안내서 > 네트워크 라이센스 계획 > 라이센스 서버 구성 계획 >
중복 라이센스 서버 모델

중복 라이센스 서버 모델에서 3개의 서버를 사용하여 단일 라이센스 파일을 인증합니다. 한 서버는 마스터 역할을 하는 반면 나머지 두 서버는 마스터 서버가 실패할 경우 백업을 제공합니다. 이 구성을 사용하면 최소한 두 서버가 작동하는 동안에는 라이센스를 계속 모니터하고 발행할 수 있습니다. 3개의 서버에 대한 라이센스 파일은 동일합니다. 각 서버에 Network License Manager를 설치해야 합니다.

중복 라이센스 서버 모델에서 모든 서버가 동일한 서브넷에 상주해야 하며 안정된 네트워크 통신을 갖추고 있어야 합니다. 느리거나 불안정한 연결 또는 전화 접속 연결은 사용하지 않는 것이 좋습니다.

중복 라이센스 서버 모델의 이점

  • 서버 3개 중 하나가 실패해도 서버 풀에서 관리하는 모든 라이센스를 계속 사용할 수 있습니다.

중복 라이센스 서버 모델의 단점

  • 2개 이상의 서버가 실패할 경우에는 라이센스를 사용할 수 없습니다.
  • 세 서버 모두 동일한 서브넷에 상주해야 하며 신뢰할 수 있는 네트워크 통신을 갖추고 있어야 합니다. 중복 서버 풀은 네트워크 내결함성을 제공하지 않습니다.
  • 중복 라이센스 서버 모델은 Windows 2000 서버 개정판 및 Windows 2003 서버 개정판에서만 지원됩니다. 중복 라이센스 서버 모델은 Windows XP 또는 Windows 2000에서 지원되지 않습니다.
  • 서버 3개 중 하나만 대치되어도 전체 중복 서버 풀을 다시 구축해야 합니다.
  • Autodesk 제품이 라이센스 대여를 지원하며 중복 라이센스 서버 풀에서 라이센스가 대여되는 경우, Network License Manager를 정지한 후 라이센스 서버를 다시 시작해야 합니다.


라이센스에 대해 알아보기

중복 라이센스 서버 모델
네트워크 라이센스 계획
라이센스 작업 및 사용 가능한 개수
Autodesk 네트워크 라이센스 안내서 > 네트워크 라이센스 계획 >
라이센스에 대해 알아보기

이 섹션에서는 라이센스 작업 및 사용 가능한 개수, 라이센스 파일, 라이센스 유형과 동작 및 하트비트 신호에 대해 알아 봅니다.

이 단원의 항목

  • 라이센스 작업 및 사용 가능한 개수
  • 라이센스 파일
  • 라이센스 파일 예제
  • 패키지 라이센스 파일 예제
  • 라이센스 유형 및 동작
  • 하트비트 신호


라이센스 작업 및 사용 가능한 개수

라이센스에 대해 알아보기
라이센스에 대해 알아보기
라이센스 파일
Autodesk 네트워크 라이센스 안내서 > 네트워크 라이센스 계획 > 라이센스에 대해 알아보기 >
라이센스 작업 및 사용 가능한 개수

Autodesk 제품을 시작하면 어떤 서버로부터 라이센스를 얻어야 하는지 결정됩니다. 그런 다음 TCP/IP 네트워크 프로토콜을 통해 라이센스 서버에 라이센스를 요청합니다.

라이센스 서버에서 사용 가능한 라이센스 개수가 초과되지 않은 경우에는 Network License Manager가 라이센스를 워크스테이션에 지정합니다. 그런 다음 워크스테이션에서 제품 세션이 시작되고 라이센스 서버에서 사용 가능한 라이센스의 개수가 1개 줄어듭니다.

마찬가지로 제품을 종료하면 Network License Manager는 다른 사용자가 사용할 수 있도록 라이센스를 해제합니다. Autodesk 제품의 여러 세션을 개인 워크스테이션에서 실행하면 라이센스가 하나만 사용됩니다. 최종 세션을 닫으면 라이센스가 해제됩니다.

다음 세 과정을 사용하여 라이센스 분배와 사용 가능 개수를 관리합니다.

  • 라이센스 관리자 데몬(lmgrd.exe). 응용프로그램과의 원래 연결을 처리한 해당 연결을 공급업체 데몬에 전달합니다. lmgrd.exe 데몬은 공급업체 데몬과 통신할 때만 사용됩니다. 따라서 lmgrd.exe는 라이센스를 인증하거나 배분하지 않고 사용자 요청을 공급업체 데몬에 전달합니다. 이 방식을 사용하면 여러 소프트웨어 공급업체에서 단일 lmgrd.exe 데몬을 사용하여 라이센스 인증을 제공할 수 있습니다. lmgrd.exe 데몬은 필요에 따라 공급업체 데몬을 시작하거나 다시 시작합니다.
  • Autodesk 공급업체 데몬(adskflex.exe). 체크 아웃된 라이센스 및 해당 라이센스를 사용하는 워크스테이션을 추적합니다. 각 소프트웨어 공급업체는 공급업체 특유의 라이센스를 관리할 수 있는 고유 공급업체 데몬을 가지고 있습니다. 이름에서 알 수 있듯이 adskflex.exe 공급업체 데몬은 Autodesk 제품을 위한 데몬입니다.
주 adskflex.exe 공급업체 데몬이 어떠한 이유로든 종료되면 lmgrd.exe가 공급업체 데몬을 다시 시작하거나 종료의 원인이 된 문제가 해결될 때까지 모든 사용자가 라이센스를 잃게 됩니다.
  • 라이센스 파일. 공급업체 특유의 라이센스 정보가 들어 있는 텍스트 파일입니다.


라이센스 파일

라이센스 작업 및 사용 가능한 개수
라이센스에 대해 알아보기
라이센스 파일 예제
Autodesk 네트워크 라이센스 안내서 > 네트워크 라이센스 계획 > 라이센스에 대해 알아보기 >
라이센스 파일

Autodesk에서 받은 네트워크 라이센스 파일에는 네트워크 설치에 필요한 라이센스 정보가 포함되어 있습니다. Autodesk 제품을 등록할 때 라이센스 파일 데이터를 얻습니다.

라이센스 파일에는 네트워크 서버 노드 및 공급업체 데몬에 대한 정보가 들어 있습니다. 또한 Autodesk에서 파일을 생성할 때 작성된 암호화된 디지털 서명도 포함되어 있습니다

라이센스 파일은 배치 마법사에서 지정한 네트워크 위치에 있습니다. 네트워크 위치는 네트워크 설치로부터 제품을 실행하는 모든 사용자가 액세스할 수 있어야 합니다.

다음 테이블은 각 라이센스 파일 매개변수를 정의합니다.

라이센스 파일 매개변수의 정의
선 | 매개변수 | 정의 | 예제
SERVER | 호스트 이름 | Network License Manager가 상주하는 서버의 호스트 이름 | labserver
 | 호스트 ID | Network License Manager가 상주하는 서버의 이더넷 주소 | 03D054C0149B
USE_SERVER | [없음] |  |
VENDOR | 공급업체 데몬 | 서버측 Autodesk 공급업체 데몬의 이름 | adskflex.exe
 | 포트 번호 | Autodesk 공급업체 데몬을 실행하는 Autodesk 제품에서만 사용할 수 있도록 예약되어 있고 할당된 네트워크 포트 번호 | port=2080
PACKAGE | 이름 | 피쳐 코드 그룹 이름 | SERIES_1
 | 공급업체 데몬 | 서버측 Autodesk 공급업체 데몬의 이름 | adskflex.exe
 | 버전 | 내부 버전 번호 참고 | 1.000
 | COMPONENTS | 패키지에서 지원하는 피쳐 코드 리스트 | COMPONENTS="526000REVIT_9_OF\ 51200ACD_2007_OF\ 513001INVBUN_11_OF"
 | OPTIONS |  | OPTIONS=SUITE
 | SUPERSEDE | 정의된 발행 날짜 이전의 날짜를 가진 동일한 라이센스 서버의 모든 라이센스 파일에서 같은 피쳐 코드의 기존 Increment 행을 대치 | SUPERSEDE
 | 발행 날짜 | 라이센스 발행 날짜 | ISSUED=15-jul-2006
 | SIGN | 라이센스 파일의 특성을 인증하는 데 사용되는 암호화된 서명 | SIGN=0 SIGN2=0
INCREMENT | 피쳐 코드 | 라이센스 파일이 지원하는 제품 | 51200ACD_2007_0F
 | PLIST | 라이센스 파일에 INCREMENT PLIST 매개변수가 있는 경우에 INCREMENT 행에 동일한 피쳐 코드가 존재하면 라이센스 사용의 우선 순위를 정의합니다. 자세한 정보는 을 참고하십시오. 라이센스 파일에 있는 추가 매개변수의 예제 | INCREMENT PLIST
 | 공급업체 데몬 | 서버측 Autodesk 공급업체 데몬의 이름 | adskflex.exe
 | 버전 | 내부 버전 번호 참고 | 1.000
 | 만료 날짜 | 라이센스를 사용할 수 있는 기간 | 영구적
 | 라이센스 개수 | 라이센스 파일이 지원하는 라이센스 개수 | 25
 | VENDOR_STRING | 라이센스 파일에서 지원하는 제품의 라이센스 사용 유형 및 라이센스 동작. INCREMENT PLIST 행 아래에 있는 VENDOR_STRING 매개변수는 피쳐 코드 리스트를 기준으로 사용되는 제품 라이센스의 순서를 결정합니다. 자세한 정보는 라이센스 파일에 있는 추가 매개변수의 예제를 참고하십시오. | COMMERCIAL
 | SUPERSEDE | 정의된 발행 날짜 이전의 날짜를 가진 동일한 라이센스 서버의 모든 라이센스 파일에서 같은 피쳐 코드의 기존 Increment 행을 대치 | SUPERSEDE
 | BORROW | 같은 증분 행 아래에 정의된 라이센스의 라이센스 대여 기간 정의 이 예제에서 다른 지시가 없는 경우 라이센스를 대여할 수 있는 최대 기간은 4320시간(180일)입니다. 예를 들어, BORROW=2880은 라이센스를 최대 2880시간(120일) 동안 대여할 수 있음을 의미합니다. 이 매개변수가 라이센스 파일에 없으면 라이센스 대여를 사용할 수 없습니다. | BORROW=4320
 | DUP_GROUP | 동일한 사용자 및 동일한 호스트가 같은 라이센스를 공유할 때 여러 라이센스 요청의 정의 | DUP_GROUP=UH
 | ISSUED | Autodesk에서 라이센스 파일을 생성한 날짜 | 15-jul-2006
 | 일련 번호 | Autodesk 제품의 일련 번호 | 123-12345678
 | SIGN | 라이센스 파일의 특성을 인증하는 데 사용되는 암호화된 서명 | SIGN=6E88EFA8D44C


라이센스 파일 예제

라이센스 파일
라이센스에 대해 알아보기
제품에 지정되지 않은 라이센스 파일의 예제
Autodesk 네트워크 라이센스 안내서 > 네트워크 라이센스 계획 > 라이센스에 대해 알아보기 >
라이센스 파일 예제

이 문서에서 제공된 라이센스 파일 예제는 특정 네트워크 설치에서 라이센스 파일이 어떤 방식으로 작동하는 지에 대한 이해를 돕습니다. Autodesk에서는 개별 제품에 대한 표준 라이센스 파일 및, 개별 제품 및 제품 세트의 일부로서 판매된 제품 모두에 대한 추가 매개변수가 있는 라이센스 파일을 제공합니다.

  • 표준 라이센스 파일. 제품 세트의 일부로 제공되지 않은 하나 이상의 개별 제품을 구입한 경우에는 표준 라이센스 파일을 받습니다.
  • 추가 매개변수가 있는 표준 라이센스 파일. 제품 세트에 포함되어 있으며 개별 제품으로도 판매되는 Autodesk 제품을 구입한 경우 추가 매개변수가 라이센스 파일에 포함된 표준 라이센스 파일을 받습니다. 추가 매개변수는 제품 세트에 대한 라이센스보다 개별 제품 라이센스를 먼저 사용하도록 라이센스 사용의 우선 순위를 정의합니다.

Autodesk 라이센스 파일 예제로는 제품에 고유하지 않은 라이센스 파일, 단일, 분산 및 중복 서버 모델에 대한 완전한 라이센스 파일, 결합된 제품 버전 라이센스 파일 및 표준 라이센스 파일에 추가된 추가 매개변수의 예제가 있습니다.

이 단원의 항목

  • 제품에 지정되지 않은 라이센스 파일의 예제
  • 단일 또는 분산 서버에 대한 라이센스 파일의 예제
  • 중복 서버에 대한 라이센스 파일의 예제
  • 결합된 Autodesk 제품 버전에 대한 라이센스 파일의 예제
  • 라이센스 파일에 있는 추가 매개변수의 예제


제품에 지정되지 않은 라이센스 파일의 예제

라이센스 파일 예제
라이센스 파일 예제
단일 또는 분산 서버에 대한 라이센스 파일의 예제
Autodesk 네트워크 라이센스 안내서 > 네트워크 라이센스 계획 > 라이센스에 대해 알아보기 > 라이센스 파일 예제 >
제품에 지정되지 않은 라이센스 파일의 예제

다음은 라이센스 파일의 내용 및 각 행과 관련된 매개변수의 예제입니다.

SERVER ServerName HostID
USE_SERVER
VENDOR adskflex port=portnumber
INCREMENT feature_code Adskflex Version ExpDate NumberofLicenses \
VENDOR_STRING=UsageType:Behavior BORROW=4320 SUPERSEDE \ DUP_GROUP=DupGrp ISSUED=IssueDate SN=SerialNumber SIGN= \


단일 또는 분산 서버에 대한 라이센스 파일의 예제

제품에 지정되지 않은 라이센스 파일의 예제
라이센스 파일 예제
중복 서버에 대한 라이센스 파일의 예제
Autodesk 네트워크 라이센스 안내서 > 네트워크 라이센스 계획 > 라이센스에 대해 알아보기 > 라이센스 파일 예제 >
단일 또는 분산 서버에 대한 라이센스 파일의 예제

다음은 단일 또는 분산 라이센스 서버 모델의 완성된 라이센스 파일 예제입니다.

SERVER Server1 1a34567c90d2
USE_SERVER
VENDOR adskflex port=2080
INCREMENT 54600ACD_2008_0F adskflex 1.000 permanent 5 \
VENDOR_STRING=commercial:permanent BORROW=4320 SUPERSEDE \
DUP_GROUP=UH ISSUED=09-Jan-2007 SN=123-12345678 SIGN="0247 \
    45D6 87C4 27A5 7F9E F24A ED3D 61E4 6B3B CC5C AD77 B865 9EA8 \
3D62 0792 0F67 19E7 57E7 FAFA A48B D582 335A EC16 1FE5 B70D \
 76AB 6488 61CC DE5E F5B7" SIGN2="09FD 0850 7CF1 F447 9F05 9FA3 \
    2A0A 38D6 83FC 1746 F3F5 5A72 6250 E002 DE0B 0E6E F88C AC95 \
    136F 87F2 A945 E4C4 A97F 44B5 74EE 83F3 3F3E 1579 B981 8994"


중복 서버에 대한 라이센스 파일의 예제

단일 또는 분산 서버에 대한 라이센스 파일의 예제
라이센스 파일 예제
결합된 Autodesk 제품 버전에 대한 라이센스 파일의 예제
Autodesk 네트워크 라이센스 안내서 > 네트워크 라이센스 계획 > 라이센스에 대해 알아보기 > 라이센스 파일 예제 >
중복 서버에 대한 라이센스 파일의 예제

다음은 중복 라이센스 서버 모델의 완전한 라이센스 파일 예제입니다.

SERVER Server1 1a34567c90d2 27005
SERVER Server2 2a34567f90d3 27005
SERVER Server3 3a34567b90d4 27005
USE_SERVER
VENDOR adskflex port=2080
INCREMENT 54600ACD_2008_0P adskflex 1.000 permanent 5 \
VENDOR_STRING=commercial:permanent BORROW=4320 SUPERSEDE \
 DUP_GROUP=UH ISSUED=09-Jan-2007 SN=123-12345678 SIGN="15A0 \
9FD4 0108 1BDE F05D 8960 55C5 0142 1D4F 5570 D4F5 C6D2 949E \
 AAA6 1195 1616 50BD 2A07 14A9 898D 69C9 F833 7EED 4D56 ADCC \
  5CD3 1173 F04A 1A63 8335" SIGN2="1239 48BA 591E 20B8 7EB9 CDF5 \
 2FCF 31F1 62DF 8BED 839D 8A20 5C41 673E 06F9 0B97 179E 4398 \
    9C10 8C5F 8020 EB0D 9AA6 772D FB67 2208 C211 096F E44C F086"
주중복 서버 모델에서는 각 서버마다 포트 번호(기본값 27005)를 추가해야 합니다.


결합된 Autodesk 제품 버전에 대한 라이센스 파일의 예제

중복 서버에 대한 라이센스 파일의 예제
라이센스 파일 예제
라이센스 파일에 있는 추가 매개변수의 예제
Autodesk 네트워크 라이센스 안내서 > 네트워크 라이센스 계획 > 라이센스에 대해 알아보기 > 라이센스 파일 예제 >
결합된 Autodesk 제품 버전에 대한 라이센스 파일의 예제

동일한 Autodesk 제품의 다른 릴리즈 또는 서로 다른 Autodesk 제품에 대한 라이센스 파일을 결합하고 하나의 라이센스 서버에서 모든 제품을 실행할 수 있습니다. 예를 들어, AutoCAD 2008의 라이센스 파일을 AutoCAD 및 AutoCAD MAP의 라이센스 파일과 결합할 수 있습니다.

다음은 결합된 라이센스 파일 내용의 예입니다.

SERVER Server1 1a34567c90d2
USE_SERVER
VENDOR adskflex port=2080
INCREMENT 42600ACD_2004_0F adskflex 1.000 permanent 3 \
VENDOR_STRING=commercial:permanent BORROW=4320 SUPERSEDE \
DUP_GROUP=UH ISSUED=22-jun-2003 SN=123-12345678 SIGN=6E88EFA8D44C \
INCREMENT 54600ACD_2008_0F adskflex 1.000 permanent 5 \
 VENDOR_STRING=commercial:permanent BORROW=4320 SUPERSEDE \
DUP_GROUP=UH ISSUED=09-Jan-2007 SN=123-12345678 SIGN="0247 \
    45D6 87C4 27A5 7F9E F24A ED3D 61E4 6B3B CC5C AD77 B865 9EA8 \
 3D62 0792 0F67 19E7 57E7 FAFA A48B D582 335A EC16 1FE5 B70D \
76AB 6488 61CC DE5E F5B7" SIGN2="09FD 0850 7CF1 F447 9F05 9FA3 \
    2A0A 38D6 83FC 1746 F3F5 5A72 6250 E002 DE0B 0E6E F88C AC95 \
    136F 87F2 A945 E4C4 A97F 44B5 74EE 83F3 3F3E 1579 B981 8994"
INCREMENT 51700MAP_2008_0F adskflex 1.000 permanent 5 \
  VENDOR_STRING=commercial:permanent BORROW=4320 SUPERSEDE \
DUP_GROUP=UH ISSUED=09-Jan-2007 SN=123-12345678 SIGN="1707 \
 9EAC CBCB 2405 692E 4A89 FC45 C009 E360 944A 14BA E99C 9B24 \
    5A1B 4A44 083A BE5F 3827 AA26 30CC 2AC2 D6B3 A61B AB5E 492E \
3EBD 0B48 4E75 193A DA82" SIGN2="004A FC90 AB47 3F6B 59BC \
    6681 6971 A76A BA52 98E2 5671 26B3 0E78 791B 109F 0591 7DC3 \
F09F 4D8D 4FB7 E341 4A03 CD68 1D77 27F8 8555 9CF7 DEDD 9380"


라이센스 파일에 있는 추가 매개변수의 예제

결합된 Autodesk 제품 버전에 대한 라이센스 파일의 예제
라이센스 파일 예제
패키지 라이센스 파일 예제
Autodesk 네트워크 라이센스 안내서 > 네트워크 라이센스 계획 > 라이센스에 대해 알아보기 > 라이센스 파일 예제 >
라이센스 파일에 있는 추가 매개변수의 예제

제품 세트에 포함되어 있으며 개별 제품으로도 판매되는 Autodesk 제품의 경우에는 라이센스 파일에 정의된 우선 순위에 따라 라이센스가 할당됩니다. 이러한 제품의 경우 다음 예제와 비슷한 정보가 라이센스 파일에 나타납니다.

SERVER Server1 1a34567c90d2
USE_SERVER
VENDOR adskflex port=2080
INCREMENT 54600ACD_2008_0F adskflex 1.000 permanent 5 \
  VENDOR_STRING=commercial:permanent BORROW=4320 SUPERSEDE \
DUP_GROUP=UH ISSUED=09-Jan-2007 SN=123-12345678 SIGN="0247 \
    45D6 87C4 27A5 7F9E F24A ED3D 61E4 6B3B CC5C AD77 B865 9EA8 \
 3D62 0792 0F67 19E7 57E7 FAFA A48B D582 335A EC16 1FE5 B70D \
76AB 6488 61CC DE5E F5B7" SIGN2="09FD 0850 7CF1 F447 9F05 9FA3 \
    2A0A 38D6 83FC 1746 F3F5 5A72 6250 E002 DE0B 0E6E F88C AC95 \
    136F 87F2 A945 E4C4 A97F 44B5 74EE 83F3 3F3E 1579 B981 8994"
INCREMENT PLIST adskflex 1.000 permanent 1 \
VENDOR_STRING=A07:51600ACDLAND_2007_0F:52200CIV3D_2007_0F;B07:51900AMECH_PP_2007_0F:51300INVBUN_11_0F:51400INVPRO_11_0F07:51900AMECH_PP_2007_0F:51300INVBUN_11_0F:51400INVPRO_11_0F
 SUPERSEDE ISSUED=15-jul-2006 SIGN="14C8 A29F BA92 C89A F132 \
BE66 0206 D8BE F9B7 3FB5 9229 FEB8 2E8D 995E EBB5 1B9E 0142 \
    C933 9483 D0D0 CA94 6532 1CB5 37D7 03CD B085 7301 7484 CA71 \
  2861" SIGN2="0B21 109E EED0 4863 A6E9 6A65 8C7B 6D0B 0B04 \
    2F22 355F 433B 2D81 A540 1D45 55A1 DA71 4024 DA50 35E2 \
0089 3081 724E 860B A11F EBBE 3641 A1D5"


패키지 라이센스 파일 예제

라이센스 파일에 있는 추가 매개변수의 예제
라이센스에 대해 알아보기
단일 서버에 대한 패키지 라이센스 파일 예제
Autodesk 네트워크 라이센스 안내서 > 네트워크 라이센스 계획 > 라이센스에 대해 알아보기 >
패키지 라이센스 파일 예제

Autodesk에서는 패키지로 묶여 함께 판매되는 제품 세트를 사용할 수 있는 패키지 라이센스 파일 옵션을 제공하는 동시에 사용자가 구입한 전체 라이센스 수를 제어합니다.

패키지 라이센스를 통해 구입한 총 시트 수까지 모든 조합의 패키지 제품을 실행하는 단일 라이센스 파일을 받습니다.

예를 들어, Autodesk 제품 세 개에 대해 100개의 시트를 구입하면 단일 라이센스 파일을 사용하여 최대 100개의 시트까지 패키지의 제품 세 개를 어떤 조합으로든 실행할 수 있습니다.

다음에 단일, 분산 및 중복 라이센스 서버에 대한 패키지 라이센스 파일 예제의 일부와 결합된 Autodesk 제품 버전에 대한 파일 예제 하나가 있습니다.

이 단원의 항목

  • 단일 서버에 대한 패키지 라이센스 파일 예제
  • 단일 서버에 대한 패키지 라이센스 파일 예제
  • 중복 서버에 대한 패키지 라이센스 파일 예제
  • 결합된 Autodesk 제품 버전에 대한 라이센스 파일의 예제


단일 서버에 대한 패키지 라이센스 파일 예제

패키지 라이센스 파일 예제
패키지 라이센스 파일 예제
단일 서버에 대한 패키지 라이센스 파일 예제
Autodesk 네트워크 라이센스 안내서 > 네트워크 라이센스 계획 > 라이센스에 대해 알아보기 > 패키지 라이센스 파일 예제 >
단일 서버에 대한 패키지 라이센스 파일 예제

다음은 중복 라이센스 서버 모델의 완전한 라이센스 파일 예제입니다.

SERVER Server1 1a34567c90d2
USE_SERVER
VENDOR adskflex port=2080
PACKAGE SERIES_1 adskflex 1.000 COMPONENTS="54700REVIT_2008_0F \
54600ACD_2008_0F 51300INVBUN_11_0F" OPTIONS=SUITE SUPERSEDE \
 ISSUED=09-Jan-2007 SIGN="1707 9EAC CBCB 2405 692E 4A89 \
AA26 30CC 2AC2 D6B3 A61B AB5E 492E 3EBD 0B48 4E75 193A DA82" \
    FC45 C009 E360 944A 14BA E99C 9B24 5A1B 4A44 083A BE5F 3827 \
SIGN2="004A FC90 AB47 3F6B 59BC 0E6D 6681 6971 A76A BA52 98E2 \
    5671 26B3 0E78 791B 109F 0591 7DC3 F09F 4D8D 4FB7 E341 4A03 \
CD68 1D77 27F8 8555 9CF7 DEDD 9380"
INCREMENT SERIES_1 adskflex 1.000 permanent 100 \
VENDOR_STRING=commercial:permanent BORROW=4320 DUP_GROUP=UH \
 SUITE_DUP_GROUP=UHV SN=123-12345678 SIGN="1707 9EAC CBCB \
    692E 4A89 FC45 C009 E360 944A 14BA E99C 9B24 5A1B 4A44 BE5F \
3827 AA26 30CC 2AC2 D6B3 A61B AB5E 492E 3EBD 0B48 DA82" \
SIGN2="004A FC90 AB47 3F6B 59BC 0E6D 6681 6971 A76A BA52 \
    5671 26B3 0E78 791B 109F 0591 7DC3 F09F 4D8D 4FB7 E341 4A03 \
CD68 1D77 27F8 8555 9CF7 DEDD 9380"


단일 서버에 대한 패키지 라이센스 파일 예제
패키지 라이센스 파일 예제
중복 서버에 대한 패키지 라이센스 파일 예제
Autodesk 네트워크 라이센스 안내서 > 네트워크 라이센스 계획 > 라이센스에 대해 알아보기 > 패키지 라이센스 파일 예제 >
단일 서버에 대한 패키지 라이센스 파일 예제

다음은 중복 라이센스 서버 모델의 완전한 라이센스 파일 예제입니다.

SERVER Server1 1a34567c90d2
USE_SERVER
VENDOR adskflex port=2080
PACKAGE SERIES_1 adskflex 1.000 COMPONENTS="54700REVIT_2008_0F \
54600ACD_2008_0F 51300INVBUN_11_0F" OPTIONS=SUITE SUPERSEDE \
 ISSUED=09-Jan-2007 SIGN="1707 9EAC CBCB 2405 692E 4A89 \
    FC45 C009 E360 944A 14BA E99C 9B24 5A1B 4A44 083A BE5F 3827 \
AA26 30CC 2AC2 D6B3 A61B AB5E 492E 3EBD 0B48 4E75 DA82" \
SIGN2="004A FC90 AB47 3F6B 59BC 0E6D 6681 6971 A76A BA52 \
    5671 26B3 0E78 791B 109F 0591 7DC3 F09F 4D8D 4FB7 E341 4A03 \
CD68 1D77 27F8 8555 9CF7 DEDD 9380"
INCREMENT SERIES_1 adskflex 1.000 permanent 100 \
VENDOR_STRING=commercial:permanent BORROW=4320 DUP_GROUP=UH \
 SUITE_DUP_GROUP=UHV SN=123-12345678 SIGN="1707 9EAC CBCB \
    692E 4A89 FC45 C009 E360 944A 14BA E99C 9B24 5A1B 4A44 083A \
3827 AA26 30CC 2AC2 D6B3 A61B AB5E 492E 3EBD 0B48 DA82" \
SIGN2="004A FC90 AB47 3F6B 59BC 0E6D 6681 6971 A76A BA52 \
    5671 26B3 0E78 791B 109F 0591 7DC3 F09F 4D8D 4FB7 E341 4A03 \    5671 26B3 0E78 791B 109F 0591 7DC3 F09F 4D8D 4FB7 E341 4A03 \
CD68 1D77 27F8 8555 9CF7 DEDD 9380"


중복 서버에 대한 패키지 라이센스 파일 예제

단일 서버에 대한 패키지 라이센스 파일 예제
패키지 라이센스 파일 예제
결합된 Autodesk 제품 버전에 대한 라이센스 파일의 예제
Autodesk 네트워크 라이센스 안내서 > 네트워크 라이센스 계획 > 라이센스에 대해 알아보기 > 패키지 라이센스 파일 예제 >
중복 서버에 대한 패키지 라이센스 파일 예제

다음은 중복 라이센스 서버 모델의 완전한 라이센스 파일 예제입니다.

SERVER Server1 1a34567c90d2 27005
SERVER Server2 2a34567f90d3 27005
SERVER Server3 3a34567b90d4 27005
USE_SERVER
VENDOR adskflex port=2080
PACKAGE SERIES_1 adskflex 1.000 COMPONENTS="54700REVIT_2008_0F \
54600ACD_2008_0F 51300INVBUN_11_0F" OPTIONS=SUITE SUPERSEDE \
 ISSUED=09-Jan-2007 SIGN="1707 9EAC CBCB 2405 692E 4A89 \
    FC45 C009 E360 944A 14BA E99C 9B24 5A1B 4A44 083A BE5F \
AA26 30CC 2AC2 D6B3 A61B AB5E 492E 3EBD 0B48 4E75 DA82" \
SIGN2="004A FC90 AB47 3F6B 59BC 0E6D 6681 6971 A76A BA52 \
    5671 26B3 0E78 791B 109F 0591 7DC3 F09F 4D8D 4FB7 E341 4A03 \
CD68 1D77 27F8 8555 9CF7 DEDD 9380"
INCREMENT SERIES_1 adskflex 1.000 permanent 100 \
VENDOR_STRING=commercial:permanent BORROW=4320 DUP_GROUP=UH \
 SUITE_DUP_GROUP=UHV SN=123-12345678 SIGN="1707 9EAC CBCB \
    692E 4A89 FC45 C009 E360 944A 14BA E99C 9B24 5A1B 4A44 BE5F \
3827 AA26 30CC 2AC2 D6B3 A61B AB5E 492E 3EBD 0B48 DA82" \
SIGN2="004A FC90 AB47 3F6B 59BC 0E6D 6681 6971 A76A BA52 \
    5671 26B3 0E78 791B 109F 0591 7DC3 F09F 4D8D 4FB7 E341 4A03 \
CD68 1D77 27F8 8555 9CF7 DEDD 9380"


결합된 Autodesk 제품 버전에 대한 라이센스 파일의 예제

중복 서버에 대한 패키지 라이센스 파일 예제
패키지 라이센스 파일 예제
라이센스 유형 및 동작
Autodesk 네트워크 라이센스 안내서 > 네트워크 라이센스 계획 > 라이센스에 대해 알아보기 > 패키지 라이센스 파일 예제 >
결합된 Autodesk 제품 버전에 대한 라이센스 파일의 예제

이 예제에서 대여한 처음 50개의 AutoCAD 2008 제품(54600ACD_2008_0F) 라이센스는 상위 증분 행에서 감소합니다. 대여된 51번째 라이센스는 패키지 행에서 감소됩니다.

SERVER Server1 1a34567c90d2 27005
USE_SERVER
VENDOR adskflex port=2080
INCREMENT 54600ACD_2008_0F adskflex 1.000 permanent 50 \
  VENDOR_STRING=commercial:permanent BORROW=4320 SUPERSEDE \
DUP_GROUP=UH ISSUED=09-Jan-2007 SN=123-12345678 SIGN=6E88EFA8D44C \
PACKAGE SERIES_1 adskflex 1.000 COMPONENTS="54700REVIT_2008_0F \
54600ACD_2008_0F 51300INVBUN_11_0F" OPTIONS=SUITE SUPERSEDE \
 ISSUED=09-Jan-2007 SIGN="1707 9EAC CBCB 2405 692E 4A89 \
    FC45 C009 E360 944A 14BA E99C 9B24 5A1B 4A44 083A BE5F \
AA26 30CC 2AC2 D6B3 A61B AB5E 492E 3EBD 0B48 4E75 DA82" \
SIGN2="004A FC90 AB47 3F6B 59BC 0E6D 6681 6971 A76A 98E2 \
    5671 26B3 0E78 791B 109F 0591 7DC3 F09F 4D8D 4FB7 E341 4A03 \
CD68 1D77 27F8 8555 9CF7 DEDD 9380"
INCREMENT SERIES_1 adskflex 1.000 permanent 100 \
VENDOR_STRING=commercial:permanent BORROW=4320 DUP_GROUP=UH \
 SUITE_DUP_GROUP=UHV SN=123-12345678 SIGN="1707 9EAC CBCB \
    692E 4A89 FC45 C009 E360 944A 14BA E99C 9B24 5A1B 4A44 083A \
3827 AA26 30CC 2AC2 D6B3 A61B AB5E 492E 3EBD 0B48 DA82" \
SIGN2="004A FC90 AB47 3F6B 59BC 0E6D 6681 6971 A76A BA52 \
    5671 26B3 0E78 791B 109F 0591 7DC3 F09F 4D8D 4FB7 E341 4A03 \
CD68 1D77 27F8 8555 9CF7 DEDD 9380"
다음 예제에서 대여한 첫 150개의 AutoCAD 2008 제품(54600ACD_2008_0F) 라이센스는 패키지/증분 행에서 감소합니다. 대여된 151번째 라이센스는 증분 행에서 감소됩니다.
SERVER Server1 1a34567c90d2 27005
USE_SERVER
VENDOR adskflex port=2080
PACKAGE SERIES_1 adskflex 1.000 COMPONENTS="54700REVIT_2008_0F \
54600ACD_2008_0F 51300INVBUN_11_0F" OPTIONS=SUITE SUPERSEDE \
 ISSUED=09-Jan-2007 SIGN="1707 9EAC CBCB 2405 692E 4A89 \
    FC45 C009 E360 944A 14BA E99C 9B24 5A1B 4A44 083A BE5F \
 30CC 2AC2 D6B3 A61B AB5E 492E 3EBD 0B48 4E75 193A DA82" \
SIGN2="004A FC90 AB47 3F6B 59BC 0E6D 6681 6971 A76A BA52 \
    5671 26B3 0E78 791B 109F 0591 7DC3 F09F 4D8D 4FB7 E341 \
CD68 1D77 27F8 8555 9CF7 DEDD 9380"
INCREMENT SERIES_1 adskflex 1.000 permanent 150 \
VENDOR_STRING=commercial:permanent BORROW=4320 DUP_GROUP=UH \
 SUITE_DUP_GROUP=UHV SN=123-12345678 SIGN="1707 9EAC CBCB \
    692E 4A89 FC45 C009 E360 944A 14BA E99C 9B24 5A1B 4A44 \
3827 AA26 30CC 2AC2 D6B3 A61B AB5E 492E 3EBD 0B48 DA82" \
SIGN2="004A FC90 AB47 3F6B 59BC 0E6D 6681 6971 A76A BA52 \
    5671 26B3 0E78 791B 109F 0591 7DC3 F09F 4D8D 4FB7 E341 4A03 \
CD68 1D77 27F8 8555 9CF7 DEDD 9380"
INCREMENT 54600ACD_2008_0F adskflex 1.000 permanent 50 \
  VENDOR_STRING=commercial:permanent BORROW=4320 SUPERSEDE \
DUP_GROUP=UH ISSUED=09-Jan-2007 SN=123-12345678 \
SIGN=6E88EFA8D44C


라이센스 유형 및 동작

결합된 Autodesk 제품 버전에 대한 라이센스 파일의 예제
라이센스에 대해 알아보기
하트비트 신호
Autodesk 네트워크 라이센스 안내서 > 네트워크 라이센스 계획 > 라이센스에 대해 알아보기 >
라이센스 유형 및 동작

Autodesk는 동적 제품 사용 및 라이센스 동작을 지원합니다. 즉, 특정 라이센스에 대한 특정 유형의 동작을 구입한 다음 나중에 Autodesk 제품을 설치제거 및 다시 설치하지 않고도 라이센스를 변경할 수 있다는 의미입니다.

라이센스 종류는 다음과 같습니다.

  • 상업용. 상업적으로 구입한 제품에 대한 라이센스입니다.
  • 재판매 불가용. 상업적으로 판매되지 않은 제품에 대한 라이센스입니다.
  • 교육(EDU)/기관용. 특별히 교육 기관용으로 만들어진 라이센스입니다.
  • 학생 포트폴리오용. 교과 과정의 일환으로 Autodesk 제품을 사용하는 학생을 위한 라이센스입니다.

라이센스 동작은 다음과 같습니다.

  • 영구적. Autodesk 제품을 영구적으로 사용할 수 있습니다.
  • 기간 연장 가능. 제한된 기간 동안 Autodesk 제품을 사용할 수 있습니다. 언제든지 기간을 연장할 수 있습니다.
  • 기간 연장 불가능. 제한된 기간 동안만 Autodesk 제품을 사용할 수 있습니다. 기간을 연장할 수 없습니다.


하트비트 신호

라이센스 유형 및 동작
라이센스에 대해 알아보기
네트워크 라이센스 도구
Autodesk 네트워크 라이센스 안내서 > 네트워크 라이센스 계획 > 라이센스에 대해 알아보기 >
하트비트 신호

Autodesk 제품을 실행 중일 때는 “하트비트” 신호라는 통신 방법을 사용하여 일정한 간격으로 라이센스 서버와 정보를 교환합니다. 하트비트 신호가 없어지면 서버가 다시 연결하려고 시도합니다. 서버가 다시 연결할 수 없는 경우 라이센스 오류 메시지가 나타납니다.

Autodesk 제품과 서버의 연결이 끊어져 제품 작동이 중지되는 경우에는 제품을 종료하고 프로그램을 다시 시작해야 합니다. 하트비트 신호을 끊어지게 한 문제점이 해결되고 서버에 사용 가능한 라이센스가 있으면 프로그램을 다시 시작할 수 있습니다.


네트워크 라이센스 도구

하트비트 신호
Autodesk Network License Manager 설치
Autodesk 네트워크 라이센스 안내서 >
네트워크 라이센스 도구

이 섹션에는 네트워크상의 Autodesk Network License Manager 설치와 구성 및 네트워크 라이센스 활성화 유틸리티 설치와 사용에 대한 정보가 들어 있습니다.

이 단원의 항목

  • Autodesk Network License Manager 설치
  • 네트워크 라이센스 활성화 유틸리티 설치
  • 네트워크 라이센스 활성화 유틸리티 사용
  • 서버 호스트 이름 및 호스트 ID를 수동으로 얻기
  • 라이센스 서버 구성
  • 라이센스 서버 정지 및 다시 시작
  • 옵션 파일 설정 및 사용
  • Network License Manager 설치제거


Autodesk Network License Manager 설치

네트워크 라이센스 도구
네트워크 라이센스 도구
네트워크 라이센스 활성화 유틸리티 설치
Autodesk 네트워크 라이센스 안내서 > 네트워크 라이센스 도구 >
Autodesk Network License Manager 설치

설치 마법사를 사용하기 전이나 후에 Network License Manager를 설치할 수 있습니다. 필요한 모든 항목을 설치하고 네트워크 응용프로그램 전체에 일관된 라이센스 서버 정보를 제공하기만 하면 네트워크 응용프로그램을 설치하는 순서는 중요하지 않습니다.

컴퓨터에 이전 Network License Manager 버전이 이미 설치되어 있는 경우에는 Autodesk Network License Manager를 이전 버전이 있는 폴더에 설치하여 업그레이드해야 합니다. 다른 설치 폴더를 선택할 경우 컴퓨터에는 Network License Manager의 두 가지 버전이 존재합니다.

Autodesk Network License Manager를 설치하려면

  1. AutoCAD 2008 설치 마법사에서 도구 및 유틸리티 설치를 클릭합니다.
  2. [AutoCAD 2008 설치 마법사 사용을 환영합니다] 페이지에서 다음을 클릭합니다.
  3. 해당 국가 또는 지역의 Autodesk 소프트웨어 라이센스 계약서를 검토합니다. 설치를 계속하려면 이 계약서에 동의해야 합니다. 해당 국가 또는 지역을 선택하고 동의함을 클릭하고 다음을 클릭합니다.
    주라이센스 항목에 동의하지 않고 설치를 종료하려면 취소를 클릭합니다.
  4. 설치할 항목 선택 페이지에서 Network License Manager가 선택되었는지 확인하고 다음을 클릭합니다.
  5. 검토 - 구성 - 설치 페이지에서 구성을 클릭합니다.
  6. Network License Manager 탭을 클릭합니다.
  7. Network License Manager 설치 페이지에서 기본 설치 경로(C:\Program Files\Autodesk\NLM\)를 승인하거나 찾아보기를 클릭하여 다른 위치를 지정합니다 입력한 경로가 존재하지 않으면 제공된 이름과 위치를 사용하여 새 폴더가 작성됩니다. [다음]을 클릭합니다.
    경고Network License Manager를 원격 드라이브에 설치하지 마십시오. Network License Manager 파일을 설치할 때 로컬 드라이브 경로를 제공해야 합니다. 드라이브 문자를 지정해야 합니다. UNC(범용 명명 규칙)는 지원되지 않습니다.
  8. 도구에 온라인 액세스 페이지에서 다음을 클릭하여 Network License Manager와 함께 선택한 기타 모든 도구 및 유틸리티를 설치합니다.
  9. 설치 완료 페이지가 표시되면 마침을 클릭합니다.


네트워크 라이센스 활성화 유틸리티 설치

Autodesk Network License Manager 설치
네트워크 라이센스 도구
네트워크 라이센스 활성화 유틸리티 사용
Autodesk 네트워크 라이센스 안내서 > 네트워크 라이센스 도구 >
네트워크 라이센스 활성화 유틸리티 설치

네트워크 라이센스 활성화 유틸리티를 설치하여 인터넷에서 라이센스 파일을 받을 수 있도록 합니다.

네트워크 라이센스 활성화 유틸리티를 설치하려면

  1. AutoCAD 2008 설치 마법사에서 도구 및 유틸리티 설치를 클릭합니다.
  2. [AutoCAD 2008 설치 마법사 사용을 환영합니다] 페이지에서 다음을 클릭합니다.
  3. 해당 국가 또는 지역의 Autodesk 소프트웨어 라이센스 계약서를 검토합니다. 설치를 계속하려면 이 계약서에 동의해야 합니다. 해당 국가 또는 지역을 선택하고 동의함을 클릭하고 다음을 클릭합니다.
    주라이센스 항목에 동의하지 않고 설치를 종료하려면 취소를 클릭합니다.
  4. 설치할 항목 선택 페이지에서 네트워크 라이센스 활성화 유틸리티가 선택되었는지 확인하고 다음을 클릭합니다.
  5. 검토 - 구성 - 설치 페이지에서 구성을 클릭합니다.
  6. 네트워크 라이센스 활성화 유틸리티 탭을 클릭합니다.
  7. 네트워크 라이센스 활성화 유틸리티 설치 페이지에서 기본 설치 경로(C:\Program Files\Autodesk\NLA\)를 승인하거나 찾아보기를 클릭하여 다른 위치를 지정합니다. 입력한 경로가 존재하지 않으면 제공된 이름과 위치를 사용하여 새 폴더가 작성됩니다. [다음]을 클릭합니다.
  8. 도구에 온라인 액세스 페이지에서 다음을 클릭하여 네트워크 라이센스 활성화 유틸리티와 함께 선택한 기타 모든 도구 및 유틸리티를 설치합니다.
  9. 설치 완료 페이지가 표시되면 마침을 클릭합니다.


네트워크 라이센스 활성화 유틸리티 사용

네트워크 라이센스 활성화 유틸리티 설치
네트워크 라이센스 도구
서버 호스트 이름 및 호스트 ID를 수동으로 얻기
Autodesk 네트워크 라이센스 안내서 > 네트워크 라이센스 도구 >
네트워크 라이센스 활성화 유틸리티 사용

네트워크 라이센스 활성화 유틸리티를 사용하여 인터넷을 통해 라이센스를 받을 수 있습니다. 또한 유틸리티를 통해 제품을 등록하고, 인터넷으로 라이센스를 받을 수 없는 경우 전자 우편 자동 지원을 받고, 라이센스 파일을 자동으로 저장하거나 마이그레이션할 수도 있습니다.

네트워크 라이센스 활성화 유틸리티를 사용하여 라이센스 파일을 받으려면 다음 정보가 있어야 합니다.

  • 호스트 이름 및 호스트 ID를 포함한 라이센스 서버 정보
  • 이전 제품의 일련 번호(업그레이드할 경우에만)
  • 라이센스 파일을 저장할 수 있는 위치에 대한 접근

네트워크 라이센스 활성화 유틸리티를 사용하려면(온라인 요청)

  1. Windows의 시작 메뉴에서 모든 프로그램(또는 프로그램) [image] Autodesk [image] Network License Manager [image] AutoCAD 2008 네트워크 라이센스 활성화 유틸리티를 클릭합니다.
  2. 네트워크 라이센스 받기 페이지에서 직접 연결(인터넷 상에서)이 활성화되어 있는지 확인한 후 다음을 클릭합니다.
  3. 서버 정보 페이지에서 다음 데이터를 입력합니다.
    • 그룹 ID의 제품 일련 번호
      주기존 라이센스 파일을 수정하거나 기존 제품의 새 라이센스를 받으려는 경우 이전에 입력한 정보가 표시될 수 있습니다. 표시된 일련 번호가 라이센스할 번호인지 확인합니다. 아니면, 정확한 제품 일련 번호를 입력합니다.
    • 라이센스 서버 모델

      각 라이센스 서버 모델에 대한 자세한 정보를 보려면 ? 버튼을 클릭합니다.

    • 서버 호스트 이름

      호스트 이름을 모르면 […] 버튼을 클릭하여 사용하려는 각 서버 이름을 찾습니다.

      주분산 서버 모델에서 최대 서버 수는 20개로 제한됩니다. 제한된 서버 수인 20개에 도달하면 추가 버튼이 사라집니다.
    • 사용자가 입력한 각 서버 호스트 이름의 호스트 ID

      호스트 ID를 찾을 수 없는 경우에는 찾기를 클릭하여 유틸리티가 자동으로 서버의 호스트 ID를 찾도록 합니다.

      주서버에 하나 이상의 네트워크 어댑터가 있으면 물리적 네트워크 어댑터에 해당되는 것을 선택하십시오. 물리적 어댑터를 확인하려면 Windows 명령 프롬프트에 ipconfig /all을 입력하고 각 물리적 주소 위의 설명 필드를 봅니다. 두 개 이상의 물리적 네트워크 어댑터가 있는 경우, ipconfig /all을 실행할 때 해당 네트워크 어댑터가 나열되어 있기만 하면 임의의 하나를 사용할 수 있습니다. VPN 어댑터, PPP 어댑터 및 모뎀과 같은 논리적 장치가 나열될 수는 있지만 라이센스 대상이 아닙니다.
    • 각 라이센스 서버의 시트 수

      분산 서버 모델을 선택하면 시트 상자가 표시됩니다. 각 라이센스 서버의 시트 수를 입력합니다.

    [다음]을 클릭합니다.

  4. 서버 정보 확인 페이지에서 입력한 서버 정보를 검토하고, 다음을 클릭합니다.
  5. 로그인 페이지에서 사용자 ID 및 암호를 입력한 다음 로그인을 클릭합니다.

    사용자 계정이 없는 경우에는 지금 사용자 ID 작성 링크를 클릭하고 지시사항을 따라 사용자 계정을 새로 작성합니다.

  6. 사용자 정보 확인 페이지에서 프로파일을 선택하고 다음을 클릭합니다.
  7. 라이센스 받음 페이지의 [컴퓨터 이름]에 대한 라이센스 파일 저장 필드에서 라이센스 파일을 저장할 위치를 입력하거나 찾아보기를 클릭하여 위치를 검색합니다.
    주Network License Manager를 설치한 위치에 라이센스 파일을 저장하는 것이 좋습니다.

    이 페이지의 내용은 선택한 서버 모델에 따라 다를 수 있습니다.

    [다음]을 클릭합니다.

  8. 라이센스 활성화 성공 페이지에서 [인쇄]를 클릭하여 라이센스 정보의 인쇄본을 저장하거나, [완료]를 클릭하여 트랜잭션을 완료한 후 네트워크 활성화 유틸리티를 종료합니다.

라이센스 파일을 받고 로컬로 저장한 후에 라이센스 서버 구성 방법을 참고하여 라이센스 관리자를 구성합니다.

네트워크 라이센스 활성화 유틸리티를 사용하려면 (오프라인 요청)

  1. Windows의 시작 메뉴에서 모든 프로그램(또는 프로그램) [image] Autodesk [image] Network License Manager [image] AutoCAD 2008 네트워크 라이센스 활성화 유틸리티를 클릭합니다.
  2. 네트워크 라이센스 받기 페이지에서 직접 연결(인터넷 상에서)이 활성화되어 있는지 확인한 후 다음을 클릭합니다.
  3. 서버 정보 페이지에서 다음 데이터를 입력합니다.
    • 그룹 ID의 제품 일련 번호
      주기존 라이센스 파일을 수정하거나 기존 제품의 새 라이센스를 받으려는 경우 이전에 입력한 정보가 표시될 수 있습니다. 표시된 일련 번호가 라이센스할 번호인지 확인합니다. 아니면, 정확한 제품 일련 번호를 입력합니다.
    • 라이센스 서버 모델

      각 라이센스 서버 모델에 대한 자세한 정보를 보려면 ? 버튼을 클릭합니다.

    • 서버 호스트 이름

      호스트 이름을 모르면 […] 버튼을 클릭하여 사용하려는 각 서버 이름을 찾습니다.

      주분산 서버 모델에서 최대 서버 수는 20개로 제한됩니다. 제한된 서버 수인 20개에 도달하면 추가 버튼이 사라집니다.
    • 사용자가 입력한 각 서버 호스트 이름의 호스트 ID

      호스트 ID를 찾을 수 없는 경우에는 찾기를 클릭하여 유틸리티가 자동으로 서버의 호스트 ID를 찾도록 합니다.

      주서버에 하나 이상의 네트워크 어댑터가 있으면 물리적 네트워크 어댑터에 해당되는 것을 선택하십시오. 물리적 어댑터를 확인하려면 Windows 명령 프롬프트에 ipconfig /all을 입력하고 각 물리적 주소 위의 설명 필드를 봅니다. 두 개 이상의 물리적 네트워크 어댑터가 있는 경우, ipconfig /all을 실행할 때 해당 네트워크 어댑터가 나열되어 있기만 하면 임의의 하나를 사용할 수 있습니다. VPN 어댑터, PPP 어댑터 및 모뎀과 같은 논리적 장치가 나열될 수는 있지만 라이센스 대상이 아닙니다.
    • 각 라이센스 서버의 시트 수

      분산 서버 모델을 선택하면 시트 상자가 표시됩니다. 각 라이센스 서버의 시트 수를 입력합니다.

    [다음]을 클릭합니다.

  4. 서버 정보 확인 페이지에서 입력한 서버 정보를 검토하고, 다음을 클릭합니다.
  5. 제품 등록 페이지가 표시되면 다음을 모두 수행합니다.
    • 제품을 회사로 등록할지 아니면 개인으로 등록할지 선택합니다.
    • 사용자가 거주하는 국가 또는 지역을 선택합니다.
    • 제품 업그레이드인지 여부를 지정합니다.

    [다음]을 클릭합니다.

  6. 고객 정보 페이지에 개인화 데이터를 입력하고 활성화 코드를 받을 방법을 선택합니다. [다음]을 클릭합니다.
  7. 정보 확인 페이지에 개인화 데이터를 검토하고 요청을 제출하는 데 사용할 방법을 선택합니다. 닫기를 클릭합니다.
    • 전자 우편으로 요청을 제출하는 경우 고객 정보 페이지에 지정한 방법으로 활성화 코드를 받게 됩니다.
    • 팩스, 전화 또는 우편으로 요청을 제출하는 경우에는 Autodesk 팩스 번호, 전화 번호 및 주소가 포함된 Autodesk 연락처 페이지가 표시됩니다. 활성화 요청 양식을 인쇄할 수도 있습니다.

라이센스 파일을 받고 로컬로 저장한 후에 라이센스 서버 구성 방법을 참고하여 라이센스 관리자를 구성합니다.

주Network License Manager를 설치한 위치에 라이센스 파일을 저장하는 것이 좋습니다.


서버 호스트 이름 및 호스트 ID를 수동으로 얻기

네트워크 라이센스 활성화 유틸리티 사용
네트워크 라이센스 도구
라이센스 서버 구성
Autodesk 네트워크 라이센스 안내서 > 네트워크 라이센스 도구 >
서버 호스트 이름 및 호스트 ID를 수동으로 얻기

네트워크 라이센스 활성화 유틸리티를 사용하여 서버 호스트 이름 및 호스트 ID를 받을 수 없는 경우 이 정보를 수동으로 얻을 수 있습니다. Autodesk는 서버 호스트 이름, 호스트 ID 및 제품 일련 번호를 사용하여 라이센스 파일을 생성합니다.

정보를 수동으로 얻으려면 Windows 명령 프롬프트를 사용하거나 lmtools.exe 유틸리티를 실행하십시오. lmtools.exe를 사용하는 경우에는 원격 워크스테이션에서 실행하지 마십시오.

Windows 명령 프롬프트를 사용하여 호스트 이름 및 ID를 얻으려면

  1. Windows의 시작 메뉴 [image] 모든 프로그램(또는 프로그램) [image] 보조프로그램 [image] 명령 프롬프트를 클릭합니다.
  2. Windows 명령 프롬프트에서 다음 명령을 입력한 다음 ENTER 키를 누릅니다.

    ipconfig /all

  3. 호스트 이름 행을 찾아 호스트 이름을 기록합니다.
  4. 물리적 주소 행을 찾습니다. 대시 없이 물리적 주소를 기록합니다. 이것은 12개 문자로 된 호스트 ID입니다.
    주서버에 하나 이상의 네트워크 어댑터가 있으면 물리적 네트워크 어댑터에 해당되는 것을 선택하십시오. 물리적 어댑터를 결정하려면: Windows 명령 프롬프트에서 ipconfig /all을 입력한 다음 각 물리적 주소 위에 있는 설명 필드를 봅니다. 물리적 네트워크 어댑터가 2개 이상 있는 경우 어느 어댑터를 사용하든지 문제되지 않습니다. 그러나 어댑터가 제대로 설치되어 작동하고 있는지는 확인해야 합니다. VPN 어댑터, PPP 어댑터 및 모뎀 등의 장치는 적합하지 않습니다.
  5. Windows 명령 프롬프트를 닫습니다.

lmtools.exe를 사용하여 호스트 이름 및 ID를 얻으려면

LMTOOLS 유틸리티를 사용하는 경우에는 관리자 권한으로 로그인해야 합니다.

  1. 다음 중 하나를 수행합니다.
    • 시작 메뉴(Windows XP & 2000) [image] 모든 프로그램(또는 프로그램) [image] Autodesk [image] Network License Manager [image] LMTOOLS를 클릭합니다.
    • 바탕 화면에서 LMTOOLS 아이콘(Windows Vista)을 마우스 오른쪽 버튼으로 클릭하고 [관리자로 실행]을 선택합니다.
  2. Lmtools 프로그램에서 시스템 설정 탭을 클릭합니다.
  3. 시스템 설정 탭에서 컴퓨터/호스트 이름 상자를 찾습니다. 호스트 이름을 복사하고 정보를 텍스트 편집기에 붙여넣습니다.
  4. 이더넷 주소 상자를 찾습니다. 이더넷 주소는 12자로 이루어진 호스트 ID입니다. 정보를 적어둡니다. 사용자의 이더넷 주소가 12개 이상의 문자인 경우에는 처음 12개의 문자만 메모합니다.
    주서버에 이더넷 어댑터가 2개 이상 있으면 물리적 네트워크 어댑터에 해당하는 것을 선택하십시오.
  5. lmtools.exe를 닫습니다.


라이센스 서버 구성

서버 호스트 이름 및 호스트 ID를 수동으로 얻기
네트워크 라이센스 도구
라이센스 서버 정지 및 다시 시작
Autodesk 네트워크 라이센스 안내서 > 네트워크 라이센스 도구 >
라이센스 서버 구성

Autodesk 제품 라이센스를 관리할 수 있도록 라이센스 서버를 구성합니다. lmtools.exe 유틸리티로 라이센스 서버를 구성합니다.

라이센스 서버를 구성하려면

LMTOOLS 유틸리티를 사용하는 경우에는 관리자 권한으로 로그인해야 합니다.

  1. 다음 중 하나를 수행합니다.
    • 시작 메뉴(Windows XP & 2000) [image] 모든 프로그램(또는 프로그램) [image] Autodesk [image] Network License Manager [image] LMTOOLS를 클릭합니다.
    • 바탕 화면에서 LMTOOLS 아이콘(Windows Vista)을 마우스 오른쪽 버튼으로 클릭하고 [관리자로 실행]을 선택합니다.
  2. Lmtools 프로그램의 서비스/라이센스 파일 탭에서 사용 서비스 구성 옵션을 선택합니다.
  3. 서비스 구성 탭을 클릭합니다.
  4. 서비스 구성 탭의 서비스 이름 리스트에서 서비스 이름을 선택하거나 다음 작업 중 하나를 수행합니다.
    • 서비스 이름이 선택되면 해당 서비스가 라이센스를 관리하는 데 사용할 서비스인지 확인합니다.
    • 서비스 이름이 없으면 라이센스를 관리하는 데 사용할 서비스 이름을 입력합니다.
    주라이센스 관리에 대해 FLEXlm®을 사용하는 공급업체가 둘 이상인 경우 서비스 이름 리스트에 둘 이상의 옵션이 포함됩니다.
  5. Lmgrd.exe 파일 경로 상자에 Network License Manager 데몬(lmgrd.exe)의 경로를 입력하거나, [찾아보기]를 클릭하여 해당 파일을 찾습니다.

    기본적으로 이 데몬은 Program Files\Autodesk Network License Manager 폴더에 설치되어 있습니다.

  6. 라이센스 파일 경로 상자에 사용자 라이센스 파일의 경로를 입력하거나, [찾아보기]를 클릭하여 파일을 찾습니다.
  7. 디버그 로그 파일 경로 상자에 디버그 로그를 작성할 경로를 입력하거나, [찾아보기]를 클릭하여 기존 로그 파일을 찾습니다.
  8. lmgrd.exe를 서비스로 실행하려면 [서비스 사용]을 선택합니다.
  9. 시스템이 시작될 때 lmgrd.exe를 자동으로 시작하려면 전원 켜기에서 [서버 시작]을 선택합니다.
  10. [서비스 저장]을 클릭하여 4단계에서 선택한 서비스 이름으로 새 구성을 저장합니다. [예]를 클릭합니다.
  11. 시작/정지/다시 읽기 탭을 클릭합니다.
  12. 시작/정지/다시 읽기 탭에서 다음 작업 중 하나를 수행합니다.
    • Autodesk 서비스가 아직 정의되지 않은 경우, [서버 시작]을 클릭하여 라이센스 서버를 시작합니다.
    • Autodesk 서비스가 이미 정의되고 실행 중인 경우, 라이센스 파일 다시 읽기를 클릭하여 Network License Manager를 라이센스 파일 또는 옵션 파일 변경사항으로 갱신합니다.

      라이센스 서버가 실행되고 클라이언트 요청에 응답할 준비가 되어 있습니다.

  13. lmtools.exe를 닫습니다.


라이센스 서버 정지 및 다시 시작

라이센스 서버 구성
네트워크 라이센스 도구
옵션 파일 설정 및 사용
Autodesk 네트워크 라이센스 안내서 > 네트워크 라이센스 도구 >
라이센스 서버 정지 및 다시 시작

라이센스 서버에서 시스템 유지보수를 수행하려면 먼저 라이센스 서버를 정지해야 합니다. 유지보수를 완료했으면 라이센스 서버를 다시 시작할 수 있습니다.

라이센스 서버를 중지하려면

LMTOOLS 유틸리티를 사용하는 경우에는 관리자 권한으로 로그인해야 합니다.

  1. 다음 중 하나를 수행합니다.
    • 시작 메뉴(Windows XP & 2000) [image] 모든 프로그램(또는 프로그램) [image] Autodesk [image] Network License Manager [image] LMTOOLS를 클릭합니다.
    • 바탕 화면에서 LMTOOLS 아이콘(Windows Vista)을 마우스 오른쪽 버튼으로 클릭하고 [관리자로 실행]을 선택합니다.
  2. Lmtools 프로그램의 서비스/라이센스 파일 탭에서 사용 서비스 구성 옵션을 선택합니다.
  3. 수동으로 시작할 라이센스 서버의 서비스 이름을 선택합니다.
  4. 시작/정지/다시 읽기 탭을 클릭합니다.
  5. 시작/정지/다시 읽기 탭에서 [서버 정지]를 클릭합니다.
  6. lmtools.exe를 닫습니다.

라이센스 서버를 다시 시작하려면

LMTOOLS 유틸리티를 사용하는 경우에는 관리자 권한으로 로그인해야 합니다.

  1. 다음 중 하나를 수행합니다.
    • 시작 메뉴(Windows XP & 2000) [image] 모든 프로그램(또는 프로그램) [image] Autodesk [image] Network License Manager [image] LMTOOLS를 클릭합니다.
    • 바탕 화면에서 LMTOOLS 아이콘(Windows Vista)을 마우스 오른쪽 버튼으로 클릭하고 [관리자로 실행]을 선택합니다.
  2. Lmtools 프로그램의 서비스/라이센스 파일 탭에서 사용 서비스 구성 옵션을 선택합니다.
  3. 수동으로 시작할 라이센스 서버의 서비스 이름을 선택합니다.
  4. 시작/정지/다시 읽기 탭을 클릭합니다.
  5. 시작/정지/다시 읽기 탭에서 [서버 시작]을 클릭하여 라이센스 서버를 다시 시작합니다.


옵션 파일 설정 및 사용

라이센스 서버 정지 및 다시 시작
네트워크 라이센스 도구
보고서 로그 작성
Autodesk 네트워크 라이센스 안내서 > 네트워크 라이센스 도구 >
옵션 파일 설정 및 사용

설정한 각 라이센스 서버에 대한 라이센스를 관리하기 위해 옵션 파일을 사용하여 구성 옵션을 설정합니다. 옵션 파일은 라이센스 파일에서 읽고 Lmgrd 프로그램이 실행하는 매개변수를 설정합니다.

라이센스 서버 일부 또는 전체에 대해 동일한 라이센스 동작을 지정하려면 각 라이센스 서버당 같은 옵션 파일이 있어야 합니다. 다른 라이센스 서버에 대해서 다른 라이센스 동작을 지정하려면 각 라이센스 동작에 대한 옵션 파일을 작성해야 합니다. 각 옵션 파일은 특정 라이센스 동작을 필요로 하는 서버에 저장해야 합니다.

주옵션 파일의 변경 사항이 라이센스 서버에 적용되려면, 옵션 파일을 저장한 다음 lmtools.exe를 사용하여 라이센스 파일을 다시 읽어야 합니다.

옵션 파일을 사용하여 다음 작업을 수행할 수 있습니다.

  • 보고서 로그 작성
  • 라이센스 대여 구성
  • 라이센스 시간 종료 설정

다음은 옵션 파일 내용의 예입니다.

REPORTLOG=c:\test\report.rl

BORROW_LOWWATER Autodesk_f1 3

TIMEOUT Autodesk_f1 7200

또한 라이센스 예약하기, 라이센스 사용 제한하기 또는 사용자 그룹 정의하기와 같은 고급 라이센스 매개변수를 설정할 수도 있습니다. 고급 옵션 파일 매개변수을 설정하는 데 대한 자세한 정보는 Program Files\Autodesk License Manager\docs\FlexUser 폴더에 있는 FLEXlm 문서를 참고하십시오.

옵션 파일을 작성하려면

LMTOOLS 유틸리티를 사용하는 경우에는 관리자 권한으로 로그인해야 합니다.

  1. 텍스트 편집기를 열어 원하는 매개변수를 입력한 다음 문서를 라이센스 파일이 저장된 동일한 위치에 adskflex.opt로 명명된 파일로 저장합니다.
    주파일을 확장자 .opt로 저장하도록 확인합니다. 기본 확장자인 .txt는 Network License Manager에서 인식되지 않습니다.
  2. 다음 중 하나를 수행합니다.
    • 시작 메뉴(Windows XP & 2000) [image] 모든 프로그램(또는 프로그램) [image] Autodesk [image] Network License Manager [image] LMTOOLS를 클릭합니다.
    • 바탕 화면에서 LMTOOLS 아이콘(Windows Vista)을 마우스 오른쪽 버튼으로 클릭하고 [관리자로 실행]을 선택합니다.
  3. Lmtools 프로그램의 시작/정지/다시 읽기 탭에서 [라이센스 파일 다시 읽기]를 클릭합니다.
  4. lmtools.exe를 닫습니다.

이 단원의 항목

  • 보고서 로그 작성
  • 라이센스 대여 구성
  • 라이센스 시간 종료 설정


보고서 로그 작성

옵션 파일 설정 및 사용
옵션 파일 설정 및 사용
라이센스 대여 구성
Autodesk 네트워크 라이센스 안내서 > 네트워크 라이센스 도구 > 옵션 파일 설정 및 사용 >
보고서 로그 작성

옵션 파일에서 SAMreport-Lite에서 사용되는 보고 로그 파일을 작성할 수 있습니다.

보고서 로그를 작성하려면

  1. 텍스트 편집기에서 옵션 파일 adskflex.opt를 엽니다.
  2. 옵션 파일에서 다음 구문을 해당 행에 입력합니다(표시된 바와 같이 REPORTLOG를 대문자로 입력).

    REPORTLOG [+]report_log_path

    예를 들어, REPORTLOG +"c:\My Documents\report.rl" 구문은 report.rl로 명명된 보고서 로그가 c:\My Documents 폴더에 있음을 의미합니다.

    주공백이 포함된 경로 이름은 인용 부호로 묶어야 합니다.

    REPORTLOG 구문에서 “[+]”는 작성한 로그 파일의 항목이 Network License Manager가 다시 시작될 때마다 대치되지 않고 추가됨을 의미합니다. 로그 항목의 사용 내역을 유지할 수 있도록 이 옵션을 사용하는 것이 좋습니다.


라이센스 대여 구성

보고서 로그 작성
옵션 파일 설정 및 사용
라이센스 시간 종료 설정
Autodesk 네트워크 라이센스 안내서 > 네트워크 라이센스 도구 > 옵션 파일 설정 및 사용 >
라이센스 대여 구성

Autodesk 제품이 라이센스 대여 기능을 지원하는 경우 옵션 파일을 사용하여 라이센스 대여 옵션을 설정할 수 있습니다. 예를 들어, 사용자의 네트워크에서 어떤 경우에도 대여할 수 없는 최대 라이센스 개수를 정의할 수 있습니다. 또한 Autodesk 제품 라이센스를 대여할 수 있는 사용자를 정의할 수도 있습니다. 라이센스는 컴퓨터당이 아닌 사용자당으로 대여합니다.

주Autodesk 제품이 라이센스 대여를 지원하며 중복 라이센스 서버 풀에서 라이센스가 대여되는 경우, Network License Manager를 정지한 후 라이센스 서버를 다시 시작해야 합니다.

대여 기간이 끝나면 대여된 라이센스가 사용자의 컴퓨터에서 자동으로 작동 불가능하게 되며 라이센스 서버에서는 다시 사용 가능하게 됩니다. 사용자는 대여 기간이 끝나기 전에 라이센스를 반환할 수도 있습니다.

라이센스 대여 매개변수를 설정하려면

  1. 옵션 파일에서 다음 구문을 해당 행에 입력합니다(보여준 바와 같이 BORROW_LOWWATER을 대문자로 입력).

    BORROW_LOWWATER feature_code n

    BORROW 구문에서 “feature_code”는 라이센스 파일의 제품 이름이며 “n”은 대여 불가능한 라이센스의 개수입니다.

    예를 들어, BORROW_LOWWATER Autodesk_f1 3 구문은 라이센스 서버에서 Autodesk_f1 제품에 대해 3개의 라이센스를 대여할 수 없음을 의미합니다.

  2. 다음 행에 다음 구문을 입력합니다(보여준 바와 같이 MAX_BORROW_HOURS를 대문자로 입력).

    MAX_BORROW_HOURS feature_code n

    이 구문에서 “n”은 라이센스를 대여할 수 있는 시간 수입니다.

    예를 들어, MAX_BORROW_HOURS Autodesk_f1 360 구문은 Autodesk_f1 제품의 라이센스를 360시간(15일) 동안 대여할 수 있음을 의미합니다.

    주라이센스는 24시간 단위로만 대여됩니다. 24시간보다 큰 숫자는 사용되지 않습니다. 예를 들어, 숫자 365는 360시간(15일)으로 버림 처리합니다.

라이센스 대여 피쳐 설정에 대한 자세한 정보는 Program Files\Autodesk Network License Manager\Docs\FlexUser 폴더에 있는 FLEXlm 문서를 참고하십시오.

주도구 메뉴 [image] 라이센스 대여를 클릭하거나 Autodesk 제품 명령행에 borrowlicense를 입력하여 Autodesk 제품의 라이센스를 대여할 수 있습니다. 이 기능의 도움말은 [Autodesk 제품 이름]을 위한 라이센스 대여 윈도우 및 \Program Files\[Autodesk 제품 이름]\Help\[Autodesk 제품 이름]_brw.chm에 있습니다.


라이센스 시간 종료 설정

라이센스 대여 구성
옵션 파일 설정 및 사용
Network License Manager 설치제거
Autodesk 네트워크 라이센스 안내서 > 네트워크 라이센스 도구 > 옵션 파일 설정 및 사용 >
라이센스 시간 종료 설정

라이센스 시간 종료는 옵션 파일에서 설정되며 라이센스 서버에 의해 라이센스가 다시 요청되기 전까지 제품 세션의 유휴 기간을 결정합니다. 옵션 파일에 이 플래그를 설정한 경우 제품이 워크스테이션에서 정의된 시간 초과 기간보다 오래 유휴 상태에 있으면 라이센스 서버에서 사용자 라이센스를 다시 청구합니다.

유휴 시간 초과로 인해 라이센스를 상실한 경우 사용자가 제품을 다시 사용할 때 제품에서 새 라이센스를 요청하게 됩니다. 사용 가능한 라이센스가 없는 경우 제품이 종료되기 전에 작업을 저장할 수 있습니다.

라이센스 시간 종료 매개변수를 설정하려면

  • 옵션 파일에 다음 구문을 해당 행에 입력합니다(보여준 바와 같이 TIMEOUT를 대문자로 입력).

    TIMEOUT feature_code n

    TIMEOUT 구문에서 “feature_code”는 라이센스 파일의 INCREMENT 행에 있는 제품 이름이며 “n”은 라이센스 서버에서 비활성 라이센스를 다시 청구할 때까지의 시간(초)입니다.

    예를 들어, 구문 TIMEOUT Autodesk_f1 7200 은 제품 Autodesk_f1에 대해 7200초, 즉 1시간의 라이센스 시간 종료 기간이 설정되었음을 의미합니다.

라이센스 시간 종료 기능 사용에 대한 자세한 정보는 Program Files\Autodesk Network License Manager\Docs\FlexUser 폴더에 있는 FLEXlm 문서를 참고하십시오.


Network License Manager 설치제거

라이센스 시간 종료 설정
네트워크 라이센스 도구
용어집
Autodesk 네트워크 라이센스 안내서 > 네트워크 라이센스 도구 >
Network License Manager 설치제거

라이센스 서버에서 Network License Manager를 설치제거할 수 있습니다. Network License Manager를 설치제거하면 사용자들은 더 이상 라이센스를 사용할 수 없습니다.

Network License Manager를 설치제거하려면

  1. 다음 중 하나를 수행합니다.
    • 시작 메뉴(Windows XP & 2000) [image] 모든 프로그램(또는 프로그램) [image] Autodesk [image] Network License Manager [image] LMTOOLS를 클릭합니다.
    • 바탕 화면에서 LMTOOLS 아이콘(Windows Vista)을 마우스 오른쪽 버튼으로 클릭하고 [관리자로 실행]을 선택합니다.
  2. Lmtools 프로그램의 서비스/라이센스 파일 탭에서 사용 서비스 구성 옵션을 선택합니다.
  3. Lmtools 프로그램에서 시작/정지/다시 읽기 탭을 클릭합니다.
  4. 시작/정지/다시 읽기 탭에서 [서버 정지]를 클릭합니다.
  5. lmtools.exe를 닫습니다.
  6. Windows 제어판에서 프로그램 추가/제거를 두 번 클릭합니다.
  7. 프로그램 추가/제거 윈도우에서 Autodesk Network License Manager를 클릭한 다음 제거를 클릭합니다.
  8. 시스템을 다시 시작하라는 프롬프트가 나타나면 시스템을 다시 시작합니다.
주Network License Manager용으로 작성한 파일(예: 로그 파일, 라이센스 파일 및 옵션 파일)을 수동으로 삭제해야 합니다. 이러한 파일은 Network License Manager를 설치제거할 때 자동으로 삭제되지 않습니다.


용어집

Network License Manager 설치제거
Autodesk 네트워크 라이센스 안내서 >
용어집
ADSKFLEX_LICENSE_FILE

분산 라이센스 서버 구성에서 워크스테이션을 분산 라이센스 서버에 지정하는 데 사용되는 환경 변수입니다.

adskflex.exe

FLEXlm 라이센스 기술을 통해 사용되는 Autodesk 공급업체 데몬입니다. 이 데몬은 체크 아웃된 Autodesk 라이센스 및 이 라이센스를 사용하는 워크스테이션을 추적합니다.

FLEXlm

Autodesk 제품군에 구현되는 Macrovision Corporation 라이센스 관리 기술입니다.

JRE(Java Runtime Environment)

Java 프로그램을 실행해야 하는 프로그램입니다. 이 프로그램은 SAMreport-Lite와 함께 설치해야 합니다.

licpath.lic

단일 및 중복 서버 구성 모두에서 FLEXlm 라이센스 서버에 워크스테이션을 지정하는 데 사용되는 파일입니다. Licpath.lic는 루트 설치 폴더에 있습니다.

lmgrd.exe

라이센스 관리자 데몬입니다. 이 데몬은 프로그램과의 원래 연결을 처리한 다음 연결을 공급업체 데몬인 adskflex.exe에 전달합니다.

lmtools.exe

FLEXlm 라이센스 기술을 관리하는 데 사용되는 그래픽 사용자 인터페이스 유틸리티입니다. (Lmutil.exe는 이 유틸리티의 명령행 버전입니다.)

lmutil.exe

FLEXlm 라이센스 기술을 관리하는 데 사용되는 명령행 유틸리티입니다. (Lmtools.exe는 이 유틸리티의 그래픽 사용자 인터페이스 버전입니다.)

Network License Manager

Autodesk에서 네트워크 라이센스 관리를 위해 사용하는 기술입니다.

SAMreport-Lite

Macrovision Corporation의 SAMreport 도구 버전. SAMreport-Lite는 Autodesk 제품 CD-ROM에 들어 있습니다.

공급업체 데몬

adskflex.exe를 참고하십시오.

네트워크 라이센스 설치

네트워크 서버에서 Network License Manager를 설치하고 실행해야 하는 설치 유형입니다. 클라이언트가 Autodesk 제품을 실행하기 전에 Network License Manager를 설치하고 구성해야 합니다.

네트워크 라이센스 활성화 유틸리티

네트워크 관리자가 인터넷 상에서 Autodesk 제품의 네트워크 버전을 라이센스하고 권한을 부여할 수 있도록 해주는 유틸리티입니다.

대여 라이센스

별도로 라이센스를 구입하거나 라이센스 서버에 연결할 필요 없이 제한된 기간 동안 Autodesk 제품을 사용할 수 있게 해주는 라이센스입니다. 이전 버전의 Autodesk 제품에서는 라이센스 구성 전환기를 사용했습니다.

데몬

컴퓨터의 배경에서 계속해서 실행되는 프로그램입니다. 데몬은 컴퓨터의 요청을 처리한 다음 해당 요청을 다른 프로그램이나 프로세스에 전달합니다. Network License Manager가 사용하는 두 개 데몬: 공급업체 데몬(adskflex.exe)라이센스 관리자 데몬(lmgrd.exe).

디버그 로그 파일

FLEXlm을 통해 네트워크 라이센스 관리자와 워크스테이션 사이의 연결 작업(라이센스 실패 또는 시작과 중지 등)을 기록하는 데 사용되는 파일입니다.

라이센스 구성 전환기

대여 라이센스를 참고하십시오.

라이센스 서버

Network License Manager가 있는 서버입니다.

라이센스 시간 초과

유휴 상태의 라이센스를 서버에 자동으로 반환하여 다시 사용될 수 있도록 라이센스 서버에 시간 종료 기간을 설정하는 기능입니다.

라이센스 파일

FLEXlm을 통해 사용 가능한 시트 수를 조정하는 파일입니다. 이 파일은 ASCII 일반 텍스트 형식이어야 합니다.

마스터 데몬

lmgrd.exe를 참고하십시오.

물리적 주소

호스트 ID를 참고하십시오.

배치

서버에 작성된 파일과 폴더이며 워크스테이션에서 Autodesk 프로그램을 설치하는 데 사용합니다.

보고서 로그 파일

FLEXlm 및 SAMreport-Lite를 사용하는 파일. 이 로그 파일은 네트워크 라이센스 사용 현황에 대한 정보를 제공합니다. 옵션 파일은 보고서 로그를 작성합니다.

분산 서버

여러 서버를 사용하여 라이센스 분배를 관리하는 라이센스 서버 구성 옵션입니다. 분산 라이센스 서버에는 각각 고유한 라이센스 파일과 고정된 라이센스 개수가 있습니다. 분산 라이센스 서버 중 하나가 실패하더라도 나머지 서버를 사용하여 라이센스를 계속 분배할 수 있습니다.

실행 트리

acad.exe와 같은 Autodesk 제품 프로그램 파일의 위치입니다.

옵션 파일

SAMreport-Lite를 통해 사용되는 보고서 로그를 작성하고 라이센스를 예약하는 등 라이센스 관리자 매개변수를 제어하기 위해 FLEXlm이 사용하는 파일입니다.

워크스테이션

네트워크에서 개별 사용자가 사용하는 데스크탑 컴퓨터입니다.

유휴

제품의 비활성 상태로서 네트워크 라이센스 서버에서 라이센스를 다시 요청하도록 합니다. 제품 사용 중, 옵션 파일에 정의된 일정 시간 동안 키 입력이나 마우스 클릭 작업이 없거나 처리 중인 명령, LISP 표현식, 메뉴 매크로 또는 스크립트가 없을 때와 같이 여러 가지 이유로 인해 제품이 유휴 상태로 간주됩니다. 라이센스 시간 초과를 참고하십시오.

이더넷 주소

호스트 ID를 참고하십시오.

중복 서버

서버 3개를 사용하여 라이센스를 관리하는 라이센스 서버 구성 옵션입니다. 중복 서버는 라이센스 파일 및 라이센스 풀을 공유합니다. 중복 서버 풀은 서버 3개 중 2개가 실행되는 한 작동됩니다.

하트비트 신호

Network License Manager와 워크스테이션 사이의 통신 신호로서 워크스테이션이 사용 가능한지 그리고 실행 중인 활성 Autodesk 제품 세션이 있는지 확인합니다.

호스트 ID

네트워크 어댑터의 고유 하드웨어 주소입니다. 이더넷 주소 또는 물리적 주소라고도 합니다.

호스트 이름

컴퓨터에 연결된 TCP/IP 이름입니다. FLEXlm 기술은 호스트 이름을 매개변수로 사용하므로 호스트 이름은 NetBIOS(서버) 이름과 구별되어야 합니다.


의견 내보내기

의견이 있으시면 이 양식을 사용해서 문서 담당 부서인 Autodesk Technical Publications 그룹으로 보내주십시오.

항목 제목 및 위치 (편집하지 마십시오.):
이름(선택사항):
         전자 우편(선택사항):
설명:

주: 이 양식은 피드백이나 기술적 지원을 받는 용도로 작성되는 것은 아닙니다. 여러분께서 보내주신 정보는 앞으로 문서를 업데이트하는 데 사용됩니다. 감사합니다!