DXF 형식

본 참조서의 구성
DXF 참조서 >
DXF 형식

DXF™ 형식은 AutoCAD® 도면 파일에 포함되어 있는 모든 정보를 태그가 지정된 데이터로 표현한 파일 형식입니다. 태그가 지정된 데이터란 그룹 코드라고 하는 정수가 앞에 붙어 있는 파일 내의 각 데이터 요소를 의미합니다. 그룹 코드의 값은 다음에 나오는 데이터 요소의 유형을 나타냅니다. 또한, 이 값은 주어진 객체 또는 레코드의 유형에 대한 데이터 요소의 의미도 나타냅니다. 사실상, 도면 파일의 모든 사용자 지정 정보는 DXF 형식으로 나타낼 수 있습니다.

이 단원의 항목

  • 본 참조서의 구성
  • DXF 참조서의 개정 사항
  • 본 참조서의 형식화 규칙
  • 객체 및 도면요소 코드
  • 그룹 코드 값 유형
  • 번호순의 그룹 코드
의견?


본 참조서의 구성

DXF 형식
DXF 형식
DXF 참조서의 개정 사항
DXF 참조서 > DXF 형식 >
본 참조서의 구성

DXF 참조서는 DXF 파일에 있고 AutoLISP® 및 ObjectARX® 응용프로그램에 나타나는 DXF™ 그룹 코드를 제공합니다. 이 장에서는 일반적인 DXF 규칙에 대해 설명합니다. 나머지 장에는 객체 유형별로 구성된 그룹 코드가 나열되어 있습니다. 그룹 코드는 DXF 파일에서 발견되는 순서로 제공되며 각 장의 이름은 연관된 DXF 파일 섹션에 따라 명명되어 있습니다. DXF 파일 형식을 사용해 본 참조서가 구성되긴 했지만 실제로 DXF 파일을 형식화하는 특정 정보에 대해서는 도면 교환 파일 형식에서 찾아 볼 수 있습니다. DXF 그룹 코드는 응용프로그램과 DXF 파일 모두와 관련되어 있으므로 DXF 그룹 코드와 연관된 고급 개념에 대해서는 DXF 고급 정보에 설명되어 있습니다.

그룹 코드를 사용하는 AutoLISP 기능에 대한 설명은 AutoLISP Developer's Guide의 "Using AutoLISP to Manipulate AutoCAD Objects"를 참고하십시오.


DXF 참조서의 개정 사항

본 참조서의 구성
DXF 형식
본 참조서의 형식화 규칙
DXF 참조서 > DXF 형식 >
DXF 참조서의 개정 사항

여기에는 DXF 참조서를 마지막으로 업데이트한 이후의 개정 사항이 나열되어 있습니다. 본 DXF 참조서의 버전 번호는 u19.1.01입니다.

  • ENTITIES 섹션
  • OBJECTS 섹션


본 참조서의 형식화 규칙

DXF 참조서의 개정 사항
DXF 형식
객체 및 도면요소 코드
DXF 참조서 > DXF 형식 >
본 참조서의 형식화 규칙

본 참조서에 포함되어 있는 각 그룹 코드는 숫자 그룹 코드 값과 해당 설명으로 제공되어 있습니다. 모든 그룹 코드는 DXF™ 파일, 응용프로그램(AutoLISP 또는 ObjectARX) 또는 두 가지 모두에 적용할 수 있습니다. 응용프로그램과 DXF 파일에 대해 코드 설명이 다를 경우(또는 둘 중 어느 하나에만 적용될 경우), 다음과 같은 표시기가 설명 앞에 붙습니다.

  • APP.응용프로그램별 설명
  • DXF.DXF 파일별 설명

설명이 DXF 파일과 응용프로그램 모두에 공통적이라면 표시기가 제공되지 않습니다.

선택 가능한 코드는 설명에서 “선택 사항”으로 표시됩니다.


객체 및 도면요소 코드

본 참조서의 형식화 규칙
DXF 형식
그룹 코드 값 유형
DXF 참조서 > DXF 형식 >
객체 및 도면요소 코드

DXF™ 형식에서 객체의 정의는 도면요소와 다릅니다. 도면요소에는 그래픽적 표현이 포함되지만 객체에는 포함되지 않습니다. 예를 들어, 사전은 객체이며 도면요소가 아닙니다. 도면요소가 그래픽 객체로 지칭되는 반면 객체는 비그래픽 객체로 지칭됩니다.

도면요소는 DXF 파일의 BLOCK 및 ENTITIES 섹션 모두에 나타납니다. 두 섹션에서의 그룹 코드 사용은 동일합니다.

도면요소를 정의하는 일부 그룹 코드는 항상 표시되는 반면 나머지 다른 그룹 코드는 선택적이며 그 값이 기본값과 다를 경우에만 표시됩니다.

여기에 제공된 순서를 따르는 프로그램은 작성하지 마십시오. 도면요소의 끝은 다음 도면요소를 시작하거나 섹션의 끝을 나타내는 다음 0 그룹에 의해 표시됩니다.

주정의되지 않은 그룹 코드는 무시하고 도면요소 내의 그룹 코드 순서에 대한 가정이 없이 테이블 구동 방식으로 DXF 프로세싱 프로그램을 작성할 경우 AutoCAD®의 이후 릴리즈에서 DXF 파일을 더욱 편리하게 사용할 수 있습니다. 새로운 각각의 AutoCAD 릴리즈에서는 도면요소에 새로운 그룹 코드들이 추가되어 부가 기능을 사용할 수 있습니다.


그룹 코드 값 유형

객체 및 도면요소 코드
DXF 형식
번호순의 그룹 코드
DXF 참조서 > DXF 형식 >
그룹 코드 값 유형

그룹 코드는 다음과 같은 그룹 코드 범위 테이블에 따라, 연관된 값의 유형을 정수, 부동 소수 값 또는 문자열로 정의합니다. 이 테이블에서 사용된 축약어 및 형식에 대한 정보는 본 참조서의 형식화 규칙를 참고하십시오.

그룹 코드 값 유형
코드 범위 | 그룹 값 유형
0-9 | 문자열(AutoCAD 2000에서 확장된 기호 이름이 소개되어 255자 제한이 행 끝에 새 행을 포함하지 않고 2049 단일 바이트 문자로 늘어남)
10-39 | 배정밀도 3D 점 값
40-59 | 배정밀도 부동 소수 값
60-79 | 16비트 정수 값
90-99 | 32비트 정수 값.
100 | 문자열(최대값은 255 문자. 유니코드 문자열은 더 적음)
102 | 문자열(최대값은 255 문자. 유니코드 문자열은 더 적음)
105 | 16진 핸들 값을 나타내는 문자열
110-119 | 배정밀도 부동 소수 값
120-129 | 배정밀도 부동 소수 값
130-139 | 배정밀도 부동 소수 값
140-149 | 배정밀도 스칼라 부동 소수 값
170-179 | 16비트 정수 값
210-239 | 배정밀도 부동 소수 값
270-279 | 16비트 정수 값
280-289 | 16비트 정수 값
290-299 | 부울 플래그 값
300-309 | 임의의 문자열
310-319 | 이진 청크의 16진 값을 나타내는 문자열
320-329 | 16진 핸들 값을 나타내는 문자열
330-369 | 16진 객체 ID를 나타내는 문자열
370-379 | 16비트 정수 값
380-389 | 16비트 정수 값
390-399 | 16진 핸들 값을 나타내는 문자열
400-409 | 16비트 정수 값
410-419 | 문자열
420-429 | 32비트 정수 값.
430-439 | 문자열
440-449 | 32비트 정수 값.
450-459 | 배정밀도
460-469 | 배정밀도 부동 소수 값
470-479 | 문자열
999 | 주석(문자열)
1000-1009 | 문자열(0-9 코드 범위에서와 동일한 한계)
1010-1059 | 배정밀도 부동 소수 값
1060-1070 | 16비트 정수 값
1071 | 32비트 정수 값.


번호순의 그룹 코드

그룹 코드 값 유형
DXF 형식
HEADER 섹션
DXF 참조서 > DXF 형식 >
번호순의 그룹 코드

다음 테이블에는 그룹 코드 값에 대한 설명과 함께 그룹 코드 또는 그룹 코드 범위가 제공되어 있습니다. 테이블에서 “고정됨”은 해당 그룹 코드가 항상 같은 용도로 사용됨을 나타냅니다. 그룹 코드가 고정되지 않은 경우 작업 환경에 따라 용도가 달라집니다. 이 테이블에서 사용된 축약어 및 형식에 대한 정보는 본 참조서의 형식화 규칙를 참고하십시오.

번호순의 그룹 코드
그룹 코드 | 설명
-5 | APP: 영구 리액터 체인
-4 | APP: 조건 연산자(ssget에서만 사용됨)
-3 | APP: 확장 데이터(XDATA) 센티널(고정됨)
-2 | APP: 도면요소 이름 참조(고정됨)
-1 | APP: 도면요소 이름. 이름은 도면이 열릴 때마다 변경됩니다. 이름은 절대로 저장되지 않습니다.(고정됨)
0 | 도면요소 유형을 나타내는 문자열(고정됨)
1 | 도면요소에 대한 1차 문자 값
2 | 이름(속성 태그, 블록 이름 등)
3-4 | 기타 문자 또는 이름 값
5 | 도면요소 핸들; 최대 16개의 16진 숫자로 구성된 문자열(고정됨)
6 | 선종류 이름(고정됨)
7 | 문자 스타일 이름(고정됨)
8 | 도면층 이름(고정됨)
9 | DXF: 변수 이름 식별자(DXF 파일의 HEADER 섹션에서만 사용됨)
10 | 1차 점: 선 또는 문자 도면요소, 원의 중심 등의 시작점 DXF: 1차 점의 X 값(다음에 Y 및 Z값 코드 20, 30이 옴) APP: 3D 점(3개의 실수 리스트)
11-18 | 기타 점 DXF: 기타 점의 X 값(다음에 Y 값 코드 21-28 및 Z 값 코드 31-38이 옴) APP: 3D 점(3개의 실수 리스트)
20, 30 | DXF: 1차 점의 Y 및 Z 값
21-28, 31-37 | DXF: 기타 점의 Y 및 Z 값
38 | DXF: 0이 아닌 경우 도면요소의 고도
39 | 0이 아닌 경우 도면요소의 두께(고정됨)
40-48 | 배정밀도 부동 소수 값(문자 높이, 축척 요인 등)
48 | 선종류 축척; 배정밀도 부동 소수 스칼라 값으로서 모든 도면요소 유형에 대해 기본값이 정의되어 있습니다.
49 | 반복된 배정밀도 부동 소수 값. LTYPE 테이블의 대시 길이와 같이 가변 길이 테이블에 대해서는 한 도면요소에 여러 개의 49 그룹이 표시될 수 있습니다. 7x 그룹은 항상 첫 번째 49 그룹 이전에 표시되어 테이블 길이를 지정합니다.
50-58 | 각도(DXF 파일에서는 도 단위, AutoLISP 및 ObjectARX 응용프로그램에서는 라디안 단위로 출력됨)
60 | 도면요소의 가시성: 정수 값으로 값이 없거나 0이면 가시적으로 설정되고 1이면 비가시적으로 설정됩니다.
62 | 색상 번호(고정됨)
66 | “뒤에 오는 도면요소” 플래그(고정됨)
67 | 공간—모형 또는 도면 공간(고정됨)
68 | APP: 뷰포트는 켜져 있지만 활성이 아니어서 화면이 완전히 꺼져 있는지 아니면 뷰포트가 꺼져 있는지 식별합니다.
69 | APP: 뷰포트 식별 번호
70-78 | 반복 횟수, 플래그 비트 등의 정수 값 또는 모드
90-99 | 32비트 정수 값
100 | 하위 클래스 데이터 표식기(문자열로 된 파생된 클래스 이름을 가진). 다른 실제 클래스로부터 파생된 모든 객체 및 도면요소 클래스에 요구됩니다. 하위 클래스 데이터 표식기는 동일한 객체에 대해 상속 체인의 다른 클래스에서 정의된 데이터를 분리시킵니다. 이는 ObjectARX에서 파생된 각각의 실제 클래스에 대한 DXF 이름 관련 요구사항에 추가됩니다.(하위 클래스 표식기 참고)
102 | 조정 문자열, 다음에 “{<고유 이름>” 또는 “}”이 옵니다. 문자열이 “{“으로 시작할 때 응용프로그램에 따라 의미가 달라지는 임의의 문자열이 뒤에 올 수 있다는 것을 제외하면 확장 데이터 1002 그룹 코드와 유사합니다. 유일하게 허용되는 기타 조정 문자열은 그룹 종료자인 “}”입니다. AutoCAD는 도면 검사 작업 중에만 이들 문자열을 해석합니다. 이런 문자열은 응용프로그램용입니다.
105 | DIMVAR 시스템 테이블 항목에 대한 객체 핸들
110 | UCS 원점(코드 72가 1로 설정되어 있는 경우에만 표시됨) DXF: X 값, APP: 3D점
111 | UCS X축(코드 72가 1로 설정되어 있는 경우에만 표시됨) DXF: X 값, APP: 3D 벡터
112 | UCS Y축(코드 72가 1로 설정되어 있는 경우에만 표시됨) DXF: X 값, APP: 3D 벡터
120-122 | DXF: UCS 원점의 Y 값, UCS X축 및 UCS Y축
130-132 | DXF: UCS 원점의 Z 값, UCS X축 및 UCS Y축
140-149 | 배정밀도 부동 소수 값(예를 들어, 점, 고도 및 DIMSTYLE 설정값)
170-179 | DIMSTYLE 설정값을 나타내는 플래그 비트 등의 16비트 정수 값
210 | 돌출 방향(고정됨) DXF: 돌출 방향의 X 값 APP: 3D 돌출 방향 벡터
220, 230 | DXF: 돌출 방향의 Y 및 Z 값
270-279 | 16비트 정수 값
280-289 | 16비트 정수 값
290-299 | 부울 플래그 값
300-309 | 임의의 문자열
310-319 | 1004 그룹 코드와 동일한 표현 및 한계를 가진 임의의 이진 묶음: 최대 254자로 구성된 16진 문자열은 최대 127바이트로 구성된 데이터 묶음를 나타냅니다.
320-329 | 임의의 객체 핸들, “있는 그대로” 간주되는 핸들 값입니다. INSERT 및 XREF 명령이 실행되는 동안 변환되지 않습니다.
330-339 | 소프트 포인터 핸들, 같은 DXF 파일 또는 도면 내의 다른 객체에 대한 임의의 소프트 포인터입니다. INSERT 및 XREF 명령이 실행되는 동안 변환됩니다.
340-349 | 하드 포인터 핸들; 같은 DXF 파일이나 도면 내의 다른 객체에 대한 임의의 하드 포인터. INSERT 및 XREF 명령이 실행되는 동안 변환됩니다.
350-359 | 소프트 소유자 핸들; 같은 DXF 파일이나 도면 내의 다른 객체에 대한 임의의 소프트 소유권 링크. INSERT 및 XREF 명령이 실행되는 동안 변환됩니다.
360-369 | 하드 소유자 핸들; 같은 DXF 파일이나 도면 내의 다른 객체에 대한 임의의 하드 소유권 링크. INSERT 및 XREF 명령이 실행되는 동안 변환됩니다.
370-379 | 선가중치 enum 값(AcDb::LineWeight). 16비트 정수로서 저장되거나 이동됨. AutoCAD와 AutoLISP에서는 모두 370 그룹 코드를 항상 도면요소의 선가중치로 간주하기 때문에 사용자 비도면요소 객체는 전체 범위를 사용할 수 있지만 도면요소 클래스는 371-379 DXF 그룹 코드만 표현식에 사용할 수 있습니다. 따라서 370은 다른 “공통” 도면요소 필드와 같이 동작합니다.
380-389 | PlotStyleName 유형 enum(AcDb::PlotStyleNameType). 16비트 정수로서 저장되거나 이동됨. 위의 선가중치 범위에서와 같은 이유로, 사용자 비도면요소 객체는 전체 범위를 사용할 수 있지만 도면요소 클래스는 381-389 DXF 그룹 코드만 표현식에 사용할 수 있습니다.
390-399 | PlotStyleName 객체의 핸들 값을 나타내는 문자열로서 기본적으로는 하드 포인터지만 역 호환성을 더 쉽게 처리할 수 있게 해 주는 다른 범위를 갖습니다. 객체 ID(DXF 파일에서는 핸들)로서 그리고 AutoLISP에서는 특별 유형으로서 저장되거나 이동됩니다. 위의 선가중치 범위에서와 같은 이유로, 사용자 비도면요소 객체는 전체 범위를 사용할 수 있지만 도면요소 클래스는 391-399 DXF 그룹 코드만 표현식에 사용할 수 있습니다.
400-409 | 16비트 정수
410-419 | 문자열
420-427 | 32비트 정수 값. 트루 컬러와 함께 사용될 경우, 24비트 색상 값을 나타내는 32비트 정수. 높은 순서의 바이트(8비트)는 0이며 낮은 순서의 바이트는 파란색 값(0~255)을 유지하는 unsigned char이며 그 다음은 초록색 값, 그리고 높은 순서 다음의 바이트는 빨간색 값입니다. 이 정수 값을 16진 값으로 변환하면 다음과 같은 비트 마스크가 생성됩니다. 0x00RRGGBB. 예를 들어, 빨간색==200, 초록색==100 및 파란색==50인 트루 컬러는 0x00C86432이며 DXF에서는 십진수로 13132850입니다.
430-437 | 문자열; 트루 컬러에 사용될 경우 색상 이름을 나타내는 문자열
440-447 | 32비트 정수 값. 트루 컬러에 사용될 경우 투명 값
450-459 | 배정밀도
460-469 | 배정밀도 부동 소수 값
470-479 | 문자열
999 | DXF: 999 그룹 코드는 이 코드 다음의 행이 주석 문자열임을 나타냅니다. SAVEAS에서는 그런 그룹을 DXF 출력 파일에 포함하지 않지만 OPEN에서는 유효하며 주석을 무시합니다. 999 그룹을 사용하여 편집한 DXF 파일에 주석을 포함할 수 있습니다.
1000 | 확장 데이터의 ASCII 문자열(최대 255바이트 길이)
1001 | 확장 데이터의 등록된 응용프로그램 이름(최대 31바이트 길이의 ASCII 문자열)
1002 | 확장 데이터 조정 문자열(“{” 또는 “}”)
1003 | 확장 데이터 도면층 이름
1004 | 확장 데이터의 바이트 묶음(최대 127바이트 길이)
1005 | 확장 데이터의 도면요소 핸들; 최대 16개의 16진 숫자로 구성된 문자열
1010 | 확장 데이터의 점 DXF: X 값(1020 및 1030 그룹이 뒤에 옴) APP: 3D 점
1020, 1030 | DXF: 점의 Y 및 Z 값
1011 | 확장 데이터의 3D 표준 공간 위치 DXF: X 값(1021 및 1031 그룹이 뒤에 옴) APP: 3D 점
1021, 1031 | DXF: 표준 공간 위치의 Y 및 Z 값
1012 | 확장 데이터의 3D 표준 공간 변위 DXF: X 값(1022 및 1032 그룹이 뒤에 옴) APP: 3D 벡터
1022, 1032 | DXF: 표준 공간 변위의 Y 및 Z 값
1013 | 확장 데이터의 3D 표준 공간 방향 DXF: X 값(1022 및 1032 그룹이 뒤에 옴) APP: 3D 벡터
1023, 1033 | DXF: 표준 공간 방향의 Y 및 Z 값
1040 | 확장 데이터 배정밀도 부동 소수 값
1041 | 확장 데이터 거리 값
1042 | 확장 데이터 축척 요인
1070 | 확장 데이터 부호 있는 16비트 정수
1071 | 확장 데이터 부호 있는 32비트 길이


HEADER 섹션

번호순의 그룹 코드
HEADER 섹션 그룹 코드
DXF 참조서 >
HEADER 섹션

이 장에서 설명한 그룹 코드는 DXF™ 파일에만 해당됩니다. DXF 파일의 HEADER 섹션에는 도면과 연관된 변수의 설정값이 들어 있습니다. 각 변수는 변수 이름을 제공하는 9 그룹 코드와 이어서 변수 값을 제공하는 그룹에 의해 지정됩니다. 이 장에서는 도면 파일에 저장되는 변수만 나열합니다.

이 단원의 항목

  • HEADER 섹션 그룹 코드


HEADER 섹션 그룹 코드

HEADER 섹션
HEADER 섹션
개정된 VPORT 헤더 변수
DXF 참조서 > HEADER 섹션 >
HEADER 섹션 그룹 코드

다음 테이블은 DXF™ 파일의 HEADER 섹션에 표현된 변수를 나열합니다. 이 테이블에서 사용된 축약어 및 형식에 대한 정보는 본 참조서의 형식화 규칙를 참고하십시오.

DXF 헤더 변수

변수

그룹 코드

설명

$ACADMAINTVER

70

유지보수 버전 번호(무시되어야 함)

$ACADVER

1

AutoCAD 도면 데이터베이스 버전 번호:

AC1006 = R10; AC1009 = R11 및 R12;

AC1012 = R13; AC1014 = R14; AC1015 = AutoCAD 2000;

AC1018 = AutoCAD 2004

$ANGBASE

50

각도 0 방향

$ANGDIR

70

1 = 시계 방향 각도

0 = 시계 반대 방향 각도

$ATTMODE

70

속성 가시성:

0 = 없음

1 = 일반

2 = 전체

$AUNITS

70

각도 단위 형식

$AUPREC

70

각도 단위 정밀도

$CECOLOR

62

현재 도면요소의 색상 번호:

0 = BYBLOCK, 256 = BYLAYER

$CELTSCALE

40

현재 도면요소 선종류 축척

$CELTYPE

6

도면요소 선종류 이름 또는 BYBLOCK 또는 BYLAYER

$CELWEIGHT

370

새 객체의 선가중치

$CEPSNID

390

새 객체의 플롯 스타일 핸들; CEPSNTYPE이 3일 경우, 이 값이 핸들을 나타냅니다.

$CEPSNTYPE

380

새 객체의 플롯 스타일:

0 = 도면층별 플롯 스타일

1 = 블록별 플롯 스타일

2 = 사전 기본값별 플롯 스타일

3 = 객체 ID/핸들별 플롯 스타일

$CHAMFERA

40

첫 번째 모따기 거리

$CHAMFERB

40

두 번째 모따기 거리

$CHAMFERC

40

모따기 길이

$CHAMFERD

40

모따기 각도

$CLAYER

8

현재 도면층 이름

$CMLJUST

70

현재 여러 줄 자리맞추기:

0 = 맨 위, 1 = 중간, 2 = 맨 아래

$CMLSCALE

40

현재 여러 줄 축척

$CMLSTYLE

2

현재 여러 줄 스타일 이름

$CSHADOW

280

3D 객체의 그림자 모드:

0 = 그림자 주사 및 수신

1 = 그림자 주사

2 = 그림자 수신

3 = 그림자 무시

$DIMADEC

70

각도 치수에 표시되는 정밀도 자릿수

$DIMALT

70

0이 아닌 경우, 대체 단위 치수 기입을 수행합니다.

$DIMALTD

70

대체 단위 소수 자리

$DIMALTF

40

대체 단위 축척 요인

$DIMALTRND

40

대체 단위 라운딩을 결정합니다.

$DIMALTTD

70

대체 단위 치수의 공차값에 대한 소수 자리 수

$DIMALTTZ

70

대체 공차값에 대한 0 억제를 조정:

0 = 0피트를 억제하고 정확하게 0인치를 억제합니다.

1 = 0피트를 포함하고 정확하게 0인치를 포함합니다.

2 = 0피트를 포함하고 0인치를 억제합니다.

3 = 0인치를 포함하고 0피트를 억제합니다.

$DIMALTU

70

각도 치수를 제외한 모든 치수 스타일 군 구성원의 대체 단위 형식:

1 = 과학, 2 = 십진, 3 = 공학,

4 = 건축(스택), 5 = 분수(스택),

6 = 건축, 7 = 분수

$DIMALTZ

70

대체 단위 치수 값의 0 억제를 조정:

0 = 0피트를 억제하고 정확하게 0인치를 억제합니다.

1 = 0피트를 포함하고 정확하게 0인치를 포함합니다.

2 = 0피트를 포함하고 0인치를 억제합니다.

3 = 0인치를 포함하고 0피트를 억제합니다.

$DIMAPOST

1

대체 치수 기입 꼬리글

$DIMASO

70

1 = 연관 치수기입을 작성합니다.

0 = 개별 도면요소를 그립니다.

$DIMASSOC

280

치수 객체의 연관성을 조정합니다.

0 = 분해 치수를 작성합니다. 치수 요소 사이에 연관이 없으며, 선, 호, 화살촉 및 치수 문자는 독립적인 객체로 작성됩니다.

1 = 비연관 치수 객체를 작성합니다. 치수 요소는 단일 객체로 형성됩니다. 객체에서 정의점이 이동하는 경우 치수 값이 업데이트됩니다.

2 = 연관 치수 객체를 작성합니다. 치수 요소는 단일 객체로 형성되며, 치수에 있는 하나 이상의 정의점은 기하학 객체에 있는 연관점과 결합됩니다.

$DIMASZ

40

치수기입 화살표 크기

$DIMATFIT

70

치수보조선 내부에 치수 문자와 화살표를 배치할 공간이 충분하지 않을 때 치수 문자와 화살표 위치를 조정합니다.

0 = 문자와 화살표를 치수보조선 외부에 배치합니다.

1 = 먼저 화살표를 이동한 다음 문자를 이동합니다.

2 = 먼저 문자를 이동한 다음 화살표를 이동합니다.

3 = 문자 또는 화살표 중 가장 잘 맞는 것을 이동합니다.

DIMTMOVE가 1로 설정될 때 AutoCAD가 지시선을 이동된 치수 문자에 추가합니다.

$DIMAUNIT

70

각도 치수에 대한 각도 형식:

0 = 십진 도수, 1 = 도/분/초,

2 = 그라디안, 3 = 라디안, 4 = 측량사 단위

$DIMAZIN

70

각도 치수에서 0 억제를 조정합니다.

0 = 모든 선행 및 후행 0을 표시합니다.

1 = 십진 치수에서 선행 0을 억제합니다.

2 = 십진 치수에서 후행 0을 억제합니다.

3 = 선행 및 후행 0을 억제합니다.

$DIMBLK

1

화살표 블록 이름

$DIMBLK1

1

첫 번째 화살표 블록 이름

$DIMBLK2

1

두 번째 화살표 블록 이름

$DIMCEN

40

중심 표식/선의 크기

$DIMCLRD

70

치수 선 색상:

범위 0 = BYBLOCK, 256 = BYLAYER

$DIMCLRE

70

치수보조선 색상:

범위 0 = BYBLOCK, 256 = BYLAYER

$DIMCLRT

70

치수 문자 색상:

범위 0 = BYBLOCK, 256 = BYLAYER

$DIMDEC

70

1차 단위 치수의 공차값에 대한 소수 자리 수

$DIMDLE

40

치수 선 연장

$DIMDLI

40

치수 선 증분

$DIMDSEP

70

단위 형식이 십진인 치수를 작성할 때 사용되는 단일 문자 소수부 구분자

$DIMEXE

40

치수보조선 연장

$DIMEXO

40

치수보조선 간격띄우기

$DIMFAC

40

치수 분수 및 공차에 대한 문자 높이 계산에 사용되는 축척 요인. AutoCAD는 DIMTXT와 DIMTFAC을 곱한 값으로 분수 또는 공차 문자의 높이를 설정합니다.

$DIMGAP

40

치수 선 간격

$DIMJUST

70

수평 치수 문자의 위치:

0 = 치수 선 위 그리고 치수보조선 사이의 중심에 정렬

1 = 치수 선 위 그리고 첫 번째 치수보조선 옆에 정렬

2 = 치수 선 위 그리고 두 번째 치수보조선 옆에 정렬

3 = 첫 번째 치수보조선 위 그리고 중심에 정렬

4 = 두 번째 치수보조선 위 그리고 중심에 정렬

$DIMLDRBLK

1

지시선에 대한 화살표 블록 이름

$DIMLFAC

40

선형 측정 축척 요인

$DIMLIM

70

0이 아닌 경우, 치수 한계가 생성됩니다.

$DIMLUNIT

70

각도를 제외한 모든 치수 유형의 단위를 설정합니다.

1 = 과학, 2 = 십진, 3 = 공학,

4 = 건축, 5 = 분수, 6 = Windows 데스크탑

$DIMLWD

70

치수 선 선가중치:

-3 = 표준

-2 = 도면층별

-1 = 블록별

0-211 = mm의 100분의 1을 나타내는 정수

$DIMLWE

70

치수보조선 선가중치:

-3 = 표준

-2 = 도면층별

-1 = 블록별

0-211 = mm의 100분의 1을 나타내는 정수

$DIMPOST

1

일반 치수기입 꼬리글

$DIMRND

40

치수 거리의 반올림 값

$DIMSAH

70

0이 아닌 경우, 별도의 화살표 블록을 사용합니다.

$DIMSCALE

40

전체 치수기입 축척 요인

$DIMSD1

70

첫 번째 치수보조선 억제:

0 = 억제되지 않음, 1 = 억제됨

$DIMSD2

70

두 번째 치수보조선 억제:

0 = 억제되지 않음, 1 = 억제됨

$DIMSE1

70

0이 아닌 경우, 첫 번째 치수보조선이 억제됩니다.

$DIMSE2

70

0이 아닌 경우, 두 번째 치수보조선이 억제됩니다.

$DIMSHO

70

1 = 끌어오는 동안 치수를 재계산합니다.

0 = 원래 이미지를 끌어옵니다.

$DIMSOXD

70

0이 아닌 경우, 치수 선의 바깥쪽 연장을 억제합니다.

$DIMSTYLE

2

치수 스타일 이름

$DIMTAD

70

0이 아닌 경우, 치수 선 위 문자

$DIMTDEC

70

공차값 표시를 위한 소수 자리 수

$DIMTFAC

40

치수 공차 화면 표시 축척 요인

$DIMTIH

70

0이 아닌 경우, 수평 내의 문자

$DIMTIX

70

0이 아닌 경우, 문자를 치수보조선 내에 강제 배치합니다.

$DIMTM

40

음의 공차

$DIMTMOVE

70

치수 문자 이동 규칙:

0 = 치수 선을 치수 문자와 함께 이동합니다.

1 = 치수 문자가 이동될 때 지시선을 추가합니다.

2 = 지시선 없이 문자를 자유롭게 이동할 수 있습니다.

$DIMTOFL

70

치수보조선 외부에 문자가 있는 경우, 0이 아니라면 치수보조선 사이로 선을 강제 연장합니다.

$DIMTOH

70

0이 아닌 경우, 수평 외부의 문자

$DIMTOL

70

0이 아닌 경우, 치수 공차가 생성됩니다.

$DIMTOLJ

70

공차값에 대한 수직 자리맞추기:

0 = 맨 위, 1 = 중간, 2 = 맨 아래

$DIMTP

40

양의 공차

$DIMTSZ

40

치수기입 눈금 크기:

0 = 눈금 없음

$DIMTVP

40

문자 수직 위치

$DIMTXSTY

7

치수 문자 스타일

$DIMTXT

40

치수기입 문자 높이

$DIMTZIN

70

공차값에 대한 0 억제를 조정:

0 = 0피트를 억제하고 정확하게 0인치를 억제합니다.

1 = 0피트를 포함하고 정확하게 0인치를 포함합니다.

2 = 0피트를 포함하고 0인치를 억제합니다.

3 = 0인치를 포함하고 0피트를 억제합니다.

$DIMUPT

70

사용자 위치 지정 문자에 대한 커서 기능:

0 = 치수 선 위치만 조정합니다.

1 = 치수 선 위치와 문자 위치 모두를 조정합니다.

$DIMZIN

70

1차 단위값에 대한 0 억제를 조정:

0 = 0피트를 억제하고 정확하게 0인치를 억제합니다.

1 = 0피트를 포함하고 정확하게 0인치를 포함합니다.

2 = 0피트를 포함하고 0인치를 억제합니다.

3 = 0인치를 포함하고 0피트를 억제합니다.

$DISPSILH

70

와이어프레임 모드에서 본체 객체의 윤곽 곡선에 대한 화면 표시를 조정:

0 = 끄기; 1 = 켜기

$DRAGVS

349

3D 솔리드 기본체를 작성하는 동안 뷰 스타일의 하드 포인터 ID입니다. 기본값은 NULL입니다.

$DWGCODEPAGE

3

도면 코드 페이지. 새 도면이 작성될 때 시스템 코드 페이지로 설정되며 AutoCAD에 의해 다른 상태로 관리되지 않습니다.

$ELEVATION

40

ELEV 명령으로 설정한 현재 고도

$ENDCAPS

280

새 객체에 대한 선가중치 끝막음 설정값:

0 = 없음, 1 = 둥근 모양, 2 = 각진 모양, 3 = 사각형 모양

$EXTMAX

10, 20, 30

X, Y 및 Z 도면 범위 오른쪽 상단 구석(WCS)

$EXTMIN

10, 20, 30

X, Y 및 Z 도면 범위 왼쪽 아래 구석(WCS)

$EXTNAMES

290

기호 테이블 이름 지정을 조정합니다.

0 = 릴리즈 14 호환성 이름을 31 자리까지의 문자로 제한합니다. A 에서 Z까지의 문자와 0에서 9까지의 숫자 그리고 달러 기호($), 밑줄(_), 하이픈(-)과 같은 특수 문자를 이름에 사용할 수 있습니다.

1 = AutoCAD 2000. 이름에는 최대 255자를 사용할 수 있으며, A에서 Z까지의 문자, 0(영)에서 9까지의 숫자, 공백, 그리고 Microsoft Windows 및 AutoCAD에서 다른 목적으로 사용되지 않은 모든 특수 문자를 사용할 수 있습니다.

$FILLETRAD

40

모깎기 반지름

$FILLMODE

70

0이 아닌 경우, 채우기 모드를 켬

$FINGERPRINTGUID

2

작성 시각에 설정되며 특정 도면을 고유하게 식별합니다.

$HALOGAP

280

다른 객체에 의해 객체가 숨겨지는 곳에 간격이 표시되도록 지정합니다; 값은 한 단위의 퍼센트로 지정되며 줌 단계에는 영향을 받지 않습니다. 무리선의 길이는 SHADEMODE의 숨김 옵션이나 HIDE가 사용될 때 무리선이 숨겨진 지점에서 짧아집니다.

$HANDSEED

5

사용 가능한 다음 핸들

$HIDETEXT

290

HIDETEXT 시스템 변수 지정:

0 = 숨겨진 뷰가 생성될 때 HIDE가 문자 객체를 무시합니다.

1 = HIDE가 문자 객체를 무시하지 않습니다.

$HYPERLINKBASE

1

도면에 있는 모든 연관 하이퍼링크의 경로. null인 경우, 도면 경로가 사용됩니다.

$INDEXCTL

280

도면 파일에서 도면층 및 공간 색인을 작성하고 저장할지 여부를 조정합니다.

0 = 색인을 작성하지 않습니다.

1 = 도면층 색인을 작성합니다.

2 = 공간 색인을 작성합니다.

3 = 도면층 및 공간 색인을 작성합니다.

$INSBASE

10, 20, 30

BASE 명령으로 설정한 삽입 기준(WCS)

$INSUNITS

70

AutoCAD DesignCenter 블록에 대한 기본 도면 단위:

0 = 단위 없음, 1 = 인치, 2 = 피트, 3 = 마일, 4 = 밀리미터,

5 = 센티미터, 6 =미터, 7 = 킬로미터, 8 = 마이크로인치,

9 = 마일, 10 = 야드, 11 = 옹스트롱, 12 = 나노미터,

13 = 마이크론, 14 = 데시미터, 15 = 데카미터,

16 = 헥토미터, 17 = 기가미터, 18 = 천문학 단위,

19 = 광년, 20 = 파세크

$INTERFERECOLOR

62

간섭 command.Default 값이 1일 때 작성된 "간섭 객체"의 ACI 색상 색인을 나타냅니다.

$INTERFEREOBJVS

345

간섭 객체에 대한 뷰 스타일의 하드 포인터 ID입니다. 기본 뷰 스타일은 개념입니다.

$INTERFEREVPVS

346

간섭 확인 중에 뷰포트에 대한 뷰 스타일의 하드 포인터 ID입니다. 기본 뷰 스타일은 3D 와이어프레임입니다.

$INTERSECTIONCOLOR

70

교차 폴리선의 도면요소 색상을 지정합니다.

1에서 255까지의 값은 AutoCAD 색상 색인(ACI)을 지정합니다.

0 = 색상 BYBLOCK

256 = 색상 BYLAYER

257 = 색상 BYENTITY

$INTERSECTIONDISPLAY

290

교차 폴리선의 화면표시를 지정합니다.

0 = 교차 폴리선을 화면에 표시하지 않습니다.

1 = 교차 폴리선을 화면에 표시합니다.

$JOINSTYLE

280

새 객체에 대한 선가중치 접합부 설정값:

0=없음, 1= 둥근 모양, 2 = 각진 모양, 3 = 평평한 모양

$LIMCHECK

70

한계 점검 기능이 켜진 경우, 0이 아님

$LIMMAX

10, 20

XY 도면 한계 오른쪽 상단 구석(WCS)

$LIMMIN

10, 20

XY 도면 한계 오른쪽 상단 구석(WCS)

$LTSCALE

40

전체 선종류 축척

$LUNITS

70

좌표 및 거리에 대한 단위 형식

$LUPREC

70

좌표 및 거리에 대한 단위 정밀도

$LWDISPLAY

290

모형 또는 레이아웃 탭에서 선가중치 화면표시를 조정합니다.

0 = 선가중치를 표시하지 않습니다.

1 = 선가중치를 표시합니다.

$MAXACTVP

70

재생성할 뷰포트의 최대 개수를 설정합니다.

$MEASUREMENT

70

도면 단위를 설정합니다. 0 = 영국식, 1 = 미터법

$MENU

1

메뉴 파일의 이름

$MIRRTEXT

70

0이 아닌 경우, 문자를 대칭합니다.

$OBSCOLOR

70

가려진 선의 색상을 지정합니다. 가려진 선은 색상과 선종류를 변경하면 보이는 은선이며, HIDE나 SHADEMODE HIDE 명령을 사용할 때에만 표시됩니다. OBSCUREDCOLOR 설정은 OBSCUREDLTYPE을 0 이외의 값으로 설정하여 OBSCUREDLTYPE이 켜져 있는 경우에만 볼 수 있습니다.

0 및 256 = 도면요소 색상

1-255 = AutoCAD 색상 색인(ACI)

$OBSLTYPE

280

가려진 선의 선종류를 지정합니다. 가려진 선종류는 일반적인 AutoCAD 선종류와 달리 줌 단계와 관계가 없습니다. 0이 기본값이며, 가려진 선의 표시를 끕니다. 선종류 값은 다음과 같이 정의됩니다.

0 = 없음

1 = 실선

2 = 대시

3 = 점선

4 = 짧은 대시

5 = 중간 대시

6 = 긴 대시

7 = 두겹 짧은 대시

8 = 두겹 중간 대시

9 = 두겹 긴 대시

10 = 중간 긴 대시

11 = 성긴 도트

$ORTHOMODE

70

0이 아닌 경우, 직교 모드를 켬

$PDMODE

70

점 화면 표시 모드

$PDSIZE

40

점 화면 표시 크기

$PELEVATION

40

현재 도면 공간 고도

$PEXTMAX

10, 20, 30

도면 공간의 최대 X, Y 및 Z 범위

$PEXTMIN

10, 20, 30

도면 공간의 최소 X, Y 및 Z 범위

$PINSBASE

10, 20, 30

도면 공간 삽입 기준점

$PLIMCHECK

70

0이 아닌 경우, 도면 공간의 한계를 점검합니다.

$PLIMMAX

10, 20

도면 공간의 최대 X 및 Y 한계

$PLIMMIN

10, 20

도면 공간의 최소 X 및 Y 한계

$PLINEGEN

70

2D 폴리선의 정점 주변의 선종류 패턴 생성을 조정합니다.

1 = 폴리선의 정점 주변에 연속 패턴의 선종류를 생성합니다.

0 = 폴리선의 각 세그먼트를 대시로 시작하고 끝냅니다.

$PLINEWID

40

기본 폴리선 폭

$PROJECTNAME

1

현재 도면에 프로젝트 이름을 지정합니다. 외부 참조 또는 이미지가 원래 경로에서 찾을 수 없을 때 사용됩니다. 프로젝트 이름은 레지스트리 내의 하나의 구역을 가리키며, 정의된 각각의 프로젝트 이름에는 1개 이상의 검색 경로가 들어 있을 수 있습니다. 프로젝트 이름과 프로젝트 이름의 검색 디렉토리는 옵션 대화상자의 파일 탭에서 작성됩니다.

$PROXYGRAPHICS

70

프록시 객체 이미지의 저장을 조정합니다.

$PSLTSCALE

70

도면 공간 선종류 축척을 조정합니다.

1 = 특별한 선종류 축척을 하지 않습니다.

0 = 뷰포트 축척이 선종류 축척을 조정합니다.

$PSTYLEMODE

290

현재 도면이 색상 종속 플롯 스타일 모드인지 명명된 플롯 스타일 모드인지 여부를 나타냅니다.

0 = 현재 도면에 명명된 플롯 스타일 테이블을 사용합니다.

1 = 현재 도면에서 색상 종속 플롯 스타일 테이블을 사용합니다.

$PSVPSCALE

40

새 뷰포트에 대한 뷰 축척 비율:

0 = 창에 맞게 축척

>0 = 축척 비율(양수)

$PUCSBASE

2

직교 UCS 설정의 원점과 방향을 정의하는 UCS 이름(도면 공간에서만)

$PUCSNAME

2

현재 도면 공간 UCS 이름

$PUCSORG

10, 20, 30

현재 도면 공간 UCS 원점

$PUCSORGBACK

10, 20, 30

PUCSBASE가 WORLD로 설정될 때 도면 공간 UCS가 BACK으로 변경된 후 새 UCS 원점이 되는 점

$PUCSORGBOTTOM

10, 20, 30

PUCSBASE가 WORLD로 설정될 때 도면 공간 UCS가 BOTTOM으로 변경된 후 새 UCS 원점이 되는 점

$PUCSORGFRONT

10, 20, 30

PUCSBASE가 WORLD로 설정될 때 도면 공간 UCS가 FRONT로 변경된 후 새 UCS 원점이 되는 점

$PUCSORGLEFT

10, 20, 30

PUCSBASE가 WORLD로 설정될 때 도면 공간 UCS가 LEFT로 변경된 후 새 UCS 원점이 되는 점

$PUCSORGRIGHT

10, 20, 30

PUCSBASE가 WORLD로 설정될 때 도면 공간 UCS가 RIGHT로 변경된 후 새 UCS 원점이 되는 점

$PUCSORGTOP

10, 20, 30

PUCSBASE가 WORLD로 설정될 때 도면 공간 UCS가 TOP으로 변경된 후 새 UCS 원점이 되는 점

$PUCSORTHOREF

2

도면 공간 UCS가 직교(PUCSORTHOVIEW는 0이 아님)인 경우에는 직교 UCS에 상대적인 UCS의 이름입니다. 비어 있는 경우, UCS는 WCS에 상대적입니다.

$PUCSORTHOVIEW

70

도면 공간 UCS의 직교 뷰 유형:

0 = UCS는 직교가 아님,

1 = 맨 위, 2 = 맨 아래,

3 = 앞, 4 = 뒤,

5 = 왼쪽, 6 = 오른쪽

$PUCSXDIR

10, 20, 30

현재 도면 공간 UCS X축

$PUCSYDIR

10, 20, 30

현재 도면 공간 UCS Y축

$QTEXTMODE

70

0이 아닌 경우, 신속 문자 모드

$REGENMODE

70

0이 아닌 경우, REGENAUTO 모드를 켬

$SHADEDGE

70

0 = 면은 음영처리되고 모서리는 강조 표시되지 않음

1 = 면은 음영처리되고 모서리는 검은색으로 강조 표시됨

2 = 면은 채워지지 않고 모서리는 도면요소 색상으로 지정됨

3 = 면은 도면요소 색상으로, 모서리는 검은색으로 지정됨

$SHADEDIF

70

주변 광원/분산 광원 퍼센트, 범위 1-100, 기본값 70

$SHADOWPLANELOCATION

40

지면 그림자 평면의 위치입니다. Z 축 세로좌표입니다.

$SKETCHINC

40

스케치 레코드 증분

$SKPOLY

70

0 = 스케치 선; 1 = 스케치 폴리선

$SORTENTS

280

객체 정렬 방식을 조정; 옵션 대화상자의 사용자 기본 설정 탭에서 설정할 수 있습니다. SORTENTS는 다음과 같은 비트코드를 사용합니다.

0 = SORTENTS 사용 안함

1 = 객체 선택을 위해 정렬함

2 = 객체 스냅을 위해 정렬함

4 = 다시 그리기 위해 정렬함

8 = MSLIDE 명령의 슬라이드 작성을 위해 정렬함

16 = REGEN 명령을 위해 정렬함

32 = 플로팅을 위해 정렬함

64 = 포스트스크립트 출력을 위해 정렬함

$SPLFRAME

70

스플라인 조정 다각형 화면표시: 1 = 켜기, 0 = 끄기

$SPLINESEGS

70

스플라인 패치당 선 세그먼트 개수

$SPLINETYPE

70

PEDIT의 스플라인에 대한 스플라인 곡선 유형

$SURFTAB1

70

첫 번째 방향의 메쉬 도표 개수

$SURFTAB2

70

두 번째 방향의 메쉬 도표 개수

$SURFTYPE

70

PEDIT의 부드럽게 옵션에 대한 곡면 유형

$SURFU

70

M 방향의 곡면 밀도(PEDIT의 부드럽게 옵션에 대한)

$SURFV

70

N 방향의 곡면 밀도(PEDIT의 부드럽게 옵션에 대한)

$TDCREATE

40

도면이 작성된 로컬 날짜/시간(날짜/시간 변수에 대한 특별 처리 참고)

$TDINDWG

40

해당 도면의 총 편집 시간(날짜/시간 변수에 대한 특별 처리 참고)

$TDUCREATE

40

도면이 작성된 국제 날짜/시간(날짜/시간 변수에 대한 특별 처리 참고)

$TDUPDATE

40

도면이 마지막으로 업데이트된 로컬 날짜/시간(날짜/시간 변수에 대한 특별 처리 참고)

$TDUSRTIMER

40

사용자 경과 타이머

$TDUUPDATE

40

도면이 마지막으로 업데이트/저장된 국제 날짜/시간(날짜/시간 변수에 대한 특별 처리 참고)

$TEXTSIZE

40

기본 문자 높이

$TEXTSTYLE

7

현재 문자 스타일 이름

$THICKNESS

40

ELEV 명령으로 설정한 현재 두께

$TILEMODE

70

이전 릴리즈 호환성 모드는 1, 그 밖의 경우는 0으로 설정함

$TRACEWID

40

기본 두께선 폭

$TREEDEPTH

70

공간 색인의 최대 내포 단계를 지정합니다.

$UCSBASE

2

직교 UCS 설정의 원점과 방향을 정의하는 UCS 이름

$UCSNAME

2

현재 UCS의 이름

$UCSORG

10, 20, 30

현재 UCS의 원점(WCS)

$UCSORGBACK

10, 20, 30

UCSBASE가 WORLD로 설정될 때 모형 공간 UCS가 BACK으로 변경된 후 새 UCS 원점이 되는 점

$UCSORGBOTTOM

10, 20, 30

UCSBASE가 WORLD로 설정될 때 모형 공간 UCS가 BOTTOM으로 변경된 후 새 UCS 원점이 되는 점

$UCSORGFRONT

10, 20, 30

UCSBASE가 WORLD로 설정될 때 모형 공간 UCS가 FRONT로 변경된 후 새 UCS 원점이 되는 점

$UCSORGLEFT

10, 20, 30

UCSBASE가 WORLD로 설정될 때 모형 공간 UCS가 LEFT로 변경된 후 새 UCS 원점이 되는 점

$UCSORGRIGHT

10, 20, 30

UCSBASE가 WORLD로 설정될 때 모형 공간 UCS가 RIGHT로 변경된 후 새 UCS 원점이 되는 점

$UCSORGTOP

10, 20, 30

UCSBASE가 WORLD로 설정될 때 모형 공간 UCS가 TOP으로 변경된 후 새 UCS 원점이 되는 점

$UCSORTHOREF

2

모형 공간 UCS가 직교(UCSORTHOVIEW는 0이 아님)인 경우에는 직교 UCS에 상대적인 UCS의 이름입니다. 비어 있는 경우, UCS는 WCS에 상대적입니다.

$UCSORTHOVIEW

70

모형 공간 UCS의 직교 뷰 유형:

0 = UCS는 직교가 아님,

1 = 맨 위, 2 = 맨 아래,

3 = 앞, 4 = 뒤,

5 = 왼쪽, 6 = 오른쪽

$UCSXDIR

10, 20, 30

현재 UCS X축의 방향(WCS)

$UCSYDIR

10, 20, 30

현재 UCS Y축의 방향(WCS)

$UNITMODE

70

하위 비트 설정 = 분수, 피트 및 인치 그리고 입력 형식의 측량사 각도를 표시합니다.

$USERI1 - 5

70

써드 파티 개발자가 사용할 수 있도록 고안된 5개의 정수 변수

$USERR1 - 5

40

써드 파티 개발자가 사용할 수 있도록 고안된 5개의 실수 변수

$USRTIMER

70

0 = 타이머 끄기; 1 = 타이머 켜기

$VERSIONGUID

2

특정 버전의 도면을 고유하게 식별합니다. 도면이 수정될 때 업데이트됨

$VISRETAIN

70

0 = 외부 참조 종속 가시성 설정값을 유지하지 않음

1 = 외부 참조 종속 가시성 설정값을 유지함

$WORLDVIEW

70

1 = DVIEW/VPOINT 중에 UCS를 WCS로 설정함

0 = UCS를 변경하지 않음

$XCLIPFRAME

290

외부참조 자르기 경계의 가시성을 조정합니다.

0 = 자르기 경계를 표시하지 않습니다.

1 = 자르기 경계를 표시합니다.

$XEDIT

290

현재 도면을 다른 도면에서 참조할 때 내부 편집할 수 있는지 조정합니다.

0 = 내부 참조 편집을 사용할 수 없음

1 = 내부 참조 편집을 사용할 수 있음

이 단원의 항목

  • 개정된 VPORT 헤더 변수
  • 날짜/시간 변수에 대한 특별 처리


개정된 VPORT 헤더 변수

HEADER 섹션 그룹 코드
HEADER 섹션 그룹 코드
날짜/시간 변수에 대한 특별 처리
DXF 참조서 > HEADER 섹션 > HEADER 섹션 그룹 코드 >
개정된 VPORT 헤더 변수

다음의 헤더 변수는 AutoCAD® 릴리즈 11 이전에 있었지만 지금은 활성 뷰포트마다 별도의 설정값이 있습니다. OPEN은 DXF™ 파일에서 읽어들일 때 이 변수를 사용합니다. *ACTIVE 항목이 포함된 VPORT 기호 테이블이 제공된 경우(릴리즈 11 이후에서 작성된 모든 DXF 파일에 대해서도 마찬가지인 것처럼), VPORT 테이블 항목의 값이 이런 헤더 변수의 값을 재지정합니다.

개정된 VPORT 헤더 변수
변수 | 그룹 코드 | 설명
$FASTZOOM | 70 | 0이 아닌 경우 신속 줌이 작동됨
$GRIDMODE | 70 | 0이 아닌 경우, 모눈 모드를 켬
$GRIDUNIT | 10, 20 | 모눈 X 및 Y 간격
$SNAPANG | 50 | 스냅 모눈 회전 각도
$SNAPBASE | 10, 20 | 스냅/모눈 기준점(UCS)
$SNAPISOPAIR | 70 | 등각투영 평면: 0 = 왼쪽, 1 = 맨 위, 2 = 오른쪽
$SNAPMODE | 70 | 0이 아닌 경우, 스냅 모드를 켬
$SNAPSTYLE | 70 | 스냅 스타일: 0 = 표준, 1 = 등각투영
$SNAPUNIT | 10, 20 | 스냅 모눈 X 및 Y 간격
$VIEWCTR | 10, 20 | 화면 상에서 현재 뷰의 XY 중심
$VIEWDIR | 10, 20, 30 | 관측 방향(WCS에서의 대상으로부터의 방향)
$VIEWSIZE | 40 | 뷰의 높이


날짜/시간 변수에 대한 특별 처리

개정된 VPORT 헤더 변수
HEADER 섹션 그룹 코드
CLASSES 섹션
DXF 참조서 > HEADER 섹션 > HEADER 섹션 그룹 코드 >
날짜/시간 변수에 대한 특별 처리

CDATE 및 DATE 시스템 변수는 현재 날짜 및 시간에 접근할 수 있도록 합니다. TDCREATE, TDINDWG, TDUPDATE 및 TDUSRTIMER 시스템 변수(그리고 $TDCREATE, $TDUCREATE, $TDUPDATE 및 $TDUUPDATE DXF 헤더 변수)는 현재 도면과 연관된 날짜 및 시간에 접근할 수 있도록 합니다. 변수 값은 아래에 설명되어 있는 것 같이 특별한 의미를 가진 실수로 표현됩니다.

DATE는 율리우스력의 날짜와 하루의 단편 시간으로 표현된 실수 형식의 현재 날짜와 시간입니다.

<율리우스력 날짜>.<하루의 단편 시간>

예를 들어, GMT 1999년 12월 31일 오후 9시 58분 35초를 나타내는 DATE 변수 값은 다음과 같습니다.

2451544.91568287

시간과 날짜는 시스템에서 변수를 읽을 때의 컴퓨터 시계에 의해 결정됩니다. 하루의 단편 시간으로 표현된 시간과 DATE에서 반환한 시간은 시간차를 계산하기 위해 정확히 감산되기도 합니다. DATE에서 반환된 값으로부터 자정 이후의 초 수를 추출하려면 다음과 같은 AutoLISP 표현식을 사용합니다.

(setq s (getvar "DATE"))
(setq seconds (* 86400.0 (- s (fix s))))

시스템 시계가 UTC/Zulu(그리니치 표준시)로 설정된 경우 DATE는 실제 율리우스력 날짜만 반환하므로 주의해야 합니다. TDCREATE 및 TDUPDATE는 DATE와 동일한 형식이지만 그 값은 현재 도면의 작성 시간 및 최종 업데이트 시간을 나타냅니다.

TDINDWG 및 TDUSRTIMER(그리고 $TDINDWG 및 $TDUSRTIMER DXF 헤더 변수)는 DATE의 형식과 비슷한 형식을 사용하지만 그 값은 다음에서와 같이 경과 시간을 나타냅니다.

<날짜 수>.<날짜 분수>

CDATE는 달력 및 시계 형식으로 표현된 현재 날짜와 시간입니다. 값은 다음과 같은 형식을 사용하는 실수로 반환됩니다.

YYYYMMDD.HHMMSShsec

이 경우,

YYYY = 연도

MM = 월(01~12)

DD = 일(01~31)

HH = 시(00~23)

MM = 분(00~59)

SS = 초(00~59)

hsec = 100분의 1초(00~99)

예를 들어, 현재 날짜가 2005년 12월 31일이고 시간이 오후 9시 58분 35.75초인 경우 CDATE는 다음 값을 반환합니다.

20051231.21583575

CDATE 값을 사용하여 이후 값과 이전 값을 비교할 수는 있지만 그 값을 빼는 것은 무의미한 수를 생성하는 것임에 유의하십시오.


CLASSES 섹션

날짜/시간 변수에 대한 특별 처리
CLASSES 섹션 그룹 코드
DXF 참조서 >
CLASSES 섹션

이 장에서 설명한 그룹 코드는 DXF™ 파일에서만 찾을 수 있습니다. CLASSES 섹션에는 응용프로그램 정의 클래스의 복제가 데이터베이스의 BLOCKS, ENTITIES 및 OBJECTS 섹션에서 나타나는 응용프로그램 정의 클래스에 대한 정보가 들어 있습니다. 클래스 정의는 클래스 계층 구조에서 영구히 고정된 것으로 가정합니다. 모든 필드가 필요합니다.

이 단원의 항목

  • CLASSES 섹션 그룹 코드


CLASSES 섹션 그룹 코드

CLASSES 섹션
CLASSES 섹션
기본 클래스 값
DXF 참조서 > CLASSES 섹션 >
CLASSES 섹션 그룹 코드

CLASSES 섹션의 각 항목에는 다음 테이블에 설명되어 있는 그룹이 포함되어 있습니다.

CLASSES 섹션 그룹 코드
그룹 코드 | 설명
0 | 레코드 유형(CLASS). CLASS 레코드의 시작을 식별합니다.
1 | 클래스 DXF 레코드 이름; 항상 고유함
2 | C++ 클래스 이름. 객체 클래스 동작을 정의하는 소프트웨어와 함께 결합하는 데 사용되며 항상 고유함
3 | 응용프로그램 이름. 본 섹션에 나열된 클래스 정의가 현재 로드되어 있을 경우, 경고 상자에 표시됨
90 | 프록시 사용 가능성 플래그. 프록시로서의 객체 사용 가능성을 나타내는 비트 코드화된 값: 0 = 허용된 작업 없음(0) 1 = 지우기 허용(0x1) 2 = 변환 허용(0x2) 4 = 색상 변경 허용(0x4) 8 = 도면층 변경 허용(0x8) 16 = 선종류 변경 허용(0x10) 32 = 선종류 축척 변경 허용(0x20) 64 = 가시성 변경 허용(0x40) 128 =복제 허용(0x80) 256 =선가중치 변경 허용(0x100) 512 = 플롯 스타일 이름 변경 허용(0x200) 895 =복제를 제외한 모든 작업 허용(0x37F) 1023 = 모든 작업 허용(0x3FF) 1024 = 프록시 경고 대화상자 작동 불가능(0x400) 32768= R13 형식 프록시(0x8000)
91 | 사용자 클래스에 대한 복제 개수
280 | Was-a-proxy 플래그. 이 DXF 파일이 작성될 때 클래스가 로드되면 1로 설정하고 그렇지 않으면 0으로 설정합니다.
281 | Is-an-entity 플래그. 클래스가 AcDbEntity 클래스에서 파생되어 BLOCKS 또는 ENTITIES 섹션에 상주할 수 있으면 1로 설정합니다. 0으로 설정되면, 복제는 OBJECTS 섹션에서만 표시됩니다.

이 단원의 항목

  • 기본 클래스 값


기본 클래스 값

CLASSES 섹션 그룹 코드
CLASSES 섹션 그룹 코드
TABLES 섹션
DXF 참조서 > CLASSES 섹션 > CLASSES 섹션 그룹 코드 >
기본 클래스 값

AutoCAD®는 다음 테이블에 나열된 클래스를 등록합니다. (이 테이블은 DXF 파일에서 발견된 클래스에 대한 완전한 리스트가 아닐 수도 있습니다. 테이블의 내용은 현재 AutoCAD에서 사용되는 응용프로그램에 따라 다릅니다.)

기본 클래스 값
DXF 레코드 이름 코드 1 | C++ 클래스 이름 코드 2 | 코드 90 | 코드 280 | 코드 281
ACDBDICTIONARYWDFLT | AcDbDictionaryWithDefault | 0 | 0 | 0
ACDBPLACEHOLDER | AcDbPlaceHolder | 0 | 0 | 0
ARCALIGNEDTEXT | AcDbArcAlignedText | 0 | 0 | 1
DICTIONARYVAR | AcDbDictionaryVar | 0 | 0 | 0
HATCH | AcDbHatch | 0 | 0 | 1
IDBUFFER | AcDbIdBuffer | 0 | 0 | 0
IMAGE | AcDbRasterImage | 127 | 0 | 1
IMAGEDEF | AcDbRasterImageDef | 0 | 0 | 0
IMAGEDEF_REACTOR | AcDbRasterImageDefReactor | 1 | 0 | 0
LAYER_INDEX | AcDbLayerIndex | 0 | 0 | 0
LAYOUT | AcDbLayout | 0 | 0 | 0
LWPOLYLINE | AcDbPolyline | 0 | 0 | 1
OBJECT_PTR | CAseDLPNTableRecord | 1 | 0 | 0
OLE2FRAME | AcDbOle2Frame | 0 | 0 | 1
PLOTSETTINGS | AcDbPlotSettings | 0 | 0 | 0
RASTERVARIABLES | AcDbRasterVariables | 0 | 0 | 0
RTEXT | RText | 0 | 0 | 1
SORTENTSTABLE | AcDbSortentsTable | 0 | 0 | 0
SPATIAL_INDEX | AcDbSpatialIndex | 0 | 0 | 0
SPATIAL_FILTER | AcDbSpatialFilter | 0 | 0 | 0
WIPEOUT | AcDbWipeout | 127 | 0 | 1
WIPEOUTVARIABLES | AcDbWipeoutVariables | 0 | 0 | 0


TABLES 섹션

기본 클래스 값
기호 테이블 그룹 코드
DXF 참조서 >
TABLES 섹션

이 장에서 설명한 그룹 코드는 DXF™ 파일에 있으며 응용프로그램에서 사용됩니다. TABLES 섹션에는 몇 개의 테이블이 있으며 각 테이블에는 다양한 개수의 항목이 들어 있습니다. 이러한 코드는 도면요소 정의 리스트에서 AutoLISP® 및 ObjectARX® 응용프로그램에 의해 사용되기도 합니다.

이 단원의 항목

  • 기호 테이블 그룹 코드
  • 공용 기호 테이블 그룹 코드
  • APPID
  • BLOCK_RECORD
  • DIMSTYLE
  • LAYER
  • LTYPE
  • STYLE
  • UCS
  • VIEW
  • VPORT


기호 테이블 그룹 코드

TABLES 섹션
TABLES 섹션
공용 기호 테이블 그룹 코드
DXF 참조서 > TABLES 섹션 >
기호 테이블 그룹 코드

테이블의 순서는 변경할 수 있지만 LTYPE 테이블은 항상 LAYER 테이블 앞에 있어야 합니다. 각 테이블은 TABLE이라는 레이블이 붙어 있는 0 그룹 코드로 시작됩니다. 그 다음에는 특정 테이블(APPID, DIMSTYLE, LAYER, LTYPE, STYLE, UCS, VIEW, VPORT 또는 BLOCK_RECORD)을 식별하는 2 그룹 코드, 5 그룹 코드(핸들), 100 그룹 코드(AcDbSymbolTable 하위 클래스 표식기) 및 다음에 올 수 있는 테이블 도면요소의 최대 개수를 지정하는 70 그룹 코드가 차례로 표시됩니다. 테이블 이름은 대문자로 출력됩니다. DIMSTYLE 핸들은 5 그룹 코드가 아닌 105 그룹 코드입니다.

도면의 테이블에는 삭제된 항목을 포함할 수 있지만 DXF 파일에는 기입할 수 없습니다. 따라서, 70 그룹 코드가 나타낸 개수보다 더 적은 수의 테이블 항목이 테이블 헤더 다음에 올 수 있으므로 70 그룹 코드의 개수를 테이블에서 읽을 색인으로 사용해서는 안 됩니다. 이 그룹 코드가 제공되므로, DXF 파일을 읽는 프로그램은 테이블 도면요소 모두를 보유할 수 있을만큼 충분히 큰 배열을 할당할 수 있습니다.

각 테이블의 헤더 다음에는 테이블 항목이 옵니다. 테이블 항목은 각각 항목 유형(LTYPE 또는 LAYER 등의 테이블 이름과 같음)을 식별하는 0 그룹, 테이블 항목의 이름을 제공하는 2 그룹, 테이블 항목과 연관된 플래그를 지정하는 70 그룹(다음의 테이블 각각에 대해 정의됨) 및 테이블 항목의 값을 제공하는 그 밖의 그룹 등으로 구성되어 있습니다. 각 테이블의 마지막은 ENDTAB 값을 가진 0 그룹으로 표시됩니다.

여러 기호 테이블들이나 기호 테이블의 레코드들은 모두 데이터베이스 객체에 해당합니다. 이것은 AutoCAD® 내의 모든 일반적인 사용법에 있어서, 최소한 기호 테이블 레코드 객체와 기호 테이블 객체 모두에 대해 핸들이 2 그룹 코드 다음의 위치에 제공됨을 의미합니다.

DIMSTYLE 테이블은 그룹 코드 5의 이전 사용법으로 인해 핸들 코드 105를 갖는, 시스템에서 유일한 레코드 유형입니다. 프로그래머들은 이 그룹 코드가 DIMSTYLE 테이블 섹션 환경에 포함되어 있지 않다면 대체로 이런 예외점에 대해 염려하지 않습니다. 이 DIMSTYLE 테이블은 이런 예외의 경우가 발생하는 유일한 작업 환경입니다.


공용 기호 테이블 그룹 코드

기호 테이블 그룹 코드
TABLES 섹션
기호 테이블 항목의 일반 그룹 코드
DXF 참조서 > TABLES 섹션 >
공용 기호 테이블 그룹 코드

다음 테이블에는 모든 기호 테이블에 적용되는 그룹 코드가 표시되어 있습니다. 이 테이블에서 사용된 축약어 및 형식에 대한 정보는 본 참조서의 형식화 규칙를 참고하십시오.

모든 기호 테이블에 적용되는 그룹 코드
그룹 코드 | 설명
-1 | APP: 도면요소 이름(도면이 열릴 때마다 변경됨)
0 | 객체 유형(TABLE)
2 | 테이블 이름
5 | 핸들
102 | “{ACAD_XDICTIONARY”는 확장 사전 그룹의 시작을 나타냅니다. 이 그룹은 영구 리액터가 이 객체에 부착되어 있는 경우에만 존재합니다(선택 사항).
360 | 소유자 사전에 대한 하드 소유자 ID/핸들(선택 사항)
102 | 그룹의 끝, “}”(선택 사항)
330 | 소유자 객체에 대한 소프트 포인터 ID/핸들
100 | 하위 클래스 표식기(AcDbAttributeTable)
70 | 테이블 항목의 최대 개수

이 단원의 항목

  • 기호 테이블 항목의 일반 그룹 코드


기호 테이블 항목의 일반 그룹 코드

공용 기호 테이블 그룹 코드
공용 기호 테이블 그룹 코드
APPID
DXF 참조서 > TABLES 섹션 > 공용 기호 테이블 그룹 코드 >
기호 테이블 항목의 일반 그룹 코드

다음 테이블에는 모든 기호 테이블 항목에 적용되는 그룹 코드가 표시되어 있습니다. 특정 도면요소와 연관된 코드가 나열되어 있는 도면요소 유형별 그룹 코드 테이블을 참조할 경우, 여기에 표시되어 있는 코드도 제공된다는 사실을 기억하십시오. 이 테이블에서 사용된 축약어 및 형식에 대한 정보는 본 참조서의 형식화 규칙를 참고하십시오.

모든 기호 테이블 항목에 적용되는 그룹 코드
그룹 코드 | 설명
-1 | APP: 도면요소 이름(도면이 열릴 때마다 변경됨)
0 | 도면요소 유형(테이블 이름)
5 | 핸들(DIMSTYLE을 제외한 모든 경우)
105 | 핸들(DIMSTYLE 테이블의 경우만)
102 | 응용프로그램 정의 그룹 시작 “{응용프로그램 이름”. 예를 들어, “{ACAD_REACTORS”는 AutoCAD 불변의 리액터 그룹의 시작을 나타냅니다(선택 사항).
응용프로그램 정의 코드 | 102 그룹 내의 코드와 값은 응용프로그램에서 정의됩니다(선택 사항).
102 | 그룹의 끝, “}”(선택 사항)
102 | “{ACAD_REACTORS”는 AutoCAD 불변의 리액터 그룹의 시작을 나타냅니다. 이 그룹은 영구 리액터가 이 객체에 부착되어 있는 경우에만 존재합니다(선택 사항).
330 | 소유자 사전에 대한 소프트 포인터 ID/핸들(선택 사항)
102 | 그룹의 끝, “}”(선택 사항)
102 | “{ACAD_XDICTIONARY”는 확장 사전 그룹의 시작을 나타냅니다. 이 그룹은 영구 리액터가 이 객체에 부착되어 있는 경우에만 존재합니다(선택 사항).
360 | 소유자 사전에 대한 하드 소유자 ID/핸들(선택 사항)
102 | 그룹의 끝, “}”(선택 사항)
330 | 소유자 객체에 대한 소프트 포인터 ID/핸들
100 | 하위 클래스 표식기(AcDbSymbolTableRecord)


APPID

기호 테이블 항목의 일반 그룹 코드
TABLES 섹션
BLOCK_RECORD
DXF 참조서 > TABLES 섹션 >
APPID

다음 그룹 코드는 APPID 기호 테이블 항목에 적용됩니다. 여기에 설명되어 있는 그룹 코드 이외의 내용은 기호 테이블 항목의 일반 그룹 코드를 참고하십시오. 이 테이블에서 사용된 축약어 및 형식에 대한 정보는 본 참조서의 형식화 규칙를 참고하십시오.

APPID 그룹 코드
그룹 코드 | 설명
100 | 하위 클래스 표식기(AcDbRegAppTableRecord)
2 | 사용자 제공(또는 응용프로그램 제공) 응용프로그램 이름(확장된 데이터의 경우). 이런 테이블 항목은 등록된 모든 응용프로그램의 이름 세트를 관리합니다.
70 | 표준 플래그 값(비트 코드화 값): 1 = 설정될 경우 SAVEASR12가 수행될 때 이 APPID와 연관된 xdata는 작성되지 않습니다. 16 = 설정될 경우 테이블 항목은 외부 참조에 외부 종속됨 32 = 이 비트와 비트 16이 설정될 경우 외부 종속 외부 참조가 성공적으로 해석된 것임 64 = 설정될 경우 테이블 항목은 도면이 마지막으로 편집된 싯점에 도면에서 최소 한 개 이상의 도면요소에 의해 참조됩니다. (이 플래그는 AutoCAD 명령에 장점을 제공합니다. 이는 DXF 파일을 읽는 대부분의 프로그램에서 무시할 수 있으며 DXF 파일을 작성하는 프로그램에서 설정하지 않아도 됩니다.)


BLOCK_RECORD

APPID
TABLES 섹션
DIMSTYLE
DXF 참조서 > TABLES 섹션 >
BLOCK_RECORD

다음 그룹 코드는 BLOCK_RECORD 기호 테이블 항목에 적용됩니다. 여기에 설명되어 있는 그룹 코드 이외의 내용은 기호 테이블 항목의 일반 그룹 코드를 참고하십시오. 이 테이블에서 사용된 축약어 및 형식에 대한 정보는 본 참조서의 형식화 규칙를 참고하십시오.

BLOCK_RECORD 그룹 코드
그룹 코드 | 설명
100 | 하위 클래스 표식기(AcDbBlockTableRecord)
2 | 블록 이름
340 | 연관된 LAYOUT 객체에 대한 하드 포인터 ID/핸들
70 | 블록 삽입 단위
280 | 블록 분해성
281 | 블록 확장성
310 | DXF: 비트맵 미리 보기를 위한 이진 데이터(선택 사항)
1001 | 확장 데이터 응용프로그램 이름 “ACAD”(선택 사항)
1000 | 확장 데이터 문자열 데이터 “DesignCenter 데이터”(선택 사항)
1002 | 확장 데이터 시작 “{“(선택 사항)
1070 | Autodesk Design Center 버전 번호
1070 | 삽입 단위: 0 = 단위 없음, 1 =인치, 2 = 피트, 3 = 마일, 4 = 밀리미터, 5 = 센티미터, 6 =미터, 7 = 킬로미터, 8 = 마이크로인치, 9 = 마일, 10 = 야드, 11 = 옹스트롱, 12 = 나노미터, 13 = 마이크론, 14 = 데시미터, 15 = 데카미터, 16 = 헥토미터, 17 = 기가미터, 18 = 천문학 단위, 19 = 광년, 20 = 파세크
1002 | End xdata “}“


DIMSTYLE

BLOCK_RECORD
TABLES 섹션
LAYER
DXF 참조서 > TABLES 섹션 >
DIMSTYLE

다음 그룹 코드는 DIMSTYLE 기호 테이블 항목에 적용됩니다. DIMSTYLE 시스템 변수는 명령 참조서의 “시스템 변수”에 설명되어 있습니다. 여기에 설명되어 있는 그룹 코드 이외의 내용은 기호 테이블 항목의 일반 그룹 코드를 참고하십시오. 이 테이블에서 사용된 축약어 및 형식에 대한 정보는 본 참조서의 형식화 규칙를 참고하십시오.

DIMSTYLE 그룹 코드
그룹 코드 | 설명
100 | 하위 클래스 표식기(AcDbDimStyleTableRecord)
2 | 치수 스타일 이름
70 | 표준 플래그 값(비트 코드화 값): 16 = 설정될 경우 테이블 항목은 외부 참조에 외부 종속됨 32 = 이 비트와 비트 16이 설정될 경우 외부 종속 외부 참조가 성공적으로 해석된 것임 64 = 설정될 경우 테이블 항목은 도면이 마지막으로 편집된 싯점에 도면에서 최소 한 개 이상의 도면요소에 의해 참조됩니다. (이 플래그는 AutoCAD 명령에 장점을 제공합니다. 이는 DXF 파일을 읽는 대부분의 프로그램에서 무시할 수 있으며 DXF 파일을 작성하는 프로그램에서 설정하지 않아도 됩니다.)
3 | DIMPOST
4 | DIMAPOST
5 | DIMBLK(구식임, 지금은 객체 ID임)
6 | DIMBLK1(구식임, 지금은 객체 ID임)
7 | DIMBLK2(구식임, 지금은 객체 ID임)
40 | DIMSCALE.
41 | DIMASZ
42 | DIMEXO
43 | DIMDLI
44 | DIMEXE
45 | DIMRND
46 | DIMDLE
47 | DIMTP
48 | DIMTM
140 | DIMTXT
141 | DIMCEN
142 | DIMTSZ
143 | DIMALTF
144 | DIMLFAC
145 | DIMTVP
146 | DIMTFAC
147 | DIMGAP
148 | DIMALTRND
71 | DIMTOL
72 | DIMLIM
73 | DIMTIH
74 | DIMTOH
75 | DIMSE1
76 | DIMSE2
77 | DIMTAD
78 | DIMZIN
79 | DIMAZIN
170 | DIMALT
171 | DIMALTD
172 | DIMTOFL
173 | DIMSAH
174 | DIMTIX
175 | DIMSOXD
176 | DIMCLRD
177 | DIMCLRE
178 | DIMCLRT
179 | DIMADEC
270 | DIMUNIT(구식임, 지금은 DIMLUNIT 및 DIMFRAC을 사용함)
271 | DIMDEC
272 | DIMTDEC
273 | DIMALTU
274 | DIMALTTD
275 | DIMAUNIT
276 | DIMFRAC
277 | DIMLUNIT
278 | DIMDSEP
279 | DIMTMOVE
280 | DIMJUST
281 | DIMSD1
282 | DIMSD2
283 | DIMTOLJ
284 | DIMTZIN
285 | DIMALTZ
286 | DIMALTTZ
287 | DIMFIT(구식임, 지금은 DIMATFIT 및 DIMTMOVE를 사용함)
288 | DIMUPT
289 | DIMATFIT
340 | DIMTXSTY(참조된 STYLE의 핸들)
341 | DIMLDRBLK(참조된 BLOCK의 핸들)
342 | DIMBLK(참조된 BLOCK의 핸들)
343 | DIMBLK1(참조된 BLOCK의 핸들)
344 | DIMBLK2(참조된 BLOCK의 핸들)
371 | DIMLWD(선가중치 enum 값)
372 | DIMLWE(선가중치 enum 값)


LAYER

DIMSTYLE
TABLES 섹션
LTYPE
DXF 참조서 > TABLES 섹션 >
LAYER

다음 그룹 코드는 LAYER 기호 테이블 항목에 적용됩니다. 여기에 설명되어 있는 그룹 코드 이외의 내용은 기호 테이블 항목의 일반 그룹 코드를 참고하십시오. 이 테이블에서 사용된 축약어 및 형식에 대한 정보는 본 참조서의 형식화 규칙를 참고하십시오.

LAYER 그룹 코드
그룹 코드 | 설명
100 | 하위 클래스 표식기(AcDbLayerTableRecord)
2 | 도면층 이름
70 | 표준 플래그(비트 코드화된 값): 1 = 도면층이 동결되거나 동결 해제됩니다. 2 = 도면층은 새 뷰포트에서 기본적으로 동결됩니다. 4 = 도면층이 잠깁니다. 16 = 설정된 경우, 테이블 항목에 대한 외부 참조가 가능합니다. 32= 이 비트와 비트 16이 설정된 경우, 외부 참조가 성공적으로 이루어졌음을 나타냅니다. 64 = 설정된 경우, 마지막으로 수정된 도면의 하나 이상의 도면요소에 의해 테이블 항목이 참조됩니다. (이 플래그는AutoCAD 명령에 장점을 제공합니다. 이는 DXF 파일을 읽는 대부분의 프로그램에서 무시할 수 있으며 DXF 파일을 작성하는 프로그램에서 설정하지 않아도 됩니다.)
62 | 색상 번호(음의 값이면 도면층이 꺼짐)
6 | 선종류 이름
290 | 플로팅 플래그. 0으로 설정되면 이 도면층을 플롯하지 않습니다.
370 | 선가중치 enum 값
390 | PlotStyleName 객체의 하드 포인터 ID/핸들
347 | 재료 객체에 대한 하드 포인터 ID/핸들

외부 참조 종속 도면층은 SAVEAS의 출력입니다. 이러한 도면층에 대해 DXF 파일의 연관된 선종류 이름은 항상 CONTINUOUS입니다.


LTYPE

LAYER
TABLES 섹션
STYLE
DXF 참조서 > TABLES 섹션 >
LTYPE

다음 그룹 코드는 LTYPE 기호 테이블 항목에 적용됩니다. 여기에 설명되어 있는 그룹 코드 이외의 내용은 기호 테이블 항목의 일반 그룹 코드를 참고하십시오. 이 테이블에서 사용된 축약어 및 형식에 대한 정보는 본 참조서의 형식화 규칙를 참고하십시오.

LTYPE 그룹 코드
그룹 코드 | 설명
100 | 하위 클래스 표식기(AcDbLinetypeTableRecord)
2 | 선종류 이름
70 | 표준 플래그 값(비트 코드화 값): 16 = 설정될 경우 테이블 항목은 외부 참조에 외부 종속됨 32 = 이 비트와 비트 16이 설정될 경우 외부 종속 외부 참조가 성공적으로 해석된 것임 64 = 설정될 경우 테이블 항목은 도면이 마지막으로 편집된 싯점에 도면에서 최소 한 개 이상의 도면요소에 의해 참조됩니다. (이 플래그는 AutoCAD 명령에 장점을 제공합니다. 이는 DXF 파일을 읽는 대부분의 프로그램에서 무시할 수 있으며 DXF 파일을 작성하는 프로그램에서 설정하지 않아도 됩니다.)
3 | 선종류에 대한 설명문
72 | 정렬 코드로서, 값은 항상 A의 ASCII 코드값인 65입니다.
73 | 선종류 요소의 개수
40 | 전체 패턴 길이
49 | 대시, 도트 또는 빈칸 길이(요소당 한 항목)
74 | 복합 선종류 요소 유형(요소당 하나) 기본값은 0(포함된 쉐이프/문자가 없음)입니다. 다음 코드는 비트 값입니다. 1 = 설정된 경우 코드 50은 절대 회전을 지정하며, 설정되지 않은 경우 코드 50은 상대 회전을 지정합니다. 2 = 포함된 요소는 문자열입니다. 4 = 포함된 요소는 쉐이프입니다.
75 | 코드 74가 포함된 쉐이프를 지정하는 경우, 쉐이프 번호(요소당 하나) 코드 74가 포함된 문자열을 지정하는 경우, 이 값은 0으로 설정됩니다. 코드 74가 0으로 설정된 경우, 코드 75는 생략됩니다.
340 | STYLE 객체에 대한 포인터(코드 74 > 0인 경우, 요소당 하나)
46 | S = 축척값(선택 사항). 여러 항목이 있을 수 있습니다.
50 | 포함된 쉐이프 또는 문자에 대한 라디안 단위의 R = (상대적) 또는 A = (절대적) 회전값. 코드 74가 포함된 쉐이프 또는 문자열을 지정할 경우, 요소당 하나의 값을 갖습니다.
44 | X = X 간격띄우기 값(선택 사항). 여러 항목이 있을 수 있습니다.
45 | Y = Y 간격띄우기 값(선택 사항). 여러 항목이 있을 수 있습니다.
9 | 문자열(코드 74의 값이 2인 경우, 요소당 하나)

tblsearch 또는 tblnext 함수는 그룹 코드 74, 75, 340, 46, 50, 44, 45 및 9를 반환하지 않습니다. 응용프로그램에서 이 값들을 검색하려면 tblobjname을 사용해야 합니다.


STYLE

LTYPE
TABLES 섹션
UCS
DXF 참조서 > TABLES 섹션 >
STYLE

다음 그룹 코드는 STYLE 기호 테이블 항목에 적용됩니다. 여기에 설명되어 있는 그룹 코드 이외의 내용은 기호 테이블 항목의 일반 그룹 코드를 참고하십시오. 이 테이블에서 사용된 축약어 및 형식에 대한 정보는 본 참조서의 형식화 규칙를 참고하십시오.

STYLE 그룹 코드
그룹 코드 | 설명
100 | 하위 클래스 표식기(AcDbTextStyleTableRecord)
2 | 유형 이름
70 | 표준 플래그 값(비트 코드화 값): 1 = 설정될 경우 이 항목은 쉐이프를 설명합니다. 4 = 세로 문자 16 = 설정될 경우 테이블 항목은 외부 참조에 외부 종속됨 32 = 이 비트와 비트 16이 설정될 경우 외부 종속 외부 참조가 성공적으로 해석된 것임 64 = 설정될 경우 테이블 항목은 도면이 마지막으로 편집된 싯점에 도면에서 최소 한 개 이상의 도면요소에 의해 참조됩니다. (이 플래그는 AutoCAD 명령에 장점을 제공합니다. 이는 DXF 파일을 읽는 대부분의 프로그램에서 무시할 수 있으며 DXF 파일을 작성하는 프로그램에서 설정하지 않아도 됩니다.)
40 | 고정된 문자 높이. 고정되지 않은 경우는 0
41 | 폭 비율
50 | 기울기 각도
71 | 문자 생성 플래그: 2 = 역순서의 문자(X 방향으로 대칭됨) 4 = 위아래가 뒤집힌 문자(Y 방향으로 대칭됨)
42 | 마지막으로 사용된 높이
3 | 1차 글꼴 파일 이름
4 | 큰 글꼴 파일 이름, 없으면 비어 있음

STYLE 테이블 항목은 쉐이프 파일 LOAD 명령 요청을 기록하는 데도 사용됩니다. 이 경우, 첫 번째 비트(1)는 70 그룹 플래그에서 설정되며 3 그룹(쉐이프 파일 이름)만 의미가 있습니다(그래도 다른 그룹들도 모두 출력됨).


UCS

STYLE
TABLES 섹션
VIEW
DXF 참조서 > TABLES 섹션 >
UCS

다음 그룹 코드는 UCS 기호 테이블 항목에 적용됩니다. 여기에 설명되어 있는 그룹 코드 이외의 내용은 기호 테이블 항목의 일반 그룹 코드를 참고하십시오. 이 테이블에서 사용된 축약어 및 형식에 대한 정보는 본 참조서의 형식화 규칙를 참고하십시오.

UCS 그룹 코드
그룹 코드 | 설명
100 | 하위 클래스 표식기(AcDbUCSTableRecord)
2 | UCS 이름
70 | 표준 플래그 값(비트 코드화 값): 16 = 설정될 경우 테이블 항목은 외부 참조에 외부 종속됨 32 = 이 비트와 비트 16이 설정될 경우 외부 종속 외부 참조가 성공적으로 해석된 것임 64 = 설정될 경우 테이블 항목은 도면이 마지막으로 편집된 싯점에 도면에서 최소 한 개 이상의 도면요소에 의해 참조됩니다. (이 플래그는 AutoCAD 명령에 장점을 제공합니다. 이는 DXF 파일을 읽는 대부분의 프로그램에서 무시할 수 있으며 DXF 파일을 작성하는 프로그램에서 설정하지 않아도 됩니다.)
10 | 원점(WCS) DXF: X 값, APP: 3D 점
20, 30 | DXF: 원점의 Y 및 Z 값(WCS)
11 | X축 방향(WCS) DXF: X값, APP: 3D 벡터
21, 31 | DXF: X축 방향의 Y 및 Z 값(WCS)
12 | Y축 방향(WCS) DXF: X 값, APP: 3D 벡터
22, 32 | DXF: Y축 방향의 Y 및 Z 값(WCS)
79 | 항상 0
146 | 고도
346 | 직교인 경우, 기준 UCS의 ID/핸들 79 코드가 0인 경우, 이 코드는 제공되지 않습니다. 이 코드가 제공되지 않고 79 코드가 0이 아니면 WORLD를 기준 UCS로 간주합니다.
71 | 직교 유형(선택 사항, 항상 13, 23, 33 코드와 함께 쌍으로 표시됨): 1 = 맨 위, 2 =맨 아래 3 = 앞, 4 = 뒤 5 = 왼쪽, 6 = 오른쪽
13 | UCS에 상대적인 직교 유형에 대한 원점 DXF: 원점의 X 값, APP: 3D 점
23, 33 | DXF: 원점의 Y 및 Z 값

각각의 71/13,23,33 쌍은 이 UCS에 상대적인 특정 직교 유형에 대한 UCS 원점을 정의합니다. 예를 들어, 다음의 쌍이 있는 경우 UCSBASE가 이 UCS로 설정될 때 UCS/LEFT 명령을 호출하면 새 UCS 원점은 (1,2,3)이 됩니다.

71: 5
13: 1.0
23: 2.0
33: 3.0

이 쌍이 없는 경우 UCS/LEFT 명령을 호출하면 새 UCS 원점은 이 UCS의 원점으로 설정됩니다.


VIEW

UCS
TABLES 섹션
VPORT
DXF 참조서 > TABLES 섹션 >
VIEW

다음 그룹 코드는 VIEW 기호 테이블 항목에 적용됩니다. 여기에 설명되어 있는 그룹 코드 이외의 내용은 기호 테이블 항목의 일반 그룹 코드를 참고하십시오. 이 테이블에서 사용된 축약어 및 형식에 대한 정보는 본 참조서의 형식화 규칙를 참고하십시오.

VIEW 그룹 코드
그룹 코드 | 설명
100 | 하위 클래스 표식기(AcDbViewTableRecord)
2 | 뷰의 이름
70 | 표준 플래그 값(비트 코드화 값): 1 = 설정될 경우 도면 공간 뷰임 16 = 설정될 경우 테이블 항목은 외부 참조에 외부 종속됨 32 = 이 비트와 비트 16이 설정될 경우 외부 종속 외부 참조가 성공적으로 해석된 것임 64 = 설정될 경우 테이블 항목은 도면이 마지막으로 편집된 싯점에 도면에서 최소 한 개 이상의 도면요소에 의해 참조됩니다. (이 플래그는 AutoCAD 명령에 장점을 제공합니다. 이는 DXF 파일을 읽는 대부분의 프로그램에서 무시될 수 있으며 DXF 파일을 작성하는 프로그램에서 설정되지 않아도 됩니다.)
40 | 뷰 높이(DCS)
10 | 뷰 중심점(DCS) DXF: X 값, APP: 2D 점
20 | DXF: 뷰 중심점의 Y 값(DCS)
41 | 뷰 폭(DCS)
11 | 대상으로부터의 뷰 방향(WCS) DXF: X 값, APP: 3D 벡터
21, 31 | DXF: 대상으로부터 뷰 방향의 Y 및 Z 값(WCS)
12 | 대상점(WCS) DXF: X 값, APP: 3D 점
22, 32 | DXF: 대상점의 Y 및 Z 값(WCS)
42 | 렌즈 길이
43 | 앞면 자르기 평면(대상점으로부터 간격띄우기)
44 | 뒷면 자르기 평면(대상점으로부터 간격띄우기)
50 | 비틀림 각도
71 | 뷰 모드(VIEWMODE 시스템 변수 참고)
281 | 렌더 모드: 0 = 2D 최적화(일반 2D) 1 = 와이어프레임 2 = 은선 3 =단순 음영처리 4 = 구로 음영처리 5 = 와이어프레임으로 단순 음영처리 6 = 와이어프레임으로 구로 음영처리 2D 최적화 이외의 모든 렌더링 모드는 새로운 3D 그래픽 파이프라인을 사용합니다. 이들 값은 바로 SHADEMODE 명령 및 AcDbAbstractViewTableRecord::RenderMode enum에 해당합니다.
72 | 이 뷰와 연관된 UCS가 있는 경우에는 1이며 아니면 0입니다.
73 | 카메라가 플롯 가능할 경우 1입니다.
332 | 배경 객체에 대한 소프트 포인터 ID/핸들(선택 사항)
334 | 활성 단면 객체에 대한 소프트 포인터 ID/핸들(선택 사항)
348 | 뷰 스타일 객체에 대한 소프트 포인터 ID/핸들(선택 사항)

다음 코드는 코드 72가 1로 설정된 경우에만 표시되며 이 뷰와 연관된 UCS를 정의합니다. 이 UCS는 이 뷰가 복원될 때마다 현재 UCS가 됩니다(코드 72가 0이면, UCS는 변경되지 않음).

UCS 그룹 코드가 있는 VIEW
그룹 코드 | 설명
110 | UCS 원점(코드 72가 1로 설정되어 있는 경우에만 표시됨) DXF: X 값, APP: 3D 점
120, 130 | DXF: UCS 원점의 Y 및 Z 값
111 | UCS X축(코드 72가 1로 설정되어 있는 경우에만 표시됨) DXF: X 값, APP: 3D 벡터
121, 131 | DXF: UCS X축의 Y 및 Z 값
112 | UCS Y축(코드 72가 1로 설정되어 있는 경우에만 표시됨) DXF: X 값, APP: 3D 벡터
122, 132 | DXF: UCS Y축의 Y 및 Z 값
79 | UCS의 직교 유형(코드 72가 1로 설정되어 있는 경우에만 표시됨): 0 = UCS는 직교가 아님 1 = 맨 위, 2 = 맨 아래 3 = 앞, 4 = 뒤 5 = 왼쪽, 6 = 오른쪽
146 | UCS 고도(코드 72가 1로 설정되어 있는 경우에만 표시됨)
345 | UCS가 명명된 UCS인 경우, AcDbUCSTableRecord의 ID/핸들. 제공되지 않은 경우, UCS는 명명되지 않습니다(코드 72가 1로 설정되어 있는 경우에만 표시됨).
346 | UCS가 직교인 경우, 기준 UCS의 AcDbUCSTableRecord의 ID/핸들(79 코드는 0이 아님). 제공되지 않고 79 코드가 0이 아닌 경우, 기준 UCS는 WORLD가 됩니다(코드 72가 1로 설정되어 있는 경우에만 표시됨).


VPORT

VIEW
TABLES 섹션
BLOCKS 섹션
DXF 참조서 > TABLES 섹션 >
VPORT

다음 그룹 코드는 VPORT 기호 테이블 항목에 적용됩니다. VPORT 테이블은 고유한 특성을 갖습니다. (다중 뷰포트 구성을 나타내는) 동일한 이름으로 여러 항목을 포함할 수 있습니다 활성 뷰포트 구성에 대한 항목은 모두 *ACTIVE 이름을 갖습니다. 그 항목들 중 첫 번째 항목이 현재 뷰포트를 설명합니다. 여기에 설명되어 있는 그룹 코드 이외의 내용은 기호 테이블 항목의 일반 그룹 코드를 참고하십시오. 이 테이블에서 사용된 축약어 및 형식에 대한 정보는 본 참조서의 형식화 규칙를 참고하십시오.

VPORT 그룹 코드
그룹 코드 | 설명
100 | 하위 클래스 표식기(AcDbViewportTableRecord)
2 | 뷰포트 이름
70 | 표준 플래그 값(비트 코드화 값): 16 = 설정될 경우 테이블 항목은 외부 참조에 외부 종속됨 32 = 이 비트와 비트 16이 설정될 경우 외부 종속 외부 참조가 성공적으로 해석된 것임 64 = 설정될 경우 테이블 항목은 도면이 마지막으로 편집된 싯점에 도면에서 최소 한 개 이상의 도면요소에 의해 참조됩니다. (이 플래그는 AutoCAD 명령에 장점을 제공합니다. 이는 DXF 파일을 읽는 대부분의 프로그램에서 무시될 수 있으며 DXF 파일을 작성하는 프로그램에서 설정되지 않아도 됩니다.)
10 | 뷰포트의 왼쪽 아래 구석 DXF: X 값, APP: 2D 점
20 | DXF: 뷰포트의 왼쪽 아래 구석의 Y 값
11 | 뷰포트의 오른쪽 위 구석 DXF: X 값, APP: 2D 점
21 | DXF: 뷰포트의 오른쪽 위 구석의 Y 값
12 | 뷰 중심점(DCS) DXF: X 값, APP: 2D 점
22 | DXF: 뷰 중심점의 Y 값(DCS)
13 | 스냅 기준점(DCS에서) DXF: X 값, APP: 2D 점
23 | DXF: 스냅 기준점의 Y 값(DCS에서)
14 | 스냅 간격 X 및 Y DXF: X 값, APP: 2D 점
24 | DXF: 스냅 간격 X 및 Y 중 Y 값
15 | 모눈 간격 X 및 Y DXF: X 값, APP: 2D 점
25 | DXF: 모눈 간격 X 및 Y 중 Y 값
16 | 대상점으로부터의 뷰 방향(WCS) DXF: X 값, APP: 3D 점
26, 36 | DXF: 대상점으로부터 뷰 방향의 Y 및 Z 값 (WCS)
17 | 뷰 대상점(WCS) DXF: X 값, APP: 3D 점
27, 37 | DXF: 뷰 대상점의 Y 및 Z 값(WCS)
42 | 렌즈 길이
43 | 앞면 자르기 평면(대상점으로부터 간격띄우기)
44 | 뒷면 자르기 평면(대상점으로부터 간격띄우기)
45 | 뷰 높이
50 | 스냅 회전 각도
51 | 뷰 비틀림 각도
72 | 원 면
331 또는 441 | 동결 도면층 객체에 대한 소프트 또는 하드 포인터 ID/핸들, 동결 도면층마다 반복합니다.
70 | 비트 플래그 및 투시 모드
1 | 플롯 스타일 시트
281 | 렌더 모드: 0 = 2D 최적화(일반 2D) 1 = 와이어프레임 2 = 은선 3 =단순 음영처리 4 = 구로 음영처리 5 = 와이어프레임으로 단순 음영처리 6 = 와이어프레임으로 구로 음영처리 2D 최적화 이외의 모든 렌더링 모드는 새로운 3D 그래픽 파이프라인을 사용합니다. 이들 값은 바로 SHADEMODE 명령 및 AcDbAbstractViewTableRecord::RenderMode enum에 해당합니다.
71 | 뷰 모드(VIEWMODE 시스템 변수 참고)
74 | UCSICON 설정
110 | UCS 원점 DXF: X 값, APP: 3D 점
120, 130 | DXF: UCS 원점의 Y 및 Z 값
111 | UCS X축 DXF: X 값, APP: 3D 벡터
121, 131 | DXF: UCS X축의 Y 및 Z 값
112 | UCS Y축 DXF: X값, APP: 3D 벡터
122, 132 | DXF: UCS Y축의 Y 및 Z 값
345 | UCS가 명명된 UCS인 경우, AcDbUCSTableRecord의 ID/핸들. 제공되지 않은 경우, UCS가 명명되지 않습니다.
346 | UCS가 직교인 경우, 기준 UCS의 AcDbUCSTableRecord의 ID/핸들(79 코드는 0이 아님). 제공되지 않고 79 코드가 0이 아닌 경우, 기준 UCS는 WORLD로 됩니다.
79 | UCS의 직교 유형 0 = UCS는 직교가 아님 1 = 맨 위, 2 = 맨 아래 3 = 앞, 4 = 뒤 5 = 왼쪽, 6 = 오른쪽
146 | 고도
170 | 음영 플롯 설정
61 | 주 모눈선
332 | 배경 객체에 대한 소프트 포인터 ID/핸들(선택 사항)
333 | 음영 플롯 객체에 대한 소프트 포인터 ID/핸들(선택 사항)
348 | 뷰 스타일 객체에 대한 소프트 포인터 ID/핸들(선택 사항)
292 | 기본 조명 켜짐 플래그
282 | 기본 조명 유형 0 = 한 개의 거리 광원 1 = 두 개의 거리 광원
141 | 밝기
142 | 대비
63, 421, 431 | 주변 색상(검은색이 아닐 때만 출력)


BLOCKS 섹션

VPORT
BLOCKS 섹션 그룹 코드
DXF 참조서 >
BLOCKS 섹션

이 장에서 설명한 그룹 코드는 DXF™ 파일에 있으며 응용프로그램에서 사용됩니다. BLOCKS 섹션에는 도면의 각 블록 참조에 대한 항목이 들어 있습니다.

이 단원의 항목

  • BLOCKS 섹션 그룹 코드
  • BLOCK
  • ENDBLK


BLOCKS 섹션 그룹 코드

BLOCKS 섹션
BLOCKS 섹션
BLOCK
DXF 참조서 > BLOCKS 섹션 >
BLOCKS 섹션 그룹 코드

DXF 파일의 BLOCKS 섹션은 HATCH 명령과 연관 치수기입에 의해 생성된 익명 블록을 포함하여 모든 블록 정의를 포함합니다. 각 블록 정의에는 도면에서 블록이 사용될 때 해당 블록을 구성하는 도면요소가 포함됩니다. 이 섹션에 있는 도면요소의 형식은 ENTITIES 섹션의 도면요소 형식과 같습니다. BLOCKS 섹션의 모든 도면요소는 블록 및 endblk 도면요소 사이에 표시됩니다. 블록 및 endblk 도면요소는 BLOCKS 섹션에만 표시됩니다. 블록 정의가 삽입 도면요소를 포함할 수는 있지만 블록 정의는 절대 내포되지 않습니다(즉, block 또는 endblk 도면요소는 절대 다른 block과 endblk 쌍 내에 표시되지 않습니다).

외부 참조는 외부 참조의 경로와 파일 이름을 지정하는 문자열(그룹 코드 1)도 포함한다는 점을 제외하고는 블록 정의와 같이 DXF 파일에 기입됩니다.

블록 테이블 핸들은 임의의 확장 데이터 및 영구 리액터와 함께 각각의 블록 정의에 표시되는데, 이 바로 앞에는 블록 테이블 레코드에 저장된 모든 특정 정보를 포함하는 BLOCK 레코드가 있습니다.


BLOCK

BLOCKS 섹션 그룹 코드
BLOCKS 섹션
ENDBLK
DXF 참조서 > BLOCKS 섹션 >
BLOCK

다음 그룹 코드는 블록 도면요소에 적용됩니다. 이 테이블에서 사용된 축약어 및 형식에 대한 정보는 본 참조서의 형식화 규칙를 참고하십시오.

블록 그룹 코드
그룹 코드 | 설명
0 | 도면요소 유형(BLOCK)
5 | 핸들
102 | 응용프로그램 정의 그룹 시작 “{응용프로그램 이름”. 예를 들어, “{ACAD_REACTORS”는 AutoCAD 불변의 리액터 그룹의 시작을 나타냅니다(선택 사항).
응용프로그램 정의 코드 | 102 그룹 내의 코드와 값은 응용프로그램에서 정의됩니다(선택적임).
102 | 그룹의 끝, “}”(선택 사항)
330 | 소유자 객체에 대한 소프트 포인터 ID/핸들
100 | 하위 클래스 표식기(AcDbEntity)
8 | 도면층 이름
100 | 하위 클래스 표식기(AcDbBlockBegin)
2 | 블록 이름
70 | 블록 유형 플래그(비트 코드화된 값, 서로 결합될 수도 있음): 0 = 다음 플래그를 적용할 수 없음을 나타냅니다. 1 = 이것은 해칭, 연관 치수기입, 기타 내부 작업 또는 응용프로그램에 의해 생성된 익명 블록입니다. 2 = 이 블록에는 일정하지 않은 속성 정의가 있습니다(속성 정의가 일정하거나 속성 정의가 전혀 없는 블록인 경우에는 이 비트가 설정되지 않습니다). 4 = 이 블록은 외부 참조(xref)입니다. 8 = 이 블록은 외부 참조 중첩입니다. 16 = 이 블록은 외부 종속입니다. 32 = 이것은 해석된 외부 참조 또는 외부 참조 종속입니다(입력시 무시됨). 64 = 이 정의는 참조된 외부 참조입니다( 입력시 무시됨).
10 | 기준점 DXF: X 값, APP: 3D 점
20, 30 | DXF: 기준점의 Y 및 Z 값
3 | 블록 이름
1 | 외부 참조 경로 이름
4 | 블록 설명(선택 사항)

블록 정의가 작성될 때 활성인 UCS가 블록 정의의 모든 도면요소에 대한 WCS로 됩니다. 이들 도면요소의 새 원점은 블록 정의를 위해 정의된 기준점에 일치하도록 이동됩니다. 모든 도면요소 데이터가 변환되어 새 WCS에 맞춰집니다.

모형 공간 및 도면 공간 블록 정의

BLOCKS 섹션에는 3개의 빈 정의가 항상 표시되어 있습니다. 이들의 제목은 *Model_Space, *Paper_Space 및 *Paper_Space0입니다. 이런 정의는 모형 공간 및 도면 공간의 표현을 내부적으로 블록 정의로 명시합니다. 첫 번째 도면 공간 레이아웃의 내부 이름은 *Paper_Space, 두 번째는 *Paper_Space0, 세 번째는 *Paper_Space1 등으로 지정됩니다.

모형 공간 및 도면 공간 도면요소 분리

모형 공간과 도면 공간 사이의 인터리빙은 더 이상 발생하지 않습니다. 대신, 모든 도면 공간 도면요소가 출력된 다음 모형 공간 도면요소가 출력됩니다. 이들을 구별하는 플래그는 그룹 코드 67입니다.


ENDBLK

BLOCK
BLOCKS 섹션
ENTITIES 섹션
DXF 참조서 > BLOCKS 섹션 >
ENDBLK

다음 그룹 코드는 endblk 도면요소에 적용됩니다. 이 테이블에서 사용된 축약어 및 형식에 대한 정보는 본 참조서의 형식화 규칙를 참고하십시오.

Endblk 그룹 코드
그룹 코드 | 설명
0 | 도면요소 유형(ENDBLK)
5 | 핸들
102 | 응용프로그램 정의 그룹 시작 “{응용프로그램 이름”. 예를 들어, “{ACAD_REACTORS”는 AutoCAD 불변의 리액터 그룹의 시작을 나타냅니다(선택 사항).
응용프로그램 정의 코드 | 102 그룹 내의 코드와 값은 응용프로그램에서 정의됩니다(선택 사항).
102 | 그룹의 끝, “}”(선택 사항)
330 | 소유자 객체에 대한 소프트 포인터 ID/핸들
100 | 하위 클래스 표식기(AcDbEntity)
8 | 도면층 이름
100 | 하위 클래스 표식기(AcDbBlockEnd)


ENTITIES 섹션

ENDBLK
도면요소의 공용 그룹 코드
DXF 참조서 >
ENTITIES 섹션

이 장에서는 그래픽 객체에 적용되는 그룹 코드를 제공합니다. 이러한 코드는 DXF™ 파일의 ENTITIES 섹션에 있으며 도면요소 정의 리스트에 있는 AutoLISP® 및 ObjectARX® 응용프로그램에서 사용됩니다.

이 단원의 항목

  • 도면요소의 공용 그룹 코드
  • 3DFACE
  • 3DSOLID
  • ACAD_PROXY_ENTITY
  • ARC
  • ATTDEF
  • ATTRIB
  • BODY
  • CIRCLE
  • DIMENSION
  • ELLIPSE
  • HATCH
  • HELIX
  • IMAGE
  • INSERT
  • LEADER
  • LIGHT
  • LINE
  • LWPOLYLINE
  • MLINE
  • MLEADER
  • MLEADERSTYLE
  • MTEXT
  • OLEFRAME
  • OLE2FRAME
  • POINT
  • POLYLINE
  • RAY
  • REGION
  • SECTION
  • SEQEND
  • SHAPE
  • SOLID
  • SPLINE
  • SUN
  • SURFACE
  • TABLE
  • TEXT
  • TOLERANCE
  • TRACE
  • UNDERLAY
  • VERTEX
  • VIEWPORT
  • WIPEOUT
  • XLINE


도면요소의 공용 그룹 코드

ENTITIES 섹션
ENTITIES 섹션
3DFACE
DXF 참조서 > ENTITIES 섹션 >
도면요소의 공용 그룹 코드

다음 테이블에는 모든 그래픽 객체에 실제적으로 적용되는 그룹 코드가 표시되어 있습니다. 여기에 표시된 그룹 코드 중 일부는 도면요소가 특성에 대해 기본값이 아닌 값을 갖는 경우에만 도면요소 정의에 포함됩니다. 특정 도면요소와 연관된 코드 리스트인 도면요소 유형별 그룹 코드를 참조할 경우, 여기에 표시되어 있는 코드도 제공된다는 사실을 기억하십시오.

주이런 DXF 코드 테이블에 표시된 순서에 의존하는 프로그램은 작성하지 마십시오. 이 테이블은 그룹 코드가 일반적으로 표시되는 대로 순서를 나타내고 있지만 순서는 특정 상황에 따라 변경될 수 있으며 이후의 AutoCAD® 릴리즈에서 변경될 수도 있습니다. 예기치 않은 순서에 대해서도 각 그룹을 바르게 처리할 수 있도록, 도면요소를 조정하는 코드는 경우(스위치) 또는 테이블에 따라 운용되어야 합니다.

그룹이 생략된 경우에는 입력 시(OPEN을 사용할 때)의 기본값이 세 번째 열에 표시됩니다. 그룹 코드의 값이 기본값과 같으면 출력 시(SAVEAS를 사용할 때)에 생략됩니다. 이 테이블에서 사용된 축약어 및 형식에 대한 정보는 본 참조서의 형식화 규칙을 참고하십시오.

모든 그래픽 객체에 적용되는 그룹 코드
그룹 코드 | 설명 | 생략될 경우 …으로 기본 설정
-1 | APP: 도면요소 이름(도면이 열릴 때마다 변경됨) | 생략되지 않음
0 | 도면요소 유형 | 생략되지 않음
5 | 핸들 | 생략되지 않음
102 | 응용프로그램 정의 그룹의 시작 “{응용프로그램 이름”(선택 사항) | 기본값 없음
응용프로그램 정의 코드 | 102 그룹 내의 코드와 값은 응용프로그램에서 정의됩니다(선택 사항). | 기본값 없음
102 | 그룹의 끝, “}”(선택 사항) | 기본값 없음
102 | “{ACAD_REACTORS”는 AutoCAD 불변의 리액터 그룹의 시작을 나타냅니다. 이 그룹은 영구 리액터가 이 객체에 부착되어 있는 경우에만 존재합니다(선택 사항). | 기본값 없음
330 | 소유자 사전에 대한 소프트 포인터 ID/핸들(선택 사항) | 기본값 없음
102 | 그룹의 끝, “}”(선택 사항) | 기본값 없음
102 | “{ACAD_XDICTIONARY”는 확장 사전 그룹의 시작을 나타냅니다. 이 그룹은 확장 사전이 객체에 부착되어 있는 경우에만 존재합니다(선택 사항). | 기본값 없음
360 | 소유자 사전에 대한 하드 소유자 ID/핸들(선택 사항) | 기본값 없음
102 | 그룹의 끝, “}”(선택 사항) | 기본값 없음
330 | 소유자 BLOCK_RECORD 객체에 대한 소프트 포인터 ID/핸들 | 생략되지 않음
100 | 하위 클래스 표식기(AcDbEntity) | 생략되지 않음
67 | 제공되지 않거나 0(영)인 경우에는 도면요소가 모형 공간에 있음을 나타냅니다. 1은 도면요소가 도면 공간에 있음을 나타냅니다(선택 사항). | 0
410 | APP: 레이아웃 탭 이름 | 생략되지 않음
8 | 도면층 이름 | 생략되지 않음
6 | 선종류 이름(BYLAYER가 아닌 경우에 제공됨). 특수 이름인 BYBLOCK은 부동 선종류를 나타냅니다(선택 사항). | BYLAYER
347 | 재료 객체에 대한 하드 포인터 ID/핸들(BYLAYER가 아닐 경우 제공됨) | BYLAYER
62 | 색상 번호(BYLAYER가 아닌 경우에 제공됨)로서, 0은 BYBLOCK(부동) 색상을, 256은 BYLAYER를, 음의 값은 도면층이 꺼짐을 나타냅니다(선택 사항). | BYLAYER
370 | 선가중치 enum 값. 16 비트 정수로서 저장되거나 이동됨. | 생략되지 않음
48 | 선종류 축척(선택 사항) | 1.0
60 | 객체 가시성(선택 사항): 0 = 표시, 1 = 숨김 | 0
92 | 이진 묶음 레코드인 후속 310 그룹에서 표현된 프록시 도면요소 그래픽의 바이트 수(선택 사항) | 기본값 없음
310 | 프록시 도면요소 그래픽 데이터(여러 줄: 행당 최대 256자)(선택 사항) | 기본값 없음
420 | 24비트 색상 값으로서, 0에서 255 사이의 값을 가진 바이트로 환산하여 취급해야 합니다. 가장 낮은 바이트는 파란색 값, 중간 바이트는 초록색 값, 세 번째 바이트는 빨간색 값입니다. 최상위 바이트는 항상 0(영)입니다. 그룹 코드는 AcDbEntity, 클래스 단계의 색상 데이터와 AcDbEntity, 클래스 단계의 투명도 데이터를 위해 예약되어 있으므로, 사용자 도면요소는 자신의 데이터를 위해 그룹 코드를 사용할 수 없습니다. | 기본값 없음
430 | 색상 이름 그룹 코드는 AcDbEntity, 클래스 단계의 색상 데이터와 AcDbEntity, 클래스 단계의 투명도 데이터를 위해 예약되어 있으므로, 사용자 도면요소는 자신의 데이터를 위해 그룹 코드를 사용할 수 없습니다. | 기본값 없음
440 | 투명도 값 그룹 코드는 AcDbEntity, 클래스 단계의 색상 데이터와 AcDbEntity, 클래스 단계의 투명도 데이터를 위해 예약되어 있으므로, 사용자 도면요소는 자신의 데이터를 위해 그룹 코드를 사용할 수 없습니다. | 기본값 없음
390 | 플롯 스타일 객체에 대한 하드 포인터 ID/핸들 | 기본값 없음
284 | 그림자 모드 0 = 그림자 주사 및 수신 1 = 그림자 주사 2 = 그림자 수신 3 = 그림자 무시 | 기본값 없음


3DFACE

도면요소의 공용 그룹 코드
ENTITIES 섹션
3DSOLID
DXF 참조서 > ENTITIES 섹션 >
3DFACE

다음 그룹 코드는 3dface 도면요소에 적용됩니다. 여기에 설명되어 있는 그룹 코드 이외의 내용은 도면요소의 공용 그룹 코드를 참고하십시오. 이 테이블에서 사용된 축약어 및 형식에 대한 정보는 본 참조서의 형식화 규칙을 참고하십시오.

3dface 그룹 코드
그룹 코드 | 설명
100 | 하위 클래스 표식기(AcDbFace)
10 | 첫 번째 구석(WCS) DXF: X 값, APP: 3D 점
20, 30 | DXF: 첫 번째 구석의 Y 및 Z 값(WCS)
11 | 두 번째 구석(WCS) DXF: X 값, APP: 3D 점
21, 31 | DXF: 두 번째 구석의 Y 및 Z 값(WCS)
12 | 세 번째 구석(WCS) DXF: X 값, APP: 3D 점
22, 32 | DXF: 세 번째 구석의 Y 및 Z 값(WCS)
13 | 네 번째 구석(WCS) 세 개의 구석만 입력된 경우 네 번째 구석은 세 번째 구석과 동일합니다. DXF: X 값, APP: 3D 점
23, 33 | DXF: 네 번째 구석의 Y 및 Z 값(WCS)
70 | 표시되지 않는 모서리 플래그(선택 사항, 기본값 = 0): 1 = 첫 번째 모서리가 표시되지 않습니다. 2 = 두 번째 모서리가 표시되지 않습니다. 4 = 세 번째 모서리가 표시되지 않습니다. 8 = 네 번째 모서리가 표시되지 않습니다.


3DSOLID

3DFACE
ENTITIES 섹션
ACAD_PROXY_ENTITY
DXF 참조서 > ENTITIES 섹션 >
3DSOLID

다음 그룹 코드는 3dsolid 도면요소에 적용됩니다. 여기에 설명되어 있는 그룹 코드 이외의 내용은 도면요소의 공용 그룹 코드를 참고하십시오. 이 테이블에서 사용된 축약어 및 형식에 대한 정보는 본 참조서의 형식화 규칙을 참고하십시오.

3dsolid 그룹 코드
그룹 코드 | 설명
100 | 하위 클래스 표식기(AcDbModelerGeometry)
70 | 모델러 형식 버전 번호(현재 = 1)
1 | 독점권을 가진 데이터(여러 줄< 행당 255 문자)
3 | 독점권을 가진 데이터의 추가 행(이전 그룹 1 문자열이 255 문자를 넘는 경우)(선택 사항)
100 | 하위 클래스 표식기(AcDb3dSolid)
350 | 사용 내역 객체에 대한 소프트 소유자 ID/핸들


ACAD_PROXY_ENTITY

3DSOLID
ENTITIES 섹션
ARC
DXF 참조서 > ENTITIES 섹션 >
ACAD_PROXY_ENTITY

다음 그룹 코드는 프록시 도면요소에 적용됩니다. 여기에 설명되어 있는 그룹 코드 이외의 내용은 도면요소의 공용 그룹 코드를 참고하십시오. 이 테이블에서 사용된 축약어 및 형식에 대한 정보는 본 참조서의 형식화 규칙를 참고하십시오.

Acad_proxy_entity 그룹 코드
그룹 코드 | 설명
100 | DXF: AcDbProxyEntity
90 | DXF: 프록시 도면요소 클래스 ID(항상 498)
91 | DXF: 응용프로그램 도면요소의 클래스 ID 클래스 ID는 CLASSES 섹션에 있는 클래스의 순서를 따릅니다. 첫 번째 클래스의 ID는 500으로, 다음 ID는 501 등으로 제공됩니다.
92 | DXF: 바이트 단위의 그래픽 데이터 크기
310 | DXF: 이진 그래픽 데이터(여러 항목이 표시될 수 있음)(선택 사항)
93 | DXF: 비트 단위로 나타낸 도면요소 데이터의 크기
310 | DXF: 이진 도면요소 데이터(여러 항목이 표시될 수 있음)(선택 사항)
330 또는 340 또는 350 또는 360 | DXF: 객체 ID(여러 항목이 표시될 수 있음)(선택 사항)
94 | DXF: 0(객체 ID 섹션의 끝을 나타냄)
95 | DXF: 프록시가 될 때의 객체 도면 형식(서명되지 않은 32 비트 정수): Low word는 AcDbDwgVersion입니다. High word는 MaintenanceReleaseVersion입니다.
70 | DXF: 원래의 사용자 객체 데이터 형식: 0 = DWG 형식 1 = DXF 형식


ARC

ACAD_PROXY_ENTITY
ENTITIES 섹션
ATTDEF
DXF 참조서 > ENTITIES 섹션 >
ARC

다음 그룹 코드는 호 도면요소에 적용됩니다. 여기에 설명되어 있는 그룹 코드 이외의 내용은 도면요소의 공용 그룹 코드를 참고하십시오. 이 테이블에서 사용된 축약어 및 형식에 대한 정보는 본 참조서의 형식화 규칙을 참고하십시오.

호 그룹 코드
그룹 코드 | 설명
100 | 하위 클래스 표식기(AcDbCircle)
39 | 두께(선택 사항, 기본값 = 0)
10 | 중심점(OCS) DXF: X 값, APP: 3D 점
20, 30 | DXF: 중심점의 Y 및 Z 값(OCS)
40 | 반지름
100 | 하위 클래스 표식기(AcDbArc)
50 | 시작 각도
51 | 끝 각도
210 | 돌출 방향(선택 사항, 기본값 = 0, 0, 1) DXF: X 값, APP: 3D 벡터
220, 230 | DXF: 돌출 방향의 Y 및 Z 값(선택 사항)


ATTDEF

ARC
ENTITIES 섹션
ATTRIB
DXF 참조서 > ENTITIES 섹션 >
ATTDEF

다음 그룹 코드는 attdef(속성 정의) 도면요소에 적용됩니다. 여기에 설명되어 있는 그룹 코드 이외의 내용은 도면요소의 공용 그룹 코드를 참고하십시오. 이 테이블에서 사용된 축약어 및 형식에 대한 정보는 본 참조서의 형식화 규칙을 참고하십시오.

Attdef 그룹 코드
그룹 코드 | 설명
100 | 하위 클래스 표식기(AcDbText)
39 | 두께(선택 사항, 기본값 = 0)
10 | 첫 번째 정렬점(OCS) DXF: X 값, APP: 3D 점
20, 30 | DXF: 문자 시작점의 Y 및 Z 값(OCS)
40 | 문자 높이
1 | 기본값(문자열)
100 | 하위 클래스 표식기(AcDbAttributeDefinition)
50 | 문자 회전(선택 사항, 기본값 = 0)
41 | 상대 X 축척 비율(폭) (선택 사항, 기본값 = 1). 맞춤 유형 문자가 사용될 경우, 이 값도 조정됩니다.
51 | 기울기 각도(선택 사항, 기본값 = 0)
7 | 문자 스타일 이름(선택 사항, 기본값 = STANDARD)
71 | 문자 생성 플래그(선택 사항, 기본값 = 0), TEXT 그룹 코드 참고
72 | 수평 문자 자리맞추기 유형(선택 사항, 기본값 = 0), TEXT 그룹 코드 참고
11 | 두 번째 정렬점(OCS)(선택 사항) DXF: X 값, APP: 3D 점 72 그룹 값 또는 74 그룹 값이 0이 아닌 경우에만 적용됩니다.
21, 31 | DXF: 두 번째 정렬점의 Y 및 Z 값(OCS)(선택 사항)
210 | 돌출 방향(선택 사항, 기본값 = 0, 0, 1) DXF: X 값, APP: 3D 벡터
220, 230 | DXF: 돌출 방향의 Y 및 Z 값
100 | 하위 클래스 표식기(AcDbAttributeDefinition)
3 | 프롬프트 문자열
2 | 태그 문자열(공백이 포함될 수 없음)
70 | 속성 플래그: 1 = 속성이 보이지 않습니다(표시되지 않음). 2 = 이것은 상수 속성입니다. 4 = 이 속성의 입력을 검증해야 합니다. 8 = 속성이 미리 설정되었습니다(삽입 도중 프롬프트 표시되지 않음).
73 | 필드 길이(선택 사항, 기본값 = 0)(현재 사용되지 않음)
74 | 수직 문자 자리맞추기 유형(선택 사항, 기본값 = 0), TEXT의 그룹 코드 73 참고
280 | 위치 잠금 플래그 블록 참조 내 속성의 위치를 잠급니다.
100 | 하위 클래스 표식기(AcDbXrecord)
280 | 레코드 복제 플래그 중복(중복 항목을 결합하는 방법 결정): 1 = 기존 값 유지
70 | MText 플래그: 2 = 여러 줄 속성 4 = 일정한 여러 줄 속성 정의
70 | isReallyLocked 플래그: 0 = 잠금해제 1 = 잠금
70 | 보조 속성 또는 속성 정의 수
340 | 보조 속성 또는 속성 정의의 하드 포인터 ID
10 | 속성 또는 속성 정의의 정렬 점 DXF: X 값, APP: 3D 점
20,30 | DXF: 삽입점의 Y 및 Z 값
40 | 현재 주석 축척
2 | 속성 또는 속성 정의 태그 문자열
0 | 도면요소 유형(MTEXT)
100 | 하위 클래스 표식기(AcDbEntity)
67 | 제공되지 않거나 0(영)인 경우에는 도면요소가 모형 공간에 있음을 나타냅니다. 1은 도면요소가 도면 공간에 있음을 나타냅니다(선택사항).
8 | 도면층 이름
100 | 하위 클래스 표식기(AcDbMText)
10 | 삽입점 DXF: X 값, APP: 3D 점
20,30 | DXF: 삽입점의 Y 및 Z 값
40 | 명목상의(초기) 문자 높이
41 | 참조 직사각형 폭
46 | 정의된 주석 높이
71 | 부착 점: 1 = 맨 위 왼쪽, 2 = 맨 위 중심, 3 = 맨 위 오른쪽 4 = 중간 왼쪽, 5 = 중간 중심, 6 = 중간 오른쪽 7 = 맨 아래 왼쪽, 8 = 맨 아래 중심, 9 = 맨 아래 오른쪽
72 | 도면 방향: 1 = 왼쪽에서 오른쪽으로 3 = 맨 위에서 맨 아래로 5 = 스타일별(흐름 방향은 관련 문자 스타일에서 상속됩니다.)
1 | 문자열 250자 미만의 문자열인 경우, 모든 문자는 그룹 1에 표시됩니다. 문자열이 250자를 초과하는 경우, 250 문자 묶음으로 문자열이 나누어져 하나 이상의 그룹 3 코드에 표시됩니다. 그룹 3 코드가 사용되면 마지막 그룹이 그룹 1이며 250자 미만의 문자 수를 갖습니다.
3 | 추가 문자(항상 250 문자 묶음에 포함됨)(선택 사항)
7 | DXF: X 값; APP: 3D vectText 스타일 이름(공되지 않은 경우에는 STANDARD)(선택 사항)
210 | 돌출 방향(선택 사항, 기본값 = 0, 0, 1) DXF: X 값, APP: 3D 벡터
220,230 | DXF: 돌출 방향의 Y 및 Z 값(선택사항)
11 | X축 방향 벡터(WCS) DXF: X 값, APP: 3D 벡터
21,31 | DXF: X축 방향 벡터의 Y 및 Z 값(WCS)
42 | 여러 줄 문자 도면요소를 구성하는 문자의 가로 너비. 이 값은 항상 그룹 코드 41의 값 이하입니다(읽기 전용이며 제공된 경우 무시됨).
43 | 여러 줄 문자 도면요소의 수직 높이(읽기 전용이며 제공된 경우 무시됨)
50 | 라디안 단위의 회전 각도
73 | 여러 줄 문자 행 간격 스타일(선택 사항): 1 = 최소(더 큰 문자가 재지정됨) 2 = 정확함(더 큰 문자가 재지정되지 않음)
44 | 여러 줄 문자 행 간격 비율(선택 사항): 적용할 기본(3-on-5) 선 간격의 백분율. 적합한 값의 범위는 0.25에서 4.00까지 입니다.
90 | 배경 채우기 설정: 0 = 배경 채우기 끄기 1 = 배경 채우기 색상 사용 2 = 배경 채우기 색상으로 도면 윈도우 색상 사용
63 | 배경 색상(색상 색인 번호일 경우)
420-429 | 배경 색상(RGB 색상일 경우)
430-439 | 배경 색상(색상 이름일 경우)
45 | 채우기 상자 축척(선택 사항): 문자 주변에 있는 경계의 정도를 결정합니다.
63 | 배경 채우기 색상(선택 사항): 그룹 코드 90이 1일 때 배경 채우기에 사용할 색상입니다.
441 | 배경 채우기 색상의 투명도(구현되지 않음)

그룹 72 및/또는 74 값이 0이 아닌 경우 첫 번째 정렬점 값이 무시되고 AutoCAD가 두 번째 정렬점 및 문자열 자체의 높이와 길이를 기준으로 한 새 값을 계산합니다(문자 스타일 적용 후). 72와 74 값이 0(영)이거나 누락된 경우, 두 번째 정렬점은 의미가 없습니다.


ATTRIB

ATTDEF
ENTITIES 섹션
BODY
DXF 참조서 > ENTITIES 섹션 >
ATTRIB

다음 그룹 코드는 attrib(속성) 도면요소에 적용됩니다. 여기에 설명되어 있는 그룹 코드 이외의 내용은 도면요소의 공용 그룹 코드를 참고하십시오. 이 테이블에서 사용된 축약어 및 형식에 대한 정보는 본 참조서의 형식화 규칙을 참고하십시오.

Attrib 그룹 코드
그룹 코드 | 설명
100 | 하위 클래스 표식기(AcDbText)
39 | 두께(선택 사항, 기본값 = 0)
10 | 문자 시작점(OCS) DXF: X 값, APP: 3D 점
20, 30 | DXF: 문자 시작점의 Y 및 Z 값(OCS)
40 | 문자 높이
1 | 기본값(문자열)
100 | 하위 클래스 표식기(AcDbAttribute)
2 | 속성 태그(문자열, 공백이 포함될 수 없음)
70 | 속성 플래그: 1 = 속성이 보이지 않습니다(표시되지 않음). 2 = 이것은 상수 속성입니다. 4 = 이 속성의 입력을 검증해야 합니다. 8 = 속성이 미리 설정되었습니다(삽입 도중 프롬프트 표시되지 않음).
73 | 필드 길이(선택 사항, 기본값 = 0) (현재 사용되지 않음)
50 | 문자 회전(선택 사항, 기본값 = 0)
41 | 상대 X 축척 비율(폭) (선택 사항, 기본값 = 1). 맞춤 유형 문자가 사용될 경우, 이 값도 조정됩니다.
51 | 기울기 각도(선택 사항, 기본값 = 0)
7 | 문자 스타일 이름(선택 사항, 기본값 = STANDARD)
71 | 문자 생성 플래그(선택 사항, 기본값 = 0). TEXT 그룹 코드 참고
72 | 수평 문자 자리맞추기 유형(선택 사항, 기본값 = 0). TEXT 그룹 코드 참고
74 | 수직 문자 자리맞추기 유형(선택 사항, 기본값 = 0). TEXT의 그룹 코드 73 참고
11 | 정렬점(OCS)(선택 사항) DXF: X 값, APP: 3D 점 72 또는 74 그룹이 있으며 0(영)이 아닌 경우에만 표시됩니다.
21, 31 | DXF: 정렬점의 Y 및 Z 값(OCS)(선택 사항)
210 | 돌출 방향. 도면요소의 돌출 방향이 WCS Z 축에 평행하지 않는 경우에만 표시됩니다(선택 사항, 기본값 = 0, 0, 1) DXF: X 값, APP: 3D 벡터
220, 230 | DXF: 돌출 방향의 Y 및 Z 값(선택 사항)
280 | 위치 잠금 플래그 블록 참조 내 속성의 위치를 잠급니다.
100 | 하위 클래스 표식기(AcDbXrecord)
280 | 레코드 복제 플래그 중복(중복 항목을 결합하는 방법 결정): 1 = 기존 값 유지
70 | MText 플래그: 2 = 여러 줄 속성 4 = 일정한 여러 줄 속성 정의
70 | isReallyLocked 플래그: 0 = 잠금해제 1 = 잠금
70 | 보조 속성 또는 속성 정의 수
340 | 보조 속성 또는 속성 정의의 하드 포인터 ID
10 | 속성 또는 속성 정의의 정렬 점 DXF: X 값, APP: 3D 점
20,30 | DXF: 삽입점의 Y 및 Z 값
40 | 현재 주석 축척
2 | 속성 또는 속성 정의 태그 문자열
0 | 도면요소 유형(MTEXT)
100 | 하위 클래스 표식기(AcDbEntity)
67 | 제공되지 않거나 0(영)인 경우에는 도면요소가 모형 공간에 있음을 나타냅니다. 1은 도면요소가 도면 공간에 있음을 나타냅니다(선택사항).
8 | 도면층 이름
100 | 하위 클래스 표식기(AcDbMText)
10 | 삽입점 DXF: X 값, APP: 3D 점
20,30 | DXF: 삽입점의 Y 및 Z 값
40 | 명목상의(초기) 문자 높이
41 | 참조 직사각형 폭
46 | 정의된 주석 높이
71 | 부착 점: 1 = 맨 위 왼쪽, 2 = 맨 위 중심, 3 = 맨 위 오른쪽 4 = 중간 왼쪽, 5 = 중간 중심, 6 = 중간 오른쪽 7 = 맨 아래 왼쪽, 8 = 맨 아래 중심, 9 = 맨 아래 오른쪽
72 | 도면 방향: 1 = 왼쪽에서 오른쪽으로 3 = 맨 위에서 맨 아래로 5 = 스타일별(흐름 방향은 관련 문자 스타일에서 상속됩니다.)
1 | 문자열 250자 미만의 문자열인 경우, 모든 문자는 그룹 1에 표시됩니다. 문자열이 250자를 초과하는 경우, 250 문자 묶음으로 문자열이 나누어져 하나 이상의 그룹 3 코드에 표시됩니다. 그룹 3 코드가 사용되면 마지막 그룹이 그룹 1이며 250개보다 적은 수의 문자를 갖습니다.
3 | 추가 문자(항상 250 문자 묶음에 포함됨)(선택 사항)
7 | DXF: X 값; APP: 3D vectText 스타일 이름(공되지 않은 경우에는 STANDARD)(선택 사항)
210 | 돌출 방향(선택 사항, 기본값 = 0, 0, 1) DXF: X 값, APP: 3D 벡터
220,230 | DXF: 돌출 방향의 Y 및 Z 값(선택사항)
11 | X축 방향 벡터(WCS) DXF: X 값, APP: 3D 벡터
21,31 | DXF: X축 방향 벡터의 Y 및 Z 값(WCS)
42 | 여러 줄 문자 도면요소를 구성하는 문자의 가로 너비. 이 값은 항상 그룹 코드 41의 값 이하입니다(읽기 전용이며 제공된 경우 무시됨).
43 | 여러 줄 문자 도면요소의 수직 높이(읽기 전용이며 제공된 경우 무시됨)
50 | 라디안 단위의 회전 각도
73 | 여러 줄 문자 행 간격 스타일(선택 사항): 1 = 최소(더 큰 문자가 재지정됨) 2 = 정확함(더 큰 문자가 재지정되지 않음)
44 | 여러 줄 문자 행 간격 비율(선택 사항): 적용할 기본(3-on-5) 선 간격의 백분율. 적합한 값의 범위는 0.25에서 4.00까지 입니다.
90 | 배경 채우기 설정: 0 = 배경 채우기 끄기 1 = 배경 채우기 색상 사용 2 = 배경 채우기 색상으로 도면 윈도우 색상 사용
63 | 배경 색상(색상 색인 번호일 경우)
420-429 | 배경 색상(RGB 색상일 경우)
430-439 | 배경 색상(색상 이름일 경우)
45 | 채우기 상자 축척(선택 사항): 문자 주변에 있는 경계의 정도를 결정합니다.
63 | 배경 채우기 색상(선택 사항): 그룹 코드 90이 1일 때 배경 채우기에 사용할 색상입니다.
441 | 배경 채우기 색상의 투명도(구현되지 않음)

그룹 72 및/또는 74 값이 0이 아닌 경우 문자 삽입점 값이 무시되고 AutoCAD가 문자 정렬점 및 문자열 자체의 길이를 기준으로 한 새 값을 계산합니다(문자 스타일 적용 후). 72와 74 값이 0(영)이거나 누락된 경우, 문자 정렬점이 무시되고 문자 삽입점과 문자열 자체의 길이를 기준으로 새 값이 다시 계산됩니다(문자 스타일 적용 후).


BODY

ATTRIB
ENTITIES 섹션
CIRCLE
DXF 참조서 > ENTITIES 섹션 >
BODY

다음 그룹 코드는 본체 도면요소에 적용됩니다. 여기에 설명되어 있는 그룹 코드 이외의 내용은 도면요소의 공용 그룹 코드를 참고하십시오. 이 테이블에서 사용된 축약어 및 형식에 대한 정보는 본 참조서의 형식화 규칙을 참고하십시오.

본체 그룹 코드
그룹 코드 | 설명
100 | 하위 클래스 표식기(AcDbModelerGeometry)
70 | 모델러 형식 버전 번호(현재 = 1)
1 | 독점권을 가진 데이터(여러 줄< 행당 255 문자)
3 | 독점권을 가진 데이터의 추가 행(이전 그룹 1 문자열이 255 문자를 초과하는 경우)(선택 사항)


CIRCLE

BODY
ENTITIES 섹션
DIMENSION
DXF 참조서 > ENTITIES 섹션 >
CIRCLE

다음 그룹 코드는 원 도면요소에 적용됩니다. 여기에 설명되어 있는 그룹 코드 이외의 내용은 도면요소의 공용 그룹 코드를 참고하십시오. 이 테이블에서 사용된 축약어 및 형식에 대한 정보는 본 참조서의 형식화 규칙을 참고하십시오.

원 그룹 코드
그룹 코드 | 설명
100 | 하위 클래스 표식기(AcDbCircle)
39 | 두께(선택 사항, 기본값 = 0)
10 | 중심점(OCS) DXF: X 값, APP: 3D 점
20, 30 | DXF: 중심점의 Y 및 Z 값(OCS)
40 | 반지름
210 | 돌출 방향(선택 사항, 기본값 = 0, 0, 1) DXF: X 값, APP: 3D 벡터
220, 230 | DXF: 돌출 방향의 Y 및 Z 값(선택 사항)


DIMENSION

CIRCLE
ENTITIES 섹션
공용 치수 그룹 코드
DXF 참조서 > ENTITIES 섹션 >
DIMENSION

치수 도면요소 정의는 모든 치수 유형에 공용인 그룹 코드에 이어서 특정 유형별 코드로 구성됩니다.

이 단원의 항목

  • 공용 치수 그룹 코드
  • 정렬된 치수 그룹 코드
  • 선형 및 회전 치수 그룹 코드
  • 반지름 및 지름 치수 그룹 코드
  • 각도 치수 그룹 코드
  • 세로좌표 치수 그룹 코드
  • 치수 스타일 재지정


공용 치수 그룹 코드

DIMENSION
DIMENSION
정렬된 치수 그룹 코드
DXF 참조서 > ENTITIES 섹션 > DIMENSION >
공용 치수 그룹 코드

다음 그룹 코드는 모든 치수 도면요소 유형에 적용됩니다. 여기에 설명되어 있는 그룹 코드 이외의 내용은 도면요소의 공용 그룹 코드를 참고하십시오. 이 테이블에서 사용된 축약어 및 형식에 대한 정보는 본 참조서의 형식화 규칙을 참고하십시오.

공용 치수 그룹 코드
그룹 코드 | 설명
100 | 하위 클래스 표식기(AcDbDimension)
2 | 치수 그림을 구성하는 도면요소가 포함된 블록의 이름
10 | 정의점(WCS) DXF: X 값, APP: 3D 점
20, 30 | DXF: 정의점의 Y 및 Z 값(WCS)
11 | 치수 문자의 중간점(OCS) DXF: X 값, APP: 3D 점
21, 31 | DXF: 치수 문자 중간점의 Y 및 Z 값(OCS)
70 | 치수 유형: 0에서 6까지의 값은 치수 유형을 나타내는 정수 값입니다. 값 32, 64, 128은 정수 값에 추가된 비트 값입니다(값 32는 R13 및 이후 릴리즈에서 항상 설정됨) 0 = 회전, 수평 또는 수직, 1 = 정렬 2 = 각도, 3 = 지름, 4 = 반지름 5 = 각도 3 점, 6 = 세로좌표 32 = 이 치수에 의해서만 블록 참조(그룹 코드 2)가 참조됨을 나타냅니다. 64 = 세로좌표 유형. 이 값은 정수 값 6으로만 사용되는 비트 값(비트 7)입니다. 설정된 경우 세로좌표는 X 유형이며, 설정되지 않은 경우 세로좌표는 Y 유형입니다. 128 = 치수 문자의 위치가 기본 위치 이외의 사용자 정의 위치로 정해진 경우, 이 값은 다른 그룹 70 값에 추가된 비트 값(비트 8)입니다.
71 | 부착 점: 1 = 맨 위 왼쪽, 2 = 맨 위 중심, 3 = 맨 위 오른쪽 4 = 중간 왼쪽, 5 = 중간 중심, 6 = 중간 오른쪽 7 = 맨 아래 왼쪽, 8 = 맨 아래 중심, 9 = 맨 아래 오른쪽
72 | 치수 문자 행 간격 스타일(선택 사항): 1(또는 생략 시) = 최소(더 큰 문자는 재지정됨) 2 = 정확함(더 큰 문자가 재지정되지 않음)
41 | 치수 문자 행 간격 비율(선택 사항): 적용할 기본(3-on-5) 선 간격의 백분율. 적합한 값의 범위는 0.25에서 4.00까지 입니다.
42 | 실제 측정치(선택 사항, 읽기 전용 값)
1 | 사용자가 명시적으로 입력한 치수 문자. 선택 사항이며 기본값은 측정치입니다. 널(null) 또는 “<>”인 경우 치수 측정값은 문자로 그려집니다. ““(한 개의 빈 칸)의 경우 문자가 억제됩니다. 그 밖의 모든 경우는 문자로 그려집니다.
53 | 선택 사항인 그룹 코드 53은 치수 문자의 기본 방향(치수 선 방향)으로부터 치수 문자가 회전되는 각도입니다(선택 사항).
51 | 모든 치수 유형에는 51 그룹 코드가 선택 사항으로 되어 있으며 이 코드는 치수 도면요소의 수평 방향을 나타냅니다. 치수 도면요소는 수평, 수직 및 회전 선형 치수에 대한 치수 문자 및 선의 방향을 결정합니다. 이 그룹 값은 OCS X축과 UCS X축 사이 각도의 음수입니다. 항상 OCS의 XY 평면에 존재합니다.
210 | 돌출 방향(선택 사항, 기본값 = 0, 0, 1) DXF: X 값, APP: 3D 벡터
220, 230 | DXF: 돌출 방향의 Y 및 Z 값(선택 사항)
3 | 치수 스타일 이름

이 도면요소에 대해 치수가 재지정된 적이 있었던 경우, 응용프로그램 ID "ACAD"에 속하는 확장 데이터가 치수 도면요소 다음에 표시됩니다. 치수 스타일 재지정을 참고하십시오.

모든 치수 유형에 대해 다음의 그룹 코드는 3D WCS 점을 나타냅니다.

  • (10, 20, 30)
  • (13, 23, 33)
  • (14, 24, 34)
  • (15, 25, 35)

모든 치수 유형에 대해 다음의 그룹 코드는 3D OCS 점을 나타냅니다.

  • (11, 21, 31)
  • (12, 22, 32)
  • (16, 26, 36)


정렬된 치수 그룹 코드

공용 치수 그룹 코드
DIMENSION
선형 및 회전 치수 그룹 코드
DXF 참조서 > ENTITIES 섹션 > DIMENSION >
정렬된 치수 그룹 코드

다음 그룹 코드는 정렬된 치수에 적용됩니다. 여기에 설명된 그룹 코드 이외에 도면요소의 공용 그룹 코드 및 공용 치수 그룹 코드에 나와 있는 코드도 표시됩니다. 이 테이블에서 사용된 축약어 및 형식에 대한 정보는 본 참조서의 형식화 규칙을 참고하십시오.

정렬된 치수 그룹 코드
그룹 코드 | 설명
100 | 하위 클래스 표식기(AcDbAlignedDimension)
12 | 치수 복제용 삽입점—기준선 및 계속(OCS) DXF: X 값, APP: 3D 점
22, 32 | DXF: 치수 복제용 삽입점의 Y 및 Z 값—기준선 및 계속(OCS에서)
13 | 선형 및 각도 치수의 정의점(WCS) DXF: X 값, APP: 3D 점
23, 33 | DXF: 선형 및 각도 치수에 대한 정의점의 Y 및 Z 값(WCS)
14 | 선형 및 각도 치수의 정의점(WCS) DXF: X 값, APP: 3D 점
24, 34 | DXF: 선형 및 각도 치수에 대한 정의점의 Y 및 Z 값(WCS)

점(13,23,33)은 첫 번째 치수보조선의 시작점을 지정하며 점(14,24,34)은 두 번째 치수보조선의 시작점을 지정합니다. 점(10,20,30)은 치수 선 위치를 지정합니다. 점 (11,21,31)은 치수 문자의 중간점을 지정합니다.


선형 및 회전 치수 그룹 코드

정렬된 치수 그룹 코드
DIMENSION
반지름 및 지름 치수 그룹 코드
DXF 참조서 > ENTITIES 섹션 > DIMENSION >
선형 및 회전 치수 그룹 코드

다음 그룹 코드는 선형 및 회전 치수에 적용됩니다(선형 및 회전 치수는 AcDbAlignedDimension 하위 클래스의 일부임에 유의하십시오). 여기에 설명된 그룹 코드 이외에 도면요소의 공용 그룹 코드 및 공용 치수 그룹 코드에 나와 있는 코드도 표시됩니다. 이 테이블에서 사용된 축약어 및 형식에 대한 정보는 본 참조서의 형식화 규칙을 참고하십시오.

선형 및 회전 치수 그룹 코드
그룹 코드 | 설명
100 | 하위 클래스 표식기(AcDbAlignedDimension)
12 | 치수 복제용 삽입점—기준선 및 계속(OCS) DXF: X 값, APP: 3D 점
22, 32 | DXF: 치수 복제용 삽입점의 Y 및 Z 값—기준선 및 계속(OCS에서)
13 | 선형 및 각도 치수의 정의점(WCS) DXF: X 값, APP: 3D 점
23, 33 | DXF: 선형 및 각도 치수에 대한 정의점의 Y 및 Z 값(WCS)
14 | 선형 및 각도 치수의 정의점(WCS) DXF: X 값, APP: 3D 점
24, 34 | DXF: 선형 및 각도 치수에 대한 정의점의 Y 및 Z 값(WCS)
50 | 회전, 수평 또는 수직 치수의 각도
52 | 기울기 각도가 포함된 선형 치수 유형은 선택적인 그룹 코드 52를 갖습니다. 선형 치수(그룹 코드 50)의 회전 각도에 추가된 경우, 치수보조선의 각도가 제공됩니다.
100 | 하위 클래스 표식기(AcDbRotatedDimension)


반지름 및 지름 치수 그룹 코드

선형 및 회전 치수 그룹 코드
DIMENSION
각도 치수 그룹 코드
DXF 참조서 > ENTITIES 섹션 > DIMENSION >
반지름 및 지름 치수 그룹 코드

다음 그룹 코드는 반지름 및 지름 치수에 적용됩니다. 여기에 설명된 그룹 코드 이외에 도면요소의 공용 그룹 코드 및 공용 치수 그룹 코드에 나와 있는 코드도 표시됩니다. 이 테이블에서 사용된 축약어 및 형식에 대한 정보는 본 참조서의 형식화 규칙을 참고하십시오.

반지름 및 지름 치수 그룹 코드
그룹 코드 | 설명
100 | 하위 클래스 표식기(AcDbRadialDimension 또는 AcDbDiametricDimension)
15 | 지름, 반지름 및 각도 치수의 정의점(WCS) DXF: X 값, APP: 3D 점
25, 35 | DXF: 지름, 반지름 및 각도 치수에 대한 정의점의 Y 및 Z 값(WCS)
40 | 반지름 및 지름 치수의 지시선 길이

점(15,25,35)은 원이나 호의 치수 선에 대한 첫 번째 점을 지정하며 점(10,20,30)은 첫 번째 점의 반대쪽 점을 지정합니다. 점 (11,21,31)은 치수 문자의 중간점을 지정합니다.

점(15,25,35)은 원이나 호의 치수 선에 대한 첫 번째 점을 지정하며 점(10,20,30)은 원이나 호의 중심을 지정합니다. 점 (11,21,31)은 치수 문자의 중간점을 지정합니다.


각도 치수 그룹 코드

반지름 및 지름 치수 그룹 코드
DIMENSION
세로좌표 치수 그룹 코드
DXF 참조서 > ENTITIES 섹션 > DIMENSION >
각도 치수 그룹 코드

다음 그룹 코드는 각도 치수에 적용됩니다. 여기에 설명된 그룹 코드 이외에 도면요소의 공용 그룹 코드 및 공용 치수 그룹 코드에 나와 있는 코드도 표시됩니다. 이 테이블에서 사용된 축약어 및 형식에 대한 정보는 본 참조서의 형식화 규칙을 참고하십시오.

각도 치수 그룹 코드
그룹 코드 | 설명
100 | 하위 클래스 표식기(AcDb3PointAngularDimension)
13 | 선형 및 각도 치수의 정의점(WCS) DXF: X 값, APP: 3D 점
23, 33 | DXF: 선형 및 각도 치수에 대한 정의점의 Y 및 Z 값(WCS)
14 | 선형 및 각도 치수의 정의점(WCS) DXF: X 값, APP: 3D 점
24, 34 | DXF: 선형 및 각도 치수에 대한 정의점의 Y 및 Z 값(WCS)
15 | 지름, 반지름 및 각도 치수의 정의점(WCS) DXF: X 값, APP: 3D 점
25, 35 | DXF: 지름, 반지름 및 각도 치수에 대한 정의점의 Y 및 Z 값(WCS)
16 | 각도 치수에 대한 치수 호를 정의하는 점(OCS) DXF: X 값, APP: 3D 점
26, 36 | DXF: 각도 치수에 대한 치수 호를 정의하는 점의 Y 및 Z 값(OCS)

점 (13,23,33)과 점 (14,24,34)은 첫 번째 치수보조선의 결정에 사용되는 선의 양 끝점을 지정합니다. 점 (10,20,30)과 점 (15,25,35)은 두 번째 치수보조선의 결정에 사용되는 선의 양 끝점을 지정합니다. 점(16,26,36)은 치수 선 호의 위치를 지정합니다. 점 (11,21,31)은 치수 문자의 중간점을 지정합니다.

점(15,25,35)은 각의 정점을 지정합니다. 점 (13,23,33)과 점 (14,24,34)은 치수보조선의 양 끝점을 지정합니다. 점(10,20,30)은 치수 선 호의 위치를 지정하며 점(11,21,31)은 치수 문자의 중간점을 지정합니다.


세로좌표 치수 그룹 코드

각도 치수 그룹 코드
DIMENSION
치수 스타일 재지정
DXF 참조서 > ENTITIES 섹션 > DIMENSION >
세로좌표 치수 그룹 코드

다음 그룹 코드는 세로좌표 치수에 적용됩니다. 여기에 설명된 그룹 코드 이외에 도면요소의 공용 그룹 코드 및 공용 치수 그룹 코드에 나와 있는 코드도 표시됩니다. 이 테이블에서 사용된 축약어 및 형식에 대한 정보는 본 참조서의 형식화 규칙을 참고하십시오.

세로좌표 치수 그룹 코드
그룹 코드 | 설명
100 | 하위 클래스 표식기(AcDbOrdinateDimension)
13 | 선형 및 각도 치수의 정의점(WCS) DXF: X 값, APP: 3D 점
23, 33 | DXF: 선형 및 각도 치수에 대한 정의점의 Y 및 Z 값(WCS)
14 | 선형 및 각도 치수의 정의점(WCS) DXF: X 값, APP: 3D 점
24, 34 | DXF: 선형 및 각도 치수에 대한 정의점의 Y 및 Z 값(WCS)

점(13,23,33)은 피쳐 위치를 지정하며 점(14,24,34)은 지시선의 끝점을 지정합니다. 점 (11,21,31)은 치수 문자의 중간점을 지정합니다. 점(10,20,30)은 치수가 작성될 때의 현재 좌표인 UCS의 원점에 배치됩니다.


치수 스타일 재지정

세로좌표 치수 그룹 코드
DIMENSION
ELLIPSE
DXF 참조서 > ENTITIES 섹션 > DIMENSION >
치수 스타일 재지정

치수 스타일 재지정은 치수, 지시선 및 공차 도면요소에 적용할 수 있습니다. 이런 도면요소에 적용된 모든 재지정은 확장 데이터로 도면요소에 저장됩니다. 재지정된 치수 변수 그룹 코드 및 관련 값은 그룹 1002 제어 문자열 내에 포함됩니다. 다음 예제는 DIMTOL 및 DIMCLRE 변수가 재지정된 치수 도면요소의 확장 데이터를 보여줍니다.

(setq diment (car (entsel))) , 치수 도면요소 선택
(setq elst(entget diment '("ACAD"))) , 도면요소 정의 리스트 가져오기
(assoc -3 elst) , 확장 데이터 추출 전용

이 코드는 다음과 같은 결과를 반환합니다.

(-3("ACAD" 확장 데이터의 ACAD APPID 섹션 시작
  (1000 . "DSTYLE") (1002 . "{") 치수 스타일 하위 절의 시작
  (1070 . 177) (1070 . 3) DIMCLRE(코드 177) 재지정 + 값(3)
  (1070 . 71) (1070 . 1) DIMTOL(코드 71) 재지정 + 값(1)
  (1002 . "}") )) 치수 스타일 하위 절 및 ACAD 절의 종료


ELLIPSE

치수 스타일 재지정
ENTITIES 섹션
HATCH
DXF 참조서 > ENTITIES 섹션 >
ELLIPSE

다음 그룹 코드는 타원 도면요소에 적용됩니다. 여기에 설명되어 있는 그룹 코드 이외의 내용은 도면요소의 공용 그룹 코드를 참고하십시오. 이 테이블에서 사용된 축약어 및 형식에 대한 정보는 본 참조서의 형식화 규칙을 참고하십시오.

타원 그룹 코드
그룹 코드 | 설명
100 | 하위 클래스 표식기(AcDbEllipse)
10 | 중심점(WCS) DXF: X 값, APP: 3D 점
20, 30 | DXF: 중심점의 Y 및 Z 값(WCS)
11 | 중심에 상대적인, 장축의 끝점(WCS) DXF: X 값, APP: 3D 점
21, 31 | DXF: 중심에 상대적인 장축 끝점의 Y 및 Z 값(WCS)
210 | 돌출 방향(선택 사항, 기본값 = 0, 0, 1) DXF: X 값, APP: 3D 벡터
220, 230 | DXF: 돌출 방향의 Y 및 Z 값(선택 사항)
40 | 단축 대 장축의 비율
41 | 시작 매개변수(완전 타원의 경우, 이 값은 0.0임)
42 | 끝 매개변수(완전 타원의 경우, 이 값은 2pi임)


HATCH

ELLIPSE
ENTITIES 섹션
경계 경로 데이터
DXF 참조서 > ENTITIES 섹션 >
HATCH

다음 그룹 코드는 해치 및 MPolygon 도면요소에 적용됩니다. 여기에 설명되어 있는 그룹 코드 이외의 내용은 도면요소의 공용 그룹 코드를 참고하십시오. 이 테이블에서 사용된 축약어 및 형식에 대한 정보는 본 참조서의 형식화 규칙을 참고하십시오.

해치 그룹 코드
그룹 코드 | 설명
100 | 하위 클래스 표식기(AcDbHatch)
10 | 고도점(OCS) DXF: X 값 = 0, APP: 3D 점(X 및 Y는 항상 0과 같음, Z는 고도를 나타냄)
20, 30 | DXF: 고도점의 Y 및 Z 값(OCS) Y 값 = 0, Z는 고도를 나타냅니다.
210 | 돌출 방향(선택 사항, 기본값 = 0, 0, 1) DXF: X 값, APP: 3D 벡터
220, 230 | DXF: 돌출 방향의 Y 및 Z 값
2 | 해치 패턴 이름
70 | 솔리드 채우기 플래그(솔리드 채우기 = 1, 패턴 채우기 = 0), MPolygon의 경우, MPolygon의 버전
63 | MPolygon의 경우, ACI의 패턴 채우기 색상
71 | 연관성 플래그(연관 = 1, 비연관 = 0), MPolygon의 경우에는 솔리드 채우기 플래그임(솔리드 채우기가 있으면 1이며 솔리드 채우기가 없으면 0임)
91 | 경계 경로(루프)의 개수
다양함 | 경계 경로 데이터. 코드 91에 의해 지정된 횟수만큼 반복합니다. 경계 경로 데이터 참고
75 | 해치 스타일: 0 = 해치 “홀수 패리티” 영역(일반 스타일) 1 = 해치 최외곽 영역만(외부 스타일) 2 = 전체 영역에 걸친 해치(무시 스타일)
76 | 해치 패턴 유형: 0 = 사용자 정의, 1 = 미리 정의, 2 = 사용자
52 | 해치 패턴 각도(패턴 채우기의 경우에만)
41 | 해치 패턴 축척 또는 간격두기(패턴 채우기의 경우에만)
73 | MPolygon의 경우, 경계 주석 플래그(경계가 주석이 있으면 1, 주석이 없으면 0)
77 | 해치 패턴 이중 플래그(패턴 채우기의 경우에만): 0 = 이중 아님, 1 = 이중
78 | 패턴 정의 선의 개수
다양함 | 패턴 선 데이터. 코드 78에 의해 지정된 횟수만큼 반복합니다. 패턴 데이터 참고
47 | 플러드 해칭 방식을 사용하여 작성된 해치 및 연관 해치에 대한 해치 패턴 계산 시, 다양한 교차 및 광선 주사 작업을 수행하기 위한 밀도를 지정하는 데 사용되는 픽셀 크기
98 | 시드점의 개수
11 | MPolygon의 경우, 간격띄우기 벡터
99 | MPolygon의 경우, 해치에 의해 무시된 경계인 퇴보 경계 경로(루프)의 개수
10 | 시드점(OCS) DXF: X 값, APP: 2D 점(다중 항목)
20 | DXF: 시드점의 Y 값(OCS),(다중 항목)
450 | 솔리드 해치 또는 그라데이션을 나타냅니다. 솔리드 해치인 경우 나머지 코드값은 무시되지만 제공해야 합니다. (선택 사항) 코드 450이 파일에 있는 경우 코드 451, 452, 453, 460, 461, 462, 470도 반드시 파일에 있어야 합니다. 코드 450이 파일에 없는 경우에 코드 451, 452, 453, 460, 461, 462, 470도 파일에 있어서는 안됩니다. 0 = 솔리드 해치 1 = 그라데이션
451 | 이후 사용을 위해 0(영)이 예약됩니다.
452 | 색상 정의 방식을 기록하며 대화상자 코드로만 사용됩니다. 0 = 이중 색상 그라데이션 1 = 단일 색상 그라데이션
453 | 색상 수: 0 = 솔리드 해치 2 = 그라데이션
460 | 그라데이션을 위한 라디안 단위의 회전 각도(기본값 = 0, 0)
461 | 그라데이션 정의로서 경계 해치 및 채우기 대화상자의 그라데이션 탭에 있는 [중심] 옵션에 해당합니다. 각 그라데이션에는 [이동함], [이동 안함]이라는 두 개의 정의가 있습니다. 이동 값은 이 두 정의를 혼합하여 사용하는 것에 대해 설명합니다. 값 0.0은 이동 안함 버전만 사용해야 하는 것을 의미하며 값 1.0은 이동함 버전만 사용해야 함을 의미합니다.
462 | 대화상자에서 사용될 색상 색조 값 코드(기본값 = 0.0, 범위는 0.0에서 1.0까지). 색상 색조 값은 그라데이션 색상이며, 해치 그룹 코드 452가 1로 설정된 경우 대화상자의 색조 정도를 조정합니다.
463 | 나중에 사용할 수 있도록 예약됨: 0 = 첫 번째 값 1 = 두 번째 값
470 | 문자열(기본값 = LINEAR)

이 단원의 항목

  • 경계 경로 데이터
  • 패턴 데이터


경계 경로 데이터

HATCH
HATCH
패턴 데이터
DXF 참조서 > ENTITIES 섹션 > HATCH >
경계 경로 데이터

각 해치 객체의 경계는 하나 이상의 세그먼트로 구성된 경로(또는 루프)를 사용해 정의됩니다. 경로 세그먼트 데이터는 해당 경로를 구성하는 도면요소 유형(들)에 따라 다릅니다. 각 경로 세그먼트는 고유한 그룹 코드 세트를 사용해 정의됩니다. 이 테이블에서 사용된 축약어 및 형식에 대한 정보는 본 참조서의 형식화 규칙을 참고하십시오.

해치 경계 경로 데이터 그룹 코드
그룹 코드 | 설명
92 | 경계 경로 유형 플래그(비트 코드화됨): 0 = 기본값, 1 = 외부, 2 = 폴리선 4 = 파생, 8 = 문자 상자, 16 = 최외곽
다양함 | 폴리선 경계 유형 데이터(경계가 폴리선인 경우에만). 아래의 폴리선 경계 데이터 테이블을 참고하십시오.
93 | 이 경계 경로의 모서리 개수(경계가 폴리선이 아닌 경우에만)
72 | 모서리 유형(경계가 폴리선이 아닌 경우에만): 1 = 선, 2 = 원형 호, 3 = 타원형 호, 4 = 스플라인
다양함 | 모서리 유형 데이터(경계가 폴리선이 아닌 경우에만). 아래에 있는 적절한 모서리 데이터 테이블을 참고하십시오.
97 | 원본 경계 객체의 개수
330 | 원본 경계 객체에 대한 참조(다중 항목)

폴리선 경계 데이터 그룹 코드
그룹 코드 | 설명
72 | Has bulge 플래그
73 | Is closed 플래그
93 | 폴리선 정점의 개수
10 | 정점 위치(OCS) DXF: X 값, APP: 2D 점(다중 항목)
20 | DXF: 정점 위치의 Y 값(OCS)(다중 항목)
42 | 팽창(선택 사항, 기본값 = 0)

선 모서리 데이터 그룹 코드
그룹 코드 | 설명
10 | 시작점(OCS) DXF: X 값, APP: 2D 점
20 | DXF: 시작점의 Y 값(OCS)
11 | 끝점(OCS) DXF: X 값, APP: 2D 점
21 | DXF: 끝점의 Y 값(OCS)

호 모서리 데이터 그룹 코드
그룹 코드 | 설명
10 | 중심점(OCS) DXF: X 값, APP: 2D 점
20 | DXF: 중심점의 Y 값(OCS)
40 | 반지름
50 | 시작 각도
51 | 끝 각도
73 | 시계 반대 방향 플래그입니다.

타원 모서리 데이터 그룹 코드
그룹 코드 | 설명
10 | 중심점(OCS) DXF: X 값, APP: 2D 점
20 | DXF: 중심점의 Y 값(OCS)
11 | 중심점에 상대적인 장축의 끝점(OCS) DXF: X 값, APP: 2D 점
21 | DXF: 장축 끝점의 Y 값(OCS)
40 | 단축의 길이(장축 길이에 대한 백분율)
50 | 시작 각도
51 | 끝 각도
73 | 시계 반대 방향 플래그입니다.

스플라인 모서리 데이터 그룹 코드
그룹 코드 | 설명
94 | 도
73 | 유리
74 | 주기적
95 | 매듭의 개수
96 | 조정점의 개수
40 | 매듭 값(다중 항목)
10 | 조정점(OCS) DXF: X 값, APP: 2D 점
20 | DXF: 조정점의 Y 값(OCS)
42 | 가중치(선택 사항, 기본값 = 1)


패턴 데이터

경계 경로 데이터
HATCH
HELIX
DXF 참조서 > ENTITIES 섹션 > HATCH >
패턴 데이터

다음 패턴 데이터 코드는 각 패턴 정의 선에 대해서 반복됩니다. 이 테이블에서 사용된 축약어 및 형식에 대한 정보는 본 참조서의 형식화 규칙을 참고하십시오.

해치 패턴 데이터 그룹 코드
그룹 코드 | 설명
53 | 패턴 선 각도
43 | 패턴 선 기준점, X 구성요소
44 | 패턴 선 기준점, Y 구성요소
45 | 패턴 선 간격띄우기, X 구성요소
46 | 패턴 선 간격띄우기, Y 구성요소
79 | 대시 길이 항목의 개수
49 | 대시 길이(다중 항목)


HELIX

패턴 데이터
ENTITIES 섹션
IMAGE
DXF 참조서 > ENTITIES 섹션 >
HELIX

다음 그룹 코드는 나선 도면요소에 적용됩니다. 여기에 설명되어 있는 그룹 코드 이외의 내용은 도면요소의 공용 그룹 코드를 참고하십시오. 이 테이블에서 사용된 축약어 및 형식에 대한 정보는 본 참조서의 형식화 규칙를 참고하십시오.

HELIX 그룹 코드
그룹 코드 | 설명
 | 스플라인 데이터
100 | 하위 클래스 표식기(AcDbHelix)
90 | 주요 릴리즈 번호
91 | 유지보수 릴리즈 번호
10, 20, 30 | 축 기준점
11, 21, 31 | 시작점
12, 22, 32 | 축 벡터
40 | 반지름
41 | 회전 수
42 | 회전 높이
290 | 방향성, 0 = 왼쪽, 1 = 오른쪽
280 | 유형 제한 0 = 회전 높이 제한 1 = 회전 제한 2 = 높이 제한


IMAGE

HELIX
ENTITIES 섹션
INSERT
DXF 참조서 > ENTITIES 섹션 >
IMAGE

다음 그룹 코드는 이미지 도면요소에 적용됩니다. 여기에 설명되어 있는 그룹 코드 이외의 내용은 도면요소의 공용 그룹 코드를 참고하십시오. 이 테이블에서 사용된 축약어 및 형식에 대한 정보는 본 참조서의 형식화 규칙을 참고하십시오.

이미지 그룹 코드
그룹 코드 | 설명
100 | 하위 클래스 표식기(AcDbRasterImage)
90 | 클래스 버전
10 | 삽입점(WCS) DXF: X 값, APP: 3D 점
20, 30 | DXF: 삽입점의 Y 및 Z 값(WCS)
11 | 단일 픽셀의 U 벡터(삽입점에서 시작하여 시각적으로 보이는 이미지의 맨 아래 쪽을 따라 가리킴)(WCS) DXF: X 값, APP: 3D 점
21, 31 | DXF: U 벡터의 Y 및 Z 값(WCS)
12 | 단일 픽셀의 V 벡터(삽입점에서 시작하여 시각적으로 보이는 이미지의 왼쪽 편을 따라 가리킴)(WCS) DXF: X 값, APP: 3D 점
22, 32 | DXF: V 벡터의 Y 및 Z 값(WCS)
13 | 픽셀 단위의 이미지 크기 DXF: U 값, APP: 2D 점(U 및 V 값)
23 | DXF: 픽셀 단위 이미지 크기의 V 값
340 | imagedef 객체에 대한 하드 참조
70 | 이미지 화면표시 특성: 1 = 이미지를 표시함 2 = 화면에 정렬되지 않을 때 이미지를 표시함 4 = 자르기 경계를 사용함 8 = 투명도를 켬
280 | 자르기 상태: 0 = 끄기, 1 = 켜기
281 | 밝기 값(0-100, 기본값 = 50)
282 | 대비 값(0-100, 기본값 = 50)
283 | 감쇄 값(0-100, 기본값 = 0)
360 | imagedef_reactor 객체에 대한 하드 참조
71 | 자르기 경계 유형. 1 = 직사각형, 2 = 다각형
91 | 다음에 올 자르기 경계 정점의 개수
14 | 자르기 경계 정점(OCS) DXF: X 값, APP: 2D 점(다중 항목) 주 1)직사각형 자르기 경계 유형에 대해서는 두 개의 반대 구석을 지정해야 합니다. 기본값은 (-0.5,-0.5), (size.x-0.5, size.y-0.5)입니다. 2) 다각형 자르기 경계 유형의 경우, 3개 이상의 정점을 지정해야 합니다. 다각형 정점은 순차적으로 나열해야 합니다.
24 | DXF: 자르기 경계 정점의 Y 값(OCS)(다중 항목)


INSERT

IMAGE
ENTITIES 섹션
LEADER
DXF 참조서 > ENTITIES 섹션 >
INSERT

다음 그룹 코드는 삽입(블록 참조) 도면요소에 적용됩니다. 여기에 설명되어 있는 그룹 코드 이외의 내용은 도면요소의 공용 그룹 코드를 참고하십시오. 이 테이블에서 사용된 축약어 및 형식에 대한 정보는 본 참조서의 형식화 규칙을 참고하십시오.

삽입 그룹 코드
그룹 코드 | 설명
100 | 하위 클래스 표식기(AcDbBlockReference)
66 | 가변 attributes-follow 플래그(선택 사항, 기본값 = 0), attributes-follow 플래그의 값이 1이면, 삽입 다음에 일련의 속성 도면요소가 오며 seqend 도면요소로 종료됩니다.
2 | 블록 이름
10 | 삽입점(OCS) DXF: X 값, APP: 3D 점
20, 30 | DXF: 삽입점의 Y 및 Z 값(OCS)
41 | X 축척 비율(선택 사항, 기본값 = 1)
42 | Y 축척 비율(선택 사항, 기본값 = 1)
43 | Z 축척 비율(선택 사항, 기본값 = 1)
50 | 회전 각도(선택 사항, 기본값 = 0)
70 | 열 개수(선택 사항, 기본값 = 1)
71 | 행 개수(선택 사항, 기본값 = 1)
44 | 열 간격(선택 사항, 기본값 = 0)
45 | 행 간격(선택 사항, 기본값 = 0)
210 | 돌출 방향(선택 사항, 기본값 = 0, 0, 1) DXF: X 값, APP: 3D 벡터
220, 230 | DXF: 돌출 방향의 Y 및 Z 값(선택 사항)


LEADER

INSERT
ENTITIES 섹션
LIGHT
DXF 참조서 > ENTITIES 섹션 >
LEADER

다음 그룹 코드는 지시선 도면요소에 적용됩니다. 여기에 설명되어 있는 그룹 코드 이외의 내용은 도면요소의 공용 그룹 코드를 참고하십시오. 이 테이블에서 사용된 축약어 및 형식에 대한 정보는 본 참조서의 형식화 규칙을 참고하십시오.

지시선 그룹 코드
그룹 코드 | 설명
100 | 하위 클래스 표식기(AcDbLeader)
3 | 치수 스타일 이름
71 | 화살촉 플래그: 0 = 작동 불가능, 1 = 작동 가능
72 | 지시선 경로 유형: 0 = 직선 세그먼트, 1 = 스플라인
73 | 지시선 작성 플래그(기본값 = 3): 0 = 문자 주석과 함께 작성됨 1 = 공차 주석과 함께 작성됨 2 = 블록 참조 주석과 함께 작성됨 3 = 주석 없이 작성됨
74 | 갈고리선 방향 플래그: 0 = 갈고리선(또는 스플라인 지시선에 대한 접선의 끝)이 수평 벡터의 반대 방향입니다. 1 = 갈고리선(또는 스플라인 지시선에 대한 접선의 끝)이 수평 벡터와 같은 방향입니다(코드 75 참고).
75 | 갈고리선 플래그: 0 = 갈고리선 없음, 1 = 갈고리선 있음
40 | 문자 주석 높이
41 | 문자 주석 폭
76 | 지시선 내의 정점 개수(OPEN에서는 무시됨)
10 | 정점 좌표(각 정점당 하나의 항목) DXF: X 값, APP: 3D 점
20, 30 | DXF: 정점 좌표의 Y 및 Z 값
77 | 지시선의 DIMCLRD가 BYBLOCK인 경우 사용할 색상
340 | 연관된 주석에 대한 하드 참조(여러 줄 문자, 공차 또는 삽입 도면요소)
210 | 법선 벡터 DXF: X 값, APP: 3D 벡터
220, 230 | DXF: 법선 벡터의 Y 및 Z 값
211 | 지시선의 “수평” 방향 DXF: X 값, APP: 3D 벡터
221, 231 | DXF: 지시선에 대한 “수평” 방향의 Y 및 Z 값
212 | 블록 참조 삽입점으로부터의 마지막 지시선 정점 간격띄우기 DXF: X 값, APP: 3D 벡터
222, 232 | DXF: 간격띄우기의 Y 및 Z 값
213 | 주석 배치점으로부터의 마지막 지시선 정점 간격띄우기 DXF: X 값, APP: 3D 벡터
223, 233 | DXF: 간격띄우기의 Y 및 Z 값

이 도면요소에 대해 치수가 재지정된 적이 있었던 경우, 응용프로그램 ID "ACAD"에 속하는 확장 데이터가 지시선 도면요소 다음에 표시됩니다. 치수 스타일 재지정을 참고하십시오.


LIGHT

LEADER
ENTITIES 섹션
LINE
DXF 참조서 > ENTITIES 섹션 >
LIGHT

다음 그룹 코드는 광원 도면요소에 적용됩니다. 여기에 설명되어 있는 그룹 코드 이외의 내용은 도면요소의 공용 그룹 코드를 참고하십시오. 이 테이블에서 사용된 축약어 및 형식에 대한 정보는 본 참조서의 형식화 규칙를 참고하십시오.

조명 그룹 코드
그룹 코드 | 설명
100 | 하위 클래스 표식기(AcDbLight)
90 | 버전 번호
1 | 광원 이름
70 | 광원 유형(거리 = 1, 점 = 2, 스폿 = 3)
290 | 상태
291 | 그림 문자 플롯
40 | 조도
10 | 광원 위치 DXF: X 값, APP: 3D 점
20, 30 | DXF: 광원 위치의 X, Y 및 Z 값
11 | 대상 위치 DXF: X 값, APP: 3D 점
21, 31 | DXF: 대상 위치의 X, Y 및 Z 값
72 | 감쇠 유형 0 = 없음 1 = 역 선형 2 = 역 제곱
292 | 감쇠 한계 사용
41 | 감쇠 시작 한계
42 | 감쇠 끝 한계
50 | 핫스폿 각도
51 | 감소 각도
293 | 그림자 주사
73 | 그림자 유형 0 = 광선추적된 그림자 1 = 그램자 맵
91 | 그림자 맵 크기
280 | 그림자 맵 부드러움


LINE

LIGHT
ENTITIES 섹션
LWPOLYLINE
DXF 참조서 > ENTITIES 섹션 >
LINE

다음 그룹 코드는 선 도면요소에 적용됩니다. 여기에 설명되어 있는 그룹 코드 이외의 내용은 도면요소의 공용 그룹 코드를 참고하십시오. 이 테이블에서 사용된 축약어 및 형식에 대한 정보는 본 참조서의 형식화 규칙을 참고하십시오.

선 그룹 코드
그룹 코드 | 설명
100 | 하위 클래스 표식기(AcDbLine)
39 | 두께(선택 사항, 기본값 = 0)
10 | 시작점(WCS) DXF: X 값, APP: 3D 점
20, 30 | DXF: 시작점의 Y 및 Z 값(WCS)
11 | 끝점(WCS) DXF: X 값, APP: 3D 점
21, 31 | DXF: 끝점의 Y 및 Z 값(WCS)
210 | 돌출 방향(선택 사항, 기본값 = 0, 0, 1) DXF: X 값, APP: 3D 벡터
220, 230 | DXF: 돌출 방향의 Y 및 Z 값(선택 사항)


LWPOLYLINE

LINE
ENTITIES 섹션
MLINE
DXF 참조서 > ENTITIES 섹션 >
LWPOLYLINE

다음 그룹 코드는 lwpolyline 도면요소에 적용됩니다. 여기에 설명되어 있는 그룹 코드 이외의 내용은 도면요소의 공용 그룹 코드를 참고하십시오. 이 테이블에서 사용된 축약어 및 형식에 대한 정보는 본 참조서의 형식화 규칙을 참고하십시오.

Lwpolyline 그룹 코드
그룹 코드 | 설명
100 | 하위 클래스 표식기(AcDbPolyline)
90 | 정점의 개수
70 | 폴리선 플래그(비트 코드화됨), 기본값은 0: 1 = 닫힌 폴리선, 128 = 폴리선 생성
43 | 고정 폭(선택 사항, 기본값 = 0) 다양한 폭(코드 40 및/또는 41)이 설정된 경우에는 사용되지 않음
38 | 고도(선택 사항, 기본값 = 0)
39 | 두께(선택 사항, 기본값 = 0)
10 | 정점 좌표(OCS), 다중 항목, 각 정점당 하나의 항목 DXF: X 값, APP: 2D 점
20 | DXF: Y 값 정점 좌표(OCS), 다중 항목, 각 정점당 하나의 항목
40 | 시작 부분의 폭(각 정점당 하나의 항목씩 여러 개의 항목이 있음)(선택 사항, 기본값 = 0, 다중 항목). 고정 폭(코드 43)이 설정된 경우에는 사용되지 않습니다.
41 | 끝 부분의 폭(각 정점당 하나의 항목씩 여러 개의 항목이 있음)(선택 사항, 기본값 = 0, 다중 항목). 고정 폭(코드 43)이 설정된 경우에는 사용되지 않습니다.
42 | 팽창(각 정점당 하나의 항목씩 여러 개의 항목이 있음)(선택 사항, 기본값 = 0).
210 | 돌출 방향(선택 사항, 기본값 = 0, 0, 1) DXF: X 값, APP: 3D 벡터
220, 230 | DXF: 돌출 방향의 Y 및 Z 값(선택 사항)


MLINE

LWPOLYLINE
ENTITIES 섹션
MLEADER
DXF 참조서 > ENTITIES 섹션 >
MLINE

다음 그룹 코드는 다중선 도면요소에 적용됩니다. 여기에 설명되어 있는 그룹 코드 이외의 내용은 도면요소의 공용 그룹 코드를 참고하십시오. 이 테이블에서 사용된 축약어 및 형식에 대한 정보는 본 참조서의 형식화 규칙을 참고하십시오.

다중선 그룹 코드
그룹 코드 | 설명
100 | 하위 클래스 표식기(AcDbMline)
2 | 최대 32 문자로 구성된 문자열. 다중선에 사용된 스타일의 이름. 이 스타일의 항목은 MLINESTYLE 사전에 있어야 합니다. MLINESTYLE 사전의 연관된 항목을 업데이트하지 않은 상태에서 이 필드를 수정하지 마십시오.
340 | MLINESTYLE 객체의 포인터 핸들/ID
40 | 축척 비율
70 | 자리맞추기: 0 = 맨 위, 1 = 0, 2 = 맨 아래
71 | 플래그(비트 코드화된 값): 1 = 최소 하나의 정점을 가짐(코드 72는 0보다 큼) 2 = 닫힘 4 = 시작 부분의 끝막음 억제 8 = 끝 부분의 끝막음 억제
72 | 정점의 개수
73 | MLINESTYLE 정의에 있는 요소의 개수
10 | 시작점(WCS) DXF: X 값, APP: 3D 점
20, 30 | DXF: 시작점의 Y 및 Z 값(WCS)
210 | 돌출 방향(선택 사항, 기본값 = 0, 0, 1) DXF: X 값, APP: 3D 벡터
220, 230 | DXF: 돌출 방향의 Y 및 Z 값(선택 사항)
11 | 정점 좌표(다중 항목, 각 정점당 하나의 항목) DXF: X 값, APP: 3D 점
21, 31 | DXF: 정점 좌표의 Y 및 Z 값
12 | 이 정점에서 시작하는 세그먼트의 방향 벡터(각 정점당 하나의 항목씩 여러 개의 항목이 있음) DXF: X 값, APP: 3D 벡터
22, 32 | DXF: 이 정점에서 시작하는 세그먼트의 방향 벡터의 Y 및 Z 값
13 | 이 정점에서 연귀의 방향 벡터(각 정점당 하나의 항목씩 여러 개의 항목이 있음) DXF: X 값, APP: 3D 벡터
23, 33 | DXF: 연귀의 방향 벡터의 Y 및 Z 값
74 | 이 요소의 매개변수 개수(세그먼트의 각 요소에 대해 반복됨)
41 | 요소 매개변수(이전 코드 74를 기준으로 반복됨)
75 | 이 요소의 영역 채우기 매개변수 개수(세그먼트의 각 요소에 대해 반복됨)
42 | 영역 채우기 매개변수(이전 코드 75를 기준으로 반복됨)

그룹 코드 41 매개변수화는 그룹 코드 41당 하나의 실수로 구성된 실수값 리스트입니다. 이 리스트에는 0개 이상의 항목이 포함됩니다. 첫 번째 그룹 코드 41 값은 연귀 벡터를 따라 세그먼트 정점에서 시작하여 연귀 벡터를 교차하는 선 요소의 경로 지점까지의 거리입니다. 그 다음 그룹 코드 41 값은 선 요소의 경로를 따라 첫 번째 그룹 코드 41에서 정의된 점에서 시작하여 선 요소의 실제 시작 부분까지의 거리입니다. 그 다음은 선 요소의 시작 부분에서 선 요소의 첫 번째 중단(또는 절단) 지점까지의 거리입니다. 후속 그룹 코드 41 값은 다중선의 세그먼트에서 선 요소의 시작점 및 끝점을 계속 나열합니다. 선종류는 그룹 41 리스트에 영향을 주지 않습니다.

그룹 코드 42 매개변수화도 실수값 리스트입니다. 그룹 코드 41의 매개변수화와 비슷하게, 이 다중선 세그먼트에 대한 채우기 영역의 매개변수화를 설명합니다. 값은 41 매개변수와 동일하게 해석되며 다중선 세그먼트의 모든 선 요소에 대한 전체 값을 취할 경우, 해당 값에 의해 다중선 세그먼트의 채우기 영역 경계가 정의됩니다.

그룹 코드 42 메커니즘 사용에 대한 일반적인 예는 채워진 다중선에 대해 채워지지 않은 다중선이 교차할 경우 채워진 다중선이 교차 영역에서 채워지지 않게 표시되도록 mledit을 사용하는 경우입니다. 이로 인해, 영향을 받은 다중선 세그먼트에는 각 선 요소당 두 개의 그룹 42가 만들어집니다. 한 그룹은 채우기 중단용이며 다른 그룹은 채우기 시작용입니다.

다중선 도면요소 및 다중선 스타일 객체의 2 그룹 코드는 중복 필드입니다. 이런 그룹을 안전하게 읽을 수 있고 그룹의 값을 사용할 수 있다 하더라도 어떤 상황에서든 그룹을 수정해서는 안됩니다. 수정할 수 있는 올바른 필드는 다음과 같습니다.

다중선

같은 객체에서 적절한 MLINESTYLE 객체를 나타내는 340 그룹.

다중선 스타일

현재 다중선 스타일의 핸들 또는 도면요소 이름을 가진 350 그룹 앞에 있는 MLINESTYLE 사전의 3 그룹 값.


MLEADER

MLINE
ENTITIES 섹션
MLEADERSTYLE
DXF 참조서 > ENTITIES 섹션 >
MLEADER

다음 그룹 코드는 다중 지시선 도면요소에 적용됩니다. 여기에 설명되어 있는 그룹 코드 이외의 내용은 도면요소의 공용 그룹 코드를 참고하십시오. 이 테이블에서 사용된 축약어 및 형식에 대한 정보는 본 참조서의 형식화 규칙를 참고하십시오.

다중 지시선 그룹 코드
그룹 코드 | 설명
170 | 컨텐츠 유형
171 | DrawMLeaderOrder 유형
172 | DrawLeaderOrder 유형
90 | MaxLeader 세그먼트 점
40 | 첫 번째 세그먼트 각도 구속조건
41 | 두 번째 세그먼트 각도 구속조건
173 | LeaderLineType
91 | LeaderLineColor
340 | LeaderLineType ID
92 | LeaderLineWeight
290 | 연결선 사용
42 | 연결선 간격
291 | 도그레그 지시선 사용
43 | 도그레그 지시선 길이
3 | 다중 지시선 스타일 설명
341 | 화살촉 ID
44 | 화살촉 크기
300 | 기본 여러 줄 문자 컨텐츠
342 | mTextStyleId
174 | 문자 왼쪽 부착 유형
175 | 문자 각도 유형
176 | 문자 정렬 유형
178 | 문자 오른쪽 부착 유형
93 | 문자 색상
45 | 문자 높이
292 | 프레임 문자 사용
297 | 항상 왼쪽으로 문자 정렬
46 | 공간 정렬
343 | 블록 컨텐츠 ID
94 | 블록 컨텐츠 색
47 | X축의 블록 컨텐츠 축척
49 | Y축의 블록 컨텐츠 축척
140 | Z축의 블록 컨텐츠 축척
293 | 블록 컨텐츠 축척 사용
141 | 블록 컨텐츠 회전
294 | 블록 컨텐츠 회전 사용
177 | 블록 컨텐츠 연결 유형
142 | 축척
295 | 속성 값 덮어쓰기
296 | 주석입니다.
143 | 끊기 간격 크기


MLEADERSTYLE

MLEADER
ENTITIES 섹션
공통 MLeaderStyle 그룹 코드
DXF 참조서 > ENTITIES 섹션 >
MLEADERSTYLE

MLeaderStyle 도면요소 정의는 모든 MLeaderStyle 스타일에 공통인 그룹 코드와 해당 유형에 특정한 코드로 구성됩니다.

이 단원의 항목

  • 공통 MLeaderStyle 그룹 코드
  • MLeaderStyle 컨텍스트 데이터 그룹 코드
  • MLeaderStyle 지시선 노드 그룹 코드
  • MLeaderStyle 지시선 그룹 코드


공통 MLeaderStyle 그룹 코드

MLEADERSTYLE
MLEADERSTYLE
MLeaderStyle 컨텍스트 데이터 그룹 코드
DXF 참조서 > ENTITIES 섹션 > MLEADERSTYLE >
공통 MLeaderStyle 그룹 코드

다음 그룹 코드는 모든 MLeaderStyle 도면요소 유형에 적용됩니다. 여기에 설명되어 있는 그룹 코드 이외의 내용은 도면요소의 공용 그룹 코드를 참고하십시오. 이 테이블에서 사용된 축약어 및 형식에 대한 정보는 본 참조서의 형식화 규칙를 참고하십시오.

공통 MLeaderStyle 선 그룹 코드 |
그룹 코드 | 설명
340 | 지시선 스타일 ID
90 | 특성 재지정 플래그
170 | LeaderLineType
91 | Leade LineColor
341 | LeaderLineTypeID
171 | 지시선 가중치
290 | 연결선 사용
291 | 도그레그 지시선 사용
41 | 도그레그 지시선 길이
342 | 화살촉 ID
42 | 화살촉 크기
172 | 컨텐츠 유형
343 | 문자 스타일 ID
173 | 문자 왼쪽 부착 유형
95 | 문자 오른쪽 부착 유형
174 | 문자 각도 유형
175 | 문자 정렬 유형
92 | 문자 색상
292 | 프레임 문자 사용
344 | 블록 컨텐츠 ID
93 | 블록 컨텐츠 색
10 | 블록 컨텐츠 축척
43 | 블록 컨텐츠 회전
176 | 블록 컨텐츠 연결 유형
293 | 주석 축척 사용
94 | 화살촉 색인
345 | 화살촉 ID
330 | 블록 속성 ID
177 | 블록 속성 색인
44 | 블록 속성 폭
302 | 블록 속성 문자열
294 | 음수 문자 방향
178 | IPE에서 문자 정렬
179 | 문자 부착 점


MLeaderStyle 컨텍스트 데이터 그룹 코드

공통 MLeaderStyle 그룹 코드
MLEADERSTYLE
MLeaderStyle 지시선 노드 그룹 코드
DXF 참조서 > ENTITIES 섹션 > MLEADERSTYLE >
MLeaderStyle 컨텍스트 데이터 그룹 코드

다음 그룹 코드는 모든 MLeaderStyle 도면요소 유형의 컨텍스트 데이터에 적용됩니다. 여기에 설명되어 있는 그룹 코드 이외의 내용은 도면요소의 공용 그룹 코드를 참고하십시오. 이 테이블에서 사용된 축약어 및 형식에 대한 정보는 본 참조서의 형식화 규칙를 참고하십시오.

MLeaderStyle 컨텍스트 데이터 그룹 코드
그룹 코드 | 설명
40 | 컨텐츠 축척
10,20,30 | 컨텐츠 기본 위치
41 | 문자 높이
140 | 화살촉 크기
145 | 연결선 간격
290 | hasMText
304 | 기본 문자 컨텐츠
11,21,31 | 문자 법선 방향
340 | 문자 스타일 ID
12,22,32 | 문자 위치
13,23,33 | 문자 위치
42 | 문자 회전
43 | 문자 폭
44 | 문자 높이
45 | 문자 선 간격 비율
170 | 문자 선 간격 스타일
90 | 문자 색상
171 | 문자 부착
172 | 문자 흐름 방향
91 | 문자 배경색
141 | 문자 배경 축척 비율
92 | 문자 배경 투명도
291 | 문자 배경색 설정
292 | 문자 배경 채우기 설정
173 | 문자 열 유형
293 | 문자 자동 높이 사용
142 | 문자 열 폭
143 | 문자 열 사이 여백 폭
294 | 문자 열 흐름 반전
144 | 문자 열 높이
295 | 문자 사용 단어 끊기
296 | HasBlock
341 | 블록 컨텐츠 ID
14,24,34 | 블록 컨텐츠 법선 방향
15,25,35 | 블록 컨텐츠 위치
16 | 블록 컨텐츠 축척
46 | 블록 컨텐츠 회전
93 | 블록 컨텐츠 색
47 | 블록 변환 행렬
110 | 다중 지시선 평면 원점
111 | 다중 지시선 평면 X축 방향
112 | 다중 지시선 평면 Y축 방향
297 | 다중 지시선 평면 법선 반전
10,20,30 | 정점
90 | 중단점 색인
43 | 문자 폭
44 | 문자 높이
45 | 문자 선 간격 비율
170 | 문자 선 간격 스타일
90 | 문자 색상
171 | 문자 부착
172 | 문자 흐름 방향
91 | 문자 배경색
141 | 문자 배경 축척 비율
92 | 문자 배경 투명도
291 | 문자 배경색 설정
292 | 문자 배경 채우기 설정
173 | 문자 열 유형
293 | 문자 자동 높이 사용
142 | 문자 열 폭
143 | 문자 열 사이 여백 폭
294 | 문자 열 흐름 반전
144 | 문자 열 높이
295 | 문자 사용 단어 끊기
296 | HasBlock
341 | 블록 컨텐츠 ID
14,24,34 | 블록 컨텐츠 법선 방향
15,25,35 | 블록 컨텐츠 위치
16 | 블록 컨텐츠 축척
46 | 블록 컨텐츠 회전
93 | 블록 컨텐츠 색
47 | 블록 변환 행렬
110 | 다중 지시선 평면 원점
111 | 다중 지시선 평면 X축 방향
112 | 다중 지시선 평면 Y축 방향
297 | 다중 지시선 평면 법선 반전


MLeaderStyle 지시선 노드 그룹 코드

MLeaderStyle 컨텍스트 데이터 그룹 코드
MLEADERSTYLE
MLeaderStyle 지시선 그룹 코드
DXF 참조서 > ENTITIES 섹션 > MLEADERSTYLE >
MLeaderStyle 지시선 노드 그룹 코드

다음 그룹 코드는 모든 MLeaderStyle 도면요소 유형의 지시선 노드에 적용됩니다. 여기에 설명되어 있는 그룹 코드 이외의 내용은 도면요소의 공용 그룹 코드를 참고하십시오. 이 테이블에서 사용된 축약어 및 형식에 대한 정보는 본 참조서의 형식화 규칙를 참고하십시오.

MLeaderStyle 지시선 노드 그룹 코드 |
그룹 코드 | 설명
290 | Has Set 마지막 지시선 점
291 | Has Set 도그레그 지시선 벡터
10,20,30 | 마지막 지시선 점
11,21,31 | 도그레그 지시선 벡터
12,22,32 | 시작점 끊기
13,23,33 | 끝점 끊기
90 | 지시선 분기 색인
40 | 도그레그 지시선 길이


MLeaderStyle 지시선 그룹 코드

MLeaderStyle 지시선 노드 그룹 코드
MLEADERSTYLE
MTEXT
DXF 참조서 > ENTITIES 섹션 > MLEADERSTYLE >
MLeaderStyle 지시선 그룹 코드

다음 그룹 코드는 모든 MLeaderStyle 도면요소 유형의 지시선에 적용됩니다. 여기에 설명되어 있는 그룹 코드 이외의 내용은 도면요소의 공용 그룹 코드를 참고하십시오. 이 테이블에서 사용된 축약어 및 형식에 대한 정보는 본 참조서의 형식화 규칙를 참고하십시오.

지시선 그룹 코드 |
그룹 코드 | 설명
10,20,30 | 정점
90 | 중단점 색인
11,21,31 | 시작점 끊기
12,22,32 | 끝점 끊기
91 | 지시선 색인


MTEXT

MLeaderStyle 지시선 그룹 코드
ENTITIES 섹션
OLEFRAME
DXF 참조서 > ENTITIES 섹션 >
MTEXT

다음 그룹 코드는 여러 줄 문자 도면요소에 적용됩니다. 여기에 설명되어 있는 그룹 코드 이외의 내용은 도면요소의 공용 그룹 코드를 참고하십시오. 이 테이블에서 사용된 축약어 및 형식에 대한 정보는 본 참조서의 형식화 규칙을 참고하십시오.

여러 줄 문자 그룹 코드
그룹 코드 | 설명
100 | 하위 클래스 표식기(AcDbMText)
10 | 삽입점 DXF: X 값, APP: 3D 점
20, 30 | DXF: 삽입점의 Y 및 Z 값
40 | 명목상의(초기) 문자 높이
41 | 참조 직사각형 폭
71 | 부착 점: 1 = 맨 위 왼쪽, 2 = 맨 위 중심, 3 = 맨 위 오른쪽 4 = 중간 왼쪽, 5 = 중간 중심, 6 = 중간 오른쪽 7 = 맨 아래 왼쪽, 8 = 맨 아래 중심, 9 = 맨 아래 오른쪽
72 | 도면 방향: 1 = 왼쪽에서 오른쪽으로 3 = 맨 위에서 맨 아래로 5 = 스타일별(흐름 방향은 관련 문자 스타일에서 상속됩니다.)
1 | 문자열. 250자 미만의 문자열인 경우, 모든 문자는 그룹 1에 표시됩니다. 문자열이 250자를 초과하는 경우, 250 문자 묶음으로 문자열이 나누어져 하나 이상의 그룹 3 코드에 표시됩니다. 그룹 3 코드가 사용되면 마지막 그룹이 그룹 1이며 250개보다 적은 수의 문자를 갖습니다.
3 | 추가 문자(항상 250 문자 묶음에 포함됨)(선택 사항)
7 | 문자 스타일 이름(제공되지 않은 경우에는 STANDARD)(선택 사항)
210 | 돌출 방향(선택 사항, 기본값 = 0, 0, 1) DXF: X 값, APP: 3D 벡터
220, 230 | DXF: 돌출 방향의 Y 및 Z 값(선택 사항)
11 | X축 방향 벡터(WCS) DXF: X 값, APP: 3D 벡터 DXF 입력으로 전달될 그룹 코드 50(라디안 단위의 회전 각도)이 해당 방향 벡터로 변환됩니다(코드 50과 코드 11, 21, 31이 모두 전달된 경우에는 마지막 코드가 사용됩니다). 이 값은 문자 객체로부터의 변환을 편리하게 하기 위해 제공됩니다.
21, 31 | DXF: X축 방향 벡터의 Y 및 Z 값(WCS)
42 | 여러 줄 문자 도면요소를 구성하는 문자의 가로 너비. 이 값은 항상 그룹 코드 41의 값 이하입니다(읽기 전용이며 제공된 경우 무시됨)
43 | 여러 줄 문자 도면요소의 수직 높이(읽기 전용이며 제공된 경우 무시됨)
50 | 라디안 단위의 회전 각도
73 | 여러 줄 문자 행 간격 스타일(선택 사항): 1 = 최소(더 큰 문자가 재지정됨) 2 = 정확함(더 큰 문자가 재지정되지 않음)
44 | 여러 줄 문자 행 간격 비율(선택 사항): 적용할 기본(3-on-5) 선 간격의 백분율. 적합한 값의 범위는 0.25에서 4.00까지 입니다.
90 | 배경 채우기 설정: 0 = 배경 채우기 끄기 1 = 배경 채우기 색상 사용 2 = 배경 채우기 색상으로 도면 윈도우 색상 사용
63 | 배경 색상(색상 색인 번호일 경우)
420-429 | 배경 색상(RGB 색상일 경우)
430-439 | 배경 색상(색상 이름일 경우)
45 | 채우기 상자 축척(선택 사항): 문자 주변에 있는 경계의 정도를 결정합니다.
63 | 배경 채우기 색상(선택 사항): 그룹 코드 90이 1일 때 배경 채우기에 사용할 색상입니다.
441 | 배경 채우기 색상의 투명도(구현되지 않음)
75 | 열 유형
76 | 열 개수
78 | 열 흐름 반전
79 | 열 자동 높이
48 | 열 폭
49 | 열 사이 여백
50 | 열 길이, 이 코드 다음에는 열 개수(Int16)와 열 높이 수가 옵니다.

여러 줄 문자 도면요소 다음에 나오는 "DCO15" 응용프로그램 ID를 가진 확장 데이터. 여기에는 dbConnect 기능과 관련된 정보가 들어 있습니다.


OLEFRAME

MTEXT
ENTITIES 섹션
OLE2FRAME
DXF 참조서 > ENTITIES 섹션 >
OLEFRAME

다음 그룹 코드는 oleframe 도면요소에 적용됩니다. 여기에 설명되어 있는 그룹 코드 이외의 내용은 도면요소의 공용 그룹 코드를 참고하십시오. 이 테이블에서 사용된 축약어 및 형식에 대한 정보는 본 참조서의 형식화 규칙을 참고하십시오.

Oleframe 그룹 코드
그룹 코드 | 설명
100 | 하위 클래스 표식기(AcDbOleFrame)
70 | OLE 버전 번호
90 | 이진 데이터의 길이
310 | 이진 데이터(다중선)
1 | OLE 데이터의 끝(문자열 “OLE”)


OLE2FRAME

OLEFRAME
ENTITIES 섹션
POINT
DXF 참조서 > ENTITIES 섹션 >
OLE2FRAME

다음 그룹 코드는 ole2frame 도면요소에 적용됩니다. 이 정보는 읽기 전용입니다. OPEN 작업 시, 값은 OLE 이진 객체의 일부이므로 무시되고 접근 기능을 사용하여 얻을 수 있습니다. 여기에 설명되어 있는 그룹 코드 이외의 내용은 도면요소의 공용 그룹 코드를 참고하십시오. 이 테이블에서 사용된 축약어 및 형식에 대한 정보는 본 참조서의 형식화 규칙을 참고하십시오.

Ole2frame 그룹 코드
그룹 코드 | 설명
100 | 하위 클래스 표식기(AcDbOle2Frame)
70 | OLE 버전 번호
3 | 이진 데이터의 길이
10 | 왼쪽 위 구석(WCS) DXF: X 값, APP: 3D 점
20, 30 | DXF: 왼쪽 위 구석의 Y 및 Z 값(WCS)
11 | 오른쪽 아래 구석(WCS) DXF: X 값, APP: 3D 점
21, 31 | DXF: 오른쪽 아래 구석의 Y 및 Z 값(WCS)
71 | OLE 객체 유형, 1 = 링크, 2 = 포함, 3 = 정적
72 | 타일 모드 설명자: 0 = 객체가 모형 공간에 있습니다. 1 = 객체가 도면 공간에 있습니다.
90 | 이진 데이터의 길이
310 | 이진 데이터(다중선)
1 | OLE 데이터의 끝(문자열 “OLE”)

예제 DXF 출력:

    OLE2FRAME
      5
    2D
    100
    AcDbEntity
     67
         1
      8
    0
    100
    AcDbOle2Frame
     70
         2
      3
    Paintbrush Picture
     10
    4.43116
     20
    5.665992
     30
    0.0
     11
    6.4188
     21
    4.244939
     31
    0.0
     71
         2
     72
         1
     90
        23680
    310 0155764BD60082B91140114B08C8F9A916400000000000000000506DC0D0D9AC
    310
    1940114B08C8F9A916400000000000000000506DC0D0D9AC194002303E5CD1FA
    310
    10400000000000000000764BD60082B9114002303E5CD1FA1040000000000000
    ...
    ...
AutoLISP entnext 함수 예제 출력:
명령:  (setq e (entget e3))
    ((-1 . <도면요소 이름: 7d50428>) (0 . "OLE2FRAME") (5 . "2D")
    (100 . "AcDbEntity") (67 . 1) (8 . "0") (100 . AcDbOle2Frame
    (70 . 2) (3 "Paintbrush Picture") (10 4.43116 5.66599 0.0)
    (11 6.4188 4.24494 0.0) (71 . 2) (72 . 1))


POINT

OLE2FRAME
ENTITIES 섹션
POLYLINE
DXF 참조서 > ENTITIES 섹션 >
POINT

다음 그룹 코드는 점 도면요소에 적용됩니다. 여기에 설명되어 있는 그룹 코드 이외의 내용은 도면요소의 공용 그룹 코드를 참고하십시오. 이 테이블에서 사용된 축약어 및 형식에 대한 정보는 본 참조서의 형식화 규칙을 참고하십시오.

점 그룹 코드
그룹 코드 | 설명
100 | 하위 클래스 표식기(AcDbPoint)
10 | 점 위치(WCS) DXF: X 값, APP: 3D 점
20, 30 | DXF: 점 위치의 Y 및 Z 값(WCS)
39 | 두께(선택 사항, 기본값 = 0)
210 | 돌출 방향(선택 사항, 기본값 = 0, 0, 1) DXF: X 값, APP: 3D 벡터
220, 230 | DXF: 돌출 방향의 Y 및 Z 값(선택 사항)
50 | 점이 그려질 때 활성인 UCS에 대한 X축의 각도(선택 사항, 기본값 = 0), PDMODE 값이 0이 아닐 때 사용됨


POLYLINE

POINT
ENTITIES 섹션
폴리면 메쉬
DXF 참조서 > ENTITIES 섹션 >
POLYLINE

다음 그룹 코드는 폴리선 도면요소에 적용됩니다. 여기에 설명되어 있는 그룹 코드 이외의 내용은 도면요소의 공용 그룹 코드를 참고하십시오. 이 테이블에서 사용된 축약어 및 형식에 대한 정보는 본 참조서의 형식화 규칙을 참고하십시오.

폴리선 그룹 코드
그룹 코드 | 설명
100 | 하위 클래스 표식기(AcDb2dPolyline 또는 AcDb3dPolyline)
66 | 구형, 이전에는 “뒤에 오는 도면요소 플래그”였음(선택 사항, 제공될 경우 무시)
10 | DXF: 항상 0 APP: “더미” 점으로, X 및 Y 값은 항상 0이며 Z 값은 폴리선의 고도입니다(2D일 경우 OCS, 3D일 경우 WCS).
20 | DXF: 항상 0
30 | DXF: 폴리선의 고도(2D일 경우 OCS, 3D일 경우 WCS)
39 | 두께(선택 사항, 기본값 = 0)
70 | 폴리선 플래그(비트 코드화됨, 기본값 = 0): 1 = 닫힌 폴리선입니다(또는 M 방향에서 닫힌 다각형 메쉬임). 2 = 곡선 맞춤 정점이 추가되었습니다. 4 = 스플라인 맞춤 정점이 추가되었습니다. 8 = 3D 폴리선입니다. 16 = 3D 다각형 메쉬입니다. 32 = 다각형 메쉬가 N 방향에서 닫힙니다. 64 = 폴리선은 폴리면 메쉬입니다. 128 = 폴리선의 정점 주변에 선종류 패턴이 연속적으로 생성됩니다.
40 | 기본 시작 폭(선택 사항, 기본값 = 0)
41 | 기본 끝 폭(선택 사항, 기본값 = 0)
71 | 다각형 메쉬 M 정점 개수(선택 사항, 기본값 = 0)
72 | 다각형 메쉬 N 정점 개수(선택 사항, 기본값 = 0)
73 | 부드러운 곡면 M 밀도(선택 사항, 기본값 = 0)
74 | 부드러운 곡면 N 밀도(선택 사항, 기본값 = 0)
75 | 곡선 및 부드러운 곡면 유형(선택 사항, 기본값 = 0), 정수 코드이며 비트 코드화되지 않음. 0 = 부드러운 곡면 맞춤을 안함 5 = 2차원 B 스플라인 곡면 6 = 3차원 B 스플라인 곡면 8 = 베지어 곡면
210 | 돌출 방향(선택 사항, 기본값 = 0, 0, 1) DXF: X 값, APP: 3D 벡터
220, 230 | DXF: 돌출 방향의 Y 및 Z 값(선택 사항)

"AUTOCAD_POSTSCRIPT_FIGURE" 응용프로그램 ID를 가진 확장 데이터가 폴리선 도면요소 다음에 올 수 있습니다. 여기에는 PostScript 이미지 및 PostScript 채우기 정보에 관련된 내용이 들어 있습니다.

이 단원의 항목

  • 폴리면 메쉬


폴리면 메쉬

POLYLINE
POLYLINE
RAY
DXF 참조서 > ENTITIES 섹션 > POLYLINE >
폴리면 메쉬

폴리면 메쉬는 DXF 파일에서 폴리선 도면요소의 variant로서 표현됩니다. 폴리선 헤더는 폴리선 플래그(70) 그룹의 64 비트에 의해 폴리면을 도입할 때 식별됩니다. 71 그룹은 메쉬의 정점 개수를 지정하며 72 그룹은 면 개수를 지정합니다. 이런 개수는 PFACE 명령을 사용해 작성된 모든 메쉬에 대해 정확하지만 응용프로그램에서는 이런 필드에 정확한 값을 배치하지 않아도 됩니다. 다음에 올 폴리선 헤더는 정점 좌표를 지정하는 일련의 정점 도면요소이며 그 다음에 메쉬를 구성하는 면이 오게 됩니다.

제공된 면 도면요소가 지정할 수 있는 정점의 개수는 AutoCAD 도면요소 구조에 의해 제한됩니다. 복잡한 다각형은 삼각형 쐐기로 분해되어 더 복잡한 다각형에 대한 표현이 가능해졌습니다. 다각형의 모서리들은 이런 분할 작업으로 인해 만들어진 가시적 가공품들이 실제로 그려지지 않도록 비가시적으로 만들어야 합니다. PFACE 명령은 이런 분할 작업을 자동으로 수행하지만 응용프로그램에서 폴리면 메쉬를 직접 생성할 경우에는 응용프로그램이 이 분할 작업을 자체적으로 수행해야 합니다. 하나의 면에 존재하는 정점의 개수는 분할 작업의 중요한 매개변수입니다. PFACEVMAX 시스템 변수는 면 도면요소당 정점 개수를 응용프로그램에 제공합니다. 이 값은 읽기 전용이며 4로 설정됩니다.

PFACE 명령으로 작성된 폴리면 메쉬는 항상 모든 정점 좌표 도면요소를 먼저 사용한 다음 면 정의 도면요소를 사용해 생성됩니다. 폴리면 메쉬를 처리하는 AutoCAD에서의 코드는 이 순서를 따라야 합니다. DXF 형식으로 폴리면 메쉬를 생성하는 프로그램은 먼저 모든 정점을 생성한 다음 모든 면을 생성해야 합니다. 그러나 DXF 형식의 파일에서 폴리면 메쉬를 읽어 들이는 프로그램은 정점과 면의 잘못된 순서를 묵인하게 될 것입니다.


RAY

폴리면 메쉬
ENTITIES 섹션
REGION
DXF 참조서 > ENTITIES 섹션 >
RAY

다음 그룹 코드는 광선 도면요소에 적용됩니다. 여기에 설명되어 있는 그룹 코드 이외의 내용은 도면요소의 공용 그룹 코드를 참고하십시오. 이 테이블에서 사용된 축약어 및 형식에 대한 정보는 본 참조서의 형식화 규칙을 참고하십시오.

광선 그룹 코드
그룹 코드 | 설명
100 | 하위 클래스 표식기(AcDbRay)
10 | 시작점(WCS) DXF: X 값, APP: 3D 점
20, 30 | DXF: 시작점의 Y 및 Z 값(WCS)
11 | 단위 방향 벡터(WCS) DXF: X 값, APP: 3D 벡터
21, 31 | DXF: 단위 방향 벡터의 Y 및 Z 값(WCS)


REGION

RAY
ENTITIES 섹션
SECTION
DXF 참조서 > ENTITIES 섹션 >
REGION

다음 그룹 코드는 영역 도면요소에 적용됩니다. 여기에 설명되어 있는 그룹 코드 이외의 내용은 도면요소의 공용 그룹 코드를 참고하십시오. 이 테이블에서 사용된 축약어 및 형식에 대한 정보는 본 참조서의 형식화 규칙을 참고하십시오.

영역 그룹 코드
그룹 코드 | 설명
100 | 하위 클래스 표식기(AcDbModelerGeometry)
70 | 모델러 형식 버전 번호(현재 = 1)
1 | 독점권을 가진 데이터(여러 줄< 행당 255 문자)
3 | 독점권을 가진 데이터의 추가 행(이전 그룹 1 문자열이 255 문자를 넘는 경우)(선택 사항)


SECTION

REGION
ENTITIES 섹션
SEQEND
DXF 참조서 > ENTITIES 섹션 >
SECTION

다음 그룹 코드는 단면 도면요소에 적용됩니다. 여기에 설명되어 있는 그룹 코드 이외의 내용은 도면요소의 공용 그룹 코드를 참고하십시오. 이 테이블에서 사용된 축약어 및 형식에 대한 정보는 본 참조서의 형식화 규칙를 참고하십시오.

섹션 그룹 코드
그룹 코드 | 설명
100 | 하위 클래스 표식기(AcDbSection)
90 | 단면 상태
91 | 단면 플래그
1 | 이름
10, 20, 30 | 수직 방향
40 | 맨 위 높이
41 | 맨 아래 높이
70 | 지시자 투명도
63, 411 | 지시자 색상
92 | 정점의 개수
11, 21, 31 | 정점(정점 수만큼 반복)
93 | 뒤선 정점의 개수
12, 22, 32 | 뒤선 정점(뒤선 정점 수만큼 반복)
360 | 형상 설정 객체에 대한 하드 포인터 ID/핸들


SEQEND

SECTION
ENTITIES 섹션
SHAPE
DXF 참조서 > ENTITIES 섹션 >
SEQEND

다음 그룹 코드는 seqend 도면요소에 적용됩니다. 여기에 설명되어 있는 그룹 코드 이외의 내용은 도면요소의 공용 그룹 코드를 참고하십시오. 이 테이블에서 사용된 축약어 및 형식에 대한 정보는 본 참조서의 형식화 규칙을 참고하십시오.

Seqend 그룹 코드
그룹 코드 | 설명
-2 | APP: 순서를 시작한 도면요소의 이름. 이 도면요소는 폴리선에 대한 정점(정점 유형 이름)의 마지막 또는 속성(삽입 도면요소에 제공된 66 그룹의 0(영)이 아닌 값에 의해 표시됨)을 가진 삽입 도면요소에 대한 속성 도면요소(속성 유형 이름)의 마지막을 표시합니다. 이 코드는 DXF 파일에 저장되지 않습니다.


SHAPE

SEQEND
ENTITIES 섹션
SOLID
DXF 참조서 > ENTITIES 섹션 >
SHAPE

다음 그룹 코드는 쉐이프 도면요소에 적용됩니다. 여기에 설명되어 있는 그룹 코드 이외의 내용은 도면요소의 공용 그룹 코드를 참고하십시오. 이 테이블에서 사용된 축약어 및 형식에 대한 정보는 본 참조서의 형식화 규칙을 참고하십시오.

쉐이프 그룹 코드
그룹 코드 | 설명
100 | 하위 클래스 표식기(AcDbShape)
39 | 두께(선택 사항, 기본값 = 0)
10 | 삽입점(WCS) DXF: X 값, APP: 3D 점
20, 30 | DXF: 삽입점의 Y 및 Z 값(WCS)
40 | 크기
2 | 쉐이프 이름
50 | 회전 각도(선택 사항, 기본값 = 0)
41 | 상대 X 축척 비율(선택 사항, 기본값 = 1).
51 | 기울기 각도(선택 사항, 기본값 = 0)
210 | 돌출 방향(선택 사항, 기본값 = 0, 0, 1) DXF: X 값, APP: 3D 벡터
220, 230 | DXF: 돌출 방향의 Y 및 Z 값(선택 사항)


SOLID

SHAPE
ENTITIES 섹션
SPLINE
DXF 참조서 > ENTITIES 섹션 >
SOLID

다음 그룹 코드는 솔리드 도면요소에 적용됩니다. 여기에 설명되어 있는 그룹 코드 이외의 내용은 도면요소의 공용 그룹 코드를 참고하십시오. 이 테이블에서 사용된 축약어 및 형식에 대한 정보는 본 참조서의 형식화 규칙을 참고하십시오.

솔리드 그룹 코드
그룹 코드 | 설명
100 | 하위 클래스 표식기(AcDbTrace)
10 | 첫 번째 구석 DXF: X 값, APP: 3D 점
20, 30 | DXF: 첫 번째 구석의 Y 및 Z 값
11 | 두 번째 구석 DXF: X 값, APP: 3D 점
21, 31 | DXF: 두 번째 구석의 Y 및 Z 값
12 | 세 번째 구석 XF: X 값, APP: 3D 점
22, 32 | DXF: 세 번째 구석의 Y 및 Z 값
13 | 네 번째 구석. 솔리드를 정의하기 위해 세 개의 구석만 입력된 경우, 네 번째 구석의 좌표는 세 번째 구석의 좌표와 같습니다. DXF: X 값, APP: 3D 점
23, 33 | DXF: 네 번째 구석의 Y 및 Z 값
39 | 두께(선택 사항, 기본값 = 0)
210 | 돌출 방향(선택 사항, 기본값 = 0, 0, 1) DXF: X 값, APP: 3D 벡터
220, 230 | DXF: 돌출 방향의 Y 및 Z 값(선택 사항)


SPLINE

SOLID
ENTITIES 섹션
SUN
DXF 참조서 > ENTITIES 섹션 >
SPLINE

다음 그룹 코드는 스플라인 도면요소에 적용됩니다. 여기에 설명되어 있는 그룹 코드 이외의 내용은 도면요소의 공용 그룹 코드를 참고하십시오. 이 테이블에서 사용된 축약어 및 형식에 대한 정보는 본 참조서의 형식화 규칙을 참고하십시오.

스플라인 그룹 코드
그룹 코드 | 설명
100 | 하위 클래스 표식기(AcDbSpline)
210 | 법선 벡터(스플라인이 비평면형인 경우에는 생략됨) DXF: X 값, APP: 3D 벡터
220, 230 | DXF: 법선 벡터의 Y 및 Z 값(선택 사항)
70 | 스플라인플래그(비트 코드화됨): 1 = 닫힌 스플라인 2 = 주기적 스플라인 4 = 유리 스플라인 8 = 평면형 16 = 선형(평면형 비트도 설정됨)
71 | 스플라인 곡선의 도수
72 | 매듭의 개수
73 | 조정점의 개수
74 | 맞춤점의 개수(있는 경우)
42 | 매듭 공차(기본값 = 0.0000001)
43 | 조정점 공차(기본값 = 0.0000001)
44 | 맞춤 공차(기본값 = 0.0000000001)
12 | 시작 접선—생략 가능(WCS에서) DXF: X 값, APP: 3D 점
22, 32 | DXF: 시작 접선의 Y 및 Z 값—생략 가능(WCS에서)
13 | 끝 접선—생략 가능(WCS에서) DXF: X 값, APP: 3D 점
23, 33 | DXF: 끝 접선의 Y 및 Z 값—생략 가능(WCS에서)
40 | 매듭 값(매듭당 하나의 항목)
41 | 가중치(1이 아닌 경우), 여러 쌍의 그룹을 갖고 있으며 모두 1이 아닐 경우에 제공됩니다.
10 | 조정점(WCS), 각 조정점당 하나의 항목 DXF: X 값, APP: 3D 점
20, 30 | DXF: 조정점의 Y 및 Z 값(WCS), 각 조정점당 하나의 항목
11 | 맞춤점(WCS), 맞춤점당 하나의 항목 DXF: X 값, APP: 3D 점
21, 31 | DXF: 맞춤점의 Y 및 Z 값(WCS), 맞춤점당 하나의 항목


SUN

SPLINE
ENTITIES 섹션
SURFACE
DXF 참조서 > ENTITIES 섹션 >
SUN

다음 그룹 코드는 일영 도면요소에 적용됩니다. 여기에 설명되어 있는 그룹 코드 이외의 내용은 도면요소의 공용 그룹 코드를 참고하십시오. 이 테이블에서 사용된 축약어 및 형식에 대한 정보는 본 참조서의 형식화 규칙를 참고하십시오.

일영 그룹 코드
그룹 코드 | 설명
100 | 하위 클래스 표식기(AcDbSun)
90 | 버전 번호
290 | 상태
63 | Color
40 | 조도
291 | 그림자
91 | 율리우스력 일
92 | 시간(자정 이후의 초 수)
292 | 일광 절약 시간
70 | 그림자 유형 0 = 광선 추적 그림자 1 = 그램자 맵
71 | 그림자 맵 크기
280 | 그림자 부드러움


SURFACE

SUN
ENTITIES 섹션
돌출된 곡면
DXF 참조서 > ENTITIES 섹션 >
SURFACE

곡면 도면요소 정의는 모든 곡면 유형에 공용인 그룹 코드에 이어서 특정 유형별 코드로 구성됩니다.

공용 곡면 그룹 코드
그룹 코드 | 설명
100 | 하위 클래스 표식기(AcDbModelerGeometry)
70 | 모델러 형식 버전 번호(현재 = 1)
1 | 독점권을 가진 데이터(여러 줄< 행당 255 문자)
3 | 독점권을 가진 데이터의 추가 행(이전 그룹 1 문자열이 255 문자를 넘는 경우)(선택 사항)
100 | 하위 클래스 표식기(AcDbSurface)
71 | U 등각선 수
72 | V 등각선 수

이 단원의 항목

  • 돌출된 곡면
  • 로프트 곡면
  • 회전 곡면
  • 스윕 곡면


돌출된 곡면

SURFACE
SURFACE
로프트 곡면
DXF 참조서 > ENTITIES 섹션 > SURFACE >
돌출된 곡면

다음 그룹 코드는 돌출된 곡면에 적용됩니다. 여기에 설명되어 있는 그룹 코드 이외의 내용은 도면요소의 공용 그룹 코드를 참고하십시오. 이 테이블에서 사용된 축약어 및 형식에 대한 정보는 본 참조서의 형식화 규칙를 참고하십시오.

돌출된 곡면 그룹 코드
그룹 코드 | 설명
100 | 하위 클래스 표식기(AcDbExtrudedSurface)
90 | 클래스 ID
90 | 이진 데이터의 크기
310 | 이진 데이터
10, 20, 30 | 스윕 벡터
40 | 돌출된 도면요소의 변환 행렬(16개 실수, 행 주 형식, 기본값 = 단위 행렬)
42 | 기울기 각도(라디안 단위)
43 | 기울기 시작 거리
44 | 기울기 끝 거리
45 | 비틀림 각도
48 | 축척 비율
49 | 정렬 각도(라디안 단위)
46 | 스윕 도면요소의 변환 행렬(16개 실수, 행 주 형식, 기본값 = 단위 행렬)
47 | 경로 도면요소의 변환 행렬(16개 실수, 행 주 형식, 기본값 = 단위 행렬)
290 | 솔리드 플래그
70 | 스윕 정렬 옵션 0 = 정렬 없음 1 = 경로에 스윕 도면요소 정렬 2 = 경로로 스윕 도면요소 변환 3 = 스윕 도면요소로 경로 변환
292 | 시작 플래그 정렬
293 | 뱅크 플래그
294 | 기준점 세트 플래그
295 | 스윕 도면요소 변환 계산 플래그
296 | 경로 도면요소 변환 계산 플래그
11, 21, 31 | 비틀기를 조정하는 참조 벡터


로프트 곡면

돌출된 곡면
SURFACE
회전 곡면
DXF 참조서 > ENTITIES 섹션 > SURFACE >
로프트 곡면

다음 그룹 코드는 로프트 곡면에 적용됩니다. 여기에 설명되어 있는 그룹 코드 이외의 내용은 도면요소의 공용 그룹 코드를 참고하십시오. 이 테이블에서 사용된 축약어 및 형식에 대한 정보는 본 참조서의 형식화 규칙를 참고하십시오.

로프트 곡면 그룹 코드
그룹 코드 | 설명
100 | 하위 클래스 표식기(AcDbLoftedSurface)
40 | 로프트 도면요소의 변환 행렬(16개 실수, 행 주 형식, 기본값 = 단위 행렬)
 | 횡단의 도면요소 데이터
 | GUIDE 곡선의 도면요소 데이터
 | 경로 곡선의 도면요소 데이터
70 | 평면 법선 올림 유형
41 | 시작 기울기 각도(라디안 단위)
42 | 끝 기울기 각도(라디안 단위)
43 | 시작 기울기 크기
44 | 끝 기울기 크기
290 | 호 길이 매개변수화 플래그
291 | 비틀기 없음 플래그
292 | 정렬 방향 플래그
293 | 단순 곡면 작성 플래그
294 | 닫힌 곡면 작성 플래그
295 | 솔리드 플래그
296 | 직선보간 곡면 작성 플래그
297 | 가상 가이드 플래그


회전 곡면

로프트 곡면
SURFACE
스윕 곡면
DXF 참조서 > ENTITIES 섹션 > SURFACE >
회전 곡면

다음 그룹 코드는 회전 곡면에 적용됩니다. 여기에 설명되어 있는 그룹 코드 이외의 내용은 도면요소의 공용 그룹 코드를 참고하십시오. 이 테이블에서 사용된 축약어 및 형식에 대한 정보는 본 참조서의 형식화 규칙를 참고하십시오.

회전 곡면 그룹 코드
그룹 코드 | 설명
100 | 하위 클래스 표식기(AcDbRevolvedSurface)
90 | 회전 도면요소의 ID
90 | 이진 데이터의 크기
310 | 이진 데이터
10, 20, 30 | 축 점
11, 21, 31 | 축 벡터
40 | 회전 각도(라디안 단위)
41 | 시작 각도(라디안 단위)
42 | 회전 도면요소의 변환 행렬(16개 실수, 행 주 형식, 기본값 = 단위 행렬)
43 | 기울기 각도(라디안 단위)
44 | 시작 기울기 거리
45 | 끝 기울기 거리
46 | 비틀기 각도(라디안 단위)
290 | 솔리드 플래그
291 | 축 플래그에 가까움


스윕 곡면

회전 곡면
SURFACE
TABLE
DXF 참조서 > ENTITIES 섹션 > SURFACE >
스윕 곡면

다음 그룹 코드는 스윕 곡면에 적용됩니다. 여기에 설명되어 있는 그룹 코드 이외의 내용은 도면요소의 공용 그룹 코드를 참고하십시오. 이 테이블에서 사용된 축약어 및 형식에 대한 정보는 본 참조서의 형식화 규칙를 참고하십시오.

스윕 곡면 그룹 코드
그룹 코드 | 설명
100 | 하위 클래스 표식기(AcDbSweptSurface)
90 | 스윕 도면요소의 ID
90 | 이진 데이터의 크기
310 | 이진 데이터
90 | 경로 도면요소의 ID
90 | 이진 데이터의 크기
310 | 독점권이 있는 데이터
40 | 스윕 도면요소의 변환 행렬(16개 실수, 행 주 형식, 기본값 = 단위 행렬)
41 | 경로 도면요소의 변환 행렬(16개 실수, 행 주 형식, 기본값 = 단위 행렬)
42 | 기울기 각도(라디안 단위)
43 | 기울기 시작 거리
44 | 기울기 끝 거리
45 | 비틀림 각도
48 | 축척 비율
49 | 정렬 각도(라디안 단위)
46 | 스윕 도면요소의 변환 행렬(16개 실수, 행 주 형식, 기본값 = 단위 행렬)
47 | 경로 도면요소의 변환 행렬(16개 실수, 행 주 형식, 기본값 = 단위 행렬)
290 | 솔리드 플래그
70 | 스윕 정렬 옵션 0 = 정렬 없음 1 = 경로에 스윕 도면요소 정렬 2 = 경로로 스윕 도면요소 변환 3 = 스윕 도면요소로 경로 변환
292 | 시작 플래그 정렬
293 | 뱅크 플래그
294 | 기준점 세트 플래그
295 | 스윕 도면요소 변환 계산 플래그
296 | 경로 도면요소 변환 계산 플래그
11, 21, 31 | 비틀기를 조정하는 참조 벡터


TABLE

스윕 곡면
ENTITIES 섹션
TEXT
DXF 참조서 > ENTITIES 섹션 >
TABLE

다음 그룹 코드는 테이블 도면요소에 적용됩니다. 여기에 설명되어 있는 그룹 코드 이외의 내용은 도면요소의 공용 그룹 코드를 참고하십시오. 이 테이블에서 사용된 축약어 및 형식에 대한 정보는 본 참조서의 형식화 규칙을 참고하십시오.

테이블 그룹 코드
그룹 코드 | 설명
0 | 도면요소 이름(ACAD_TABLE)
5 | 도면요소 핸들
330 | 소유자 사전에 대한 소프트 포인터 ID
100 | 하위 클래스 표식기. 세 개의 하위 클래스 표시기가 AcDbEntity, AcDbBlockReference, AcDbTable 순서로 나열되어 있습니다.
92 | 프록시 도면요소 그래픽의 바이트 수
310 | 프록시 도면요소 그래픽 데이터(여러 줄, 각 행당 최대 256자)
2 | 블록 이름, 익명의 블록은 *T 값으로 시작합니다.
10,20,30 | 삽입점
342 | TABLESTYLE 객체의 하드 포인터 ID
343 | 소유 BLOCK 레코드의 하드 포인터 ID
11,21,31 | 수평 방향 벡터
90 | 테이블 값의 플래그(부호 없는 정수)
91 | 행 수
92 | 열 수
93 | 재지정 플래그
94 | 경계 색상 재지정 플래그
95 | 경계 선가중치 재지정 플래그
96 | 경계 가시성 재지정 플래그
141 | 행 높이, 이 값은 반복됩니다(행당 1 값).
142 | 열 높이, 이 값은 반복됩니다(행당 1 값).
171 | 셀 유형, 이 값은 반복됩니다(셀당 1 값). 1 = 문자 유형 2 = 블록 유형
172 | 셀 플래그 값, 이 값은 반복됩니다(셀당 1 값).
173 | 셀 병합 값, 이 값은 반복됩니다(셀당 1 값).
174 | 자동 맞춤 옵션이 셀에 설정되었는지 여부를 나타내는 부울 플래그, 이 값은 반복됩니다(셀당 1 값).
175 | 셀 경계 폭(병합 셀에 적용), 이 값은 반복됩니다(셀당 1 값).
176 | 셀 경계 높이(병합 셀에 적용), 이 값은 반복됩니다(셀당 1 값).
91 | 셀 재지정 플래그, 이 값은 반복됩니다(셀당 1 값). (AutoCAD 2007부터)
178 | 가상 모서리에 대한 플래그 값
145 | 회전 값(실제, 블록 유형 셀과 문자 유형 셀에 적용 가능)
344 | FIELD 객체의 하드 포인터 ID. 이것은 문자 유형 셀에만 적용됩니다. 셀의 문자에 하나 이상의 필드가 들어 있는 경우, FIELD 객체의 ID만 저장됩니다. 문자열(그룹 코드 1 및 3)은 무시됩니다.
1 | 셀에 있는 문자열. 250자 미만의 문자열인 경우, 모든 문자는 코드 1에 표시됩니다. 문자열이 250자를 초과하는 경우, 250 문자 묶음으로 문자열이 나누어집니다. 묶음은 하나 이상의 코드 3 코드에 들어 있습니다. 코드 3 코드가 사용되면 마지막 그룹은 코드 1이며 250자보다 짧은 문자를 갖습니다. 이 값은 문자 유형 셀에만 적용되고 반복됩니다(셀당 1 값).
3 | 셀에 있는 문자열, 250 문자 묶음, 선택 사항. 이 값은 문자 유형 셀에만 적용되고 반복됩니다(셀당 1 값).
340 | 블록 테이블 레코드의 하드 포인터 ID. 이 값은 블록 유형 셀에만 적용되고 반복됩니다(셀당 1 값).
144 | 블록 축척(실제). 이 값은 블록 유형 셀에만 적용되고 반복됩니다(셀당 1 값).
179 | 블록 테이블 레코드의 속성 정의 개수(블록 유형 셀에만 적용 가능)
331 | 블록 테이블 레코드에 있는 속성 정의의 소프트 포인터 ID, 그룹 코드 179로 참조됨(블록 유형 셀에만 적용 가능). 이 값은 반복됩니다(속성 정의당 한 번).
300 | 속성 정의에 대한 문자열 값, 속성 정의당 한 번 반복되며 블록 유형 셀에만 적용 가능함
7 | 문자 스타일 이름(문자열). 재지정은 셀 단계에서 적용됨
140 | 문자 높이 값. 재지정은 셀 단계에서 적용됨
170 | 셀 정렬 값. 재지정은 셀 단계에서 적용됨
64 | 셀 컨텐츠 색상에 대한 값. 재지정은 셀 단계에서 적용됨
63 | 셀 컨텐츠 배경(채우기) 색상에 대한 값. 재지정은 셀 단계에서 적용됨
69 | 셀 맨 위 경계선의 트루 컬러 값. 재지정은 셀 단계에서 적용됨
65 | 셀 오른쪽 경계선의 트루 컬러 값. 재지정은 셀 단계에서 적용됨
66 | 셀 맨 아래 경계선의 트루 컬러 값. 재지정은 셀 단계에서 적용됨
68 | 셀 왼쪽 경계선의 트루 컬러 값. 재지정은 셀 단계에서 적용됨
279 | 셀 맨 위 경계선의 선가중치. 재지정은 셀 단계에서 적용됨
275 | 셀 오른쪽 경계선의 선가중치. 재지정은 셀 단계에서 적용됨
276 | 셀 맨 아래 경계선의 선가중치. 재지정은 셀 단계에서 적용됨
278 | 셀 왼쪽 경계선의 선가중치. 재지정은 셀 단계에서 적용됨
283 | 채우기 색상의 활성화 여부에 대한 부울 플래그. 재지정은 셀 단계에서 적용됨
289 | 셀 맨 위 경계선의 가시성에 대한 부울 플래그. 재지정은 셀 단계에서 적용됨
285 | 셀 오른쪽 경계선의 가시성에 대한 부울 플래그. 재지정은 셀 단계에서 적용됨
286 | 셀 맨 아래 경계선의 가시성에 대한 부울 플래그. 재지정은 셀 단계에서 적용됨
288 | 셀 왼쪽 경계선의 가시성에 대한 부울 플래그. 재지정은 셀 단계에서 적용됨
70 | 흐름 방향. 재지정은 테이블 도면요소 단계에서 적용됨
40 | 수평 셀 여백. 재지정은 테이블 도면요소 단계에서 적용됨
41 | 수직 셀 여백. 테이블 도면요소 단계에 적용되는 재지정
280 | 제목 억제 여부에 대한 플래그. 재지정은 테이블 도면요소 단계에서 적용됨
281 | 헤더 행 억제 여부에 대한 플래그. 재지정은 테이블 도면요소 단계에서 적용됨
7 | 문자 스타일 이름(문자열). 재지정은 테이블 도면요소 단계에서 적용됨. 각 셀 유형에는 하나의 항목이 있을 수 있습니다
140 | 문자 높이(실제). 테이블 도면요소 단계에 적용되는 재지정. 각 셀 유형에는 하나의 항목이 있을 수 있습니다
170 | 셀 정렬(정수). 테이블 도면요소 단계에 적용되는 재지정. 각 셀 유형에는 하나의 항목이 있을 수 있습니다
63 | 테이블의 셀 배경 또는 수직, 왼쪽 경계선의 색상 값. 재지정은 테이블 도면요소 단계에서 적용됩니다. 각 셀 유형에는 하나의 항목이 있을 수 있습니다
64 | 테이블의 셀 컨텐츠 또는 수평 맨 위 경계선의 색상 값. 재지정은 테이블 도면요소 단계에서 적용됩니다. 각 셀 유형에는 하나의 항목이 있을 수 있습니다
65 | 수평 내부 경계선의 색상 값. 재지정은 테이블 도면요소 단계에서 적용됨
66 | 수평 맨 아래 경계선의 색상 값. 재지정은 테이블 도면요소 단계에서 적용됨
68 | 수직 내부 경계선의 색상 값. 재지정은 테이블 도면요소 단계에서 적용됨
69 | 수직 오른쪽 경계선의 색상 값. 재지정은 테이블 도면요소 단계에서 적용됨
283 | 배경 색상의 사용 여부에 대한 플래그(기본값 = 0). 재지정은 테이블 도면요소 단계에서 적용됩니다. 각 셀 유형에는 하나의 항목이 있을 수 있습니다. 0 = 사용 불가능 1 = 사용 가능
274-279 | 셀의 각 경계선 유형에 대한 선가중치(기본값 = kLnWtByBlock). 재지정은 테이블 도면요소 단계에서 적용됩니다. 각 셀 유형에는 하나의 그룹이 있을 수 있습니다.
284-289 | 셀의 각 경계선 유형 가시성에 대한 플래그(기본값 = 1). 재지정은 테이블 도면요소 단계에서 적용됩니다. 각 셀 유형에는 하나의 그룹이 있을 수 있습니다. 0 = 숨김 1 = 표시
97 | 표준/제목/헤더 행 데이터 유형
98 | 표준/제목/헤더 행 단위 유형
4 | 표준/제목/헤더 행 형식 문자열
177 | 셀 재지정 플래그 값(AutoCAD 2007 이전)
92 | 확장 셀 플래그(AutoCAD 2007부터)
301 | 셀 값 블록 시작((AutoCAD 2007부터)

그룹 코드 178은 가상 모서리의 플래그 값입니다. 가상 모서리는 모눈 선을 두 개의 셀이 공유할 때 사용됩니다. 예를 들어, 테이블에 하나의 행과 두 개의 열이 있으며 셀 A와 셀 B가 있는 경우, 중앙 모눈 선에는 셀 A의 오른쪽 모서리와 셀 B의 왼쪽 모서리가 있습니다. 하나의 모서리는 실제 모서리이고 다른 모서리는 가상 모서리입니다. 실제 모서리에 대한 가상 모서리 점, 두 개의 모서리는 색상, 선가중치 및 가시성 등의 특성 집합이 동일합니다.


TEXT

TABLE
ENTITIES 섹션
TOLERANCE
DXF 참조서 > ENTITIES 섹션 >
TEXT

다음 그룹 코드는 문자 도면요소에 적용됩니다. 여기에 설명되어 있는 그룹 코드 이외의 내용은 도면요소의 공용 그룹 코드를 참고하십시오. 이 테이블에서 사용된 축약어 및 형식에 대한 정보는 본 참조서의 형식화 규칙을 참고하십시오.

문자 그룹 코드
그룹 코드 | 설명
100 | 하위 클래스 표식기(AcDbText)
39 | 두께(선택 사항, 기본값 = 0)
10 | 첫 번째 정렬점(OCS) DXF: X 값, APP: 3D 점
20, 30 | DXF: 첫 번째 정렬점의 Y 및 Z 값(OCS)
40 | 문자 높이
1 | 기본값(문자열 자체)
50 | 문자 회전(선택 사항, 기본값 = 0)
41 | 상대 X 축척 비율—폭(선택 사항, 기본값 = 1) 맞춤 유형 문자가 사용될 경우, 이 값도 조정됩니다.
51 | 기울기 각도(선택 사항, 기본값 = 0)
7 | 문자 스타일 이름(선택 사항, 기본값 = STANDARD)
71 | 문자 생성 플래그(선택 사항, 기본값 = 0): 2 = 역순서의 문자(X 방향으로 대칭됨) 4 = 위아래가 뒤집힌 문자(Y 방향으로 대칭됨)
72 | 수평 문자 자리맞추기 유형(선택 사항, 기본값 = 0) 정수 코드(비트 코드화되지 않음) 0 = 왼쪽, 1= 중심, 2 = 오른쪽 3 = 정렬(수직 정렬 = 0(영)인 경우) 4 = 중간(수직 정렬 = 0(영)인 경우) 5 = 맞춤(수직 정렬 = 0인 경우) 설명은 그룹 72 및 73 정수 코드 테이블 참고
11 | 두 번째 정렬점(OCS)(선택 사항) DXF: X 값, APP: 3D 점 이 값은 72 또는 73 그룹의 값이 0(영)이 아닌 경우에만 의미가 있습니다(자리맞추기가 기준선/왼쪽 이외의 설정으로 되어 있는 경우).
21, 31 | DXF: 두 번째 정렬점의 Y 및 Z 값(OCS)(선택 사항)
210 | 돌출 방향(선택 사항, 기본값 = 0, 0, 1) DXF: X 값, APP: 3D 벡터
220, 230 | DXF: 돌출 방향의 Y 및 Z 값(선택 사항)
100 | 하위 클래스 표식기(AcDbText)
73 | 수직 문자 자리맞추기 유형(선택 사항, 기본값 = 0): 정수 코드(비트 코드화되지 않음): 0 = 기준선, 1 = 맨 아래, 2 = 중간, 3 = 맨 위 설명은 그룹 72 및 73 정수 코드 테이블을 참고하십시오.

다음 테이블은 그룹 코드 72(수평 정렬) 및 73(수직 정렬)에 대한 더 자세한 내용을 설명합니다.

그룹 72 및 73 정수 코드
그룹 73 | 그룹 72 0 | 1 | 2 | 3 | 4 | 5
3(맨 위) | 맨 위 왼쪽 | 맨 위 중심 | 맨 위 오른쪽 |  |  |
2 (중간) | 중간 왼쪽 | 중간 중심 | 중간 오른쪽 |  |  |
1(맨 아래) | 맨 아래 왼쪽 | 맨 아래 중심 | 맨 아래 오른쪽 |  |  |
0(기준선) | 좌측면 | 중심 | 우측면 | 정렬 | 중간 | 맞춤

그룹 72 및/또는 73 값이 0(영)이 아닌 경우, 첫 번째 정렬점 값이 무시되고 AutoCAD가 두 번째 정렬점 및 문자열 자체의 높이와 길이를 기준으로 한 새 값을 계산합니다(문자 스타일 적용 후). 72와 73 값이 0(영)이거나 누락된 경우, 두 번째 정렬점은 의미가 없습니다.


TOLERANCE

TEXT
ENTITIES 섹션
TRACE
DXF 참조서 > ENTITIES 섹션 >
TOLERANCE

다음 그룹 코드는 공차 도면요소에 적용됩니다. 여기에 설명되어 있는 그룹 코드 이외의 내용은 도면요소의 공용 그룹 코드를 참고하십시오. 이 테이블에서 사용된 축약어 및 형식에 대한 정보는 본 참조서의 형식화 규칙을 참고하십시오.

공차 그룹 코드
그룹 코드 | 설명
100 | 하위 클래스 표식기(AcDbFcf)
3 | 치수 스타일 이름
10 | 삽입점(WCS) DXF: X 값, APP: 3D 점
20, 30 | DXF: 삽입점의 Y 및 Z 값(WCS)
1 | 공차의 시각적 표현을 나타내는 문자열
210 | 돌출 방향(선택 사항, 기본값 = 0, 0, 1) DXF: X 값, APP: 3D 벡터
220, 230 | DXF: 돌출 방향의 Y 및 Z 값(선택 사항)
11 | X축 방향 벡터(WCS) DXF: X 값, APP: 3D 벡터
21, 31 | DXF: X축 방향 벡터의 Y 및 Z 값(WCS)


TRACE

TOLERANCE
ENTITIES 섹션
UNDERLAY
DXF 참조서 > ENTITIES 섹션 >
TRACE

다음 그룹 코드는 두께선 도면요소에 적용됩니다. 여기에 설명되어 있는 그룹 코드 이외의 내용은 도면요소의 공용 그룹 코드를 참고하십시오. 이 테이블에서 사용된 축약어 및 형식에 대한 정보는 본 참조서의 형식화 규칙을 참고하십시오.

두께선 그룹 코드
그룹 코드 | 설명
100 | 하위 클래스 표식기(AcDbTrace)
10 | 첫 번째 구석(OCS) DXF: X 값, APP: 3D 점
20, 30 | DXF: 첫 번째 구석의 Y 및 Z 값(OCS)
11 | 두 번째 구석(OCS) DXF: X 값, APP: 3D 점
21, 31 | DXF: 두 번째 구석의 Y 및 Z 값(OCS)
12 | 세 번째 구석(OCS) DXF: X 값, APP: 3D 점
22, 32 | DXF: 세 번째 구석의 Y 및 Z 값(OCS)
13 | 네 번째 구석(OCS) DXF: X 값, APP: 3D 점
23, 33 | DXF: 네 번째 구석의 Y 및 Z 값(OCS)
39 | 두께(선택 사항, 기본값 = 0)
210 | 돌출 방향(선택 사항, 기본값 = 0, 0, 1) DXF: X 값, APP: 3D 벡터
220, 230 | DXF: 돌출 방향의 Y 및 Z 값(선택 사항)


UNDERLAY

TRACE
ENTITIES 섹션
VERTEX
DXF 참조서 > ENTITIES 섹션 >
UNDERLAY

다음 그룹 코드는 밑바탕에 적용됩니다. 여기에 설명되어 있는 그룹 코드 이외의 내용은 도면요소의 공용 그룹 코드를 참고하십시오. 이 테이블에서 사용된 축약어 및 형식에 대한 정보는 본 참조서의 형식화 규칙를 참고하십시오.

밑바탕 그룹 코드
그룹 코드 | 설명
100 | 하위 클래스 표식기(AcDbUnderlayReference)
340 | AcDbUnderlayDefinition 객체의 ID
10,20,30 | 밑바탕 삽입점의 X,Y 및 Z 좌표 이 좌표는 OCS/ECS 좌표입니다.
41,42,43 | DXF: X, Y 및 Z 축척 비율
50 | 회전 각도(OCS/ECS. 좌표계 X 축 및 Z 축 주변의 CCW)
210,220,230 | 법선 벡터(WCS에서)
280 | 플래그 1 = 자르기 켜짐 2 = 밑바탕 켜짐 4 = 단색 8 = 배경에 맞게 조정
281 | 대비(20과 100 사이의 값)
282 | 흐림(0과 80 사이의 값)
11, 21 | 반복: OCS/ECS의 2D 점 두 개만 있을 경우 자르기 직사각형의 왼쪽 아래 및 오른쪽 위 구석 점입니다. 두 개 이상일 경우 자르기 다각형의 정점입니다.


VERTEX

UNDERLAY
ENTITIES 섹션
VIEWPORT
DXF 참조서 > ENTITIES 섹션 >
VERTEX

다음 그룹 코드는 정점 도면요소에 적용됩니다. 여기에 설명되어 있는 그룹 코드 이외의 내용은 도면요소의 공용 그룹 코드를 참고하십시오. 이 테이블에서 사용된 축약어 및 형식에 대한 정보는 본 참조서의 형식화 규칙을 참고하십시오.

정점 그룹 코드
그룹 코드 | 설명
100 | 하위 클래스 표식기(AcDbVertex)
100 | 하위 클래스 표식기(AcDb2dVertex 또는 AcDb3dPolylineVertex)
10 | 위치 점(2D일 경우 OCS, 3D일 경우 WCS) DXF: X 값, APP: 3D 점
20, 30 | DXF: 위치 점의 Y 및 Z 값(2D일 경우 OCS, 3D일 경우 WCS)
40 | 시작 부분의 폭(선택 사항, 기본값 = 0)
41 | 끝 부분의 폭(선택 사항, 기본값 = 0)
42 | 팽창(선택 사항, 기본값 = 0). 팽창은 호 세그먼트에 대한 사이각의 1/4 접선으로서 호가 시작점에서 끝점으로 시계 방향으로 진행될 경우 음의 값입니다. 팽창값이 0(영)이면 직선 세그먼트를, 1이면 반원을 나타냅니다.
70 | 정점 플래그: 1 = 곡선 맞춤으로 작성한 추가 정점 2 = 이 정점에 대해 정의된 곡선 맞춤 접선. 곡선 맞춤 접선 방향이 0(영)이면 DXF 출력에서 생략될 수 있지만 이 비트가 설정된 경우에는 중요합니다 4 = 사용하지 않음 8 = 스플라인 맞춤에 의해 작성된 스플라인 정점 16 = 스플라인 프레임 조정점 32 = 3D 폴리선 정점 64 = 3D 다각형 메쉬 128 = 폴리면 메쉬 정점
50 | 곡선 맞춤 접선 방향
71 | 폴리면 메쉬 정점 색인(선택 사항, 0이 아닌 경우만 제공)
72 | 폴리면 메쉬 정점 색인(선택 사항, 0(영)이 아닌 경우만 제공)
73 | 폴리면 메쉬 정점 색인(선택 사항, 0이 아닌 경우만 제공)
74 | 폴리면 메쉬 정점 색인(선택 사항, 0이 아닌 경우만 제공)

폴리면 메쉬의 일부가 되는 모든 정점에는 정점 플래그 128 비트가 설정되어 있습니다. 도면요소가 메쉬의 정점 좌표를 제공할 경우, 정점에 대한 64 비트가 설정될 뿐 아니라 10, 20, 30 그룹에 의해 정점 좌표가 제공됩니다. 정점 색인 값은 정점 도면요소가 폴리선에 표시되는 순서대로 결정되며 첫 번째 정점의 색인은 1로 지정됩니다.

정점이 메쉬의 면을 정의하는 경우, 정점 플래그 그룹은 64 비트가 아닌 128 비트 세트를 갖게 됩니다. 이 경우, 면 도면요소의 10, 20, 30(위치) 그룹은 의미가 없으며 DXF 파일에는 항상 0(영)으로 쓰여집니다. 메쉬를 정의하는 정점 색인은 71, 72, 73 및 74 그룹 코드에서 제공하는 데, 그룹 코드의 값은 색인별로 이전에 정의했던 정점 중 하나를 지정합니다. 색인이 음수이면 해당 정점으로 시작되는 모서리는 표시되지 않습니다. 첫 번째 0 정점은 면의 정점들 중 마지막을 표시합니다.


VIEWPORT

VERTEX
ENTITIES 섹션
WIPEOUT
DXF 참조서 > ENTITIES 섹션 >
VIEWPORT

다음 그룹 코드는 뷰포트 도면요소에 적용됩니다. 여기에 설명되어 있는 그룹 코드 이외의 내용은 도면요소의 공용 그룹 코드를 참고하십시오. 이 테이블에서 사용된 축약어 및 형식에 대한 정보는 본 참조서의 형식화 규칙을 참고하십시오.

뷰포트 그룹 코드
그룹 코드 | 설명
100 | 하위 클래스 표식기(AcDbViewport)
10 | 중심점(WCS) DXF: X 값, APP: 3D 점
20, 30 | DXF: 중심점의 Y 및 Z 값(WCS)
40 | 도면 공간 단위의 폭
41 | 도면 공간 단위의 높이
68 | 뷰포트 상태 필드: -1 = 켜짐(그러나 화면은 완전히 꺼짐) 또는 현재 $MAXACTVP 개수가 초과하고 있으므로 활성이 아닌 뷰포트 중 하나입니다. 0 = 끄기 <양의 값 > = 켜기 및 활성화. 값은 뷰포트 스태킹의 순서에 대해 1은 활성 뷰포트, 2는 그 다음 활성 뷰포트 등의 순서로 나타냅니다.
69 | 뷰포트 ID
12 | 뷰 중심점(DCS) DXF: X 값, APP: 2D 점
22 | DXF: 뷰 중심점 Y 값(DCS)
13 | 스냅 기준점 DXF: X 값, APP: 2D 점
23 | DXF: 스냅 기준점 Y 값
14 | 스냅 간격 DXF: X 값, APP: 2D 점
24 | DXF: 스냅 간격 Y 값
15 | 모눈 간격 DXF: X 값, APP: 2D 점
25 | DXF: 모눈 간격 Y 값
16 | 뷰 방향 벡터(WCS) DXF: X 값, APP: 3D 벡터
26, 36 | DXF: 뷰 방향 벡터의 Y 및 Z 값(WCS)
17 | 뷰 대상점(WCS) DXF: X 값, APP: 3D 벡터
27, 37 | DXF: 뷰 대상점의 Y 및 Z 값(WCS)
42 | 투시도 렌즈 길이
43 | 앞면 자르기 평면 Z 값
44 | 뒷면 자르기 평면 Z 값
45 | 뷰 높이(모형 공간 단위)
50 | 스냅 각도
51 | 뷰 비틀림 각도
72 | 원 줌 퍼센트
331 | 동결된 도면층 객체 ID/핸들(여러 항목이 있을 수 있음)(선택 사항)
90 | 뷰포트 상태 비트 코드화됨 플래그: 1(0x1) = 투시도 모드를 작동합니다. 2(0x2) = 앞면 자르기를 작동합니다. 4(0x4) = 뒷면 자르기를 작동합니다. 8(0x8) = UCS 따르기를 작동합니다. 16(0x10) = 카메나 눈 이외에 앞면 자르기를 작동합니다. 32(0x20) = UCS 아이콘 가시성을 작동합니다. 64(0x40) = 원점에 UCS 아이콘을 작동합니다. 128(0x80) = 고속 줌을 작동합니다. 256(0x100) = 스냅 모드를 작동합니다. 512(0x200) = 모눈 모드를 작동합니다. 1024(0x400) = 등각투영 스냅 스타일을 작동합니다. 2048(0x800) = 플롯 숨김 모드를 작동합니다. 4096(0x1000) = kIsoPairTop. 이렇게 설정되고 kIsoPairRight가 설정되지 않은 경우, isopair top이 작동됩니다. kIsoPairTop와 kIsoPairRight가 모두 설정된 경우 isopair left가 작동됩니다. 8192 (0x2000) = kIsoPairRight. 이렇게 설정되고 kIsoPairTop이 설정되지 않은 경우, isopair right가 작동됩니다. 16384(0x4000) = 뷰포트 줌 잠금을 작동합니다. 32768(0x8000) = 현재는 항상 작동됩니다. 65536(0x10000) = 비직사각형 자르기를 작동합니다. 131072(0x20000) = 뷰포트를 끕니다.
340 | 뷰포트의 자르기 경계로 사용되는 도면요소에 대한 하드 포인터 ID/핸들(뷰포트가 직사각형이 아닐 경우에만 제공됨)
1 | 이 뷰포트에 지정된 플롯 스타일 시트 이름
281 | 렌더 모드: 0 = 2D 최적화(일반 2D) 1 = 와이어프레임 2 = 은선 3 =단순 음영처리 4 = 구로 음영처리 5 = 와이어프레임으로 단순 음영처리 6 = 와이어프레임으로 구로 음영처리 2D 최적화 이외의 모든 렌더링 모드는 새로운 3D 그래픽 파이프라인을 사용합니다. 이들 값은 바로 SHADEMODE 명령 및 AcDbAbstractViewTableRecord::RenderMode enum에 해당합니다.
71 | 뷰포트 플래그에 대한 UCS: 0 = 이 뷰포트가 활성화될 때 UCS는 변경되지 않습니다. 1 = 이 뷰포트는 뷰포트가 활성화될 때마다 현재 UCS가 될 자신의 UCS를 저장합니다.
74 | UCS 원점에 UCS 아이콘 표시 플래그: UCS 아이콘이 뷰포트 UCS를 나타낼지 현재 UCS를 나타낼지 여부를 조정합니다(UCSVP가 1이고 뷰포트가 활성이 아닌 경우, 이 값은 달라짐). 하지만, 이 필드는 현재 무시되며 아이콘은 항상 뷰포트 UCS를 나타냅니다.
110 | UCS 원점 DXF: X 값, APP: 3D 점
120, 130 | DXF: UCS 원점의 Y 및 Z 값
111 | UCS X축 DXF: X 값, APP: 3D 벡터
121, 131 | DXF: UCS X축의 Y 및 Z 값
112 | UCS Y축 DXF: X값, APP: 3D 벡터
122, 132 | DXF: UCS Y축의 Y 및 Z 값
345 | UCS가 명명된 UCS인 경우, AcDbUCSTableRecord의 ID/핸들. 제공되지 않은 경우, UCS가 명명되지 않습니다.
346 | UCS가 직교인 경우, 기준 UCS의 AcDbUCSTableRecord의 ID/핸들(79 코드는 0이 아님). 제공되지 않고 79 코드가 0이 아닌 경우, 기준 UCS는 WORLD로 됩니다.
79 | UCS의 직교 유형: 0 = UCS는 직교가 아님 1 = 맨 위, 2 = 맨 아래 3 = 앞, 4 = 뒤 5 = 왼쪽, 6 = 오른쪽
146 | 고도
170 | ShadePlot 모드: 0 = 표시되는 대로 1 = 와이어프레임 2 = 숨김 3 = 렌더됨
61 | 부 모눈선 대비 주 모눈선의 빈도
332 | 배경 ID/핸들(선택 사항)
333 | 음영 플롯 ID/핸들(선택 사항)
348 | 뷰 스타일 ID/핸들(선택 사항)
292 | 기본 조명 플래그 사용자 조명이 지정되어 있지 않을 경우 켜집니다.
282 | 기본 조명 유형: 0 = 한 개의 거리 광원 1 = 두 개의 거리 광원
141 | 뷰 밝기
142 | 뷰 대비
63,421,431 | 주변 광원 색상 검은색이 아닐 경우에만 씁니다.
361 | 일영 ID/핸들(선택 사항)
335 | 뷰포트 객체에 대한 소프트 포인터 참조(도면층 VP 특성 재지정에 해당)
343 | 뷰포트 객체에 대한 소프트 포인터 참조(도면층 VP 특성 재지정에 해당)
344 | 뷰포트 객체에 대한 소프트 포인터 참조(도면층 VP 특성 재지정에 해당)
91 | 뷰포트 객체에 대한 소프트 포인터 참조(도면층 VP 특성 재지정에 해당)
주ZOOM XP 비율은 다음 공식으로 계산됩니다. group_41 / group_45(또는 pspace_height / mspace_height).


WIPEOUT

VIEWPORT
ENTITIES 섹션
XLINE
DXF 참조서 > ENTITIES 섹션 >
WIPEOUT

다음 그룹 코드는 가리기 도면요소에 적용됩니다. 여기에 설명되어 있는 그룹 코드 이외의 내용은 도면요소의 공용 그룹 코드를 참고하십시오. 이 테이블에서 사용된 축약어 및 형식에 대한 정보는 본 참조서의 형식화 규칙을 참고하십시오.

그룹 코드 가리기
그룹 코드 | 설명
100 | 하위 클래스 표식기(AcDbRasterImage)
90 | 클래스 버전
10 | 삽입점(WCS) DXF: X 값, APP: 3D 점
20, 30 | DXF: 삽입점의 Y 및 Z 값(WCS)
11 | 단일 픽셀의 U 벡터(삽입점에서 시작하여 시각적으로 보이는 이미지의 맨 아래 쪽을 따라 가리킴)(WCS) DXF: X 값, APP: 3D 점
21, 31 | DXF: U 벡터의 Y 및 Z 값(WCS)
12 | 단일 픽셀의 V 벡터(삽입점에서 시작하여 시각적으로 보이는 이미지의 왼쪽 편을 따라 가리킴)(WCS) DXF: X 값, APP: 3D 점
22, 32 | DXF: V 벡터의 Y 및 Z 값(WCS)
13 | 픽셀 단위의 이미지 크기 DXF: U 값, APP: 2D 점(U 및 V 값)
23 | DXF: 픽셀 단위 이미지 크기의 V 값
340 | imagedef 객체에 대한 하드 참조
70 | 이미지 화면표시 특성: 1 = 이미지를 표시함 2 = 화면에 정렬되지 않을 때 이미지를 표시함 4 = 자르기 경계를 사용함 8 = 투명도를 켬
280 | 자르기 상태: 0 = 끄기, 1 = 켜기
281 | 밝기 값(0-100, 기본값 = 50)
282 | 대비 값(0-100, 기본값 = 50)
283 | 감쇄 값(0-100, 기본값 = 0)
360 | imagedef_reactor 객체에 대한 하드 참조
71 | 자르기 경계 유형. 1 = 직사각형, 2 = 다각형
91 | 다음에 올 자르기 경계 정점의 개수
14 | 자르기 경계 정점(OCS) DXF: X 값, APP: 2D 점(다중 항목) 주 1)직사각형 자르기 경계 유형에 대해서는 두 개의 반대 구석을 지정해야 합니다. 기본값은 (-0.5,-0.5), (size.x-0.5, size.y-0.5)입니다. 2) 다각형 자르기 경계 유형의 경우, 3개 이상의 정점을 지정해야 합니다. 다각형 정점은 순차적으로 나열해야 합니다.
24 | DXF: 자르기 경계 정점의 Y 값(OCS)(다중 항목)


XLINE

WIPEOUT
ENTITIES 섹션
OBJECTS 섹션
DXF 참조서 > ENTITIES 섹션 >
XLINE

다음 그룹 코드는 X선 도면요소에 적용됩니다. 여기에 설명되어 있는 그룹 코드 이외의 내용은 도면요소의 공용 그룹 코드를 참고하십시오. 이 테이블에서 사용된 축약어 및 형식에 대한 정보는 본 참조서의 형식화 규칙을 참고하십시오.

X선 그룹 코드
그룹 코드 | 설명
100 | 하위 클래스 표식기(AcDbXline)
10 | 첫 번째 점(WCS) DXF: X 값, APP: 3D 점
20, 30 | DXF: 첫 번째 점의 Y 및 Z 값(WCS)
11 | 단위 방향 벡터(WCS) DXF: X 값, APP: 3D 벡터
21, 31 | DXF: 단위 방향 벡터의 Y 및 Z 값(WCS)


OBJECTS 섹션

XLINE
OBJECT 섹션 그룹 코드
DXF 참조서 >
OBJECTS 섹션

이 장은 비그래픽 객체에 적용되는 그룹 코드를 제공합니다. 이러한 코드는 DXF™ 파일의 OBJECTS 섹션에 있으며 도면요소 정의 리스트에 있는 AutoLISP® 및 ObjectARX® 응용프로그램에서 사용됩니다.

이 단원의 항목

  • OBJECT 섹션 그룹 코드
  • 객체의 일반 그룹 코드
  • ACAD_PROXY_OBJECT
  • ACDBDICTIONARYWDFLT
  • ACDBPLACEHOLDER
  • DATATABLE
  • DICTIONARY
  • DICTIONARYVAR
  • DIMASSOC
  • FIELD
  • GROUP
  • IDBUFFER
  • IMAGEDEF
  • IMAGEDEF_REACTOR
  • LAYER_INDEX
  • LAYER_FILTER
  • LAYOUT
  • LIGHTLIST
  • MATERIAL
  • MLINESTYLE
  • OBJECT_PTR
  • PLOTSETTINGS
  • RASTERVARIABLES
  • RENDER
  • SECTION
  • SPATIAL_INDEX
  • SPATIAL_FILTER
  • SORTENTSTABLE
  • SUNSTUDY
  • TABLESTYLE
  • UNDERLAYDEFINITION
  • VISUALSTYLE
  • VBA_PROJECT
  • WIPEOUTVARIABLES
  • XRECORD


OBJECT 섹션 그룹 코드

OBJECTS 섹션
OBJECTS 섹션
객체 소유자
DXF 참조서 > OBJECTS 섹션 >
OBJECT 섹션 그룹 코드

객체는 그래픽 또는 기하학적 의미를 갖지 않는다는 점을 제외하면 도면요소와 유사합니다. 도면요소 또는 기호 테이블 레코드 또는 기호 테이블이 아닌 객체는 모두 이 섹션에 저장됩니다. 이 섹션은 동질적인 다수의 객체를 해당 객체의 소유자를 객체 앞에 표시하는 방식으로 소유자별로 객체의 위상을 순서화해 나타냅니다.

이 단원의 항목

  • 객체 소유자


객체 소유자

OBJECT 섹션 그룹 코드
OBJECT 섹션 그룹 코드
객체의 일반 그룹 코드
DXF 참조서 > OBJECTS 섹션 > OBJECT 섹션 그룹 코드 >
객체 소유자

OBJECTS 섹션에 표시되는 대부분 객체의 원소유자는 명명된 객체 사전이며 따라서 명명된 객체 사전이 항상 이 섹션에 표시되는 첫 번째 객체입니다. 명명된 객체 사전에 소유되지 않은 객체는 다른 도면요소, 객체 또는 기호 테이블 항목에 소유되어 있습니다. 이 섹션의 객체는 AutoCAD® 또는 ObjectARX® API를 통해 응용프로그램에서 정의될 수 있습니다. 응용프로그램에서 정의된 객체 유형의 DXF 이름은 DXF 파일의 CLASS 섹션에 있는 클래스 이름과 항상 연관되어야 하며, 연관되지 않을 경우에는 해당 객체 레코드가 그 레코드를 해석할 응용프로그램에 결합될 수 없습니다.

다른 사전의 경우와 마찬가지로 명명된 객체 사전의 레코드는 연관된 객체에 대한 연관 항목 이름 및 하드 소유자 포인터 참조 쌍으로만 구성됩니다.

객체 사이의 이름 충돌을 피하려면 개발자는 항목에 자신의 등록된 개발자 머리글을 사용해야 합니다.


객체의 일반 그룹 코드

객체 소유자
OBJECTS 섹션
ACAD_PROXY_OBJECT
DXF 참조서 > OBJECTS 섹션 >
객체의 일반 그룹 코드

다음 테이블은 거의 모든 비그래픽 객체에 적용되는 그룹 코드를 보여 줍니다. 그룹 코드 테이블을 객체 유형별로 참조 즉 특정 객체에 연관된 코드 리스트를 참조할 경우 여기서 보는 코드들도 표시될 수 있다는 점을 기억하십시오. 일부 그룹 코드는 객체가 해당 그룹 코드 특성에 대해 기본값이 아닌 값을 가질 때에만 그 객체에 포함됩니다. 이 테이블에서 사용된 축약어 및 형식에 대한 정보는 본 참조서의 형식화 규칙를 참고하십시오.

일반 객체 그룹 코드
그룹 코드 | 설명
0 | 객체 유형
5 | 핸들
102 | 응용프로그램 정의 그룹의 시작 “{응용프로그램 이름”(선택 사항)
응용프로그램 정의 코드 | 102 그룹 내의 코드와 값은 응용프로그램에서 정의됩니다(선택 사항).
102 | 그룹의 끝, “}”(선택 사항)
102 | “{ACAD_REACTORS”는 AutoCAD 불변의 리액터 그룹의 시작을 나타냅니다. 이 그룹은 영구 리액터가 이 객체에 부착되어 있는 경우에만 존재합니다(선택 사항).
330 | 소유자 사전에 대한 소프트 포인터 ID/핸들(선택 사항)
102 | 그룹의 끝, “}”(선택 사항)
102 | “{ACAD_XDICTIONARY”는 확장 사전 그룹의 시작을 나타냅니다. 이 그룹은 영구 리액터가 이 객체에 부착되어 있는 경우에만 존재합니다(선택 사항).
360 | 소유자 사전에 대한 하드 소유자 ID/핸들(선택 사항)
102 | 그룹의 끝, “}”(선택 사항)
330 | 소유자 객체에 대한 소프트 포인터 ID/핸들


ACAD_PROXY_OBJECT

객체의 일반 그룹 코드
OBJECTS 섹션
ACDBDICTIONARYWDFLT
DXF 참조서 > OBJECTS 섹션 >
ACAD_PROXY_OBJECT

다음 그룹 코드는 ACAD_PROXY_OBJECT 객체에 적용됩니다. 여기에 설명되어 있는 그룹 코드 이외의 내용은 객체의 일반 그룹 코드를 참고하십시오. 이 테이블에서 사용된 축약어 및 형식에 대한 정보는 본 참조서의 형식화 규칙를 참고하십시오.

ACAD_PROXY_OBJECT 그룹 코드
그룹 코드 | 설명
100 | DXF: 하위 클래스 표식기(AcDbProxyObject)
90 | DXF: 프록시 객체 클래스 ID(항상 499)
91 | DXF: 응용프로그램 객체의 클래스 ID 클래스 ID는 CLASSES 섹션에 있는 클래스의 순서를 따릅니다. 첫 번째 클래스의 ID는 500으로, 다음 ID는 501 등으로 제공됩니다.
93 | DXF: 비트 단위로 나타낸 객체 데이터의 크기
310 | DXF: 이진 객체 데이터(여러 항목이 표시될 수 있음)(선택 사항)
330 또는 340 또는 350 또는 360 | DXF: 객체 ID(여러 항목이 표시될 수 있음)(선택 사항)
94 | DXF: 0(객체 ID 섹션의 끝을 나타냄)
95 | DXF: 프록시가 될 때의 객체 도면 형식(서명되지 않은 32 비트 정수): Low word는 AcDbDwgVersion입니다. High word는 MaintenanceReleaseVersion입니다.
70 | DXF: 원래의 사용자 객체 데이터 형식: 0 = DWG 형식 1 = DXF 형식

92 필드는 AcDbProxyObject에 사용되지 않습니다. 이 클래스의 객체에는 그래픽이 전혀 없습니다.


ACDBDICTIONARYWDFLT

ACAD_PROXY_OBJECT
OBJECTS 섹션
ACDBPLACEHOLDER
DXF 참조서 > OBJECTS 섹션 >
ACDBDICTIONARYWDFLT

다음 그룹 코드는 ACDBDICTIONARYWDFLT 객체에 의해 사용됩니다. 여기에 설명되어 있는 그룹 코드 이외의 내용은 객체의 일반 그룹 코드를 참고하십시오. 이 테이블에서 사용된 축약어 및 형식에 대한 정보는 본 참조서의 형식화 규칙를 참고하십시오.

ACDBDICTIONARYWDFLT 그룹 코드
그룹 코드 | 설명
0 | 객체 이름(ACDBDICTIONARYWDFLT)
5 | 핸들
102 | 불변의 리액터 그룹의 시작, 항상 “{ACAD_REACTORS”
330 | 소유자 사전에 대한 소프트 포인터 ID/핸들
102 | 불변의 리액터 그룹의 시작, 항상 “}”
330 | 소유자 객체에 대한 소프트 소유자 ID/핸들
100 | 하위 클래스 표식기(AcDbDictionary)
281 | 중복 레코드 복제 플래그(중복 항목 결합 방법을 결정함): 0 = 적용할 수 없음 1 = 기존 유지 2 = 복제 사용 3 = <외부 참조>$0$<이름> 4 = $0$<이름> 5 =언맹글 이름
3 | 항목 이름(각 항목당 하나)
350 | 항목 객체에 대한 소프트 소유자 ID/핸들(각 항목당 하나)
100 | 하위 클래스 표식기(AcDbDictionaryWithDefault)
340 | 기본 객체 ID/핸들에 대한 하드 포인터(현재는 “Normal”로 명명된 플롯 스타일 사전의 기본 항목에만 사용됨)


ACDBPLACEHOLDER

ACDBDICTIONARYWDFLT
OBJECTS 섹션
DATATABLE
DXF 참조서 > OBJECTS 섹션 >
ACDBPLACEHOLDER

다음 그룹 코드는 ACDBPLACEHOLDER 객체에 의해 사용됩니다. 여기에 설명되어 있는 그룹 코드 이외의 내용은 객체의 일반 그룹 코드를 참고하십시오. 이 테이블에서 사용된 축약어 및 형식에 대한 정보는 본 참조서의 형식화 규칙를 참고하십시오.

ACDBPLACEHOLDER 그룹 코드
그룹 코드 | 설명
0 | 객체 이름(ACDBPLACEHOLDER)
5 | 핸들
102 | 불변의 리액터 그룹의 시작, 항상 “{ACAD_REACTORS”
330 | 소유자 사전에 대한 소프트 포인터 ID/핸들
102 | 불변의 리액터 그룹의 시작, 항상 “}”
330 | 소유자 객체에 대한 소프트 포인터 ID/핸들


DATATABLE

ACDBPLACEHOLDER
OBJECTS 섹션
DICTIONARY
DXF 참조서 > OBJECTS 섹션 >
DATATABLE

다음 그룹 코드는 DATATABLE 객체에 의해 사용됩니다. 여기에 설명되어 있는 그룹 코드 이외의 내용은 객체의 일반 그룹 코드를 참고하십시오. 이 테이블에서 사용된 축약어 및 형식에 대한 정보는 본 참조서의 형식화 규칙를 참고하십시오.

DATATABLE 그룹 코드
그룹 코드 | 설명
0 | 객체 이름(DATATABLE)
5 | 핸들
102 | 불변의 리액터 그룹의 시작, 항상 “{ACAD_REACTORS”
330 | 소유자 사전에 대한 소프트 포인터 ID/핸들
102 | 불변의 리액터 그룹의 시작, 항상 “}”
330 | 소유자 객체에 대한 소프트 포인터 ID/핸들
100 | 하위 클래스 표식기(AcDbDataTable)
70 | 버전
90 | 열 수
91 | 유효 행 수
1 | 테이블 이름
92, 2 | 열 유형 및 이름, 각 열만큼 반복됩니다.
 | 각 열의 행마다 한 개 값이 기록됩니다.
71 | 부울 값
93 | 정수 값
40 | Double 값
3 | 문자열 값
10, 20, 30 | 2D 점
11, 21, 31 | 3D 점
331 | 객체 값에 대한 소프트 포인터 ID/핸들
360 | 하드 포인터 소유권 ID
350 | 소프트 포인터 소유권 ID
340 | 하드 포인터 ID/핸들
330 | 소프트 포인터 ID/핸들


DICTIONARY

DATATABLE
OBJECTS 섹션
DICTIONARYVAR
DXF 참조서 > OBJECTS 섹션 >
DICTIONARY

다음 그룹 코드는 DICTIONARY 객체에 의해 사용됩니다. 여기에 설명되어 있는 그룹 코드 이외의 내용은 객체의 일반 그룹 코드를 참고하십시오. 이 테이블에서 사용된 축약어 및 형식에 대한 정보는 본 참조서의 형식화 규칙를 참고하십시오.

DICTIONARY 그룹 코드
그룹 코드 | 설명
0 | 객체 이름(DICTIONARY)
5 | 핸들
102 | 불변의 리액터 그룹의 시작, 항상 “{ACAD_REACTORS”
330 | 소유자 사전에 대한 소프트 포인터 ID/핸들
102 | 불변의 리액터 그룹의 시작, 항상 “}”
330 | 소유자 객체에 대한 소프트 포인터 ID/핸들
100 | 하위 클래스 표식기(AcDbDictionary)
280 | 하드 소유자 플래그. 1로 설정된 경우, 사전의 요소가 하드 소유 요소로 처리될 것임을 나타냅니다.
281 | 중복 레코드 복제 플래그(중복 항목 결합 방법을 결정함): 0 = 적용할 수 없음 1 = 기존 유지 2 = 복제 사용 3 = <외부 참조>$0$<이름> 4 = $0$<이름> 5 =언맹글 이름
3 | 항목 이름(각 항목당 하나)(선택 사항)
350 | 항목 객체에 대한 소프트 소유자 ID/핸들(각 항목당 하나)(선택 사항)

AutoCAD®는 여러 줄 스타일 및 그룹 정의와 같은 항목을 사전의 객체로 유지합니다. 다음 섹션은 사전에서 유지되는 AutoCAD 객체 그룹 코드에 대해 설명합니다. 그러나 다른 응용프로그램은 해당 응용프로그램에 적합하다고 생각되는 자체 사전을 자유롭게 작성하여 사용할 수 있습니다. 머리글 "ACAD_"는 AutoCAD 응용프로그램용입니다.


DICTIONARYVAR

DICTIONARY
OBJECTS 섹션
DIMASSOC
DXF 참조서 > OBJECTS 섹션 >
DICTIONARYVAR

다음 그룹 코드는 DICTIONARYVAR 객체에 의해 사용됩니다. 여기에 설명되어 있는 그룹 코드 이외의 내용은 객체의 일반 그룹 코드를 참고하십시오. 이 테이블에서 사용된 축약어 및 형식에 대한 정보는 본 참조서의 형식화 규칙를 참고하십시오.

DICTIONARYVAR 그룹 코드
그룹 코드 | 설명
0 | 객체 이름(DICTIONARYVAR)
5 | 핸들
102 | 불변의 리액터 그룹의 시작, 항상 “{ACAD_REACTORS”
330 | 소유자 사전에 대한 소프트 포인터 ID/핸들(ACDBVARIABLEDICTIONARY)
102 | 불변의 리액터 그룹의 시작, 항상 “}”
100 | 하위 클래스 표식기(DictionaryVariables)
280 | 객체 스키마 번호(현재 0으로 설정됨)
1 | 변수 값

DICTIONARYVAR 객체는 DXF™ HEADER 섹션에 항목을 추가하지 않고도 setvar/getvar이 가능하도록 데이터베이스에 명명된 값을 저장하는 수단으로 AutoCAD에서 사용됩니다. DICTIONARYVAR 객체로 저장된 시스템 변수는 DEFAULTVIEWCATEGORY, DIMADEC, DIMASSOC, DIMDSEP, DRAWORDERCTL, FIELDEVAL, HALOGAP, HIDETEXT, INDEXCTL, INDEXCTL, INTERSECTIONCOLOR, INTERSECTIONDISPLAY, MSOLESCALE, OBSCOLOR, OBSLTYPE, OLEFRAME, PROJECTNAME, SORTENTS, UPDATETHUMBNAIL, XCLIPFRAME 및 XCLIPFRAME입니다.


DIMASSOC

DICTIONARYVAR
OBJECTS 섹션
FIELD
DXF 참조서 > OBJECTS 섹션 >
DIMASSOC

다음 그룹 코드는 DIMASSOC 객체에 의해 사용됩니다. 여기에 설명되어 있는 그룹 코드 이외의 내용은 객체의 일반 그룹 코드를 참고하십시오. 이 테이블에서 사용된 축약어 및 형식에 대한 정보는 본 참조서의 형식화 규칙를 참고하십시오.

DIMASSOC 그룹 코드
그룹 코드 | 설명
0 | 객체 이름(DIMASSOC)
5 | 핸들
102 | 불변의 리액터 그룹, 항상 “{ACAD_REACTORS}”
330 | 소프트 포인터 ID
100 | 하위 클래스 표식기(AcDbDimAssoc)
330 | 치수 객체의 ID
90 | 연관성 플래그 1 = 첫 번째 점 참조 2 = 두 번째 점 참조 4 = 세 번째 점 참조 8 = 네 번째 점 참조
70 | 공간 변환 플래그(참/거짓)
71 | 회전된 치수 유형(평행, 수직)
1 | 클래스 이름(AcDbOsnapPointRef)
72 | 객체 Osnap 유형 0 = 없음 1 = 끝점 2 = 중간점 3 = 중심 4 = 노드 5 = 사분점 6 = 교차점 7 = 삽입점 8 = 수직점 9 = 접점 10 = 근사점 11 = 가상 교차점 12 = 평행 13 = 시작점
331 | 주 객체의 ID(형상)
73 | 주 객체의 SubentType(모서리, 면)
91 | 주 객체의 GsMarker(색인)
301 | 외부 참조 객체의 핸들(문자열)
40 | 근처점 객체 스냅의 형상 매개변수
10 | WCS에서의 객체 스냅 점; X 값
20 | WCS에서의 객체 스냅 점; Y 값
30 | WCS에서의 객체 스냅 점; Z 값
332 | 교차 객체의 ID(형상)
74 | 교차 객체의 SubentType(모서리, 면)
92 | 교차 객체의 GsMarker(색인)
302 | 교차 외부 참조 객체의 핸들(문자열)
75 | hasLastPointRef 플래그(참/거짓)

DIMASSOC 객체는 치수 객체와 도면 형상 객체 사이에 연관을 지정하여 연관 치수를 구현합니다. 연관 치수는 연관된 형상이 수정되면 자동으로 업데이트되는 치수입니다.


FIELD

DIMASSOC
OBJECTS 섹션
GROUP
DXF 참조서 > OBJECTS 섹션 >
FIELD

다음 그룹 코드는 FIELD 객체에 사용됩니다. 여기에 설명되어 있는 그룹 코드 이외의 내용은 객체의 일반 그룹 코드를 참고하십시오. 이 테이블에서 사용된 축약어 및 형식에 대한 정보는 본 참조서의 형식화 규칙를 참고하십시오.

FIELD 그룹 코드
그룹 코드 | 설명
0 | 객체 이름(ACAD_FIELD)
1 | 평가자 ID
2 | 필드 코드 문자열
3 | 필드 코드 문자열의 오버플로우
90 | 종속 필드의 개수
360 | 종속 필드 ID(AcDbHardOwnershipId), 종속 필드의 개수만큼 반복됩니다
97 | 필드 코드에 사용되는 객체 ID의 개수
331 | 필드 코드에 사용되는 객체 ID(AcDbSoftPointerId)이며, 필드 코드에 사용되는 객체 ID 개수만큼 반복됩니다.
93 | 필드의 데이터 세트 개수
6 | 필드 데이터의 키 문자열이며, 키 필드 쌍은 필드에 설정된 데이터 세트 개수만큼 반복됩니다.
7 | 평가된 캐시의 키 문자열이며, 이 키는 ACFD_FIELD_VALUE로 하드 코드화됩니다.
90 | 필드 값의 데이터 유형
91 | Long 값(필드 값의 데이터 유형이 long인 경우)
140 | Double 값(필드 값의 데이터 유형이 double인 경우)
330 | ID 값, AcDbSoftPointerId(필드 값의 데이터 유형이 ID인 경우)
92 | 이진 데이터 버퍼 크기(필드 값의 데이터 유형이 이진인 경우)
310 | 이진 데이터(필드 값의 데이터 유형이 이진인 경우)
301 | 문자열 형식
9 | 형식 문자열의 오버플로우
98 | 형식 문자열의 길이


GROUP

FIELD
OBJECTS 섹션
IDBUFFER
DXF 참조서 > OBJECTS 섹션 >
GROUP

다음 그룹 코드는 GROUP 객체에 사용됩니다. 여기에 설명되어 있는 그룹 코드 이외의 내용은 객체의 일반 그룹 코드를 참고하십시오. 이 테이블에서 사용된 축약어 및 형식에 대한 정보는 본 참조서의 형식화 규칙를 참고하십시오.

GROUP 그룹 코드
그룹 코드 | 설명
0 | 객체 이름(GROUP)
5 | 핸들
102 | 불변의 리액터 그룹의 시작, 항상 “{ACAD_REACTORS” (불변의 리액터 그룹은 기본 사전을 제외한 모든 사전에 표시됩니다.)
330 | 소유자 사전에 대한 소프트 포인터 ID/핸들. GROUP 객체의 경우 이것은 항상 명명된 객체 사전의 ACAD_GROUP 항목입니다.
102 | 불변의 리액터 그룹의 시작, 항상 “}”
330 | 소유자 객체에 대한 소프트 포인터 ID/핸들
100 | 하위 클래스 표식기(AcDbGroup)
300 | 그룹 설명
70 | “명명되지 않음” 플래그: 1 = 명명되지 않음, 0 = 명명됨
71 | 선택 가능 플래그: 1 = 선택 가능, 0 = 선택 불가능
340 | 그룹 내 도면요소에 대한 하드 포인터 핸들(객체당 하나의 항목)


IDBUFFER

GROUP
OBJECTS 섹션
IMAGEDEF
DXF 참조서 > OBJECTS 섹션 >
IDBUFFER

다음 그룹 코드는 IDBUFFER 객체에 사용됩니다. 여기에 설명되어 있는 그룹 코드 이외의 내용은 객체의 일반 그룹 코드를 참고하십시오. 이 테이블에서 사용된 축약어 및 형식에 대한 정보는 본 참조서의 형식화 규칙를 참고하십시오.

IDBUFFER 그룹 코드
그룹 코드 | 설명
100 | 하위 클래스 표식기(AcDbIdBuffer)
330 | 도면요소에 대한 소프트 포인터 참조(여러 항목이 존재할 수 있음)

IDBUFFER 객체는 단지 객체에 대한 참조 리스트로서 유틸리티 객체입니다.


IMAGEDEF

IDBUFFER
OBJECTS 섹션
IMAGEDEF_REACTOR
DXF 참조서 > OBJECTS 섹션 >
IMAGEDEF

다음 그룹 코드는 IMAGEDEF 객체에 사용됩니다. 여기에 설명되어 있는 그룹 코드 이외의 내용은 객체의 일반 그룹 코드를 참고하십시오. 이 테이블에서 사용된 축약어 및 형식에 대한 정보는 본 참조서의 형식화 규칙를 참고하십시오.

IMAGEDEF 그룹 코드
그룹 코드 | 설명
0 | 객체 이름(IMAGEDEF)
5 | 핸들
102 | 불변의 리액터 그룹의 시작, 항상 “{ACAD_REACTORS”
330 | ACAD_IMAGE_DICT 사전에 대한 소프트 포인터 ID/핸들
330 | IMAGEDEF_REACTOR 객체에 대한 소프트 포인터 ID/핸들(각 복제당 하나씩 여러 개의 항목)
102 | 불변의 리액터 그룹의 시작, 항상 “}”
100 | 하위 클래스 표식기(AcDbRasterImageDef)
90 | 클래스 버전 0
1 | 이미지의 파일 이름
10 | 픽셀에서의 이미지 크기 DXF: U 값, APP: 2D 점(U 및 V 값)
20 | DXF: 픽셀 단위의 이미지 크기의 V 값
11 | AutoCAD 단위에서 픽셀 하나의 기본 크기 DXF: U 값, APP: 2D 점(U 및 V 값)
12 | DXF: 픽셀 크기의 V 값
280 | 이미지가 로드됨 플래그. 0 = 언로드됨, 1 = 로드됨
281 | 해상도 단위. 0 = 단위 없음, 2 = 센티미터, 5 = 인치


IMAGEDEF_REACTOR

IMAGEDEF
OBJECTS 섹션
LAYER_INDEX
DXF 참조서 > OBJECTS 섹션 >
IMAGEDEF_REACTOR

다음 그룹 코드는 IMAGEDEF_REACTOR 객체에 사용됩니다. 여기에 설명되어 있는 그룹 코드 이외의 내용은 객체의 일반 그룹 코드를 참고하십시오. 이 테이블에서 사용된 축약어 및 형식에 대한 정보는 본 참조서의 형식화 규칙를 참고하십시오.

IMAGEDEF_REACTOR 그룹 코드
그룹 코드 | 설명
0 | 객체 이름(IMAGEDEF_REACTOR)
5 | 핸들
100 | 하위 클래스 표식기(AcDbRasterImageDefReactor)
90 | 클래스 버전 2
330 | 연관된 이미지 객체의 객체 ID


LAYER_INDEX

IMAGEDEF_REACTOR
OBJECTS 섹션
LAYER_FILTER
DXF 참조서 > OBJECTS 섹션 >
LAYER_INDEX

다음 그룹 코드는 LAYER_INDEX 객체에 사용됩니다. 여기에 설명되어 있는 그룹 코드 이외의 내용은 객체의 일반 그룹 코드를 참고하십시오. 이 테이블에서 사용된 축약어 및 형식에 대한 정보는 본 참조서의 형식화 규칙를 참고하십시오.

LAYER_INDEX 그룹 코드
그룹 코드 | 설명
0 | 객체 이름(LAYER_INDEX)
5 | 핸들
102 | 불변의 리액터 그룹의 시작, 항상 “{ACAD_REACTORS”
330 | 소유자 사전에 대한 소프트 포인터 ID/핸들
102 | 불변의 리액터 그룹의 시작, 항상 “}”
100 | 하위 클래스 표식기(AcDbIndex)
40 | 시간 스탬프(율리우스력 날짜)
100 | 하위 클래스 표식기(AcDbLayerIndex)
8 | 도면층 이름(여러 항목이 존재할 수 있음)
360 | IDBUFFER에 대한 하드 소유자 참조(여러 항목이 존재할 수 있음)
90 | IDBUFFER 리스트의 항목 수(여러 항목이 존재할 수 있음)


LAYER_FILTER

LAYER_INDEX
OBJECTS 섹션
LAYOUT
DXF 참조서 > OBJECTS 섹션 >
LAYER_FILTER

다음 그룹 코드는 LAYER_FILTER 객체에 사용됩니다. 여기에 설명되어 있는 그룹 코드 이외의 내용은 객체의 일반 그룹 코드를 참고하십시오. 이 테이블에서 사용된 축약어 및 형식에 대한 정보는 본 참조서의 형식화 규칙를 참고하십시오.

LAYER_FILTER 그룹 코드
그룹 코드 | 설명
0 | 객체 이름(LAYER_FILTER)
5 | 핸들
102 | 불변의 리액터 그룹의 시작, 항상 “{ACAD_REACTORS”
330 | 소유자 사전에 대한 소프트 포인터 ID/핸들
102 | 불변의 리액터 그룹의 시작, 항상 “}”
100 | 하위 클래스 표식기(AcDbFilter)
100 | 하위 클래스 표식기(AcDbLayerFilter)
8 | 도면층 이름(여러 항목이 존재할 수 있음)


LAYOUT

LAYER_FILTER
OBJECTS 섹션
LIGHTLIST
DXF 참조서 > OBJECTS 섹션 >
LAYOUT

다음 그룹 코드는 LAYOUT 객체에 사용됩니다. 여기에 설명되어 있는 그룹 코드 이외의 내용은 객체의 일반 그룹 코드를 참고하십시오. 이 테이블에서 사용된 축약어 및 형식에 대한 정보는 본 참조서의 형식화 규칙를 참고하십시오.

LAYOUT 그룹 코드
그룹 코드 | 설명
0 | 객체 이름(LAYOUT)
5 | 핸들
102 | 불변의 리액터 그룹의 시작, 항상 “{ACAD_REACTORS”
330 | 소유자 사전에 대한 소프트 포인터 ID/핸들
102 | 불변의 리액터 그룹의 시작, 항상 “}”
330 | 소유자 객체에 대한 소프트 포인터 ID/핸들
100 | 하위 클래스 표식기(AcDbPlotSettings)
plotsettings 객체 그룹 코드 | AcDbPlotSettings 표식기 다음에 오는 그룹 코드 및 설명은 PLOTSETTINGS를 참고하십시오.
100 | 하위 클래스 표식기(AcDbLayout)
1 | 레이아웃 이름
70 | 비트 코드화된 플래그는 다음과 같이 조정합니다. 1 = 이 레이아웃이 현재 레이아웃일 때 이 레이아웃에 대한 PSLTSCALE 값 표시 2 = 이 레이아웃이 현재 레이아웃일 때 이 레이아웃에 대한 LIMCHECK 값 표시
71 | 탭 순서. 이 숫자는 AutoCAD 도면 프레임 윈도우에 부착된 탭 컨트롤에서 이 배치의 순서를 나타내는 서수입니다. “모형” 탭은 탭 순서에 관계 없이 항상 첫 번째 탭으로 나타납니다.
10 | 이 레이아웃의 최소 한계(이 레이아웃이 현재 레이아웃일 경우 LIMMIN에서 정의됨) DXF: X 값, APP: 2D 점
20 | DXF: 최소 한계의 Y 값
11 | 이 레이아웃의 최대 한계(이 레이아웃이 현재 레이아웃일 경우 LIMMAX에서 정의됨): DXF: X 값, APP: 2D 점
21 | DXF: 최대 한계의 Y 값
12 | 이 레이아웃의 삽입 기준점(이 레이아웃이 현재 레이아웃일 경우 INSBASE에서 정의됨): DXF: X 값, APP: 3D 점
22, 32 | DXF: 삽입 기준점의 Y 및 Z 값
14 | 이 레이아웃의 최소 범위(이 레이아웃이 현재 레이아웃일 경우 EXTMIN에서 정의됨): DXF: X 값, APP: 3D 점
24, 34 | DXF: 최소 범위의 Y 및 Z 값
15 | 이 레이아웃의 최대 범위(이 레이아웃이 현재 레이아웃일 경우 EXTMAX에서 정의됨): DXF: X 값, APP: 3D 점
25, 35 | DXF: 최대 범위의 Y 및 Z 값
146 | 고도
13 | UCS 원점 DXF: X 값, APP: 3D 점
23, 33 | DXF: UCS 원점의 Y 및 Z 값
16 | UCS X축 DXF: X 값, APP: 3D 벡터
26, 36 | DXF: UCS X축의 Y 및 Z 값
17 | UCS Y 축 DXF: X 값, APP: 3D 벡터
27, 37 | DXF: UCS Y 축의 Y 및 Z 값
76 | UCS의 직교 유형 0 = UCS는 직교가 아님 1 = 맨 위, 2 = 맨 아래 3 = 앞, 4 = 뒤 5 = 왼쪽, 6 = 오른쪽
330 | 배치의 연관된 도면 공간 블록 테이블 레코드에 대한 ID/핸들
331 | 이 레이아웃이 현재 레이아웃인 동안 이 레이아웃에서 마지막으로 활성화된 뷰포트에 대한 ID/핸들
345 | UCS가 명명된 UCS인 경우, AcDbUCSTableRecord의 ID/핸들. 제공되지 않은 경우, UCS가 명명되지 않습니다.
346 | UCS가 직교인 경우, 기준 UCS의 AcDbUCSTableRecord의 ID/핸들(76 코드는 0이 아님). 제공되지 않고 76 코드가 0이 아닌 경우, 기준 UCS는 WORLD로 됩니다.
333 | 음영 플롯 ID


LIGHTLIST

LAYOUT
OBJECTS 섹션
MATERIAL
DXF 참조서 > OBJECTS 섹션 >
LIGHTLIST

다음 그룹 코드는 LIGHTLIST 객체에 사용됩니다. 여기에 설명되어 있는 그룹 코드 이외의 내용은 객체의 일반 그룹 코드를 참고하십시오. 이 테이블에서 사용된 축약어 및 형식에 대한 정보는 본 참조서의 형식화 규칙를 참고하십시오.

LIGHTLIST 그룹 코드
그룹 코드 | 설명
0 | 객체 이름(LIGHTLIST)
5 | 핸들
102 | 불변의 리액터 그룹의 시작, 항상 “{ACAD_REACTORS”
330 | 소유자 사전에 대한 소프트 포인터 ID/핸들. LIGHTLIST 객체의 경우 이것은 항상 명명된 객체 사전의 ACAD_LIGHT 항목입니다.
102 | 불변의 리액터 그룹의 시작, 항상 “}”
330 | 소유자 객체에 대한 소프트 포인터 ID/핸들
100 | 하위 클래스 표식기(AcDbLightList)
90 | 버전 번호
90 | 조명 수
5 | 조명 핸들(각 조명에 하나)
1 | 조명 이름(각 조명에 하나)


MATERIAL

LIGHTLIST
OBJECTS 섹션
MLINESTYLE
DXF 참조서 > OBJECTS 섹션 >
MATERIAL

다음 그룹 코드는 MATERIAL 객체에 사용됩니다. 여기에 설명되어 있는 그룹 코드 이외의 내용은 객체의 일반 그룹 코드를 참고하십시오. 이 테이블에서 사용된 축약어 및 형식에 대한 정보는 본 참조서의 형식화 규칙를 참고하십시오.

MATERIAL 그룹 코드
그룹 코드 | 설명
0 | 객체 이름(MATERIAL)
5 | 핸들
102 | 불변의 리액터 그룹의 시작, 항상 “{ACAD_REACTORS” (불변의 리액터 그룹은 기본 사전을 제외한 모든 사전에 표시됩니다.)
330 | 소유자 사전에 대한 소프트 포인터 ID/핸들. MATERIAL 객체의 경우 이것은 항상 명명된 객체 사전의 ACAD_MATERIAL 항목입니다.
102 | 불변의 리액터 그룹의 시작, 항상 “}”
100 | 하위 클래스 표식기(AcDbMaterial)
1 | 재료 이름(문자열)
2 | 설명(문자열, 기본 null 문자열)
70 | 주변 색상 방법(기본값 = 0): 0 = 현재 색상 사용 1 = 현재 색상 재지정
40 | 주변 색상 비율(실제, 기본값 = 1.0. 유효한 범위는 0.0~1.0임)
90 | 주변 색상 값(AcCmEntityColor를 나타내는 부호 없는 32 비트 정수)
71 | 분산 색상 방법(기본값 = 0): 0 = 현재 색상 사용 1 = 현재 색상 재지정
41 | 확산 색 비율(실제, 기본값 = 1.0. 유효한 범위는 0.0~1.0임)
91 | 분산 색상 값(AcCmEntityColor를 나타내는 부호 없는 32 비트 정수)
42 | 분산 맵 혼합 요인(실수, 기본값 = 1.0)
72 | 분산 맵 소스(기본값= 1): 0 = 현재 장면 사용 1 = 이미지 파일 사용(파일 이름으로 지정됨, null 파일 이름은 매핑 없음을 지정합니다.)
3 | 분산 맵 파일 이름(문자열, 기본값 = null 문자열)
73 | 분산 맵 맵퍼의 투영 방법(기본값= 1): 1 = 평면형 2 = 상자 3 = 원통 4 = 구형
74 | 분산 맵 맵퍼의 타일링 방법(기본값= 1): 1 = 타일식 2 = 오리기 3 = 계단식
75 | 분산 맵 맵퍼의 자동 변환 방법(비트 세트, 기본값 = 1): 1= 자동 변환 없음 2 = 현재 도면요소 범위에 대해 맵퍼 축척, 도면요소 원점으로 맵퍼 변환 4 = 현재 블록 변환을 맵퍼 변환에 포함
43 | 분산 맵 맵퍼의 변환 행렬(16개 실수; 행 주 형식; 기본값 = 단위 행렬)
44 | 완전 반사 광택 요인(실수, 기본값 = 0.5)
76 | 완전 반사 색상 방법(기본값 = 0): 0 = 현재 색상 사용 1 = 현재 색상 재지정
45 | 완전 반사 색상 요인(실수, 기본값 = 1.0; 유효한 범위는 0.0에서 1.0까지임)
92 | 완전 반사 색상 값(AcCmEntityColor를 나타내는 부호 없는 32 비트 정수)
46 | 완전 반사 맵 혼합 요인(실수; 기본값 = 1.0)
77 | 완전 반사 맵 소스(기본값= 1): 0 = 현재 장면 사용 1 = 이미지 파일 사용(파일 이름으로 지정됨, null 파일 이름은 매핑 없음을 지정합니다.)
4 | 완전 반사 맵 파일 이름(문자열; 기본값 = null 문자열)
78 | 완전 반사 맵 맵퍼의 투영 방법(기본값= 1): 1 = 평면형 2 = 상자 3 = 원통 4 = 구형
79 | 완전 반사 맵 맵퍼의 타일링 방법(기본값= 1): 1 = 타일식 2 = 오리기 3 = 계단식
170 | 완전 반사 맵 맵퍼의 자동 변환 방법(비트 세트, 기본값 = 1): 1 = 자동 변환 없음 2 = 현재 도면요소 범위에 대해 맵퍼 축척, 도면요소 원점으로 맵퍼 변환 4 = 현재 블록 변환을 맵퍼 변환에 포함
47 | 완전 반사 맵 맵퍼의 변환 행렬(16개 실수; 행 주 형식; 기본값 = 단위 행렬)
48 | 반사 맵의 혼합 요인(실수, 기본값 = 1.0)
171 | 반사 맵 소스(기본값= 1): 0 = 현재 장면 사용 1 = 이미지 파일 사용(파일 이름으로 지정됨, null 파일 이름은 매핑 없음을 지정합니다.)
6 | 반사 맵 파일 이름(문자열; 기본값 = null 문자열)
172 | 반사 맵 맵퍼의 투영 방법(기본값= 1): 1 = 평면형 2 = 상자 3 = 원통 4 = 구형
173 | 반사 맵 맵퍼의 타일링 방법(기본값= 1): 1 = 타일식 2 = 오리기 3 = 계단식
174 | 반사 맵 맵퍼의 자동 변환 방법(비트 세트, 기본값 = 1): 1 = 자동 변환 없음 2 = 현재 도면요소 범위에 대해 맵퍼 축척, 도면요소 원점으로 맵퍼 변환 4 = 현재 블록 변환을 맵퍼 변환에 포함
49 | 반사 맵 맵퍼의 변환 행렬(16개 실수; 행 주 형식; 기본값 = 단위 행렬)
140 | 불투명 퍼센트(실수; 기본값 = 1.0)
141 | 불투명 맵의 혼합 요인(실수; 기본값 = 1.0)
175 | 불투명 맵 소스(기본값= 1): 0 = 현재 장면 사용 1 = 이미지 파일 사용(파일 이름으로 지정됨, null 파일 이름은 매핑 없음을 지정합니다.)
7 | 불투명 맵 파일 이름(문자열; 기본값 = null 문자열)
176 | 불투명 맵 맵퍼의 투영 방법(기본값= 1): 1 = 평면형 2 = 상자 3 = 원통 4 = 구형
177 | 불투명 맵 맵퍼의 타일링 방법(기본값= 1): 1 = 타일식 2 = 오리기 3 = 계단식
178 | 불투명 맵 맵퍼의 자동 변환 방법(비트 세트, 기본값 = 1): 1 = 자동 변환 없음 2 = 현재 도면요소 범위에 대해 맵퍼 축척, 도면요소 원점으로 맵퍼 변환 4 = 현재 블록 변환을 맵퍼 변환에 포함
142 | 불투명 맵 맵퍼의 변환 행렬(16개 실수; 행 주 형식; 기본값 = 단위 행렬)
143 | 융기 맵의 혼합 요인(실수; 기본값 = 1.0)
179 | 융기 맵 소스(기본값= 1): 0 = 현재 장면 사용 1 = 이미지 파일 사용(파일 이름으로 지정됨, null 파일 이름은 매핑 없음을 지정합니다.)
8 | 융기 맵 파일 이름(문자열; 기본값 = null 문자열)
270 | 융기 맵 맵퍼의 투영 방법(기본값= 1): 1 = 평면형 2 = 상자 3 = 원통 4 = 구형
271 | 융기 맵 맵퍼의 타일링 방법(기본값= 1): 1 = 타일식 2 = 오리기 3 = 계단식
272 | 융기 맵 맵퍼의 자동 변환 방법(비트 세트, 기본값 = 1): 1 = 자동 변환 없음 2 = 현재 도면요소 범위에 대해 맵퍼 축척, 도면요소 원점으로 맵퍼 변환 4 = 현재 블록 변환을 맵퍼 변환에 포함
144 | 융기 맵 맵퍼의 변환 행렬(16개 실수; 행 주 형식; 기본값 = 단위 행렬)
145 | 굴절 색인(실수; 기본값 = 1.0)
146 | 굴절 맵의 혼합 요인(실수; 기본값 = 1.0)
273 | 굴절 맵 소스(기본값= 1): 0 = 현재 장면 사용 1 = 이미지 파일 사용(파일 이름으로 지정됨, null 파일 이름은 매핑 없음을 지정합니다.)
9 | 굴절 맵 파일 이름(문자열; 기본값 = null 문자열)
274 | 굴절 맵 맵퍼의 투영 방법(기본값= 1): 1 = 평면형 2 = 상자 3 = 원통 4 = 구형
275 | 굴절 맵 맵퍼의 타일링 방법(기본값= 1): 1 = 타일식 2 = 오리기 3 = 계단식
276 | 굴절 맵 맵퍼의 자동 변환 방법(비트 세트, 기본값 = 1): 1 = 자동 변환 없음 2 = 현재 도면요소 범위에 대해 맵퍼 축척, 도면요소 원점으로 맵퍼 변환 4 = 현재 블록 변환을 맵퍼 변환에 포함
147 | 굴절 맵 맵퍼의 변환 행렬(16개 실수; 행 주 형식; 기본값 = 단위 행렬)
460 | 색상 번짐 축척
461 | 간접 덤프 축척
462 | 반사 배율
463 | 투과율 배율
290 | 양면 재료
464 | 광도
270 | 조도 모드
271 | 법선 맵 메서드
465 | 법선 맵 강도
42 | 법선 맵 혼합 비율
72 | 법선 맵 원본
3 | 법선 맵 원본 파일 이름
73 | 법선 맵퍼 투영
74 | 법선 맵퍼 배열
75 | 법선 맵퍼 자동 변환
43 | 법선 맵퍼 변환
293 | 익명 재료
272 | 전역 조명 모드
273 | 파이널 게더링 모드
300 | GenProcName
291 | GenProcValBool
271 | GenProcValInt
469 | GenProcValReal
301 | GenProcValText
292 | GenProcTableEnd
62 | GenProcValColorIndex
420 | GenProcValColorRGB
430 | GenProcValColorName
270 | U 배열 매핑
271 | V 배열 매핑


MLINESTYLE

MATERIAL
OBJECTS 섹션
OBJECT_PTR
DXF 참조서 > OBJECTS 섹션 >
MLINESTYLE

다음 그룹 코드는 MLINESTYLE 객체에 사용됩니다. 여기에 설명되어 있는 그룹 코드 이외의 내용은 객체의 일반 그룹 코드를 참고하십시오. 이 테이블에서 사용된 축약어 및 형식에 대한 정보는 본 참조서의 형식화 규칙를 참고하십시오.

MLINESTYLE 그룹 코드
그룹 코드 | 설명
0 | 객체 이름(MLINESTYLE)
5 | 핸들
102 | 불변의 리액터 그룹의 시작, 항상 “{ACAD_REACTORS” (불변의 리액터 그룹은 기본 사전을 제외한 모든 사전에 표시됩니다.)
330 | 소유자 사전에 대한 소프트 포인터 ID/핸들. MLINESTYLE 객체의 경우 이것은 항상 명명된 객체 사전의 ACAD_MLINESTYLE 항목입니다.
102 | 불변의 리액터 그룹의 시작, 항상 “}”
100 | 하위 클래스 표식기(AcDbMlineStyle)
2 | 다중선 스타일 이름
70 | 비트 코드화된 플래그: 1 =채우기 2 = 미터 표시 16 = 사각형 끝(선) 마개 시작 32 = 내부 호 마개 시작 64 = 둥근(외부 호) 마개 시작 256 = 사각형(선) 마개 끝 512 = 내부 호 마개 끝 1024 = 둥근(외부 호) 마개 끝
3 | 스타일 설명(문자열, 최대 255자)
62 | 채우기 색상(정수, 기본값 = 256)
51 | 시작 각도(실수, 기본값은 90도임)
52 | 끝 각도(실수, 기본값은 90도임)
71 | 요소 개수
49 | 요소 간격띄우기(실수, 기본값 없음). 여러 항목이 존재할 수 있음; 각 요소당 하나의 항목
62 | 요소 색상(정수, 기본값 = 0). 여러 항목이 존재할 수 있음; 각 요소당 하나의 항목
6 | 요소 선종류(문자열, 기본값 = BYLAYER). 여러 항목이 존재할 수 있음; 각 요소당 하나의 항목

다중선 도면요소와 MLINESTYLE 객체의 그룹 코드 2는 중복 필드입니다. 이런 그룹은 안전하게 읽을 수 있고 그 값을 사용할 수 있다 하더라도 어떤 상황에서든 수정해서는 안됩니다. 수정할 올바른 필드는 다음과 같습니다.

다중선

같은 객체에서 적절한 MLINESTYLE 객체를 나타내는 340 그룹.

다중선 스타일

현재 다중선 스타일의 핸들이나 도면요소 이름을 가진 350 그룹 이전에 있는 MLINESTYLE 사전의 3 그룹 값.


OBJECT_PTR

MLINESTYLE
OBJECTS 섹션
PLOTSETTINGS
DXF 참조서 > OBJECTS 섹션 >
OBJECT_PTR

다음 그룹 코드는 OBJECT_PTR 객체에 사용됩니다. 여기에 설명되어 있는 그룹 코드 이외의 내용은 객체의 일반 그룹 코드를 참고하십시오. 이 테이블에서 사용된 축약어 및 형식에 대한 정보는 본 참조서의 형식화 규칙를 참고하십시오.

OBJECT_PTR 그룹 코드
그룹 코드 | 설명
0 | 객체 이름(OBJECT_PTR)
5 | 핸들
102 | 불변의 리액터 그룹의 시작, 항상 “{ACAD_REACTORS”
330 | 소유자 사전에 대한 소프트 포인터 ID/핸들
102 | 불변의 리액터 그룹의 시작, 항상 “}”
1001 | ASE xdata 시작(DC015)


PLOTSETTINGS

OBJECT_PTR
OBJECTS 섹션
RASTERVARIABLES
DXF 참조서 > OBJECTS 섹션 >
PLOTSETTINGS

다음 그룹 코드는 PLOTSETTINGS 객체에 사용됩니다. 여기에 설명되어 있는 그룹 코드 이외의 내용은 객체의 일반 그룹 코드를 참고하십시오. 이 테이블에서 사용된 축약어 및 형식에 대한 정보는 본 참조서의 형식화 규칙를 참고하십시오.

PLOTSETTINGS 그룹 코드
그룹 코드 | 설명
0 | 객체 이름(PLOTSETTINGS)
5 | 핸들
102 | 불변의 리액터 그룹의 시작, 항상 “{ACAD_REACTORS”
330 | 소유자 사전에 대한 소프트 포인터 ID/핸들
102 | 불변의 리액터 그룹의 시작, 항상 “}”
330 | 소유자 객체에 대한 소프트 포인터 ID/핸들
100 | 하위 클래스 표식기(AcDbPlotSettings)
1 | 페이지 설정 이름
2 | 시스템 프린터 또는 플롯 구성 파일의 이름
4 | 용지 크기
6 | 플롯 뷰 이름
40 | 밀리미터 단위로 나타낸 용지 왼쪽 인쇄 불가능 여백의 크기
41 | 밀리미터 단위로 나타낸 용지 맨 아래 인쇄 불가능 여백의 크기
42 | 밀리미터 단위로 나타낸 용지 오른쪽 인쇄 불가능 여백의 크기
43 | 밀리미터 단위로 나타낸 용지 맨 위 인쇄 불가능 여백의 크기
44 | 플롯 용지 크기: 밀리미터 단위의 실제 용지 폭
45 | 플롯 용지 크기: 밀리미터 단위의 실제 용지 높이
46 | 플롯 원점: 밀리미터 단위로 나타낸 원점 간격띄우기의 X 값
47 | 플롯 원점: 밀리미터 단위로 나타낸 원점 간격띄우기의 Y 값
48 | 플롯 윈도우 영역: 윈도우 왼쪽 아래 구석의 X 값
49 | 플롯 윈도우 영역: 윈도우 오른쪽 위 구석의 Y 값
140 | 플롯 윈도우 영역: 윈도우 왼쪽 아래 구석의 X 값
141 | 플롯 윈도우 영역: 윈도우 오른쪽 위 구석의 Y 값
142 | 사용자 인쇄 축척의 분자: 실사회(용지) 단위
143 | 사용자 인쇄 축척의 분모: 도면 단위
70 | 플롯 레이아웃 플래그: 1 = PlotViewportBorders 2 = ShowPlotStyles 4 = PlotCentered 8 = PlotHidden 16 = UseStandardScale 32 = PlotPlotStyles 64 = ScaleLineweights 128 = PrintLineweights 512 = DrawViewportsFirst 1024 = ModelType 2048 = UpdatePaper 4096 = ZoomToPaperOnUpdate 8192 = 시작 16384 = PrevPlotInit
72 | 플롯 용지 단위: 0 = 인치 단위의 플롯 1 = 밀리미터 단위의 플롯 2 = 픽셀 단위의 플롯
73 | 플롯 회전: 0 = 회전 안함 1 = 시계 반대 방향으로 90도 2 = 거꾸로 3 = 시계 방향으로 90도
74 | 플롯 유형(매체로 출력할 도면 공간 부분): 0 = 마지막 화면 표시 1 = 도면 범위 2 = 도면 한계 3 = 코드 6에서 지정된 뷰 4 = 코드 48, 49, 140 및 141에서 지정된 윈도우 5 = 레이아웃 정보
7 | 현재 스타일 시트
75 | 표준 축척 유형: 0 = 꼭 맞게 축척 1 = 1/128"=1'; 2 = 1/64"=1'; 3 = 1/32"=1' 4 = 1/16"=1'; 5 = 3/32"=1'; 6 = 1/8"=1' 7 = 3/16"=1'; 8 = 1/4"=1'; 9 = 3/8"=1' 10 = 1/2"=1'; 11 = 3/4"=1'; 12 = 1"=1' 13 = 3"=1'; 14 = 6"=1'; 15 = 1'=1' 16= 1:1 ; 17= 1:2; 18 = 1:4; 19 = 1:8; 20 = 1:10; 21= 1:16 22 = 1:20; 23 = 1:30; 24 = 1:40; 25 = 1:50; 26 = 1:100 27 = 2:1; 28 = 4:1; 29 = 8:1; 30 = 10:1; 31 = 100:1; 32 = 1000:1
76 | ShadePlot 모드: 0 = 표시되는 대로 1 = 와이어프레임 2 = 숨김 3 = 렌더됨
77 | ShadePlot 해상도 수준: 0 = 초안 1 = 미리보기 2 = 일반 3 = 프리젠테이션 4 = 최대 5 = 사용자
78 | ShadePlot 사용자 DPI: 유효 범위: 100-32767 ShadePlot 해상도 수준이 5(사용자)로 설정된 경우에만 적용됩니다.
147 | 코드 75에서 지정된 표준 축척 값을 나타내는 부동 소수점 축척 요인
148 | 용지 이미지 원점: X 값
149 | 용지 이미지 원점: Y 값
333 | ShadePlot ID/핸들(선택 사항)


RASTERVARIABLES

PLOTSETTINGS
OBJECTS 섹션
RENDER
DXF 참조서 > OBJECTS 섹션 >
RASTERVARIABLES

다음 그룹 코드는 RASTERVARIABLES 객체에 사용됩니다. 여기에 설명되어 있는 그룹 코드 이외의 내용은 객체의 일반 그룹 코드를 참고하십시오. 이 테이블에서 사용된 축약어 및 형식에 대한 정보는 본 참조서의 형식화 규칙를 참고하십시오.

RASTERVARIABLES 그룹 코드
그룹 코드 | 설명
0 | 객체 이름(RASTERVARIABLES)
5 | 핸들
102 | 불변의 리액터 그룹의 시작, 항상 “{ACAD_REACTORS”
330 | 소유자 사전에 대한 소프트 포인터 ID/핸들. RASTERVARIABLES 객체의 경우 이것은 항상 명명된 객체 사전의 ACAD_IMAGE_VARS 항목입니다.
102 | 불변의 리액터 그룹의 시작, 항상 “}”
100 | 하위 클래스 표식기(AcDbRasterVariables)
90 | 클래스 버전 0
70 | 이미지 프레임 표시 플래그: 0 = 프레임 없음, 1 = 프레임 표시
71 | 이미지 표시 품질(화면에만 해당): 0 = 초안, 1 = 높음
72 | 이미지 삽입을 위한 AutoCAD 단위. 즉 하나의 AutoCAD 단위는 이미지를 연관된 해상도로 삽입 및 축척하기 위해 동일하다는 것을 뜻합니다. 0 = 없음, 1 = 밀리미터, 2 = 센티미터 3 = 미터, 4 = 킬로미터, 5 = 인치 6 = 피트, 7 = 야드, 8 = 마일


RENDER

RASTERVARIABLES
OBJECTS 섹션
RENDERENVIRONMENT
DXF 참조서 > OBJECTS 섹션 >
RENDER

렌더 관련 그룹 코드

이 단원의 항목

  • RENDERENVIRONMENT
  • MENTALRAYRENDERSETTINGS
  • RENDERGLOBAL


RENDERENVIRONMENT

RENDER
RENDER
MENTALRAYRENDERSETTINGS
DXF 참조서 > OBJECTS 섹션 > RENDER >
RENDERENVIRONMENT

다음 그룹 코드는 RENDERENVIRONMENT 객체에 사용됩니다. 여기에 설명되어 있는 그룹 코드 이외의 내용은 객체의 일반 그룹 코드를 참고하십시오. 이 테이블에서 사용된 축약어 및 형식에 대한 정보는 본 참조서의 형식화 규칙를 참고하십시오.

RENDERENVIRONMENT 그룹 코드
그룹 코드 | 설명
0 | 객체 이름(RENDERENVIRONMENT)
5 | 핸들
102 | 불변의 리액터 그룹의 시작, 항상 “{ACAD_REACTORS”
330 | 소유자 사전에 대한 소프트 포인터 ID/핸들. RENDERENVIRONMENT 객체의 경우 이것은 항상 명명된 객체 사전의 ACAD_RENDER_ENVIRONMENT 항목입니다.
102 | 불변의 리액터 그룹의 시작, 항상 “}”
100 | 하위 클래스 표식기(AcDbRenderEnvironment)
90 | 클래스 버전 1
290 | 안개 사용 플래그, 사용 가능할 경우 1
290 | 배경 안개 플래그, 사용 가능할 경우 1
280, 280, 280 | 안개 색상, 빨간색, 초록색 및 파란색 채널 값
40, 40 | 안개 밀도, 퍼센트로 가깝고 먼 밀도
40, 40 | 카메라와 먼 자르기 평면 사이의 거리 퍼센트로 가깝고 먼 거리
290 | 환경 이미지 플래그
1 | 환경 이미지 파일 이름(이전 플래그가 0일 경우 공백이 될 수 있음)


MENTALRAYRENDERSETTINGS

RENDERENVIRONMENT
RENDER
RENDERGLOBAL
DXF 참조서 > OBJECTS 섹션 > RENDER >
MENTALRAYRENDERSETTINGS

다음 그룹 코드는 MENTALRAYRENDERSETTINGS 객체에 사용됩니다. 여기에 설명되어 있는 그룹 코드 이외의 내용은 객체의 일반 그룹 코드를 참고하십시오. 이 테이블에서 사용된 축약어 및 형식에 대한 정보는 본 참조서의 형식화 규칙를 참고하십시오.

MENTALRAYRENDERSETTINGS 그룹 코드
그룹 코드 | 설명
0 | 객체 이름(MENTALRAYRENDERSETTINGS)
5 | 핸들
102 | 불변의 리액터 그룹의 시작, 항상 “{ACAD_REACTORS”
330 | 소유자 사전에 대한 소프트 포인터 ID/핸들
102 | 불변의 리액터 그룹의 시작, 항상 “}”
100 | 하위 클래스 표식기(AcDbRenderSettings)
90 | 클래스 버전 1
1 | 렌더 사전 설정 이름
290 | 렌더 재료 플래그
90 | 텍스츄어 견본 품질
290 | 렌더 뒷면 플래그
290 | 렌더 그림자 플래그
1 | 미리보기 이미지 파일 이름(공백이 될 수 있음)
100 | 하위 클래스 표식기(AcDbMentalRayRenderSettings)
90 | 클래스 버전 1
90 | 견본 비율(최소)
90 | 견본 비율(최대)
70 | 견본 필터 유형 0 = 상자 1 = 삼각형 2 = 가우스 3 = Mitchell 4 = Lanczos
40, 40 | 필터 폭, 높이
40, 40, 40, 40 | 견본 대비 색상, 빨간색, 초록색, 파란색 및 알파 채널 값
70 | 그림자 모드 0 = 단순 1 = 정렬 2 = 세그먼트
290 | 그림자 맵 플래그, 매핑된 그림자를 사용하는 조명에만 적용됨
290 | 광선 추적 플래그
90, 90, 90 | 반사, 굴절의 광선 추적 깊이 및 최대 깊이
290 | 전역 조명 플래그
90 | 광자/견본 개수
290 | 전역 조명 반지름 플래그
40 | 전역 조명 견본 반지름
90 | 광원당 광자 수
90, 90, 90 | 반사, 굴절의 전역 조명 광선 추적 깊이 및 최대 깊이
290 | 파이널 게더링 플래그
90 | 파이널 게더링 광선 개수
290, 290 | 파이널 게더링 최소 및 최대 반지름 플래그
290 | 파이널 게더링 픽셀 플래그
40, 40 | 파이널 게더링 최소 및 최대 견본 반지름
40 | 광도 축척(에너지 승수)
70 | 진단 모드 0 = 끄기 1 = 모눈 2 = 광자 4 = BSP
70 | 진단 모눈 모드 0 = 객체 1 = 표준 2 = 카메라
40 | 모눈 크기
70 | 진단 광자 모드 0 = 밀도 1 = 복사조도
70 | 진단 BSP 모드 0 = 깊이 1 = 크기
290 | MI 통계 플래그 내보내기
1 | MI 통계 파일 이름(공백이 될 수 있음)
90 | 배열 크기
70 | 배열 순서 0 = 힐베르트 1 = 나선 2 = 왼쪽에서 오른쪽으로 3 = 오른쪽에서 왼쪽으로 4 = 하향식 5 = 상향식
90 | 메모리 한계


RENDERGLOBAL

MENTALRAYRENDERSETTINGS
RENDER
SECTION
DXF 참조서 > OBJECTS 섹션 > RENDER >
RENDERGLOBAL

다음 그룹 코드는 RENDERGLOBAL 객체에 의해 사용됩니다. 여기에 설명되어 있는 그룹 코드 이외의 내용은 객체의 일반 그룹 코드를 참고하십시오. 이 테이블에서 사용된 축약어 및 형식에 대한 정보는 본 참조서의 형식화 규칙를 참고하십시오.

RENDERGLOBAL 그룹 코드
그룹 코드 | 설명
0 | 객체 이름(RENDERGLOBAL)
5 | 핸들
102 | 불변의 리액터 그룹의 시작, 항상 “{ACAD_REACTORS”
330 | 소유자 사전에 대한 소프트 포인터 ID/핸들. RENDERGLOBAL 객체의 경우 이것은 항상 명명된 객체 사전의 ACAD_RENDER_GLOBAL 항목입니다.
102 | 불변의 리액터 그룹의 시작, 항상 “}”
100 | 하위 클래스 표식기(AcDbRenderGlobal)
90 | 클래스 버전 2
90 | 렌더 절차: 0 = 보기 1 = 오리기 2 = 선택
90 | 렌더 대상 0 = 렌더 윈도우 1 = 뷰포트
290 | 파일 플래그로 저장
1 | 렌더 이미지 저장 파일 이름
90 | 이미지 폭
90 | 이미지 높이
290 | 미리 정의된 사전 설정 첫 번째 플래그
290 | 높은 정보 수준 플래그


SECTION

RENDERGLOBAL
OBJECTS 섹션
단면 관리자
DXF 참조서 > OBJECTS 섹션 >
SECTION

단면 관리자 및 단면 설정 그룹 코드.

이 단원의 항목

  • 단면 관리자
  • 단면 설정
  • 단면 유형 설정
  • 단면 형상 설정


단면 관리자

SECTION
SECTION
단면 설정
DXF 참조서 > OBJECTS 섹션 > SECTION >
단면 관리자

다음 그룹 코드는 SECTIONMANAGER 객체에 적용됩니다. 이 테이블에서 사용된 축약어 및 형식에 대한 정보는 본 참조서의 형식화 규칙를 참고하십시오.

SECTIONMANAGER 그룹 코드
그룹 코드 | 설명
0 | 객체 이름(SECTIONMANAGER)
5 | 핸들
102 | 불변의 리액터 그룹의 시작, 항상 “{ACAD_REACTORS”
330 | 소유자 사전에 대한 소프트 포인터 ID/핸들
102 | 불변의 리액터 그룹의 시작, 항상 “}”
330 | 소유자 객체에 대한 소프트 소유자 ID/핸들
100 | 하위 클래스 표식기(AcDbSectionManager)
70 | 전체 업데이트 플래그가 필요합니다.
90 | 단면 수
330 | 단면 도면요소에 대한 소프트 포인터 ID/핸들(단면 수만큼 반복됩니다.)


단면 설정

단면 관리자
SECTION
단면 유형 설정
DXF 참조서 > OBJECTS 섹션 > SECTION >
단면 설정

다음 그룹 코드는 SECTIONSETTINGS 객체에 적용됩니다. 이 테이블에서 사용된 축약어 및 형식에 대한 정보는 본 참조서의 형식화 규칙를 참고하십시오.

SECTIONSETTINGS 그룹 코드
그룹 코드 | 설명
0 | 객체 이름(SECTIONSETTINGS)
5 | 핸들
102 | 불변의 리액터 그룹의 시작, 항상 “{ACAD_REACTORS”
330 | 소유자 사전에 대한 소프트 포인터 ID/핸들
102 | 불변의 리액터 그룹의 시작, 항상 “}”
330 | 소유자 객체에 대한 소프트 소유자 ID/핸들
100 | 하위 클래스 표식기(AcDbSectionSettings)
90 | 단면 유형
91 | 생성 설정 수
 | 단면 유형 설정 데이터는 다음을 따릅니다.


단면 유형 설정

단면 설정
SECTION
단면 형상 설정
DXF 참조서 > OBJECTS 섹션 > SECTION >
단면 유형 설정

다음 그룹 코드는 단면 유형 설정에 적용됩니다. 이 테이블에서 사용된 축약어 및 형식에 대한 정보는 본 참조서의 형식화 규칙를 참고하십시오.

단면 유형 설정 그룹 코드
그룹 코드 | 설명
1 | “SectionTypeSettings” 표식기
90 | 단면 유형
91 | 생성 옵션 플래그
92 | 원본 객체 수
330 | 원본 객체에 대한 소프트 포인터 ID/핸들(원본 객체 수만큼 반복됩니다.)
331 | 대상 블록 객체에 대한 소프트 포인터 ID/핸들
1 | 대상 파일 이름
93 | 생성 설정 수
2 | “SectionGeometrySettings” 데이터 표식기
 | 단면 형상 설정 데이터
3 | “SectionTypeSettingsEnd” 표식기


단면 형상 설정

단면 유형 설정
SECTION
SPATIAL_INDEX
DXF 참조서 > OBJECTS 섹션 > SECTION >
단면 형상 설정

다음 그룹 코드는 단면 형상 설정에 적용됩니다. 이 테이블에서 사용된 축약어 및 형식에 대한 정보는 본 참조서의 형식화 규칙를 참고하십시오.

단면 형상 설정 그룹 코드
그룹 코드 | 설명
90 | 단면 유형
91 | 형상 개수
92 | 비트 플래그
63 | 색상 데이터
8 | 도면층 이름
6 | 선종류 이름
40 | 선종류 축척
1 | 플롯 스타일 이름
370 | 선 가중치
70 | 면 투명도
71 | 모서리 투명도
72 | 해치 패턴 유형
2 | 해치 패턴 이름
41 | 해치 각도
42 | 해치 축척
43 | 해치 간격두기
3 | “SectionGeometrySettingsEnd” 데이터 표식기


SPATIAL_INDEX

단면 형상 설정
OBJECTS 섹션
SPATIAL_FILTER
DXF 참조서 > OBJECTS 섹션 >
SPATIAL_INDEX

다음 그룹 코드는 SPATIAL_INDEX 객체에 사용됩니다. 여기에 설명되어 있는 그룹 코드 이외의 내용은 객체의 일반 그룹 코드를 참고하십시오. 이 테이블에서 사용된 축약어 및 형식에 대한 정보는 본 참조서의 형식화 규칙를 참고하십시오.

SPATIAL_INDEX 그룹 코드
그룹 코드 | 설명
0 | 객체 이름(SPATIAL_INDEX)
5 | 핸들
102 | 불변의 리액터 그룹의 시작, 항상 “{ACAD_REACTORS”
330 | 소유자 사전에 대한 소프트 포인터 ID/핸들
102 | 불변의 리액터 그룹의 시작, 항상 “}”
100 | 하위 클래스 표식기(AcDbIndex)
40 | 시간 스탬프(율리우스력 날짜)
100 | 하위 클래스 표식기(AcDbSpatialIndex)

SPATIAL_INDEX는 항상 비어 있는 상태로 DXF 파일에 씌어집니다. 이 객체는 무시할 수 있습니다.


SPATIAL_FILTER

SPATIAL_INDEX
OBJECTS 섹션
SORTENTSTABLE
DXF 참조서 > OBJECTS 섹션 >
SPATIAL_FILTER

다음 그룹 코드는 SPATIAL_FILTER 객체에 사용됩니다. 여기에 설명되어 있는 그룹 코드 이외의 내용은 객체의 일반 그룹 코드를 참고하십시오. 이 테이블에서 사용된 축약어 및 형식에 대한 정보는 본 참조서의 형식화 규칙를 참고하십시오.

SPATIAL_FILTER 그룹 코드
그룹 코드 | 설명
0 | 객체 이름(SPATIAL_FILTER)
5 | 핸들
102 | 불변의 리액터 그룹의 시작, 항상 “{ACAD_REACTORS”
330 | 소유자 사전에 대한 소프트 포인터 ID/핸들(SPATIAL)
102 | 불변의 리액터 그룹의 시작, 항상 “}”
100 | 하위 클래스 표식기(AcDbFilter)
100 | 하위 클래스 표식기(AcDbSpatialFilter)
70 | 자르기 경계 위의 점의 수 2 = 직사각형 자르기 경계(왼쪽 아래 및 오른쪽 위) 2개보다 많음 = 폴리선 자르기 경계
10 | 외부 참고 축척 1을 기준으로 한 자르기 경계 정의점(OCS)(항상 2개 이상) DXF: X 값, APP: 2D 점
20 | DXF: 경계 정의점의 Y 값(항상 2 이상)
210 | 자르기 경계가 포함된 평면에 수직 DXF: X 값, APP: 3D 벡터
220, 230 | DXF: 돌출 방향의 Y 및 Z 값
11 | 자르기 경계의 로컬 좌표계를 정의하기 위해 사용된 원점 DXF: X 값, APP: 3D 점
21, 31 | 자르기 경계의 로컬 좌표계를 정의하기 위해 사용된 원점 DXF: Y 및 Z 값
71 | 사용 가능한 자르기 경계 표시 플래그 0 = 사용 안함, 1 = 사용
72 | 앞면 자르기 평면 플래그; 0 = 아니오; 1 = 예
40 | 앞면 자르기 평면 거리(코드 72 = 1인 경우)
73 | 뒷면 자르기 평면 플래그; 0 = 아니오; 1 = 예
41 | 뒷면 자르기 평면 거리(코드 73 = 1인 경우)
40 | 열의 주 순서를 사용해 작성된 4x3 변환 행렬. 이 행렬은 원본 블록 참조(삽입 도면요소) 변환의 역입니다. 원본 블록 참조 변환은 블록 참조가 재생성될 때 블록 내의 모든 도면요소에 적용되는 변환입니다(항상 12개 항목).
40 | 열의 주 순서를 사용해 작성된 4x3 변환 행렬. 이 행렬은 점을 자르기 경계의 좌표계로 변환합니다(12개 항목).


SORTENTSTABLE

SPATIAL_FILTER
OBJECTS 섹션
SUNSTUDY
DXF 참조서 > OBJECTS 섹션 >
SORTENTSTABLE

다음 그룹 코드는 SORTENTSTABLE 객체에 사용됩니다. 여기에 설명되어 있는 그룹 코드 이외의 내용은 객체의 일반 그룹 코드를 참조하십시오. 이 테이블에서 사용된 축약어 및 형식에 대한 정보는 본 참조서의 형식화 규칙를 참고하십시오.

SORTENTSTABLE 그룹 코드
그룹 코드 | 설명
0 | 객체 이름(SORTENTSTABLE)
5 | 핸들
102 | 불변의 리액터 그룹의 시작, 항상 “{ACAD_REACTORS”
330 | 소유자 사전에 대한 소프트 포인터 ID/핸들(ACAD_SORTENTS)
102 | 불변의 리액터 그룹의 시작, 항상 “}”
100 | 하위 클래스 표식기(AcDbSortentsTable)
330 | 소유자에 대한 소프트 포인터 ID/핸들(현재는 *MODEL_SPACE 블록 또는 *PAPER_SPACE 블록에만 해당됨)
331 | 도면요소에 대한 소프트 포인터 ID/핸들(0개 이상의 항목이 존재할 수 있음)
5 | 정렬 핸들(0개 이상의 항목이 존재할 수 있음)

SORTENTS 재생성 플래그(비트 코드값 16)가 설정된 경우 AutoCAD는 오름차순 핸들 순서로 도면요소를 재생성합니다. DRAWORDER 명령을 사용하면 SORTENTSTABLE 객체는 *Model_Space 또는 *Paper_Space 블록의 확장 사전에서 ACAD_SORTENTS 이름 아래에 부착됩니다. 이 사전과 관련된 SORTENTSTABLE 객체는 각 도면요소에 다른 핸들을 연관시키므로 도면요소의 재생성 순서가 다시 정의됩니다.


SUNSTUDY

SORTENTSTABLE
OBJECTS 섹션
TABLESTYLE
DXF 참조서 > OBJECTS 섹션 >
SUNSTUDY

다음 그룹 코드는 SUNSTUDY 객체에 사용됩니다. 여기에 설명되어 있는 그룹 코드 이외의 내용은 객체의 일반 그룹 코드를 참고하십시오. 이 테이블에서 사용된 축약어 및 형식에 대한 정보는 본 참조서의 형식화 규칙를 참고하십시오.

SUNSTUDY 그룹 코드
그룹 코드 | 설명
0 | 객체 이름(SUNSTUDY)
5 | 핸들
102 | 불변의 리액터 그룹의 시작, 항상 “{ACAD_REACTORS”
330 | 소유자 사전에 대한 소프트 포인터 ID/핸들
102 | 불변의 리액터 그룹의 시작, 항상 “}”
330 | 소유자 객체에 대한 소프트 소유자 ID/핸들
100 | 하위 클래스 표식기(AcDbSunStudy)
90 | 버전 번호
1 | 일영 설정 이름
2 | 설명
70 | 출력 유형
3 | 시트 세트 이름 출력 유형이 시트 세트일 경우에만 포함됩니다.
290 | 하위 세트 플래그 사용 출력 유형이 시트 세트일 경우만 포함됩니다.
4 | 시트 하위 세트 이름 출력 유형이 시트 세트일 경우만 포함됩니다.
291 | 달력 플래그에서 날짜 선택
91 | 날짜 입력 배열 크기(선택한 날짜 수를 나타냄)
90 | 율리우스력 일, 날짜를 나타냅니다. 선택한 각 날짜에 대한 하나의 항목
90 | 자정 이후의 초 수, 하루의 시간을 나타냅니다. 선택한 각 날짜에 대한 하나의 항목
292 | 날짜 범위 플래그 선택
93 | 시작 시간 날짜 범위 플래그가 참일 경우
94 | 끝 시간 날짜 범위 플래그가 참일 경우.
95 | 간격(초) 날짜 범위 플래그가 참일 경우.
73 | 시간
290 | 시간 위의 시간 항목에서 지정된 시간마다 한 항목
340 | 페이지 설정 마법사 하드 포인터 ID
341 | 뷰 하드 포인터 ID
342 | 뷰 스타일 ID
74 | 음영 플롯 유형
75 | 페이지당 뷰포트
76 | 뷰포트 분배를 위한 행 수
77 | 뷰포트 분배를 위한 열 수
40 | 간격두기
293 | 뷰포트 잠금 플래그
294 | 뷰포트 레이블 플래그
343 | 문자 스타일 ID


TABLESTYLE

SUNSTUDY
OBJECTS 섹션
UNDERLAYDEFINITION
DXF 참조서 > OBJECTS 섹션 >
TABLESTYLE

다음 그룹 코드는TABLESTYLE 객체에 사용됩니다. 여기에 설명되어 있는 그룹 코드 이외의 내용은 객체의 일반 그룹 코드를 참고하십시오. 이 테이블에서 사용된 축약어 및 형식에 대한 정보는 본 참조서의 형식화 규칙를 참고하십시오.

TABLESTYLE 그룹 코드
그룹 코드 | 설명
0 | 객체 이름(TABLESTYLE)
5 | 핸들
102 | 불변의 리액터 그룹의 시작, 항상 “{ACAD_REACTORS” (불변의 리액터 그룹은 기본 사전을 제외한 모든 사전에 표시됩니다.)
330 | 소유자 사전에 대한 소프트 포인터 ID/핸들. TABLESTYLE 객체의 경우 이 코드는 항상 명명된 객체 사전의 ACAD_TABLESTYLE 항목입니다.
102 | 불변의 리액터 그룹의 시작, 항상 “}”
100 | 하위 클래스 표식기(AcDbTableStyle)
3 | 테이블 스타일 설명(문자열, 최대 255자)
70 | FlowDirection(정수): 0 = 아래 1 = 위
71 | 비트 코드화된 플래그
40 | 수평 셀 여백(실제, 기본값 = 0.06)
41 | 수직 셀 여백(실제, 기본값 = 0.06)
280 | 제목 억제 여부에 대한 플래그: 0 = 억제되지 않음 1 = 억제됨
281 | 열 머리글 억제 여부에 대한 플래그: 0 = 억제되지 않음 1 = 억제됨
 | 다음 그룹 코드는 테이블의 셀마다 반복됩니다.
7 | 문자 스타일 이름(문자열, 기본값 = STANDARD)
140 | 문자 높이(실제)
170 | 셀 정렬(정수)
62 | 문자 색상(정수, 기본값 = BYBLOCK)
63 | 셀 채우기 색상(정수, 기본값 = 7)
283 | 배경 색상의 사용 여부에 대한 플래그(기본값 = 0): 0 = 사용 안함 1 = 사용
90 | 셀 데이터 유형
91 | 셀 단위 유형
274-279 | 셀의 각 경계 유형과 연관된 선가중치(기본값 = kLnWtByBlock)
284-289 | 셀의 각 경계 유형과 연관된 가시성 플래그(기본값= 1): 0 = 숨김 1 = 표시
64-69 | 셀의 각 경계 유형과 연관된 색상 값(기본값 = BYBLOCK)


UNDERLAYDEFINITION

TABLESTYLE
OBJECTS 섹션
VISUALSTYLE
DXF 참조서 > OBJECTS 섹션 >
UNDERLAYDEFINITION

다음 그룹 코드는 UNDERLAYDEFINITION 기호 테이블 항목에 적용됩니다. 여기에 설명되어 있는 그룹 코드 이외의 내용은 기호 테이블 항목의 일반 그룹 코드를 참고하십시오. 이 테이블에서 사용된 축약어 및 형식에 대한 정보는 본 참조서의 형식화 규칙를 참고하십시오.

UNDERLAYDEFINITION 그룹 코드
그룹 코드 | 설명
0 | 객체 이름(UNDERLAYDEFINITION)
5 | 핸들
102 | 불변의 리액터 그룹의 시작, 항상 “{ACAD_REACTORS”
330 | 소유자 사전에 대한 소프트 포인터 ID/핸들
102 | 불변의 리액터 그룹의 시작, 항상 “}”
100 | 하위 클래스 표식기(AcDbUnderlayDefinition)
1 | 밑바탕 경로 및 파일 이름
2 | 밑바탕 이름


VISUALSTYLE

UNDERLAYDEFINITION
OBJECTS 섹션
VBA_PROJECT
DXF 참조서 > OBJECTS 섹션 >
VISUALSTYLE

다음 그룹 코드는 VISUALSTYLE 객체에 적용됩니다. 이 테이블에서 사용된 축약어 및 형식에 대한 정보는 본 참조서의 형식화 규칙를 참고하십시오.

VISUALSTYLE 그룹 코드
그룹 코드 | 설명
0 | 객체 이름(VISUALSTYLE)
5 | 핸들
102 | 불변의 리액터 그룹의 시작, 항상 “{ACAD_REACTORS”
330 | 소유자 사전에 대한 소프트 포인터 ID/핸들
102 | 불변의 리액터 그룹의 시작, 항상 “}”
330 | 소유자 객체에 대한 소프트 소유자 ID/핸들
100 | 하위 클래스 표식기(AcDbVisualStyle)
2 | 설명
70 | 유형
71 | 면 조명 모형 0 =숨김 1 = 보임 2 = Phong 3 = Gooch
72 | 면 조명 품질 0 = 조명 없음 1 = 면 기준 조명 2 = 정점 기준 조명
73 | 면 색상 모드 0 = 색상 없음 1 = 객체 색상 2 = 배경 색상 3 = 사용자 색상 4 = 단색 5 = 색조 6 = 채도 없애기
90 | 면 수정자 0 = 수정자 없음 1 = 불투명 2 = 반사
40 | 면 불투명 수준
41 | 면 반사 수준
62, 63 | Color
421 | 면 스타일 단색
74 | 모서리 스타일 모형 0 = 모서리 없음 1 = 등각선 2 = 퍼셋 모서리
91 | 모서리 유형
64 | 모서리 교차 색상
65 | 가려진 모서리 색상
75 | 가려진 모서리 선종류
175 | 모서리 교차 선종류
42 | 모서리 주름 각도
92 | 모서리 수정자
66 | 모서리 색상
43 | 모서리 불투명 수준
76 | 모서리 폭
77 | 모서리 돌출부
78 | 모서리 지터
67 | 모서리 윤곽 색상
79 | 모서리 윤곽 폭
170 | 모서리 halo 격차(갭)
171 | 모서리 등각선 수
290 | 모서리 가리기 정밀도 플래그
174 | 모서리 스타일 적용 플래그
93 | 스타일 표시 설정값 표시
44 | 밝기
173 | 그림자 유형
291 | 내부 전용 플래그


VBA_PROJECT

VISUALSTYLE
OBJECTS 섹션
WIPEOUTVARIABLES
DXF 참조서 > OBJECTS 섹션 >
VBA_PROJECT

다음 그룹 코드는 VBA_PROJECT 객체에 사용됩니다. 이 테이블에서 사용된 축약어 및 형식에 대한 정보는 본 참조서의 형식화 규칙를 참고하십시오.

VBA_PROJECT 그룹 코드
그룹 코드 | 설명
0 | 객체 이름(VBA_PROJECT)
5 | 핸들
102 | 불변의 리액터 그룹의 시작, 항상 “{ACAD_REACTORS”
330 | 소유자 사전에 대한 소프트 포인터 ID/핸들
102 | 불변의 리액터 그룹의 시작, 항상 “}”
330 | 소유자 객체에 대한 소프트 소유자 ID/핸들
100 | 하위 클래스 표식기(AcDbVbaProject)
90 | (다음에 오는 그룹 코드 310 레코드에 포함된) 이진 묶음 데이터의 바이트 수
310 | DXF: 이진 객체 데이터(VBA 프로젝트 데이터를 포함한 여러 개의 항목)


WIPEOUTVARIABLES

VBA_PROJECT
OBJECTS 섹션
XRECORD
DXF 참조서 > OBJECTS 섹션 >
WIPEOUTVARIABLES

다음 그룹 코드는 WIPEOUTVARIABLES 객체에 사용됩니다. 여기에 설명되어 있는 그룹 코드 이외의 내용은 객체의 일반 그룹 코드를 참고하십시오. 이 테이블에서 사용된 축약어 및 형식에 대한 정보는 본 참조서의 형식화 규칙를 참고하십시오.

WIPEOUTVARIABLES 그룹 코드
그룹 코드 | 설명
0 | 객체 이름(WIPEOUTVARIABLES)
5 | 핸들
102 | 불변의 리액터 그룹의 시작, 항상 “{ACAD_REACTORS”
330 | 소유자 사전에 대한 소프트 포인터 ID/핸들. WIPEOUTVARIABLES 객체의 경우 이것은 항상 명명된 객체 사전의 ACAD_IMAGE_VARS 항목입니다.
102 | 불변의 리액터 그룹의 시작, 항상 “}”
100 | 하위 클래스 표식기(AcDbRasterVariables)
90 | 클래스 버전 0
70 | 이미지 프레임 표시 플래그: 0 = 프레임 없음; 1 = 프레임 표시


XRECORD

WIPEOUTVARIABLES
OBJECTS 섹션
THUMBNAILIMAGE 섹션
DXF 참조서 > OBJECTS 섹션 >
XRECORD

다음 그룹 코드는 모든 xrecord 객체에 공통으로 사용됩니다. 여기에 설명되어 있는 그룹 코드 이외의 내용은 객체의 일반 그룹 코드를 참고하십시오. 이 테이블에서 사용된 축약어 및 형식에 대한 정보는 본 참조서의 형식화 규칙를 참고하십시오.

Xrecord 그룹 코드
그룹 코드 | 설명
100 | 하위 클래스 표식기(AcDbXrecord)
280 | 중복 레코드 복제 플래그(중복 항목 결합 방법을 결정함): 0 = 적용할 수 없음 1 = 기존 유지 2 = 복제 사용 3 = <외부 참조>$0$<이름> 4 = $0$<이름> 5 =언맹글 이름
1~369(5와 105는 제외) | 이 값들은 응용프로그램에서 어떤 방식으로도 사용될 수 있습니다.

Xrecord 객체는 임의의 데이터를 저장하고 관리하는 데 사용됩니다. 이들은 “일반 객체” 그룹이 있는 DXF 그룹 코드(확장 데이터가 아닌 그룹 코드)로 구성되며 지원 범위는 1부터 369까지입니다. 이 객체는 개념적으로 xdata와 유사하지만 크기나 순서의 제한이 없습니다.

Xrecord 객체는 릴리즈 R13c0부터 R13c3까지를 위반하지 않는 방식으로 동작하도록 설계되었습니다. 그러나 R13c4 이전 버전의 AutoCAD®로 읽어들이면 xrecord 객체는 사라집니다.


THUMBNAILIMAGE 섹션

XRECORD
THUMBNAILIMAGE 섹션 그룹 코드
DXF 참조서 >
THUMBNAILIMAGE 섹션

이 장은 DXF™ 파일의 THUMBNAILIMAGE 섹션에 있는 그룹 코드를 제공합니다. 이 섹션은 미리보기 이미지가 DXF 파일과 함께 저장된 경우에만 존재합니다.

이 단원의 항목

  • THUMBNAILIMAGE 섹션 그룹 코드


THUMBNAILIMAGE 섹션 그룹 코드

THUMBNAILIMAGE 섹션
THUMBNAILIMAGE 섹션
도면 교환 파일 형식
DXF 참조서 > THUMBNAILIMAGE 섹션 >
THUMBNAILIMAGE 섹션 그룹 코드

다음 그룹 코드는 THUMBNAILIMAGE 섹션에 있습니다. 이 테이블에서 사용된 축약어 및 형식에 대한 정보는 본 참조서의 형식화 규칙를 참고하십시오.

THUMBNAILIMAGE 그룹 코드
그룹 코드 | 설명
90 | 이미지(및 후속 이진 청크 레코드)의 바이트 수
310 | 미리보기 이미지 데이터(여러 줄: 행당 최대 256자)


도면 교환 파일 형식

THUMBNAILIMAGE 섹션 그룹 코드
ASCII DXF 파일
DXF 참조서 >
도면 교환 파일 형식

이 부록에서는 AutoCAD®가 다른 응용프로그램과 도면 데이터를 교환하는 데 사용하는 다양한 파일 형식을 설명합니다. 제공되는 형식은 도면 교환 파일(DXF™), 이진 DXF, 슬라이드(SLD) 및 슬라이드 라이브러리(SLB) 파일 형식입니다.

DXF 파일은 ASCII 또는 이진 형식일 수 있습니다. ASCII DXF 파일이 이진 형식보다 더 일반적이기 때문에 DXF 파일이라는 용어는 ASCII DXF 파일을 나타내는 데 사용되고 이진 형식에 대해서는 이진 DXF 파일이라는 용어가 사용됩니다.

이 단원의 항목

  • ASCII DXF 파일
  • 이진 DXF 파일
  • 슬라이드 파일
  • 슬라이드 라이브러리 파일


ASCII DXF 파일

도면 교환 파일 형식
도면 교환 파일 형식
일반적인 DXF 파일 구조
DXF 참조서 > 도면 교환 파일 형식 >
ASCII DXF 파일

이 섹션에서는 ASCII DXF 파일의 형식을 설명합니다. 이 정보는 자신의 프로그램을 작성하여 DXF 파일을 처리하거나 AutoLISP® 및 ObjectARX® 응용프로그램으로 확보한 도면요소 정보 관련 작업을 수행하는 경우에만 필요한 정보입니다.

이 단원의 항목

  • 일반적인 DXF 파일 구조
  • DXF 파일의 그룹 코드
  • DXF 파일의 헤더 그룹 코드
  • DXF 파일의 클래스 그룹 코드
  • DXF 파일의 기호 테이블 그룹 코드
  • DXF 파일의 블록 그룹 코드
  • DXF 파일의 도면요소 그룹 코드
  • DXF 파일의 객체 그룹 코드
  • DXF 인터페이스 프로그램 쓰기


일반적인 DXF 파일 구조

ASCII DXF 파일
ASCII DXF 파일
DXF 파일의 그룹 코드
DXF 참조서 > 도면 교환 파일 형식 > ASCII DXF 파일 >
일반적인 DXF 파일 구조

본질적으로 DXF 파일은 코드와 연관 값의 쌍으로 구성됩니다. 그룹 코드라고 하는 코드는 뒤에 오는 값의 유형을 나타냅니다. 이들 그룹 코드와 값의 쌍을 사용하여 DXF 파일은 레코드로 구성된 섹션들로 이루어지며 레코드는 다시 그룹 코드와 데이터 항목으로 구성되어 있습니다. 각 그룹 코드와 값은 DXF 파일에서 자신의 행에 위치합니다.

각 섹션은 뒤에 SECTION이라는 문자열이 붙은 그룹 코드 0으로 시작됩니다. 그룹 코드 0 다음에는 그룹 코드 2와 해당 섹션의 이름을 나타내는 문자열(예: HEADER)이 옵니다. 각 섹션은 그룹 코드와 해당 요소를 정의하는 값으로 구성됩니다. 섹션은 뒤에 문자열 ENDSEC이 붙은 0으로 끝납니다.

이 섹션에 제공된 정보를 읽으면서 작은 도면으로부터 DXF를 만들고 인쇄하며 그 파일을 참조하면 편리할 수 있습니다.

DXF 파일의 전체적인 구성은 다음과 같습니다.

  • HEADER 섹션.도면에 대한 일반 정보를 포함합니다. 이 섹션은 AutoCAD 데이터베이스의 버전 번호와 다양한 시스템 변수로 구성됩니다. 각 매개변수는 변수 이름과 연관된 값을 포함하고 있습니다.
  • CLASSES 섹션.데이터베이스의 BLOCKS, ENTITIES 및 OBJECTS 섹션에서 인스턴스가 사용되는 응용프로그램 정의 클래스에 대한 정보를 보유하고 있습니다. 클래스 정의는 클래스 계층에 고정됩니다.
  • TABLES 섹션.다음의 기호 테이블에 대한 정의를 포함합니다.

    APPID(응용프로그램 식별 테이블)

    BLOCK_RECORD(블록 참조 테이블)

    DIMSTYLE(치수 스타일 테이블)

    LAYER(도면층 테이블)

    LTYPE(선종류 테이블)

    STYLE(텍스트 스타일 테이블)

    UCS(사용자 좌표계 테이블)

    (뷰 테이블)

    VPORT(뷰포트 구성 테이블)

  • BLOCKS 섹션.도면의 각 블록 참조를 구성하는 블록 정의 및 도면요소를 포함합니다.
  • ENTITIES 섹션.블록 참조(삽입 도면요소)와 함께 도면의 그래픽 객체(도면요소)를 포함합니다.
  • OBJECTS 섹션.도면의 비그래픽 객체를 포함합니다. 도면요소 또는 기호 테이블 레코드 또는 기호 테이블이 아닌 객체는 모두 이 섹션에 저장됩니다. OBJECTS 섹션에 표시되는 항목의 예로는 다중선 스타일 및 그룹이 포함된 사전을 들 수 있습니다.
  • THUMBNAILIMAGE 섹션.도면의 미리보기 이미지 데이터를 포함합니다. 이 섹션은 선택 사항입니다.

SAVE 또는 SAVEAS 명령의 객체 선택 옵션을 사용하면 결과로 생성된 DXF 파일의 ENTITIES 섹션에는 선택한 도면요소만 포함됩니다.


DXF 파일의 그룹 코드

일반적인 DXF 파일 구조
ASCII DXF 파일
DXF 파일의 ASCII 제어 문자
DXF 참조서 > 도면 교환 파일 형식 > ASCII DXF 파일 >
DXF 파일의 그룹 코드

그룹 코드 및 연관된 값은 객체 또는 도면요소의 특정 모습을 정의합니다. 그룹 코드 다음에 바로 이어지는 행이 연관된 값입니다. 이 값은 문자열이나 정수일 수 있으며 또는 점의 X 좌표와 같이 부동 소수점 값일 수 있습니다. 그룹의 두 번째 행 다음에 이어지는 행이 있다면 이 행은 그룹 정의와 그 그룹에 연관된 데이터에 의해 결정됩니다.

특수한 그룹 코드는 섹션 및 테이블의 시작과 끝 그리고 파일 자체의 끝을 나타내는 표식기 등과 같은 파일 구분자로 사용됩니다.

도면요소, 객체, 클래스, 테이블 및 테이블 항목, 그리고 파일 구분자는 해당 그룹을 설명하는 이름이 뒤에 오는 그룹 코드 0으로 시작됩니다.

DXF 파일의 최대 문자열 길이는 256자입니다. AutoCAD 도면에 이 수를 초과하는 문자열이 포함되면 SAVE, SAVEAS 및 WBLOCK 작업 중에 해당 문자열의 일부가 잘리게 됩니다. DXF 파일에 이 수를 초과하는 문자열이 포함된 경우에는 OPEN과 INSERT 실행이 실패합니다.

이 단원의 항목

  • DXF 파일의 ASCII 제어 문자


DXF 파일의 ASCII 제어 문자

DXF 파일의 그룹 코드
DXF 파일의 그룹 코드
DXF 파일의 헤더 그룹 코드
DXF 참조서 > 도면 교환 파일 형식 > ASCII DXF 파일 > DXF 파일의 그룹 코드 >
DXF 파일의 ASCII 제어 문자

SAVEAS는 문자열의 ASCII 제어 문자를 해당 글자 앞에 탈자 기호(^)를 붙여 문자를 확장하는 방식으로 처리합니다. 예를 들어, ASCII Control-G(BEL, 십진 코드 7)는 ^G로 쓰여집니다. 문자 자체에 탈자 기호(^)가 포함된 경우에는 탈자 기호, 빈 칸(^)의 형태로 확장됩니다. OPEN과 INSERT가 보완적인 변환을 수행합니다.


DXF 파일의 헤더 그룹 코드

DXF 파일의 ASCII 제어 문자
ASCII DXF 파일
DXF 파일의 클래스 그룹 코드
DXF 참조서 > 도면 교환 파일 형식 > ASCII DXF 파일 >
DXF 파일의 헤더 그룹 코드

응용프로그램은AutoLISP의 getvar 함수를 사용하여 이 변수들의 값을 가져올 수 있습니다.

다음은 DXF™ 파일에 있는 HEADER 섹션의 예제입니다.

0 SECTION 2 HEADER | HEADER 섹션의 시작
9 $<변수> <그룹 코드> <값> | 각 헤더 변수에 대해 반복
0 ENDSEC | HEADER 섹션의 끝


DXF 파일의 클래스 그룹 코드

DXF 파일의 헤더 그룹 코드
ASCII DXF 파일
DXF 파일의 기호 테이블 그룹 코드
DXF 참조서 > 도면 교환 파일 형식 > ASCII DXF 파일 >
DXF 파일의 클래스 그룹 코드

다음은 DXF 파일에 있는 CLASSES 섹션의 예제입니다.

0 SECTION 2 CLASSES | CLASSES 섹션의 시작
0 CLASS 1 <클래스 dxf 레코드> 2 <클래스 이름> 3 <응용프로그램 이름> 90 <플래그> 280 <플래그> 281 <플래그> | 각 항목에 대해 반복
0 ENDSEC | CLASSES 섹션의 끝


DXF 파일의 기호 테이블 그룹 코드

DXF 파일의 클래스 그룹 코드
ASCII DXF 파일
기호 테이블 예제
DXF 참조서 > 도면 교환 파일 형식 > ASCII DXF 파일 >
DXF 파일의 기호 테이블 그룹 코드

다음은 DXF 파일에 있는 TABLES 섹션의 예제입니다.

0 SECTION 2 TABLES | TABLES 섹션의 시작
0 TABLE 2 <테이블 유형> 5 <핸들> 100 AcDbSymbolTable 70 <최대값 항목> | 일반 테이블 그룹 코드: 각 항목에 대해 반복
0 <테이블 유형> 5 <핸들> 100 AcDbSymbolTableRecord . . <데이터> . | 테이블 항목 데이터: 각 테이블 레코드에 대해 반복
0 ENDTAB | 테이블의 끝
0 ENDSEC | TABLES 섹션의 끝

이 단원의 항목

  • 기호 테이블 예제


기호 테이블 예제

DXF 파일의 기호 테이블 그룹 코드
DXF 파일의 기호 테이블 그룹 코드
DXF 파일의 블록 그룹 코드
DXF 참조서 > 도면 교환 파일 형식 > ASCII DXF 파일 > DXF 파일의 기호 테이블 그룹 코드 >
기호 테이블 예제

이 DXF 시퀀스는 세 개의 완전한 객체, 즉 기호 테이블 자체와 두 개의 항목을 나타냅니다.

0 |
TABLE | 기호 테이블 항목을 나타냅니다.
2 |
STYLE | 텍스트 스타일 기호 테이블 항목. 코드 0의 유형 정의 규칙에 대한 예외
5 |
1C | STYLE 테이블 핸들: 도면요소 및 기타 객체의 경우와 동일
70 |
3 | 다음에 오는 STYLE 테이블 레코드의 최대 수(이전 릴리즈 13의 필드)
1001 |
APP_X | APP_X는 기호 테이블에 확장 데이터를 넣습니다.
1040 |
42.0 | 단일 부동 소수점 수
0 |
STYLE | STYLE 기호 테이블에서 첫 번째 요소의 시작
5 |
3A | 첫 번째 항목의 핸들(DIMSTYLE 항목은 여기서 105를 가짐)
2 |
ENTRY_1 | 첫 번째 항목의 문자 이름
70 |
64 | 표준 플래그 값
40 |
.4 | 문자 높이
41 |
1.0 | 폭 축척 비율
50 |
0.0 | 기울기 각도
71 |
0 | 문자 생성 플래그
42 |
0.4 | 마지막으로 사용된 높이
3 |
BUFONTS.TXT | 1차 글꼴 파일 이름
0 |
STYLE | 두 번째 항목이 시작됩니다. 첫 번째 항목에는 확장 데이터 또는 영구 리액터가 없음
5 |
C2 | 두 번째 항목 핸들
2 |
ENTRY_2 | 두 번째 항목의 문자 이름
... |
... | 그룹 코드 3을 만드는 기타 필드
3 |
BUFONTS.TXT | 1차 글꼴 파일 이름 및 마지막 객체 유형—특정 그룹
102 |
{ACAD_REACTORS | 이 항목에 두 개의 영구 리액터가 있습니다.
330 |
3C2 | 첫 번째 리액터 객체에 대한 소프트 ID
330 |
41B | 첫 번째 리액터 객체에 대한 소프트 ID
102 |
} | 리액터 세트의 끝을 나타냅니다.
1001 |
APP_1 | 이 항목에 부착된 확장 데이터
1070 |
45 |
1001 |
APP_2 |
1004 |
18A5B3EF2C199A |
0 |
UCS | UCS 테이블의 시작(및 이전 레코드와 테이블의 끝)


DXF 파일의 블록 그룹 코드

기호 테이블 예제
ASCII DXF 파일
DXF 파일의 도면요소 그룹 코드
DXF 참조서 > 도면 교환 파일 형식 > ASCII DXF 파일 >
DXF 파일의 블록 그룹 코드

다음은 DXF 파일에 있는 BLOCKS 섹션의 예제입니다.

0 SECTION 2 BLOCKS | BLOCKS 섹션의 시작
0 BLOCK 5 <핸들> 100 AcDbEntity 8 <도면층> 100 AcDbBlockBegin 2 <블록 이름> 70 <플래그> 10 <X 값> 20 <Y 값> 30 <Z 값> 3 <블록 이름> 1 <외부 참조 경로> | 각 블록 항목의 시작(블록 도면요소 정의)
0 <도면요소 유형> . . <데이터> . | 블록 내의 각 도면요소 정의에 대해 하나의 항목
0 ENDBLK 5 <핸들> 100 AcDbBlockEnd | 각 블록 항목의 끝(endblk 도면요소 정의)
0 ENDSEC | BLOCKS 섹션의 끝


DXF 파일의 도면요소 그룹 코드

DXF 파일의 블록 그룹 코드
ASCII DXF 파일
DXF 파일의 객체 그룹 코드
DXF 참조서 > 도면 교환 파일 형식 > ASCII DXF 파일 >
DXF 파일의 도면요소 그룹 코드

다음은 DXF 파일에 있는 ENTITIES 섹션의 예제입니다.

0 SECTION 2 ENTITIES | ENTITIES 섹션의 시작
0 <도면요소 유형> 5 <핸들> 330 <소유자에 대한 포인터> 100 AcDbEntity 8 <도면층> 100 AcDb<클래스 이름> . . <데이터> . | 각 도면요소 정의에 대한 하나의 항목
0 ENDSEC | ENTITIES 섹션의 끝


DXF 파일의 객체 그룹 코드

DXF 파일의 도면요소 그룹 코드
ASCII DXF 파일
DXF 인터페이스 프로그램 쓰기
DXF 참조서 > 도면 교환 파일 형식 > ASCII DXF 파일 >
DXF 파일의 객체 그룹 코드

다음은 DXF 파일에 있는 OBJECTS 섹션의 예제입니다.

0 SECTION 2 OBJECTS | OBJECTS 섹션의 시작
0 DICTIONARY 5 <핸들> 100 AcDbDictionary | 명명된 객체 사전의 시작(루트 사전 객체)
3 <사전 이름> 350 <하위 핸들> | 각 항목에 대해 반복
0 <객체 유형> . . <데이터> . | 객체 데이터 그룹
0 ENDSEC | OBJECTS 섹션의 끝


DXF 인터페이스 프로그램 쓰기

DXF 파일의 객체 그룹 코드
ASCII DXF 파일
DXF 파일 읽기
DXF 참조서 > 도면 교환 파일 형식 > ASCII DXF 파일 >
DXF 인터페이스 프로그램 쓰기

DXF 파일로 AutoCAD와 통신하는 프로그램을 작성하는 것은 생각만큼 어렵지 않습니다. DXF 형식을 사용하면 필요한 정보를 읽으면서 불필요한 정보를 쉽게 확인하여 넘어갈 수 있습니다.

이 단원의 항목

  • DXF 파일 읽기
  • DXF 파일 쓰기


DXF 파일 읽기

DXF 인터페이스 프로그램 쓰기
DXF 인터페이스 프로그램 쓰기
DXF 파일 쓰기
DXF 참조서 > 도면 교환 파일 형식 > ASCII DXF 파일 > DXF 인터페이스 프로그램 쓰기 >
DXF 파일 읽기

다음은 DXF 파일을 읽고 해당 섹션의 주어진 객체에서 특정 코드 및 값을 추출하는 간단한 Visual Basic 6 프로그램의 예제입니다.

' ReadDXF extracts specified code/value pairs from a DXF file.
' This function requires four string parameters, a valid DXF
' file name, a DXF section name, the name of an object in that
' section, and a comma delimited list of codes.
'
Function ReadDXF( _
        ByVal dxfFile As String, ByVal strSection As String, _
        ByVal strObject As String, ByVal strCodeList As String)
    Dim tmpCode, lastObj As String
    Open dxfFile For Input As #1
    ' Get the first code/value pair
    codes = ReadCodes
    ' Loop through the whole file until the "EOF" line
    While codes(1) <> "EOF"
        ' If the group code is '0' and the value is 'SECTION' ..
        If codes(0) = "0" And codes(1) = "SECTION" Then
            ' This must be a new section, so get the next
            ' code/value pair.
            codes = ReadCodes
            ' If this section is the right one ..
            If codes(1) = strSection Then
                ' Get the next code/value pair and ..
                codes = ReadCodes
                ' Loop through this section until the 'ENDSEC'
                While codes(1) <> "ENDSEC"
                    ' While in a section, all '0' codes indicate
                    ' an object. If you find a '0' store the
                    ' object name for future use.
                    If codes(0) = "0" Then lastObj = codes(1)
                    ' If this object is one you're interested in
                    If lastObj = strObject Then
                        ' Surround the code with commas
                        tmpCode = "," & codes(0) & ","
                        ' If this code is in the list of codes ..
                        If InStr(strCodeList, tmpCode) Then
                            ' Append the return value.
                            ReadDXF = ReadDXF & _
                                codes(0) & "=" & codes(1) & vbCrLf
                        End If
                    End If
                    ' Read another code/value pair
                    codes = ReadCodes
                Wend
            End If
        Else
            codes = ReadCodes
        End If
    Wend
    Close #1
End Function
' ReadCodes reads two lines from an open file and returns a two item
' array, a group code and its value. As long as a DXF file is read
' two lines at a time, all should be fine. However, to make your
' code more reliable, you should add some additional error and
' other checking.
'
Function ReadCodes() As Variant
    Dim codeStr, valStr As String
    Line Input #1, codeStr
    Line Input #1, valStr
    ' Trim the leading and trailing space from the code
    ReadCodes = Array(Trim(codeStr), valStr)
End Function


DXF 파일 쓰기

DXF 파일 읽기
DXF 인터페이스 프로그램 쓰기
이진 DXF 파일
DXF 참조서 > 도면 교환 파일 형식 > ASCII DXF 파일 > DXF 인터페이스 프로그램 쓰기 >
DXF 파일 쓰기

DXF 파일 생성 프로그램의 작성은 AutoCAD가 파일을 수용할 수 있도록 도면 내에 일관성을 유지해야 하기 때문에 DXF 파일 읽기 프로그램을 작성하는 것보다 어려울 수 있습니다. AutoCAD는 DXF 파일의 많은 항목을 생략하면서도 사용 가능한 도면을 확보할 수 있게 해줍니다.

  • 헤더 변수를 설정하지 않는 경우 전체 HEADER 섹션을 생략할 수 있습니다.
  • 항목을 만들 필요가 없는 경우 TABLES 섹션 내의 해당 테이블을 생략할 수 있으며 TABLES 섹션에 필요한 항목이 없으면 전체 TABLES 섹션을 삭제할 수 있습니다.
  • LTYPE 테이블에 선종류를 정의하는 경우 이 테이블은 LAYER 테이블 앞에 표시되어야 합니다.
  • 도면에서 블록 정의를 사용하지 않는 경우 BLOCKS 섹션을 생략할 수 있습니다.
  • 존재하는 경우 BLOCKS 섹션은 ENTITIES 섹션 앞에 표시되어야 합니다.
  • LAYER 테이블에 도면층 이름을 정의하지 않았더라도 ENTITIES 섹션 내에서 도면층 이름을 참조할 수 있습니다. 이러한 도면층은 색상 7과 CONTINUOUS 선종류를 사용하여 자동으로 작성됩니다.
  • EOF 항목은 파일 끝에 있어야 합니다.

다음 Visual Basic 6 서브 루틴은 다각형을 표현하는 DXF 파일을 구성합니다.

' WriteDXFPolygon creates a minimal DXF file that only contains
' the ENTITIES section. This subroutine requires five parameters,
' the DXF file name, the number of sides for the polygon, the X
' and Y coordinates for the bottom end of the right-most side
' (it starts in a vertical direction), and the length for each
' side. Note that because this only requests 2D points, it does
' not include the Z coordinates (codes 30 and 31). The lines are
' placed on the layer "Polygon."
'
Sub WriteDXFPolygon( _
        dxfFile As String, iSides As Integer, _
        dblX As Double, dblY As Double, dblLen As Double)
    Dim i As Integer
    Dim dblA1, dblA, dblPI, dblNX, dblNY As Double
    Open dxfFile For Output As #1
    Print #1, 0
    Print #1, "SECTION"
    Print #1, 2
    Print #1, "ENTITIES"
    dblPI = Atn(1) * 4
    dblA1 = (2 * dblPI) / iSides
    dblA = dblPI / 2
    For i = 1 To iSides
        Print #1, 0
        Print #1, "LINE"
        Print #1, 8
        Print #1, "Polygon"
        Print #1, 10
        Print #1, 0
        Print #1, 20
        Print #1, 0
        dblNX = dblLen * Cos(dblA) + dblX
        dblNY = dblLen * Sin(dblA) + dblY
        Print #1, 11
        Print #1, 0
        Print #1, 21
        Print #1, 0
        dblX = dblNX
        dblY = dblNY
        dblA = dblA + dblA1
    Next I
    Print #1, 0
    Print #1, "ENDSEC"
    Print #1, 0
    Print #1, "EOF"
    Close #1
End Sub

데이터가 있어야 할 행에 올바르게 형식이 지정된 항목이 표시되기만 하면 DXFIN은 이 항목을 수용합니다. (물론 빈 칸이 해당 문자열의 일부가 아닌 경우에는 문자열 앞에 빈 칸이 있어서는 안 됩니다.) 이 BASIC 프로그램은 다양한 입력 형식을 사용하며 AutoCAD가 생성하는 것과 완전히 동일한 파일을 생성하지는 않습니다.

DXFIN을 사용하여 로드할 때 오류가 발생한 경우, AutoCAD는 오류를 감지하기 전 DXF 파일에서 최종 처리된 행 및 오류 특성을 나타내는 메시지와 함께 해당 오류를 보고합니다. 특히 필수 그룹을 생략한 오류 등에서와 같이 이 행이 오류가 발생한 행은 아닐 수 있습니다.


이진 DXF 파일

DXF 파일 쓰기
도면 교환 파일 형식
슬라이드 파일
DXF 참조서 > 도면 교환 파일 형식 >
이진 DXF 파일

ASCII DXF 파일 형식은 AutoCAD 도면을 ASCII 텍스트 형태로 표현한 것으로 다른 프로그램에 의해 쉽게 처리됩니다. 또한, AutoCAD는 완전한 DXF 파일의 이진 형태를 생성하거나 읽을 수 있으며 다른 이진 파일 형식으로 된 제한적 입력도 수용합니다.

SAVE와 SAVEAS 명령은 이진 DXF 파일을 쓰는 이진 옵션을 제공합니다. 이러한 파일은 ASCII DXF 파일에서 제공되는 모든 정보를 포함하고 있지만 파일 공간을 약 25 퍼센트 덜 차지하는 보다 압축된 형태로 포함하고 있습니다. AutoCAD는 이러한 파일을 보다 빠르게(일반적으로 5배 더 빠름) 읽고 쓸수 있습니다. 크기와 부동 소수점 정확도 사이의 균형을 수반하는 ASCII DXF 파일과 달리 이진 DXF 파일은 도면 데이터베이스에서의 정확도를 유지합니다. (AutoCAD 릴리즈 10은 이러한 형태의 DXF 파일을 지원하는 첫 번째 버전입니다. 이전의 버전에서는 이러한 파일을 읽을 수 없습니다.)

이진 DXF 파일은 다음과 같이 구성된 22바이트의 시작/끝 표식 문자로 시작합니다.

AutoCAD Binary DXF<CR><LF><SUB><NULL>

시작/끝 표식 문자 다음에는 ASCII DXF 파일에서와 같지만 이진 형태로 표현된 쌍(그룹, 값)이 옵니다. 그룹 코드는 2바이트의 이진 값(AutoCAD Release 14 이전 DXF 파일의 경우 1바이트)이며, 뒤에 오는 값은 다음 중 하나입니다.

  • 가장 덜 중요한 바이트가 첫 번째에 오고 가장 중요한 바이트가 마지막에 오는 2바이트 정수
  • 가장 덜 중요한 바이트가 첫 번째에 오고 가장 중요한 바이트가 마지막에 오도록 저장되는 8바이트의 IEEE 배정밀도 부동 소수점 수
  • 0(NULL) 바이트로 종료되는 ASCII 문자열

그룹 뒤에 오는 데이터 유형은 ASCII DXF 파일의 디코딩에 사용되는 것과 같은 규칙으로 그룹 코드로부터 결정됩니다. 각도를 도 표현으로, 날짜를 부분 율리우스력 날짜 표현으로 변환하는 것은 ASCII DXF 파일과 이진 파일 모두에 대해 수행됩니다. 주석 그룹 999는 이진 DXF 파일에서는 사용되지 않습니다.

확장 데이터의 그룹 코드는 값 256을 가진 단일 바이트, 실제 그룹 코드가 포함된 2바이트의 정수 값, 실제 값의 순서로 이루어진 이진 DXF로 표시됩니다.

확장 데이터의 긴(long) 값(그룹 코드 1071)은 4바이트 데이터로 구성됩니다. 확장 데이터의 이진 묶음(그룹 코드 1004)은 단일 바이트의 부호 없는 정수 길이, 지정한 바이트 수의 묶음 데이터 순서로 표시됩니다. 예를 들어, 확장 데이터의 긴(long) 그룹을 전송하려면 각각 1, 2, 4바이트를 차지하는 다음과 같은 값이 표시됩니다.

255 Escape 그룹 코드
1071 트루 그룹 코드
999999 1071 그룹 코드 값

SAVEAS는 ASCII DXF 파일에서와 같은 파일 유형 (.dxf)로 이진 DXF 파일을 씁니다. OPEN과 INSERT 명령은 표식 문자열로 이진 파일을 자동으로 인식합니다. 이진 파일을 식별하지 않아도 됩니다.

이진 DXF 파일에서 OPEN 및 INSERT 명령으로 오류가 발생하면 AutoCAD는 오류가 감지된 파일의 해당 바이트 주소를 보고합니다.


슬라이드 파일

이진 DXF 파일
도면 교환 파일 형식
이전 슬라이드 헤더
DXF 참조서 > 도면 교환 파일 형식 >
슬라이드 파일
주이 정보는 숙련된 프로그래머를 위한 것이며 예고 없이 변경될 수 있습니다.

AutoCAD 슬라이드 파일은 MSLIDE 명령에 의해 작성되고 VSLIDE 명령에 의해 읽혀지는 화면 이미지입니다. 이 섹션에서는 프로그램에 슬라이드에 대한 지원을 통합하고자 하는 개발자를 위해 슬라이드 파일의 형식을 설명합니다.

슬라이드 파일은 헤더 부분(31바이트)과 가변 길이를 갖는 하나 이상의 레코드로 구성됩니다. 슬라이드 파일에 씌어지는 모든 좌표 및 크기는 슬라이드가 작성된 화면 표시 장치의 도면 영역을 반영하며 점 (0,0)의 위치는 도면 영역의 왼쪽 구석에 지정됩니다. AutoCAD 릴리즈 9 이상의 경우 슬라이드 파일 헤더는 다음과 같은 필드로 구성됩니다.

슬라이드 파일 헤더
필드 | 바이트 | 설명
ID 문자열 | 17 | “AutoCAD 슬라이드” CR LF ^Z NUL
유형 표시기 | 1 | 현재 56으로 설정됨(십진).
단계 표시기 | 1 | 현재 2로 설정됨.
높은 X 도트 | 2 | 그래픽 영역의 폭: 1, 픽셀 단위
높은 Y 도트 | 2 | 그래픽 영역의 높이: 1, 픽셀 단위
가로 세로 비율 | 4 | 10,000,000으로 축척된 도면 영역 가로 세로 비율(인치 단위의 가로 크기/세로 크기). 이 값은 항상 가장 덜 중요한 바이트가 먼저 씌어집니다.
하드웨어 채우기 | 2 | 0 또는 2(값은 중요하지 않음)
테스트 숫자 | 2 | 슬라이드의 모든 2바이트 값이 상위 바이트가 먼저 쓰여졌는지(Intel 8086 제품군 CPU), 하위 바이트가 먼저 쓰여졌는지(Motorola 68000 제품군 CPU) 여부를 판별하는 데 사용되는 수(1234 16진수)

데이터 레코드는 헤더 다음에 옵니다. 각 데이터 레코드는 상위 바이트가 레코드 유형을 나타내는 2바이트 필드로 시작됩니다. 레코드의 나머지는 다음 테이블에 설명된 1바이트 또는 2바이트 필드로 구성됩니다. 2바이트 필드에 상위 바이트가 먼저 씌어지는지 하위 바이트가 먼저 씌어지는지 여부를 판별하려면 이전 테이블에 설명된 헤더의 테스트 숫자 필드를 확인하십시오.

슬라이드 파일 데이터 레코드
레코드 유형 (16진수) | 바이트 | 의미 | 설명
00-7F | 8 | 벡터 | 일반 벡터의 시작-X 좌표. 시작-Y, 끝-X, 끝-Y의 순서로 2바이트 값이 뒤에 옵니다. 시작 좌표 점이 마지막 점으로 저장됩니다
80-FA | — | 정의되지 않음 | 나중에 사용할 수 있도록 예약됨.
FB | 5 | 간격띄우기 벡터 | 하위 바이트와 다음의 3바이트는 저장된 마지막 점으로부터 간격띄우기(-128부터 +127까지)의 항으로 벡터의 끝점(시작-X, 시작-Y, 끝‑X, 끝-Y)을 지정합니다. 조정된 시작 좌표 점이 이후의 벡터들이 사용할 마지막 점으로 저장됩니다.
FC | 2 | 파일의 끝 | 하위 바이트가 00입니다.
FD | 6 | 솔리드 채우기 | 하위 바이트가 항상 0입니다. 다음의 두 개의 2바이트 값은 솔리드 채우기될 다각형에서 한 정점의 X 및 Y 좌표를 지정합니다. 10 중 3의 비율로 그러한 레코드는 일련의 시퀀스로 발생합니다. 음의 Y 좌표를 가진 솔리드 채우기 레코드는 그러한 플러드 시퀀스의 시작 또는 끝을 나타냅니다. 시작 레코드에서 X 좌표는 뒤에 오는 정점 레코드의 수를 나타냅니다.
FE | 3 | 공통 선의 벡터 | 마지막 점에서 시작하는 벡터입니다. 하위 바이트와 다음의 바이트는 저장된 마지막 점으로부터 간격띄우기(-128부터 +127까지)의 항으로 끝-X와 끝-Y를 지정합니다. 조정된 끝 좌표 점이 이후의 벡터들이 사용할 마지막 점으로 저장됩니다.
FF | 2 | 새로운 색상 | 이후의 벡터들은 하위 바이트에 의해 지시된 색상 번호를 사용하여 그려집니다.

솔리드에 벡터가 조금이라도 포함되어 있으면 새로운 색상 레코드가 첫 번째 데이터 레코드가 됩니다. 슬라이드 내 벡터들의 순서와 벡터들의 끝점 순서는 변할 수도 있습니다.

예를 들어, 다음은 IBM 확장 그래픽 어댑터가 장착된 IBM PC/AT에서 작성된 간단한 슬라이드 파일의 주석 달린 16진 덤프입니다. 이 슬라이드는 도면 영역의 왼쪽 아래 구석에서 오른쪽 위 구석까지 흰색 대각선, 왼쪽 아래 구석 근처의 초록색 수직선, 왼쪽 아래 구석의 작은 빨간색 직사각형으로 구성됩니다.

41 75 74 6F 43 41 ID 문자열(“AutoCAD 슬라이드” CR LF ^Z NUL)
44 20 53 6C 69 64
65 0D 0A 1A 00
56 유형 표시기(56)
02 단계 표시기(2)
3C 02 높은 X 도트(572)
24 01 높은 Y 도트(292)
0B 80 DF 00 가로 세로 비율(14,647,307 / 10,000,000 = 1.46)
02 00 하드웨어 채우기(2)
34 12 테스트 숫자(1234 16진수)
07 FF 새로운 색상(7 = 흰색)
3C 02 24 01 00 00 00 00 572,292에서 0,0까지의 벡터. 572,292는 “마지막”점이 됩니다.
3 FF 새로운 색상(3 = 초록색)
0F 00 32 00 0F 00 13 00 15,50에서 15,19까지의 벡터. \x1115,50이
“마지막” 점
01 FF 새로운 색상(1 = 빨간색)
12 FB E7 12 CE 15+18,50-25 (33,25)에서 15+18,
50-50 (33,0). 33,25는 “마지막” 점이 됩니다.
DF FE 00 33,25에서 33-33,25+0
(0,25). 0,25는 “마지막” 점이 됩니다.
00 FE E7 (0,25)에서 0+0,25-25
(0,0). 0,0은 “마지막” 점이 됩니다.
21 FE 00 (0,0)에서 0+33,0+0
(33,0).33,0은 “마지막” 점이 됩니다.
00 FC 파일의 끝

이 단원의 항목

  • 이전 슬라이드 헤더


이전 슬라이드 헤더

슬라이드 파일
슬라이드 파일
슬라이드 라이브러리 파일
DXF 참조서 > 도면 교환 파일 형식 > 슬라이드 파일 >
이전 슬라이드 헤더

앞 섹션에서 설명한 슬라이드 형식은 AutoCAD 릴리즈 9 이상에서 생성되며 AutoCAD 9 릴리즈 이상을 실행하는 모든 컴퓨터들 사이에 이전이 가능합니다. 이전 AutoCAD(AutoShade® 1.0 및 AutoSketch® 1.02도 마찬가지로) 버전은 다음 테이블에서처럼 헤더가 조금 다른 슬라이드를 생성합니다.

이전 슬라이드 파일 헤더
필드 | 바이트 | 설명
ID 문자열 | 17 | “AutoCAD 슬라이드” CR LF ^Z NUL
유형 표시기 | 1 | 56 (10진)
단계 표시기 | 1 | 1 (이전의 형식)
높은 X 도트 | 2 | 도면 영역의 폭: 1, 픽셀 단위
높은 Y 도트 | 2 | 도면 영역의 높이: 1, 픽셀 단위
가로 세로 비율 | 8 | 부동 소수점 수로 씌어진 도면 영역 가로 세로 비율(인치 단위의 가로 크기/세로 크기)
하드웨어 채우기 | 2 | 0 또는 2(값은 중요하지 않음)
채우기 바이트 | 1 | 사용되지 않음

이전 형식의 헤더에는 테스트 숫자 필드가 없습니다. 부동 소수점 가로 세로 비율 값과 모든 2바이트 정수는 해당 파일을 작성하는 데 사용된 CPU의 고유 형식으로 씌어집니다(8086 제품군 CPU의 경우, IEEE 배정밀도이며 하위 바이트가 먼저 옴). 이전 형식의 슬라이드 파일은 기계 유형들 사이에 이전이 불가능하지만 해당 슬라이드가 작성된 CPU와 동일한 유형의 CPU에서 실행되는 모든 버전의 AutoCAD에서 읽을 수 있습니다.


슬라이드 라이브러리 파일

이전 슬라이드 헤더
도면 교환 파일 형식
DXF 고급 정보
DXF 참조서 > 도면 교환 파일 형식 >
슬라이드 라이브러리 파일

이 섹션에서는 프로그램에 슬라이드 라이브러리에 대한 지원을 적용하려는 개발자를 위해 AutoCAD 슬라이드 라이브러리(릴리즈 9 이상)의 형식을 설명합니다.

슬라이드 라이브러리의 일반 형식은 다음과 같습니다.

"AutoCAD 슬라이드 라이브러리 1.0" CR LF ^Z NUL NUL NUL NUL 헤더(32바이트)
하나 이상의 슬라이드 디렉토리 항목(각 36바이트)
하나 이상의 슬라이드(가변 길이)

슬라이드 디렉토리 항목은 다음과 같은 형식을 갖습니다.

슬라이드 이름(NUL 종료)(32바이트)
라이브러리 파일 내의 슬라이드 주소(4바이트)

슬라이드 주소는 항상 하위 바이트가 먼저 쓰여집니다. 디렉토리가 가리키는 각 슬라이드는 앞 섹션에 설명된 것과 같은 완전한 슬라이드 파일입니다. 슬라이드 디렉토리의 끝은 null 슬라이드 이름(첫 번째 바이트가 NUL임)을 가진 항목으로 나타내어 집니다. 슬라이드 라이브러리에는 이전 형식의 슬라이드와 새로운 형식의 슬라이드가 섞여 있을 수 있습니다.


DXF 고급 정보

슬라이드 라이브러리 파일
데이터베이스 객체
DXF 참조서 >
DXF 고급 정보

이 부록에서는 DXF™ 그룹 코드와 관련된 고급 개념을 논의합니다.

이 단원의 항목

  • 데이터베이스 객체
  • 객체간 영구 참조 핸들
  • 하위 클래스 표식기
  • 확장 사전 및 영구 리액터
  • 확장 데이터
  • 객체 좌표계(OCS)
  • 임의의 축 알고리즘


데이터베이스 객체

DXF 고급 정보
DXF 고급 정보
객체간 영구 참조 핸들
DXF 참조서 > DXF 고급 정보 >
데이터베이스 객체

AutoCAD® 도면은 주로 데이터베이스 객체에 대한 구조화된 컨테이너로 구성됩니다. 데이터베이스 객체 각각은 다음과 같은 기능을 갖습니다.

  • 도면/DXF 파일마다 값이 고유하고 도면의 존속 기간 동안 변하지 않는 핸들. 이 형식은 AutoCAD 릴리즈 10부터 있었으며 AutoCAD 릴리즈 13부터는 핸들이 항상 작동 가능합니다.
  • AutoCAD 릴리즈 11부터 도면요소로서의 선택적인 확장 데이터 테이블.
  • 선택적인 영구 리액터 테이블.
  • 차례로 응용프로그램에 의해 배치된 하위객체를 소유하고 있는 확장 사전에 대한 선택적인 소유자 포인터.

기호 테이블 및 기호 테이블 레코드는 데이터베이스 객체이므로 핸들을 갖습니다. 이들은 또한 DXF 레코드에 확장 데이터와 영구 리액터도 갖습니다.


객체간 영구 참조 핸들

데이터베이스 객체
DXF 고급 정보
포인터 및 소유자 참조
DXF 참조서 > DXF 고급 정보 >
객체간 영구 참조 핸들

일련의 그룹 코드 범위는 객체가 같은 도면/DXF 파일 내의 다른 객체에 대한 참조를 직접 지정할 수 있도록 허용합니다. 네 개의 범위에 지정할 수 있는 다음의 네 가지 참조 핸들 유형이 제공됩니다.

  • 소프트 포인터 핸들
  • 하드 포인터 핸들
  • 소프트 소유자 핸들
  • 하드 소유자 핸들

이러한 핸들 유형은 AutoLISP®에서 도면요소 이름으로, ObjectARX®에서 ads_name 값으로, 그리고 ObjectARX에서 파생된 유사한 이름의 클래스로 명시됩니다. 복사 중인 세트 내 객체들 사이의 참조는 복사한 객체를 가리키도록 업데이트되고 다른 객체에 대한 참조는 변경되지 않은 채 유지됨으로써 삽입, 외부 참조 및 wblock 작업에서 이 값들은 항상 유지됩니다.

또한 도면요소 이름으로 변환되지 않고 이후에 삽입, 외부 참조 또는 wblock으로 변환되는 핸들 값을 편리하게 저장할 수 있도록 “임의의” 핸들에 대한 그룹 코드 범위도 정의됩니다.

주1005 확장 데이터를 사용하여 핸들을 저장하면 이들은 소프트 포인터 핸들처럼 처리되는데 이것은 객체 그룹이 다른 도면에 복사되거나 삽입되는 경우 관련된 객체들 사이의 참조가 변환되는 것을 뜻합니다. 1005 확장 데이터 항목은 AutoLISP 및 ObjectARX에서 항상 핸들로 반환되기는 하지만 모든 참조 핸들 그룹 코드 범위는 AutoLISP의 “도면요소 이름” 및 ObjectARX의 ads_name 구조로 표시됩니다.

이 단원의 항목

  • 포인터 및 소유자 참조
  • 하드 및 소프트 참조
  • 임의의 핸들
  • 1005 그룹 코드


포인터 및 소유자 참조

객체간 영구 참조 핸들
객체간 영구 참조 핸들
하드 및 소프트 참조
DXF 참조서 > DXF 고급 정보 > 객체간 영구 참조 핸들 >
포인터 및 소유자 참조

포인터는 다른 객체에 대해 사용은 가능하지만 소유나 책임은 가지고 있지 않음을 나타내는 참조입니다. 포인터 참조는 객체가 다른 객체를 일부 방식으로 사용하고 접근을 공유하는 것을 뜻합니다.

소유자 참조는 소유자 객체가 해당소유자 핸들을 가진 객체에 대해 책임을 가지고 있음을 뜻합니다. 소유자 참조는 몇 개의 키 루트 객체부터 시작되는 일반적인 방식으로 전체 DWG 및 DXF 파일의 쓰기를 지시합니다.

객체는 연관된 포인터 참조를 얼마든지 가질수 있지만 소유자는 하나만 있을 수 있습니다.


하드 및 소프트 참조

포인터 및 소유자 참조
객체간 영구 참조 핸들
임의의 핸들
DXF 참조서 > DXF 고급 정보 > 객체간 영구 참조 핸들 >
하드 및 소프트 참조

포인터인지 소유자인지에 관계없이 하드 참조는 객체를 소거되는 것으로부터 보호합니다. 소프트 참조는 보호하지 않습니다.

AutoCAD에서 블록 정의와 복합 도면요소는 자체 요소에 대한 하드 소유자입니다. 기호 테이블 및 사전은 자신의 요소에 대한 소프트 소유자입니다. 폴리선 도면요소는 자신의 정점 및 seqend 도면요소에 대한 소유자입니다. 삽입 도면요소는 자신의 속성 및 seqend 도면요소에 대한 하드 소유자입니다.

다른 객체에 대한 참조를 설정할 때는 참조가 PURGE 명령으로부터 객체를 보호해야 하는지 여부를 고려하는 것이 좋습니다.


임의의 핸들

하드 및 소프트 참조
객체간 영구 참조 핸들
1005 그룹 코드
DXF 참조서 > DXF 고급 정보 > 객체간 영구 참조 핸들 >
임의의 핸들

임의의 핸들은 내부적으로 세션간 영구 식별자로 또는 AutoLISP의 도면요소 이름 등으로 변환되지 않는다는 점에서 구별됩니다. 핸들로 저장됩니다. 핸들 값이 도면 병합 작업에서 변환될 때 임의의 핸들은 무시됩니다.

모든 환경에서 임의의 핸들은 handent 함수를 사용하여 현재 도면의 도면요소 이름으로 교체될 수 있습니다. 임의의 핸들의 일반적인 용도는 외부 DXF 및 DWG 파일의 객체를 참조하는 것입니다.


1005 그룹 코드

임의의 핸들
객체간 영구 참조 핸들
하위 클래스 표식기
DXF 참조서 > DXF 고급 정보 > 객체간 영구 참조 핸들 >
1005 그룹 코드

1005 확장 데이터 그룹 코드는 소프트 포인터와 같은 동작 및 의미를 가지므로 호스트 객체가 다른 도면에 병합될 때마다 변환됩니다. 그러나 1005 항목은 세션간 영구 식별자나 AutoLISP 및 ObjectARX의 내부 도면요소 이름으로 변환되지 않습니다. 핸들로 저장됩니다.


하위 클래스 표식기

1005 그룹 코드
DXF 고급 정보
확장 사전 및 영구 리액터
DXF 참조서 > DXF 고급 정보 >
하위 클래스 표식기

그룹 데이터 스트림을 파일링할 때 파일링이 수행된 각 상속 단계당 하나씩 단일 객체가 여러 개의 파일러 구성원으로 구성될 수 있습니다. 파생된 클래스와 상속 단계는 각각 별개로 진행되므로 각 클래스 파일러 구성원의 데이터는 다른 구성원으로부터 분리되어야 합니다. 이것은 하위 클래스 표식기를 사용하여 이루어집니다.

모든 클래스 파일러 구성원은 자신의 클래스에 해당하는 복제 데이터 부분 앞에 “하위 클래스” 표식기—해당 클래스의 실제 이름을 가진 문자열이 뒤에 오는 그룹 코드 100이 붙습니다. 이것이 객체 상태를 정의하는 데 필요한 상태에 영향을 미치지 않지만 DXF 파일 구문 분석기가 그룹 코드를 해당 응용프로그램 소프트웨어에 연결하는 수단을 제공합니다.

예를 들어, 여러 파생된 클래스의 데이터를 가진 객체는 다음과 같이 표시됩니다.

999
AcDbSonOfSonOfFoo 클래스에 의해 정의된 FOOGRANDCHILD
999
 AcDbSonOfFoo에서 파생됨
  0
FOOGRANDCHILD
  5
C2
100
AcDbFoo
999
10/20/30 그룹 코드 사용
 10
1.1
 20
2.3
 30
7.3
100
AcDbSonOfFoo
999
또한 10/20/30 그룹 코드를 다른 목적으로 사용
 10
1.1
 20
2.3
 30
7.3
100
AcDbSonOfSonOfFoo
999
또한 10/20/30 그룹 코드를 또 다른 목적으로 사용
 10
13.2
 20
23.1
 30
31.2
999
확장 데이터용
1001
APP_1
1070
45
1001
APP_2
1004
18A5B3EF2C199A


확장 사전 및 영구 리액터

하위 클래스 표식기
DXF 고급 정보
확장 데이터
DXF 참조서 > DXF 고급 정보 >
확장 사전 및 영구 리액터

확장 사전은 현재 객체에 속한 사전 객체의 핸들을 저장하는 선택적인 시퀀스이며 확장 사전 자체적으로도 항목을 포함하고 있을 수 있습니다. 이 기능은 임의의 데이터베이스 객체를 어느 데이터베이스 객체에나 부착할 수 있게 해 줍니다. 임의의 객체나 항목에는 이 섹션이 있습니다.

영구 리액터는 현재 객체에 대한 리액터로 등록된 객체의 객체 핸들을 저장하는 선택적인 시퀀스입니다. 임의의 객체나 항목에는 이 섹션이 있습니다.


확장 데이터

확장 사전 및 영구 리액터
DXF 고급 정보
객체 좌표계(OCS)
DXF 참조서 > DXF 고급 정보 >
확장 데이터

확장 데이터(xdata)는 AutoLISP 또는 ObjectARX 응용프로그램으로 작성됩니다. 도면요소에 확장 데이터가 포함되어 있으면 이 데이터는 도면요소의 일반 정의 데이터 뒤에 나옵니다. 그룹 코드 1000~1071까지가 확장 데이터를 설명합니다. 다음은 DXF 형식에서 확장 데이터를 포함한 도면요소의 예제입니다.

일반 도면요소 정의 데이터:

  0
INSERT
  5
F11
100
AcDbEntity
  8
TOP
100
AcDbBlockReference
 2
BLOCK_A
 10
0.0
 20
0.0
 30
0.0

확장 도면요소 정의 데이터:

1001
AME_SOL
1002
{
1070
 0
1071
 1.95059E+06
1070
 519
1010
2.54717
1020
2.122642
1030
2.049201
1005
ECD
1005
EE9
1005
0
1040
0.0
1040
1.0
1000
MILD_STEEL

그룹 코드 1001은 확장 데이터의 시작을 나타냅니다. 일반 도면요소 데이터와 달리 확장 데이터의 경우는 같은 그룹 코드가 여러 번 표시될 수 있으며 순서가 중요합니다.

확장 데이터는 등록된 응용프로그램 이름으로 그룹화됩니다. 등록된 각 응용프로그램 그룹은 그룹 코드 1001로 시작되며 해당 응용프로그램 이름도 문자열 값으로 함께 표시됩니다. 등록된 응용프로그램 이름은 APPID 기호 테이블의 항목과 일치합니다.

응용프로그램은 필요한 수만큼의 APPID 이름을 사용할 수 있습니다. 도면에서 APPID 이름을 현재 사용하지 않으면 소거할 수 있지만 APPID 이름은 영구적입니다. APPID 이름은 각 도면요소에 부착된 하나의 데이터 그룹만을 가질 수 있습니다. 응용프로그램 그룹 내에서 확장 데이터 그룹의 순서 및 의미는 응용프로그램에 의해 정의됩니다.

확장 데이터 그룹 코드가 다음 테이블에 나열되어 있습니다.

확장 데이터의 그룹 코드 및 설명
도면요소 이름 | 그룹 코드 | 설명
문자열 | 1000 | 확장 데이터의 문자열 길이는 255 바이트까지일 수 있습니다(256번째 바이트는 null 문자를 위해 예약됨).
응용프로그램 이름 | 1001 또한 문자열 값 | 응용프로그램 이름의 길이는 31 바이트까지일 수 있습니다(32번째 바이트는 null 문자를 위해 예약됨). 주AutoCAD가 새 응용프로그램 확장 데이터 그룹의 시작으로 간주하므로 확장 데이터에 1001 그룹을 추가하지 마십시오.
제어 문자열 | 1002 | 확장 데이터 조정 문자열은 “{”또는 “}”일 수 있습니다. 응용프로그램은 중괄호를 사용하여 데이터를 리스트로 세분하여 구성될 수 있습니다. 왼쪽 중괄호는 리스트를 시작하고 오른쪽 중괄호는 가장 최근 리스트를 종료합니다. 리스트는 내포될 수 있습니다. AutoCAD가 특정 응용프로그램의 확장 데이터를 읽을 때 AutoCAD는 중괄호의 짝이 맞는지 확인합니다.
도면층 이름 | 1003 | 확장 데이터에 연관된 도면층의 이름.
이진 데이터 | 1004 | 이진 데이터는 가변 길이 묶음으로 구성됩니다. 각 묶음의 최대 길이는 127 바이트입니다. ASCII DXF 파일에서 이진 데이터는 이진 바이트당 두 개씩 16진수의 문자열로 표시됩니다.
데이터베이스 핸들 | 1005 | 도면 데이터베이스에 있는 도면요소의 핸들 주핸들 및 확장 데이터 핸들을 가진 도면을 INSERT, INSERT *, XREF Bind, XBIND 또는 부분적 OPEN을 사용하여 다른 도면 내로 가져오면 확장 데이터 핸들은 해당 도면요소 핸들과 같은 방식으로 변환되며 따라서 결합이 유지됩니다. EXPLODE 블록 작업 또는 다른 모든 AutoCAD 작업에서도 마찬가지입니다. AUDIT가 도면 파일에 있는 도면요소의 핸들과 일치하지 않는 확장 데이터 핸들을 탐지하면 오류로 간주됩니다. AUDIT가 도면요소를 수정하는 경우 그 핸들은 0으로 설정됩니다.
3개의 실수 | 1010, 1020, 1030 | X, Y, Z 순서의 세 개의 실수값. 이들은 점 또는 벡터 레코드로 사용될 수 있습니다. AutoCAD는 이들의 값을 결코 변경하지 않습니다.
표준 공간 위치 | 1011, 1021, 1031 | 단순한 3D 점과 달리 표준 공간 좌표는 확장 데이터가 속한 상위 도면요소와 함께 이동하고, 축척되며, 대칭됩니다. 표준 공간 위치는 또한 STRETCH 명령이 상위 도면요소에 적용될 때 신축되며 이 점은 선택 윈도우 내에 놓입니다.
표준 공간 변위 | 1012, 1022, 1032 | 역시 상위 도면요소와 함께 축척되고, 회전되고, 대칭되는 3D 점입니다. 그러나 이동하거나 신축되지는 않습니다.
표준 방향 | 1013, 1023, 1033 | 역시 상위 도면요소와 함께 회전되고 대칭되는 3D 점입니다. 그러나 이동하거나, 축척되거나, 신축되지는 않습니다.
실수 | 1040 | 실수값
거리 | 1041 | 상위 도면요소와 함께 축척되는 실수값.
축척 비율 | 1042 | 역시 상위 도면요소와 함께 축척되는 실수값. 거리와 축척 요인 사이의 차이는 응용프로그램에서 정의된다는 것입니다.
정수 | 1070 | 16 비트 정수(부호 있는 또는 부호 없는)
배정밀도 | 1071 | 32 비트 부호 있는 (긴) 정수


객체 좌표계(OCS)

확장 데이터
DXF 고급 정보
임의의 축 알고리즘
DXF 참조서 > DXF 고급 정보 >
객체 좌표계(OCS)

공간을 도면 데이터베이스(및 DXF 파일)에 저장하려면 각 도면요소에 연관된 점은 도면요소 자체의 객체 좌표계(OCS) 항으로 표시됩니다. OCS에 대해 3D 공간에서 도면요소의 위치를 설명하는 데 필요한 유일한 추가 정보는 OCS의 Z 축을 설명하는 3D 벡터와 고도 값입니다.

주어진 Z축(또는 돌출) 방향에 대해 3D 공간의 원점을 변환하고 Z축 둘레로 X 및 Y축을 회전하여 정의되는 무한한 수의 좌표계가 있습니다. 그러나 동일한 Z축 방향에 대해 OCS는 단 하나입니다. OCS는 다음과 같은 특성을 갖습니다.

  • 원점이 WCS의 원점과 일치합니다.
  • XY 평면 내의 X 및 Y축 방향은 임의의 방식으로 계산될 수 있지만 일관성이 유지되어야 합니다. AutoCAD는 이 계산을 임의의 축 알고리즘을 사용하여 수행합니다(임의의 축 알고리즘 참고).

일부 도면요소의 경우 OCS가 WCS와 동일한 기능을 하며 모든 점(DXF 그룹 10-37)이 표준 좌표로 표시됩니다. 다음 표를 참고하십시오.

도면 유형에 연관된 좌표계
도면요소 | 주
선, 점, 3D 면, 3D 폴리선, 3D 정점, 3D 메쉬, 3D 메쉬 정점 등과 같은 3D 도면요소 | 이 도면요소들은 특정 평면에 놓이지 않습니다. 모든 점이 표준 좌표로 표시됩니다. 이 도면요소들 중에서 선과 점만이 돌출될 수 있습니다. 이들의 돌출 방향은 표준 Z축과 다를 수 있습니다.
원, 호, 솔리드, 두께선, 문자, 속성, 속성 정의, 쉐이프, 삽입, 2D 폴리선, 2D 정점, 단순 폴리선, 해치, 이미지 등과 같은 2D 도면요소 | 이 도면요소들은 사실상 평면형입니다. 모든 점이 객체 좌표로 표시됩니다. 이 도면요소들은 돌출될 수 있습니다. 이들의 돌출 방향은 표준 Z축과 다를 수 있습니다.
치수 | 치수 점 중 일부는 WCS로 표시되고 일부는 OCS로 표시됩니다.
뷰포트 | 표준 좌표계로 표시됩니다.

일단 AutoCAD가 주어진 도면요소에 대해 OCS를 설정하면 OCS가 다음과 같이 작동됩니다. 도면요소와 함께 저장된 고도값은 XY 평면을 해당 도면요소가 포함된 평면과 일치시키기 위해 Z축을 기준으로 WCS 원점으로부터 이동한 거리를 표시합니다. 이 값에서 사용자가 정의한 고도가 얼마나 되는지는 중요하지 않습니다.

UCS를 통해 입력된 2D 점은 OCS의 상응하는 2D 점으로 변환되며 UCS를 기준으로 이동되고 회전합니다.

다음은 이러한 과정으로부터 파생되는 결과입니다.

  • 도면요소를 얻었을 때 어떤 UCS가 사용 중이었는지 확실하게 알 수 없습니다.
  • 지정된 UCS에서 도면요소의 XY 좌표를 입력한 다음 SAVEAS를 수행하면 DXF 파일에서 입력된 XY 좌표를 인식할 수 없게 됩니다. 이 값에 대한 작업을 하려면 AutoCAD가 X 및 Y축을 계산하는 방법을 알아야 합니다.
  • 도면요소 및 DXF 파일의 출력에 저장되는 고도값은 UCS XY 평면과 OCS XY 평면 그리고 도면요소를 그릴 때 사용자가 지정한 고도값 사이의 Z 좌표 차이를 요약해 보여 줍니다.


임의의 축 알고리즘

객체 좌표계(OCS)
DXF 고급 정보
DXF 참조서 > DXF 고급 정보 >
임의의 축 알고리즘

임의의 축 알고리즘은 객체 좌표를 사용하는 모든 도면요소에 대해 임의의 방식으로 그러나 일관성있는 객체 좌표계 생성을 구현하기 위해 AutoCAD 내부에서 사용됩니다.

좌표계의 Z축으로 사용될 단위 길이 벡터가 주어지면 임의의 축 알고리즘은 이 좌표계의 상응하는 X축을 생성합니다. 그런 다음 Y축이 오른손 법칙을 적용해서 결정됩니다.

방법은 주어진 Z축(법선 벡터라고도 함)을 검사하는 것입니다. 주어진 Z축이 양의 또는 음의 표준 Z축에 가까우면 표준 Y축을 주어진 Z축과 교차시켜 임의의 X축에 도달하도록 합니다. 가깝지 않으면 표준 Z축을 주어진 Z축과 교차시켜 임의의 X축에 도달하도록 합니다. 이러한 결정이 내려지는 경계는 계산하는 데 비용이 거의 들지 않고 기계들 사이에 완전히 이전 가능하도록 선택되었습니다. 6개의 소수 숫자와 6개의 이진 비트로 정확하게 지정할 수 있으며 범위가 1/64인 일종의 “사각형” 극관(polar cap)을 채용함으로써 이것이 가능합니다.

이 알고리즘은 다음을 수행합니다. (모든 벡터는 3D 공간에 있는 것으로 간주되고 표준 좌표계에서 지정됩니다.)

주어진 법선 벡터는 N.
항상 (0,1,0)인 표준 Y축은 Wy.
항상 (0,0,1)인 표준 Z축은 Wz.

여기에서 우리는 법선 N에 상응하는 임의의 X와 Y축을 찾고 있습니다. 이들은 Ax와 Ay라고 합니다. N도 다음에서와 같이 Az(임의의 Z축)라고 할 수 있습니다.

(abs (Nx) < 1/64) 및 (abs (Ny) < 1/64)  일 경우
     Ax = Wy X N  (여기서 “X”는 교차곱 연산자임)
그렇지 않으면,
     Ax = Wz X N.
단위 길이로 Ax를 축척.

Ay 벡터를 얻는 방법은 다음과 같습니다.

Ay = N X Ax.   단위 길이로 Ay 축척


의견 내보내기

의견이 있으시면 이 양식을 사용해서 문서 담당 부서인 Autodesk Technical Publications 그룹으로 보내주십시오.

항목 제목 및 위치 (편집하지 마십시오.):
이름(선택사항):
         전자 우편(선택사항):
설명:

주: 이 양식은 피드백이나 기술적 지원을 받는 용도로 작성되는 것은 아닙니다. 여러분께서 보내주신 정보는 앞으로 문서를 업데이트하는 데 사용됩니다. 감사합니다!