AutoCAD 2008 개발자 도움말

AutoCAD 2008 개발자 도움말에 오신 걸 환영합니다!

AutoCAD 개발자 도움말은 AutoCAD를 사용자화하고 확장하기 위한 모든 정보를 제공합니다. 오른쪽에 있는 링크를 클릭하거나 목차 탭을 사용하여 도움말 항목을 찾아 보십시오.

일반 정보

도움말 파일

사용자화 안내서

AutoLISP Reference

AutoLISP Developer's Guide

AutoLISP Tutorial

DXF 참조서

ActiveX/VBA 개발자 안내서

ActiveX and VBA Reference

Sheet Set Objects Reference

Connectivity Automation Reference

ObjectARX

내 도움말
웹 상의 자원


AutoCAD 2008 도움말

사용자화 안내서

사용자화 안내서는 경험이 풍부한 사용자를 위해 AutoCAD 사용자화 방법을 설명합니다. 사용자화 안내서를 찾아보려면 도움말 윈도우 왼쪽에 있는 목차 탭을 사용하십시오.

  • 기본 사용자화
  • 사용자 선종류
  • 사용자 해치 패턴
  • 사용자 인터페이스 사용자화
  • DIESEL
  • 슬라이드 및 명령 스크립트
  • 프로그래밍 인터페이스 소개
  • 쉐이프 및 쉐이프 글꼴
일반 정보

도움말 파일

사용자화 안내서

AutoLISP Reference

AutoLISP Developer's Guide

AutoLISP Tutorial

DXF 참조서

ActiveX 및 VBA 개발자 안내서

ActiveX and VBA Reference

Sheet Set Objects Reference

Connectivity Automation Reference


AutoLISP Reference

AutoLISP Tutorial는 AutoCAD 명령, 시스템 변수 및 대화상자를 호출하기 위한 모든 기능이 갖춰진 해석 프로그래밍 언어인 AutoLISP®에 대한 포괄적인 참조서입니다. AutoLISP Tutorial에는 다음과 같은 주제가 포함되어 있습니다.

  • AutoLISP 함수: 연산자, A, B, C, D, E, F, G, H, I, J, K, L, M, N, O, P, Q, R, S, T, U, V, W, X, Y, Z.
  • 외부 정의 명령어
일반 정보

도움말 파일

사용자화 안내서

AutoLISP Reference

AutoLISP Developer's Guide

AutoLISP Tutorial

DXF 참조서

ActiveX/VBA 개발자 안내서

ActiveX and VBA Reference


AutoLISP Developer's Guide

AutoLISP Developer's Guide는 대화식 Visual LISP® 개발 환경을 사용하여 AutoLISP® 프로그램을 개발하고 테스트하기 위한 정보를 제공합니다. 본 안내서는 또한 Visual LISP와 함께 제공되는 확장기능을 사용하여 ActiveX® 자동화를 작성하는 방법을 설명합니다. AutoLISP Developer's Guide에는 다음과 같은 주제가 포함되어 있습니다.

  • 소개
  • Visual LISP 환경 사용하기
  • AutoLISP 언어 사용하기
  • 프로그래밍할 수 있는 대화상자로 작업하기
  • 부록
일반 정보

도움말 파일

사용자화 안내서

AutoLISP Reference

AutoLISP Developer's Guide

AutoLISP Tutorial

DXF 참조서


AutoLISP Tutorial

AutoLISP Tutorial은 Visual LISP™를 사용하여 AutoLISP® 응용프로그램을 개발하는 방법을 가르쳐 주는 단계별 학습서입니다. AutoLISP Tutorial에는 다음과 같은 주제가 포함되어 있습니다.

  • 소개
  • 프로그램 설계 및 시작하기
  • Visual LISP 디버깅 도구 사용하기
  • 경로 경계 그리기
  • 프로젝트 작성 및 인터페이스 추가하기
  • 타일 그리기
  • 리액터로 작업하기
  • 모두 결합하기
일반 정보

도움말 파일

사용자화 안내서

AutoLISP Reference

AutoLISP Developer's Guide

AutoLISP Tutorial


DXF 참조서

DXF 참조서는 DXF™ 파일 형식에 대한 포괄적인 참조서입니다. DXF 참조서에는 다음과 같은 주제가 포함되어 있습니다.

  • DXF 형식
  • HEADER 섹션
  • CLASSES 섹션
  • TABLES 섹션
  • BLOCKS 섹션
  • ENTITIES 섹션
  • OBJECTS 섹션
  • THUMBNAILIMAGE 섹션
  • DXF(Drawing Interexchange File) 형식
  • DXF 고급 정보
일반 정보

도움말 파일

사용자화 안내서

AutoLISP Reference

AutoLISP Developer's Guide

AutoLISP Tutorial


ActiveX 및 VBA 개발자 안내서

ActiveX/VBA 개발자 안내서는 ActiveX와 VBA를 사용하여 AutoCAD를 사용자화하는 프로그램을 개발하는 방법을 설명합니다. 이 안내서에는 예제 코드와 단계별 절차도 수록되어 있습니다. ActiveX/VBA 개발자 안내서에는 다음과 같은 주제가 포함되어 있습니다.

  • 소개
  • VBA 시작
  • ActiveX 자동화 기본 개념
  • AutoCAD 환경 조정
  • AutoCAD 도면요소 작성 및 편집
  • 치수와 공차
  • 도구막대 및 메뉴 사용자화
  • 이벤트 사용
  • 3차원 공간에서 작업
  • 배치 및 플롯 정의
  • 고급 도면 및 구성 기법
  • VBA를 사용하여 응용프로그램 개발
  • 다른 응용프로그램 및 Windows API와의 상호작용
  • ActiveX/VBA 튜토리얼:정원 경로 설계
  • Visual LISP와 ActiveX/VBA 비교
일반 정보

도움말 파일

사용자화 안내서

AutoLISP Reference

AutoLISP Developer's Guide

AutoLISP Tutorial


ActiveX and VBA Reference

ActiveX and VBA Reference는 ActiveX 객체 모델 및 연관된 인터페이스 구성요소에 대한 참조서입니다. ActiveX and VBA Reference에는 다음과 같은 주제가 포함되어 있습니다.

  • 객체 모델
  • 이벤트
  • 메서드
  • 특성
  • 객체
  • 코드 예제
일반 정보

도움말 파일

사용자화 안내서

AutoLISP Reference

AutoLISP Developer's Guide

AutoLISP Tutorial

ActiveX 및 VBA 개발자 안내서


Sheet Set Objects Reference

Sheet Set Objects Reference는 시트 세트 관리자의 객체에 대한 참조서입니다. Sheet Set Objects Reference에는 다음과 같은 주제가 포함되어 있습니다.

  • 시트 세트 관리자 객체 개요
  • 객체
  • 메서드
  • 특성
  • 이넘
일반 정보

도움말 파일

사용자화 안내서

AutoLISP Reference

AutoLISP Developer's Guide

AutoLISP Tutorial


Connectivity Automation Reference

Connectivity Automation Reference는 연결 자동화 객체 모델 및 연관된 인터페이스 구성요소에 대한 참조를 제공합니다. Connectivity Automation Reference에는 다음과 같은 주제가 포함되어 있습니다.

  • 연결 자동화 객체
  • 객체 모델
  • 객체
  • 메서드
  • 특성
  • 이벤트
일반 정보

도움말 파일

사용자화 안내서

AutoLISP Reference

AutoLISP Developer's Guide

AutoLISP Tutorial


ObjectARX

AutoCAD® 런타임 확장 프로그래밍 환경인 ObjectARX®에는 AutoCAD 응용프로그램을 개발하고 AutoCAD 클래스와 프로토콜을 확장하고 내장된 AutoCAD 명령과 같은 방식으로 작동하는 새 명령을 작성하는 데 사용할 수 있는 구성 블록인 C++ 라이브러리가 포함되어 있습니다.

이 도움말 항목이 페이지 아이콘( [image])으로 목차 탭에 표시되면 도움말 시스템에서 ObjectARX 문서를 사용할 수 없습니다.

AutoCAD ObjectARX 문서는 Autodesk 웹 사이트의 Developer Center 섹션에서 다운로드할 수 있습니다. ObjectARX 문서를 AutoCAD 문서에 통합하려면 ObjectARX의 도움말 파일을 AutoCAD \HELP\ 폴더로 복사합니다.
일반 정보

도움말 파일

사용자화 안내서

AutoLISP Reference

AutoLISP Developer's Guide

AutoLISP Tutorial

연결성 및 자동화 참조서


내 도움말

내 도움말이라고 하는 사용자 고유의 도움말 항목 그룹을 작성할 수 있습니다. 작성된 내 도움말 항목을 AutoCAD 도움말에 추가하여 도움말 윈도우 왼쪽 창의 목차 탭, 색인 탭(색인 항목을 추가한 경우) 및 검색 탭에서 사용할 수 있습니다. AutoCAD 도움말에 추가된 도움말 항목에 접근하려면 목차 탭의 내 도움말 항목을 클릭하십시오.

내 도움말 설정에 대한 자세한 정보는 내 도움말 설정을 참조하십시오.
일반 정보

도움말 파일

사용자화 안내서

AutoLISP Reference

AutoLISP Developer's Guide

AutoLISP Tutorial


의견 내보내기

의견이 있으시면 이 양식을 사용해서 문서 담당 부서인 Autodesk Technical Publications 그룹으로 보내주십시오.

항목 제목 및 위치 (편집하지 마십시오.):
이름(선택사항):
         전자 우편(선택사항):
설명:

주: 이 양식은 피드백이나 기술적 지원을 받는 용도로 작성되는 것은 아닙니다. 여러분께서 보내주신 정보는 앞으로 문서를 업데이트하는 데 사용됩니다. 감사합니다!


저작권 및 상표

Copyright © 2007 Autodesk, Inc.

판권 소유

이 책자 또는 이에 대한 부분은 어떤 형태 또는 어떤 방법, 어떤 목적으로도 복제할 수 없습니다.

AUTODESK, INC.는 본 자료와 관련하여 특정 목적에 대한 적합성과 상업성에 대한 묵시적 보증을 비롯하여 어떠한 묵시적 또는 명시적 보증도 하지 않으며 자료를 "있는 그대로" 제공합니다.

AUTODESK, INC.는 어떠한 경우에도 이 자료와 관련되고 구입한 데 따른 특수한, 간접적, 파생적, 부수적 손해에 대한 책임을 지지 않습니다. AUTODESK, INC.의 단독 및 배타적 책임은 어떠한 경우에도 여기에 명시된 자료의 구입 비용을 초과하지 않습니다.

Autodesk, Inc.는 제품을 수정하고 향상시킬 수 있는 권한을 보유합니다. 이 책자의 내용은 책자가 출판되는 시점의 제품 상태를 설명하고 있으며, 이후에 이루어진 제품의 변경 사항은 반영되지 않을 수 있습니다.

Autodesk 상표

다음은 Autodesk, Inc.의 미국 및 다른 나라에서의 등록 상표 또는 상표입니다. 3DEC (디자인/로고), 3December, 3December.com, 3ds Max, ActiveShapes, Actrix, ADI, Alias, Alias (소용돌이 모양 디자인/로고), AliasStudio, Alias|Wavefront (design/logo), ATC, AUGI, AutoCAD, AutoCAD Learning Assistance, AutoCAD LT, AutoCAD Simulator, AutoCAD SQL Extension, AutoCAD SQL Interface, Autodesk, Autodesk Envision, Autodesk Insight, Autodesk Intent, Autodesk Inventor, Autodesk Map, Autodesk MapGuide, Autodesk Streamline, AutoLISP, AutoSnap, AutoSketch, AutoTrack, Backdraft, Built with ObjectARX (로고), Burn, Buzzsaw, CAiCE, Can You Imagine, Character Studio, Cinestream, Civil 3D, Cleaner, Cleaner Central, ClearScale, Colour Warper, Combustion, Communication Specification, Constructware, Content Explorer, Create>what's>Next> (디자인/로고), Dancing Baby (이미지), DesignCenter, Design Doctor, Designer's Toolkit, DesignKids, DesignProf, DesignServer, DesignStudio, Design|Studio (디자인/로고), Design Your World, Design Your World (디자인/로고), DWF, DWG, DWG (로고), DWG TrueConvert, DWG TrueView, DXF, EditDV, Education by Design, Extending the Design Team, FBX, Filmbox, FMDesktop, GDX Driver, Gmax, Heads-up Design, Heidi, HOOPS, HumanIK, i-drop, iMOUT, Incinerator, IntroDV, Kaydara, Kaydara (디자인/로고), LocationLogic, Lustre, Maya, Mechanical Desktop, MotionBuilder, ObjectARX, ObjectDBX, Open Reality, PolarSnap, PortfolioWall, Powered with Autodesk Technology, Productstream, ProjectPoint, Reactor, RealDWG, Real-time Roto, Render Queue, Revit, Showcase, SketchBook, StudioTools, Topobase, Toxik, Visual, Visual Bridge, Visual Construction, Visual Drainage, Visual Hydro, Visual Landscape, Visual Roads, Visual Survey, Visual Syllabus, Visual Toolbox, Visual Tugboat, Visual LISP, Voice Reality, Volo 및 Wiretap.

다음은 Autodesk Canada Co.의 미국 및/또는 캐나다 및 다른 나라에서의 등록 상표입니다. Backburner, Discreet, Fire, Flame, Flint, Frost, Inferno, Multi-Master Editing, River, Smoke, Sparks, Stone, Wire.

써드 파티 상표

기타 모든 브랜드 이름, 제품 이름 또는 상표는 해당 소유권자의 소유입니다.

써드 파티 소프트웨어 프로그램 정보

ACIS Copyright © 1989-2001 Spatial Corp

Copyright © 1999-2000 The Apache Software Foundation. 판권 소유. 이 제품은 Apache Software Foundation (http://www.apache.org)의 라이센스 사용 조건(http://xml.apache.org/dist/LICENSE.txt)에 따르는, Apache Software Foundation에 의해 개발된 소프트웨어를 포함합니다.

Typefaces from the Bitstream © typeface library Copyright © 1992.

HLM © Copyright D-Cubed Ltd. 1996-2006. HLM은 D-Cubed Ltd의 상표입니다.

AutoCAD © 2008 및 AutoCAD LT ® 2008은 Dainippon Ink and Chemicals, Inc.의 DIC Color Guide©로부터 파생된 데이터의 라이센스 하에서 제작되었습니다. Copyright © Dainippon Ink and Chemicals, Inc. 판권 소유. DIC 및 DIC Color Guide는 Dainippon Ink and Chemicals, Inc.의 등록 상표입니다.

이 소프트웨어의 부분은 Independent JPEG Group의 작업에 근거합니다.

Active Delivery© 2.0 © 1999-2000 Inner Media, Inc. 판권 소유.

ISYS 및 ISYS 로고는 ISYS© Search Software Inc의 등록 상표 또는 상표입니다.

Copyright © 1988-1997 Sam Leffler. Copyright© 1991-1997 Silicon Graphics, Inc.

Copyright © Lingea s.r.o. 2006

새로운 기능 워크샵은 Macromedia, Inc의 Macxromedia Flash™ Player소프트웨어를 포함합니다. Copyright © 1995-2005 Macromedia, Inc. 판권 소유. Macromedia © 및 Flash ©는 미국 또는 다른 나라에서 Adobe Systems Incorporated의 등록 상표 또는 상표입니다.

Copyright © 1996-2006 Macrovision Corporation 판권 소유.

Copyright © 1996-2006 Microsoft Corporation. 판권 소유

Copyright © 2002 Joseph M. O'Leary.

사용자 문서 또는 소프트웨어 응용프로그램에 표시된 PANTONE© 색상은 PANTONE 식별 표준과 일치하지 않을 수 있습니다. 정확한 색상은 현재 PANTONE Color Publication을 참조하십시오.

PANTONE © 및 기타 Pantone, Inc. 상표는 Pantone, Inc. © Pantone, Inc., 2004의 소유입니다.

Pantone, Inc.는 특정 Autodesk 소프트웨어 제품과 함께 사용할 경우에만 분배하도록 Autodesk, Inc.에 라이센스가 부여된 색상 데이터 또는 소프트웨어의 저작권 소유자입니다. PANTONE 색상 데이터 및/또는 소프트웨어는 이 Autodesk 소프트웨어 제품 실행의 부분으로서가 아니면 다른 디스크 또는 메모리로 복사해서는 안됩니다.

Typefaces from the Bitstream ® typeface library copyright 1992, 1996. 판권 소유.

RAL DESIGN © RAL, Sankt Augustin, 2004.

RAL CLASSIC © RAL, Sankt Augustin, 2004.

RAL 색상의 표현은 RAL Deutsches Institut für Gütesicherung und Kennzeichnung e.V. (RAL German Institute for Quality Assurance and Certification, re. Assoc.)의 승인으로 완료되었습니다. D-53757 Sankt Augustin.

이 제품은 RSA Security, Inc로부터 라이센스 된 코드를 포함합니다. IBM으로부터의 일부 부분은 http://oss.software.ibm.com/icu4j/에서 사용 가능합니다.

The Sentry Spelling-Checker Engine Copyright © 1994-2003 Wintertree Software, Inc.

이 소프트웨어의 부분은 하나 또는 그 이상의 Boost libraries를 포함합니다. Boost libraries의 사용은 라이센스 계약서 http://www.boost.org/LICENSE_1_0.txt에 따릅니다.


내 도움말 설정

내 도움말을 설정하려면 HTML 형식으로 도움말 항목을 작성한 다음 Microsoft HTML Help Workshop으로 컴파일하여 myhelp.chm이라는 이름의 컴파일된 도움말 파일을 작성해야 합니다. 이 파일을 AutoCAD\Help 폴더로 복사합니다.

하이퍼링크된 항목의 제목을 기본 내 도움말 항목에 표시하려면

  • 해당 항목의 제목이 나열되어 있는 파일을 CHM 파일에 포함시킵니다. 포함된 파일을 myhelp_toc.html로 명명합니다.

항목의 제목을 목차 탭에 표시하려면

  • 해당 항목의 제목이 나열되어 있는 HHC(도움말 목차) 파일을 CHM 파일에 포함시킵니다.

도움말 항목에 추가된 모든 색인 항목을 표시하려면

  • HHK(도움말 색인) 파일을 CHM 파일에 포함시킵니다.

myhelp_toc.html 파일이나 HHC 또는 HHK 파일을 포함시키지 않았더라도 검색 탭에서 CHM 파일의 내용을 볼 수 있습니다.