사용자화 안내서

기본 사용자화
AutoCAD 2008 사용자화 안내서 >
사용자화 안내서

사용자화 안내서는 경험이 있는 사용자들을 상대로 AutoCAD를 사용자화하는 방법을 알려줍니다. 사용자화 안내서를 찾아보려면 도움말 윈도우의 왼쪽 탭의 목차 탭을 사용하십시오.

이 페이지에 대한 의견을 보내주십시오


기본 사용자화

사용자화 안내서
사용자화에 대한 개요
AutoCAD 2008 사용자화 안내서 >
기본 사용자화

AutoCAD®는 개방형 구조를 사용하여 설계된 일반 용도의 제도 시스템이므로 많은 기능을 사용자화하고 확장할 수 있습니다 따라서 사용자 요구에 따라 AutoCAD를 확장하고 자신에게 맞게 변경할 수 있습니다.

이 단원의 항목

  • 사용자화에 대한 개요
  • 프로그램 및 지원 파일 구성

    프로그램 및 지원 파일의 기본 디렉토리 구조를 자신의 요구에 맞게 변경할 수 있습니다.

  • [웹으로 출판] 템플릿 사용자화

    제공된 [웹으로 출판] 템플릿(PWT) 파일 중 하나를 수정하여 [웹으로 출판] 마법사에서 사용할 사용자화된 템플릿을 작성할 수 있습니다. 임의의 HTML 편집기 또는 문자 편집기를 사용합니다.

  • 사용자 명령 정의

    AutoCAD에서 실행할 수 있는 외부 명령을 정의할 수 있습니다. 명령 정의가 저장된 ASCII 텍스트 파일인 acad.pgp 파일에서 AutoCAD 명령의 명령 별칭을 작성할 수도 있습니다.


사용자화에 대한 개요 (개념)

기본 사용자화
기본 사용자화
프로그램 및 지원 파일 구성
AutoCAD 2008 사용자화 안내서 > 기본 사용자화 >
사용자화에 대한 개요
개념 요약 참조

AutoCAD를 간단하게 사용자화할 수 있습니다. 예를 들어, 디렉토리 구조를 변경하거나 한 도구막대에서 다른 도구막대로 버튼을 이동할 수 있습니다. 인터페이스를 변경하려면 CUI 파일을 편집하고 DIESEL 코드를 사용하여 사용자 고유의 명령으로 사용자화를 작성할 수 있습니다.

여러 가지 강력한 API(Application Programming Interface)를 사용하여 필요에 따라 AutoCAD에 추가하고 수정할 수도 있습니다.

다음 리스트는 복잡도가 낮은 것에서 높은 순서로 정렬되어 있습니다.

  • 파일 구성. 프로그램, 지원 및 도면 파일을 구성할 수 있습니다. 예를 들어, 각 프로젝트에 대해 프로젝트에 필요한 지원 파일만 들어 있는 별도의 폴더를 만들 수 있습니다.
  • 도구 팔레트 사용자화. 도면에서 도구 팔레트로 객체를 끌어 도구를 작성할 수 있습니다. 도구 팔레트 제목 표시줄을 마우스 오른쪽 버튼으로 클릭하고 새 팔레트를 선택하여 도구 팔레트를 작성할 수 있습니다. 도구 팔레트 사용자화에 대한 자세한 정보는 사용자 안내서의 “도구 팔레트 사용자화”를 참고하십시오.
  • 사용자화 템플릿 작성. [웹으로 출판] 마법사를 사용하여 도면을 게시할 때 템플릿을 사용하여 일반적인 매개변수를 정의합니다.
  • AutoCAD 내에서 외부 프로그램 및 유틸리티 실행. 예를 들어, 적절한 외부 명령을 프로그램 매개변수(PGP) 파일 acad.pgp에 추가하여 AutoCAD 내에서 디스크를 복사하거나 파일을 삭제할 수 있습니다.
  • 명령 별칭 정의. PGP 파일 acad.pgp에 명령을 추가하여 AutoCAD 내에서 자주 사용되는 명령에 대해 간단한 축약어 또는 별칭을 정의할 수 있습니다. 예를 들어, b를 입력하여 BLOCK 명령을 시작할 수 있습니다.
  • 사용자 선종류, 해치 패턴, 쉐이프 및 문자 글꼴 작성. 회사 표준과 작업 방법에 맞는 선종류, 해치 패턴, 쉐이프 및 문자 글꼴을 작성할 수 있습니다.
  • 사용자 인터페이스 사용자화. CUI 파일은 좌표 입력 장치 버튼의 동작, 풀다운 메뉴, 타블렛 메뉴, 이미지 배열 메뉴, 도구막대 및 가속 키의 기능과 모양 등 사용자 인터페이스의 여러 측면을 조정합니다. CUI 파일을 편집하거나 새로 작성하여 명령을 추가하거나, 명령을 결합하여 메뉴, 도구막대 또는 기타 위치에 지정할 수 있습니다.
  • 상태 행 사용자화. DIESEL 문자열 표현식 언어와 MODEMACRO 시스템 변수를 사용하여 상태 행에 날짜와 시간, 시스템 변수 설정값 또는 AutoLISP®를 사용하여 검색 가능한 정보 등 추가 정보를 제공할 수 있습니다.
  • 스크립트를 작성하여 반복 작업 자동화. 스크립트는 명령이 들어 있는 ASCII 텍스트 파일로, 스크립트를 실행할 때 배치 파일과 유사하게 처리됩니다. 예를 들어, 도면 세트를 특정 방식으로 플롯해야 하는 경우 각 도면을 열고 여러 도면층을 숨기거나 표시하고, PLOT 명령을 실행하는 스크립트를 작성할 수 있습니다. 스크립트를 슬라이드와 함께 사용하여 무역 박람회에 사용되는 것과 같은 자동화된 프리젠테이션을 작성할 수 있습니다. 슬라이드는 편집할 수 없는 도면 영역의 “스냅샷”입니다. 슬라이드는 이미지 배열 메뉴와 대화상자에 사용할 수도 있습니다.
  • 선택한 AutoCAD 명령을 명령 프롬프트에서 또는 AutoLISP나 ObjectARX® 프로그램의 일부로 재정의하거나 작동 불가능하게 합니다. 특정 AutoCAD 명령을 재정의하여 보조 메시지와 지시사항을 실행하거나, QUIT 명령을 재정의하는 도면 관리 시스템을 작성하여 편집 세션을 종료하기 전에 청구 내역 정보를 로그 파일에 쓸 수 있습니다.

사용자화 안내서에 설명되어 있는 방법 이외에 AutoCAD를 사용자화하는 데 사용할 수 있는 API(Application Programming Interfaces)가 있습니다. 프로그래밍 인터페이스 소개에서는 이러한 API에 대해 간략하게 설명하며 자세한 정보를 볼 수 있는 상호 참조를 제공합니다.

참고

    • 프로그램 및 지원 파일 구성

    • 도구막대 사용자화

    • [웹으로 출판] 템플릿 사용자화

    • 명령 별칭 작성

    • 사용자 선종류

    • 사용자 해치 패턴

    • 사용자 인터페이스 사용자화

    • DIESEL

    • 상태 행 사용자화

    • 프로그래밍 인터페이스 소개

    • 슬라이드 및 명령 스크립트


사용자화에 대한 개요 (요약 참조)

사용자화에 대한 개요
파일 구성에 대한 개요
AutoCAD 2008 사용자화 안내서 > 기본 사용자화 > 사용자화에 대한 개요 >
사용자화에 대한 개요
개념 요약 참조

명령

CUSTOMIZE

사용자화 도구 팔레트

CUI

작업공간, 도구막대, 메뉴, 바로 가기 메뉴 및 키보드 바로 가기와 같은 사용자화된 사용자 인터페이스 요소를 관리합니다.

REDEFINE

UNDEFINE에 의해 재지정된 AutoCAD 내부 명령을 복원합니다.

UNDEFINE

응용프로그램에서 정의한 명령이 내부 명령을 재지정할 수 있도록 합니다.

시스템 변수

TOOLTIPS

도구막대에 툴팁의 표시를 제어합니다.

유틸리티

항목이 없습니다.

명령 수정자

항목이 없습니다.


프로그램 및 지원 파일 구성

사용자화에 대한 개요
기본 사용자화
파일 구성에 대한 개요
AutoCAD 2008 사용자화 안내서 > 기본 사용자화 >
프로그램 및 지원 파일 구성

프로그램 및 지원 파일의 기본 디렉토리 구조를 자신의 요구에 맞게 변경할 수 있습니다.

이 단원의 항목

  • 파일 구성에 대한 개요
  • 다중 구성

    여러 좌표 입력 장치를 사용하거나 여러 플로터를 사용하는 경우, 구성 파일을 여러 개 설정하여 장치 간에 쉽게 전환하도록 할 수 있습니다.

  • 다중 도면 폴더

    도면 및 기타 관련 파일을 별도의 디렉토리에 보관하면 기본적인 파일 관리 작업을 쉽게 수행할 수 있습니다.


파일 구성에 대한 개요 (개념)

프로그램 및 지원 파일 구성
프로그램 및 지원 파일 구성
다중 구성
AutoCAD 2008 사용자화 안내서 > 기본 사용자화 > 프로그램 및 지원 파일 구성 >
파일 구성에 대한 개요
개념 요약 참조

AutoCAD는 사용자화 정의 저장, AutoLISP 및 ObjectARX 응용프로그램 로드, 문자 글꼴 설명과 같은 목적으로 지원 파일을 사용합니다.

AutoCAD 프로그램과 지원 파일의 기본 디렉토리 구조를 통해 파일을 논리 그룹으로 효과적으로 구성할 수 있습니다. 이 구성이 사용자 요구에 맞지 않으면 변경할 수 있습니다. 그러나 일부 응용프로그램은 특정 위치에서 특정 파일을 찾기 때문에 수정한 사항이 그러한 응용프로그램 요구사항과 충돌하지 않는지 확인해야 합니다. 드라이브와 디렉토리 등 전체 경로를 지정하지 않으면 AutoCAD는 라이브러리 검색 경로에 있는 파일만 찾을 수 있습니다.

support 폴더의 위치가 AutoCAD 2004에서 변경되었습니다. 로컬 사용자화 가능 파일의 위치는 LOCALROOTPREFIX 시스템 변수에 저장되어 있습니다. 사용자화 및 로밍 가능한 파일의 위치는 ROAMABLEROOTPREFIX 시스템 변수에 저장됩니다. 네트워크에서 로밍을 지원하는 경우, 로그온한 시스템에서 사용자의 로밍 프로파일에 있는 사용자화 가능한 파일을 사용할 수 있습니다.

다음 LISP 스크립트는 올바른 폴더에서 Windows® 탐색기를 시작하는 CUSTFILES 명령을 작성합니다.

(defun c:custfiles ()
  (command "shell"
    (strcat "explorer \"" (getvar "roamablerootprefix") "\"")
  )
  (princ)
)

라이브러리 검색 경로

라이브러리 검색 경로는 전체 경로 이름을 지정하지 않은 경우 파일을 찾을 위치를 다음과 같이 지정합니다.

  • 현재 디렉토리. (보통 바로 가기 아이콘의 “시작 ”설정에 따라 결정됩니다.)
  • 현재 도면 파일이 들어 있는 디렉토리.
  • OPTIONS의 파일 탭에서 지정한 검색 경로에 나열된 디렉토리. (사용자 안내서의 검색 경로와 파일 위치를 지정합니다을 참고하십시오.)
  • AutoCAD 프로그램 파일이 들어 있는 디렉토리.

현재 환경에 따라 두 개 이상의 디렉토리가 동일할 수도 있습니다.

파일이 이 검색 경로에 없으면 경로 이름과 파일 이름을 모두 지정해야 AutoCAD에서 해당 경로를 찾을 수 있습니다. 예를 들어, part5.dwg 도면을 현재 도면에 삽입할 경우 도면이 라이브러리 검색 경로에 없으면 다음과 같이 전체 경로 이름을 지정해야 합니다.

명령: insert

블록 이름 입력 또는 [?]: /files2/olddwgs/part5

도면이 해당 위치에 있으면 AutoCAD는 보통 INSERT 명령을 종료할지 묻는 프롬프트를 표시합니다.

디렉토리 구조

AutoCAD는 트리 구조 디렉토리와 하위 디렉토리를 사용합니다. AutoLISP 응용프로그램 및 사용자화 파일 등의 보조 파일은 AutoCAD 프로그램 및 지원 파일과 별도로 보관하는 것이 좋습니다. 이렇게 하면 충돌이 일어나는지 쉽게 파악할 수 있고, 나머지 응용프로그램에 영향을 주지 않으면서 각 응용프로그램을 쉽게 업그레이드할 수 있습니다.

AutoCAD의 기본 위치는 Program Files 폴더에 있습니다. 같은 수준의 새 디렉토리(예: /AcadApps)를 작성하고 사용자 AutoLISP 및 VBA 매크로, 사용자화 파일 및 기타 외부 응용프로그램을 다음 수준의 하위 디렉토리에 저장할 수 있습니다. 여러 개의 도면 디렉토리(별도의 작업 파일용)를 관리하려면 각 작업의 하위 디렉토리와 함께 하나의 디렉토리(예: /AcadJobs)를 작성하면 됩니다.

명령 검색 절차

명령을 입력할 때 AutoCAD는 일련의 단계를 거쳐 명령 이름의 유효성을 확인합니다. 명령은 내장된 명령이나 시스템 변수, acad.pgp 파일에 정의된 외부 명령이나 별칭 또는 사용자 정의 AutoLISP 명령이 될 수 있습니다. ObjectARX 응용프로그램이나 장치 드라이버 명령으로 명령을 정의할 수 있습니다. 명령 프롬프트에서 명령을 입력하거나 해당 메뉴에서 명령을 선택할 수 있습니다. 스크립트 파일에서 또는 AutoLISP나 ObjectARX 응용프로그램에서도 명령을 입력할 수 있습니다.

다음 리스트에서는 AutoCAD를 사용하여 명령 이름의 유효성을 확인하는 검색 순서에 대해 설명합니다.

  1. 입력이 null 응답(SPACEBAR 또는 ENTER)이면 AutoCAD는 마지막으로 실행한 명령의 이름을 사용합니다. HELP가 기본값입니다.
  2. AutoCAD는 내장된 명령의 리스트와 비교하여 명령 이름을 확인합니다. 명령이 리스트에 있지만 앞에 마침표(.)가 오지 않으면 AutoCAD는 명령을 정의되지 않은 명령 리스트와 대조하여 확인합니다. 명령이 정의되어 있지 않으면 검색이 계속됩니다. 명령이 정의되어 있으면 다른 이유로 명령 실행이 중단되지 않는 한 그 명령이 실행됩니다. 명령을 투명하게 실행하거나 투시도 모드에서 실행하는 것이 불가능할 수도 있습니다.
  3. AutoCAD는 장치 드라이버에서 정의한 명령 이름 및 디스플레이 드라이버에서 정의한 명령 이름과 차례로 비교하여 명령 이름을 확인합니다.
  4. AutoCAD는 프로그램 매개변수 파일 (acad.pgp)에 정의된 외부 명령과 비교하여 명령 이름을 확인합니다. 정의된 외부 명령과 명령 이름이 일치하면 명령이 실행되고 검색이 완료됩니다.
  5. AutoCAD는 AutoLISP나 ObjectARX 응용프로그램에서 정의한 명령 리스트와 비교하여 명령 이름을 확인합니다. 이 때 자동 로드 명령이 로드됩니다.
  6. AutoCAD는 시스템 변수 리스트와 비교하여 명령 이름을 확인합니다. 명령 이름이 리스트에 있는 경우 AutoCAD는 입력을 변수 이름으로 사용하여 SETVAR 명령을 실행합니다.
  7. 명령 이름이 프로그램 매개변수 파일에 정의된 명령 별칭에 해당하는 경우, AutoCAD는 확장 명령 이름을 사용하고 검색을 계속하여 내장된 명령 리스트와 비교하여 새로운 검색을 시작합니다.
  8. 앞 단계가 모두 실패하면 검색이 중단되고 부적절한 명령 이름에 대한 경고 메시지가 표시됩니다.
참고

    • AutoLISP 자동 로드의 개요

    • 사용자 안내서의 Specify Search Paths and File Locations를 참고하십시오.


파일 구성에 대한 개요 (요약 참조)

사용자화에 대한 개요
파일 구성에 대한 개요
다중 구성
AutoCAD 2008 사용자화 안내서 > 기본 사용자화 > 프로그램 및 지원 파일 구성 > 파일 구성에 대한 개요 >
파일 구성에 대한 개요
개념 요약 참조

명령

OPTIONS

프로그램 설정값을 사용자화합니다.

시스템 변수

LOCALROOTPREFIX

로컬 사용자화 가능 파일이 설치된 루트 폴더의 전체 경로를 저장합니다

ROAMABLEROOTPREFIX

로밍할 수 있는 사용자화 가능 파일이 설치된 루트 폴더의 전체 경로를 저장합니다

유틸리티

항목이 없습니다.

명령 수정자

항목이 없습니다.


다중 구성 (개념)

파일 구성에 대한 개요
프로그램 및 지원 파일 구성
다중 도면 폴더
AutoCAD 2008 사용자화 안내서 > 기본 사용자화 > 프로그램 및 지원 파일 구성 >
다중 구성
개념 요약 참조

여러 좌표 입력 장치를 사용하거나 여러 플로터를 사용하는 경우, 구성 파일을 여러 개 설정하여 장치 간에 쉽게 전환하도록 할 수 있습니다.

AutoCAD를 좌표 입력 장치와 플로터 드라이버에 맞게 구성하면 사용자가 제공한 정보가 구성 파일에 기록됩니다. acad2008.cfg 구성 파일의 기본 위치는 옵션 대화상자에 있는 파일 탭의 도움말 및 기타 파일 이름에 표시되지만 다른 경로 또는 파일 이름을 지정할 수 있습니다.

일반적으로 구성 파일은 하나만 필요하지만 여러 개의 구성이 필요한 경우도 있습니다. 예를 들어, 대부분의 작업에 마우스를 사용하지만 간혹 큰 디지타이징 타블렛이 필요한 경우, 장치를 변경할 때마다 재구성하는 대신 다중 구성을 처리하도록 시스템을 설정할 수 있습니다.

구성 파일에는 여러 AutoCAD 시스템 변수의 값과 옵션 대화상자에 정의된 구성 옵션이 저장됩니다. 이러한 시스템 변수와 작동 매개변수를 다르게 설정하려면 각 값을 서로 다른 구성 파일에 저장합니다. 시스템 변수와 시스템 변수가 저장되는 위치의 리스트는 명령 참조의 시스템 변수를 참고하십시오.

다중 구성을 이용하려면 AutoCAD가 서로 다른 구성 파일을 사용하도록 설정해야 합니다. 시작 시 대체 구성 파일을 지정하려면 /c 스위치를 사용합니다.

참고

    • 사용자 안내서의 시작하기 사용자화를 참고하십시오.


다중 구성 (요약 참조)

파일 구성에 대한 개요
다중 구성
다중 도면 폴더
AutoCAD 2008 사용자화 안내서 > 기본 사용자화 > 프로그램 및 지원 파일 구성 > 다중 구성 >
다중 구성
개념 요약 참조

명령

OPTIONS

프로그램 설정값을 사용자화합니다.

시스템 변수

항목이 없습니다.

유틸리티

항목이 없습니다.

명령 수정자

항목이 없습니다.


다중 도면 폴더 (개념)

다중 구성
프로그램 및 지원 파일 구성
[웹으로 출판] 템플릿 사용자화
AutoCAD 2008 사용자화 안내서 > 기본 사용자화 > 프로그램 및 지원 파일 구성 >
다중 도면 폴더
개념 요약 참조

도면 및 기타 관련 파일을 별도의 디렉토리에 보관하면 기본적인 파일 관리 작업을 쉽게 수행할 수 있습니다.

도면 파일 및 기타 관련 파일을 별도의 디렉토리에 보관하면 기본적인 파일 관리 작업을 쉽게 수행할 수 있습니다. 이 항목에서 설명하는 시나리오는 파일 구성에 대한 개요에서 설명한 예제 디렉토리 구조를 기반으로 하지만, 사용자가 원하는 대로 구조를 확장하거나 변경할 수 있습니다.

도면 하위 디렉토리가 포함되도록 /AcadJobs 디렉토리를 설정할 수 있습니다. 도면 하위 디렉토리에는 특정 도면 종류나 작업에 필요한 관련 지원 파일을 보관하는 다른 하위 디렉토리가 포함될 수 있습니다. /AcadJobs/Job1/Support 디렉토리에는 /AcadJobs/Job1의 도면 파일 고유의 AutoLISP 파일과 블록이 포함될 수 있습니다. 지원 경로에 경로 머리글 없이 support를 지정하면 지원 경로에 대한 현재 디렉토리 내에 support 디렉토리가 추가됩니다. 옵션 대화상자를 사용하여 디렉토리를 지정하는 경우에는 AutoCAD가 해당 디렉토리의 하드 코드화 경로를 작성한다는 점에 유의하십시오. 앞에서 설명한 상대 명명 규칙을 사용하려면 명령행에서 /s 스위치를 사용하여 지원 경로를 지정해야 합니다. 사용자 안내서의 Customize Startup을 참고하십시오.

AutoCAD를 시작할 때 원하는 도면 디렉토리를 현재 디렉토리로 작성하여 이 디렉토리의 모든 파일 및 하위 디렉토리에 쉽게 접근할 수 있도록 하려는 경우, 각 작업에 대해 올바른 작업 디렉토리를 지정하는 프로그램 아이콘 또는 시작 메뉴 항목을 작성할 수 있습니다. 이 기능은 AutoCAD 시스템 변수REMEMBERFOLDERS를 0(영)으로 설정한 경우에만 작동합니다.

아이콘이나 메뉴 대신 배치 프로그램을 사용할 수 있습니다. 배치 프로그램을 사용하여 자동으로 새 작업 디렉토리를 작성할 수 있습니다. 다음 배치 프로그램은 지정된 디렉토리가 있는지 확인하고, 해당 디렉토리가 현재 디렉토리가 되도록 설정한 다음 AutoCAD를 실행합니다.

@echo off
C:
if exist \AcadJobs\Jobs\%1 goto RUNACAD
echo.
echo *** Creating \AcadJobs\Jobs\%1
echo *** Press Ctrl+C to cancel.
echo.
pause
mkdir \AcadJobs\Jobs\%1
:RUNACAD
cd \AcadJobs\Jobs\%1
start C:\ AutoCAD\acad.exe

메모장과 같은 ASCII 문자 편집기를 사용하여 배치 프로그램을 acad.bat라는 파일에 저장합니다. 드라이브와 디렉토리 이름은 반드시 시스템에 있는 이름과 일치하도록 변경해야 합니다. 이 파일을 시스템 검색 경로(예: C:\winnt)에 있는 디렉토리에 배치합니다. 이 배치 프로그램은 시작 메뉴의 실행 명령을 사용하거나 탐색기에서 해당 파일을 두 번 눌러 실행할 수 있습니다. 파일을 acad.bat로 저장한 경우에는 다음 구문을 사용합니다.

acadjobname

여기에서 jobname은 현재 디렉토리로 만들 작업 디렉토리의 이름입니다.


다중 도면 폴더 (요약 참조)

다중 구성
다중 도면 폴더
[웹으로 출판] 템플릿 사용자화
AutoCAD 2008 사용자화 안내서 > 기본 사용자화 > 프로그램 및 지원 파일 구성 > 다중 도면 폴더 >
다중 도면 폴더
개념 요약 참조

명령

항목이 없습니다.

시스템 변수

CMDECHO

AutoLISP 명령이 작동하는 동안 프롬프트와 입력을 반향하는지 여부를 조정합니다

유틸리티

항목이 없습니다.

명령 수정자

항목이 없습니다.


[웹으로 출판] 템플릿 사용자화 (개념)

다중 도면 폴더
기본 사용자화
사용자 명령 정의
AutoCAD 2008 사용자화 안내서 > 기본 사용자화 >
[웹으로 출판] 템플릿 사용자화
개념 절차 요약 참조

제공된 [웹으로 출판] 템플릿(PWT) 파일 중 하나를 수정하여 [웹으로 출판] 마법사에서 사용할 사용자화된 템플릿을 작성할 수 있습니다. 임의의 HTML 편집기 또는 문자 편집기를 사용합니다.

사용자 템플릿을 작성하려면 다음 요소를 추가하거나 수정합니다.

  • 이미지
  • 문자
  • 하이퍼링크
  • 색상
  • 제목
  • 비디오, 애니메이션 등

[웹으로 출판] 템플릿에는 사용자화하는 데 다음의 4가지 유형이 있습니다.

  • 썸네일 배열. 썸네일 이미지 배열을 포함하는 웹 페이지를 작성합니다.
  • 요약 추가 배열.썸네일 이미지 배열과 각 이미지에 대한 요약 정보를 포함하는 웹 페이지를 작성합니다.
  • 도면 리스트. 도면 리스트와 이미지 프레임을 포함하는 웹 페이지를 작성합니다.
  • 요약 추가 나열. 도면 리스트, 이미지 프레임 및 선택된 이미지에 대한 요약 정보를 포함하는 웹 페이지를 작성합니다.
주[웹으로 출판] 템플릿을 사용자화하려면 HTML 구문에 대해 잘 알고 있어야 합니다.

템플릿의 모양과 분위기를 변경하거나 추가할 수는 있지만 그 안에 있는 이미지 배열은 변경할 수 없습니다. 예를 들어, 썸네일 배열 템플릿의 경우 이미지는 페이지에서 행 단위로 표시됩니다. 이미지 표시를 변경할 수는 없지만, 이미지 테이블 주위의 문자와 그래픽을 줄바꿈할 수는 있습니다.

경고기본 [웹으로 출판] 템플릿 파일을 덮어쓰지 않도록 변경하기 전에 파일을 백업하십시오.


[웹으로 출판] 템플릿 사용자화 (절차)

[웹으로 출판] 템플릿 사용자화
[웹으로 출판] 템플릿 사용자화
AutoCAD 2008 사용자화 안내서 > 기본 사용자화 > [웹으로 출판] 템플릿 사용자화 >
[웹으로 출판] 템플릿 사용자화
개념 절차 요약 참조

[웹으로 출판] 템플릿에 빠르게 접근하려면

[웹으로 출판] 템플릿을 사용자화하려면


[웹으로 출판] 템플릿 사용자화 (절차)

[웹으로 출판] 템플릿 사용자화
[웹으로 출판] 템플릿 사용자화
[웹으로 출판] 템플릿 사용자화
AutoCAD 2008 사용자화 안내서 > 기본 사용자화 > [웹으로 출판] 템플릿 사용자화 >
[웹으로 출판] 템플릿 사용자화
개념 절차 요약 참조

[웹으로 출판] 템플릿에 빠르게 접근하려면

  1. 도구 메뉴 [image] 옵션을 클릭합니다.명령 프롬프트에서 options를 입력합니다.
  2. 옵션 대화상자의 파일 탭에서 템플릿 설정 옆에 있는 더하기 기호(+)를 클릭합니다. 그런 다음 도면 템플릿 파일 위치 옆에 있는 더하기 기호를 클릭합니다.
  3. 커서를 표시된 경로 이름으로 이동하여 내부를 클릭하고 F2 키를 누른 다음 Ctrl 키를 누른 상태에서 C 키를 눌러 복사합니다.
  4. [확인] 또는 [취소]를 클릭하여 옵션 대화상자를 닫습니다.
  5. 파일 메뉴 [image] 열기를 클릭합니다.명령 프롬프트에서 open을 입력합니다.
  6. 파일 선택 대화상자에서 왼쪽에 있는 세로 패널의 빈 영역을 마우스 오른쪽 버튼으로 클릭하고 바로 가기 메뉴에서 [추가]를 클릭합니다.
  7. 항목 이름 상자에 이름(예: Templates)을 입력합니다.
  8. Ctrl 키를 누른 상태에서 V 키를 눌러 경로를 항목 경로 상자에 붙여넣고 확인을 클릭합니다

    이제 파일 선택 대화상자의 왼쪽 패널에 있는 버튼을 클릭하여 템플릿 폴더에 접근할 수 있습니다.


[웹으로 출판] 템플릿 사용자화 (절차)

[웹으로 출판] 템플릿 사용자화
[웹으로 출판] 템플릿 사용자화
사용자 명령 정의
AutoCAD 2008 사용자화 안내서 > 기본 사용자화 > [웹으로 출판] 템플릿 사용자화 >
[웹으로 출판] 템플릿 사용자화
개념 절차 요약 참조

[웹으로 출판] 템플릿을 사용자화하려면

  1. 웹으로 출판 템플릿 폴더를 찾아보고 파일 메뉴 [image] 열기를 클릭합니다.웹으로 출판 템플릿 폴더를 찾아보고 명령 프롬프트에서 open을 입력합니다.

    [웹으로 출판] 템플릿에 빠르게 접근하려면를 참고하십시오.

  2. PTWTemplates 폴더를 두 번 클릭하여 엽니다. 다음 폴더들이 표시됩니다. 각 폴더에는 다음과 같이 [웹으로 출판] 템플릿과 [웹으로 출판] 마법사를 실행할 때 보이는 미리보기 이미지(BMP)가 들어 있습니다.
    • Template1.썸네일 배열 템플릿과 미리보기 이미지가 들어 있습니다.
    • Template2.요약 추가 배열 템플릿, 미리보기 이미지 및 HTML 프레임이 들어 있습니다.
    • Template3. 도면 리스트 템플릿, 미리보기 이미지 및 HTML 프레임이 들어 있습니다.
    • Template4.요약 추가 나열 템플릿, 미리보기 이미지 및 HTML 프레임이 들어 있습니다.
  3. 사용할 폴더를 마우스 오른쪽 버튼으로 클릭하고 [복사]를 클릭합니다.
  4. Alt 키를 누른 상태에서 2 키를 누르고 PTWTemplates 폴더를 마우스 오른쪽 버튼으로 클릭한 다음 붙여넣기를 클릭합니다
  5. PTWTemplates 폴더를 다시 열고 새 폴더를 마우스 오른쪽 버튼으로 클릭한 다음 이름을 변경합니다.
  6. 새 폴더를 마우스 오른쪽 버튼으로 클릭하고 [열기]를 클릭하여 내용을 표시합니다.
  7. [웹으로 출판] 템플릿(PWT) 파일을 .htm 또는 .html 파일 확장자를 사용하여 이름을 변경합니다.
  8. HTML 편집기나 문자 편집기에서 템플릿 파일을 엽니다.

    템플릿 파일에는 새 웹 페이지를 작성하기 위해 어떤 코드 영역을 수정할 수 있는지 파악하도록 도와 주는 주석이 포함됩니다.

  9. 주석을 검토하고 사용자화할 템플릿 부분을 변경합니다.
  10. 템플릿을 확장자가 .pwt인 파일로 저장합니다. 파일이 3단계에서 작성한 템플릿 폴더에 저장되었는지 확인합니다.
    주각 템플릿 폴더에는 하나의 PWT 파일만 포함될 수 있습니다. 새 PWT 파일을 작성하는 경우, 같은 폴더에 있는 다른 PWT 파일은 반드시 삭제해야 합니다.

    [웹으로 출판] 마법사를 실행하면 새 템플릿이 템플릿 리스트에 나타납니다.


[웹으로 출판] 템플릿 사용자화 (요약 참조)

다중 도면 폴더
[웹으로 출판] 템플릿 사용자화
외부 명령 정의
AutoCAD 2008 사용자화 안내서 > 기본 사용자화 > [웹으로 출판] 템플릿 사용자화 >
[웹으로 출판] 템플릿 사용자화
개념 절차 요약 참조

명령

PUBLISHTOWEB

선택한 도면의 이미지가 포함된 HTML 페이지를 작성합니다.

시스템 변수

항목이 없습니다.

유틸리티

항목이 없습니다.

명령 수정자

항목이 없습니다.


사용자 명령 정의

[웹으로 출판] 템플릿 사용자화
기본 사용자화
외부 명령 정의
AutoCAD 2008 사용자화 안내서 > 기본 사용자화 >
사용자 명령 정의
개념 절차

AutoCAD에서 실행할 수 있는 외부 명령을 정의할 수 있습니다. 명령 정의가 저장된 ASCII 텍스트 파일인 acad.pgp 파일에서 AutoCAD 명령의 명령 별칭을 작성할 수도 있습니다.

이 단원의 항목

  • 외부 명령 정의

    외부 명령은 AutoCAD가 실행 중인 동안 다른 프로그램이나 유틸리티를 시작합니다.

  • 명령 별칭 작성

    명령 별칭은 전체 명령 이름을 입력하는 대신 명령 프롬프트에 입력하는 축약어입니다.


사용자 명령 정의 (절차)

[웹으로 출판] 템플릿 사용자화
사용자 명령 정의
외부 명령 정의
AutoCAD 2008 사용자화 안내서 > 기본 사용자화 > 사용자 명령 정의 >
사용자 명령 정의
개념 절차

프로그램 매개변수 파일(acad.pgp)을 열려면


외부 명령 정의 (개념)

사용자 명령 정의
사용자 명령 정의
명령 별칭 작성
AutoCAD 2008 사용자화 안내서 > 기본 사용자화 > 사용자 명령 정의 >
외부 명령 정의
개념 절차 요약 참조

외부 명령은 AutoCAD가 실행 중인 동안 다른 프로그램이나 유틸리티를 시작합니다.

AutoCAD를 실행하는 동안 다음과 같은 다른 프로그램이나 유틸리티를 동시에 호출할 수 있습니다.

  • start, type, dir 또는 copy와 같은 Windows 시스템 명령 및 유틸리티
  • 문자 편집기나 워드 프로세서와 같은 응용프로그램
  • 데이터베이스 관리자, 스프레드시트 및 통신 프로그램
  • 배치 파일이나 VBA 매크로와 같은 사용자 제공 프로그램

외부 명령을 입력하면 AutoCAD가 acad.pgp에서 명령을 검색합니다. acad.pgp의 첫 번째 섹션에는 외부 명령이 정의됩니다. 메모장과 같은 ASCII 문자 편집기에서 acad.pgp를 편집하여 명령 정의를 추가할 수 있습니다. PGP 파일을 열려면 도구 [image] 사용자화 [image] 프로그램 매개변수 편집(acad.pgp)을 클릭합니다.도구 메뉴 [image] 사용자화 [image] 프로그램 매개변수 편집(acad.pgp)을 클릭합니다.

주필요한 경우 acad.pgp를 편집하기 전에 나중에 복원할 수 있도록 백업 파일을 작성합니다.

외부 명령을 정의할 때 명령 프롬프트에서 사용할 명령 이름과 운영 체제로 전달할 실행 가능한 명령 문자열을 지정합니다. 외부 명령 섹션의 각 행에는 다음과 같은 5개의 쉼표 구분 필드가 있습니다.

command,[executable],flags[,[*]prompt[,return_code]]
command

명령 프롬프트에 입력되는 명령. 이름이 내부 AutoCAD 명령 이름인 경우에는 무시됩니다. 이름은 대소문자를 구분하지 않습니다.

executable

명령 이름을 입력할 때 운영 체제로 전송되는 상수 문자열. 이는 운영 체제 프롬프트에서 실행할 수 있는 명령일 수 있습니다. 문자열에 스위치나 매개변수가 포함될 수 있습니다. 이 문자열에서 대소문자를 구분할지 여부는 실행 중인 응용프로그램에 따라 다릅니다.

flags

필수 비트 코드 매개변수 다음 정수 값들의 조합을 추가하여 원하는 결과를 얻을 수 있습니다.

0 응용프로그램을 시작한 다음 종료될 때까지 기다립니다.

1 응용프로그램이 종료될 때까지 기다리지 않습니다.

2 응용프로그램을 최소화 모드에서 실행합니다.

4 응용프로그램을 “숨김” 상태에서 실행합니다.

8 인수 문자열을 따옴표 안에 배치합니다.

비트 값 2와 4는 동시에 적용할 수 없습니다. 둘 다 지정된 경우에는 2비트만 사용됩니다. 응용프로그램이 완료되어야 AutoCAD를 사용할 수 있으므로 값 1 없이 값 2나 4를 사용하면 안됩니다.

비트 값 8을 사용하면 공백이 포함된 파일 이름에 대해 del과 같은 명령이 제대로 실행됩니다. 이로 인해 파일 이름에 대한 공백 구분 리스트가 이 명령으로 전달되지 않게 됩니다. 다중 파일 지원을 사용하려는 경우에는 비트 값 8을 사용하지 마십시오.

prompt

선택적 필드. AutoCAD 명령행에 표시하거나 동적 입력 툴팁의 프롬프트를 지정합니다. 이 프롬프트에 대한 응답이 실행 가능한 필드의 문자열에 추가됩니다. 프롬프트 필드의 첫 번째 문자가 별표(*)이면 응답에 공백이 포함될 수 있으며, 응답을 종료하려면 ENTER 키를 눌러야 합니다. 그렇지 않으면 응답이 SPACEPAR 키 또는 ENTER 키로 종료됩니다. 프롬프트가 지정되지 않았으면 입력하라는 메시지가 표시되지 않지만, 반환 코드를 제공하거나 프롬프트에 후행 공백을 두려면 쉼표를 추가해야 합니다.

return_code

선택적 비트 코드 매개변수. 다음 정수 값들의 조합을 추가하여 원하는 결과를 얻을 수 있습니다. 예를 들어, 값 1과 2가 필요하면 3을 반환 코드로 사용합니다. 값은 다음과 같이 정의됩니다. 코드 0과 4는 Windows 환경에서 의미가 없으므로 포함되지 않았습니다.

1 DXB 파일을 로드합니다. AutoCAD는 명령이 종료된 후 $cmd.dxb라는 DXB 파일을 도면에 로드합니다. DXB 파일이 로드되면 $cmd.dxb 파일이 삭제됩니다. 이 동작의 결과는 DXBIN 명령과 같습니다.

2 DXB 파일에서 블록 정의를 구성합니다. AutoCAD는 $cmd.dxb라는 DXB 파일에서 블록 정의를 작성합니다. 프롬프트 필드에 대한 응답이 블록 이름으로 사용됩니다. 이 이름은 현재 도면에 있지 않은 유효한 블록 이름이어야 하므로, 이 모드에서는 앞에서 정의한 블록을 다시 정의할 수 없습니다. AutoCAD가 DXB 파일을 로드하면 $cmd.dxb 파일이 삭제됩니다. INSERT 명령의 기본 이름이 새로 정의된 블록에 설정됩니다.

파일에는 앞에 세미콜론(;)이 오는 주석 행이 포함될 수도 있습니다.

Windows 시스템 명령

start 및 cmd Windows 시스템 명령은 외부 명령을 정의할 때 매우 유용합니다. start 또는 cmd 명령을 사용하지 않는 실행 파일 문자열을 지정하는 경우 윈도우를 닫아야 AutoCAD를 사용할 수 있습니다.

start 명령은 별도의 윈도우를 시작하고 지정된 프로그램이나 명령을 실행합니다. start가 매개변수 없이 사용되면 새 명령 프롬프트 윈도우가 열립니다. start 명령에는 새 윈도우의 화면표시에 영향을 미치는 많은 명령행 스위치가 있습니다. Windows 응용프로그램을 실행하려면 스위치 없이 start를 사용합니다. start 명령은 응용프로그램과 연관된 문서를 시작하는 데도 매우 유용합니다. 예를 들어, start를 사용하여 워드 프로세서로 작성한 문서나 HTML 파일을 직접 열 수 있습니다.

cmd 명령은 AutoCAD의 쉘 역할을 하는 명령 프롬프트 윈도우를 엽니다. 이 윈도우는 컨트롤이 AutoCAD 명령 프롬프트로 복귀하기 전에 닫아야 합니다. 두 가지 명령행 스위치 /c와 /k가 외부 명령에 유용합니다. /c 스위치는 지정된 명령을 수행한 다음 중지됩니다(윈도우를 닫음). /k 스위치는 지정된 명령을 수행한 다음 계속합니다(윈도우를 열어 둠). /k 스위치를 사용할 때 exit 명령을 사용하여 명령 윈도우를 닫아야 합니다.

일반적으로 start는 AutoCAD와 별개의 프로세스인 새로운 윈도우나 응용프로그램을 시작하는 데 사용합니다. cmd는 별개의 윈도우를 작성하지 않는 배치 파일 또는 명령 스크립트를 실행하는 데 사용하거나, 컨트롤을 AutoCAD로 다시 전달하기 전에 닫아야 할 윈도우를 작성하는 데 사용합니다. 이러한 명령 및 스위치에 대한 자세한 정보는 Windows 시스템 명령 문서를 참고하십시오.

사용자 정의 명령

다음 예제에서는 RUN, LISTSET 및 DXB2BLK의 세 가지 새로운 명령을 정의합니다.

RUN, cmd /c,0,*Batch file to run: ,
LISTSET,cmd /k SET,0
DXB2BLK,cmd /c DXBCOPY,0,DXB file: ,2

RUN 명령은 배치 파일이나 명령 스크립트를 실행합니다. cmd 명령 뒤에 /c 스위치를 사용하면 명령 윈도우가 열리고 배치 파일이 실행된 다음 닫힙니다.

LISTSET 명령은 현재 DOS 환경 변수 설정을 표시합니다. 이 예제에서는 start를 사용하지 않고 cmd /k를 사용하므로 AutoCAD로 복귀하기 전에 명령 윈도우를 닫아야 합니다. 이 윈도우를 활성 상태로 두려면 start /reAltime을 사용합니다. 이러한 명령 및 스위치에 대한 자세한 정보는 Windows 시스템 명령 문서를 참고하십시오.

DXB2BLK 명령은 지정한 DXB 파일에서 블록 정의를 작성합니다. DXB 파일은 모든 객체를 행으로 변환합니다. 이 절차로 얻을 수 있는 한 가지 장점은 문자 객체를 행으로 분해하는 간단한 방법을 제공하는 것입니다.

DXB2BLK는 지정한 DXB 파일 이름을 dxbcopy 배치 파일로 전달하여 해당 파일 이름을 파일 이름 $cmd.dxb에 복사합니다. 그러면 AutoCAD가 지정된 DXB 파일에서 블록을 작성합니다. DXB 파일 프롬프트에 제공된 이름이 새 블록 이름으로 사용됩니다. dxbcopy.cmd 파일을 작성하려면 Windows 명령 프롬프트에서 다음을 입력합니다.

echo copy %1.dxb $cmd.dxb > dxbcopy.cmd

그러면 현재 디렉토리에 dxbcopy.cmd 파일이 작성됩니다. 이 파일을 DOS 경로에 있는 디렉토리로 이동하거나 acad.pgp 파일에서 파일 위치를 명확하게 지정합니다. 예를 들어, dxbcopy.cmd 파일이 D:\cad에 있으면 acad.pgp 파일의 외부 명령 섹션에 다음을 입력합니다.

DXB2BLK, cmd \c D:\CAD\DXBCOPY,0,DXB file: ,2

DXB 파일을 작성하려면 현재 프린터로 AutoCAD DXB 파일 형식을 선택한 다음, 파일에 플롯합니다. 프린터 구성에 대한 자세한 정보는 드라이버 및 주변기기 안내서의 Set Up Plotters and Printers을 참조하십시오.


프로그램 매개변수 파일(acad.pgp)을 열려면 (절차)

사용자 명령 정의
상위 단계로
간단한 사용자 선종류
AutoCAD 2008 사용자화 안내서 > 기본 사용자화 > 사용자 명령 정의 > 외부 명령 정의 >
프로그램 매개변수 파일(acad.pgp)을 열려면
개념 절차 요약 참조

프로그램 매개변수 파일(acad.pgp)을 열려면

  • 다음을 클릭합니다. 도구 [image] 사용자화 [image] 프로그램 매개변수 편집(acad.pgp)도구 메뉴 [image] 사용자화 [image] 프로그램 매개변수 편집(acad.pgp)을 클릭합니다.


외부 명령 정의 (요약 참조)

[웹으로 출판] 템플릿 사용자화
외부 명령 정의
명령 별칭 작성
AutoCAD 2008 사용자화 안내서 > 기본 사용자화 > 사용자 명령 정의 > 외부 명령 정의 >
외부 명령 정의
개념 절차 요약 참조

명령

REINIT

디지타이저, 디지타이저 입/출력 포트 및 프로그램 매개변수 파일을 다시 초기화합니다.

시스템 변수

항목이 없습니다.

유틸리티

항목이 없습니다.

명령 수정자

항목이 없습니다.


명령 별칭 작성 (개념)

외부 명령 정의
사용자 명령 정의
사용자 선종류
AutoCAD 2008 사용자화 안내서 > 기본 사용자화 > 사용자 명령 정의 >
명령 별칭 작성
개념 요약 참조

명령 별칭은 전체 명령 이름을 입력하는 대신 명령 프롬프트에 입력하는 축약어입니다.

예를 들어, circle을 입력하는 대신 c를 입력하여 CIRCLE 명령을 시작할 수 있습니다. 별칭은 SAVE에 해당하는 Ctrl+S와 같은 키 입력 조합인 키보드 바로 가기와는 다릅니다.

별칭은 AutoCAD 명령, 장치 드라이버 명령 또는 외부 명령에 대해 정의할 수 있습니다. acad.pgp 파일의 두 번째 섹션에서는 명령 별칭을 정의합니다. 메모장과 같은 ASCII 문자 편집기에서 acad.pgp를 편집하여 기존 별칭을 변경하거나 새 별칭을 추가할 수 있습니다. PGP 파일을 열려면 도구 [image] 사용자화 [image] 프로그램 매개변수 편집(acad.pgp)을 클릭합니다.도구 메뉴 [image] 사용자화 [image] 프로그램 매개변수 편집(acad.pgp)을 클릭합니다. 파일에는 앞에 세미콜론(;)이 오는 주석 행이 포함될 수도 있습니다.

주필요한 경우 acad.pgp를 편집하기 전에 나중에 복원할 수 있도록 백업을 작성합니다.

명령 별칭을 정의하려면 acad.pgp 파일의 명령 별칭 섹션에 다음 구문을 사용하여 행을 추가합니다.

abbreviation,*command

여기서 축약어(abbreviation)는 명령 프롬프트에서 입력하는 명령 별칭이고 명령(command)은 간략화할 명령입니다. 이 행을 명령 별칭 정의로 식별하려면 명령 이름 앞에 별표(*)를 입력해야 합니다.

명령을 투명 명령처럼 입력할 수 있으면 별칭도 투명 명령처럼 입력할 수 있습니다. 명령 별칭을 입력하면 명령 프롬프트에 전체 명령 이름이 표시되고 명령이 실행됩니다.

여기에 나열된 것 같이 대화상자 대신 명령 프롬프트를 표시하는 명령 버전에 액세스하는 특수 하이픈(-) 머리글이 포함된 명령 별칭을 작성할 수 있습니다.

BH, *-BHATCH
BD, *-BOUNDARY
주명령 스크립트에는 명령 별칭을 사용할 수 없습니다. 사용자화 파일에는 명령 별칭을 사용하지 않는 것이 좋습니다.

AutoCAD가 실행 중인 동안 acad.pgp를 편집하는 경우 reinit을 입력하여 수정된 파일을 사용합니다. AutoCAD를 다시 시작하여 파일을 자동으로 다시 로드할 수도 있습니다.


명령 별칭 작성 (요약 참조)

외부 명령 정의
명령 별칭 작성
선종류 정의에 대한 개요
AutoCAD 2008 사용자화 안내서 > 기본 사용자화 > 사용자 명령 정의 > 명령 별칭 작성 >
명령 별칭 작성
개념 요약 참조

명령

REINIT

디지타이저, 디지타이저 입/출력 포트 및 프로그램 매개변수 파일을 다시 초기화합니다.

시스템 변수

항목이 없습니다.

유틸리티

항목이 없습니다.

명령 수정자

항목이 없습니다.


사용자 선종류

명령 별칭 작성
선종류 정의에 대한 개요
AutoCAD 2008 사용자화 안내서 >
사용자 선종류

표준 선종류의 라이브러리는 acad.lin 및 acadiso.lin 파일에 제공됩니다. 선종류를 있는 그대로 사용할 수 있고, 수정하거나 사용자 선종류를 작성할 수도 있습니다.

이 단원의 항목

  • 선종류 정의에 대한 개요

    선종류는 파일 확장자가 .lin인 하나 이상의 선종류 정의 파일로 정의됩니다.

  • 간단한 사용자 선종류

    선종류 정의 파일의 두 행에 각 선종류가 정의되어 있습니다. 첫 번째 행에는 선종류 이름과 설명(선택 사항)이 들어 있습니다. 두 번째 행은 실제 선종류 패턴을 설명하는 코드입니다.

  • 사용자 선종류의 문자

    문자 글꼴의 문자가 선종류에 포함될 수 있습니다.

  • 사용자 선종류의 쉐이프

    복합 선종류에는 쉐이프 파일에 저장된 내포된 쉐이프를 포함할 수 있습니다. 복합 선종류로 유틸리티, 경계, 윤곽선 등을 나타낼 수 있습니다.


선종류 정의에 대한 개요 (개념)

사용자 선종류
사용자 선종류
간단한 사용자 선종류
AutoCAD 2008 사용자화 안내서 > 사용자 선종류 >
선종류 정의에 대한 개요
개념 요약 참조

선종류는 파일 확장자가 .lin인 하나 이상의 선종류 정의 파일로 정의됩니다.

선종류의 이름과 정의는 대시와 점의 특정 순서, 대시와 공백의 상대 길이, 포함된 문자나 쉐이프의 특성 등을 결정합니다. AutoCAD가 제공하는 표준 선종류를 사용하거나 사용자 고유의 선종류를 작성할 수 있습니다.

LIN 파일에는 여러 간단한 선종류 및 복잡한 선종류의 정의가 들어 있습니다. 기존 LIN 파일에 새 선종류를 추가하거나 고유의 LIN 파일을 작성할 수 있습니다. 선종류 정의를 작성하거나 수정하려면 문자 편집기나 워드 프로세서를 사용하여 LIN 파일을 편집하거나 명령 프롬프트에서 LINETYPE를 사용하십시오.

선종류를 작성할 때 선종류를 사용하려면 선종류를 로드해야 합니다.

AutoCAD에 포함된 LIN 파일은 acad.lin 및 acadiso.lin입니다. 이 텍스트 파일을 화면에서 보거나 인쇄해서 보면 선종류 구성 방법을 보다 잘 이해할 수 있습니다.


선종류 정의에 대한 개요 (요약 참조)

명령 별칭 작성
선종류 정의에 대한 개요
간단한 사용자 선종류
AutoCAD 2008 사용자화 안내서 > 사용자 선종류 > 선종류 정의에 대한 개요 >
선종류 정의에 대한 개요
개념 요약 참조

명령

LINETYPE

선종류를 로드하거나 설정하거나 수정합니다.

시스템 변수

MEASUREINIT

신축에서 시작하는 도면에 영국식 또는 미터법 기본 설정값을 사용할지 여부를 조정합니다

유틸리티

항목이 없습니다.

명령 수정자

항목이 없습니다.


간단한 사용자 선종류 (개념)

선종류 정의에 대한 개요
사용자 선종류
사용자 선종류의 문자
AutoCAD 2008 사용자화 안내서 > 사용자 선종류 >
간단한 사용자 선종류
개념 절차 요약 참조

선종류 정의 파일의 두 행에 각 선종류가 정의되어 있습니다. 첫 번째 행에는 선종류 이름과 설명(선택 사항)이 들어 있습니다. 두 번째 행은 실제 선종류 패턴을 설명하는 코드입니다.

두 번째 행은 A(정렬) 글자로 시작해야 하고 그 뒤에 펜 업 길이(공백), 펜 다운 길이(대시) 및 점을 정의하는 패턴 설명자 리스트가 와야 합니다. LIN 파일에서 세미콜론(;)으로 행을 시작하여 주석을 포함할 수 있습니다.

선종류 정의 형식

선종류 정의 형식은 다음과 같습니다.

*linetype_name,description
A,descriptor1,descriptor2, ...

예를 들어, DASHDOT라는 선종류는 다음과 같이 정의됩니다.

*DASHDOT,Dash dot __ . __ . __ . __ . __ . __ . __ . __
A,.5,-.25,0,-.25

이것은 길이가 0.5 도면 단위인 대시, 길이가 0.25 도면 단위인 공간, 점 및 길이가 0.25 도면 단위인 또 다른 공간으로 시작하는 반복 패턴을 나타냅니다. 이 패턴은 선의 길이에 대해 계속되어 길이가 0.5 도면 단위인 대시로 끝납니다. 선종류는 다음과 같이 표시됩니다.

__ . __ . __ . __ . __ . __ . __ . __

LIN 파일은 ASCII 형식으로 저장하고 .lin 파일 확장자를 사용해야 합니다. 선종류 정의에서 각 필드에 대한 추가 정보가 뒤에 나옵니다.

선종류 이름

선종류 이름 필드는 별표(*)로 시작하며, 선종류에 대해 고유하고 설명적인 이름을 제공해야 합니다.

설명

선종류에 대한 설명은 LIN 파일을 편집할 때 선종류를 시각화하는 데 도움이 됩니다. 설명은 선종류 관리자와 선종류 로드 또는 다시 로드 대화상자에도 표시됩니다.

설명은 선택 사항이며, 다음 내용을 포함할 수 있습니다.

  • ASCII 문자를 사용하는 선종류 패턴에 관한 간단한 표현
  • 선종류에 대한 확장된 설명
  • "이 선종류를 은선으로 사용하십시오"와 같은 주석

설명을 생략하는 경우에는 선종류 이름 뒤에 쉼표를 삽입하지 마십시오. 설명은 47자를 초과할 수 없습니다.

정렬 필드(A)

정렬 필드는 개별 선, 원 및 호의 끝에서 패턴 정렬 동작을 지정합니다. 현재 AutoCAD는 A-유형 정렬을 지원합니다. 이 정렬은 선 및 호의 끝점에서 대시로 시작하고 끝나도록 합니다.

예를 들어, 일반적으로 중심선으로 사용되는 대시와 점의 반복적 연결을 표시하는 CENTRAL이라는 선종류를 작성한다고 가정해 보십시오. AutoCAD는 대시와 선의 끝점이 일치하도록 각 선에서 대시와 점의 순서를 조정합니다. 패턴은 적어도 첫 번째 대시의 절반이 선으로 시작되고 끝나도록 선을 맞춥니다. 필요한 경우 첫 번째 대시와 마지막 대시의 길이가 늘어납니다. 선이 너무 짧아서 대시와 점 순서를 하나도 표시할 수 없는 경우 AutoCAD는 끝점 사이에 연속선을 그립니다. 호의 경우에도 대시가 끝점에 그려지도록 패턴을 조정합니다. 원에는 끝점이 없지만 AutoCAD는 적절하게 화면에 표시되도록 대시와 점 순서를 조정합니다.

정렬 필드에 a를 입력하여 A-유형 정렬을 지정해야 합니다.

패턴 설명

각 패턴 설명자 필드는 선종류를 이루는 세그먼트의 길이를 쉼표로 분리하여 지정합니다. 공백은 허용되지 않습니다.

  • 양수 십진수는 해당 길이의 펜 다운(대시) 세그먼트를 나타냅니다.
  • 음수 십진수는 해당 길이의 펜 업(공백) 세그먼트를 나타냅니다.
  • 대시 길이가 0이면 점이 그려집니다.

LIN 파일에서 80자 행에 맞기만 하면 선종류당 최대 12대시 길이 지정을 입력할 수 있습니다. 패턴 설명자에서 정의한 선종류 패턴의 하나의 패턴 반복만을 포함해야 합니다. 선종류를 그리면 AutoCAD는 대시 시작 및 끝에 첫 번째 패턴 설명자를 사용합니다. 시작 대시와 끝 대시 사이에는 두 번째 대시 지정으로 시작되고 필요한 경우 패턴을 첫 번째 대시 지정으로 다시 시작하는 패턴 대시 지정이 연속해서 그려집니다.

A 유형의 정렬에서는 첫 번째 대시의 길이가 0 이상(펜 다운 세그먼트)이어야 합니다. 펜 업 세그먼트가 필요한 경우 두 번째 대시 길이는 0 미만이어야 하고 연속 선종류를 작성하는 경우 0보다 커야 합니다. A 유형 정렬에는 적어도 2개의 대시 지정이 있어야 합니다.


간단한 사용자 선종류 (절차)

외부 명령 정의
간단한 사용자 선종류
사용자 선종류의 문자
AutoCAD 2008 사용자화 안내서 > 사용자 선종류 > 간단한 사용자 선종류 >
간단한 사용자 선종류
개념 절차 요약 참조

간단한 선종류를 작성하려면

  1. 명령 프롬프트에 -linetype을 입력합니다.
  2. c(작성)를 입력합니다.
  3. 선종류의 이름을 입력하고 ENTER 키를 누릅니다.

    선종류 이름은 255자까지 가능합니다. 선종류 이름에는 글자, 숫자 그리고 특수 문자인 달러 기호($), 하이픈(-) 및 밑줄(_) 등이 포함될 수 있습니다. 선종류 이름에는 공백을 사용할 수 없습니다.

  4. 선종류 파일 작성 또는 추가 대화상자의 파일 이름 상자에서 LIN 선종류 라이브러리 파일을 선택한 다음 [저장]을 선택합니다.

    기존 파일을 선택하면 새 선종류 이름은 파일의 선종류 이름에 추가됩니다.

  5. 새 선종류를 설명하는 문자를 입력합니다(선택 사항).
  6. 패턴 입력 프롬프트에서 선의 패턴을 지정합니다. 다음 지침을 따르십시오.
    • 모든 선종류는 대시로 시작되어야 합니다.
    • 점에는 0을 입력합니다.
    • 공백에는 음의 실수를 입력합니다. 이 값은 공백 길이를 도면 단위로 정의합니다.
    • 대시에는 양의 실수를 입력합니다. 이 값은 대시 길이를 도면 단위로 정의합니다.
    • 쉼표로 그 다음의 각 점, 대시 또는 공간 값과 분리합니다.
    • 점과 대시 사이에 공백을 사용합니다.
  7. ENTER 키를 눌러 명령을 종료합니다.
주선종류는 작성 시 도면에 자동으로 로드되지 않습니다. LINETYPE의 로드 옵션을 사용합니다.


간단한 사용자 선종류 (요약 참조)

선종류 정의에 대한 개요
간단한 사용자 선종류
사용자 선종류의 문자
AutoCAD 2008 사용자화 안내서 > 사용자 선종류 > 간단한 사용자 선종류 >
간단한 사용자 선종류
개념 절차 요약 참조

명령

LINETYPE

선종류를 로드하거나 설정하거나 수정합니다.

시스템 변수

MEASUREINIT

신축에서 시작하는 도면에 영국식 또는 미터법 기본 설정값을 사용할지 여부를 조정합니다

유틸리티

항목이 없습니다.

명령 수정자

항목이 없습니다.


사용자 선종류의 문자 (개념)

간단한 사용자 선종류
사용자 선종류
사용자 선종류의 쉐이프
AutoCAD 2008 사용자화 안내서 > 사용자 선종류 >
사용자 선종류의 문자
개념 절차 요약 참조

문자 글꼴의 문자가 선종류에 포함될 수 있습니다.

문자 글꼴의 문자가 선종류에 포함될 수 있습니다. 내포된 문자가 있는 선종류는 유틸리티, 경계, 윤곽선 등을 나타낼 수 있습니다. 단순 선종류의 경우와 마찬가지로 사용자가 정점을 지정할 때 동적으로 선이 그려집니다. 선에 내포된 문자는 잘리는 일이 없이 항상 전체가 표시됩니다.

내포된 문자는 도면의 문자 스타일과 연관되어 있습니다. 선종류와 연관된 문자 스타일은 선종류를 로드하기 전에 도면에 있어야 합니다.

포함된 문자가 있는 선종류의 형식은 쉼표로 구분되는 패턴 설명자 리스트를 가진 단순 선종류의 형식과 유사합니다.

문자 설명자 형식

선종류 설명에 문자를 추가하기 위한 형식은 다음과 같습니다.

["text",textstylename,scale,rotation,xoffset,yoffset]

이 형식은 단순 선종류에 설명자로 추가됩니다. 예를 들어, HOT_WATER_SUPPLY라는 선종류는 다음과 같이 정의됩니다.

*HOT_WATER_SUPPLY,---- HW ---- HW ---- HW ---- HW ---- HW ----
A,.5,-.2,["HW",STANDARD,S=.1,R=0.0,X=-0.1,Y=-.05],-.2

이 형식은 길이가 0.5 도면 단위인 대시로 시작하는 반복 패턴, 길이가 0.2 도면 단위인 공백, 일부 축척 및 배치 매개변수가 있는 HW 및 길이가 0.2 도면 단위인 다른 공백을 나타냅니다. 0.1 축척, 상대 회전 0도, X 간격띄우기 -0.1 및 Y 간격띄우기 -0.05인 STANDARD 문자 스타일에 지정된 문자 글꼴에서 문자가 제공됩니다. 이러한 패턴은 해당 선 길이에 계속 나타나고 길이가 0.5 도면 단위인 대시로 끝납니다. 선종류는 다음과 같이 표시됩니다.

전체 업스트로크 길이는 0.2 + 0.2 = 0.4이고 문자 원점은 첫 번째 업스트로크 끝에서 X 방향으로 -.01 단위로 간격띄우기됩니다. 이와 동일한 선종류는 다음과 같습니다.

*HOT_WATER_SUPPLY,---- HW ---- HW ---- HW ---- HW ---- HW ----
A,.5,-.1,["HW",STANDARD,S=.1,R=0.0,X=0.0,Y=-.05],-.3

전체 업스트로크는 아직도 0.1 + 0.3 = 0.4이지만 문자 원점은 X 방향으로 간격띄우기가 되지 않습니다.

문자 설명자의 각 필드에 대한 추가 정보가 뒤에 표시됩니다. 사용될 값은 1, -17 및 0.01과 같은 십진수로 표시됩니다.

문자

선종류에 사용되는 문자

문자 스타일 이름

사용할 문자 스타일 이름. 문자 스타일이 지정되지 않으면 AutoCAD는 현재 정의되어 있는 스타일을 사용합니다.

축척

S=값. 선종류 축척에 상대적인 문자 스타일에 사용할 축척 비율. 문자 스타일 높이에 축척 비율을 곱합니다. 높이가 0(영)이면 S=값의 값만 높이로 사용됩니다.

회전

R=값 또는 A=값. R= 선에 관해 상대 회전 또는 접선 회전을 지정합니다. A= 원점과 관련하여 문자의 절대 회전을 지정하며, 모든 문자는 선에 대한 상대적 위치에 관계없이 동일하게 회전합니다. 값은 도에는 d(도는 기본값), 반지름에는 r, 그래드에는 g와 같이 부착할 수 있습니다. 회전이 없으면 상대 회전 0이 사용됩니다.

회전의 중심은 기준선과 일반 캡 높이 사이에 있습니다.

xoffset

X=값. 선종류의 X축에서 선을 따라 문자 이동. xoffset이 생략되었거나 0인 경우에는 문자가 간격띄우기 없이 정교화됩니다. 이 필드를 사용하여 문자와 이전 펜 업 또는 펜 다운 스트로크 사이의 거리를 조정합니다. 이 값은 S=값으로 정의된 축척 비율로 축척되지 않고, 선종류로 축척됩니다.

yoffset

Y=값. 선종류의 Y축에서 선에 90도 각도로 문자 이동. yoffset이 생략되었거나 0인 경우에는 문자가 간격띄우기 없이 정교화됩니다. 이 필드를 사용하여 선에 대해 문자의 수직 정렬을 조정합니다. 이 값은 S=값으로 정의된 축척 비율로 축척되지 않고, 선종류로 축척됩니다.


사용자 선종류의 문자 (절차)

간단한 사용자 선종류
사용자 선종류의 문자
해치 패턴 정의에 대한 개요
AutoCAD 2008 사용자화 안내서 > 사용자 선종류 > 사용자 선종류의 문자 >
사용자 선종류의 문자
개념 절차 요약 참조

선종류에 문자를 포함하려면

  1. 단순 선종류를 간단한 선종류를 작성하려면에서 설명한 대로 작성합니다.
  2. 선종류 패턴에서 다음 형식을 사용하여 문자 설명자를 추가합니다.

    ["text",textstylename,scale,rotation,xoffset,yoffset]

  3. LINETYPE을 종료하려면 ENTER 키를 누릅니다.


사용자 선종류의 문자 (요약 참조)

간단한 사용자 선종류
사용자 선종류의 문자
사용자 선종류의 쉐이프
AutoCAD 2008 사용자화 안내서 > 사용자 선종류 > 사용자 선종류의 문자 >
사용자 선종류의 문자
개념 절차 요약 참조

명령

LINETYPE

선종류를 로드하거나 설정하거나 수정합니다.

시스템 변수

MEASUREINIT

신축에서 시작하는 도면에 영국식 또는 미터법 기본 설정값을 사용할지 여부를 조정합니다

유틸리티

항목이 없습니다.

명령 수정자

항목이 없습니다.


사용자 선종류의 쉐이프 (개념)

사용자 선종류의 문자
사용자 선종류
사용자 해치 패턴
AutoCAD 2008 사용자화 안내서 > 사용자 선종류 >
사용자 선종류의 쉐이프
개념 요약 참조

복합 선종류에는 쉐이프 파일에 저장된 내포된 쉐이프를 포함할 수 있습니다. 복합 선종류로 유틸리티, 경계, 윤곽선 등을 나타낼 수 있습니다.

단순 선종류의 경우와 마찬가지로 복합 선은 사용자가 정점을 지정할 때 동적으로 그려집니다. 선에 포함된 쉐이프와 문자 객체는 잘려지는 일 없이 항상 완전히 표시됩니다.

복합 선종류의 구문은 패턴 설명자의 쉼표 구분 리스트라는 점에서 단순 선종류의 구문과 유사합니다. 복합 선종류는 대시-점 설명자뿐 아니라 패턴 설명자로서 쉐이프와 문자 객체도 포함할 수 있습니다.

선종류 설명에서 쉐이프 객체 설명자의 구문은 다음과 같습니다.

[shapename,shxfilename] 또는 [shapename,shxfilename,transform]

여기서 transform은 선택 사항으로, 다음 중 하나일 수 있습니다(맨 앞에 쉼표가 옴).

R=##상대 회전

A=##절대 회전

S=##축척

X=##X 간격띄우기

Y=##Y간격띄우기

이 구문에서 ##는 부호 있는 십진수(예: 1, -17, 0.01 등)이며, 회전에는 각도 단위가 사용되고 나머지 옵션에는 선종류 축척 도면 단위가 사용됩니다. 앞에 transform 문자가 사용되는 경우 그 뒤에는 등호와 숫자가 와야 합니다.

다음 선종류 정의는 선 세그먼트, 공백 및 ep.shx 파일의 내포된 쉐이프 CON1의 반복적인 패턴으로 구성되는 CON1LINE라는 선종류를 정의합니다. (다음 예제가 제대로 작동하려면 지원 경로에 ep.shx 파일이 있어야 합니다.)

*CON1LINE, --- [CON1] --- [CON1] --- [CON1]
A,1.0,-0.25,[CON1,ep.shx],-1.0

대괄호 안의 코드를 제외한 모든 코드가 단순 선종류의 정의와 일치합니다.

앞에서 설명한 것처럼 쉐이프를 선종류의 일부로 정의하는 데에는 총 6개의 필드를 사용할 수 있습니다. 처음 2개 필드는 필수 필드이면서 위치에 따라 값이 달라지고, 그 다음 4개 필드는 선택적인 필드이면서 임의대로 순서를 정할 수 있습니다. 다음 두 예제는 쉐이프 정의 필드의 다양한 항목을 보여줍니다.

[CAP,ep.shx,S=2,R=10,X=0.5]

위의 코드는 ep.shx 쉐이프 파일에 정의된 CAP 쉐이프를 선종류 단위 축척의 2배, 시계 반대 방향으로 10도 접선 회전, 0.5 도면 단위의 X 간격띄우기로 그린 후 쉐이프를 정교하게 만들어 줍니다.

[DIP8,pc.shx,X=0.5,Y=1,R=0,S=1]

위의 코드는 쉐이프 도면이 생기기 전에 pd.shx 쉐이프 파일에 정의된 DIP8 쉐이프를 X 간격띄우기 0.5 도면 단위로 그리고, 선종류의 단위 축척과 동일한 축척 및 0회전으로 선종류 위에 1 도면 단위로 Y 간격띄우기를 그립니다.

다음 구문은 쉐이프를 복합 선종류의 일부로 정의합니다.

[shapename,shapefilename,scale,rotate,xoffset,yoffset]

구문에서 필드는 다음과 같이 정의됩니다.

쉐이프 이름(shapename)

그릴 쉐이프의 이름. 이 필드는 반드시 포함되어야 합니다. 이 필드가 없으면 선종류 정의에 실패합니다. shapename이 지정한 쉐이프 파일에 없으면 내포된 쉐이프가 없는 선종류 그리기를 계속합니다.

쉐이프 파일 이름(shapefilename)

컴파일된 쉐이프 정의 파일(SHX)의 이름. 이 필드가 없으면 선종류 정의에 실패합니다. shapefilename이 지정되어 있지 않은 경우(즉, 아무런 경로도 지정되지 않음)에는 파일에 대한 라이브러리 경로를 검색합니다. shapefilename이 정확하게 지정되었는데 해당 위치에 없는 경우에는 머리글을 제거하고 라이브러리 경로에서 파일을 검색합니다. 이 파일을 찾지 못하면 내포된 쉐이프 없이 선종류 그리기를 계속합니다.

축척(scale)

S=값 쉐이프의 축척은 쉐이프 내부에 정의된 축척을 증가시키는 축척 비율로 사용됩니다. 쉐이프 내부에 정의된 축척이 0이면 S=값만 축척으로 사용됩니다.

회전(rotate)

R=값 또는 A=값R=은 선의 정교화와 관련하여 상대 회전이나 접선 회전을 나타냅니다. A= 원점과 관련하여 쉐이프의 절대 회전을 나타내며, 모든 쉐이프는 선에 상대적인 위치와 관계없이 똑같이 회전합니다. 값은 도에는 d(생략된 경우 도가 기본값), 반지름에는 r, 그래드에는 g와 같이 부착할 수 있습니다. 회전이 없으면 상대 회전 0이 사용됩니다.

xoffset

X=값 선종류 정의 정점의 끝에서 계산된 선종류의 X축에서 쉐이프 이동. xoffset이 생략되었거나 0인 경우에는 간격띄우기 없이 쉐이프가 정교화됩니다. 쉐이프가 있는 연속선을 원하면 이 필드를 포함시킵니다. 이 값은 S=로 정의된 축척 비율에 의해 축척되지 않습니다.

yoffset

Y=값 선종류 정의 정점의 끝에서 계산된 선종류의 Y축에서 쉐이프 이동. yoffset이 생략되었거나 0인 경우에는 간격띄우기 없이 쉐이프가 정교화됩니다. 이 값은 S=로 정의된 축척 비율에 의해 축척되지 않습니다.

참고

    • 쉐이프 및 쉐이프 글꼴


사용자 선종류의 쉐이프 (요약 참조)

사용자 선종류의 문자
사용자 선종류의 쉐이프
해치 패턴 정의에 대한 개요
AutoCAD 2008 사용자화 안내서 > 사용자 선종류 > 사용자 선종류의 쉐이프 >
사용자 선종류의 쉐이프
개념 요약 참조

명령

LINETYPE

선종류를 로드하거나 설정하거나 수정합니다.

SHAPE

LOAD를 사용하여 로드된 쉐이프 파일의 쉐이프를 삽입합니다.

시스템 변수

MEASUREINIT

신축에서 시작하는 도면에 영국식 또는 미터법 기본 설정값을 사용할지 여부를 조정합니다

유틸리티

항목이 없습니다.

명령 수정자

항목이 없습니다.


사용자 해치 패턴

사용자 선종류의 쉐이프
해치 패턴 정의에 대한 개요
AutoCAD 2008 사용자화 안내서 >
사용자 해치 패턴

표준 해치 패턴의 라이브러리는 acad.pat 및 acadiso.pat 파일에서 제공됩니다. 해치 패턴을 있는 그대로 사용할 수 있고, 수정하거나 사용자 해치 패턴을 작성할 수도 있습니다.

이 단원의 항목

  • 해치 패턴 정의에 대한 개요

    미리 정의되어 제공된 해치 패턴을 사용하는 것 외에도 사용자 해치 패턴을 설계하고 작성할 수 있습니다.

  • 대시선 해치 패턴

    대시선 패턴을 정의하려면 대시 길이 항목을 선 정의 항목의 끝에 추가합니다.

  • 여러 줄 해치 패턴

    복잡한 해치 패턴에는 원점에서 간격띄우기를 통과하는 원점이 있을 수 있으며 선 집합에 여러 구성원이 있을 수 있습니다.


해치 패턴 정의에 대한 개요 (개념)

사용자 해치 패턴
사용자 해치 패턴
대시선 해치 패턴
AutoCAD 2008 사용자화 안내서 > 사용자 해치 패턴 >
해치 패턴 정의에 대한 개요
개념 절차 요약 참조

미리 정의되어 제공된 해치 패턴을 사용하는 것 외에도 사용자 해치 패턴을 설계하고 작성할 수 있습니다.

미리 정의되어 제공된 해치 패턴을 사용하는 것 외에도 사용자 해치 패턴을 설계하고 작성할 수 있습니다. 해치 패턴 정의를 개발하려면 지식과 연습, 그리고 인내심이 필요합니다. 해치를 사용자화하려면 해치 패턴과 익숙해야 하므로 새로운 사용자에게는 해치 사용자화를 권장하지 않습니다.

AutoCAD에서 제공하는 해치 패턴은 acad.pat 및 acadiso.pat 텍스트 파일에 저장되어 있습니다. 해치 패턴 정의를 파일에 추가하거나 자신의 고유 파일을 작성할 수 있습니다.

정의가 저장되어 있는 위치에 관계없이 사용자 해치 패턴의 형식은 동일합니다. 해치 패턴에는 이름이 있는 헤더 행이 있습니다. 머리글은 별표로 시작하고 31자를 초과하지 않으며 선택적으로 설명을 추가할 수 있습니다.

*pattern-name, description

또한 다음과 같은 형태의 행 설명자도 두 개 이상 포함됩니다.

angle, x-origin,y-origin, delta-x,delta-y,dash-1,dash-2, …

경계 해치 및 채우기 대화상자에 표시된 기본 해치 패턴 ANSI31의 모양은 다음과 같습니다.

또한 다음과 같이 정의됩니다.

*ANSI31, ANSI Iron, Brick, Stone masonry
45, 0,0, 0,.125

첫 번째 행의 패턴 이름, *ANSI31 뒤에는 ANSI Iron, Brick, Stone masonry 설명이 옵니다. 이 간단한 패턴은 45도 각도로 선이 그려지고, 해치 선 집합의 첫 번째 선이 도면 원점(0,0)을 통과하고, 집합의 해치 선 사이 간격이 0.125 도면 단위가 되도록 지정합니다.

해치 패턴 정의는 다음과 같은 규칙을 따릅니다.

  • 패턴 정의의 각 행에는 최대 80자가 포함될 수 있습니다. 글자, 숫자 및 특수 문자인 밑줄(_), 하이픈(-) 및 달러 기호($)를 포함할 수 있습니다. 그러나 패턴 정의는 특수 문자가 아닌 글자나 숫자로 시작해야 합니다.
  • AutoCAD는 세미콜론 오른쪽의 빈 줄과 문자를 모두 무시합니다.
  • 각 패턴 선은 선 집합의 첫 번째 구성원으로 간주되며 양쪽 방향으로 증분 간격띄우기를 적용하여 수없이 많은 평행선 집합을 생성합니다.
  • delta-x 값은 선 방향으로 집합 구성원 사이의 변위를 나타냅니다. 이 값은 대시선에만 사용됩니다.
  • delta-y 값은 집합 구성원들 사이의 간격 즉, 선에 대해 수직으로 측정한 값을 설정합니다.
  • 선은 길이가 무한한 것으로 간주됩니다. 대시 패턴은 선에 사용됩니다.

해치 프로세스에서는 패턴 정의의 각 선을 해당 평행선 집합으로 무한대로 확장합니다. 선택된 모든 객체에 이러한 선과의 교차점이 있는지 확인하며, 교차점은 해치 스타일에 따라 해치 선을 켜고 끕니다. 각 해치 선 집합은 올바르게 정렬되도록 절대 원점과 함께 처음 선에 평행으로 생성됩니다.

매우 조밀한 해치를 작성할 경우 AutoCAD는 해치를 거부하고 해치 축척이 너무 작거나 대시 길이가 너무 짧음을 나타내는 메시지를 표시할 수 있습니다. (setenv “MaxHatch” “n”)을 사용하는 MaxHatch 시스템 레지스트리 변수를 설정하여 해치선의 최대 개수를 변경할 수 있습니다. 여기서 n은 100과 10000000(천만) 사이의 숫자입니다.

주MaxHatch의 값을 변경하면 표시된 것과 같이 대문자로 MaxHatch를 입력해야 합니다.


해치 패턴 정의에 대한 개요 (절차)

사용자 선종류의 문자
해치 패턴 정의에 대한 개요
대시선 해치 패턴
AutoCAD 2008 사용자화 안내서 > 사용자 해치 패턴 > 해치 패턴 정의에 대한 개요 >
해치 패턴 정의에 대한 개요
개념 절차 요약 참조

단순 해치 패턴을 작성하려면

  1. acad.pat 또는 acadiso.pat 파일을 ASCII 형식으로 저장하는 문자 편집기(예: Microsoft® Windows® 메모장)에서 엽니다.
  2. 별표와 패턴 이름이 포함된 헤더 행을 작성합니다. 해치 패턴 이름의 길이는 31자로 제한됩니다.
  3. (선택 사항) 헤더 행에 설명을 포함시키려면 패턴 이름 뒤에 쉼표와 설명 문자를 넣으십시오.
  4. 다음을 포함하는 설명자 행을 작성합니다.
    • 선이 그려지는 각도
    • X,Y 원점
    • 0 값의 delta-x
    • 임의의 값의 delta-y


해치 패턴 정의에 대한 개요 (요약 참조)

사용자 선종류의 쉐이프
해치 패턴 정의에 대한 개요
대시선 해치 패턴
AutoCAD 2008 사용자화 안내서 > 사용자 해치 패턴 > 해치 패턴 정의에 대한 개요 >
해치 패턴 정의에 대한 개요
개념 절차 요약 참조

명령

ADCENTER

블록, 외부 참조 및 해치 패턴과 같은 컨텐츠를 관리하거나 삽입합니다.

BHATCH

닫힌 영역 또는 선택된 객체를 해치 패턴 또는 그라데이션 채우기로 채웁니다.

FILL

해치, 이차원 솔리드 및 굵은 폴리선과 같은 객체의 채우기를 조정합니다.

HATCH

해치 패턴, 솔리드 채우기, 또는 그라데이션 채우기로 닫힌 영역이나 선택된 객체를 채웁니다.

HATCHEDIT

기존 해치 또는 채우기를 수정합니다.

SOLID

솔리드로 채워진 삼각형과 사변형을 작성합니다.

시스템 변수

FILLMODE

해치와 채우기, 2차원 솔리드 및 굵은 폴리선을 채울지 여부를 지정합니다

HPANG

해치 패턴 각도를 지정합니다

HPBOUND

BHATCH 명령과 BOUNDARY 명령으로 작성되는 객체 유형을 조정합니다

HPDOUBLE

사용자 정의 패턴에 해치 패턴 이중화를 지정합니다

HPNAME

기본 해치 패턴 이름을 공백 없이 최대 34자까지 설정합니다

HPSCALE

해치 패턴 축척 비율을 지정합니다. 이 값은 0보다 커야 합니다.

HPSPACE

사용자 정의 단순 패턴의 해치 패턴 선 간격을 지정합니다. 이 값은 0보다 커야 합니다.

유틸리티

항목이 없습니다.

명령 수정자

항목이 없습니다.


대시선 해치 패턴 (개념)

해치 패턴 정의에 대한 개요
사용자 해치 패턴
여러 줄 해치 패턴
AutoCAD 2008 사용자화 안내서 > 사용자 해치 패턴 >
대시선 해치 패턴
개념 절차 요약 참조

대시선 패턴을 정의하려면 대시 길이 항목을 선 정의 항목의 끝에 추가합니다.

대시선 패턴을 정의하려면 대시 길이 항목을 선 정의 항목의 끝에 추가합니다. 각 대시 길이 항목은 선을 구성하는 세그먼트의 길이를 지정합니다. 길이가 양수이면 펜 다운 세그먼트가 그려집니다. 길이가 음수이면 세그먼트가 펜 업되어 그려지지 않습니다. 패턴은 첫 번째 세그먼트가 있는 원점에서 시작되고 세그먼트 사이를 순환합니다. 대시 길이가 0이면 점이 그려집니다. 패턴 선마다 대시 길이를 6개까지 지정할 수 있습니다.

경계 해치 및 채우기 대화상자에 표시된 해치 패턴 ANSI33의 모양은 다음과 같습니다.

또한 다음과 같이 정의됩니다.

*ANSI33, ANSI Bronze, Brass, Copper
45, .176776695,0, 0,.25, .125,-.0625

예를 들어, 패턴을 45도로 수정하여 대시 길이가 0.5 단위이고 대시 사이의 간격이 0.5 단위인 대시선을 그리려면 선을 다음과 같이 정의하십시오.

*DASH45, Dashed lines at 45 degrees
45, 0,0, 0,.5, .5,-.5

이는 해치 패턴 정의에 대한 개요에 표시된 45도 패턴과 같지만 끝 부분에 대시 지정이 추가됩니다. 목표한 대로 펜 다운 길이는 0.5 단위이고 펜 업 길이는 0.5입니다. 그 다음 대시 앞에 0.5 단위 대시, 0.25 단위 공백, 점, 0.25 단위 공백을 그리려면 다음과 같이 정의합니다.

*DDOT45,Dash-dot-dash pattern: 45 degrees
45, 0,0, 0,.5, .5,-.25, 0,-.25

다음 예제는 delta-x를 지정했을 때 대시선 집합에 미치는 효과를 보여 줍니다. 먼저 다음 정의를 고려해 보십시오.

*GOSTAK
0, 0,0, 0,.5, .5,-.5

각 선을 대시와 공간으로 똑같이 끊은, 0.5 단위씩 분리된 선 집합이 그려집니다. delta-x가 0이기 때문에 각 집합 구성원의 대시가 정렬됩니다. 이 패턴으로 해치된 영역의 모양은 다음과 같습니다.

이제 패턴을 다음과 같이 변경합니다.

*SKEWED
0, 0,0, .5,.5, .5,-.5

이것은 delta-x를 0.5로 설정한 것을 제외하면 동일한데, 선의 방향(이 경우, X축에 평행임)으로 0.5씩 각 연속 집합 구성원의 간격을 띄웁니다. 선 길이는 무한하기 때문에 대시 패턴은 지정된 크기까지 줄어듭니다. 해치된 영역의 모양은 다음과 같습니다.


대시선 해치 패턴 (절차)

해치 패턴 정의에 대한 개요
대시선 해치 패턴
여러 줄 해치 패턴
AutoCAD 2008 사용자화 안내서 > 사용자 해치 패턴 > 대시선 해치 패턴 >
대시선 해치 패턴
개념 절차 요약 참조

대시선 해치 패턴을 작성하려면

  1. acad.pat 또는 acadiso.pat 파일을 ASCII 형식으로 저장하는 문자 편집기(예: 메모장)에서 엽니다.
  2. 별표와 패턴 이름이 포함된 헤더 행을 작성합니다. 해치 패턴 이름의 길이는 31자로 제한됩니다.
  3. (선택 사항) 헤더 행에 설명을 포함시키려면 패턴 이름 뒤에 쉼표와 설명 문자를 넣으십시오.
  4. 다음을 포함하는 설명자 행을 작성합니다.
    • 선이 그려지는 각도
    • X,Y 원점
    • 선 집합에서 대체 선의 간격을 띄우려는 경우 임의의 값의 delta-x
    • 임의의 값의 delta-y
    • 대시 길이 값
    • 점 길이 값
    • 다른 대시 길이에 대한 선택적인 두 번째 값
    • 다른 점 길이에 대한 선택적인 두 번째 값


대시선 해치 패턴 (요약 참조)

해치 패턴 정의에 대한 개요
대시선 해치 패턴
여러 줄 해치 패턴
AutoCAD 2008 사용자화 안내서 > 사용자 해치 패턴 > 대시선 해치 패턴 >
대시선 해치 패턴
개념 절차 요약 참조

명령

ADCENTER

블록, 외부 참조 및 해치 패턴과 같은 컨텐츠를 관리하거나 삽입합니다.

BHATCH

닫힌 영역 또는 선택된 객체를 해치 패턴 또는 그라데이션 채우기로 채웁니다.

FILL

해치, 이차원 솔리드 및 굵은 폴리선과 같은 객체의 채우기를 조정합니다.

HATCH

해치 패턴, 솔리드 채우기, 또는 그라데이션 채우기로 닫힌 영역이나 선택된 객체를 채웁니다.

HATCHEDIT

기존 해치 또는 채우기를 수정합니다.

SOLID

솔리드로 채워진 삼각형과 사변형을 작성합니다.

시스템 변수

FILLMODE

해치와 채우기, 2차원 솔리드 및 굵은 폴리선을 채울지 여부를 지정합니다

HPANG

해치 패턴 각도를 지정합니다

HPBOUND

BHATCH 명령과 BOUNDARY 명령으로 작성되는 객체 유형을 조정합니다

HPDOUBLE

사용자 정의 패턴에 해치 패턴 이중화를 지정합니다

HPNAME

기본 해치 패턴 이름을 공백 없이 최대 34자까지 설정합니다

HPSCALE

해치 패턴 축척 비율을 지정합니다. 이 값은 0보다 커야 합니다.

HPSPACE

사용자 정의 단순 패턴의 해치 패턴 선 간격을 지정합니다. 이 값은 0보다 커야 합니다.

유틸리티

항목이 없습니다.

명령 수정자

항목이 없습니다.


여러 줄 해치 패턴 (개념)

대시선 해치 패턴
사용자 해치 패턴
사용자 인터페이스 사용자화
AutoCAD 2008 사용자화 안내서 > 사용자 해치 패턴 >
여러 줄 해치 패턴
개념 절차 요약 참조

복잡한 해치 패턴에는 원점에서 간격띄우기를 통과하는 원점이 있을 수 있으며 선 집합에 여러 구성원이 있을 수 있습니다.

모든 해치 패턴이 0,0 원점을 사용하는 것은 아닙니다. 복잡한 해치 패턴에는 원점에서 간격띄우기를 통과하는 원점이 있을 수 있으며 선 집합에 여러 구성원이 있을 수 있습니다. 더 복잡한 패턴을 구성할 때는 각 선 집합의 시작점, 간격띄우기 및 대시 패턴을 신중히 지정하여 정확한 해치 패턴을 구성해야 합니다.

경계 해치 및 채우기 대화상자에 표시된 해치 패턴 AR-B816의 모양은 다음과 같습니다.

또한 패턴을 설명하는 여러 행을 포함하여 다음과 같이 정의됩니다.

*AR-B816, 8x16 Block elevation stretcher bond
0, 0,0, 0,8
90, 0,0, 8,8, 8,-8

다음 그림은 뒤집힌 모양의 직각 U 패턴(위쪽 방향 선, 가로 방향 선, 아래쪽 방향 선)을 나타냅니다. 한 단위마다 패턴이 반복되며 각 단위는 0.5 높이/폭입니다.

이 패턴은 다음과 같이 정의됩니다.

*IUS,Inverted U's
90, 0,0, 0,1, .5,-.5
0, 0,.5, 0,1, .5,-.5
270, .5,.5, 0,1, .5,-.5

첫 번째 선(위쪽을 향한 막대)은 원점이 0.0인 간단한 대시선입니다. 두 번째 선(맨 위에 있는 막대)은 위쪽을 향하는 막대의 끝에서 시작해야 원점이 0,.5입니다. 세 번째 선(아래로 그어진 선)은 패턴의 첫 번째 복제에 대해 .5,.5인 맨 위에 있는 막대의 끝점에서 시작해야 이 점이 원점이 됩니다. 패턴의 세 번째 선은 다음과 같습니다.

90, .5,0, 0,1, .5,-.5

또는

270, .5,1, 0,1, -.5,.5

대시 패턴은 원점에서 시작되고, 각도 지정으로 주어지는 벡터 방향으로 계속됩니다. 따라서 180도의 반대 방향에 놓인 두 개의 대시선 집합은 같지 않습니다. 두 솔리드 선 집합은 같습니다.

다음 패턴은 6점 별을 작성합니다.

이 예제는 패턴 정의 기술을 익히는 데 도움이 됩니다. (힌트: 0.866은 60도의 사인 값입니다.)

다음은 이러한 패턴의 AutoCAD 정의입니다.

*STARS,Star of David
0, 0,0, 0,.866, .5,-.5
60, 0,0, 0,.866, .5,-.5
120, .25,.433, 0,.866, .5,-.5


여러 줄 해치 패턴 (절차)

대시선 해치 패턴
여러 줄 해치 패턴
사용자화 파일 작업
AutoCAD 2008 사용자화 안내서 > 사용자 해치 패턴 > 여러 줄 해치 패턴 >
여러 줄 해치 패턴
개념 절차 요약 참조

여러 줄 해치 패턴을 작성하려면

  1. acad.pat 또는 acadiso.pat 파일을 ASCII 형식으로 저장하는 문자 편집기(예: 메모장)에서 엽니다.
  2. 별표와 패턴 이름이 포함된 헤더 행을 작성합니다. 해치 패턴 이름의 길이는 31자로 제한됩니다.
  3. (선택 사항) 헤더 행에 설명을 포함시키려면 패턴 이름 뒤에 쉼표와 설명 문자를 넣으십시오.
  4. 다음을 포함하는 설명자 행을 작성합니다.
    • 선이 그려지는 각도
    • X,Y 원점
    • 선 집합에서 대체 선의 간격을 띄우려는 경우 임의의 값의 delta-x
    • 임의의 값의 delta-y
    • 대시 길이 값
    • 점 길이 값
    • 다른 대시 길이에 대한 선택적인 두 번째 값
    • 다른 점 길이에 대한 선택적인 두 번째 값
  5. 이전 단계에서 모든 매개변수를 포함하여 두 번째 선을 작성합니다.
  6. (선택 사항) 추가로 선을 작성하여 여러 줄 해치 패턴을 완성합니다.


여러 줄 해치 패턴 (요약 참조)

대시선 해치 패턴
여러 줄 해치 패턴
중요한 사용자화 용어
AutoCAD 2008 사용자화 안내서 > 사용자 해치 패턴 > 여러 줄 해치 패턴 >
여러 줄 해치 패턴
개념 절차 요약 참조

명령

ADCENTER

블록, 외부 참조 및 해치 패턴과 같은 컨텐츠를 관리하거나 삽입합니다.

BHATCH

닫힌 영역 또는 선택된 객체를 해치 패턴 또는 그라데이션 채우기로 채웁니다.

FILL

해치, 이차원 솔리드 및 굵은 폴리선과 같은 객체의 채우기를 조정합니다.

HATCH

해치 패턴, 솔리드 채우기, 또는 그라데이션 채우기로 닫힌 영역이나 선택된 객체를 채웁니다.

HATCHEDIT

기존 해치 또는 채우기를 수정합니다.

SOLID

솔리드로 채워진 삼각형과 사변형을 작성합니다.

시스템 변수

FILLMODE

해치와 채우기, 2차원 솔리드 및 굵은 폴리선을 채울지 여부를 지정합니다

HPANG

해치 패턴 각도를 지정합니다

HPBOUND

BHATCH 명령과 BOUNDARY 명령으로 작성되는 객체 유형을 조정합니다

HPDOUBLE

사용자 정의 패턴에 해치 패턴 이중화를 지정합니다

HPNAME

기본 해치 패턴 이름을 공백 없이 최대 34자까지 설정합니다

HPSCALE

해치 패턴 축척 비율을 지정합니다. 이 값은 0보다 커야 합니다.

HPSPACE

사용자 정의 단순 패턴의 해치 패턴 선 간격을 지정합니다. 이 값은 0보다 커야 합니다.

유틸리티

항목이 없습니다.

명령 수정자

항목이 없습니다.


사용자 인터페이스 사용자화

여러 줄 해치 패턴
사용자 인터페이스 사용자화의 개요
AutoCAD 2008 사용자화 안내서 >
사용자 인터페이스 사용자화

프로그램 실행 시 다양한 메뉴, 도구막대, 바로 가기 키 및 다른 사용자 인터페이스 요소를 사용하여 작업을 효과적으로 수행할 수 있습니다. 또한 이러한 요소를 사용자화하여 사용자 환경을 간단화 할 수도 있습니다.

이 단원의 항목

  • 사용자 인터페이스 사용자화의 개요

    AutoCAD의 사용자화 도구를 사용하여 도면 환경을 사용자의 필요에 맞게 조정할 수 있습니다.

  • 사용자화 파일 작업

    사용자화(CUI) 파일은 명령, 사용자 인터페이스 요소 및 부분적 CUI 파일과 AutoLISP 파일에 대한 참조를 저장하는 데 사용됩니다. CUI 파일은 주, 부분적 또는 엔터프라이즈로 지정될 수 있습니다. CUI 파일을 지정하면 파일이 로드되는 순서가 결정됩니다. 사용자 인터페이스 요소는 여러 CUI 파일 간에 전송될 수 있으며, 이는 마이그레이션 과정을 더욱 용이하게 해줍니다.

  • 명령 사용자화

    명령을 쉽게 작성, 편집 및 재사용할 수 있습니다. 사용자 인터페이스 사용자화 편집기의 사용자화 탭에는 제품에 로드된 명령의 마스터 리스트가 표시됩니다. 이 리스트의 모든 명령어를 도구막대, 메뉴 및 다른 사용자 인터페이스 요소로 추가할 수 있습니다.

  • 매크로 작성

    매크로는 인터페이스 요소가 선택될 경우 발생하는 작업을 정의합니다. 매크로는 사용자가 수행해야 할 일련의 도면 작업을 단일 작업으로 수행합니다. 매크로는 명령, 특수 문자, DIESEL(Direct Interpretively Evaluated String Expression Language) 또는 AutoLISP 프로그래밍 코드를 포함할 수 있습니다.

  • 도구막대 사용자화

    도구막대를 사용자화하면 도면 영역에서 도구막대의 배치 또는 크기 조정이 쉬워지기 때문에 도면 효율성이나 공간을 최대로 얻을 수 있습니다. 또한 명령 및 컨트롤 요소를 추가하고 도구막대 버튼을 작성 및 편집함으로서 도구막대와 플라이아웃 도구막대를 작성 및 수정할 수도 있습니다.

  • 풀다운 메뉴 및 바로 가기 메뉴 작성

    풀다운 메뉴는 메뉴 막대 아래 리스트로 표시됩니다. 바로 가기 메뉴(상황에 맞는 메뉴라고도 함)는 도면 윈도우, 문자 윈도우, 명령 윈도우 또는 도구막대 영역에서 마우스 오른쪽 버튼으로 클릭할 때 십자선 또는 커서 위치나 그 근처에 표시됩니다.

  • 대시보드 패널 사용자화

    대시보드 패널 사용자화를 사용하면 대시보드 윈도우에 표시되는 버튼과 컨트롤을 추가하거나 제거하여 패널을 작성하고 수정할 수 있습니다. 도구막대 대신 패널을 사용하여 대시보드 윈도우에서 일반적으로 사용하고 액세스하는 명령을 구성할 수 있습니다. 명령을 구성하면 사용할 수 있는 도면 영역의 양이 최대화됩니다.

  • 바로 가기 키 및 임시 재지정 키 추가

    바로 가기 키(가속키라고도 함)를 자주 사용하는 명령에 지정할 수 있고, 임시 재지정 키를 지정하여 키를 눌렀을 때 명령을 실행하거나 설정을 변경할 수 있습니다.

  • 두 번 클릭 동작 작성

    두 번 클릭 동작은 도면에서 커서가 한 객체 위에 있고 두 번 클릭이 좌표 입력 장치에서 등록된 경우 편집 명령을 작성하는 데 사용됩니다. 두 번 클릭 동작은 객체 유형을 구분하므로 특정 객체 유형에 사용할 특정 명령을 설정할 수 있습니다

  • 마우스 버튼 사용자화

    이 프로그램에서 좌표 입력 장치의 표준 동작을 변경할 수 있습니다.

  • 기존 인터페이스 요소 사용자화

    “기존”이라는 용어는 보통 프로그램의 현재 버전에서는 사용되지 않지만 현재 제공되는 사용자 인터페이스 요소보다 더 선호하는 사용자를 위해 계속 지원되고 있는 사용자 인터페이스 요소를 의미합니다.

  • AutoLISP 파일 로드

    AutoLISP(LSP 또는 MNL) 파일에는 사용자화 작업 또는 동작을 인터페이스에 추가하는 스크립트가 포함됩니다. 사용자 인터페이스 사용자화 편집기의 사용자화 탭을 사용하여 AutoLISP 파일을 CUI 파일로 로드할 수 있습니다.

  • 작업공간 사용자화

    작업공간을 사용자화하여 선택하는 도구막대, 메뉴 및 팔레트만 표시하는 도면 환경을 작성할 수 있습니다.

  • 사용자 인터페이스 사용자화 FAQ

    FAQ는 사용자 인터페이스 사용자화(CUI) 편집기 사용에 관해 가장 자주 묻는 질문에 대한 답을 찾는데 도움이 됩니다.


사용자 인터페이스 사용자화의 개요

사용자 인터페이스 사용자화
사용자 인터페이스 사용자화
중요한 사용자화 용어
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 >
사용자 인터페이스 사용자화의 개요

AutoCAD의 사용자화 도구를 사용하여 도면 환경을 사용자의 필요에 맞게 조정할 수 있습니다.

CUI(사용자 인터페이스 사용자화) 파일 형식 및 사용자 인터페이스 사용자화 편집기가 포함된 사용자화 기능은 사용자화된 내용을 쉽게 작성 및 수정할 수 있도록 도와줍니다. XML 기반의 CUI 파일은 AutoCAD 2006 이전 릴리즈에서 사용된 메뉴 파일을 대치합니다. 메뉴 파일(MNU 및 MNS 파일)을 사용자화하기 위해 문자 편집기를 사용하는 대신 AutoCAD 내에서 사용자 인터페이스를 사용자화할 수 있습니다. 다음을 수행할 수 있습니다.

  • 도구막대 및 메뉴(바로 가기 메뉴, 이미지 배열 메뉴 및 타블렛 메뉴 포함) 추가 또는 변경
  • 작업공간 작성 또는 변경
  • 다양한 사용자 인터페이스 요소에 명령 지정
  • 매크로 작성 또는 변경
  • DIESEL 문자열 정의
  • 별칭 작성 또는 변경
  • 툴팁 추가
  • 상태 행에 설명 문자 제공

이 단원의 항목

  • 중요한 사용자화 용어

    AutoCAD 2008을 사용자화하는 데 필요한 여러 가지 용어를 알아야 합니다.

  • 사용자화가 변경된 방식

    기본 사용자화 기술은 이전 버전의 제품과 동일하지만 제품을 사용자화하기 위해 사용하는 환경은 AutoCAD 2006부터 변경되었습니다.

  • 사용자 인터페이스 사용자화 편집기의 개요

    사용자 인터페이스 사용자화(CUI) 편집기는 XML 기반 CUI 파일에 있는 사용자화 항목을 수정하는 데 사용됩니다.


중요한 사용자화 용어 (개념)

사용자 인터페이스 사용자화의 개요
사용자 인터페이스 사용자화의 개요
사용자화가 변경된 방식
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 사용자 인터페이스 사용자화의 개요 >
중요한 사용자화 용어
개념 요약 참조

AutoCAD 2008을 사용자화하는 데 필요한 여러 가지 용어를 알아야 합니다.

MNS(기존 메뉴 파일)

AutoCAD 2005 및 이전 버전에 대한 메뉴 사용자화 데이터를 저장하는 ASCII 형식 파일입니다. 대부분의 파일은 메모장과 같은 문자 편집기를 사용하여 AutoCAD 외부에서 편집해야 했지만 CUSTOMIZE 명령을 사용하여 AutoCAD에서 사용자화할 수 있는 기능도 일부 있었습니다. MNS 파일은 CUI 파일로 대치되었습니다. CUI 파일은 CUI 명령의 전송 탭을 사용하여 MNS 파일로부터 생성할 수 있습니다.

MNU(기존 메뉴 템플릿)

MENU 또는 MENULOAD 명령을 사용하여 AutoCAD로 MNU 파일을 로드할 때 MNS 파일의 내용을 정의하기 위한 템플릿으로 사용하는 ASCII 기반 파일입니다. MNU 파일은 AutoCAD 2005 및 이전 버전에서 사용되며 MNS 파일과 매우 유사합니다. MNU 파일은 CUI 파일로 대치되었습니다. CUI 파일은 CUI 명령의 전송 탭을 사용하여 MNU 파일로부터 생성할 수 있습니다.

사용자화(CUI) 파일

사용자화 데이터를 저장하는 XML 기반 파일입니다. 사용자 인터페이스 사용자화 편집기를 통해 사용자화 파일을 수정합니다. CUI 파일은 AutoCAD 2006 이전 릴리즈에서 메뉴를 정의하는 데 사용된 MNU, MNS 및 MNC 파일을 대치합니다.

주 사용자화 파일

대부분의 사용자 인터페이스 요소(표준 메뉴, 도구막대, 키보드 가속기 등)를 정의하는 기록 가능한 CUI 파일입니다. AutoCAD를 시작할 때 acad.cui 파일(기본 주 CUI 파일)이 자동으로 로드됩니다.

엔터프라이즈 사용자화 파일

일반적으로 CAD 관리자가 조정하는 CUI 파일입니다. 이 파일에는 많은 사용자가 자주 접근하며 파일 저장 위치는 공유 네트워크입니다. 읽기 전용의 파일이기 때문에 사용자가 파일의 데이터를 변경할 수 없습니다. CAD 관리자가 주 CUI 파일을 수정한 다음 공유 네트워크 위치에 저장하여 엔터프라이즈 CUI 파일을 작성하게 됩니다. 그런 다음 사용자가 파일 탭의 옵션 대화상자에서 이 파일을 수정합니다.

부분적 사용자화 파일

주 CUI 파일 또는 엔터프라이즈 CUI 파일로 정의되지 않은 모든 CUI 파일입니다. 도면 세션 중 필요에 따라 부분적 CUI 파일을 로드 및 언로드할 수 있습니다.

사용자화 그룹

CUI 파일의 사용자화 내용을 식별하기 위해 CUI 파일에 지정된 이름입니다. 프로그램에서 CUI 파일 사이의 충돌을 방지하기 위해 AutoCAD에 로드된 CUI 파일은 고유 사용자화 그룹 이름을 가져야 합니다. 이전 릴리즈에서는 메뉴 그룹이라 하였습니다.

인터페이스 요소

도구막대, 풀다운 메뉴, 바로 가기 키, 팔레트 등과 같은 사용자화할 수 있는 객체입니다. 사용자 인터페이스 항목을 포함하는 <파일 이름>의 사용자화 창의 노드입니다.

인터페이스 항목

도구막대 버튼, 풀다운 메뉴 항목, 바로 가기 키, 임시 재지정 키와 같은 사용자 인터페이스 요소의 개별 부분입니다.

트리 노드

사용자 인터페이스 사용자화 편집기의 계층 구조입니다. 이 구조에는 가져오기, 내보내기 및 사용자화가 가능한 인터페이스 요소 및 항목이 포함됩니다.

작업공간

사용자 인터페이스 요소의 내용, 표시 상태 및 위치를 포함하는 집합입니다.

팔레트

도면 영역에서 고정 가능하거나 부동 가능한 인터페이스 요소입니다. 팔레트에는 명령행 윈도우, 도구 팔레트 윈도우, 특성 팔레트 등이 들어 있습니다.

요소 ID

인터페이스 요소의 고유 식별자입니다. 이전 릴리즈에서는 태그라 하였습니다.


중요한 사용자화 용어 (요약 참조)

여러 줄 해치 패턴
중요한 사용자화 용어
사용자화가 변경된 방식
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 사용자 인터페이스 사용자화의 개요 > 중요한 사용자화 용어 >
중요한 사용자화 용어
개념 요약 참조

명령

CUI

작업공간, 도구막대, 메뉴, 바로 가기 메뉴 및 키보드 바로 가기와 같은 사용자화된 사용자 인터페이스 요소를 관리합니다.

CUIEXPORT

사용자화된 설정을 acad.cui에서 엔터프라이즈 또는 부분적 CUI 파일로 내보냅니다.

CUIIMPORT

사용자화된 설정을 엔터프라이즈 또는 부분적 CUI 파일에서 acad.cui로 가져옵니다.

CUILOAD

CUI 파일 로드

CUIUNLOAD

CUI 파일 언로드

CUSTOMIZE

사용자화 도구 팔레트

DASHBOARD

대시보드 윈도우를 엽니다.

TOOLPALETTES

도구 팔레트 윈도우를 엽니다.

QUICKCUI

사용자 인터페이스 사용자화 대화상자를 축소된 상태로 표시합니다.

시스템 변수

DBLCLKEDIT

도면 영역에서 두 번 클릭 편집 동작을 조정합니다.

ENTERPRISEMENU

파일 이름의 경로를 포함하여 엔터프라이즈 CUI(정의된 경우)에 대한 파일 이름을 표시합니다.

MENUNAME

파일 이름의 경로를 포함하여 사용자화 파일 이름을 저장합니다

TOOLTIPS

도구막대에 툴팁의 표시를 제어합니다.

유틸리티

항목이 없습니다.

명령 수정자

항목이 없습니다.


사용자화가 변경된 방식 (개념)

중요한 사용자화 용어
사용자 인터페이스 사용자화의 개요
사용자 인터페이스 사용자화 편집기의 개요
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 사용자 인터페이스 사용자화의 개요 >
사용자화가 변경된 방식
개념 요약 참조

기본 사용자화 기술은 이전 버전의 제품과 동일하지만 제품을 사용자화하기 위해 사용하는 환경은 AutoCAD 2006부터 변경되었습니다.

이전의 모든 사용자화 옵션을 계속 사용할 수 있습니다. 인터페이스 요소의 작성, 편집 및 삭제가 가능하며, 부분적 사용자화 파일을 작성할 수 있고, 매크로 및 고급 항목(예: DIESEL 표현식, AutoLISP 루틴)을 사용할 수 있습니다.

그러나 직접 MNU나 MNS 텍스트 파일을 작성 또는 편집하여 사용자화 작업을 수행하지는 않습니다. 모든 사용자화는 사용자 인터페이스 사용자화 편집기의 프로그램 인터페이스를 통해 수행됩니다.

메뉴 파일 대 사용자화 파일

AutoCAD 2006 이전 릴리즈에서는 메모장과 같은 ASCII 문자 편집기에서 MNU 또는 MNS 파일을 편집하여 사용자 인터페이스를 사용자화했습니다. 사용자화 데이터를 텍스트 파일에 수동으로 입력하고 점검하였으나 이 처리는 지루하고 오류가 발생하기 쉽습니다. 결과적으로 텍스트 파일의 간단한 구문 오류(괄호 불일치와 같은 경우)가 전체 메뉴 파일을 무효화할 수 있으며 텍스트 파일로 되돌아가 오류 발생 지점을 조사해야 할 수도 있습니다.

사용자 인터페이스 사용자화 편집기를 사용하여 명령을 메뉴 또는 도구막대로 끌어오거나 마우스 오른쪽 버튼으로 클릭하여 사용자 인터페이스 요소를 추가, 삭제 또는 수정할 수 있습니다. 사용자 인터페이스 사용자화 편집기에는 선택할 옵션 리스트 및 요소 특성이 표시됩니다. 항목을 선택하면 MNU 또는 MNS 파일에서 문자를 수동으로 입력할 때 발생할 수 있는 구문 오류나 철자 실수를 방지할 수 있습니다.

이전에 사용했던 MNU 및 MNS 파일은 하나의 파일 유형인 XML 기반 CUI 파일로 바뀌었습니다.

XML 기반 형식의 CUI 파일은 제품이 사용자화를 추적할 수 있도록 해줍니다. 프로그램을 향후 버전으로 업그레이드할 경우 모든 사용자화가 새 릴리즈로 자동 통합됩니다. XML 형식은 역 호환 사용자화 파일도 지원합니다. 이는 향후 버전의 사용자화 데이터를 보존하면서 이전 릴리즈의 향후 버전에서 CUI 파일을 볼 수 있다는 의미입니다. 그러나 이전 릴리즈에서 향후 버전의 CUI 파일을 수정할 수는 없습니다. 사용자화 데이터 마이그레이션에 관한 자세한 정보는 사용자화 마이그레이션 및 전송을 참고하십시오.

다음 테이블은 이전에 제품에 제공된 메뉴 파일을 나열하며 이들 파일이 AutoCAD 2008에 매핑되는 방식을 보여줍니다.

CUI 파일로 매핑된 메뉴 파일
메뉴 파일 | 설명 | AutoCAD 2008에서 | 변경 사항 설명
MNU | ASCII 텍스트 파일입니다. 이전 릴리즈에서는 대부분의 사용자 인터페이스 요소로 정의되었습니다. 주 MNU 파일인 acad.mnu는 제품을 시작하면 자동으로 로드되었습니다. 도면 세션 중 필요하면 부분적 MNU 파일을 로드 또는 언로드할 수 있습니다. | CUI | 대부분의 사용자 인터페이스 요소를 정의하는 XML 파일입니다. 주 CUI 파일인 acad.cui는 제품을 시작하면 자동으로 로드됩니다. 도면 세션 도중 필요에 따라 부분적 CUI 파일을 로드 또는 언로드할 수 있습니다.
MNS | 원본 메뉴 파일입니다. 이 파일은 MNU ASCII 텍스트 파일과 같지만 주석 또는 특수 형식을 포함하지 않습니다. | CUI | 대부분의 사용자 인터페이스 요소를 정의하는 XML 파일입니다. 주 CUI 파일인 acad.cui는 제품을 시작하면 자동으로 로드됩니다. 도면 세션 도중 필요에 따라 부분적 CUI 파일을 로드 또는 언로드할 수 있습니다.
MNC | 컴파일된 ASCII 텍스트 파일입니다. 사용자 인터페이스 요소의 기능 및 모양을 정의하는 명령 문자열 및 구문이 포함됩니다. | CUI | 대부분의 사용자 인터페이스 요소를 정의하는 XML 파일입니다. 주 CUI 파일인 acad.cui는 제품을 시작하면 자동으로 로드됩니다. 도면 세션 도중 필요에 따라 부분적 CUI 파일을 로드 또는 언로드할 수 있습니다.
MNL | 메뉴 LISP 파일입니다. 사용자 인터페이스 요소가 사용하는 AutoLISP 표현식을 포함합니다. | MNL | 변경 없음.
MNR | 메뉴 리소스 파일입니다. 사용자 인터페이스 요소가 사용하는 비트맵을 포함합니다. | MNR | 변경 없음.

메뉴 텍스트 파일 구조와 CUI 구조 비교

AutoCAD 2006 이전 릴리즈에서는 텍스트 파일에서 직접 메뉴 정보를 추가, 편집 및 삭제했습니다. AutoCAD 2006 및 이후 버전에서는 사용자 인터페이스 사용자화 편집기를 사용합니다.

다음은 윈도우 메뉴가 기존 메뉴 파일 acad.mnu에서 보여지는 방법에 대한 예제입니다.

acad.mnu의 윈도우 메뉴 내용
윈도우 메뉴 | 설명
 | ***POP10 **WINDOW ID_MnWindow [&Window] ID_DWG_CLOSE [Cl&ose]^C^C_close ID_WINDOW_CLOSEALL [C&lose All]^C^C_closeall [--] ID_WINDOW_CASCADE [&Cascade]^C^C_syswindows;_cascade ID_WINDOW_TILE_HORZ [Tile &Horizontally]^C^C_syswindows;_hor ID_WINDOW_TILE_VERT [&Tile Vertically]^C^C_syswindows;_vert ID_WINDOW_ARRANGE [&Arrange Icons]^C^C_syswindows;_arrange

트리 뷰의 위 메뉴 데이터를 사용자 인터페이스 사용자화 편집기에 표시된 것과 동일한 메뉴 데이터와 비교합니다.

좀 더 세부적인 비교를 위해 다음과 같이 윈도우 메뉴 특성, 닫기 명령 특성, 전체 명령 닫기 특성 및 구분 기호 삽입 옵션에 표시된 윈도우 바로 가기 메뉴에 관한 예제를 제공합니다.

윈도우 메뉴 특성 창

윈도우 메뉴, 닫기 명령에 대한 특성 창

윈도우 메뉴, 전체 닫기 명령에 대한 특성 창

윈도우 메뉴 트리 노드, 구분 기호 삽입 옵션으로 표시된 바로 가기 메뉴

메뉴 그룹 대 사용자화 그룹

메뉴 그룹(이전 릴리즈에서 사용한 용어)과 사용자화 그룹은 동일합니다. 프로그램에서 사용자화 파일 사이의 충돌을 막기 위해 AutoCAD에 로드된 CUI 파일은 고유 사용자화 그룹 이름을 가져야 합니다.

주 CUI 파일인 acad.cui에는 기본적으로 ACAD라는 이름의 사용자화 그룹이 있습니다. 각 사용자화 파일에 고유한 사용자화 그룹 이름이 있는 한, 여러 개의 사용자화 파일을 프로그램으로 로드할 수 있습니다.

다음은 사용자 인터페이스 사용자화 편집기의 사용자화 탭에서 ACAD 사용자화 그룹 이름을 변경하는 방법에 대한 예제입니다. 같은 방법을 사용하여 부분적 CUI 파일(이 예제에서 CUSTOM으로 명명된 파일)을 변경할 수 있습니다.

동적 도움말

동적 도움말은 온라인 도움말 시스템에 있는 기능이며 AutoCAD로 로드될 때 CUI 파일에 있는 사용자화 요소 중 일부를 참조합니다. 동적 도움말의 기능은 온라인 도움말 시스템에서 인식된 명령의 요소 ID와 CUI 파일이 로드될 때 풀다운 메뉴에서 현재 참조되고 있는 명령의 위치를 찾는 것입니다.

해당 명령이 풀다운 메뉴에 있는 경우 온라인 도움말 시스템의 메뉴 액세스는 해당 명령의 위치를 적용하기 위해 업데이트됩니다. AutoCAD와 함께 제공되는 표준 명령 중 하나가 다른 풀다운 메뉴로 이동될 경우 온라인 도움말 시스템은 다음에 표시될 때 이 변경사항을 자동으로 적용합니다. 현재 온라인 도움말 시스템에 있는 명령의 풀다운 메뉴 액세스만 동적 도움말에 의해 적용됩니다.

주동적 도움말은 AutoCAD와 함께 제공되는 온라인 도움말 문서에서만 사용되며 타사 문서에 적용되지 않습니다.
참고

    • 사용자화 마이그레이션 및 전송

    • 부분적 CUI 파일 작성 및 로드

    • 엔터프라이즈 CUI 파일 작성


사용자화가 변경된 방식 (요약 참조)

중요한 사용자화 용어
사용자화가 변경된 방식
사용자 인터페이스 사용자화 편집기의 개요
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 사용자 인터페이스 사용자화의 개요 > 사용자화가 변경된 방식 >
사용자화가 변경된 방식
개념 요약 참조

명령

CUI

작업공간, 도구막대, 메뉴, 바로 가기 메뉴 및 키보드 바로 가기와 같은 사용자화된 사용자 인터페이스 요소를 관리합니다.

CUIEXPORT

사용자화된 설정을 acad.cui에서 엔터프라이즈 또는 부분적 CUI 파일로 내보냅니다.

CUIIMPORT

사용자화된 설정을 엔터프라이즈 또는 부분적 CUI 파일에서 acad.cui로 가져옵니다.

CUILOAD

CUI 파일 로드

CUIUNLOAD

CUI 파일 언로드

QUICKCUI

사용자 인터페이스 사용자화 대화상자를 축소된 상태로 표시합니다.

시스템 변수

항목이 없습니다.

유틸리티

항목이 없습니다.

명령 수정자

항목이 없습니다.


사용자 인터페이스 사용자화 편집기의 개요 (개념)

사용자화가 변경된 방식
사용자 인터페이스 사용자화의 개요
사용자화 파일 작업
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 사용자 인터페이스 사용자화의 개요 >
사용자 인터페이스 사용자화 편집기의 개요
개념 요약 참조

사용자 인터페이스 사용자화(CUI) 편집기는 XML 기반 CUI 파일에 있는 사용자화 항목을 수정하는 데 사용됩니다.

사용자 인터페이스 사용자화(CUI) 편집기는 XML 기반 CUI 파일에 있는 사용자화 항목을 수정하는 데 사용됩니다. 편집기를 사용하면 중앙 집중화된 위치에서 CUI 파일에 사용되는 명령을 작성 및 관리할 수 있습니다. 명령과 함께 기타 많은 사용자 인터페이스 요소를 사용자화할 수 있습니다. CUI 편집기에서 다음을 사용자화할 수 있습니다

  • 도구막대
  • 풀다운 메뉴
  • 대시보드 패널
  • 바로 가기 메뉴
  • 바로 가기 키
  • 임시 재지정 키
  • 두 번 클릭 동작
  • 마우스 버튼
  • 작업공간
  • 기존 사용자 인터페이스 요소(타블렛, 타블렛 버튼, 화면 메뉴 및 이미지 배열 메뉴)

사용자화 환경

메뉴, 도구막대 및 다른 사용자 인터페이스 요소를 사용자화하기 전에 사용자화 환경에 익숙해져야 합니다. 사용자 인터페이스 사용자화 편집기를 열려면 도구 메뉴 [image] 사용자화 [image] 인터페이스를 클릭합니다.사용자 인터페이스 사용자화 편집기를 열려면 명령 프롬프트에서 cui를 입력합니다. 사용자 인터페이스 사용자화 편집기를 열면 트리 구조에서 해당 요소를 확장하여 로드된 사용자화 파일의 내용을 보고 해당 파일을 선택하여 요소의 특성을 봅니다.

전송 탭을 선택하여 사용자화 마이그레이션 또는 전송 방법을 확인하고, 사용자화 탭을 선택하여 사용자 인터페이스 요소를 작성하거나 수정하는 방법을 확인합니다.

환경에 익숙해지면 도구 기능을 훨씬 잘 사용할 수 있게 됩니다. 개선된 사용자화 기능에 대한 자세한 정보는 사용자화가 변경된 방식을 참고하십시오.

다음은 사용자 인터페이스 사용자화 편집기의 사용자화 탭에 대한 예제입니다. 이 탭을 사용하여 인터페이스 요소를 CUI 파일에서 사용자화합니다.

사용자 인터페이스를 사용자화하여 도면 환경을 특정 작업 유형에 맞도록 조정합니다. 예를 들어, 가장 많이 사용하는 명령을 포함하는 도구막대가 필요한 경우 사용자 인터페이스 사용자화 편집기에서 새 즐겨찾기 도구막대를 작성한 다음 AutoCAD에 새 도구막대를 로드할 수 있습니다.

사용자화 창

사용자화 창은 로드된 사용자화 파일에 있는 여러 가지 사용자 인터페이스 요소를 검색하는 데 사용됩니다. 이 창에서 작업공간, 도구막대 및 메뉴와 같은 사용자 인터페이스 요소를 작성 및 수정할 수 있습니다. 창의 맨 위에 부분적 사용자화 파일을 주 사용자화 파일로 로드하고, 변경 사항을 로드된 사용자화 파일에 저장하고, 로드된 사용자화 파일을 보는 방법 및 사용자 인터페이스 요소가 트리 뷰에 표시되는 방법을 조정할 수 있는 도구가 있습니다.

트리 뷰는 도구막대 및 메뉴와 같은 새로운 사용자 인터페이스 요소를 작성하는 데 사용됩니다. 새로운 사용자 인터페이스 요소가 작성되면 명령 리스트 창에서 끌어 명령을 추가할 수 있습니다. 사용자 인터페이스 요소를 작성하고 사용자 인터페이스 요소에 명령을 추가할 수 있는 것 외에 명령을 위나 아래로 끌어서 도구막대 및 메뉴에 명령이 표시되는 순서를 변경할 수 있습니다.

명령 리스트 창

명령 리스트 창은 로드된 사용자화 파일에 포함된 명령을 작성하고 찾는 데 사용됩니다. 새 명령 작성 버튼을 사용하여 <파일 이름>의 사용자화 창의 맨 위에 있는 드롭다운 리스트에 나열된 CUI 파일에 사용자 명령을 새로 작성합니다. 명령을 작성한 후에 <파일 이름>의 사용자화 창에 있는 사용자 인터페이스 요소와 연관시킬 수 있습니다.

새 명령 작성 버튼 왼쪽에 명령 또는 텍스트 찾기 버튼이 있습니다. 명령 또는 텍스트 찾기 버튼을 사용하면 명령 리스트 창에서만 텍스트 문자열을 검색하거나 바꿀 수 있는 찾기 및 대치 대화상자가 표시됩니다.

명령 리스트 창의 맨 위에 있는 범주 드롭다운 리스트에는 리스트 상자에 표시된 명령을 필터링하는 데 사용되는 사전 설정 범주 리스트가 들어 있습니다. 선택할 수 있는 여러 범주가 있으며, 다음과 같습니다.

  • 모든 명령. 로드된 사용자화 파일마다 모든 명령이 표시됩니다.
  • 사용자 명령. 로드된 사용자화 파일에 추가된 사용자 정의 명령이 표시됩니다. 이러한 명령은 AutoCAD와 함께 제공되는 사용자화 파일의 일부가 아닙니다.
  • 컨트롤 요소. 드롭다운 리스트, 슬라이더 및 기타 컨트롤과 같이 도구막대나 대시보드 패널에 추가할 수 있는 특수 컨트롤이 표시됩니다.

명령 리스트 창의 중간 부분에 사용 가능한 명령과 컨트롤이 표시됩니다. 사용 가능한 명령 이름, 명령에 할당된 이미지와 해당 명령이 할당된 사용자화 그룹 이름이 표시됩니다. 커서를 명령 맨 위에 놓으면 해당 명령에 할당된 매크로가 툴팁에 표시됩니다.

명령 리스트 창의 맨 아래에는 일치 문자열을 기반으로 하는 명령 리스트를 필터링할 수 있는 텍스트 필드가 있습니다. 텍스트 문자열은 명령 이름의 일부와 일치되며 일치된 텍스트 문자열과 함께 해당 명령이 리스트 상자에 표시됩니다.

동적 표시 창

동적 표시 창은 사용자화 창이나 명령 리스트 창에서 선택된 항목에 따른 추가 창의 표시를 조정합니다. 선택된 항목을 기반으로 다음 중 하나 이상의 창이 표시됩니다.

  • 버튼 이미지
  • 정보
  • 패널 미리보기
  • 도구막대 미리보기
  • 특성
  • 바로 가기
  • 작업공간 컨텐츠


사용자 인터페이스 사용자화 편집기의 개요 (요약 참조)

사용자화가 변경된 방식
사용자 인터페이스 사용자화 편집기의 개요
사용자화 파일의 기본 사항
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 사용자 인터페이스 사용자화의 개요 > 사용자 인터페이스 사용자화 편집기의 개요 >
사용자 인터페이스 사용자화 편집기의 개요
개념 요약 참조

명령

CUI

작업공간, 도구막대, 메뉴, 바로 가기 메뉴 및 키보드 바로 가기와 같은 사용자화된 사용자 인터페이스 요소를 관리합니다.

CUIEXPORT

사용자화된 설정을 acad.cui에서 엔터프라이즈 또는 부분적 CUI 파일로 내보냅니다.

CUIIMPORT

사용자화된 설정을 엔터프라이즈 또는 부분적 CUI 파일에서 acad.cui로 가져옵니다.

CUILOAD

CUI 파일 로드

CUIUNLOAD

CUI 파일 언로드

QUICKCUI

사용자 인터페이스 사용자화 대화상자를 축소된 상태로 표시합니다.

시스템 변수

DBLCLKEDIT

도면 영역에서 두 번 클릭 편집 동작을 조정합니다.

ENTERPRISEMENU

파일 이름의 경로를 포함하여 엔터프라이즈 CUI(정의된 경우)에 대한 파일 이름을 표시합니다.

MENUNAME

파일 이름의 경로를 포함하여 사용자화 파일 이름을 저장합니다

TOOLTIPS

도구막대에 툴팁의 표시를 제어합니다.

유틸리티

항목이 없습니다.

명령 수정자

항목이 없습니다.


사용자화 파일 작업

사용자 인터페이스 사용자화 편집기의 개요
사용자 인터페이스 사용자화
사용자화 파일의 기본 사항
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 >
사용자화 파일 작업
개념 절차

사용자화(CUI) 파일은 명령, 사용자 인터페이스 요소 및 부분적 CUI 파일과 AutoLISP 파일에 대한 참조를 저장하는 데 사용됩니다. CUI 파일은 주, 부분적 또는 엔터프라이즈로 지정될 수 있습니다. CUI 파일을 지정하면 파일이 로드되는 순서가 결정됩니다. 사용자 인터페이스 요소는 여러 CUI 파일 간에 전송될 수 있으며, 이는 마이그레이션 과정을 더욱 용이하게 해줍니다.

사용자 인터페이스 사용자화 편집기를 사용하면 사용자화 파일에 대해 다음을 수행할 수 있습니다.

  • 새로운 CUI 파일을 처음부터 작성
  • 기존 CUI 파일을 다른 이름으로 저장
  • 사용자화를 두 개의 CUI 파일 간에 전송
  • CUI 파일 재설정 및 복원
  • CUI 파일을 부분적 CUI 파일로 로드

이 단원의 항목

  • 사용자화 파일의 기본 사항

    사용자화 파일은 사용자 인터페이스를 구성하는 요소를 정의하기 위해 AutoCAD로 로드되며 사용자 인터페이스 사용자화 편집기를 사용하여 편집됩니다.

  • 사용자화 마이그레이션 및 전송

    사용자 인터페이스 사용자화 편집기를 사용하여 사용자 MNU 또는 MNS 파일을 이전 릴리즈에서 마이그레이션할 수 있습니다. 이 프로그램에서는 MNU 또는 MNS 파일의 모든 데이터를 원본 메뉴 파일을 수정하지 않고도 CUI 파일로 전송할 수 있습니다. 새 CUI 파일은 사용자 원본 메뉴 파일과 같은 이름을 가진 XML 기반의 파일이지만 확장자는 .cui입니다.

  • 부분적 CUI 파일 작성 및 로드

    필요할 경우 부분적 사용자화 파일을 작성하거나 로드하거나 언로드합니다. 부분적 CUI 파일을 로드하여 사용하면 사용자화를 사용자의 주 CUI 파일로 가져오지 않고도 별도의 CUI 파일에서 대부분의 인터페이스 요소(도구막대, 메뉴 등)를 작성 및 수정할 수 있습니다.

  • 엔터프라이즈 CUI 파일 작성

    일반적으로 엔터프라이즈 CUI 파일에는 많은 사용자들이 공유하지만 CAD 관리자만 조정할 수 있는 사용자화 정보가 저장됩니다. 엔터프라이즈 CUI 파일를 사용하면 회사 표준을 조정할 책임이 있는 각 사용자가 사용자화 데이터를 더 쉽게 유지 및 수정할 수 있습니다.


사용자화 파일 작업 (절차)

여러 줄 해치 패턴
사용자화 파일 작업
사용자화 파일의 기본 사항
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 사용자화 파일 작업 >
사용자화 파일 작업
개념 절차

처음부터 사용자화 파일을 작성하려면

기존 CUI 파일에서 CUI 파일을 작성하려면

사용자화 백업 파일을 복원하려면

표준 사용자화 파일을 재설정하려면

사용자화 그룹 이름을 변경하려면

CUI 파일을 주 CUI 파일로 지정하려면

사용자 인터페이스 요소를 복사하여 붙여넣으려면

사용자 인터페이스 요소를 복제하려면

사용자화를 전송하려면

CUILOAD 명령을 사용하여 부분적 CUI 파일을 로드하려면

사용자화 탭을 사용하여 부분적 CUI 파일을 로드하려면

CUIUNLOAD 명령을 사용하여 부분적 CUI 파일을 언로드하려면

사용자화 탭을 사용하여 부분적 CUI 파일을 언로드하려면

부분적 CUI 파일에 명령을 추가하려면

CUI 파일을 엔터프라이즈 CUI 파일로 지정하려면

엔터프라이즈 CUI 파일을 수정하려면


사용자화 파일의 기본 사항 (개념)

사용자화 파일 작업
사용자화 파일 작업
사용자화 마이그레이션 및 전송
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 사용자화 파일 작업 >
사용자화 파일의 기본 사항
개념 절차 요약 참조

사용자화 파일은 사용자 인터페이스를 구성하는 요소를 정의하기 위해 AutoCAD로 로드되며 사용자 인터페이스 사용자화 편집기를 사용하여 편집됩니다.

AutoCAD는 작업 환경에 맞출 수 있는 여러 가지 CUI 파일을 제공합니다. AutoCAD는 CUI 파일에 대해 주 및 엔터프라이즈의 두 가지로 지정할 수 있으며 기본적으로 AutoCAD는 주 CUI 파일을 사용합니다. AutoCAD에서 제공하는 파일을 사용자화하거나 사용자 인터페이스 사용자화 편집기의 전송 탭을 사용하여 처음부터 자신의 CUI 파일을 작성할 수 있습니다.

AutoCAD에서 제공하는 CUI 파일을 사용자화하거나 자신의 CUI 파일을 작성하는 경우, 사용자 인터페이스 사용자화 편집기에서는 CUI 파일을 처음 변경하기 시작할 때 파일의 백업 사본을 작성합니다. 이를 통해 유지하려고 했던 것을 삭제할 경우 파일을 복원할 수 있습니다. AutoCAD에서 제공하는 CUI 파일을 수정한 경우 원래 상태가 되도록 파일을 재설정할 수 있습니다.

사용자 인터페이스 사용자화를 사용하면 처음부터 새 사용자 인터페이스 요소와 명령을 작성할 뿐만 아니라 기존 사용자 인터페이스 요소와 명령을 복사하여 수정할 수 있습니다.

참고

    • 명령 사용자화

    • 도구막대 사용자화

    • 풀다운 메뉴 및 바로 가기 메뉴 작성

    • 작업공간 사용자화

    • 처음부터 사용자화 파일을 작성하려면 (절차)

    • 기존 CUI 파일에서 CUI 파일을 작성하려면 (절차)

    • 사용자화 백업 파일을 복원하려면 (절차)

    • 표준 사용자화 파일을 재설정하려면 (절차)

    • 사용자화 그룹 이름을 변경하려면 (절차)

    • CUI 파일을 주 CUI 파일로 지정하려면 (절차)

    • 사용자 인터페이스 요소를 복사하여 붙여넣으려면 (절차)

    • 사용자 인터페이스 요소를 복제하려면 (절차)


사용자화 파일의 기본 사항 (절차)

사용자화 파일 작업
상위 단계로
사용자화 파일의 기본 사항
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 사용자화 파일 작업 > 사용자화 파일의 기본 사항 >
사용자화 파일의 기본 사항
개념 절차 요약 참조

처음부터 사용자화 파일을 작성하려면

기존 CUI 파일에서 CUI 파일을 작성하려면

사용자화 백업 파일을 복원하려면

표준 사용자화 파일을 재설정하려면

사용자화 그룹 이름을 변경하려면

CUI 파일을 주 CUI 파일로 지정하려면

사용자 인터페이스 요소를 복사하여 붙여넣으려면

사용자 인터페이스 요소를 복제하려면


사용자화 파일의 기본 사항 (절차)

사용자화 파일의 기본 사항
상위 단계로
사용자화 파일의 기본 사항
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 사용자화 파일 작업 > 사용자화 파일의 기본 사항 >
사용자화 파일의 기본 사항
개념 절차 요약 참조

처음부터 사용자화 파일을 작성하려면

  1. 도구 메뉴 [image] 사용자화 [image] 인터페이스를 클릭합니다.명령 프롬프트에서 cui를 입력합니다.
  2. 사용자 인터페이스 사용자화 편집기에 있는 전송 탭의 오른쪽 창에서 새 사용자화 파일 작성 버튼을 클릭합니다.

  3. 오른쪽 창의 드롭다운 리스트에서 다른 이름으로 저장을 선택합니다.

  4. 다른 이름으로 저장 대화상자에서 새로운 사용자화 파일을 저장할 위치를 지정하고 파일 이름 문자 필드에 이름을 입력합니다.
  5. 지정된 위치에 사용자화 파일을 작성하려면 저장을 클릭합니다.


사용자화 파일의 기본 사항 (절차)

사용자화 파일의 기본 사항
상위 단계로
사용자화 파일의 기본 사항
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 사용자화 파일 작업 > 사용자화 파일의 기본 사항 >
사용자화 파일의 기본 사항
개념 절차 요약 참조

기존 CUI 파일에서 CUI 파일을 작성하려면

  1. Windows 탐색기에서 다음 위치를 찾습니다.

    C:\Documents and Settings\<사용자 프로파일 이름>\Application Data\Autodesk\<제품 이름>\<릴리즈 번호>\<언어>\support\<사용자화 파일 이름>.cui

    주일부 운영 체제에서는 사용자 프로파일 아래에 있는 폴더를 기본적으로 숨깁니다. 이 파일을 표시하려면 화면 표시 설정값을 변경해야 할 수도 있습니다. 시작 메뉴(Windows) [image] 제어판 [image] 폴더 옵션을 클릭합니다. 폴더 옵션 대화상자의 뷰 탭에서 숨긴 파일 및 폴더 표시를 클릭합니다.
  2. 선택한 CUI 파일을 새 파일 이름(예: enterprise.cui) 또는 위치(예를 들어, 사용자가 파일에 접근하는 공유 네트워크 위치)로 복사하여 원본 CUI 파일을 보존하면 나중에 이 원본 파일을 다시 수정 또는 사용할 수 있습니다.
    경고이런 방법으로 새로운 CUI 파일을 작성하는 경우, 복사된 CUI 파일에 있는 명령 및 사용자 인터페이스 요소 중 새로운 파일에서 원하지 않는 요소가 있을 경우 추가적인 작업이 필요할 수 있습니다.


사용자화 파일의 기본 사항 (절차)

사용자화 파일의 기본 사항
상위 단계로
사용자화 파일의 기본 사항
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 사용자화 파일 작업 > 사용자화 파일의 기본 사항 >
사용자화 파일의 기본 사항
개념 절차 요약 참조

사용자화 백업 파일을 복원하려면

  1. 도구 메뉴 [image] 사용자화 [image] 인터페이스를 클릭합니다.명령 프롬프트에서 cui를 입력합니다.
  2. 사용자 인터페이스 사용자화 편집기의 사용자화 탭에 있는 <파일 이름>의 사용자화 창에서 사용자화 그룹 이름을 마우스 오른쪽 버튼으로 클릭합니다.
  3. 복원 <파일 이름>을 클릭합니다.

  4. 확인을 클릭합니다.


사용자화 파일의 기본 사항 (절차)

사용자화 파일의 기본 사항
상위 단계로
사용자화 파일의 기본 사항
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 사용자화 파일 작업 > 사용자화 파일의 기본 사항 >
사용자화 파일의 기본 사항
개념 절차 요약 참조

표준 사용자화 파일을 재설정하려면

  1. 도구 메뉴 [image] 사용자화 [image] 인터페이스를 클릭합니다.명령 프롬프트에서 cui를 입력합니다.
  2. 사용자 인터페이스 사용자화 편집기의 사용자화 탭에 있는 <파일 이름>의 사용자화 창에서 사용자화 그룹 이름을 마우스 오른쪽 버튼으로 클릭합니다.
  3. 재설정 <파일 이름>을 클릭합니다.

  4. 확인을 클릭합니다.


사용자화 파일의 기본 사항 (절차)

사용자화 파일의 기본 사항
상위 단계로
사용자화 파일의 기본 사항
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 사용자화 파일 작업 > 사용자화 파일의 기본 사항 >
사용자화 파일의 기본 사항
개념 절차 요약 참조

사용자화 그룹 이름을 변경하려면

  1. 도구 메뉴 [image] 사용자화 [image] 인터페이스를 클릭합니다.명령 프롬프트에서 cui를 입력합니다.
  2. <파일 이름>의 사용자화 창에 있는 드롭다운 리스트에서 CUI 파일을 선택합니다.

  3. <파일 이름>의 사용자화 창에서 맨 위에 있는 사용자화 그룹 노드를 클릭합니다. 사용자화 그룹 이름을 마우스 오른쪽 버튼으로 클릭하고 이름 바꾸기를 클릭합니다. 새로운 사용자화 그룹 이름을 입력합니다.
    주사용자화 그룹 이름을 클릭하고 기다린 다음 다시 클릭하여 이름을 내부 편집할 수 있습니다.

    주사용자화 그룹 이름에는 공백이 있을 수 없습니다.
  4. 확인을 클릭합니다.


사용자화 파일의 기본 사항 (절차)

사용자화 파일의 기본 사항
상위 단계로
사용자화 파일의 기본 사항
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 사용자화 파일 작업 > 사용자화 파일의 기본 사항 >
사용자화 파일의 기본 사항
개념 절차 요약 참조

CUI 파일을 주 CUI 파일로 지정하려면

  1. 도구 메뉴 [image] 옵션을 클릭합니다.명령 프롬프트에서 options를 입력합니다.
  2. 옵션 대화상자의 파일 탭에서 사용자화 파일 옆에 있는 더하기 기호(+)를 클릭하여 리스트를 확장합니다.

  3. 주 사용자화 파일 옆에 있는 더하기 기호를 클릭하여 해당 항목을 확장합니다.
  4. 주 사용자화 파일 아래의 항목을 선택하고 찾아보기를 클릭합니다.

  5. 파일 선택 대화상자에서 사용자화 파일의 위치를 찾아 선택합니다. [열기]를 클릭합니다.

    이제 선택한 파일이 프로그램의 주 CUI 파일로 지정되었습니다.


사용자화 파일의 기본 사항 (절차)

사용자화 파일의 기본 사항
상위 단계로
사용자화 파일의 기본 사항
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 사용자화 파일 작업 > 사용자화 파일의 기본 사항 >
사용자화 파일의 기본 사항
개념 절차 요약 참조

사용자 인터페이스 요소를 복사하여 붙여넣으려면

  1. 도구 메뉴 [image] 사용자화 [image] 인터페이스를 클릭합니다.명령 프롬프트에서 cui를 입력합니다.
  2. 사용자 인터페이스 사용자화 편집기의 사용자화 탭에 있는 <파일 이름>의 사용자화 창에서 복사할 사용자 인터페이스 요소의 주 노드를 확장합니다.
  3. 해당 사용자 인터페이스 요소를 마우스 오른쪽 버튼으로 클릭합니다. 복사를 클릭합니다.

  4. 선택한 사용자 인터페이스 요소를 붙여넣을 노드를 마우스 오른쪽 버튼으로 클릭합니다. [붙여넣기]를 클릭합니다.

    주<파일 이름>의 사용자화 창에서 사용자 인터페이스 요소를 복사하는 데 CTRL+C 키 조합을, 사용자 인터페이스 요소를 붙여넣는 데 CTRL+V 키 조합을 사용할 수 있습니다.
  5. 확인을 클릭합니다.


사용자화 파일의 기본 사항 (절차)

사용자화 파일의 기본 사항
상위 단계로
사용자화 마이그레이션 및 전송
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 사용자화 파일 작업 > 사용자화 파일의 기본 사항 >
사용자화 파일의 기본 사항
개념 절차 요약 참조

사용자 인터페이스 요소를 복제하려면

  1. 도구 메뉴 [image] 사용자화 [image] 인터페이스를 클릭합니다.명령 프롬프트에서 cui를 입력합니다.
  2. 사용자 인터페이스 사용자화 편집기의 사용자화 탭에 있는 <파일 이름>의 사용자화 창에서 복제할 사용자 인터페이스 요소의 주 노드를 확장합니다.
  3. 해당 사용자 인터페이스 요소를 마우스 오른쪽 버튼으로 클릭합니다. 복제를 클릭합니다.

    선택한 사용자 인터페이스 요소의 사본은 <파일 이름>의 사용자화 창에서 선택한 항목 바로 위에 내부 작성됩니다.

    주사용자 인터페이스 요소를 내부 복제하는 데 CTRL+D 키 조합을 사용할 수 있습니다.
  4. 확인을 클릭합니다.


사용자화 파일의 기본 사항 (요약 참조)

사용자 인터페이스 사용자화 편집기의 개요
사용자화 파일의 기본 사항
사용자화 마이그레이션 및 전송
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 사용자화 파일 작업 > 사용자화 파일의 기본 사항 >
사용자화 파일의 기본 사항
개념 절차 요약 참조

명령

CUI

작업공간, 도구막대, 메뉴, 바로 가기 메뉴 및 키보드 바로 가기와 같은 사용자화된 사용자 인터페이스 요소를 관리합니다.

MENU

사용자화 파일 로드

시스템 변수

항목이 없습니다.

유틸리티

항목이 없습니다.

명령 수정자

항목이 없습니다.


사용자화 마이그레이션 및 전송 (개념)

사용자화 파일의 기본 사항
사용자화 파일 작업
부분적 CUI 파일 작성 및 로드
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 사용자화 파일 작업 >
사용자화 마이그레이션 및 전송
개념 절차 요약 참조

사용자 인터페이스 사용자화 편집기를 사용하여 사용자 MNU 또는 MNS 파일을 이전 릴리즈에서 마이그레이션할 수 있습니다. 이 프로그램에서는 MNU 또는 MNS 파일의 모든 데이터를 원본 메뉴 파일을 수정하지 않고도 CUI 파일로 전송할 수 있습니다. 새 CUI 파일은 사용자 원본 메뉴 파일과 같은 이름을 가진 XML 기반의 파일이지만 확장자는 .cui입니다.

파일 사이에 있는 사용자화 정보를 전송할 수도 있습니다. 예를 들어 도구막대를 부분적 CUI 파일에서 주 CUI 파일로 전송하여 해당 도구막대 정보를 프로그램에 표시할 수 있습니다.

표시: 사용자화 마이그레이션 및 전송

다음 이미지 아래의 재생 화살표를 클릭하여 애니메이션을 시작합니다.

아래 애니메이션은 이전 프로그램 릴리즈에서 작성된 메뉴 사용자화를 마이그레이션하여 현재 릴리즈로 이동하는 방법을 보여줍니다. 메뉴 사용자화를 마이그레이션하는 방법뿐만 아니라 작업공간을 사용하여 프로그램의 메뉴 막대에 메뉴를 배치하는 방법도 보여줍니다. 작업공간에 대한 자세한 정보는 작업공간 사용자화를 참조하십시오.

주부분적 CUI 파일에서 도구막대 또는 메뉴를 전송할 경우 버튼 이미지가 프로그램에 나타나지 않을 수 있습니다. 이미지가 이미지 파일로부터 로드될 경우, 해당 이미지는 옵션 대화상자의 지원 파일 검색 경로나 파일 탭의 사용자 아이콘 위치에 정의된 폴더에 있어야 합니다. 이미지가 타사의 리소스 DLL에서 제공된 경우, 리소스 DLL을 작성한 회사에 문의하십시오.
주사용자 설정값 마이그레이션 대화상자는 이전 릴리즈로부터 메뉴 사용자화를 마이그레이션하는 데 사용될 수 있습니다. 사용자 설정값 마이그레이션 대화상자에 액세스하려면 시작 메뉴(Windows) [image] 모든 프로그램(또는 프로그램) [image] Autodesk [image] [Autodesk 제품 이름] [image] 사용자 설정값 마이그레이션을 클릭합니다. 향후 릴리즈는 옵션 대화상자의 파일 탭에 있는 사용자 아이콘 위치에 정의된 폴더에 버튼 이미지를 마이그레이션합니다.

추가로, 이런 식으로 사용자화 정보를 주 CUI 파일에서 부분적 CUI 파일로 이동하거나 부분적 CUI 파일에서 다른 부분적 CUI 파일로 이동할 수 있습니다.

전송 중인 작업 공간 또는 도구막대에 원본 CUI 파일에 있는 다른 메뉴, 도구막대 또는 플라이아웃 도구막대와 관련된 플라이아웃 도구막대가 포함되어 있는 경우, 해당 인터페이스 요소에 대한 관련 정보도 전송됩니다. 예를 들어 삽입 도구막대를 참조하는 그리기 도구막대를 전송하는 경우, 삽입 도구막대도 전송됩니다.

CUI 파일에는 사용자가 만든 모든 사용자화가 기록되어 있습니다. 사용자화 데이터를 서로 다른 릴리즈 간 추적 및 보존하여 데이터 손실 또는 기존 CUI 데이터 수정 작업 없이 다른 버전의 CUI 파일을 로드할 수 있습니다.

다음은 사용자 인터페이스 사용자화 편집기의 전송 탭에 대한 예제입니다. 이 탭을 사용하여 사용자화를 마이그레이션할 수 있습니다.

주AutoCAD 2006 이전 버전에서는 CUI 파일을 표시하거나 사용할 수 없습니다.
참고

    • 사용자화를 전송하려면 (절차)


사용자화 마이그레이션 및 전송 (절차)

사용자화 파일의 기본 사항
상위 단계로
부분적 CUI 파일 작성 및 로드
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 사용자화 파일 작업 > 사용자화 마이그레이션 및 전송 >
사용자화 마이그레이션 및 전송
개념 절차 요약 참조

사용자화를 전송하려면

  1. 도구 메뉴 [image] 사용자화 [image] 사용자화 가져오기를 클릭합니다.명령 프롬프트에서 cuiimport를 입력합니다.
  2. 사용자 인터페이스 사용자화 편집기에 있는 전송 탭의 왼쪽 창에서 사용자화 파일 열기 버튼을 클릭합니다.

  3. 열기 대화상자에서 내보내려는 사용자화가 있는 사용자화 파일(MNU, MNS 또는 CUI)을 찾아 선택합니다.
  4. 오른쪽 창에서 사용자화 파일 열기 버튼을 클릭합니다.
  5. 열기 대화상자에서 사용자화를 가져올 사용자화 파일(MNU, MNS 또는 CUI)을 찾아 선택합니다.
  6. 왼쪽 창에서 인터페이스 요소 노드 옆에 있는 더하기 기호(+)를 클릭하여 해당 인터페이스 요소 노드를 확장합니다. 오른쪽 창에서 해당하는 노드를 확장합니다.
  7. 왼쪽 창에 있는 인터페이스 요소를 끌어 오른쪽 창의 적절한 위치에 놓습니다. 메뉴를 메뉴로, 도구막대를 도구막대로 끌 수 있습니다.

  8. 확인을 클릭합니다.


사용자화 마이그레이션 및 전송 (요약 참조)

사용자화 파일의 기본 사항
사용자화 마이그레이션 및 전송
부분적 CUI 파일 작성 및 로드
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 사용자화 파일 작업 > 사용자화 마이그레이션 및 전송 >
사용자화 마이그레이션 및 전송
개념 절차 요약 참조

명령

CUI

작업공간, 도구막대, 메뉴, 바로 가기 메뉴 및 키보드 바로 가기와 같은 사용자화된 사용자 인터페이스 요소를 관리합니다.

CUIEXPORT

사용자화된 설정을 acad.cui에서 엔터프라이즈 또는 부분적 CUI 파일로 내보냅니다.

CUIIMPORT

사용자화된 설정을 엔터프라이즈 또는 부분적 CUI 파일에서 acad.cui로 가져옵니다.

시스템 변수

항목이 없습니다.

유틸리티

항목이 없습니다.

명령 수정자

항목이 없습니다.


부분적 CUI 파일 작성 및 로드 (개념)

사용자화 마이그레이션 및 전송
사용자화 파일 작업
엔터프라이즈 CUI 파일 작성
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 사용자화 파일 작업 >
부분적 CUI 파일 작성 및 로드
개념 절차 요약 참조

필요할 경우 부분적 사용자화 파일을 작성하거나 로드하거나 언로드합니다. 부분적 CUI 파일을 로드하여 사용하면 사용자화를 사용자의 주 CUI 파일로 가져오지 않고도 별도의 CUI 파일에서 대부분의 인터페이스 요소(도구막대, 메뉴 등)를 작성 및 수정할 수 있습니다.

표시: 부분적 CUI 파일 로드

다음 이미지 아래의 재생 화살표를 클릭하여 애니메이션을 시작합니다.

아래 애니매이션은 부분적 CUI 파일로 CUI 파일을 로드하는 방법을 보여줍니다. 부분적 CUI 파일로 CUI 파일을 로드하는 방법뿐만 아니라 작업공간을 사용하여 부분적 CUI 파일에 포함된 도구막대 및 메뉴 표시를 조정하는 방법도 보여줍니다. 작업공간에 대한 자세한 정보는 작업공간 사용자화를 참조하십시오.

부분적 CUI 파일 트리의 부분적 CUI 파일 순서는 해당 파일이 프로그램에서 로드되는 순서를 결정합니다. 트리 계층 구조를 재정렬하여 로드 순서를 변경할 수 있습니다. 사용자 인터페이스 사용자화 편집기의 전송 탭을 사용하여 부분적 CUI 파일을 작성합니다. 자세한 정보는 사용자화를 전송하려면을(를) 참고하십시오. CUI 파일을 로드 또는 언로드하려면 프로그램의 CUILOAD 또는 CUIUNLOAD 명령을 사용하거나 사용자 인터페이스 사용자화 편집기의 사용자화 탭을 사용할 수 있습니다.

명령 및 요소는 주 CUI 파일에 로드된 부분적 CUI 파일에 추가될 수 있습니다. 부분적 CUI 파일에 명령을 추가하려면, <파일 이름>의 사용자화 창의 맨 위에 있는 드롭다운 리스트에서 부분적 CUI 파일을 선택하여야 합니다. 부분적 CUI 파일을 선택하면 새로운 명령이 부분적 CUI 파일에 추가됩니다. 자세한 정보는 부분적 CUI 파일에 명령을 추가하려면를 참고하십시오.

주부분적 CUI 파일을 로드할 경우 주 CUI 파일이 해당 파일의 작업공간 정보(메뉴, 도구막대 및 팔레트)를 무시합니다. 작업공간 내용을 부분적 CUI 파일에서 주 CUI 파일로 추가하려면 해당 작업공간을 전송해야 합니다. 자세한 정보는 작업공간 사용자화 항목의 “주 CUI 파일로 작업공간 가져오기”를 참고하십시오.
참고

    • CUILOAD 명령을 사용하여 부분적 CUI 파일을 로드하려면 (절차)

    • 사용자화 탭을 사용하여 부분적 CUI 파일을 로드하려면 (절차)

    • CUIUNLOAD 명령을 사용하여 부분적 CUI 파일을 언로드하려면 (절차)

    • 사용자화 탭을 사용하여 부분적 CUI 파일을 언로드하려면 (절차)

    • 부분적 CUI 파일에 명령을 추가하려면 (절차)


부분적 CUI 파일 작성 및 로드 (절차)

사용자화 마이그레이션 및 전송
상위 단계로
부분적 CUI 파일 작성 및 로드
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 사용자화 파일 작업 > 부분적 CUI 파일 작성 및 로드 >
부분적 CUI 파일 작성 및 로드
개념 절차 요약 참조

CUILOAD 명령을 사용하여 부분적 CUI 파일을 로드하려면

사용자화 탭을 사용하여 부분적 CUI 파일을 로드하려면

CUIUNLOAD 명령을 사용하여 부분적 CUI 파일을 언로드하려면

사용자화 탭을 사용하여 부분적 CUI 파일을 언로드하려면

부분적 CUI 파일에 명령을 추가하려면


부분적 CUI 파일 작성 및 로드 (절차)

부분적 CUI 파일 작성 및 로드
상위 단계로
부분적 CUI 파일 작성 및 로드
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 사용자화 파일 작업 > 부분적 CUI 파일 작성 및 로드 >
부분적 CUI 파일 작성 및 로드
개념 절차 요약 참조

CUILOAD 명령을 사용하여 부분적 CUI 파일을 로드하려면

  1. 명령 프롬프트에서 cuiload를 입력합니다.
  2. 사용자화 로드/언로드 대화상자의 파일 이름 상자에서 로드하려는 CUI 파일의 경로를 입력하거나, 찾아보기를 클릭하여 파일을 찾습니다.
  3. 로드를 클릭한 다음 닫기를 클릭합니다.


부분적 CUI 파일 작성 및 로드 (절차)

부분적 CUI 파일 작성 및 로드
상위 단계로
부분적 CUI 파일 작성 및 로드
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 사용자화 파일 작업 > 부분적 CUI 파일 작성 및 로드 >
부분적 CUI 파일 작성 및 로드
개념 절차 요약 참조

사용자화 탭을 사용하여 부분적 CUI 파일을 로드하려면

  1. 도구 메뉴 [image] 사용자화 [image] 인터페이스를 클릭합니다.명령 프롬프트에서 cui를 입력합니다.
  2. 사용자 인터페이스 사용자화 편집기의 사용자화 탭에 있는 <파일 이름>의 사용자화 창에서 드롭다운 리스트의 주 CUI 파일을 선택합니다. 드롭다운 리스트의 오른쪽에 있는 부분적 사용자화 파일 로드 버튼을 클릭합니다.

  3. 열기 대화상자에서 열려는 부분적 CUI 파일을 찾아 클릭한 다음 열기를 클릭합니다.
    주로드하려는 부분적 CUI 파일이 주 CUI 파일과 같은 사용자화 그룹 이름을 가진 경우, 사용자화 그룹 이름을 변경해야 합니다. 사용자 인터페이스 사용자화 대화상자에서 CUI 파일을 열고 사용자화 그룹 이름을 선택하고 마우스 오른쪽 버튼을 클릭하여 이름을 바꿉니다.
  4. 주 CUI 파일로 로드된 파일을 확인하려면 사용자화 창의 드롭다운 리스트에서 주 CUI 파일을 선택합니다.

  5. 주 사용자화 파일의 트리 뷰에서 부분적 CUI 파일 노드 옆에 있는 더하기 기호(+)를 클릭하여 확장합니다.

    주 CUI 파일에 로드된 모든 부분 메뉴가 표시됩니다.

  6. 확인을 클릭합니다.


부분적 CUI 파일 작성 및 로드 (절차)

부분적 CUI 파일 작성 및 로드
상위 단계로
부분적 CUI 파일 작성 및 로드
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 사용자화 파일 작업 > 부분적 CUI 파일 작성 및 로드 >
부분적 CUI 파일 작성 및 로드
개념 절차 요약 참조

CUIUNLOAD 명령을 사용하여 부분적 CUI 파일을 언로드하려면

  1. 명령 프롬프트에서 cuiunload를 입력합니다.
  2. 사용자화 로드/언로드 대화상자의 로드된 사용자화 그룹 상자에서 CUI 파일을 선택합니다.
  3. 언로드를 클릭한 다음 닫기를 클릭합니다.


부분적 CUI 파일 작성 및 로드 (절차)

부분적 CUI 파일 작성 및 로드
상위 단계로
부분적 CUI 파일 작성 및 로드
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 사용자화 파일 작업 > 부분적 CUI 파일 작성 및 로드 >
부분적 CUI 파일 작성 및 로드
개념 절차 요약 참조

사용자화 탭을 사용하여 부분적 CUI 파일을 언로드하려면

  1. 도구 메뉴 [image] 사용자화 [image] 인터페이스를 클릭합니다.명령 프롬프트에서 cui를 입력합니다.
  2. 사용자 인터페이스 사용자화 편집기의 사용자화 탭에 있는 <파일 이름>의 사용자화 창에서 드롭다운 리스트의 주 CUI 파일을 선택합니다.

  3. 주 사용자화 파일의 트리 뷰에서 부분적 CUI 파일 노드 옆에 있는 더하기 기호(+)를 클릭하여 확장합니다.

    주 CUI 파일에 로드된 모든 부분 메뉴가 표시됩니다.

  4. 언로드하려는 부분 메뉴를 마우스 오른쪽 버튼으로 클릭합니다. CUI 파일 언로드를 클릭합니다

    리스트에서 파일을 제거하였습니다.

  5. 확인을 클릭합니다.


부분적 CUI 파일 작성 및 로드 (절차)

부분적 CUI 파일 작성 및 로드
상위 단계로
엔터프라이즈 CUI 파일 작성
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 사용자화 파일 작업 > 부분적 CUI 파일 작성 및 로드 >
부분적 CUI 파일 작성 및 로드
개념 절차 요약 참조

부분적 CUI 파일에 명령을 추가하려면

  1. 도구 메뉴 [image] 사용자화 [image] 인터페이스를 클릭합니다.명령 프롬프트에서 cui를 입력합니다.
  2. 사용자 인터페이스 사용자화 편집기의 사용자화 탭에 있는 <파일 이름>의 사용자화 창에서 드롭다운 리스트의 부분적 CUI 파일을 선택합니다.

  3. 명령 리스트 창에서 새 명령 작성을 클릭합니다.

  4. 필요할 경우 특성 창에서 새로운 명령의 특성을 조정합니다.


부분적 CUI 파일 작성 및 로드 (요약 참조)

사용자화 마이그레이션 및 전송
부분적 CUI 파일 작성 및 로드
엔터프라이즈 CUI 파일 작성
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 사용자화 파일 작업 > 부분적 CUI 파일 작성 및 로드 >
부분적 CUI 파일 작성 및 로드
개념 절차 요약 참조

명령

CUI

작업공간, 도구막대, 메뉴, 바로 가기 메뉴 및 키보드 바로 가기와 같은 사용자화된 사용자 인터페이스 요소를 관리합니다.

CUILOAD

CUI 파일 로드

CUIUNLOAD

CUI 파일 언로드

시스템 변수

항목이 없습니다.

유틸리티

항목이 없습니다.

명령 수정자

항목이 없습니다.


엔터프라이즈 CUI 파일 작성 (개념)

부분적 CUI 파일 작성 및 로드
사용자화 파일 작업
명령 사용자화
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 사용자화 파일 작업 >
엔터프라이즈 CUI 파일 작성
개념 절차 요약 참조

일반적으로 엔터프라이즈 CUI 파일에는 많은 사용자들이 공유하지만 CAD 관리자만 조정할 수 있는 사용자화 정보가 저장됩니다. 엔터프라이즈 CUI 파일를 사용하면 회사 표준을 조정할 책임이 있는 각 사용자가 사용자화 데이터를 더 쉽게 유지 및 수정할 수 있습니다.

다음과 같은 작업을 수행하여 엔터프라이즈 CUI 파일을 작성합니다.

  • 기존 CUI 파일이나 새로운 CUI 파일에서 엔터프라이즈 CUI 파일을 작성합니다. 주 사용자화 파일(acad.cui) 또는 필요한 기본 사용자 인터페이스 요소를 모두 포함하고 있는 다른 선택된 사용자화 파일의 사본을 만듭니다. 새로운 사용자화 파일로 시작하려면 전송 탭을 사용하여 빈 사용자화 파일을 작성합니다.
  • 새 파일을 사용자의 주 CUI 파일로 지정합니다.옵션 대화상자를 사용하여 주 사용자화 파일로서 사용자화 파일을 로드하여야 모든 다른 사용자 인터페이스 요소를 편집할 수 있습니다. 나중에 복원할 필요가 있으므로 현재 주 사용자화 파일로 지정된 사용자화 파일이 어떤 것인지 숙지하십시오.
  • 엔터프라이즈 CUI 파일의 내용을 수정합니다. 사용자화 파일이 주 CUI 파일로 지정되면 필요에 따라 사용자화 그룹 이름을 변경하고 CUI 파일 내용을 수정할 수 있습니다. 사용자화 그룹 이름을 변경하면 한 번에 두 개 이상의 CUI 파일을 프로그램에 로드할 수 있습니다. 동일한 사용자화 그룹 이름을 가진 CUI 파일은 프로그램으로 로드될 수 없습니다.
  • 주 CUI 파일을 대치합니다. 옵션 대화상자를 사용하여 주 사용자화 파일로 지정된 이전 사용자화 파일을 대치합니다.
  • 엔터프라이즈 CUI 파일을 공유 네트워크 위치에 저장합니다.새 엔터프라이즈 파일을 공유 네트워크 위치에 저장하면 지정된 위치에 접근하는 모든 사용자가 해당 파일에 접근할 수 있습니다.
    주엔터프라이즈 CUI 파일을 배치한 폴더는 사용자가 접근할 수 있는 공유 위치에 있어야 합니다. 네트워크 공유 작성에 관해 좀 더 학습하려면 네트워크 관리자 안내서에 있는 “네트워크 공유 작성 방법”을 참고하십시오.
  • 엔터프라이즈 CUI 파일의 위치를 지정합니다. 옵션 대화상자에서 엔터프라이즈 사용자화 파일의 위치를 지정하면 프로그램이 해당 엔터프라이즈 사용자화 파일을 읽기 전용으로 자동 지정합니다. 엔터프라이즈 사용자화 파일의 위치는 개별 워크스테이션 또는 배치 마법사에서 지정할 수 있습니다. 배치 마법사에서 위치를 설정하는 방법에 대한 자세한 정보는 네트워크 관리자 안내서의 "검색 경로 및 파일 위치 선택"을 참고하십시오.
    경고사용자 인터페이스 사용자화(CUI) 편집기가 엔터프라이즈 사용자화 파일을 읽기 전용으로 로드하더라도 파일이 수정되지 않도록 완벽하게 보호하지는 않습니다. 엔터프라이즈 사용자화 파일은 주 사용자화 파일로 로드한 후 수정할 수 있습니다. 엔터프라이즈 사용자화 파일을 보호하려면 파일이 저장된 위치가 읽기 전용으로 표시되고 쓰기 권한은 파일을 편집할 수 있는 사용자로 제한되어야 합니다.
참고

    • CUI 파일을 엔터프라이즈 CUI 파일로 지정하려면 (절차)

    • 엔터프라이즈 CUI 파일을 수정하려면 (절차)


엔터프라이즈 CUI 파일 작성 (절차)

부분적 CUI 파일 작성 및 로드
상위 단계로
엔터프라이즈 CUI 파일 작성
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 사용자화 파일 작업 > 엔터프라이즈 CUI 파일 작성 >
엔터프라이즈 CUI 파일 작성
개념 절차 요약 참조

CUI 파일을 엔터프라이즈 CUI 파일로 지정하려면

엔터프라이즈 CUI 파일을 수정하려면


엔터프라이즈 CUI 파일 작성 (절차)

엔터프라이즈 CUI 파일 작성
상위 단계로
엔터프라이즈 CUI 파일 작성
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 사용자화 파일 작업 > 엔터프라이즈 CUI 파일 작성 >
엔터프라이즈 CUI 파일 작성
개념 절차 요약 참조

CUI 파일을 엔터프라이즈 CUI 파일로 지정하려면

  1. 각 사용자 워크스테이션의 AutoCAD에서 도구 메뉴 [image] 옵션을 클릭합니다.각 사용자 워크스테이션의 AutoCAD의 명령 프롬프트에서 options를 입력합니다.
  2. 옵션 대화상자의 파일 탭에서 사용자화 파일 옆에 있는 더하기 기호(+)를 클릭하여 리스트를 확장합니다.

  3. 엔터프라이즈 사용자화 파일 옆에 있는 더하기 기호를 클릭하여 해당 파일을 엽니다.
  4. 주 사용자화 파일 아래의 항목을 선택하고 찾아보기를 클릭합니다.

  5. 파일 선택 대화상자에서 엔터프라이즈 사용자화 파일의 위치를 찾습니다. 열기를 클릭합니다.

    해당 CUI 파일을 사용자가 접근할 수 있는 공유 네트워크 위치에 저장해야 합니다.

  6. 옵션 대화상자에서 확인을 클릭합니다.
    주배치 마법사에 있는 설정값 지정 페이지에서 엔터프라이즈 CUI 파일을 지정합니다. 배치 마법사에서 엔터프라이즈 CUI 파일을 지정하는 방법에 대한 자세한 정보는 네트워크 관리자 안내서의 "검색 경로 및 파일 위치 선택"을 참고하십시오.


엔터프라이즈 CUI 파일 작성 (절차)

엔터프라이즈 CUI 파일 작성
상위 단계로
명령 사용자화
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 사용자화 파일 작업 > 엔터프라이즈 CUI 파일 작성 >
엔터프라이즈 CUI 파일 작성
개념 절차 요약 참조

엔터프라이즈 CUI 파일을 수정하려면

  1. 도구 메뉴 [image] 옵션을 클릭합니다.명령 프롬프트에서 options를 입력합니다.
  2. 옵션 대화상자의 파일 탭에서 사용자화 파일 옆에 있는 더하기 기호(+)를 클릭하여 리스트를 확장합니다.
  3. 주 사용자화 파일 옆에 있는 더하기 기호를 클릭하여 해당 파일을 확장합니다.

    나중에 복원할 필요가 있으니 현재 주 CUI 파일 이름 및 위치를 숙지하십시오.

  4. 주 사용자화 파일 아래의 항목을 선택하고 찾아보기를 클릭합니다. 파일 선택 대화상자에서 엔터프라이즈 사용자화 파일의 위치를 찾습니다. 열기를 클릭합니다.
  5. 엔터프라이즈 사용자화 파일 옆에 있는 더하기 기호를 클릭하여 해당 항목을 확장합니다.

    나중에 복원할 필요가 있으니 현재 엔터프라이즈 CUI 파일 이름 및 위치를 숙지하십시오.

  6. 엔터프라이즈 사용자화 파일 아래의 항목을 선택하고 찾아보기를 클릭합니다. 파일 선택 대화상자에서 주 사용자화 파일의 위치를 찾습니다. 열기를 클릭합니다.
  7. 옵션 대화상자에서 확인을 클릭하여 변경 사항을 저장합니다.
  8. 도구 메뉴 [image] 사용자화 [image] 인터페이스를 클릭합니다.명령 프롬프트에서 cui를 입력합니다.
  9. 사용자 인터페이스 사용자화 편집기의 사용자화 탭에 있는 명령 리스트 창에서 필요에 따라 새로운 명령 및 사용자 인터페이스 요소를 작성합니다.
  10. 새로운 명령 및 사용자 인터페이스 요소를 추가했으면 확인을 클릭합니다. 옵션 대화상자에서 주 및 엔터프라이즈 값의 파일 이름을 전환합니다.

    이제 주 및 엔터프라이즈 CUI 파일은 변경하기 전의 원래 구성과 유사합니다.

팁주 및 엔터프라이즈 CUI 파일 간에 전환하기 위해 사용되는 두 개의 다른 프로파일을 작성할 수 있습니다. 하나의 프로파일은 제도자가 사용하는 일반 구성으로 된 CUI 파일을 가지며 다른 프로파일은 전환된 주 및 엔터프라이즈 CUI 파일을 가집니다.


엔터프라이즈 CUI 파일 작성 (요약 참조)

부분적 CUI 파일 작성 및 로드
엔터프라이즈 CUI 파일 작성
명령 작성, 편집 및 재사용
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 사용자화 파일 작업 > 엔터프라이즈 CUI 파일 작성 >
엔터프라이즈 CUI 파일 작성
개념 절차 요약 참조

명령

CUI

작업공간, 도구막대, 메뉴, 바로 가기 메뉴 및 키보드 바로 가기와 같은 사용자화된 사용자 인터페이스 요소를 관리합니다.

CUIEXPORT

사용자화된 설정을 acad.cui에서 엔터프라이즈 또는 부분적 CUI 파일로 내보냅니다.

CUILOAD

CUI 파일 로드

CUIUNLOAD

CUI 파일 언로드

MENU

사용자화 파일 로드

OPTIONS

프로그램 설정값을 사용자화합니다.

시스템 변수

ENTERPRISEMENU

파일 이름의 경로를 포함하여 엔터프라이즈 CUI(정의된 경우)에 대한 파일 이름을 표시합니다.

유틸리티

항목이 없습니다.

명령 수정자

항목이 없습니다.


명령 사용자화

엔터프라이즈 CUI 파일 작성
사용자 인터페이스 사용자화
명령 작성, 편집 및 재사용
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 >
명령 사용자화
개념 절차

명령을 쉽게 작성, 편집 및 재사용할 수 있습니다. 사용자 인터페이스 사용자화 편집기의 사용자화 탭에는 제품에 로드된 명령의 마스터 리스트가 표시됩니다. 이 리스트의 모든 명령어를 도구막대, 메뉴 및 다른 사용자 인터페이스 요소로 추가할 수 있습니다.

트리 뷰에서 원본 리스트에 있는 명령의 특성을 변경하면 해당 명령이 사용된 모든 곳에서 해당 명령의 특성이 변경됩니다.

다음 테이블은 특성 창에 나타나는 축척 명령 특성을 보여줍니다.

수정 메뉴의 축척 명령에 대한 특성
특성 창 항목 | 설명 | 예제
이름 | 도구막대 버튼을 클릭하면 문자열이 메뉴 이름 또는 툴팁으로 표시됩니다. 문자열에 하이픈(-)이나 밑줄(_) 이외의 영숫자 문자가 구두점 없이 포함되어야 합니다. | 축척(&L)
설명 | 상태 행 문자입니다. 커서를 도구막대 버튼 또는 메뉴 항목 위로 가져가면 이 문자열이 상태 막대에 표시됩니다. | 객체를 X, Y 및 Z 방향으로 비례하여 확대 또는 축소함: SCALE
매크로 | 명령 매크로입니다. 표준 매크로 구문을 따릅니다. 주매크로의 이름을 변경하더라도 해당 매크로에 해당하는 메뉴 항목 또는 도구막대 버튼의 이름은 변경되지 않습니다. 메뉴 항목 또는 도구막대 버튼 이름은 트리 뷰에서 변경해야 합니다. | $M=$(if,$(eq,$(substr,$( getvar,cmdnames),1,4), GRIP),_scale,^C^C_scale)
요소 ID | 명령을 고유하게 식별하는 태그입니다. | ID_Scale
작은 이미지 | 작은 이미지 리소스(16 × 16 비트맵)의 ID 문자열입니다. 문자열에 하이픈(-)이나 밑줄(_) 이외의 영숫자 문자가 구두점 없이 포함되어야 합니다. 또한 사용자 정의 비트맵도 포함될 수 있습니다. 타원 버튼[...]을 클릭하여 이미지 파일 선택 대화상자를 엽니다. | RCDATA_16_SCALE
큰 이미지 | 큰 이미지 리소스(32 × 32 비트맵)의 ID 문자열입니다. 지정된 비트맵이 32 × 32가 아닌 경우 프로그램이 이 크기로 축척합니다. 문자열에 하이픈(-)이나 밑줄(_) 이외의 영숫자 문자가 구두점 없이 포함되어야 합니다. 또한 사용자 정의 비트맵도 포함될 수 있습니다. 타원 버튼[...]을 클릭하여 이미지 파일 선택 대화상자를 엽니다. | RCDATA_16_SCALE

이 단원의 항목

  • 명령 작성, 편집 및 재사용

    처음부터 새 명령을 작성하거나 기존 명령을 복사하여 새 명령을 작성하거나 기존 명령의 특성을 편집할 수 있습니다. 명령을 작성하거나 편집할 경우 정의할 수 있는 특성은 명령 이름, 설명, 매크로, 요소 ID(새 명령에만 해당)와 큰 이미지 또는 작은 이미지입니다.

  • 명령 이름 및 검색 문자열 찾기

    명령 또는 검색 문자열(명령 또는 UI 요소 이름, 설명 및 매크로 포함)에 대해 하나 이상의 CUI 파일을 검색할 수 있습니다. 명령 또는 검색 문자열을 한 번에 하나씩 대치하거나 한 번에 모두 대치할 수 있습니다.

  • 명령 레이블 표시 조정

    프로그램에서 메뉴 레이블로 명령의 가용성을 표시하는 방식을 조정할 수 있습니다. 메뉴 명령을 그레이 아웃(사용 불가능)하거나, 확인 표시 또는 경계로 표시하거나, 지시자 조합을 사용합니다.

  • 명령 이미지 작성

    이미지는 명령과 연관될 수 있으며 도구막대 버튼 또는 풀다운 메뉴의 메뉴 항목 옆에 표시됩니다. 프로그램에서 제공하는 이미지를 사용하거나 직접 이미지를 작성할 수 있습니다.

  • 상태 행 도움말 메시지 작성

    상태 행 도움말 메시지는 좌표 입력 장치가 메뉴 옵션 또는 도구막대 버튼 위에 멈출 때 상태 행(도면 영역의 맨 아래)에 표시되는 간단한 설명 메시지입니다. 관련된 명령에 대한 설명 특성을 업데이트하여 메뉴 및 버튼의 설명을 변경하거나 추가할 수 있습니다.


명령 사용자화 (절차)

엔터프라이즈 CUI 파일 작성
명령 사용자화
명령 작성, 편집 및 재사용
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 명령 사용자화 >
명령 사용자화
개념 절차

명령을 작성하려면

명령을 제거하려면

명령을 편집하려면

명령을 재사용하려면

명령을 복사하여 붙여넣으려면

명령을 복제하려면

CUI 파일에서 검색 문자열을 찾으려면

명령 리스트 창에서 검색 문자열을 찾으려면

명령 리스트 창의 명령이 사용되는 위치를 찾으려면

검색 문자열을 대치하려면

명령을 대치하려면

명령의 메뉴 레이블을 그레이 아웃(사용 불가능)하려면

명령의 메뉴 레이블을 표시하려면

명령 메뉴 레이블을 그레이 아웃(사용 불가능)과 동시에 표시하려면

버튼 이미지를 편집 또는 작성하려면

표준 이미지를 명령에 지정하려면

사용자 이미지를 명령에 지정하려면

사용자 이미지를 이미지 리스트로 가져오려면

상태 행 도움말 메시지를 작성하려면


명령 작성, 편집 및 재사용 (개념)

명령 사용자화
명령 사용자화
명령 이름 및 검색 문자열 찾기
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 명령 사용자화 >
명령 작성, 편집 및 재사용
개념 절차 요약 참조

처음부터 새 명령을 작성하거나 기존 명령을 복사하여 새 명령을 작성하거나 기존 명령의 특성을 편집할 수 있습니다. 명령을 작성하거나 편집할 경우 정의할 수 있는 특성은 명령 이름, 설명, 매크로, 요소 ID(새 명령에만 해당)와 큰 이미지 또는 작은 이미지입니다.

명령 리스트 창에서 명령의 특성을 변경하면 해당 명령을 참조하는 모든 인터페이스 항목에 명령이 업데이트됩니다.

표시: 명령 작성

다음 이미지 아래의 재생 화살표를 클릭하여 애니메이션을 시작합니다.

아래 애니메이션은 주 CUI 파일에서 사용자 명령을 작성하는 방법을 보여줍니다. 이 애니메이션에는 명령에 이름, 설명 및 매크로를 지정하는 방법도 나타나 있습니다. 명령에 이미지를 지정하는 방법은 명령 이미지 작성을 참조하십시오.

참고

    • 매크로 작성

    • 명령 이미지 작성

    • 명령을 작성하려면 (절차)

    • 명령을 제거하려면 (절차)

    • 명령을 편집하려면 (절차)

    • 명령을 재사용하려면 (절차)

    • 명령을 복사하여 붙여넣으려면 (절차)

    • 명령을 복제하려면 (절차)


명령 작성, 편집 및 재사용 (절차)

명령 사용자화
상위 단계로
명령 작성, 편집 및 재사용
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 명령 사용자화 > 명령 작성, 편집 및 재사용 >
명령 작성, 편집 및 재사용
개념 절차 요약 참조

명령을 작성하려면

명령을 제거하려면

명령을 편집하려면

명령을 재사용하려면

명령을 복사하여 붙여넣으려면

명령을 복제하려면


명령 작성, 편집 및 재사용 (절차)

명령 작성, 편집 및 재사용
상위 단계로
명령 작성, 편집 및 재사용
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 명령 사용자화 > 명령 작성, 편집 및 재사용 >
명령 작성, 편집 및 재사용
개념 절차 요약 참조

명령을 작성하려면

  1. 도구 메뉴 [image] 사용자화 [image] 인터페이스를 클릭합니다.명령 프롬프트에서 cui를 입력합니다.
  2. 사용자 인터페이스 사용자화 편집기의 사용자화 탭에 있는 명령 리스트 창에서 새 명령 작성을 클릭합니다.

    (이름이 Command1인) 새 명령이 명령 리스트 창과 특성 창 모두에 표시됩니다.

  3. 특성 창에서 다음을 수행합니다.
    • 이름 상자에 명령의 이름을 입력합니다. 이 명령을 선택하면 해당 이름이 툴팁 또는 메뉴 이름으로 표시됩니다.
    • 설명 상자에 명령에 대한 설명을 입력합니다. 이 설명은 커서를 메뉴 항목 또는 도구막대 버튼 위로 가져가면 상태 막대에 표시됩니다.
    • 매크로 상자에 명령에 대한 매크로를 입력합니다.
    • 요소 ID 상자에 명령에 대한 요소 ID를 입력합니다.

    버튼 이미지를 명령에 추가하는 방법에 대한 정보는 명령 이미지 작성을 참고하십시오.


명령 작성, 편집 및 재사용 (절차)

명령 작성, 편집 및 재사용
상위 단계로
명령 작성, 편집 및 재사용
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 명령 사용자화 > 명령 작성, 편집 및 재사용 >
명령 작성, 편집 및 재사용
개념 절차 요약 참조

명령을 제거하려면

  1. 도구 메뉴 [image] 사용자화 [image] 인터페이스를 클릭합니다.명령 프롬프트에서 cui를 입력합니다.
  2. 사용자 인터페이스 사용자화 편집기의 사용자화 탭에 있는 명령 리스트 창의 필터 드롭다운 리스트에서 사용자를 선택합니다.

    로드된 사용자화 파일에서 작성한 명령만 표시되도록 리스트가 필터링됩니다.

  3. 제거할 명령을 선택하고 해당 명령을 마우스 오른쪽 버튼으로 클릭합니다.
  4. 제거를 클릭합니다.
    주도구막대 또는 메뉴와 같은 사용자 인터페이스 요소에서 참조되지 않을 경우만 명령을 제거할 수 있습니다.
    경고사용자 인터페이스 사용자화 편집기 내에서 명령이나 사용자 인터페이스 요소의 제거를 명령 취소할 수 있는 방법이 없기 때문에 명령과 사용자 인터페이스 요소를 제거할 때 주의하십시오. 잘못된 명령이나 사용자 인터페이스 요소를 실수로 제거할 경우 취소를 클릭하는 것이 최선의 방법이지만 이 경우 다른 변경사항도 모두 명령 취소됩니다. CUI 파일에서 여러 항목을 변경한 경우 이 변경 사항을 유실하지 않으려면 전송 탭에서 CUI 파일을 변경한 후 자동으로 작성되는 백업 CUI 파일을 열고 실수로 제거된 명령 또는 사용자 인터페이스 요소를 복구합니다.


명령 작성, 편집 및 재사용 (절차)

명령 작성, 편집 및 재사용
상위 단계로
명령 작성, 편집 및 재사용
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 명령 사용자화 > 명령 작성, 편집 및 재사용 >
명령 작성, 편집 및 재사용
개념 절차 요약 참조

명령을 편집하려면

  1. 도구 메뉴 [image] 사용자화 [image] 인터페이스를 클릭합니다.명령 프롬프트에서 cui를 입력합니다.
  2. 사용자 인터페이스 사용자화 편집기의 사용자화 탭에서 다음 중 하나를 수행합니다.
    • 명령 리스트 창에서 편집하려는 명령을 클릭합니다.
    • 트리 뷰 창에서 편집하려는 명령을 찾아 클릭합니다.

  3. 특성 창에서 다음 중 하나를 수행하여 명령을 편집합니다.
    • 이름 상자에 해당 명령의 새 이름을 입력합니다. 이 이름은 해당 명령을 지정하는 프로그램의 모든 메뉴에 표시됩니다.
    • 설명 상자에 해당 명령에 대한 새로운 설명을 입력합니다. 프로그램에서 해당 명령을 선택하면 상태 막대에 설명이 표시됩니다.
    • 매크로 상자에 해당 명령에 대한 새 매크로를 입력합니다.
    • 요소 ID 상자에 해당 명령에 대한 새 요소 ID를 입력합니다. (새 명령에 대해서만. 기존 명령의 요소 ID를 수정할 수 없습니다).

    버튼 이미지를 명령에 추가하는 방법에 대한 정보는 명령 이미지 작성을 참고하십시오.


명령 작성, 편집 및 재사용 (절차)

명령 작성, 편집 및 재사용
상위 단계로
명령 작성, 편집 및 재사용
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 명령 사용자화 > 명령 작성, 편집 및 재사용 >
명령 작성, 편집 및 재사용
개념 절차 요약 참조

명령을 재사용하려면

  1. 도구 메뉴 [image] 사용자화 [image] 인터페이스를 클릭합니다.명령 프롬프트에서 cui를 입력합니다.
  2. 사용자 인터페이스 사용자화 편집기의 사용자화 탭에 있는 명령 리스트 창에서 재사용하려는 명령을 찾아 해당 명령을 인터페이스 요소로 끌어옵니다.


명령 작성, 편집 및 재사용 (절차)

명령 작성, 편집 및 재사용
상위 단계로
명령 작성, 편집 및 재사용
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 명령 사용자화 > 명령 작성, 편집 및 재사용 >
명령 작성, 편집 및 재사용
개념 절차 요약 참조

명령을 복사하여 붙여넣으려면

  1. 도구 메뉴 [image] 사용자화 [image] 인터페이스를 클릭합니다.명령 프롬프트에서 cui를 입력합니다.
  2. 사용자 인터페이스 사용자화 편집기의 사용자화 탭에 있는 명령 리스트 창에서 복사할 명령을 찾습니다.
  3. 해당 명령을 마우스 오른쪽 버튼으로 클릭합니다. 복사를 클릭합니다.

  4. 도구막대 또는 메뉴 같은 UI 요소를 마우스 오른쪽 버튼으로 클릭합니다. [붙여넣기]를 클릭합니다.

    주명령 리스트 창에서 명령을 복사하는 데 CTRL+C 키 조합을, 명령을 붙여넣는 데 CTRL+V 키 조합을 사용할 수 있습니다.


명령 작성, 편집 및 재사용 (절차)

명령 작성, 편집 및 재사용
상위 단계로
명령 이름 및 검색 문자열 찾기
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 명령 사용자화 > 명령 작성, 편집 및 재사용 >
명령 작성, 편집 및 재사용
개념 절차 요약 참조

명령을 복제하려면

  1. 도구 메뉴 [image] 사용자화 [image] 인터페이스를 클릭합니다.명령 프롬프트에서 cui를 입력합니다.
  2. 사용자 인터페이스 사용자화 편집기의 사용자화 탭에 있는 명령 리스트 창에서 복제할 명령을 찾습니다.
  3. 해당 명령을 마우스 오른쪽 버튼으로 클릭합니다. 복제를 클릭합니다.

    선택한 명령의 사본은 명령 리스트 창에서 선택한 항목 바로 위에 내부 작성됩니다.

    주명령을 내부 복제하는 데 CTRL+D 키 조합을 사용할 수 있습니다.


명령 작성, 편집 및 재사용 (요약 참조)

엔터프라이즈 CUI 파일 작성
명령 작성, 편집 및 재사용
명령 이름 및 검색 문자열 찾기
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 명령 사용자화 > 명령 작성, 편집 및 재사용 >
명령 작성, 편집 및 재사용
개념 절차 요약 참조

명령

CUI

작업공간, 도구막대, 메뉴, 바로 가기 메뉴 및 키보드 바로 가기와 같은 사용자화된 사용자 인터페이스 요소를 관리합니다.

시스템 변수

항목이 없습니다.

유틸리티

항목이 없습니다.

명령 수정자

항목이 없습니다.


명령 이름 및 검색 문자열 찾기 (개념)

명령 작성, 편집 및 재사용
명령 사용자화
명령 레이블 표시 조정
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 명령 사용자화 >
명령 이름 및 검색 문자열 찾기
개념 절차 요약 참조

명령 또는 검색 문자열(명령 또는 UI 요소 이름, 설명 및 매크로 포함)에 대해 하나 이상의 CUI 파일을 검색할 수 있습니다. 명령 또는 검색 문자열을 한 번에 하나씩 대치하거나 한 번에 모두 대치할 수 있습니다.

얻으려는 검색 결과에 따라 검색을 제한하거나 확장할 수 있습니다.

  • 명령 리스트 창에 있는 명령으로 검색을 제한합니다. 이 검색에는 UI 요소 이름, 연관된 명령 및 특성이 포함되지 않습니다. 예를 들어, LINE 명령을 명령 리스트에서만 검색하도록 제한하는 경우 검색을 시작할 때 다음과 유사한 메시지가 표시됩니다. “트리 노드 'Line'에서 명령을 찾음(1/3)”
  • 사용자화 창에 있는 모든 트리 뷰 노드의 모든 특성이 포함되도록 검색을 확장합니다. 이런 검색 유형은 모든 복제 또는 검색 문자열을 찾습니다. 예를 들어, 검색 문자열 “선”을 검색하고 트리 뷰에서 시작하는 경우, 다음과 유사한 메시지가 표시됩니다. “0 위치의 트리 노드 '선형' 특성 '이름'에서 검색 문자열을 찾음(1/358)”
참고

    • CUI 파일에서 검색 문자열을 찾으려면 (절차)

    • 명령 리스트 창에서 검색 문자열을 찾으려면 (절차)

    • 명령 리스트 창의 명령이 사용되는 위치를 찾으려면 (절차)

    • 검색 문자열을 대치하려면 (절차)

    • 명령을 대치하려면 (절차)


명령 이름 및 검색 문자열 찾기 (절차)

명령 작성, 편집 및 재사용
상위 단계로
명령 이름 및 검색 문자열 찾기
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 명령 사용자화 > 명령 이름 및 검색 문자열 찾기 >
명령 이름 및 검색 문자열 찾기
개념 절차 요약 참조

CUI 파일에서 검색 문자열을 찾으려면

명령 리스트 창에서 검색 문자열을 찾으려면

명령 리스트 창의 명령이 사용되는 위치를 찾으려면

검색 문자열을 대치하려면

명령을 대치하려면


명령 이름 및 검색 문자열 찾기 (절차)

명령 이름 및 검색 문자열 찾기
상위 단계로
명령 이름 및 검색 문자열 찾기
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 명령 사용자화 > 명령 이름 및 검색 문자열 찾기 >
명령 이름 및 검색 문자열 찾기
개념 절차 요약 참조

CUI 파일에서 검색 문자열을 찾으려면

  1. 도구 메뉴 [image] 사용자화 [image] 인터페이스를 클릭합니다.명령 프롬프트에서 cui를 입력합니다.
  2. 사용자 인터페이스 사용자화 편집기의 <파일 이름>의 사용자화 창에서 트리 뷰의 아무 곳이나 마우스 오른쪽 버튼으로 클릭합니다. [찾기]를 클릭합니다.

  3. 찾기 및 대치 대화상자의 찾기 탭에서 다음 작업을 수행합니다.
    • 찾을 내용 상자에 검색 문자열을 입력합니다.
    • 검색 문자열의 대소문자에 상관없이 해당 검색 문자열의 모든 복제를 검색하려는 경우, 대소문자 무시 옵션에서 선택 상자를 취소합니다.
    • 다음 영역으로 검색 제한 옵션에서, 하나의 CUI 파일로만 검색을 제한하려는 경우 선택 상자를 선택합니다. 그런 다음 이 옵션의 드롭다운 리스트에서 CUI 파일을 선택합니다.

    • 다음 찾기를 클릭하여 검색 문자열의 모든 복제를 찾습니다.

    검색 문자열의 위치 및 검색에서 만들어진 결과 수를 상세히 보여주는 메시지가 표시됩니다.

  4. 다음 찾기를 클릭하여 검색을 계속합니다.
  5. [닫기]를 클릭합니다.
  6. 사용자 인터페이스 사용자화 편집기에서 닫기를 클릭합니다.


명령 이름 및 검색 문자열 찾기 (절차)

명령 이름 및 검색 문자열 찾기
상위 단계로
명령 이름 및 검색 문자열 찾기
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 명령 사용자화 > 명령 이름 및 검색 문자열 찾기 >
명령 이름 및 검색 문자열 찾기
개념 절차 요약 참조

명령 리스트 창에서 검색 문자열을 찾으려면

  1. 도구 메뉴 [image] 사용자화 [image] 인터페이스를 클릭합니다.명령 프롬프트에서 cui를 입력합니다.
  2. 사용자 인터페이스 사용자화 편집기에서 명령 리스트 창의 리스트 뷰 아무 곳이나 마우스 오른쪽 버튼으로 클릭합니다. [찾기]를 클릭합니다.
  3. 찾기 및 대치 대화상자의 찾기 탭에서 다음 작업을 수행합니다.
    • 찾을 내용 상자에 검색 문자열을 입력합니다.
    • 검색 문자열의 대소문자에 상관없이 해당 검색 문자열의 모든 복제를 검색하려는 경우, 대소문자 무시 옵션에서 선택 상자를 취소합니다.
    • 다음 영역으로 검색 제한 옵션에서, 하나의 CUI 파일로만 검색을 제한하려는 경우 선택 상자를 선택합니다. 그런 다음 이 옵션의 드롭다운 리스트에서 CUI 파일을 선택합니다.

    • 다음 찾기를 클릭하여 검색 문자열의 모든 복제를 찾습니다.

    검색 문자열의 위치 및 검색에서 만들어진 결과 수를 상세히 보여주는 메시지가 표시됩니다.

  4. 다음 찾기를 클릭하여 검색을 계속합니다.
  5. [닫기]를 클릭합니다.
  6. 사용자 인터페이스 사용자화 편집기에서 닫기를 클릭합니다.


명령 이름 및 검색 문자열 찾기 (절차)

명령 이름 및 검색 문자열 찾기
상위 단계로
명령 이름 및 검색 문자열 찾기
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 명령 사용자화 > 명령 이름 및 검색 문자열 찾기 >
명령 이름 및 검색 문자열 찾기
개념 절차 요약 참조

명령 리스트 창의 명령이 사용되는 위치를 찾으려면

  1. 도구 메뉴 [image] 사용자화 [image] 인터페이스를 클릭합니다.명령 프롬프트에서 cui를 입력합니다.
  2. 사용자 인터페이스 사용자화 편집기의 명령 리스트 창에서 찾으려는 명령 이름을 마우스 오른쪽 버튼으로 클릭합니다. [찾기]를 클릭합니다.

  3. 찾기 및 대치 대화상자의 찾기 탭에서 다음 작업을 수행합니다.
    • 찾을 내용 상자에 명령 이름을 입력합니다.
    • 검색 문자열의 대소문자에 상관없이 해당 검색 문자열의 모든 복제를 검색하려는 경우, 대소문자 무시 옵션에서 선택 상자를 취소합니다.
    • 선택한 명령 찾기를 클릭하여 명령의 모든 복제를 찾습니다.

  4. 표시된 문자에서, 명령 또는 검색 문자열의 각각의 위치와 트리 노드 또는 특성 창에서의 정확한 위치, 그리고 명령 또는 검색 문자열이 발생한 복제의 개수를 봅니다.
  5. 선택한 명령 찾기를 클릭하여 검색을 계속합니다.
  6. [닫기]를 클릭합니다.
  7. 사용자 인터페이스 사용자화 편집기에서 닫기를 클릭합니다.


명령 이름 및 검색 문자열 찾기 (절차)

명령 이름 및 검색 문자열 찾기
상위 단계로
명령 이름 및 검색 문자열 찾기
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 명령 사용자화 > 명령 이름 및 검색 문자열 찾기 >
명령 이름 및 검색 문자열 찾기
개념 절차 요약 참조

검색 문자열을 대치하려면

  1. 도구 메뉴 [image] 사용자화 [image] 인터페이스를 클릭합니다.명령 프롬프트에서 cui를 입력합니다.
  2. 사용자 인터페이스 사용자화 편집기의 사용자화 탭에 있는 <파일 이름>의 사용자화 창에서 트리 뷰의 아무 곳이나 마우스 오른쪽 버튼으로 클릭합니다. 대치를 클릭합니다.

  3. 찾기 및 대치 대화상자의 대치 탭에서 다음 작업을 수행합니다.
    • 찾을 내용 상자에 검색 문자열을 입력합니다.
    • 대치 대상 상자에서, 발견한 문자열을 대치하는 데 사용하려는 문자열을 지정합니다.
    • 검색 문자열의 대소문자에 상관없이 해당 검색 문자열의 모든 복제를 검색하려는 경우, 대소문자 무시 옵션에서 선택 상자를 취소합니다.
    • 다음 영역으로 검색 제한 옵션에서, 하나의 CUI 파일로만 검색을 제한하려는 경우 선택 상자를 선택합니다. 그런 다음 이 옵션의 드롭다운 리스트에서 CUI 파일을 선택합니다.
    • 대치하기 전에 찾은 문자열의 각 복제를 이동하려면 대치를 클릭합니다. 표시된 문자에서, 각 검색 문자열의 위치와 트리 노드 또는 특성 창에서의 정확한 위치, 그리고 검색 문자열이 발생한 복제의 개수를 봅니다. 이 작업을 명령 취소할 수 없습니다.
    • 검색 문자열의 모든 복제를 대치하려면 전체 대치를 클릭합니다. 이 작업을 명령 취소할 수 없습니다.

  4. [닫기]를 클릭합니다.
  5. 사용자 인터페이스 사용자화 편집기에서 닫기를 클릭합니다.


명령 이름 및 검색 문자열 찾기 (절차)

명령 이름 및 검색 문자열 찾기
상위 단계로
명령 레이블 표시 조정
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 명령 사용자화 > 명령 이름 및 검색 문자열 찾기 >
명령 이름 및 검색 문자열 찾기
개념 절차 요약 참조

명령을 대치하려면

  1. 도구 메뉴 [image] 사용자화 [image] 인터페이스를 클릭합니다.명령 프롬프트에서 cui를 입력합니다.
  2. 사용자 인터페이스 사용자화 편집기에 있는 사용자화 탭의 명령 리스트 창에서, 대치하려는 명령 이름을 마우스 오른쪽 버튼으로 클릭합니다. 대치를 클릭합니다.

  3. 찾기 및 대치 대화상자에 있는 대치 탭의 찾을 내용 상자에, 이전 단계에서 선택한 명령 이름이 표시됩니다. 대화상자를 완료하려면 다음 작업을 수행합니다.
    • 대치 대상 상자에서, 발견한 명령을 대치하는 데 사용하려는 명령 이름을 지정합니다.
    • 명령의 대소문자에 상관없이 해당 명령의 모든 복제를 검색하려는 경우, 대소문자 무시 옵션에서 선택 상자를 취소합니다.
    • 대치하기 전에 명령 이름의 각 복제를 이동하려면 대치를 클릭합니다. 표시된 문자에서, 각 명령의 위치와 트리 노드 또는 특성 창에서의 정확한 위치, 그리고 해당 명령이 발생한 복제의 개수를 봅니다. 명령 리스트에서 명령의 이름을 바꾸면 CUI 파일에서 사용된 명령의 이름을 아무 곳에서나 바꿀 수 있습니다. 이 작업을 명령 취소할 수 없습니다.
    • 명령의 모든 복제를 대치하려면 전체 대치를 클릭합니다. 이 작업을 명령 취소할 수 없습니다.

  4. [닫기]를 클릭합니다.
  5. 사용자 인터페이스 사용자화 편집기에서 닫기를 클릭합니다.


명령 이름 및 검색 문자열 찾기 (요약 참조)

명령 작성, 편집 및 재사용
명령 이름 및 검색 문자열 찾기
명령 레이블 표시 조정
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 명령 사용자화 > 명령 이름 및 검색 문자열 찾기 >
명령 이름 및 검색 문자열 찾기
개념 절차 요약 참조

명령

CUI

작업공간, 도구막대, 메뉴, 바로 가기 메뉴 및 키보드 바로 가기와 같은 사용자화된 사용자 인터페이스 요소를 관리합니다.

시스템 변수

항목이 없습니다.

유틸리티

항목이 없습니다.

명령 수정자

항목이 없습니다.


명령 레이블 표시 조정 (개념)

명령 이름 및 검색 문자열 찾기
명령 사용자화
명령 이미지 작성
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 명령 사용자화 >
명령 레이블 표시 조정
개념 절차 요약 참조

프로그램에서 메뉴 레이블로 명령의 가용성을 표시하는 방식을 조정할 수 있습니다. 메뉴 명령을 그레이 아웃(사용 불가능)하거나, 확인 표시 또는 경계로 표시하거나, 지시자 조합을 사용합니다.

메뉴 명령에는 DIESEL 문자열 표현식도 포함되는데 이 표현식은 표시된 레이블의 문자를 그레이 아웃하거나, 표식으로 표시하거나 또는 대화식으로 변경합니다. DIESEL 표현식에 대한 자세한 정보는 매크로의 DIESEL 표현식을 참고하십시오.

메뉴 레이블 그레이 아웃(사용 불가능)

메뉴의 레이블을 그레이 아웃하려면 틸드 기호(~)를 사용하여 명령의 이름을 시작합니다. 항목과 연관된 명령이 실행되지 않으며 부 메뉴에 접근할 수 없습니다.

다음 예제에서는 틸드 기호(~)를 특성 창의 이름 셀에 있는 링크 복사 명령 레이블의 맨 처음에 놓았습니다.

다음은 편집 메뉴에서 그레이 아웃된 링크 복사 명령의 결과입니다.

명령 레이블에는 표시될 때마다 조건에 따라 명령 레이블을 사용 가능 또는 사용 불가능하게 만드는 DIESEL 문자열 표현식이 포함될 수 있습니다. 예를 들어, 특성 창의 매크로 셀에 DIESEL 문자열 표현식이 있을 경우 다른 모든 명령은 활성화되지만 MOVE 명령은 사용할 수 없게 됩니다.

$(if,$(getvar,cmdactive),~)MOVE^C^C_move

또한 AutoLISP menucmd 함수를 매크로나 응용프로그램에서 항목을 사용 가능 및 사용 불가능 상태로 만드는 데 사용할 수도 있습니다. 예를 들어 풀다운 또는 바로 가기 메뉴 참조를 참고하십시오.

메뉴 레이블 표시

명령에 대한 특성 창의 이름 셀에서 느낌표와 마침표(!.)를 포함함으로써 메뉴 레이블을 표시할 수 있습니다. 메뉴 항목은 다음 두 가지 방법 중 하나로 표시됩니다.

  • 확인 표시메뉴 항목에 해당 메뉴 항목과 연관된 이미지가 없을 때 표시됨
  • 경계메뉴 항목에 해당 메뉴 항목과 연관된 이미지가 있을 때 표시되며 경계는 이미지 주변에 표시됨.

다음 예제는 확인 표시로 표시된 링크 복사 명령 및 경계로 표시된 붙여넣기 명령의 이미지가 있는 편집 메뉴입니다.

명령 레이블에는 표시될 때마다 조건에 따라 명령 레이블을 표시하는 DIESEL 문자열 표현식도 포함될 수 있습니다. 다음 DIESEL 문자열이 특성 창에서 해당 명령에 대해 매크로 셀에 추가된 경우, 관련 시스템 변수가 현재 사용 가능한 메뉴 레이블의 왼쪽에 선택 표시가 놓입니다.

$(if,$(getvar,orthomode),!.)Ortho^O
$(if,$(getvar,snapmode),!.)Snap^B
$(if,$(getvar,gridmode),!.)Grid^G

AutoLISP menucmd 함수를 매크로 또는 응용프로그램의 레이블을 표시하는 데 사용할 수 있습니다. 예를 들어 풀다운 또는 바로 가기 메뉴 참조를 참고하십시오.

동시에 명령 레이블 사용 안하기 및 표시

아래 형식 중 하나를 사용하면 명령을 표시함과 동시에 사용 불가능하게 만들 수 있습니다.

~!. labeltext
!.~ labeltext

틸드 기호(~)는 명령을 사용 불가능하게 하는 특수 문자 코드이며 느낌표와 점(!.)은 명령을 표시하는 특수 문자 코드입니다.

틸드 기호(~), 느낌표와 점(!.)이 특성 창의 이름 셀에서 링크 복사 명령 레이블의 맨 처음에 놓입니다. 다음은 편집 메뉴에서 표시 및 그레이 아웃되는 링크 복사 명령의 결과입니다.

앞의 예제와 마찬가지로 DIESEL 표현식을 사용하여 명령 레이블을 사용 불가능하게 만드는 동시에 레이블에 표식을 달 수 있습니다.

참고

    • 매크로의 DIESEL 표현식

    • 명령의 메뉴 레이블을 그레이 아웃(사용 불가능)하려면 (절차)

    • 명령의 메뉴 레이블을 표시하려면 (절차)

    • 명령 메뉴 레이블을 그레이 아웃(사용 불가능)과 동시에 표시하려면 (절차)


명령 레이블 표시 조정 (절차)

명령 이름 및 검색 문자열 찾기
상위 단계로
명령 레이블 표시 조정
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 명령 사용자화 > 명령 레이블 표시 조정 >
명령 레이블 표시 조정
개념 절차 요약 참조

명령의 메뉴 레이블을 그레이 아웃(사용 불가능)하려면

명령의 메뉴 레이블을 표시하려면

명령 메뉴 레이블을 그레이 아웃(사용 불가능)과 동시에 표시하려면


명령 레이블 표시 조정 (절차)

명령 레이블 표시 조정
상위 단계로
명령 레이블 표시 조정
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 명령 사용자화 > 명령 레이블 표시 조정 >
명령 레이블 표시 조정
개념 절차 요약 참조

명령의 메뉴 레이블을 그레이 아웃(사용 불가능)하려면

  1. 도구 메뉴 [image] 사용자화 [image] 인터페이스를 클릭합니다.명령 프롬프트에서 cui를 입력합니다.
  2. 사용자 인터페이스 사용자화 편집기의 사용자화 탭에 있는 <파일 이름>의 사용자화 창에서 사용 불가능하게 하려는 명령이 포함된 메뉴 옆의 더하기 기호(+)를 클릭합니다.
  3. 그레이 아웃하려는 명령을 클릭합니다.

  4. 특성 창의 이름 셀에서 틸드 기호(~)를 해당 명령의 맨 앞에 추가합니다.

    주명령은 사용자화 창에서 선택해야 합니다. 그렇지 않으면 단순히 명령의 이름을 수정하는 것이며 사용자에게 표시되는 레이블은 수정되지 않습니다.
  5. 확인을 클릭합니다.

    명령에 대한 변경 사항은 변경이 적용되고 CUI 편집기가 닫힌 후에 볼 수 있습니다.


명령 레이블 표시 조정 (절차)

명령 레이블 표시 조정
상위 단계로
명령 레이블 표시 조정
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 명령 사용자화 > 명령 레이블 표시 조정 >
명령 레이블 표시 조정
개념 절차 요약 참조

명령의 메뉴 레이블을 표시하려면

  1. 도구 메뉴 [image] 사용자화 [image] 인터페이스를 클릭합니다.명령 프롬프트에서 cui를 입력합니다.
  2. 사용자 인터페이스 사용자화 편집기의 사용자화 탭에 있는 <파일 이름>의 사용자화 창에서 표시할 명령이 포함된 메뉴 옆의 더하기 기호(+)를 클릭합니다.
  3. 표시하려는 명령을 클릭합니다.

  4. 특성 창의 이름 셀에서 느낌표와 점(!.)을 해당 명령의 맨 앞에 추가합니다.

  5. 확인을 클릭합니다.

    명령에 대한 변경 사항은 변경이 적용되고 CUI 편집기가 닫힌 후에 볼 수 있습니다.


명령 레이블 표시 조정 (절차)

명령 레이블 표시 조정
상위 단계로
명령 이미지 작성
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 명령 사용자화 > 명령 레이블 표시 조정 >
명령 레이블 표시 조정
개념 절차 요약 참조

명령 메뉴 레이블을 그레이 아웃(사용 불가능)과 동시에 표시하려면

  1. 도구 메뉴 [image] 사용자화 [image] 인터페이스를 클릭합니다.명령 프롬프트에서 cui를 입력합니다.
  2. 사용자 인터페이스 사용자화 편집기의 사용자화 탭에 있는 <파일 이름>의 사용자화 창에서 사용 불가능하게 하고 표시할 명령이 포함된 메뉴 옆의 더하기 기호(+)를 클릭합니다.
  3. 그레이 아웃하고 표시하려는 명령을 클릭합니다.
  4. 특성 창의 이름 셀에서 틸드 기호, 느낌표와 점(~!. 또는 !.~)을 해당 명령의 맨 앞에 추가합니다.
  5. 확인을 클릭합니다.


명령 레이블 표시 조정 (요약 참조)

명령 이름 및 검색 문자열 찾기
명령 레이블 표시 조정
명령 이미지 작성
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 명령 사용자화 > 명령 레이블 표시 조정 >
명령 레이블 표시 조정
개념 절차 요약 참조

명령

CUI

작업공간, 도구막대, 메뉴, 바로 가기 메뉴 및 키보드 바로 가기와 같은 사용자화된 사용자 인터페이스 요소를 관리합니다.

시스템 변수

항목이 없습니다.

유틸리티

항목이 없습니다.

명령 수정자

항목이 없습니다.


명령 이미지 작성 (개념)

명령 레이블 표시 조정
명령 사용자화
상태 행 도움말 메시지 작성
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 명령 사용자화 >
명령 이미지 작성
개념 절차 요약 참조

이미지는 명령과 연관될 수 있으며 도구막대 버튼 또는 풀다운 메뉴의 메뉴 항목 옆에 표시됩니다. 프로그램에서 제공하는 이미지를 사용하거나 직접 이미지를 작성할 수 있습니다.

표시: 사용자 이미지를 작성하고 이 이미지를 명령에 지정

다음 이미지 아래의 재생 화살표를 클릭하여 애니메이션을 시작합니다.

아래 애니매이션은 사용자 이미지를 작성하고 이 이미지를 사용자 명령에 지정하는 방법을 보여줍니다. 그러나 사용자 명령을 작성하는 방법을 보여주지는 않습니다. 사용자 명령을 작성하는 방법에 대한 정보는 명령 작성, 편집 및 재사용을 참조하십시오.

Autodesk는 명령을 시작하는 버튼에 표준 버튼 이미지를 제공합니다. 사용자 버튼 이미지를 작성하여 사용자 매크로를 실행할 수 있습니다. 기존 버튼 이미지를 수정하거나 자신의 고유 이미지를 작성할 수 있습니다. 버튼 이미지는 BMP 파일로 저장됩니다. BMP 파일을 해당 BMP 파일이 참조하는 CUI 파일로 같은 폴더에 저장해야 합니다.

사용자 정의 비트맵은 버튼 및 플라이아웃 명령의 작은 이미지 및 큰 이미지 자원 이름 위치에서 사용할 수 있습니다.

작은 이미지는 16 x 16 픽셀이어야 합니다. 큰 이미지는 32 x 32 픽셀이어야 합니다. 이 크기와 일치하지 않는 이미지는 꼭 맞게 축척됩니다.

참고

    • 파일 구성에 대한 개요

    • 버튼 이미지를 편집 또는 작성하려면 (절차)

    • 표준 이미지를 명령에 지정하려면 (절차)

    • 사용자 이미지를 명령에 지정하려면 (절차)

    • 사용자 이미지를 이미지 리스트로 가져오려면 (절차)


명령 이미지 작성 (절차)

명령 레이블 표시 조정
상위 단계로
명령 이미지 작성
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 명령 사용자화 > 명령 이미지 작성 >
명령 이미지 작성
개념 절차 요약 참조

버튼 이미지를 편집 또는 작성하려면

표준 이미지를 명령에 지정하려면

사용자 이미지를 명령에 지정하려면

사용자 이미지를 이미지 리스트로 가져오려면


명령 이미지 작성 (절차)

명령 이미지 작성
상위 단계로
명령 이미지 작성
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 명령 사용자화 > 명령 이미지 작성 >
명령 이미지 작성
개념 절차 요약 참조

버튼 이미지를 편집 또는 작성하려면

  1. 도구 메뉴 [image] 사용자화 [image] 인터페이스를 클릭합니다.명령 프롬프트에서 cui를 입력합니다.
  2. 사용자 인터페이스 사용자화 편집기의 사용자화 탭에 있는 명령 리스트 창 또는 <파일 이름>의 사용자화 창에서 명령을 클릭하여 버튼 이미지 창(오른쪽 맨 위)을 표시합니다.

  3. 버튼 이미지 창에서 작성하려는 버튼의 모양과 가장 닮은 버튼을 클릭합니다. [편집]을 클릭합니다.
    팁빈 이미지로 시작하려면, 버튼 이미지 창 아래의 리스트에서 이미지를 선택합니다. 편집을 클릭하여 버튼 편집기를 시작합니다. 버튼 편집기에서 왼쪽에 있는 지우기를 클릭합니다.
  4. 버튼 편집기에서 연필, 선, 원 및 지우기 버튼을 사용하여 버튼 이미지를 작성하거나 편집합니다. 색상을 사용하려면 색상 팔레트에서 색상을 선택하거나 자세히를 클릭하여 색상 선택 대화상자를 엽니다.
    • 연필 버튼 선택한 색상으로 한 번에 한 픽셀을 편집합니다. 좌표 입력 장치를 끌어 여러 픽셀을 한 번에 편집할 수도 있습니다.
    • 선 버튼 선택한 색상으로 선을 작성합니다. 마우스 왼쪽 버튼을 클릭하여 선의 첫 번째 끝점을 설정합니다. 마우스 왼쪽 버튼을 누른채로 끌어 선을 그립니다. 마우스 왼쪽 버튼을 놓으면 선이 완성됩니다.
    • 원 버튼 선택한 색상으로 원을 작성합니다. 마우스 왼쪽 버튼을 클릭하여 원의 중심을 설정합니다. 마우스 왼쪽 버튼을 누른채로 끌어 반지름을 설정합니다. 마우스 왼쪽 버튼을 놓으면 원이 완성됩니다.
    • 지우기 버튼 한 번에 한 픽셀의 색상을 흰색에 가까운 색상으로 재설정합니다.
    주플라이아웃 버튼은 편집할 수 없습니다.
  5. 사용자화한 버튼을 BMP 파일로 저장하려면 저장을 클릭합니다. 버튼을 다른 이름으로 저장하려면 다른 이름으로 저장을 사용합니다. 새 버튼 이미지를 다음 위치에 저장합니다.

    C:\Documents and Settings\<사용자 프로파일 이름>\Application Data\Autodesk\<제품 이름>\<릴리즈 번호>\<언어>\Support\Icons

    주버튼은 BMP 형식(*.bmp, *.rle, 또는 *.dib)으로만 저장할 수 있습니다.

    버튼 이미지를 저장하는 경우, 버튼 편집기는 옵션 대화상자의 파일 탭에 있는 사용자 아이콘 위치에 정의된 폴더를 기본값으로 지정합니다. 이 폴더에 있는 버튼 이미지 파일은 사용자 설정값 마이그레이션 대화상자를 사용해 향후 릴리즈에서 마이그레이션할 수 있습니다.


명령 이미지 작성 (절차)

명령 이미지 작성
상위 단계로
명령 이미지 작성
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 명령 사용자화 > 명령 이미지 작성 >
명령 이미지 작성
개념 절차 요약 참조

표준 이미지를 명령에 지정하려면

  1. 도구 메뉴 [image] 사용자화 [image] 인터페이스를 클릭합니다.명령 프롬프트에서 cui를 입력합니다.
  2. 사용자 인터페이스 사용자화 편집기에 있는 사용자화 탭의 명령 리스트 창에서 임의의 명령을 클릭하여 버튼 이미지 창(오른쪽 상단 구석에 있음) 및 특성 창(오른쪽 하단 구석에 있음)을 표시합니다.

  3. 버튼 이미지 창에서 3개의 이미지 지정 옵션 중 하나(큼, 작음, 모두)를 선택합니다.

  4. 이미지 리스트에서 이미지를 선택하면 이미지 이름은 선택된 명령의 작은 및/또는 큰 이미지 특성에 지정됩니다.

    주이미지 리스트에서 이미지를 선택하면 해당 이미지의 미리보기와 버튼 이미지 창의 편집 버튼 사이에 이미지 이름이 표시됩니다. 이미지가 비트맵 파일에 저장된 사용자 이미지인 경우 해당 파일 이름이 표시됩니다.


명령 이미지 작성 (절차)

명령 이미지 작성
상위 단계로
명령 이미지 작성
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 명령 사용자화 > 명령 이미지 작성 >
명령 이미지 작성
개념 절차 요약 참조

사용자 이미지를 명령에 지정하려면

  1. 도구 메뉴 [image] 사용자화 [image] 인터페이스를 클릭합니다.명령 프롬프트에서 cui를 입력합니다.
  2. 사용자 인터페이스 사용자화 편집기에 있는 사용자화 탭의 명령 리스트 창에서 임의의 명령을 클릭하여 버튼 이미지 창(오른쪽 상단 구석에 있음) 및 특성 창(오른쪽 하단 구석에 있음)을 표시합니다.

  3. 특성 창에서 작은 이미지 특성 옆에 있는 필드를 선택합니다. 타원 버튼은 특성의 오른쪽에 표시됩니다.
  4. 특성 옆의 타원 버튼을 클릭합니다.

  5. 이미지 파일 선택 대화상자에서 명령에 사용할 이미지 파일을 찾습니다.
  6. 명령의 큰 이미지 특성에 대해서도 3~6 단계를 반복합니다.


명령 이미지 작성 (절차)

명령 이미지 작성
상위 단계로
상태 행 도움말 메시지 작성
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 명령 사용자화 > 명령 이미지 작성 >
명령 이미지 작성
개념 절차 요약 참조

사용자 이미지를 이미지 리스트로 가져오려면

  1. 도구 메뉴 [image] 사용자화 [image] 인터페이스를 클릭합니다.명령 프롬프트에서 cui를 입력합니다.
  2. 사용자 인터페이스 사용자화 편집기의 사용자화 탭에 있는 명령 리스트 창에서 버튼 이미지 창에 표시할 명령을 클릭합니다.
  3. 버튼 이미지 창의 이미지 리스트에 마우스 오른쪽 버튼을 클릭하고 이미지 가져오기를 선택합니다.

  4. 열기 대화상자에서 가져올 BMP 이미지 파일을 찾아보고 선택한 다음 열기를 클릭합니다.
  5. 버튼 이미지 창에서 이미지 지정 옵션(큰, 작은, 모두)을 선택한 다음 이미지 리스트에서 가져온 이미지를 선택합니다.


명령 이미지 작성 (요약 참조)

명령 레이블 표시 조정
명령 이미지 작성
상태 행 도움말 메시지 작성
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 명령 사용자화 > 명령 이미지 작성 >
명령 이미지 작성
개념 절차 요약 참조

명령

CUI

작업공간, 도구막대, 메뉴, 바로 가기 메뉴 및 키보드 바로 가기와 같은 사용자화된 사용자 인터페이스 요소를 관리합니다.

시스템 변수

TOOLTIPS

도구막대에 툴팁의 표시를 제어합니다.

유틸리티

항목이 없습니다.

명령 수정자

항목이 없습니다.


상태 행 도움말 메시지 작성 (개념)

명령 이미지 작성
명령 사용자화
매크로 작성
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 명령 사용자화 >
상태 행 도움말 메시지 작성
개념 절차 요약 참조

상태 행 도움말 메시지는 좌표 입력 장치가 메뉴 옵션 또는 도구막대 버튼 위에 멈출 때 상태 행(도면 영역의 맨 아래)에 표시되는 간단한 설명 메시지입니다. 관련된 명령에 대한 설명 특성을 업데이트하여 메뉴 및 버튼의 설명을 변경하거나 추가할 수 있습니다.

참고

    • 상태 행 도움말 메시지를 작성하려면 (절차)


상태 행 도움말 메시지 작성 (절차)

명령 이미지 작성
상위 단계로
도구막대 사용자화
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 명령 사용자화 > 상태 행 도움말 메시지 작성 >
상태 행 도움말 메시지 작성
개념 절차 요약 참조

상태 행 도움말 메시지를 작성하려면

  1. 도구 메뉴 [image] 사용자화 [image] 인터페이스를 클릭합니다.명령 프롬프트에서 cui를 입력합니다.
  2. 사용자 인터페이스 사용자화 편집기에서 사용자화 탭을 클릭합니다.
  3. 명령 리스트 창에서 도움말 메시지를 추가하려는 명령을 클릭합니다.

    특성 창은 대화상자의 오른쪽에 표시됩니다.

  4. 특성 창의 설명 상자에 선택한 명령에 대한 설명 문자를 입력합니다.

  5. 적용 버튼을 클릭합니다.

    다음에 이 명령을 사용할 때에는 도구막대 버튼이나 메뉴 항목 위에 마우스 버튼을 가져갈 때 추가했던 설명 문자가 상태 행에 표시됩니다.


상태 행 도움말 메시지 작성 (요약 참조)

명령 이미지 작성
상태 행 도움말 메시지 작성
매크로에서 특수 조정 문자 사용
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 명령 사용자화 > 상태 행 도움말 메시지 작성 >
상태 행 도움말 메시지 작성
개념 절차 요약 참조

명령

CUI

작업공간, 도구막대, 메뉴, 바로 가기 메뉴 및 키보드 바로 가기와 같은 사용자화된 사용자 인터페이스 요소를 관리합니다.

시스템 변수

항목이 없습니다.

유틸리티

항목이 없습니다.

명령 수정자

항목이 없습니다.


매크로 작성

상태 행 도움말 메시지 작성
사용자 인터페이스 사용자화
매크로에서 특수 조정 문자 사용
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 >
매크로 작성

매크로는 인터페이스 요소가 선택될 경우 발생하는 작업을 정의합니다. 매크로는 사용자가 수행해야 할 일련의 도면 작업을 단일 작업으로 수행합니다. 매크로는 명령, 특수 문자, DIESEL(Direct Interpretively Evaluated String Expression Language) 또는 AutoLISP 프로그래밍 코드를 포함할 수 있습니다.

주AutoCAD가 개정되고 향상됨에 따라 여러 명령에 대한 프롬프트 순서 및 경우에 따라 명령 이름이 변경될 수 있습니다. 따라서 새로운 AutoCAD 릴리즈로 업그레이드할 때는 사용자 매크로를 다소 변경해야 할 수 있습니다.

사용자 인터페이스 사용자화 편집기를 사용하여 매크로를 인터페이스 요소에 추가합니다. 명령 리스트 창에서 기존 명령을 선택하거나 새 명령을 작성합니다. 특성 창의 매크로 섹션에 매크로를 입력합니다. 매크로의 길이에는 제한이 없습니다. 그러나 매크로에 어떤 특수 문자가 사용되었는지 알아야 하며 기타 고려사항이나 제한사항을 알고 있어야 합니다.

매크로 기본

사용자 인터페이스 요소의 매크로는 명령(예: circle) 및 특수 문자(예: ^C^C)와 같이 간단할 수 있습니다.

예를 들어 ^C^C_circle \1 매크로는 1단위의 반지름으로 원을 그립니다. 아래 테이블에서 이 매크로를 정의하는 구성요소에 대해 설명합니다.

CIRCLE 매크로의 구성요소
구성요소 | 구성요소 유형 | 결과
^C^C | 특수 조정 문자 | 실행 중인 명령 취소
_ | 특수 조정 문자 | 다른 언어로 따라 오는 명령을 자동 변환합니다.
CIRCLE | 명령 | CIRCLE 명령 시작
\ | 특수 조정 문자 | 사용자가 중심점을 지정할 수 있도록 일시 중지를 작성합니다.
1 | 특수 조정 문자 | 원의 반지름(1)에 대한 프롬프트에 응답

매크로에서 사용할 수 있는 특수 조정 문자의 리스트를 보려면 매크로에서 특수 조정 문자 사용을 참고하십시오.

실행 중인 명령 취소

매크로를 실행하기 전에 진행 중인 AutoCAD 명령이 없는지 확인합니다. 매크로를 실행하기 전에 명령을 자동으로 취소하려면, 매크로의 시작 부분에서 ^C^C를 입력합니다. 이는 ESC 키를 두 번 누르는 것과 같습니다. 단일 ^C를 사용해도 대부분의 명령이 취소되지만 치수기입 명령에서 명령 프롬프트로 되돌아가려면 ^C^C를 사용하고 도면층 명령의 현재 옵션을 기반으로 하여 ^C^C^C를 사용해야 합니다. ^C^C는 대부분의 명령 순서 취소를 처리하기 때문에 매크로가 시작되기 전에 명령이 활성화되지 않도록 하는 데 사용되는 권장 순서입니다.

매크로 문자 검증

매크로의 모든 문자가 중요하며 공백도 중요합니다.

매크로의 끝부분에 공백을 둘 경우, 명령(예: circle)을 입력하고 SPACEBAR 키를 눌러 명령을 종료했을지라도 AutoCAD는 매크로를 처리합니다.

매크로 종료

일부 매크로에는 특수 종료자가 필요합니다. 일부 명령(예: TEXT)은 종료하려면 SPACEBAR 키가 아닌 ENTER 키를 눌러야 합니다. 일부 명령은 둘 이상의 공백(또는 ENTER)이 있어야 완료되지만, 일부 문자 편집기는 뒤에 공백이 오는 행을 작성할 수 없습니다.

두 가지 특수 규칙이 이 문제를 해결해줍니다.

  • 매크로의 세미콜론(;)은 명령 프롬프트에서 자동으로 ENTER를 실행합니다.
  • 행이 조정 문자, 역슬래쉬(\), 더하기 기호(+) 또는 세미콜론(;)으로 끝나는 경우 AutoCAD는 그 뒤에 빈 공간을 추가하지 않습니다.

역슬래쉬(\)로 끝나는 항목은 사용자 입력을 위해 매크로를 일시 중지시킵니다.

다음 매크로를 비교합니다.

ucs
ucs ;

첫 번째 예제는 명령 프롬프트에 ucs를 입력하고 SPACEBAR를 누릅니다. 다음 프롬프트가 표시됩니다.

UCS의 원점 지정 또는 [면(F)/이름(NA)/객체(OB)/이전(P)/뷰(V)/표준(W)/X/Y/Z/Z축(ZA)] <표준(W)>:

두 번째 예제는 ucs를 입력하고 SPACEBAR 키를 누른 후 ENTER 키를 눌러 기본값(표준)을 승인합니다.

매크로에서 반향 및 프롬프트 억제

매크로의 문자는 키보드에서 해당 문자를 입력했더라도 명령 윈도우에 나타납니다. 이 문자는 또한 사용자 인터페이스 요소에 표시됩니다. 이 표시 중복을 “반향”이라고 합니다. MENUECHO 시스템 변수를 사용하여 “반향된” 표시를 억제할 수 있습니다. 항목 입력에서 반향 및 프롬프트가 꺼지는 경우 항목의 ^P가 해당 반향 및 프롬프트를 끕니다.

긴 매크로 작성

행의 끝에 특수 문자를 사용하지 않고 매크로의 길이에 상관없이 매크로를 작성할 수 있습니다. 사용자 인터페이스 사용자화 편집기의 특성 창에서 매크로의 모든 길이를 승인합니다.

이 단원의 항목

  • 매크로에서 특수 조정 문자 사용

    매크로에서 조정 문자를 포함하는 특수 문자를 사용할 수 있습니다. 매크로에서 탈자 기호(^)는 키보드에서 Ctrl 키를 누르는 것과 같습니다. 탈자 기호를 다른 문자와 결합하여 모눈을 켜고 끄거나(^G) 명령을 취소하는(^C) 것과 같은 작업을 하는 매크로를 구성할 수 있습니다 .

  • 매크로에서 사용자 입력을 위해 일시 중지

    명령의 중간에서 키보드나 좌표 입력 장치의 입력을 승인하려면 입력하려는 지점의 매크로에 역슬래쉬(\)를 둡니다.

  • 매크로에서 국제 지원 제공

    비영어로 된 AutoCAD 언어 버전에 사용할 수 있는 메뉴를 개발하려면 각 명령이나 옵션 앞에 밑줄 문자(_)를 둡니다. 밑줄 문자를 사용하면 표준 명령 및 옵션이 자동으로 번역됩니다.

  • 매크로에서 내장된 명령 사용

    AutoCAD의 일부인 내장된 명령을 사용하는 매크로를 개발하려면 각 명령 앞에 마침표 문자(.)를 표시합니다. 마침표 문자를 사용하면 같은 사용자화 파일을 공유하는 다른 시스템에서 사용될 때 매크로를 단정할 수 있는 UNDEFINE 명령으로 정의되어 있지 않아도 내장된 명령을 사용할 수 있습니다.

  • 매크로에서 명령 반복

    선행 별표(*)를 사용하여 다른 명령을 선택할 때까지 매크로에서 명령을 반복할 수 있습니다.

  • 매크로에서 단일 객체 선택 모드 사용

    단일 객체 선택 모드는 편집 명령에서 객체 선택 프롬프트의 일반적인 반복을 취소합니다. 하나의 객체를 선택하고 다른 모든 프롬프트에 응답하고 나면 명령이 끝납니다.

  • 매크로를 사용하여 사용자 인터페이스 요소 교체

    활성 메뉴, 마우스 버튼, 타블렛 버튼, 타블렛 메뉴 또는 화면 메뉴의 내용을 대치할 수 있습니다. 교체된 내용은 주 CUI 파일에서 같은 유형의 다른 사용자 인터페이스 요소가 될 수도 있으며 부분적 CUI 파일의 요소가 될 수도 있습니다.

  • 매크로에서 조건부 표현식 사용

    DIESEL(Direct Interpretively Evaluated String Expression Language)로 작성된 매크로 표현식을 소개하는 명령을 사용하여 매크로에 조건부 표현식을 추가할 수 있습니다.

  • 매크로에서 AutoLISP 사용

    AutoLISP를 사용하는 명령을 작성하는 것은 AutoCAD 사용자화 기능을 사용하는 보다 발전된 방법입니다.


매크로에서 특수 조정 문자 사용 (개념)

매크로 작성
매크로 작성
매크로에서 사용자 입력을 위해 일시 중지
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 매크로 작성 >
매크로에서 특수 조정 문자 사용
개념 요약 참조

매크로에서 조정 문자를 포함하는 특수 문자를 사용할 수 있습니다. 매크로에서 탈자 기호(^)는 키보드에서 Ctrl 키를 누르는 것과 같습니다. 탈자 기호를 다른 문자와 결합하여 모눈을 켜고 끄거나(^G) 명령을 취소하는(^C) 것과 같은 작업을 하는 매크로를 구성할 수 있습니다 .

아래의 주소 명령에 대한 매크로에서는 사용자가 입력할 수 있도록 일시 중지하기 위해 역슬래쉬(\)를 사용하고 ENTER 키 역할을 하는 세미콜론(;)을 사용합니다.

text \.4 0 DRAFT Inc;;;Main St.;;;City, State;

매크로는 TEXT 명령을 시작하고 사용자가 시작점을 지정하도록 일시 중지한 다음 3행에 주소를 입력합니다. 3중 세미콜론(;;;)에서 첫 번째 세미콜론은 문자열을 끝내고, 두 번째는 TEXT를 반복하며, 세 번째는 이전 행 아래의 기본 배치를 받아들입니다.

매크로는 다음 테이블에 나열된 특수 문자를 사용합니다.

매크로에서 사용되는 특수 문자
문자 | 설명
; | ENTER 키를 실행합니다.
^M | ENTER 키를 실행합니다.
^I | TAB 키를 실행합니다.
[공백] | 공백을 입력합니다. 명령에서 명령 순서 사이의 공백은 SPACEBAR 키를 누르는 것과 같습니다.
\ | 사용자 입력을 위해 일시 중지합니다(가속기와 함께 사용할 수 없음).
. | UNDEFINE 명령 사용이 정의되지 않아도 내장된 AutoCAD 명령에 액세스할 수 있습니다.
_ | AutoCAD 명령과 그 뒤에 오는 옵션을 변환합니다.
=* | 현재의 최상위 수준 풀다운, 바로 가기 또는 이미지 메뉴를 표시합니다.
*^C^C | 다른 명령을 선택할 때까지 명령을 반복합니다.
$ | 조건부 DIESEL 매크로 표현식($M=)을 소개합니다.
^B | 스냅을 켜거나 끕니다(Ctrl+B와 같음).
^C | 활성 명령 또는 명령 옵션을 취소합니다(ESC와 같음).
^D | 동적 UCS를 켜거나 끕니다(Ctrl+D에 해당됨).
^E | 다음 등각투영 평면을 설정합니다(Ctrl+E와 같음).
^G | 모눈을 켜거나 끕니다(Ctrl+G와 같음).
^H | BACKSPACE를 실행합니다.
^O | 직교를 켜거나 끕니다.
^P | MENUECHO를 켜거나 끕니다.
^Q | 모든 프롬프트, 상태 리스트 및 입력을 프린터로 반향합니다(Ctrl+Q와 같음).
^T | 타블렛을 켜거나 끕니다(Ctrl+T와 같음).
^V | 현재 뷰포트를 변경합니다.
^Z | 명령의 끝에 SPACEBAR 키의 자동 추가를 억제하는 NULL 문자입니다.


매크로에서 특수 조정 문자 사용 (요약 참조)

상태 행 도움말 메시지 작성
매크로에서 특수 조정 문자 사용
매크로에서 사용자 입력을 위해 일시 중지
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 매크로 작성 > 매크로에서 특수 조정 문자 사용 >
매크로에서 특수 조정 문자 사용
개념 요약 참조

명령

CUI

작업공간, 도구막대, 메뉴, 바로 가기 메뉴 및 키보드 바로 가기와 같은 사용자화된 사용자 인터페이스 요소를 관리합니다.

CUILOAD

CUI 파일 로드

CUIUNLOAD

CUI 파일 언로드

시스템 변수

항목이 없습니다.

유틸리티

항목이 없습니다.

명령 수정자

항목이 없습니다.


매크로에서 사용자 입력을 위해 일시 중지 (개념)

매크로에서 특수 조정 문자 사용
매크로 작성
매크로에서 국제 지원 제공
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 매크로 작성 >
매크로에서 사용자 입력을 위해 일시 중지
개념 요약 참조

명령의 중간에서 키보드나 좌표 입력 장치의 입력을 승인하려면 입력하려는 지점의 매크로에 역슬래쉬(\)를 둡니다.

circle \1

circle 예제에서, \1은 사용자가 중심점을 지정하도록 일시 중지한 다음 반지름 1을 읽습니다. 역슬래쉬 뒤에는 공백이 들어가지 않습니다.

-layer off \;

이 예제에서 매크로는 명령 프롬프트에서 LAYER를 시작하고(-layer) Off 옵션을 입력한 다음(off) 사용자가 도면층 이름을 입력하도록 일시 중지합니다(\). 그 다음 매크로는 해당 도면층을 끄고 LAYER 명령(;)을 종료합니다.

주일반적으로 LAYER는 다른 작업에 대한 프롬프트를 표시하며, SPACEBAR 또는 ENTER 키를 누를 경우에만 종료됩니다. 매크로에서 세미콜론(;)은 ENTER 키를 누르는 것과 동일합니다.

매크로는 일반적으로 한 번의 사용자 입력(예: 단일 점 위치) 이후에 계속됩니다. 그러므로 다양한 수의 입력(객체 선택에서와 같이)을 수용하고 계속하는 매크로를 구성할 수는 없습니다. 그러나 SELECT에서는 예외입니다. 즉, 객체 선택이 완료될 때까지 역슬래쉬(\)는 SELECT 명령을 중단합니다. 다음과 같은 예를 가정해 봅시다.

select \change previous ;properties color red ;

이 매크로에서 SELECT는 하나 이상의 객체에 대한 선택 세트를 작성합니다(select \). 그 다음 매크로는 CHANGE를 시작하고(change), [이전] 옵션을 사용하여 선택 세트를 참조하고(previous;), 선택된 모든 객체의 색상을 빨간색으로 변경합니다(properties color red ;).

주역슬래쉬 문자(\)는 매크로가 사용자 입력을 위해 일시 중지하도록 합니다. 매크로에서 다른 목적으로 역슬래쉬를 사용할 수 없습니다. 파일 디렉토리 경로를 지정해야 할 경우, 경로 구분자로 슬래쉬(/)를 사용합니다. 예: /direct/file.

다음과 같은 경우에는 일시 중지 후에 매크로의 재개가 지연됩니다.

  • 점 위치의 입력이 예상되는 경우, 점을 지정하기 전에 객체 스냅 모드를 사용할 수 있습니다.
  • X/Y/Z 점 필터가 사용되는 경우, 전체 점이 누적될 때까지 명령이 일시 중단됩니다.
  • SELECT의 경우에만 객체 선택이 완료될 때까지 매크로가 재개되지 않습니다.
  • 사용자가 투명 명령으로 응답하는 경우, 투명 명령이 완료되고 처음에 요청한 입력을 수신할 때까지 매크로가 중단된 상태로 유지됩니다.
  • 사용자가 옵션을 제공하거나 투명 명령을 실행하기 위해 또 다른 명령을 선택함으로써 응답하는 경우, 원래의 매크로가 중단되며 새로 선택한 항목이 끝까지 처리됩니다. 그 다음에 중단된 매크로가 재개됩니다.
주명령 입력이 명령에서 나올 경우 PICKADD 및 PICKAUTO 시스템 변수의 설정값은 각각 1과 0으로 간주됩니다. 그러면 이전 AutoCAD 릴리즈와의 호환성이 유지되며, 이들 변수의 설정을 검사할 필요가 없으므로 더 쉽게 사용자화할 수 있습니다.


매크로에서 사용자 입력을 위해 일시 중지 (요약 참조)

매크로에서 특수 조정 문자 사용
매크로에서 사용자 입력을 위해 일시 중지
매크로에서 국제 지원 제공
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 매크로 작성 > 매크로에서 사용자 입력을 위해 일시 중지 >
매크로에서 사용자 입력을 위해 일시 중지
개념 요약 참조

명령

CHANGE

기존 객체의 특성을 변경합니다.

SELECT

선택한 객체를 이전 선택 세트에 배치합니다.

시스템 변수

PICKADD

이후의 선택 사항이 현재 선택 세트를 대체할지 또는 현재 선택 세트에 추가할지 조정합니다

PICKAUTO

객체 선택 프롬프트에서 자동 윈도우 기능을 조정합니다

유틸리티

항목이 없습니다.

명령 수정자

항목이 없습니다.


매크로에서 국제 지원 제공 (개념)

매크로에서 사용자 입력을 위해 일시 중지
매크로 작성
매크로에서 내장된 명령 사용
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 매크로 작성 >
매크로에서 국제 지원 제공
개념 요약 참조

비영어로 된 AutoCAD 언어 버전에 사용할 수 있는 메뉴를 개발하려면 각 명령이나 옵션 앞에 밑줄 문자(_)를 둡니다. 밑줄 문자를 사용하면 표준 명령 및 옵션이 자동으로 번역됩니다.


매크로에서 국제 지원 제공 (요약 참조)

매크로에서 사용자 입력을 위해 일시 중지
매크로에서 국제 지원 제공
매크로에서 내장된 명령 사용
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 매크로 작성 > 매크로에서 국제 지원 제공 >
매크로에서 국제 지원 제공
개념 요약 참조

명령

CHANGE

기존 객체의 특성을 변경합니다.

SELECT

선택한 객체를 이전 선택 세트에 배치합니다.

시스템 변수

PICKADD

이후의 선택 사항이 현재 선택 세트를 대체할지 또는 현재 선택 세트에 추가할지 조정합니다

PICKAUTO

객체 선택 프롬프트에서 자동 윈도우 기능을 조정합니다

유틸리티

항목이 없습니다.

명령 수정자

항목이 없습니다.


매크로에서 내장된 명령 사용 (개념)

매크로에서 국제 지원 제공
매크로 작성
매크로에서 명령 반복
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 매크로 작성 >
매크로에서 내장된 명령 사용
개념 요약 참조

AutoCAD의 일부인 내장된 명령을 사용하는 매크로를 개발하려면 각 명령 앞에 마침표 문자(.)를 표시합니다. 마침표 문자를 사용하면 같은 사용자화 파일을 공유하는 다른 시스템에서 사용될 때 매크로를 단정할 수 있는 UNDEFINE 명령으로 정의되어 있지 않아도 내장된 명령을 사용할 수 있습니다.


매크로에서 내장된 명령 사용 (요약 참조)

매크로에서 국제 지원 제공
매크로에서 내장된 명령 사용
매크로에서 명령 반복
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 매크로 작성 > 매크로에서 내장된 명령 사용 >
매크로에서 내장된 명령 사용
개념 요약 참조

명령

REDEFINE

UNDEFINE에 의해 재지정된 AutoCAD 내부 명령을 복원합니다.

UNDEFINE

응용프로그램에서 정의한 명령이 내부 명령을 재지정할 수 있도록 합니다.

시스템 변수

항목이 없습니다.

유틸리티

항목이 없습니다.

명령 수정자

항목이 없습니다.


매크로에서 명령 반복 (개념)

매크로에서 내장된 명령 사용
매크로 작성
매크로에서 단일 객체 선택 모드 사용
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 매크로 작성 >
매크로에서 명령 반복
개념 요약 참조

선행 별표(*)를 사용하여 다른 명령을 선택할 때까지 매크로에서 명령을 반복할 수 있습니다.

명령을 선택한 다음 다른 명령으로 이동하기 전에 여러 번 사용하게 될 경우가 있습니다. 다른 명령을 선택할 때까지 매크로에서 명령을 반복할 수 있습니다. 옵션을 선택할 때는 이 기능을 사용할 수 없습니다.

매크로가 *^C^C로 시작할 경우, 키보드에서 ESC 키를 누르거나 다른 명령을 선택하여 종료할 때까지 명령이 반복됩니다.

주매크로 반복이 취소되므로 *^C^C 문자열로 시작되는 매크로에서는 ^C(취소)를 사용하지 마십시오.

다음 예제에서 매크로는 명령을 반복합니다.

*^C^Cmove Single
*^C^Ccopy Single
*^C^Cerase Single
*^C^Cstretch Single Crossing
*^C^Crotate Single
*^C^Cscale Single

예제에 있는 각 매크로는 명령을 시작한 다음 객체를 선택하는 프롬프트를 표시합니다. 명령을 완료하는 데 필요한 다른 모든 프롬프트가 표시되고 나면 명령이 끝나고 다시 시작됩니다.

주이미지 배열 메뉴의 경우에는 매크로에 명령 반복을 사용할 수 없습니다.


매크로에서 명령 반복 (요약 참조)

매크로에서 내장된 명령 사용
매크로에서 명령 반복
매크로에서 단일 객체 선택 모드 사용
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 매크로 작성 > 매크로에서 명령 반복 >
매크로에서 명령 반복
개념 요약 참조

명령

항목이 없습니다.

시스템 변수

항목이 없습니다.

유틸리티

항목이 없습니다.

명령 수정자

항목이 없습니다.


매크로에서 단일 객체 선택 모드 사용 (개념)

매크로에서 명령 반복
매크로 작성
매크로를 사용하여 사용자 인터페이스 요소 교체
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 매크로 작성 >
매크로에서 단일 객체 선택 모드 사용
개념 요약 참조

단일 객체 선택 모드는 편집 명령에서 객체 선택 프롬프트의 일반적인 반복을 취소합니다. 하나의 객체를 선택하고 다른 모든 프롬프트에 응답하고 나면 명령이 끝납니다.

다음 예제의 매크로를 고려해 봅시다.

*^C^Cerase single

이 매크로는 현재 명령을 종료하고 단일 객체 선택 모드에서 ERASE를 시작합니다. 이 명령을 선택한 후, 삭제할 단일 객체를 선택하거나 도면의 빈 영역을 클릭하고 창 선택을 지정합니다. 이러한 방식으로 선택한 모든 객체는 지워지며 앞에 별표가 있기 때문에 추가로 객체를 지울 수 있도록 명령이 반복됩니다. ESC 키를 눌러 이 모드를 종료합니다.


매크로에서 단일 객체 선택 모드 사용 (요약 참조)

매크로에서 명령 반복
매크로에서 단일 객체 선택 모드 사용
매크로를 사용하여 사용자 인터페이스 요소 교체
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 매크로 작성 > 매크로에서 단일 객체 선택 모드 사용 >
매크로에서 단일 객체 선택 모드 사용
개념 요약 참조

명령

항목이 없습니다.

시스템 변수

항목이 없습니다.

유틸리티

항목이 없습니다.

명령 수정자

항목이 없습니다.


매크로를 사용하여 사용자 인터페이스 요소 교체 (개념)

매크로에서 단일 객체 선택 모드 사용
매크로 작성
매크로에서 조건부 표현식 사용
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 매크로 작성 >
매크로를 사용하여 사용자 인터페이스 요소 교체
개념 요약 참조

활성 메뉴, 마우스 버튼, 타블렛 버튼, 타블렛 메뉴 또는 화면 메뉴의 내용을 대치할 수 있습니다. 교체된 내용은 주 CUI 파일에서 같은 유형의 다른 사용자 인터페이스 요소가 될 수도 있으며 부분적 CUI 파일의 요소가 될 수도 있습니다.

다른 유형의 인터페이스 요소(예: 메뉴, 마우스 버튼)를 교체할 수는 없습니다. 그러나 지정된 유형 내에서 다른 요소에 대한 사용자 인터페이스 요소는 교체할 수 있습니다.

주보통 매크로 수가 모두 같지 않기 때문에 타블렛 메뉴의 경우에는 교체로 인해 이상한 동작이 발생할 수 있습니다.

매크로에서 다음 구문을 사용하여 요소를 교체합니다.

$section=menugroup.menuname

다음 테이블은 요소 교체에 대한 매크로 구문의 각 섹션을 설명합니다.

요소 교체에 대한 매크로 구문

$

인터페이스 요소 로드

section

요소 유형을 지정합니다. 유효한 이름은 다음과 같습니다.

1에서 4까지의 보조 메뉴에 대한 A1~A4

1에서 4까지의 마우스 버튼에 대한 B1~B4

0에서 16까지의 풀다운 메뉴에 대한 P0~P16

이미지 배열 메뉴에 대한 I

화면 메뉴에 대한 S

1에서 4까지의 타블렛 메뉴에 대한 T1~T4

infogroup

menuname을 구성원으로 포함하는 정보 그룹을 지정합니다(menuname이 주 CUI 파일인 경우에는 불필요함).

menuname

삽입할 섹션이나 부 메뉴를 지정합니다. 로드할 섹션에 대한 주 레이블 또는 별칭입니다.

다음 명령에서는 부 메뉴 참조에 대해 설명합니다.

$S=PARTS
$T1=EDITCMDS

명령 도중에 중단 없이 부 메뉴 메커니즘을 활성화할 수 있습니다. 예를 들어, 다음 명령 문자열은 모두 동일합니다.

$S=ARCSTUFF ARC
ARC $S=ARCSTUFF

각각의 명령은 ARC 명령을 시작하고 ARCSTUFF 화면 부 메뉴로 전환하고 호 매개변수의 입력을 기다립니다. 명령의 후속 명령과 구분하기 위해 부 메뉴 참조 뒤에는 공백이 와야 합니다.

풀다운 메뉴는 메뉴 막대 또는 활성화 바로 가기 메뉴 중 한 곳에 있을 수 있지만 둘 다에 있을 수는 없습니다.


매크로를 사용하여 사용자 인터페이스 요소 교체 (요약 참조)

매크로에서 단일 객체 선택 모드 사용
매크로를 사용하여 사용자 인터페이스 요소 교체
매크로에서 조건부 표현식 사용
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 매크로 작성 > 매크로를 사용하여 사용자 인터페이스 요소 교체 >
매크로를 사용하여 사용자 인터페이스 요소 교체
개념 요약 참조

명령

항목이 없습니다.

시스템 변수

항목이 없습니다.

유틸리티

항목이 없습니다.

명령 수정자

항목이 없습니다.


매크로에서 조건부 표현식 사용 (개념)

매크로를 사용하여 사용자 인터페이스 요소 교체
매크로 작성
매크로에서 AutoLISP 사용
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 매크로 작성 >
매크로에서 조건부 표현식 사용
개념 요약 참조

DIESEL(Direct Interpretively Evaluated String Expression Language)로 작성된 매크로 표현식을 소개하는 명령을 사용하여 매크로에 조건부 표현식을 추가할 수 있습니다.

형식은 다음과 같습니다.

$M=expression

$M=이 있는 매크로는 AutoCAD가 문자열을 DIESEL 표현식으로 계산하도록 지시하며 expression은 DIESEL 표현식입니다. 다음 예제는 매크로에서 조건 표현식을 정의합니다.

FILLMODE $M=$(-,1,$(getvar,fillmode))

매크로는 1에서 FILLMODE의 현재 값을 빼고 그 결과 값을 FILLMODE 시스템 변수에 반환하여 FILLMODE 시스템 변수를 켜기 또는 끄기로 전환합니다. 이 메서드를 사용하여 유효한 값이 1 또는 0(영)인 시스템 변수를 전환할 수 있습니다.

조건부 표현식이 포함된 매크로의 종료

DIESEL 문자열 언어를 사용하여 “if-then” 테스트를 수행하는 경우, 정상적인 종료 공백이나 세미콜론(결과적으로 ENTER 키와 동일)이 필요하지 않은 위치에 조건을 둘 수 있습니다. 매크로의 끝에 ^Z를 추가할 경우 AutoCAD는 자동으로 매크로 표현식의 끝에 공백(ENTER 키)을 추가하지 않습니다.

명령의 다른 조정 문자와 마찬가지로 여기에서 사용된 ^Z는 ^(탈자 기호)과 Z로 구성된 문자열로, Ctrl+Z를 누르는 것과는 다른 효과를 가져옵니다.

다음 예제에서는 ^Z가 매크로 종료자로 사용됩니다.

^C^C$M=$(if,$(=,$(getvar,tilemode),0),$S=mview _mspace )^Z
^C^C$M=$(if,$(=,$(getvar,tilemode),0),$S=mview _pspace )^Z

이들 매크로가 ^Z로 끝나지 않으면 AutoCAD가 자동으로 공백(ENTER 키)을 추가하여 마지막으로 입력된 명령을 반복합니다.

참고

    • 매크로에서 특수 조정 문자 사용

    • DIESEL


매크로에서 조건부 표현식 사용 (요약 참조)

매크로를 사용하여 사용자 인터페이스 요소 교체
매크로에서 조건부 표현식 사용
매크로에서 AutoLISP 사용
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 매크로 작성 > 매크로에서 조건부 표현식 사용 >
매크로에서 조건부 표현식 사용
개념 요약 참조

명령

항목이 없습니다.

시스템 변수

FILLMODE

해치와 채우기, 2차원 솔리드 및 굵은 폴리선을 채울지 여부를 지정합니다

유틸리티

항목이 없습니다.

명령 수정자

항목이 없습니다.


매크로에서 AutoLISP 사용 (개념)

매크로에서 조건부 표현식 사용
매크로 작성
도구막대 사용자화
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 매크로 작성 >
매크로에서 AutoLISP 사용
개념 요약 참조

AutoLISP를 사용하는 명령을 작성하는 것은 AutoCAD 사용자화 기능을 사용하는 보다 발전된 방법입니다.

AutoLISP 변수 및 표현식을 사용하여 복잡한 작업을 수행하는 매크로를 작성할 수 있습니다. 매크로에서 AutoLISP를 효과적으로 사용하려면 AutoLISP 코드를 별도의 MNL 파일에 넣습니다. AutoCAD는 같은 위치에서 같은 이름을 가진 CUI 파일을 로드할 때 MNL 파일을 로드합니다.

사용자 인터페이스 사용자화 편집기에 로드할 추가 AutoLISP 파일을 지정할 수 있습니다 . AutoLISP를 사용하는 명령을 작성하는 것은 AutoCAD 사용자화 기능을 사용하는 보다 발전된 방법입니다. 다음 예제와 AutoLISP Reference 및 AutoLISP 개발자 안내서 정보를 자세히 검토해 보십시오. 추가 도움말 리소스에 액세스하려면 도움말 메뉴 [image] 추가 리소스 [image] 개발자 도움말을 클릭하십시오.이 기능을 효과적으로 사용하려면 여러 가지로 실험하고 실습해 보아야 합니다.

매크로 호출

풀다운 메뉴 매크로를 프로그램적으로 실행하려면 다음 구문을 사용합니다.

(menucmd "Gmenugroup.요소_ID=|")

이전 구문은 메뉴 매크로가 AutoCAD 메뉴 막대에 있는 메뉴의 일부이거나 사용 가능한 메뉴의 일부인 경우에만 작동합니다. 이 구문에 대한 자세한 정보는 AutoLISP Reference를 참고하십시오.

미리 설정된 값

블록 삽입 사전설정 값을 사용하는 응용프로그램은 [Set WINWID][Set WALLTHK][Insert Window]과 같은 명령을 제공할 수 있습니다.

^C^C^P(setq WINWID (getreal "Enter window width: ")) ^P
^C^C^P(setq WALLTHK (getreal "Enter wall thickness: ")) ^P
^C^C_INSERT window XScale !WINWID YScale !WALLTHK

이 코드는 “window”란 이름의 블록을 삽입하여 X축을 현재 윈도우 폭에 맞게 축척하고, Y축을 현재 벽 두께에 맞게 축척합니다. 이 예제에서 실제 값은 사용자 정의된 AutoLISP 기호 WINWID 및 WALLTHK에서 나옵니다. 에서 나온 값입니다. 윈도우가 벽에서 회전할 수 있도록 사용자의 위쪽으로 회전합니다.

맞물림 크기 조정

다음 명령을 사용하면 맞물림 크기를 즉시 조정할 수 있습니다.

^P(setvar "gripsize"(1+ (getvar "gripsize")))(redraw)(princ)
^P(setvar "gripsize"(1- (getvar "gripsize")))(redraw)(princ)

이러한 명령에 대한 유효성 확인을 추가하기 위해 0보다 작은 값과 255보다 큰 값을 GRIPSIZE 시스템 변수에 사용할 수 없습니다.

사용자 입력을 위한 프롬프트

다음 항목은 두 점을 지정하라는 프롬프트를 표시하고, 지정된 점을 모서리로 사용하여 직사각형 폴리선을 그립니다.

^P(setq a (getpoint "Enter first corner: "));\+
(setq b (getpoint "Enter opposite corner: "));\+
pline !a (list (car a)(cadr b)) !b (list (car b)(cadr a)) c;^P


매크로에서 AutoLISP 사용 (요약 참조)

매크로에서 조건부 표현식 사용
매크로에서 AutoLISP 사용
도구막대 작성 및 편집
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 매크로 작성 > 매크로에서 AutoLISP 사용 >
매크로에서 AutoLISP 사용
개념 요약 참조

명령

CUI

작업공간, 도구막대, 메뉴, 바로 가기 메뉴 및 키보드 바로 가기와 같은 사용자화된 사용자 인터페이스 요소를 관리합니다.

CUILOAD

CUI 파일 로드

CUIUNLOAD

CUI 파일 언로드

시스템 변수

항목이 없습니다.

유틸리티

항목이 없습니다.

명령 수정자

항목이 없습니다.


도구막대 사용자화

매크로에서 AutoLISP 사용
사용자 인터페이스 사용자화
도구막대 작성 및 편집
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 >
도구막대 사용자화
개념 절차

도구막대를 사용자화하면 도면 영역에서 도구막대의 배치 또는 크기 조정이 쉬워지기 때문에 도면 효율성이나 공간을 최대로 얻을 수 있습니다. 또한 명령 및 컨트롤 요소를 추가하고 도구막대 버튼을 작성 및 편집함으로서 도구막대와 플라이아웃 도구막대를 작성 및 수정할 수도 있습니다.

이 단원의 항목

  • 도구막대 작성 및 편집

    가장 간단한 도구막대 사용자화의 일부만 사용해도 일상의 도면 작업을 더 효율적으로 만들 수 있습니다. 예를 들어, 자주 사용하는 버튼을 하나의 도구막대에 모을 수 있고 사용하지 않는 버튼을 제거하거나 일부 간단한 도구막대의 특성을 변경할 수 있습니다.

  • 도구막대 컨트롤 추가 또는 전환

    도구막대 컨트롤은 도구막대에서 선택할 수 있는 도구막대 특정 옵션의 드롭다운 리스트입니다. 예를 들어 도면층 도구막대에는 도면층 설정값을 정의할 수 있는 컨트롤이 있습니다. 사용자 인터페이스 사용자화 편집기에서 도구막대 내에 컨트롤을 추가하고 제거하며 재배치할 수 있습니다.


도구막대 사용자화 (절차)

상태 행 도움말 메시지 작성
도구막대 사용자화
도구막대 작성 및 편집
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 도구막대 사용자화 >
도구막대 사용자화
개념 절차

도구막대를 작성하려면

처음부터 플라이아웃 도구막대를 작성하려면

풀다운 메뉴에서 도구막대를 작성하려면

다른 도구막대에서 플라이아웃 도구막대를 작성하려면

풀다운 메뉴에서 플라이아웃 도구막대를 작성하려면

사용자화 창에서 도구막대에 명령을 추가하려면

도구막대 미리보기 창에서 도구막대에 명령을 추가하려면

CUI 편집기 외부에서 도구막대에 명령을 추가하려면

사용자화 창에서 도구막대의 버튼 위치를 조정하려면

도구막대 미리보기 창에서 도구막대의 버튼 위치를 조정하려면

CUI 편집기 외부에서 도구막대의 버튼 위치를 조정하려면

사용자화 창의 도구막대에서 버튼을 제거하려면

도구막대 미리보기 창의 도구막대에서 버튼을 제거하려면

CUI 편집기 외부에 있는 도구막대에서 명령을 제거하려면

도구막대의 특성을 변경하려면

버튼의 툴팁을 변경하려면

사용자화 창에서 도구막대에 컨트롤을 추가하려면

도구막대 미리보기 창에서 도구막대에 컨트롤을 추가하려면

도구막대의 컨트롤을 전환하려면


도구막대 작성 및 편집 (개념)

도구막대 사용자화
도구막대 사용자화
도구막대 컨트롤 추가 또는 전환
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 도구막대 사용자화 >
도구막대 작성 및 편집
개념 절차 요약 참조

가장 간단한 도구막대 사용자화의 일부만 사용해도 일상의 도면 작업을 더 효율적으로 만들 수 있습니다. 예를 들어, 자주 사용하는 버튼을 하나의 도구막대에 모을 수 있고 사용하지 않는 버튼을 제거하거나 일부 간단한 도구막대의 특성을 변경할 수 있습니다.

표시: 도구막대 작성

다음 이미지 아래의 재생 화살표를 클릭하여 애니메이션을 시작합니다.

아래 애니매이션은 사용자 도구막대를 작성하고 그 위에 표준 명령 및 사용자 명령을 배치하는 방법을 보여줍니다. 그러나 사용자 명령을 작성하는 방법을 보여주지는 않습니다. 사용자 명령을 작성하는 방법에 대한 정보는 명령 작성, 편집 및 재사용을 참조하고 이미지를 명령에 지정하는 방법에 대한 정보는 명령 이미지 작성을 참조하십시오.

커서를 버튼 위로 옮겨 표시할 정보를 지정할 수도 있습니다.

도구막대에 버튼을 추가하고, 자주 사용하지 않는 버튼은 제거하고, 버튼과 도구막대를 재배치할 수 있습니다. 또한 사용자 고유의 도구막대 및 플라이아웃 도구막대를 작성하거나 도구막대 명령과 연관된 버튼 이미지를 작성 또는 변경할 수 있습니다. 도구막대를 작성할 때 처음부터 도구막대를 작성하거나 기존 도구막대의 사본을 작성하거나 풀다운 메뉴에서 도구막대를 작성할 수 있습니다.

주사용자가 도구막대에 메뉴를 복사할 경우 부 메뉴 항목은 포함되지 않습니다.
주도구막대를 작성할 때에는 해당 도구막대를 표시하려는 작업공간을 결정해야 합니다. 새 도구막대는 기본값으로 모든 작업공간에 표시됩니다.

다음 테이블은 특성 창에 나타나는 표준 도구막대 특성을 보여줍니다.

표준 도구막대의 특성
특성 창 항목 | 설명 | 예제
이름 | 문자열은 도구막대의 캡션으로 사용됩니다. | 표준
설명 | 요소를 설명하는 데 사용되는 문자로, 사용자 인터페이스에는 나타나지 않습니다. | 표준 도구막대
기본값으로 켜기 | CUI 파일이 처음으로 로드될 때 도구막대를 표시할지 여부를 지정합니다. 값은 숨김 또는 표시입니다. | 표시
방향 | CUI 파일이 처음으로 로드될 때 도구막대의 상태가 부동인지 또는 고정(맨 위, 맨 아래, 왼쪽 또는 오른쪽)인지를 지정합니다. | 맨 위
기본 X 위치 | 도구막대가 부동 상태로 나타날 때 화면의 왼쪽 모서리로부터의 위치 또는 고정되어 있을 때의 위치를 지정합니다. 고정되어 있는 경우 0 값은 고정 영역의 맨 왼쪽 위치를 나타냅니다. | 0
기본 Y 위치 | 도구막대가 부동 상태로 나타날 때 화면의 맨 위 모서리로부터의 위치 또는 고정되어 있을 때의 위치를 지정합니다. 고정되어 있는 경우 0 값은 고정 영역의 맨 위 위치를 나타냅니다. | 0
행 | 도구막대가 부동일 때 도구막대에 항목이 표시되는 행의 수를 지정합니다. | 1
별칭 | 도구막대의 별칭을 지정합니다. 타원 버튼[...]을 클릭하여 별칭 대화상자를 엽니다. CUI 파일의 별칭마다 고유해야 하며 프로그램에 따라서 도구막대를 참조하는 데 사용됩니다. | TB_STANDARD, 표준
요소 ID | 도구막대를 고유하게 식별하는 태그입니다. | ID_TbStandard
주기본값으로 켜기, 방향, 기본 X 위치, 기본 Y 위치 및 행의 특성은 처음 CUI 파일이 로드되고 기본 작업공간이 정의되지 않았을 경우만 사용됩니다. 도구막대가 처음으로 로드된 후 작업공간을 사용하여 도구막대의 모양 특성을 조정할 수 있습니다. 자세한 정보는 도구막대의 특성을 변경하려면 절차를 참고하십시오.
경고플라이아웃으로 사용되고 있는 도구막대의 별칭을 변경하지 마십시오. 변경할 경우 도구막대와 플라이아웃 사이의 연결이 끊어집니다.

플라이아웃은 도구막대에서 하나의 버튼 아래에 내포된 버튼 세트입니다. 플라이아웃 버튼에는 오른쪽 아래 구석에 검은색 삼각형이 있습니다. 플라이아웃을 작성하려면 처음부터 시작하거나 기존 도구막대를 다른 도구막대로 끌거나 풀다운 메뉴를 다른 도구막대로 끌 수 있습니다. 풀다운 메뉴를 다른 도구막대로 끌면 도구막대가 새로 작성되며 풀다운 메뉴를 도구막대로 끌어놓은 위치에 플라이아웃이 작성됩니다.

다음 테이블은 특성 창에 나타나는 줌 플라이아웃 특성을 보여줍니다.

표준 도구막대의 줌 플라이아웃 특성
특성 창 항목 | 설명 | 예제
이름 | 고유 버튼 사용 특성이 예로 설정되어 있지 않는 경우 사용자 인터페이스에 나타나지 않는 문자열입니다. | 줌
설명 | 요소를 설명하는 데 사용되는 문자로, 사용자 인터페이스에는 나타나지 않습니다. |
소스 도구막대 | 어떤 도구막대가 플라이아웃을 작성하기 위해 참조되고 있는지 지정하는 데 사용되는 읽기 전용 값입니다. | TB_ZOOM
고유 버튼 사용 | 마지막으로 사용된 도구막대 버튼을 현재 버튼으로 설정할 것인지의 여부를 조정합니다. 가능한 값은 예 또는 아니오입니다. | 아니오
작은 이미지 | 작은 이미지 리소스(16 × 16 비트맵)의 ID 문자열입니다. 문자열에 하이픈(-)이나 밑줄(_) 이외의 영숫자 문자가 구두점 없이 포함되어야 합니다. 또한 사용자 정의 비트맵도 포함될 수 있습니다. 타원 버튼[...]을 클릭하여 이미지 파일 선택 대화상자를 엽니다. | RCDATA_16_ZOOM
큰 이미지 | 큰 이미지 리소스(32 × 32 비트맵)의 ID 문자열입니다. 지정된 비트맵이 32 × 32가 아닌 경우 프로그램이 이 크기로 축척합니다. 문자열에 하이픈(-)이나 밑줄(_) 이외의 영숫자 문자가 구두점 없이 포함되어야 합니다. 또한 사용자 정의 비트맵도 포함될 수 있습니다. 타원 버튼[...]을 클릭하여 이미지 파일 선택 대화상자를 엽니다. | RCDATA_16_ZOOM

새 도구막대 또는 플라이아웃 도구막대를 작성할 때 첫 번째로 해야 할 일은 해당 도구막대에 이름을 지정하는 것입니다. 새 도구막대에는 지정된 명령 또는 컨트롤이 없습니다. 도구막대에 명령이나 컨트롤이 없을 경우 적어도 하나 이상의 명령이나 컨트롤을 추가할 때까지 프로그램에 의해 무시됩니다. 기존 도구막대 또는 명령 리스트 창에서 새 도구막대로 명령과 컨트롤을 끌 수 있습니다. 도구막대에 명령을 추가했으면 특성 창에 표시되는 이름 특성을 조정하여 버튼 맨 위에서 커서가 일시 중지될 때 툴팁에 표시되는 텍스트를 변경할 수 있습니다.

<파일 이름>의 사용자화 창의 도구막대에서 명령과 컨트롤을 추가 또는 제거할 수 있으며 도구막대 미리보기 창에서도 추가 또는 제거할 수 있습니다. 도구막대 미리보기 창을 사용하면 트리 뷰를 사용하는 대신 실시간으로 보면서 명령이나 컨트롤을 추가하거나 제거할 수 있습니다. 또한 미리보기에서 대화식으로 명령과 컨트롤을 끌어서 위치를 조정할 수 있습니다.

또한 프로그램을 사용하면 사용자 인터페이스 사용자화 편집기를 열 때 응용프로그램에 표시되는 도구막대를 사용자화할 수 있습니다. 명령 리스트 창에서 명령을 끌어서 응용프로그램에 고정 또는 부동으로 있는 표시된 도구막대에 직접 놓을 수 있습니다. 또한 CUI 편집기가 열려 있는 동안 명령을 제거하거나 위치를 조정하거나 복사할 수 있습니다.

참고

    • 도구막대를 작성하려면 (절차)

    • 풀다운 메뉴에서 도구막대를 작성하려면 (절차)

    • 처음부터 플라이아웃 도구막대를 작성하려면 (절차)

    • 다른 도구막대에서 플라이아웃 도구막대를 작성하려면 (절차)

    • 풀다운 메뉴에서 플라이아웃 도구막대를 작성하려면 (절차)

    • 사용자화 창에서 도구막대에 명령을 추가하려면 (절차)

    • 도구막대 미리보기 창에서 도구막대에 명령을 추가하려면 (절차)

    • CUI 편집기 외부에서 도구막대에 명령을 추가하려면 (절차)

    • 사용자화 창에서 도구막대의 버튼 위치를 조정하려면 (절차)

    • 도구막대 미리보기 창에서 도구막대의 버튼 위치를 조정하려면 (절차)

    • CUI 편집기 외부에서 도구막대의 버튼 위치를 조정하려면 (절차)

    • 사용자화 창의 도구막대에서 버튼을 제거하려면 (절차)

    • 도구막대 미리보기 창의 도구막대에서 버튼을 제거하려면 (절차)

    • CUI 편집기 외부에 있는 도구막대에서 명령을 제거하려면 (절차)

    • 도구막대의 특성을 변경하려면 (절차)

    • 버튼의 툴팁을 변경하려면 (절차)


도구막대 작성 및 편집 (절차)

도구막대 사용자화
상위 단계로
도구막대 작성 및 편집
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 도구막대 사용자화 > 도구막대 작성 및 편집 >
도구막대 작성 및 편집
개념 절차 요약 참조

도구막대를 작성하려면

처음부터 플라이아웃 도구막대를 작성하려면

풀다운 메뉴에서 도구막대를 작성하려면

다른 도구막대에서 플라이아웃 도구막대를 작성하려면

풀다운 메뉴에서 플라이아웃 도구막대를 작성하려면

사용자화 창에서 도구막대에 명령을 추가하려면

도구막대 미리보기 창에서 도구막대에 명령을 추가하려면

CUI 편집기 외부에서 도구막대에 명령을 추가하려면

사용자화 창에서 도구막대의 버튼 위치를 조정하려면

도구막대 미리보기 창에서 도구막대의 버튼 위치를 조정하려면

CUI 편집기 외부에서 도구막대의 버튼 위치를 조정하려면

사용자화 창의 도구막대에서 버튼을 제거하려면

도구막대 미리보기 창의 도구막대에서 버튼을 제거하려면

CUI 편집기 외부에 있는 도구막대에서 명령을 제거하려면

도구막대의 특성을 변경하려면

버튼의 툴팁을 변경하려면


도구막대 작성 및 편집 (절차)

도구막대 작성 및 편집
상위 단계로
도구막대 작성 및 편집
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 도구막대 사용자화 > 도구막대 작성 및 편집 >
도구막대 작성 및 편집
개념 절차 요약 참조

도구막대를 작성하려면

  1. 도구 메뉴 [image] 사용자화 [image] 인터페이스를 클릭합니다.명령 프롬프트에서 cui를 입력합니다.
  2. 사용자 인터페이스 사용자화 편집기의 사용자화 탭에 있는 <파일 이름>의 사용자화 창에서 도구막대를 마우스 오른쪽 버튼으로 클릭합니다. 새 도구막대를 클릭합니다.

    Toolbar1이라는 새 도구막대가 도구막대 트리의 맨 아래 놓였습니다.

  3. 다음 중 하나를 수행합니다.
    • Toolbar1 문자 위에 새 이름을 입력합니다.
    • Toolbar1을 마우스 오른쪽 버튼으로 클릭합니다. 이름 바꾸기를 클릭합니다. 새 도구막대 이름을 입력합니다.
    • Toolbar1을 클릭하고 기다린 다음 도구막대 이름을 다시 클릭하여 이름을 내부 편집합니다
  4. 트리 뷰에서 새 도구막대를 선택한 다음 특성 창을 업데이트합니다.
    • 설명 상자에 해당 도구막대에 대한 설명을 입력합니다.
    • 기본값으로 켜기 상자에서 숨기기 또는 표시를 클릭합니다. 표시를 선택한 경우 모든 작업공간에 이 도구막대가 표시됩니다.
    • 방향 상자에서 부동, 맨 위, 맨 아래, 왼쪽 또는 오른쪽을 클릭합니다.
    • 기본 X 위치 상자에 숫자를 입력합니다.
    • 기본 Y 위치 상자에 숫자를 입력합니다.
    • 행 상자에 고정되지 않은 도구막대의 행 번호를 입력합니다.
    • 별칭 상자에 도구막대의 별칭을 입력합니다.

  5. 명령 리스트 창에서 추가할 명령을 <파일 이름>의 사용자화 창에 있는 도구막대 이름 바로 아래의 위치로 끌어옵니다.

  6. 확인을 클릭합니다.


도구막대 작성 및 편집 (절차)

도구막대 작성 및 편집
상위 단계로
도구막대 작성 및 편집
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 도구막대 사용자화 > 도구막대 작성 및 편집 >
도구막대 작성 및 편집
개념 절차 요약 참조

처음부터 플라이아웃 도구막대를 작성하려면

  1. 도구 메뉴 [image] 사용자화 [image] 인터페이스를 클릭합니다.명령 프롬프트에서 cui를 입력합니다.
  2. 사용자 인터페이스 사용자화 편집기의 사용자화 탭에 있는 <파일 이름>의 사용자화 창에서 도구막대 트리 노드 옆에 있는 더하기 기호(+)를 클릭하여 트리 노드를 확장합니다.
  3. 플라이아웃 도구막대를 추가하려는 도구막대를 마우스 오른쪽 버튼으로 클릭합니다. 새 플라이아웃을 클릭합니다.

    Toolbar1이라는 이름의 새 플라이아웃 도구막대가 선택한 도구막대 아래에 놓였습니다.

  4. Toolbar1을 마우스 오른쪽 버튼으로 클릭합니다. 이름 바꾸기를 클릭합니다. 새 도구막대 이름을 입력합니다.
    주도구막대 이름을 클릭하고 기다린 다음 다시 클릭하여 이름을 내부 편집할 수 있습니다.

    주단순히 도구막대의 이름을 변경한다고 해서 플라이아웃의 이름이 변경되지는 않습니다. 도구막대와 플라이아웃이 같은 이름을 갖도록 하려면 플라이아웃도 별도로 선택해서 이름을 변경해야 합니다.
  5. 명령 리스트 창에서 추가할 명령을 <파일 이름>의 사용자화 창에 있는 도구막대 플라이아웃 이름 바로 아래의 위치로 끌어옵니다.

  6. 확인을 클릭합니다.


도구막대 작성 및 편집 (절차)

도구막대 작성 및 편집
상위 단계로
도구막대 작성 및 편집
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 도구막대 사용자화 > 도구막대 작성 및 편집 >
도구막대 작성 및 편집
개념 절차 요약 참조

풀다운 메뉴에서 도구막대를 작성하려면

  1. 도구 메뉴 [image] 사용자화 [image] 인터페이스를 클릭합니다.명령 프롬프트에서 cui를 입력합니다.
  2. 사용자 인터페이스 사용자화 편집기의 사용자화 탭에 있는 <파일 이름>의 사용자화 창에서 도구막대 트리 노드 옆에 있는 더하기 기호(+)를 클릭하여 트리 노드를 확장합니다.
  3. 메뉴 트리 노드 옆에 있는 더하기 기호(+)를 클릭하여 트리 노드를 확장합니다.
  4. 도구막대를 작성할 메뉴를 도구막대 노드에 끌어놓습니다.

  5. 필요에 맞게 작업공간을 업데이트하여 표시를 업데이트하고 새 도구막대의 위치를 조정합니다.


도구막대 작성 및 편집 (절차)

도구막대 작성 및 편집
상위 단계로
도구막대 작성 및 편집
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 도구막대 사용자화 > 도구막대 작성 및 편집 >
도구막대 작성 및 편집
개념 절차 요약 참조

다른 도구막대에서 플라이아웃 도구막대를 작성하려면

  1. 도구 메뉴 [image] 사용자화 [image] 인터페이스를 클릭합니다.명령 프롬프트에서 cui를 입력합니다.
  2. 사용자 인터페이스 사용자화 편집기의 사용자화 탭에 있는 <파일 이름>의 사용자화 창에서 도구막대 트리 노드 옆에 있는 더하기 기호(+)를 클릭하여 트리 노드를 확장합니다.
  3. 플라이아웃 도구막대를 추가하려는 도구막대 옆의 더하기 기호(+)를 클릭합니다.
  4. 추가하려는 도구막대를 플라이아웃으로 배치합니다. 해당 도구막대를 확장된 도구막대의 위치로 끌어옵니다.

  5. 확인을 클릭합니다.


도구막대 작성 및 편집 (절차)

도구막대 작성 및 편집
상위 단계로
도구막대 작성 및 편집
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 도구막대 사용자화 > 도구막대 작성 및 편집 >
도구막대 작성 및 편집
개념 절차 요약 참조

풀다운 메뉴에서 플라이아웃 도구막대를 작성하려면

  1. 도구 메뉴 [image] 사용자화 [image] 인터페이스를 클릭합니다.명령 프롬프트에서 cui를 입력합니다.
  2. 사용자 인터페이스 사용자화 편집기의 사용자화 탭에 있는 <파일 이름>의 사용자화 창에서 도구막대 트리 노드 옆에 있는 더하기 기호(+)를 클릭하여 트리 노드를 확장합니다.
  3. 메뉴 트리 노드 옆에 있는 더하기 기호(+)를 클릭하여 트리 노드를 확장합니다.
  4. 플라이아웃을 작성할 메뉴를 플라이아웃을 배치할 도구막대의 노드로 끌어놓습니다.

    도구막대에서 메뉴가 누락된 경우 새 플라이아웃 및 도구막대가 작성됩니다.

  5. 도구막대에 새 플라이아웃의 위치를 조정합니다.
  6. 표시할 작업공간을 업데이트하고 새 도구막대의 위치를 조정합니다.


도구막대 작성 및 편집 (절차)

도구막대 작성 및 편집
상위 단계로
도구막대 작성 및 편집
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 도구막대 사용자화 > 도구막대 작성 및 편집 >
도구막대 작성 및 편집
개념 절차 요약 참조

사용자화 창에서 도구막대에 명령을 추가하려면

  1. 도구 메뉴 [image] 사용자화 [image] 인터페이스를 클릭합니다.명령 프롬프트에서 cui를 입력합니다.
  2. 사용자 인터페이스 사용자화 편집기에 있는 사용자화 탭의 명령 리스트 창에서 추가할 명령을 <파일 이름>의 사용자화 창의 도구막대 이름 바로 아래의 위치로 끌어옵니다.
  3. 더하기 기호(+)를 도구막대의 왼쪽으로 클릭하여 방금 추가한 명령을 표시합니다.

  4. 확인을 클릭합니다.


도구막대 작성 및 편집 (절차)

도구막대 작성 및 편집
상위 단계로
도구막대 작성 및 편집
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 도구막대 사용자화 > 도구막대 작성 및 편집 >
도구막대 작성 및 편집
개념 절차 요약 참조

도구막대 미리보기 창에서 도구막대에 명령을 추가하려면

  1. 도구 메뉴 [image] 사용자화 [image] 인터페이스를 클릭합니다.명령 프롬프트에서 cui를 입력합니다.
  2. 사용자 인터페이스 사용자화 편집기의 사용자화 탭에 있는 <파일 이름>의 사용자화 창에서 도구막대 노드 옆에 있는 더하기 기호(+)를 클릭하여 노드를 확장합니다.
  3. 명령을 추가할 도구막대를 선택합니다.
  4. 명령 리스트 창에서 선택한 도구막대에 추가할 명령을 도구막대 미리보기 창에 있는 도구막대 미리보기에 끌어놓습니다.

    검은색 세로 스플리터 막대가 표시될 때 마우스 버튼을 놓아서 명령을 배치할 위치를 제어할 수 있습니다.

  5. 확인을 클릭합니다.


도구막대 작성 및 편집 (절차)

도구막대 작성 및 편집
상위 단계로
도구막대 작성 및 편집
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 도구막대 사용자화 > 도구막대 작성 및 편집 >
도구막대 작성 및 편집
개념 절차 요약 참조

CUI 편집기 외부에서 도구막대에 명령을 추가하려면

  1. 도구막대 버튼을 마우스 오른쪽 버튼으로 클릭하여 명령을 추가할 도구막대를 표시합니다. 도구막대 이름을 클릭합니다.
  2. 임의의 도구막대 버튼을 마우스 오른쪽 버튼으로 클릭합니다. 사용자화를 클릭합니다.
  3. 사용자 인터페이스 사용자화 편집기의 사용자화 탭에 있는 명령 리스트 창에서 추가할 명령을 도구막대로 끌어놓습니다.

    뷰 지시자로 스플리터 막대를 사용하여 명령의 위치를 제어할 수 있습니다.

  4. 확인을 클릭합니다.


도구막대 작성 및 편집 (절차)

도구막대 작성 및 편집
상위 단계로
도구막대 작성 및 편집
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 도구막대 사용자화 > 도구막대 작성 및 편집 >
도구막대 작성 및 편집
개념 절차 요약 참조

사용자화 창에서 도구막대의 버튼 위치를 조정하려면

  1. 도구 메뉴 [image] 사용자화 [image] 인터페이스를 클릭합니다.명령 프롬프트에서 cui를 입력합니다.
  2. 사용자 인터페이스 사용자화 편집기의 사용자화 탭에 있는 <파일 이름>의 사용자화 창에서 도구막대 노드 옆에 있는 더하기 기호(+)를 클릭하여 노드를 확장합니다.
  3. 도구막대 옆에 있는 더하기 기호(+)를 클릭하여 도구막대를 확장합니다.
  4. 위치를 조정하려는 버튼의 이름을 도구 리스트의 새 위치로 끌어 옵니다.

    분할 막대가 나타나면 두 버튼 사이에 해당 버튼을 놓을 수 있습니다. 왼쪽 화살표가 나타나면 다른 버튼 아래에 해당 버튼을 배치할 수 있습니다.

  5. 확인을 클릭합니다.


도구막대 작성 및 편집 (절차)

도구막대 작성 및 편집
상위 단계로
도구막대 작성 및 편집
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 도구막대 사용자화 > 도구막대 작성 및 편집 >
도구막대 작성 및 편집
개념 절차 요약 참조

도구막대 미리보기 창에서 도구막대의 버튼 위치를 조정하려면

  1. 도구 메뉴 [image] 사용자화 [image] 인터페이스를 클릭합니다.명령 프롬프트에서 cui를 입력합니다.
  2. 사용자 인터페이스 사용자화 편집기의 사용자화 탭에 있는 <파일 이름>의 사용자화 창에서 도구막대 노드 옆에 있는 더하기 기호(+)를 클릭하여 노드를 확장합니다.
  3. 도구막대의 미리보기에서 위치를 조정할 버튼을 끕니다.

    새 위치로 버튼을 끌면서 뷰 지시자로 스플리터 막대를 사용하여 해당 버튼의 위치를 지정할 수 있습니다.

  4. 확인을 클릭합니다.


도구막대 작성 및 편집 (절차)

도구막대 작성 및 편집
상위 단계로
도구막대 작성 및 편집
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 도구막대 사용자화 > 도구막대 작성 및 편집 >
도구막대 작성 및 편집
개념 절차 요약 참조

CUI 편집기 외부에서 도구막대의 버튼 위치를 조정하려면

  1. 도구막대 버튼을 마우스 오른쪽 버튼으로 클릭하여 명령을 추가할 도구막대를 표시합니다. 도구막대 이름을 클릭합니다.
  2. 임의의 도구막대 버튼을 마우스 오른쪽 버튼으로 클릭합니다. 사용자화를 클릭합니다.
  3. 도구막대에서 위치를 조정할 버튼을 끕니다.

    새 위치로 버튼을 끌면서 뷰 지시자로 스플리터 막대를 사용하여 해당 버튼의 위치를 지정할 수 있습니다.

  4. 확인을 클릭합니다.


도구막대 작성 및 편집 (절차)

도구막대 작성 및 편집
상위 단계로
도구막대 작성 및 편집
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 도구막대 사용자화 > 도구막대 작성 및 편집 >
도구막대 작성 및 편집
개념 절차 요약 참조

사용자화 창의 도구막대에서 버튼을 제거하려면

  1. 도구 메뉴 [image] 사용자화 [image] 인터페이스를 클릭합니다.명령 프롬프트에서 cui를 입력합니다.
  2. 사용자 인터페이스 사용자화 편집기의 사용자화 탭에 있는 <파일 이름>의 사용자화 창에서 도구막대 노드 옆에 있는 더하기 기호(+)를 클릭하여 노드를 확장합니다.
  3. 도구막대 옆에 있는 더하기 기호(+)를 클릭하여 도구막대를 확장합니다.
  4. 제거하려는 버튼의 이름을 마우스 오른쪽 버튼으로 클릭합니다. 제거를 클릭합니다.

  5. 확인을 클릭합니다.


도구막대 작성 및 편집 (절차)

도구막대 작성 및 편집
상위 단계로
도구막대 작성 및 편집
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 도구막대 사용자화 > 도구막대 작성 및 편집 >
도구막대 작성 및 편집
개념 절차 요약 참조

도구막대 미리보기 창의 도구막대에서 버튼을 제거하려면

  1. 도구 메뉴 [image] 사용자화 [image] 인터페이스를 클릭합니다.명령 프롬프트에서 cui를 입력합니다.
  2. 사용자 인터페이스 사용자화 편집기의 사용자화 탭에 있는 <파일 이름>의 사용자화 창에서 도구막대 노드 옆에 있는 더하기 기호(+)를 클릭하여 노드를 확장합니다.
  3. 도구막대 미리보기에서 제거할 버튼을 미리보기의 바깥 부분으로 끌어놓습니다.

  4. 확인을 클릭합니다.


도구막대 작성 및 편집 (절차)

도구막대 작성 및 편집
상위 단계로
도구막대 작성 및 편집
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 도구막대 사용자화 > 도구막대 작성 및 편집 >
도구막대 작성 및 편집
개념 절차 요약 참조

CUI 편집기 외부에 있는 도구막대에서 명령을 제거하려면

  1. 도구막대 버튼을 마우스 오른쪽 버튼으로 클릭하여 명령을 제거할 도구막대를 표시합니다. 도구막대 이름을 클릭합니다.
  2. 임의의 도구막대 버튼을 마우스 오른쪽 버튼으로 클릭합니다. 사용자화를 클릭합니다.

    사용자 인터페이스 사용자화 편집기가 표시됩니다.

  3. 도구막대에서 제거할 버튼을 도면 윈도우에 끌어놓습니다.

  4. 확인을 클릭합니다.

  5. 사용자 클릭 사용자화 편집기에서 확인을 클릭합니다.


도구막대 작성 및 편집 (절차)

도구막대 작성 및 편집
상위 단계로
도구막대 작성 및 편집
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 도구막대 사용자화 > 도구막대 작성 및 편집 >
도구막대 작성 및 편집
개념 절차 요약 참조

도구막대의 특성을 변경하려면

  1. 도구 메뉴 [image] 사용자화 [image] 인터페이스를 클릭합니다.명령 프롬프트에서 cui를 입력합니다.
  2. 사용자 인터페이스 사용자화 편집기의 사용자화 탭에 있는 <파일 이름>의 사용자화 창에서 변경할 특성이 있는 도구막대를 클릭합니다.
    주여기서 도구막대의 특성을 변경하면 CUI 파일이 로드된 후 나타나는 도구막대의 처음 모양에만 영향을 미칩니다. 도구막대의 모양을 조정하려면 작업공간을 사용하는 것이 제일 좋습니다.
  3. 특성 창에서 변경을 진행합니다.
    주도구막대에서 별칭을 변경하기 전에 함수의 별칭을 만드는 방법을 알아야 합니다. 별칭에 대한 자세한 정보는 명령 별칭 작성을 참고하십시오.
  4. 확인을 클릭합니다.


도구막대 작성 및 편집 (절차)

도구막대 작성 및 편집
상위 단계로
도구막대 컨트롤 추가 또는 전환
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 도구막대 사용자화 > 도구막대 작성 및 편집 >
도구막대 작성 및 편집
개념 절차 요약 참조

버튼의 툴팁을 변경하려면

  1. 도구 메뉴 [image] 사용자화 [image] 인터페이스를 클릭합니다.명령 프롬프트에서 cui를 입력합니다.
  2. 사용자 인터페이스 사용자화 편집기의 사용자화 탭에 있는 <파일 이름>의 사용자화 창에서 도구막대 노드 옆에 있는 더하기 기호(+)를 클릭하여 노드를 확장합니다.
  3. 변경할 툴팁 텍스트의 도구막대를 선택합니다.
  4. 특성 창의 표시 섹션에서 (명령 이름 특성이 아닌)이름 특성에 원하는 변경을 수행합니다.

  5. 확인을 클릭합니다.


도구막대 작성 및 편집 (요약 참조)

매크로에서 AutoLISP 사용
도구막대 작성 및 편집
도구막대 컨트롤 추가 또는 전환
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 도구막대 사용자화 > 도구막대 작성 및 편집 >
도구막대 작성 및 편집
개념 절차 요약 참조

명령

CUI

작업공간, 도구막대, 메뉴, 바로 가기 메뉴 및 키보드 바로 가기와 같은 사용자화된 사용자 인터페이스 요소를 관리합니다.

QUICKCUI

사용자 인터페이스 사용자화 대화상자를 축소된 상태로 표시합니다.

시스템 변수

TOOLTIPS

도구막대에 툴팁의 표시를 제어합니다.

유틸리티

항목이 없습니다.

명령 수정자

항목이 없습니다.


도구막대 컨트롤 추가 또는 전환 (개념)

도구막대 작성 및 편집
도구막대 사용자화
풀다운 메뉴 및 바로 가기 메뉴 작성
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 도구막대 사용자화 >
도구막대 컨트롤 추가 또는 전환
개념 절차 요약 참조

도구막대 컨트롤은 도구막대에서 선택할 수 있는 도구막대 특정 옵션의 드롭다운 리스트입니다. 예를 들어 도면층 도구막대에는 도면층 설정값을 정의할 수 있는 컨트롤이 있습니다. 사용자 인터페이스 사용자화 편집기에서 도구막대 내에 컨트롤을 추가하고 제거하며 재배치할 수 있습니다.

다음 테이블에는 사용자 인터페이스 사용자화 편집기 및 해당 정의에서 찾은 도구막대 컨트롤이 나열됩니다. 이 테이블의 왼쪽 열에 있는 컨트롤 요소가 항상 프로그램에서 툴팁으로 표시되는 문자는 아닙니다(예를 들어, 표면 버튼 명령 취소는 프로그램의 툴팁에서 명령 취소로 표시됩니다). 도구막대에서 컨트롤을 변경할 때 이 테이블을 참고하십시오.

도구막대에 대한 컨트롤 요소
컨트롤 요소 | 설명
치수 스타일 컨트롤 | 현재 치수 스타일의 지정사항을 제공하는 드롭다운 리스트입니다.
도면층 컨트롤 | 도면의 현재 도면층 조정을 제공하는 드롭다운 리스트입니다.
선종류 컨트롤 | 현재 선종류의 지정사항을 제공하는 드롭다운 리스트입니다.
선가중치 컨트롤 | 현재 선가중치의 지정사항을 제공하는 드롭다운 리스트입니다.
다중 지시선 스타일 컨트롤 | 현재 다중 지시선 스타일을 설정하는 드롭다운 리스트입니다.
명명된 뷰 컨트롤 | 명명된 뷰를 표시하는 드롭다운 리스트입니다.
OPT 색상 컨트롤 | 현재 색상의 지정사항을 제공하는 드롭다운 리스트입니다.
플롯 스타일 컨트롤 | 현재 플롯 스타일의 지정사항을 제공하는 드롭다운 리스트입니다.
표면 버튼 컨트롤 명령 복구 | 이전 동작을 반복하는 표준 도구막대 버튼입니다.
참조 블록 이름 컨트롤 | 편집 모드에서 현재 외부 참조 이름을 표시합니다.
테이블 스타일 컨트롤 | 현재 테이블 스타일을 설정하는 드롭다운 리스트입니다.
문자 스타일 컨트롤 | 현재 문자 스타일을 설정하는 드롭다운 리스트입니다.
UCS 컨트롤 | 현재 UCS의 지정사항을 제공하는 드롭다운 리스트입니다.
표면 버튼 컨트롤 명령 취소 | 이전 동작을 취소하는 표준 도구막대 버튼입니다.
뷰 컨트롤 | 현재 표준 3D 뷰의 지정사항을 제공하는 드롭다운 리스트입니다.
뷰포트 축척 컨트롤 | 배치의 뷰포트 축척에 대한 지정사항을 제공하는 드롭다운 리스트입니다.
작업공간 컨트롤 | 현재 작업공간을 설정하는 드롭다운 리스트입니다.
참고

    • 도구막대 사용자화

    • 사용자화 창에서 도구막대에 컨트롤을 추가하려면 (절차)

    • 도구막대 미리보기 창에서 도구막대에 컨트롤을 추가하려면 (절차)

    • 도구막대의 컨트롤을 전환하려면 (절차)


도구막대 컨트롤 추가 또는 전환 (절차)

도구막대 작성 및 편집
상위 단계로
도구막대 컨트롤 추가 또는 전환
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 도구막대 사용자화 > 도구막대 컨트롤 추가 또는 전환 >
도구막대 컨트롤 추가 또는 전환
개념 절차 요약 참조

사용자화 창에서 도구막대에 컨트롤을 추가하려면

도구막대 미리보기 창에서 도구막대에 컨트롤을 추가하려면

도구막대의 컨트롤을 전환하려면


도구막대 컨트롤 추가 또는 전환 (절차)

도구막대 컨트롤 추가 또는 전환
상위 단계로
도구막대 컨트롤 추가 또는 전환
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 도구막대 사용자화 > 도구막대 컨트롤 추가 또는 전환 >
도구막대 컨트롤 추가 또는 전환
개념 절차 요약 참조

사용자화 창에서 도구막대에 컨트롤을 추가하려면

  1. 도구 메뉴 [image] 사용자화 [image] 인터페이스를 클릭합니다.명령 프롬프트에서 cui를 입력합니다.
  2. 사용자 인터페이스 사용자화 편집기의 사용자화 탭에 있는 <파일 이름>의 사용자화 창에서 컨트롤을 추가할 도구막대 옆에 있는 더하기 기호(+)를 클릭합니다.
  3. 명령 리스트 창의 범주 리스트에서 컨트롤 요소를 클릭합니다.

    명령 리스트 창에는 컨트롤 요소만 표시됩니다.

  4. 명령 리스트에서 <파일 이름>의 사용자화 창의 컨트롤을 도구막대에서 추가할 위치로 끌어옵니다.

  5. 확인을 클릭합니다.


도구막대 컨트롤 추가 또는 전환 (절차)

도구막대 컨트롤 추가 또는 전환
상위 단계로
도구막대 컨트롤 추가 또는 전환
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 도구막대 사용자화 > 도구막대 컨트롤 추가 또는 전환 >
도구막대 컨트롤 추가 또는 전환
개념 절차 요약 참조

도구막대 미리보기 창에서 도구막대에 컨트롤을 추가하려면

  1. 도구 메뉴 [image] 사용자화 [image] 인터페이스를 클릭합니다.명령 프롬프트에서 cui를 입력합니다.
  2. 사용자 인터페이스 사용자화 편집기의 사용자화 탭에 있는 <파일 이름>의 사용자화 창에서 도구막대 노드 옆에 있는 더하기 기호(+)를 클릭하여 노드를 확장합니다.
  3. 컨트롤을 추가할 도구막대를 선택합니다.
  4. 명령 리스트 창의 범주 리스트에서 컨트롤 요소를 클릭합니다.

    명령 리스트 창에는 컨트롤 요소만 표시됩니다.

  5. 명령 리스트 창에서 선택한 도구막대에 추가할 컨트롤을 도구막대 미리보기 창에 있는 도구막대 미리보기에 끌어놓습니다.

    검은색 세로 스플리터 막대가 원하는 위치에 표시될 때 마우스 버튼을 놓아서 명령을 배치할 위치를 제어할 수 있습니다.

  6. 확인을 클릭합니다.


도구막대 컨트롤 추가 또는 전환 (절차)

도구막대 컨트롤 추가 또는 전환
상위 단계로
풀다운 메뉴 및 바로 가기 메뉴 작성
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 도구막대 사용자화 > 도구막대 컨트롤 추가 또는 전환 >
도구막대 컨트롤 추가 또는 전환
개념 절차 요약 참조

도구막대의 컨트롤을 전환하려면

  1. 도구 메뉴 [image] 사용자화 [image] 인터페이스를 클릭합니다.명령 프롬프트에서 cui를 입력합니다.
  2. 사용자 인터페이스 사용자화 편집기의 사용자화 탭에 있는 <파일 이름>의 사용자화 창에서 전환할 컨트롤 요소가 포함된 도구막대 옆에 있는 더하기 기호(+)를 클릭합니다.
  3. 컨트롤 요소를 클릭합니다.

  4. 특성 창의 컨트롤 상자에서 화살표를 클릭하여 컨트롤 리스트를 표시합니다.

  5. 컨트롤을 클릭하여 선택한 컨트롤과 원래 컨트롤을 대치합니다.
  6. 확인을 클릭합니다.


도구막대 컨트롤 추가 또는 전환 (요약 참조)

도구막대 작성 및 편집
도구막대 컨트롤 추가 또는 전환
풀다운 메뉴 작성
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 도구막대 사용자화 > 도구막대 컨트롤 추가 또는 전환 >
도구막대 컨트롤 추가 또는 전환
개념 절차 요약 참조

명령

CUI

작업공간, 도구막대, 메뉴, 바로 가기 메뉴 및 키보드 바로 가기와 같은 사용자화된 사용자 인터페이스 요소를 관리합니다.

시스템 변수

항목이 없습니다.

유틸리티

항목이 없습니다.

명령 수정자

항목이 없습니다.


풀다운 메뉴 및 바로 가기 메뉴 작성

도구막대 컨트롤 추가 또는 전환
사용자 인터페이스 사용자화
풀다운 메뉴 작성
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 >
풀다운 메뉴 및 바로 가기 메뉴 작성
개념 절차

풀다운 메뉴는 메뉴 막대 아래 리스트로 표시됩니다. 바로 가기 메뉴(상황에 맞는 메뉴라고도 함)는 도면 윈도우, 문자 윈도우, 명령 윈도우 또는 도구막대 영역에서 마우스 오른쪽 버튼으로 클릭할 때 십자선 또는 커서 위치나 그 근처에 표시됩니다.

풀다운 메뉴에 최대 999개의 명령을 포함할 수 있습니다. 바로 가기 메뉴에 최대 499개의 명령을 포함할 수 있습니다. 명령 한계는 계층 구조에서 모든 메뉴를 포함합니다. 드문 경우지만 메뉴 파일의 명령이 이 한계를 초과하는 경우 초과 명령은 프로그램에서 무시됩니다. 풀다운 또는 바로 가기 메뉴가 사용 가능한 표시 공간보다 길면 공간에 맞도록 잘립니다. 다음 테이블은 특성 창에 나타나는 파일 메뉴 특성을 보여줍니다. 풀다운 메뉴 및 바로 가기 메뉴의 특성은 동일합니다.

파일 메뉴의 특성
특성 창 항목 | 설명 | 예제
이름 | 메뉴 막대의 메뉴 캡션으로 사용되는 문자열입니다. | 파일(&F)
설명 | 요소를 설명하는 데 사용되는 문자로, 사용자 인터페이스에는 나타나지 않습니다. |
별칭 | 메뉴의 별칭을 지정합니다. 타원 버튼[...]을 클릭하여 별칭 대화상자를 엽니다. CUI 파일의 별칭마다 고유해야 하며 프로그램에 따라서 메뉴를 참조하는 데 사용됩니다. | POP1, FILE
요소 ID | 메뉴를 고유하게 식별하는 태그입니다. | ID_MnFile

풀다운 메뉴 별칭

풀다운 메뉴는 POP1에서 POP499까지의 범위에서 하나의 별칭을 가져야 합니다. 메뉴가 로드할 때 별칭이 POP1에서 POP16까지인 메뉴를 기본값으로 로드합니다. 다른 모든 메뉴는 해당 메뉴가 표시될 작업공간에 추가해야 합니다.

주또한 풀다운 또는 바로 가기 메뉴를 작성할 때 명령을 메뉴에 추가해야 합니다. 그렇지 않으면 메뉴가 파일에 저장되지 않습니다.

이 단원의 항목

  • 풀다운 메뉴 작성

    사용자 인터페이스 사용자화 편집기의 사용자화 탭에서 풀다운 메뉴를 작성하고 부 메뉴 및 명령을 추가할 수 있습니다. 이 과정은 도구막대 및 플라이아웃 작업과 매우 유사하며 약간의 차이만 있습니다.

  • 바로 가기 메뉴 작성

    좌표 입력 장치를 마우스 오른쪽 버튼으로 클릭하면 마우스 커서 위치에 바로 가기 메뉴가 표시됩니다. 제공되는 바로 가기 메뉴 및 옵션은 포인터 위치와 다른 조건(객체가 선택되었는지, 명령이 처리 중인지 여부)에 따라 달라집니다. 또한 스크립트를 사용하여 바로 가기 메뉴를 표시할 수도 있습니다.

  • 부 메뉴 작성

    메뉴를 작성한 것과 거의 같은 방식으로 부 메뉴를 작성합니다.

  • 풀다운 또는 바로 가기 메뉴 참조

    부 메뉴 활성화에 사용한 방법과 유사한 방법을 사용하여 다른 풀다운 또는 바로 가기 메뉴를 활성화 또는 비활성화할 수 있습니다. 이 방법을 메뉴 참조라고 합니다.

  • 풀다운 메뉴 교체 및 삽입

    사용자 인터페이스 사용자화 편집기를 사용하여 풀다운 메뉴의 교체를 조정하기 위해 작업공간을 사용할 수 있습니다. 그러나 풀다운 메뉴를 프로그램적으로 교체할 수도 있습니다(예: 사용자가 추가 메뉴가 필요한 응용프로그램을 로드하는 경우). 메뉴를 교체하면 다른 메뉴에서 직접 하나의 메뉴를 활성화할 수 있습니다.


풀다운 메뉴 및 바로 가기 메뉴 작성 (절차)

도구막대 컨트롤 추가 또는 전환
풀다운 메뉴 및 바로 가기 메뉴 작성
풀다운 메뉴 작성
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 풀다운 메뉴 및 바로 가기 메뉴 작성 >
풀다운 메뉴 및 바로 가기 메뉴 작성
개념 절차

풀다운 메뉴를 작성하려면

풀다운 메뉴에 명령을 추가하려면

메뉴 항목의 캡션을 변경하려면

바로 가기 메뉴를 작성하려면

명령 바로 가기 메뉴를 작성하려면

객체 바로 가기 메뉴를 작성하려면

부 메뉴를 작성하려면


풀다운 메뉴 작성 (개념)

풀다운 메뉴 및 바로 가기 메뉴 작성
풀다운 메뉴 및 바로 가기 메뉴 작성
바로 가기 메뉴 작성
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 풀다운 메뉴 및 바로 가기 메뉴 작성 >
풀다운 메뉴 작성
개념 절차 요약 참조

사용자 인터페이스 사용자화 편집기의 사용자화 탭에서 풀다운 메뉴를 작성하고 부 메뉴 및 명령을 추가할 수 있습니다. 이 과정은 도구막대 및 플라이아웃 작업과 매우 유사하며 약간의 차이만 있습니다.

메뉴에서 명령을 추가하고 수정할 수 있습니다. 메뉴에서 표준 명령의 위치 지정을 수정할 때 온라인 도움말 시스템은 동적 도움말 기능을 통해 이 변경사항을 반영하도록 자동으로 업데이트됩니다. 동적 도움말이 사용자화에 적용되는 방법에 대한 자세한 정보는 사용자화가 변경된 방식을 참조하십시오.

주메뉴를 작성할 때에는 해당 메뉴를 표시하려는 작업공간을 결정해야 합니다. 새 메뉴는 기본값으로 모든 작업공간에 표시됩니다.

표시: 풀다운 메뉴 작성

다음 이미지 아래의 재생 화살표를 클릭하여 애니메이션을 시작합니다.

아래 애니매이션은 사용자 풀다운 메뉴를 작성하고 그 위에 표준 명령 및 사용자 명령을 배치하는 방법을 보여줍니다. 그러나 사용자 명령을 작성하는 방법을 보여주지는 않습니다. 사용자 명령을 작성하는 방법에 대한 정보는 명령 작성, 편집 및 재사용을 참조하고 이미지를 명령에 지정하는 방법에 대한 정보는 명령 이미지 작성을 참조하십시오.

참고

    • 풀다운 메뉴를 작성하려면 (절차)

    • 풀다운 메뉴에 명령을 추가하려면 (절차)

    • 메뉴 항목의 캡션을 변경하려면 (절차)


풀다운 메뉴 작성 (절차)

풀다운 메뉴 및 바로 가기 메뉴 작성
상위 단계로
풀다운 메뉴 작성
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 풀다운 메뉴 및 바로 가기 메뉴 작성 > 풀다운 메뉴 작성 >
풀다운 메뉴 작성
개념 절차 요약 참조

풀다운 메뉴를 작성하려면

풀다운 메뉴에 명령을 추가하려면

메뉴 항목의 캡션을 변경하려면


풀다운 메뉴 작성 (절차)

풀다운 메뉴 작성
상위 단계로
풀다운 메뉴 작성
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 풀다운 메뉴 및 바로 가기 메뉴 작성 > 풀다운 메뉴 작성 >
풀다운 메뉴 작성
개념 절차 요약 참조

풀다운 메뉴를 작성하려면

  1. 도구 메뉴 [image] 사용자화 [image] 인터페이스를 클릭합니다.명령 프롬프트에서 cui를 입력합니다.
  2. 사용자 인터페이스 사용자화 편집기의 사용자화 탭에 있는 <파일 이름>의 사용자화 창에서 메뉴를 마우스 오른쪽 버튼으로 클릭합니다. 새 메뉴를 클릭합니다.

    (Menu1로 명명된) 새 메뉴는 메뉴 트리의 맨 아래에 놓입니다.

  3. 다음 중 하나를 수행합니다.
    • Menu1 문자 위에 새 이름을 입력합니다.
    • Menu1을 마우스 오른쪽 버튼으로 클릭합니다. 이름 바꾸기를 클릭합니다. 새 메뉴 이름을 입력합니다.
    • Menu1을 클릭하고 기다린 다음 메뉴 이름을 다시 클릭하여 이름을 내부 편집합니다.
  4. 트리 뷰에서 새 메뉴를 선택하고 특성 창을 다음과 같이 업데이트합니다.
    • 설명 상자에 메뉴에 대한 설명을 입력합니다.
    • 별칭 상자에서는 이미 로드된 메뉴 숫자를 바탕으로 새 메뉴에 별칭이 자동 지정됩니다. 예를 들어, 별칭 지정이 POP12인 경우 이미 11개의 메뉴가 로드되었다는 것을 뜻합니다. 별칭을 보거나 편집합니다.
    • (선택사항)DIESEL 표현식을 기반으로 이름을 변경하는 경우 DIESEL 표현식은 이름 상자에 포함되어야 합니다.

  5. 명령 리스트 창에서 명령을 <파일 이름>의 사용자화 창에 있는 메뉴 바로 아래의 위치로 끌어옵니다.

    주명령이 메뉴에 추가된 후에 명령 이름을 변경할 수 있습니다. 이렇게 하면 사용자가 Alt 키를 사용해 키보드 검색으로 메뉴 항목에 접근할 수 있는 방법을 정의할 수 있습니다. 이를 위해서 메뉴 노드 아래의 메뉴 항목을 선택한 다음 특성 창에서 이름 특성을 변경합니다.
  6. 확인을 클릭합니다.


풀다운 메뉴 작성 (절차)

풀다운 메뉴 작성
상위 단계로
풀다운 메뉴 작성
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 풀다운 메뉴 및 바로 가기 메뉴 작성 > 풀다운 메뉴 작성 >
풀다운 메뉴 작성
개념 절차 요약 참조

풀다운 메뉴에 명령을 추가하려면

  1. 도구 메뉴 [image] 사용자화 [image] 인터페이스를 클릭합니다.명령 프롬프트에서 cui를 입력합니다.
  2. 사용자 인터페이스 사용자화 편집기의 사용자화 탭에 있는 <파일 이름>의 사용자화 창에서 명령을 추가할 메뉴를 클릭합니다.
  3. 명령 리스트 창에서 추가할 명령을 <파일 이름>의 사용자화 창에 있는 메뉴 바로 아래의 위치로 끌어옵니다.

    주명령이 메뉴에 추가된 후에 명령 이름을 변경할 수 있습니다. 이렇게 하면 사용자가 Alt 키를 사용해 키보드 검색으로 메뉴 항목에 접근할 수 있는 방법을 정의할 수 있습니다. 이를 위해서 메뉴 노드 아래의 메뉴 항목을 선택한 다음 특성 창에서 이름 특성을 변경합니다.
  4. 확인을 클릭합니다.

    명령 작성에 대한 정보는 명령 작성, 편집 및 재사용을 참고하십시오.


풀다운 메뉴 작성 (절차)

풀다운 메뉴 작성
상위 단계로
바로 가기 메뉴 작성
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 풀다운 메뉴 및 바로 가기 메뉴 작성 > 풀다운 메뉴 작성 >
풀다운 메뉴 작성
개념 절차 요약 참조

메뉴 항목의 캡션을 변경하려면

  1. 도구 메뉴 [image] 사용자화 [image] 인터페이스를 클릭합니다.명령 프롬프트에서 cui를 입력합니다.
  2. 사용자 인터페이스 사용자화 편집기의 사용자화 탭에 있는 <파일 이름>의 사용자화 창에서 메뉴 노드 옆에 있는 더하기 기호(+)를 클릭하여 메뉴 노드를 확장합니다.
  3. 변경할 텍스트의 명령이 있는 풀다운 메뉴 옆의 더하기 기호(+)를 클릭합니다.
  4. 변경할 텍스트의 명령을 선택합니다.
  5. 특성 창의 표시 섹션에서 (명령 이름 특성이 아닌)이름 특성에 원하는 변경을 수행합니다.

  6. 확인을 클릭합니다.


풀다운 메뉴 작성 (요약 참조)

도구막대 컨트롤 추가 또는 전환
풀다운 메뉴 작성
바로 가기 메뉴 작성
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 풀다운 메뉴 및 바로 가기 메뉴 작성 > 풀다운 메뉴 작성 >
풀다운 메뉴 작성
개념 절차 요약 참조

명령

CUI

작업공간, 도구막대, 메뉴, 바로 가기 메뉴 및 키보드 바로 가기와 같은 사용자화된 사용자 인터페이스 요소를 관리합니다.

시스템 변수

항목이 없습니다.

유틸리티

항목이 없습니다.

명령 수정자

항목이 없습니다.


바로 가기 메뉴 작성 (개념)

풀다운 메뉴 작성
풀다운 메뉴 및 바로 가기 메뉴 작성
부 메뉴 작성
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 풀다운 메뉴 및 바로 가기 메뉴 작성 >
바로 가기 메뉴 작성
개념 절차 요약 참조

좌표 입력 장치를 마우스 오른쪽 버튼으로 클릭하면 마우스 커서 위치에 바로 가기 메뉴가 표시됩니다. 제공되는 바로 가기 메뉴 및 옵션은 포인터 위치와 다른 조건(객체가 선택되었는지, 명령이 처리 중인지 여부)에 따라 달라집니다. 또한 스크립트를 사용하여 바로 가기 메뉴를 표시할 수도 있습니다.

상황에 맞는 바로 가기 메뉴는 현재 명령 또는 선택된 객체와 관련된 항목을 마우스 오른쪽 버튼으로 클릭할 때 메뉴 옵션을 표시합니다.

바로 가기 메뉴 별칭

바로 가기 메뉴는 해당 별칭으로 참조하며 특수 상태에서 사용합니다. 사용자 인터페이스 사용자화 편집기에서 적절한 명명 규칙에 따라 별칭의 이름을 지정해야 합니다. 예를 들어 “기본 메뉴”로 명명된 바로 가기 메뉴는 특성 창의 별칭 섹션에 다음과 같은 정보를 표시합니다.

POP501, CMDEFAULT

객체 스냅 바로 가기 메뉴의 별칭은 POP0이어야 합니다. 상황에 맞는 바로 가기 메뉴의 별칭은 POP500와 POP999 사이의 숫자여야 하며 다음 별칭은 프로그램용으로 예약되어 있습니다.

바로 가기 메뉴의 프로그램 별칭
별칭 | 설명
GRIPS | 핫 맞물림 바로 가기 메뉴를 정의합니다. (객체의 맞물림이 선택될 때 도면 영역을 마우스 오른쪽 버튼으로 클릭합니다.)
CMDEFAULT | 기본 모드 바로 가기 메뉴를 정의합니다. (모든 명령이 비활성화이고 객체 또한 전혀 선택되지 않았을 때 도면 영역을 마우스 오른쪽 버튼으로 클릭합니다.)
CMEDIT | 편집 모드 바로 가기 메뉴를 정의합니다. (하나 이상의 객체가 선택되고 맞물림은 전혀 선택되지 않았으며 모든 명령이 비활성화일 때, 도면 영역을 마우스 오른쪽 버튼으로 클릭합니다.)
CMCOMMAND | 명령 모드 메뉴를 정의합니다. (명령이 활성화되었을 때 도면 영역을 마우스 오른쪽 버튼으로 클릭합니다.) CMCOMMAND 메뉴의 내용뿐 아니라 명령 옵션(대괄호 내의 키워드)도 이 메뉴에 삽입됩니다.
SNAP | 객체 스냅 메뉴를 정의합니다. (Shift 키를 누른 상태에서 도면 영역을 마우스 오른쪽 버튼으로 클릭합니다.)

CMEDIT 및 CMCOMMAND 바로 가기 메뉴는 상황별 메뉴가 될 수 있습니다. CMEDIT 메뉴의 내용뿐 아니라 하나 이상의 특정 객체 유형이 선택될 때 적절한 객체 메뉴(있는 경우)가 이 메뉴에 삽입됩니다. 객체 메뉴는 다음의 명명 규칙 중 하나를 사용합니다.
OBJECT_objectname

OBJECTS_objectname

단일 객체를 선택하면 OBJECT_objectname 메뉴가 사용되고, 하나 이상의 객체를 선택하면 OBJECTS_objectname 메뉴가 사용됩니다. 사용 가능한 OBJECT_objectname이 없을 경우 , 프로그램은 OBJECTS_objectname 메뉴(있을 경우)를 사용합니다.

삽입된 객체를 제외한 모든 경우에 객체 이름은 객체의 도면 교환 형식(DXF™) 이름입니다. 다음 테이블은 블록, 동적 블록 및 외부 참조에 해당하는 객체 이름을 보여줍니다.

삽입된 객체에 해당하는 객체 이름
객체 이름 | 설명
BLOCKREF | 속성 없는 블록 참조
ATTBLOCKREF | 속성 있는 블록 참조
DYNBLOCKREF | 속성 없는 동적 블록 참조
ATTDYNBLOCKREF | 속성 있는 동적 블록 참조
XREF | 외부 참조(Xref)

예를 들어, 하나 이상 선택된 블록 참조에 대해 객체 지정 바로 가기 명령을 지원하려면, 다음 특성을 사용자 인터페이스 사용자화 편집기의 특성 창에 있는 사용자화 탭에 추가합니다.

블록 참조 객체 바로 가기 메뉴의 특성
특성 창 항목 | 설명 | 예제
이름 | CUI 편집기에서만 사용되고 사용자 인터페이스에는 표시되지 않는 문자열입니다. | 블록 객체 메뉴
설명 | 요소를 설명하는 데 사용되는 문자로, 사용자 인터페이스에는 나타나지 않습니다. | 블록 객체의 바로 가기 메뉴
별칭 | 바로 가기 메뉴의 별칭을 지정합니다. 타원 버튼[...]을 클릭하여 별칭 대화상자를 엽니다. CUI 파일의 별칭마다 고유해야 하며 프로그램에 따라서 바로 가기 메뉴를 참조하는 데 사용됩니다. | POP512,OBJECTS_BLOCKREF
요소 ID | 바로 가기 메뉴를 고유하게 식별하는 태그입니다. | PM_0021

CMEDIT 메뉴처럼 CMCOMMAND 메뉴에는 상황에 맞는 정보가 포함될 수 있습니다. COMMAND_commandname으로 명명된 모든 메뉴가 CMCOMMAND 메뉴에 추가됩니다. commandname의 문자는 사용자 정의 또는 외부 명령을 포함하여 유효한 AutoCAD 명령이면 어느 것이든 가능합니다.

대부분의 경우 명령 앞에 하이픈을 입력하여 대화상자 대신 명령 프롬프트가 표시되게 할 수 있습니다. (-INSERT와 같이)대화상자 대신 프롬프트를 표시하는 명령에 대해 상황에 맞는 메뉴를 작성하려면 메뉴에 COMMAND_-INSERT라는 이름을 지정해야 합니다.

참고

    • 바로 가기 메뉴를 작성하려면 (절차)

    • 명령 바로 가기 메뉴를 작성하려면 (절차)

    • 객체 바로 가기 메뉴를 작성하려면 (절차)


바로 가기 메뉴 작성 (절차)

풀다운 메뉴 작성
상위 단계로
바로 가기 메뉴 작성
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 풀다운 메뉴 및 바로 가기 메뉴 작성 > 바로 가기 메뉴 작성 >
바로 가기 메뉴 작성
개념 절차 요약 참조

바로 가기 메뉴를 작성하려면

명령 바로 가기 메뉴를 작성하려면

객체 바로 가기 메뉴를 작성하려면


바로 가기 메뉴 작성 (절차)

바로 가기 메뉴 작성
상위 단계로
바로 가기 메뉴 작성
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 풀다운 메뉴 및 바로 가기 메뉴 작성 > 바로 가기 메뉴 작성 >
바로 가기 메뉴 작성
개념 절차 요약 참조

바로 가기 메뉴를 작성하려면

  1. 도구 메뉴 [image] 사용자화 [image] 인터페이스를 클릭합니다.명령 프롬프트에서 cui를 입력합니다.
  2. 사용자 인터페이스 사용자화 편집기의 사용자화 탭에 있는 <파일 이름>의 사용자화 창에서 바로 가기 메뉴를 마우스 오른쪽 버튼으로 클릭합니다. 새 바로 가기 메뉴를 클릭합니다.

    “ShortcutMenu1”로 명명된 새 바로 가기 메뉴는 메뉴 트리의 맨 아래에 놓입니다.

  3. 다음 중 하나를 수행합니다.
    • ShortcutMenu1 문자 위에 이름을 입력합니다.
    • ShortcutMenu1을 마우스 오른쪽 버튼으로 클릭합니다. 이름 바꾸기를 클릭합니다. 새 바로 가기 메뉴 이름을 입력합니다.
    • ShortcutMenu1을 클릭하고 기다린 다음 바로 가기 메뉴 이름을 다시 클릭하여 이름을 내부 편집합니다.
  4. 특성 창에서 다음을 수행합니다.
    • 설명 상자에 바로 가기 메뉴에 대한 설명을 입력합니다.
    • 별칭 상자에서 줄임표 버튼을 클릭합니다. 별칭 대화상자에서 줄 바꿈하도록 ENTER 키를 누릅니다. 메뉴의 추가 별칭을 입력하고 각각 입력한 다음 ENTER 키를 누릅니다. 별칭은 이미 프로그램에 로드된 바로 가기 메뉴의 수를 기준으로 자동 지정되며 다음으로 사용 가능한 POP 번호가 기본값이 됩니다.

  5. 명령 리스트 창에서 추가할 명령을 사용자화 <파일 이름> 창에 있는 바로 가기 메뉴 바로 아래의 위치로 끌어옵니다.

  6. 새 바로 가기 메뉴를 완성할 때까지 명령 추가를 계속합니다.
  7. 확인을 클릭합니다.


바로 가기 메뉴 작성 (절차)

바로 가기 메뉴 작성
상위 단계로
바로 가기 메뉴 작성
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 풀다운 메뉴 및 바로 가기 메뉴 작성 > 바로 가기 메뉴 작성 >
바로 가기 메뉴 작성
개념 절차 요약 참조

명령 바로 가기 메뉴를 작성하려면

  1. 도구 메뉴 [image] 사용자화 [image] 인터페이스를 클릭합니다.명령 프롬프트에서 cui를 입력합니다.
  2. 사용자 인터페이스 사용자화 편집기의 사용자화 탭에 있는 <파일 이름>의 사용자화 창에서 바로 가기 메뉴를 마우스 오른쪽 버튼으로 클릭합니다. 새 바로 가기 메뉴를 클릭합니다.

    “ShortcutMenu1”로 명명된 새 바로 가기 메뉴는 메뉴 트리의 맨 아래에 놓입니다.

  3. 다음 중 하나를 수행합니다.
    • ShortcutMenu1 문자 위에 이름을 입력합니다.
    • ShortcutMenu1을 마우스 오른쪽 버튼으로 클릭합니다. 이름 바꾸기를 클릭합니다. 새 바로 가기 메뉴 이름을 입력합니다.
    • ShortcutMenu1을 클릭하고 기다린 다음 바로 가기 메뉴 이름을 다시 클릭하여 이름을 내부 편집합니다.
  4. 특성 창에서 다음을 수행합니다.
    • 설명 상자에 바로 가기 메뉴에 대한 설명을 입력합니다.
    • 별칭 상자에서 줄임표 버튼을 클릭합니다. 별칭 대화상자에서 줄 바꿈하도록 ENTER 키를 누릅니다. 메뉴의 추가 별칭을 입력하고 각각 입력한 다음 ENTER 키를 누릅니다. 별칭은 이미 프로그램에 로드된 바로 가기 메뉴의 수를 기준으로 자동 지정되며 다음으로 사용 가능한 POP 번호가 기본값이 됩니다.

      명령이 활성화될 때 바로 가기 메뉴의 명령이 나타나도록 하려면 별칭 COMMAND_commandname을 사용하는지 확인하십시오. 예를 들어, LINE 명령을 사용할 때 바로 가기 메뉴의 명령이 나타나도록 할 경우 별칭 COMMAND_LINE을 사용합니다. 바로 가기 메뉴의 명령은 표시될 때 별칭 CMCOMMAND와 함께 바로 가기 메뉴의 맨 아래에 나타납니다.

  5. 명령 리스트 창에서 추가할 명령을 사용자화 <파일 이름> 창에 있는 바로 가기 메뉴 바로 아래의 위치로 끌어옵니다.

  6. 새 바로 가기 메뉴를 완성할 때까지 명령 추가를 계속합니다.
  7. 확인을 클릭합니다.


바로 가기 메뉴 작성 (절차)

바로 가기 메뉴 작성
상위 단계로
부 메뉴 작성
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 풀다운 메뉴 및 바로 가기 메뉴 작성 > 바로 가기 메뉴 작성 >
바로 가기 메뉴 작성
개념 절차 요약 참조

객체 바로 가기 메뉴를 작성하려면

  1. 도구 메뉴 [image] 사용자화 [image] 인터페이스를 클릭합니다.명령 프롬프트에서 cui를 입력합니다.
  2. 사용자 인터페이스 사용자화 편집기의 사용자화 탭에 있는 <파일 이름>의 사용자화 창에서 바로 가기 메뉴를 마우스 오른쪽 버튼으로 클릭합니다. 새 바로 가기 메뉴를 클릭합니다.

    “ShortcutMenu1”로 명명된 새 바로 가기 메뉴는 메뉴 트리의 맨 아래에 놓입니다.

  3. 다음 중 하나를 수행합니다.
    • ShortcutMenu1 문자 위에 이름을 입력합니다.
    • ShortcutMenu1을 마우스 오른쪽 버튼으로 클릭합니다. 이름 바꾸기를 클릭합니다. 새 바로 가기 메뉴 이름을 입력합니다.
    • ShortcutMenu1을 클릭하고 기다린 다음 바로 가기 메뉴 이름을 다시 클릭하여 이름을 내부 편집합니다.
  4. 특성 창에서 다음을 수행합니다.
    • 설명 상자에 바로 가기 메뉴에 대한 설명을 입력합니다.
    • 별칭 상자에서 줄임표 버튼을 클릭합니다. 별칭 대화상자에서 줄 바꿈하도록 ENTER 키를 누릅니다. 메뉴의 추가 별칭을 입력하고 각각 입력한 다음 ENTER 키를 누릅니다. 별칭은 이미 프로그램에 로드된 바로 가기 메뉴의 수를 기준으로 자동 지정되며 다음으로 사용 가능한 POP 번호가 기본값이 됩니다.

      같은 유형의 객체를 선택할 때 바로 가기 메뉴의 명령이 나타나도록 하려면 별칭 OBJECT_objecttype 또는 OBJECTS_objecttype을 사용하는지 확인하십시오. 예를 들어, 도면에서 LINE 객체를 선택할 때 바로 가기 메뉴의 명령이 나타나도록 할 경우 별칭 OBJECT_LINE을 사용합니다. 바로 가기 메뉴의 명령은 표시될 때 별칭 CMEDIT와 함께 바로 가기 메뉴의 위쪽에 나타납니다.

    주별칭 OBJECTS_objecttype과 함께 바로 가기 메뉴를 작성할 경우 마우스 오른쪽 버튼으로 도면 영역을 클릭하기 전에 하나 이상의 객체를 선택하면 바로 가기 메뉴에 지정된 명령이 표시됩니다.

  5. 명령 리스트 창에서 추가할 명령을 사용자화 <파일 이름> 창에 있는 바로 가기 메뉴 바로 아래의 위치로 끌어옵니다.

  6. 새 바로 가기 메뉴를 완성할 때까지 명령 추가를 계속합니다.
  7. 확인을 클릭합니다.


바로 가기 메뉴 작성 (요약 참조)

풀다운 메뉴 작성
바로 가기 메뉴 작성
부 메뉴 작성
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 풀다운 메뉴 및 바로 가기 메뉴 작성 > 바로 가기 메뉴 작성 >
바로 가기 메뉴 작성
개념 절차 요약 참조

명령

CUI

작업공간, 도구막대, 메뉴, 바로 가기 메뉴 및 키보드 바로 가기와 같은 사용자화된 사용자 인터페이스 요소를 관리합니다.

시스템 변수

SHORTCUTMENU

도면 영역에서 기본, 편집 및 명령 모드 바로 가기 메뉴를 사용할 수 있는지 여부를 조정합니다

유틸리티

항목이 없습니다.

명령 수정자

항목이 없습니다.


부 메뉴 작성 (개념)

바로 가기 메뉴 작성
풀다운 메뉴 및 바로 가기 메뉴 작성
풀다운 또는 바로 가기 메뉴 참조
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 풀다운 메뉴 및 바로 가기 메뉴 작성 >
부 메뉴 작성
개념 절차 요약 참조

메뉴를 작성한 것과 거의 같은 방식으로 부 메뉴를 작성합니다.

다음 테이블에서는 사용자 인터페이스 사용자화 편집기에서 사용할 수 있는 비영숫자 문자를 설명합니다. 나열되지 않은 비영숫자 문자는 나중에 특수 메뉴 문자로 사용하기 위해 예약되어 있습니다.

부 메뉴의 특수 문자
문자 | 설명 | 예제
$( | $(가 첫 번째 문자일 경우 풀다운 또는 바로 가기 명령 레이블을 사용 가능하게 하여 DIESEL 문자열 매크로를 계산합니다. |
~ | 명령을 사용할 수 없게 만듭니다. |
!. | 명령에 확인 표시를 합니다. |
& | 문자 바로 앞에 놓이며 해당 문자를 풀다운 또는 바로 가기 메뉴 레이블의 메뉴 접근 키로 지정합니다. | S&ample은 견본을 표시합니다(a 문자에 밑줄이 있음).
\t | 이 문자 다음에 입력된 모든 레이블 문자를 메뉴의 오른쪽에 넣습니다. | 도움말 \tF1은 풀다운 메뉴의 왼쪽에 도움말을 표시하며 오른쪽에는 F1을 표시합니다.
참고

    • 부 메뉴를 작성하려면 (절차)


부 메뉴 작성 (절차)

바로 가기 메뉴 작성
상위 단계로
대시보드 패널 사용자화
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 풀다운 메뉴 및 바로 가기 메뉴 작성 > 부 메뉴 작성 >
부 메뉴 작성
개념 절차 요약 참조

부 메뉴를 작성하려면

  1. 도구 메뉴 [image] 사용자화 [image] 인터페이스를 클릭합니다.명령 프롬프트에서 cui를 입력합니다.
  2. 사용자 인터페이스 사용자화 편집기의 사용자화 탭에 있는 <파일 이름>의 사용자화 창에서 메뉴 옆에 있는 더하기 기호(+)를 클릭합니다. 부 메뉴를 추가하려는 메뉴를 선택합니다.

  3. 메뉴를 마우스 오른쪽 버튼으로 클릭합니다. 새 부 메뉴를 클릭합니다.

    Menu1로 명명된 새로운 부 메뉴는 부 메뉴를 추가하기 위해 선택한 해당 메뉴의 맨 아래에 놓입니다.

  4. 다음 중 하나를 수행합니다.
    • Menu1 문자 위에 새 이름을 입력합니다.
    • Menu1을 마우스 오른쪽 버튼으로 클릭합니다. 이름 바꾸기를 클릭합니다. 새 부 메뉴 이름을 입력합니다.
    • Menu1을 클릭하고 기다린 다음 메뉴 이름을 다시 클릭하여 이름을 내부 편집합니다.
  5. 특성 창에서 다음을 수행합니다.
    • 설명 상자에 부 메뉴에 대한 설명을 입력합니다.

  6. 명령 리스트 창에서 추가할 명령을 사용자화 <파일 이름> 창에 있는 부 메뉴의 이름 바로 아래 위치로 끌어옵니다.

  7. 새 부 메뉴가 완성될 때까지 명령 추가를 계속합니다.
  8. 확인을 클릭합니다.


부 메뉴 작성 (요약 참조)

바로 가기 메뉴 작성
부 메뉴 작성
풀다운 또는 바로 가기 메뉴 참조
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 풀다운 메뉴 및 바로 가기 메뉴 작성 > 부 메뉴 작성 >
부 메뉴 작성
개념 절차 요약 참조

명령

CUI

작업공간, 도구막대, 메뉴, 바로 가기 메뉴 및 키보드 바로 가기와 같은 사용자화된 사용자 인터페이스 요소를 관리합니다.

시스템 변수

항목이 없습니다.

유틸리티

항목이 없습니다.

명령 수정자

항목이 없습니다.


풀다운 또는 바로 가기 메뉴 참조 (개념)

부 메뉴 작성
풀다운 메뉴 및 바로 가기 메뉴 작성
풀다운 메뉴 교체 및 삽입
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 풀다운 메뉴 및 바로 가기 메뉴 작성 >
풀다운 또는 바로 가기 메뉴 참조
개념 요약 참조

부 메뉴 활성화에 사용한 방법과 유사한 방법을 사용하여 다른 풀다운 또는 바로 가기 메뉴를 활성화 또는 비활성화할 수 있습니다. 이 방법을 메뉴 참조라고 합니다.

풀다운 메뉴 또는 바로 가기 메뉴를 참조하는 방법에는 상대 참조와 절대 참조의 두 가지가 있습니다. 상대 참조는 사용자화 그룹 및 요소 ID를 사용합니다. 절대 참조는 메뉴 계층 구조에 있는 메뉴 항목의 절대 위치를 사용합니다. 메뉴의 현재 상태와 관계없이 작동한다는 동적인 특성을 감안하면 상대 참조 방법을 사용하는 것이 좋습니다.

풀다운 및 바로 가기 명령의 상대 참조

사용자화 그룹 및 요소 ID를 기반으로 풀다운 또는 바로 가기 메뉴 항목을 참조하려면 AutoLISP menucmd 함수를 사용합니다. 다음 구문에서는 요소 ID를 기준으로 메뉴 항목을 참조합니다.

(menucmd "Gmenugroup.element_id=value")

다음 예제는 상대 참조 구문을 사용하여 견본 사용자화 그룹에 저장된 메뉴 항목 ID_Line이 작동하지 않도록 합니다. 이것은 메뉴에서 메뉴 항목의 위치와 관계 없이 작동합니다.

(menucmd "Gsample.ID_Line=~")

주 CUI 파일에 포함된 내용을 아는 경우, 주 파일을 참조하는 추가 메뉴 항목과 함께 부분적 CUI 파일을 작성할 수 있습니다. 이러한 방식으로 부분 CUI 파일과 특정 기본 파일이 함께 작동할 수 있습니다.

풀다운 및 바로 가기 메뉴 항목의 절대 참조

메뉴 항목을 참조하는 것 이외에도 $Pn=xxx 구문을 사용하여 메뉴 항목을 활성화 또는 비활성화할 수 있습니다. 이에 대한 형식은 다음과 같습니다.

$Pn.i=xxx

$는 메뉴 섹션을 로드합니다. Pn은 활성화 메뉴 섹션을 지정합니다(유효값은 0에서 16까지). i는 메뉴 항목 번호를 지정합니다. 그리고 xxx(있는 경우)는 그레이 아웃되거나 표시된 문자의 문자열을 지정합니다.

다음 예제에서는 $Pn=xxx 구문을 사용하여 POP7 섹션의 항목 1에 확인 표시를 추가합니다.

$P7.1=!.

다음 예제에서는 AutoLISP menucmd 함수를 사용하여 풀다운 또는 바로 가기 메뉴 항목을 참조합니다. 부분적 CUI 파일 로드 중에 사용자화 파일이 동적이기 때문에 다음 구문은 어떠한 경우에도 작동되지 않습니다.

(menucmd "P1.2=~")

이 구문은 메뉴 항목의 위치에 의존하며, CUILOAD 명령으로 POP1 앞에 새 항목을 삽입하는 경우에는 작동하지 않습니다.

메뉴 항목 번호 매기기는 메뉴의 계층 구조에 관계없이 연속적입니다.

메뉴 계층 구조에서의 위치와 관계없이 항목이 자체적으로 처리되도록 하려면 다음 형식을 사용하십시오.

$P@.@=xxx

현재 명령 또는 가장 최근에 선택한 명령을 참조합니다.

$P@.n=xxx

현재 메뉴 또는 가장 최근에 선택한 메뉴의 항목 n을 참조합니다.

레이블 상태에 AutoLISP 접근

AutoLISP menucmd 함수는 $Pn=xxx 명령 문자를 앞에 $를 제외하고 승인합니다. 이러한 함수에서 명령 문자열의 xxx 부분에는 특수한 값이 있을 수 있습니다.

Pn.i=?

지정된 항목의 현재 표식 상태와 사용 불가능 상태를 문자열로 반환합니다(예: 사용 불가능한 항목은 ~, 확인 표시가 있는 항목은 !.확인 표시가 있는 항목은 , 그레이 아웃되지도 않고 표식도 없는 항목은 "").

Pn.i=#?

Pn.i=?에 대해 설명한 것과 같은 유형의 문자열을 Pni= 머리글과 함께 반환합니다. 이것은 실제 메뉴와 항목 번호가 반환되기 때문에 @ 형식과 함께 사용하면 유용합니다.

예를 들어, POP6 섹션에서 다섯 번째 항목이 사용 불가능할 경우 다음의 menucmd 코드가 다음 문자열 값을 반환합니다.

(menucmd "P6.5=?") returns "~"
(menucmd "P6.5=#?") returns "P6.5=~"


풀다운 또는 바로 가기 메뉴 참조 (요약 참조)

부 메뉴 작성
풀다운 또는 바로 가기 메뉴 참조
풀다운 메뉴 교체 및 삽입
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 풀다운 메뉴 및 바로 가기 메뉴 작성 > 풀다운 또는 바로 가기 메뉴 참조 >
풀다운 또는 바로 가기 메뉴 참조
개념 요약 참조

명령

CUI

작업공간, 도구막대, 메뉴, 바로 가기 메뉴 및 키보드 바로 가기와 같은 사용자화된 사용자 인터페이스 요소를 관리합니다.

시스템 변수

항목이 없습니다.

유틸리티

항목이 없습니다.

명령 수정자

항목이 없습니다.


풀다운 메뉴 교체 및 삽입 (개념)

풀다운 또는 바로 가기 메뉴 참조
풀다운 메뉴 및 바로 가기 메뉴 작성
대시보드 패널 사용자화
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 풀다운 메뉴 및 바로 가기 메뉴 작성 >
풀다운 메뉴 교체 및 삽입
개념 요약 참조

사용자 인터페이스 사용자화 편집기를 사용하여 풀다운 메뉴의 교체를 조정하기 위해 작업공간을 사용할 수 있습니다. 그러나 풀다운 메뉴를 프로그램적으로 교체할 수도 있습니다(예: 사용자가 추가 메뉴가 필요한 응용프로그램을 로드하는 경우). 메뉴를 교체하면 다른 메뉴에서 직접 하나의 메뉴를 활성화할 수 있습니다.

풀다운 메뉴 교체

프로그램에는 계단식 풀다운 메뉴가 있기 때문에 메뉴를 교체할 필요가 거의 없습니다. 또한 메뉴를 교체하면 사용자 인터페이스의 일관성이 저하될 수 있습니다. 그러나 $ 명령을 사용하여 풀다운 메뉴와 부 메뉴를 교체할 수 있습니다. 메뉴를 교체하는 다른 방법으로는 상대(또는 전역) 참조가 있습니다. 이 방법을 사용하면 새로운 메뉴를 알려진 메뉴의 앞에 삽입한 다음 알려진 메뉴를 제거할 수 있습니다.

메뉴 교체를 위해 풀다운 메뉴 영역의 이름이 P1에서 P16까지로 명명되어 있습니다. 메뉴의 제목 행을 $Pn= 명령으로 대치하여 메뉴 막대에 표시되는 제목을 변경할 수 있습니다. 모든 명령 내에서 특수 명령 $Pn=*를 사용하여 현재 POPn 영역에 지정된 메뉴가 좌표 입력 장치의 이동에 더 큰 융통성을 제공할 수 있도록 아래로 펼쳐지게 할 수 있습니다.

다음 매크로 예제는 P3 위치에 있는 메뉴를 이름이 MYMENU인 사용자화 그룹의 BudsMenu 메뉴로 대치합니다.

$P3=MyMenu.BudsMenu

다음과 같이 AutoLISP menucmd 함수로도 같은 작업을 할 수 있습니다.

(menucmd "P3=MyMenu.BudsMenu")

어떤 매크로에서든지 $Pn=* 특수 명령을 사용하여 현재 POPn 영역에 지정된 메뉴가 표시되도록 할 수 있습니다.

주풀다운 메뉴의 교체는 Microsoft® 사용자 인터페이스 지침을 따르지 않으며 향후 프로그램 릴리즈에서도 이러한 기능이 제공될지는 확실하지 않습니다.

풀다운 메뉴 삽입 및 제거

메뉴를 교체하면 다른 메뉴에서 직접 하나의 메뉴를 활성화할 수 있습니다. 다음 인터페이스 요소에서 메뉴 교체가 지원됩니다.

  • 버튼
  • 풀다운 메뉴
  • 마우스 버튼
  • 이미지 배열 메뉴
  • 타블렛 메뉴

부분 메뉴 교체를 위한 구문은 다음과 같습니다.

$section=menugroup.menuname

section

B1-4, A1-4, P0-16, T1-4

menugroup

원하는 CUI 파일에 있는 사용자화 그룹 이름

menuname

주 레이블 또는 별칭

AutoLISP menucmd 함수를 사용하여 풀다운 메뉴를 삽입하거나 제거할 수 있습니다. 이에 대한 구문은 새로운 메뉴를 삽입하기 전에 풀다운 메뉴가 지정 항목의 왼쪽에 있다는 점을 제외하면 풀다운 메뉴 교체에 사용되는 구문과 유사합니다. 다음 구문에서와 같이 지정 항목의 오른쪽에는 더하기 기호(+)가 오고 그 뒤에는 메뉴 그룹의 이름, 마침표 및 메뉴 별칭이 옵니다.

(menucmd "Gmenugroup1.menuname1=+menugroup2.menuname2")

Pn= 구문을 사용하여 메뉴를 삽입할 수도 있습니다. 다음 매크로는 메뉴를 P5 메뉴 뒤에 삽입합니다. (이 형식으로 menucmd 함수를 사용할 수도 있습니다.)

(menucmd "P5=+mymenu.new3")

이 방법을 사용하여 메뉴를 삽입하면 예상하는 대로 P6 메뉴 위치에 메뉴가 삽입되지 않을 수 있습니다. 이와 같은 상황을 유발할 수 있는 두가지 원인은 다음과 같습니다.

  • 현재 메뉴 막대에 메뉴가 세 개만 있을 경우 P5 메뉴 뒤에 메뉴를 삽입하면 새 메뉴의 위치는 P4가 됩니다.
  • 사용자가 CUILOAD 명령을 사용하여 사용자화 파일을 삽입 또는 제거하거나 다른 응용프로그램이 사용자화 파일을 삽입 또는 제거하는 경우, 메뉴 번호 부여가 동기화되지 않을 수 있습니다.

다음은 메뉴를 제거하는 구문입니다.

(menucmd "Gmenugroup.menuname=-")

다음 예제는 MyMenu 그룹의 구성원인 NEW3 메뉴를 제거합니다.

(menucmd "Gmymenu.new3=-")

예상하는 것과 같이 앞의 형식이 지정된 메뉴만을 제거하기 때문에 Pn= 형식보다 선호됩니다. 다음 예제는 P4 위치에서 메뉴(종류와 관계없음)를 제거합니다.

$P4=-
주menucmd 문의 경우에만 Pn 구문을 구문의 일부로 사용합니다. 매크로 지정 구문의 경우에는 $Pn 구문을 사용합니다.

부분적 CUI 파일을 통한 도구막대 제어

부분적 CUI 파일을 통해 도구막대를 제어하려면 -TOOLBAR 명령의 도구막대 이름 입력 또는 [모두(A)]: 프롬프트에서 다음 구문을 사용합니다.

menugroup.subsection-name

이 구문은 menugroup.menuname으로 인식되는 도구막대에 접근하며 이 구문을 이용해 해당 도구막대에서 전체 -TOOLBAR 명령 옵션을 사용할 수 있습니다.

메뉴 그룹이 이 명령 및 함수에서 제외되는 경우, 프로그램의 기본값은 주 CUI 파일이 됩니다.

다음 사항에 주의해야 합니다.

  • 이미지 배열 메뉴는 외부 사용자화 파일에서 교체될 수 없습니다.
  • 같은 유형에 대해서만 사용자화 요소를 교체할 수 있습니다. 즉 예를 들어, 하나의 바로 가기 메뉴는 다른 하나의 바로 가기 메뉴로, 하나의 도구막대는 다른 하나의 도구막대로 교체할 수 있습니다. 다른 유형의 메뉴로 교체하면 예기치 않은 동작이 발생할 수 있습니다.


풀다운 메뉴 교체 및 삽입 (요약 참조)

풀다운 또는 바로 가기 메뉴 참조
풀다운 메뉴 교체 및 삽입
대시보드 패널 작성 및 편집
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 풀다운 메뉴 및 바로 가기 메뉴 작성 > 풀다운 메뉴 교체 및 삽입 >
풀다운 메뉴 교체 및 삽입
개념 요약 참조

명령

CUI

작업공간, 도구막대, 메뉴, 바로 가기 메뉴 및 키보드 바로 가기와 같은 사용자화된 사용자 인터페이스 요소를 관리합니다.

CUILOAD

CUI 파일 로드

CUIUNLOAD

CUI 파일 언로드

TOOLBAR

도구막대를 표시하고, 숨기며, 사용자화합니다.

WORKSPACE

작업공간을 작성, 수정 및 저장하고 작업공간을 현재로 만듭니다.

시스템 변수

항목이 없습니다.

유틸리티

항목이 없습니다.

명령 수정자

항목이 없습니다.


대시보드 패널 사용자화

풀다운 메뉴 교체 및 삽입
사용자 인터페이스 사용자화
대시보드 패널 작성 및 편집
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 >
대시보드 패널 사용자화
개념 절차

대시보드 패널 사용자화를 사용하면 대시보드 윈도우에 표시되는 버튼과 컨트롤을 추가하거나 제거하여 패널을 작성하고 수정할 수 있습니다. 도구막대 대신 패널을 사용하여 대시보드 윈도우에서 일반적으로 사용하고 액세스하는 명령을 구성할 수 있습니다. 명령을 구성하면 사용할 수 있는 도면 영역의 양이 최대화됩니다.

이 단원의 항목

  • 대시보드 패널 작성 및 편집

    대시보드 사용자화는 도구막대와 유사한 패널에서 자주 사용하는 명령을 구성하는 데 도움이 됩니다. 패널을 사용하면 명령에 빨리 액세스할 수 있고 AutoCAD에 표시할 수 있는 사용자 인터페이스 요소의 수를 줄이는 데 도움이 됩니다.

  • 대시보드 컨트롤 추가 또는 전환

    대시보드 패널 컨트롤은 드롭다운 리스트, 슬라이더, 텍스트 상자와 그 밖에 선택할 수 있는 대시보드 패널 특정 옵션입니다. 예를 들어, 2D 검색 패널에는 도면의 현재 뷰를 변경하는 컨트롤이 들어 있습니다. 사용자 인터페이스 사용자화 편집기에서 대시보드 패널 내에 컨트롤을 추가하고 제거하며 재배치할 수 있습니다.


대시보드 패널 사용자화 (절차)

부 메뉴 작성
대시보드 패널 사용자화
대시보드 패널 작성 및 편집
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 대시보드 패널 사용자화 >
대시보드 패널 사용자화
개념 절차

대시보드 패널을 작성하려면

대시보드 패널을 제거하려면

대시보드 패널에 행을 추가하려면

도구막대에서 대시보드 패널에 행을 추가하려면

대시보드 패널에서 행을 제거하려면

대시보드 패널에서 행의 위치를 조정하려면

사용자화 창에서 대시보드 패널에 명령을 추가하려면

패널 미리보기 창에서 대시보드 패널에 명령을 추가하려면

대시보드 패널의 행에 플라이아웃을 작성하려면

사용자화 창에서 대시보드 패널의 명령 또는 컨트롤의 위치를 조정하려면

패널 미리보기 창에서 대시보드 패널의 명령 또는 컨트롤의 위치를 조정하려면

사용자화 창에서 대시보드 패널의 명령 또는 컨트롤을 제거하려면

패널 미리보기 창에서 대시보드 패널의 명령 또는 컨트롤을 제거하려면

사용자화 창에서 대시보드 패널에 컨트롤을 추가하려면

패널 미리보기 창에서 대시보드 패널에 컨트롤을 추가하려면

대시보드 패널에서 컨트롤을 전환하려면


대시보드 패널 작성 및 편집 (개념)

대시보드 패널 사용자화
대시보드 패널 사용자화
대시보드 컨트롤 추가 또는 전환
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 대시보드 패널 사용자화 >
대시보드 패널 작성 및 편집
개념 절차 요약 참조

대시보드 사용자화는 도구막대와 유사한 패널에서 자주 사용하는 명령을 구성하는 데 도움이 됩니다. 패널을 사용하면 명령에 빨리 액세스할 수 있고 AutoCAD에 표시할 수 있는 사용자 인터페이스 요소의 수를 줄이는 데 도움이 됩니다.

표시: 대시보드 패널 작성

다음 이미지 아래의 재생 화살표를 클릭하여 애니메이션을 시작합니다.

아래 애니메이션은 대시보드 패널을 작성하고, 행을 추가하고, 행에 명령을 추가하고, 작업공간을 통해 패널 가시성을 조정하는 방법을 보여줍니다. 그러나 사용자 명령을 작성하는 방법을 보여주지는 않습니다. 사용자 명령 작성 방법에 대한 정보는 명령 작성, 편집 및 재사용을 참조하십시오. 명령에 이미지를 지정하는 방법에 대한 정보는 명령 이미지 작성을 참고하십시오. 작업공간을 작성하고 사용자화하는 방법에 대한 정보는 작업공간 사용자화를 참고하십시오.

대시보드 패널은 두 개의 다른 섹션인 상단 및 하단으로 나뉩니다. <패널 구분 기호> 항목은 두 개의 섹션에서 대시보드 패널 행이 표시되는 방법을 제어하는 데 사용됩니다. 상단 섹션의 행은 대시보드 패널이 대시보드 팔레트에서 표시될 때 기본적으로 표시되며, 하단 섹션의 행은 이중 아래쪽 화살표를 클릭하여 대시보드 패널을 확장한 경우만 표시됩니다. 사용할 방식에 맞게 사용자 인터페이스를 조정하는 데 대시보드 패널을 작성하고 수정할 수 있습니다.

대시보드 패널에서 행을 사용하여 표시되어야 할 도구의 배치를 제어합니다. 대시보드 패널의 섹션에 행을 추가하고 더 이상 필요없는 행을 제거하고 대시보드 패널의 상단 섹션과 하단 섹션 사이에서 행을 재배치할 수 있습니다. 패널 구분 기호 위 또는 아래로 도구막대를 끌어서 행을 작성할 수 있습니다.

행에 버튼을 추가하고 자주 사용하지 않는 버튼은 제거하고 버튼을 재배치할 수 있습니다. 또한 버튼과 함께 플라이아웃을 작성하고 컨트롤을 추가할 수 있습니다.

다음 테이블은 특성 창에 나타나는 2D 그리기 대시보드 패널 특성을 설명합니다.

2D 그리기 패널의 특성
특성 창 항목 | 설명 | 예제
이름 | 패널 제목, 마우스 오른쪽 버튼으로 대시보드 팔레트를 클릭하면 제어판 부 메뉴에 표시됩니다. | 2D 그리기
설명 | 요소를 설명하는 데 사용되는 문자로, 사용자 인터페이스에는 나타나지 않습니다. |
별칭 | 패널의 별칭을 지정합니다. 타원 버튼[...]을 클릭하여 별칭 대화상자를 엽니다. CUI 파일의 별칭마다 고유해야 하며 프로그램에 따라서 패널을 참조하는 데 사용됩니다. | 2D_Draw
요소 ID | 패널을 고유하게 식별하는 태그입니다. | PNL_0001
작은 이미지 | 작은 이미지 리소스(16 × 16 비트맵)의 ID 문자열입니다. 문자열에 하이픈(-)이나 밑줄(_) 이외의 영숫자 문자가 구두점 없이 포함되어야 합니다. 또한 사용자 정의 비트맵도 포함될 수 있습니다. 타원 버튼[...]을 클릭하여 이미지 파일 선택 대화상자를 엽니다. | RCDATA_16_DASH _2D_MAKE_MODIFY
큰 이미지 | 큰 이미지 리소스(32 × 32 비트맵)의 ID 문자열입니다. 지정된 비트맵이 32 × 32가 아닌 경우 프로그램이 이 크기로 축척합니다. 문자열에 하이픈(-)이나 밑줄(_) 이외의 영숫자 문자가 구두점 없이 포함되어야 합니다. 또한 사용자 정의 비트맵도 포함될 수 있습니다. 타원 버튼[...]을 클릭하여 이미지 파일 선택 대화상자를 엽니다. | RCDATA_16_DASH _2D_MAKE_MODIFY

도구막대와 유사한 행은 대시보드 패널에서 도구의 순서와 위치를 제어합니다. 행은 대시보드 패널에서 수평으로 실행됩니다. 행에 있는 모든 도구가 대시보드 팔레트에 한 번에 표시될 수 없을 경우 검은색의 작은 삼각형이 행 오른쪽에 표시되어 플라이아웃을 통해 행의 추가 명령에 액세스할 수 있습니다.

다음 테이블은 특성 창에 나타나는 2D 그리기 대시보드 패널의 행 1의 특성을 설명합니다.

2D 그리기 패널의 행 1의 특성
특성 창 항목 | 설명 | 예제
이름 | 패널 섹션의 논리 이름이며 사용자 인터페이스에 나타나지 않습니다. | 그리기
설명 | 요소를 설명하는 데 사용되는 문자로, 사용자 인터페이스에는 나타나지 않습니다. | 그리기 도구막대
행 s | 패널 섹션에 있는 행 수입니다. 패널 섹션은 패널의 <패널 구분 기호> 노드 위 또는 아래에 있는 행에 의해 정의됩니다. | 2
별칭 | 패널 섹션의 별칭을 지정합니다. 타원 버튼[...]을 클릭하여 별칭 대화상자를 엽니다. CUI 파일의 별칭마다 고유해야 하며 프로그램에 따라서 패널 섹션을 참조하는 데 사용됩니다. | TPL_0001
요소 ID | 패널 섹션을 고유하게 식별하는 태그입니다. | TPL_0001

도구막대와 같이 대시보드 패널은 유사한 도구를 구성하는 데 도움이 되는 여러 버튼과 구분 기호를 보유한 플라이아웃을 포함할 수 있습니다. 대시보드 패널 플라이아웃은 도구막대에서 플라이아웃을 작성하는 방법과 약간 다른 방법으로 작성됩니다. 도구막대를 참조하는 플라이아웃대신 풀다운 메뉴의 부 메뉴처럼 작성되지만 도구막대 플라이아웃과 같은 특성을 갖습니다.

다음 테이블은 특성 창에 나타나는 2D 그리기 대시보드 패널에서 행 1의 블록 플라이아웃의 특성을 설명합니다.

2D 그리기 패널의 행 1에서 블록 플라이아웃의 특성
특성 창 항목 | 설명 | 예제
이름 | 플라이아웃의 논리 이름이며 사용자 인터페이스에 나타나지 않습니다. | 블록
설명 | 요소를 설명하는 데 사용되는 문자로, 사용자 인터페이스에는 나타나지 않습니다. |
고유 아이콘 사용 | 마지막으로 사용된 버튼을 현재 버튼으로 설정할 것인지의 여부를 제어합니다. 가능한 값은 예 또는 아니오입니다. | 아니오
작은 이미지 | 작은 이미지 리소스(16 × 16 비트맵)의 ID 문자열입니다. 문자열에 하이픈(-)이나 밑줄(_) 이외의 영숫자 문자가 구두점 없이 포함되어야 합니다. 또한 사용자 정의 비트맵도 포함될 수 있습니다. 타원 버튼[...]을 클릭하여 이미지 파일 선택 대화상자를 엽니다. | RCDATA_16_BLOCK
큰 이미지 | 큰 이미지 리소스(32 × 32 비트맵)의 ID 문자열입니다. 지정된 비트맵이 32 × 32가 아닌 경우 프로그램이 이 크기로 축척합니다. 문자열에 하이픈(-)이나 밑줄(_) 이외의 영숫자 문자가 구두점 없이 포함되어야 합니다. 또한 사용자 정의 비트맵도 포함될 수 있습니다. 타원 버튼[...]을 클릭하여 이미지 파일 선택 대화상자를 엽니다. | RCDATA_16_BLOCK

대시보드 패널, 행 또는 대시보드 플라이아웃을 새로 작성할 경우 먼저 이름을 지정해야 합니다. 대시보드 패널을 새로 작성하면 한 개의 행이 작성되며 <패널 구분 기호>가 추가되고 명령 또는 컨트롤이 지정되지 않습니다. 기존 대시보드 패널이나 명령 리스트 창에서 새 대시보드 패널의 행으로 명령과 컨트롤을 끌어놓을 수 있습니다. 대시보드 패널에 명령을 추가했으면 특성 창의 이름 특성을 변경하여 툴팁 텍스트를 변경할 수 있습니다.

<파일 이름>의 사용자화 창에 있는 대시보드 패널의 행에서 명령과 컨트롤을 추가하거나 제거할 수 있습니다. 또한 트리 뷰를 사용하는 대신 실시간으로 보면서 명령이나 컨트롤을 추가 또는 제거할 수 있는 패널 미리보기 창을 사용하여 명령이나 컨트롤을 추가 또는 제거할 수 있습니다. 또한 미리보기에서 명령과 컨트롤을 끌어서 위치를 조정할 수 있습니다.

참고

    • 대시보드 패널을 작성하려면 (절차)

    • 대시보드 패널을 제거하려면 (절차)

    • 대시보드 패널에 행을 추가하려면 (절차)

    • 도구막대에서 대시보드 패널에 행을 추가하려면 (절차)

    • 대시보드 패널에서 행을 제거하려면 (절차)

    • 대시보드 패널에서 행의 위치를 조정하려면 (절차)

    • 사용자화 창에서 대시보드 패널에 명령을 추가하려면 (절차)

    • 패널 미리보기 창에서 대시보드 패널에 명령을 추가하려면 (절차)

    • 대시보드 패널의 행에 플라이아웃을 작성하려면 (절차)

    • 사용자화 창에서 대시보드 패널의 명령 또는 컨트롤의 위치를 조정하려면 (절차)

    • 패널 미리보기 창에서 대시보드 패널의 명령 또는 컨트롤의 위치를 조정하려면 (절차)

    • 사용자화 창에서 대시보드 패널의 명령 또는 컨트롤을 제거하려면 (절차)

    • 패널 미리보기 창에서 대시보드 패널의 명령 또는 컨트롤을 제거하려면 (절차)


대시보드 패널 작성 및 편집 (절차)

대시보드 패널 사용자화
상위 단계로
대시보드 패널 작성 및 편집
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 대시보드 패널 사용자화 > 대시보드 패널 작성 및 편집 >
대시보드 패널 작성 및 편집
개념 절차 요약 참조

대시보드 패널을 작성하려면

대시보드 패널을 제거하려면

대시보드 패널에 행을 추가하려면

도구막대에서 대시보드 패널에 행을 추가하려면

대시보드 패널에서 행을 제거하려면

대시보드 패널에서 행의 위치를 조정하려면

사용자화 창에서 대시보드 패널에 명령을 추가하려면

패널 미리보기 창에서 대시보드 패널에 명령을 추가하려면

대시보드 패널의 행에 플라이아웃을 작성하려면

사용자화 창에서 대시보드 패널의 명령 또는 컨트롤의 위치를 조정하려면

패널 미리보기 창에서 대시보드 패널의 명령 또는 컨트롤의 위치를 조정하려면

사용자화 창에서 대시보드 패널의 명령 또는 컨트롤을 제거하려면

패널 미리보기 창에서 대시보드 패널의 명령 또는 컨트롤을 제거하려면


대시보드 패널 작성 및 편집 (절차)

대시보드 패널 작성 및 편집
상위 단계로
대시보드 패널 작성 및 편집
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 대시보드 패널 사용자화 > 대시보드 패널 작성 및 편집 >
대시보드 패널 작성 및 편집
개념 절차 요약 참조

대시보드 패널을 작성하려면

  1. 도구 메뉴 [image] 사용자화 [image] 인터페이스를 클릭합니다.명령 프롬프트에서 cui를 입력합니다.
  2. 사용자 인터페이스 사용자화 편집기의 사용자화 탭에 있는 <파일 이름>의 사용자화 창에서 대시보드 패널을 마우스 오른쪽 버튼으로 클릭합니다. 새 패널을 클릭합니다.

    Panel1로 명명된 새 패널이 대시보드 패널 트리의 맨 아래에 놓입니다.

  3. 다음 중 하나를 수행합니다.
    • Panel1 문자 위에 새 이름을 입력합니다.
    • 마우스 오른쪽 버튼으로 Panel1을 클릭합니다. 이름 바꾸기를 클릭합니다. 새 대시보드 패널 이름을 입력합니다.
    • Panel1을 클릭하고 기다린 다음 대시보드 패널 이름을 다시 클릭하여 이름을 내부 편집합니다.
  4. 트리 뷰에서 새 대시보드 패널을 선택한 다음 특성 창을 업데이트합니다.
    • 설명 상자에 대시보드 패널에 대한 설명을 입력합니다.
    • 별칭 상자에 대시보드 패널의 별칭을 입력합니다.

  5. 대시보드 패널에 패널 아이콘을 지정하려면 다음 중 하나를 수행하십시오.
    • 표준 아이콘을 지정하려면 버튼 이미지 창에서 3개의 이미지 지정 옵션(큰, 작은, 모두) 중 하나를 선택합니다. 이미지 리스트에서 이미지를 선택하면 이미지 이름은 대시보드 패널의 작은 및/또는 큰 이미지 특성에 지정됩니다.
    • 사용자 아이콘을 지정하려면 특성 창에서 작은 이미지 특성 옆에 있는 필드를 선택합니다. 특성 옆에 표시된 타원 버튼을 클릭하고 이미지 파일 선택 대화상자에서 대시보드 패널에 사용할 이미지 파일을 찾아봅니다. 큰 아이콘 특성에 대해 프로세스를 반복합니다.

  6. 확인을 클릭합니다.


대시보드 패널 작성 및 편집 (절차)

대시보드 패널 작성 및 편집
상위 단계로
대시보드 패널 작성 및 편집
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 대시보드 패널 사용자화 > 대시보드 패널 작성 및 편집 >
대시보드 패널 작성 및 편집
개념 절차 요약 참조

대시보드 패널을 제거하려면

  1. 도구 메뉴 [image] 사용자화 [image] 인터페이스를 클릭합니다.명령 프롬프트에서 cui를 입력합니다.
  2. 사용자 인터페이스 사용자화 편집기의 사용자화 탭에 있는 <파일 이름>의 사용자화 창에서 대시보드 패널 옆에 있는 더하기 기호(+)를 클릭하여 확장합니다.
  3. 제거할 대시보드 패널을 선택합니다.
  4. 마우스 오른쪽 버튼으로 선택한 대시보드 패널을 클릭합니다. 삭제를 클릭합니다.

    경고인터페이스 요소의 제거를 명령 취소할 수 있는 방법이 없기 때문에 인터페이스 요소를 제거할 때 주의하십시오. 잘못된 인터페이스 요소를 제거할 경우 취소를 클릭하여 변경사항을 저장하지 않는 것이 최선의 방법이지만 이 경우 다른 변경사항도 모두 명령 취소됩니다.
  5. 확인을 클릭합니다.


대시보드 패널 작성 및 편집 (절차)

대시보드 패널 작성 및 편집
상위 단계로
대시보드 패널 작성 및 편집
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 대시보드 패널 사용자화 > 대시보드 패널 작성 및 편집 >
대시보드 패널 작성 및 편집
개념 절차 요약 참조

대시보드 패널에 행을 추가하려면

  1. 도구 메뉴 [image] 사용자화 [image] 인터페이스를 클릭합니다.명령 프롬프트에서 cui를 입력합니다.
  2. 사용자 인터페이스 사용자화 편집기의 사용자화 탭에 있는 <파일 이름>의 사용자화 창에서 대시보드 패널 옆에 있는 더하기 기호(+)를 클릭하여 확장합니다.
  3. 행을 추가할 대시보드 패널을 선택합니다.
  4. 마우스 오른쪽 버튼으로 선택한 대시보드 패널을 클릭합니다. 새 행을 클릭합니다.

  5. 확인을 클릭합니다.


대시보드 패널 작성 및 편집 (절차)

대시보드 패널 작성 및 편집
상위 단계로
대시보드 패널 작성 및 편집
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 대시보드 패널 사용자화 > 대시보드 패널 작성 및 편집 >
대시보드 패널 작성 및 편집
개념 절차 요약 참조

도구막대에서 대시보드 패널에 행을 추가하려면

  1. 도구 메뉴 [image] 사용자화 [image] 인터페이스를 클릭합니다.명령 프롬프트에서 cui를 입력합니다.
  2. 사용자 인터페이스 사용자화 편집기의 사용자화 탭에 있는 <파일 이름>의 사용자화 창에서 대시보드 패널 옆에 있는 더하기 기호(+)를 클릭하여 확장합니다.
  3. 기존 도구막대에서 새 행을 작성할 <파일 이름>의 사용자화에서 대시보드 패널 옆에 있는 더하기 기호(+)를 클릭합니다.
  4. <파일 이름>의 사용자화 창에서 도구막대 옆에 있는 더하기 기호(+)를 클릭하여 확장합니다.
  5. 대시보드 패널에서 행을 작성할 위치로 도구막대 노드를 끌어놓습니다.

    검은색 세로 스플리터 막대가 원하는 위치에 표시될 때 마우스 버튼을 놓아서 행을 배치할 위치를 제어할 수 있습니다.

  6. 확인을 클릭합니다.


대시보드 패널 작성 및 편집 (절차)

대시보드 패널 작성 및 편집
상위 단계로
대시보드 패널 작성 및 편집
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 대시보드 패널 사용자화 > 대시보드 패널 작성 및 편집 >
대시보드 패널 작성 및 편집
개념 절차 요약 참조

대시보드 패널에서 행을 제거하려면

  1. 도구 메뉴 [image] 사용자화 [image] 인터페이스를 클릭합니다.명령 프롬프트에서 cui를 입력합니다.
  2. 사용자 인터페이스 사용자화 편집기의 사용자화 탭에 있는 <파일 이름>의 사용자화 창에서 대시보드 패널 옆에 있는 더하기 기호(+)를 클릭하여 확장합니다.
  3. 행을 제거할 대시보드 패널 옆에 있는 더하기 기호(+)를 클릭합니다.
  4. 제거할 행을 선택합니다.
  5. 마우스 오른쪽 버튼으로 선택한 행을 클릭합니다. 삭제를 클릭합니다.

  6. [확인]을 클릭합니다.


대시보드 패널 작성 및 편집 (절차)

대시보드 패널 작성 및 편집
상위 단계로
대시보드 패널 작성 및 편집
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 대시보드 패널 사용자화 > 대시보드 패널 작성 및 편집 >
대시보드 패널 작성 및 편집
개념 절차 요약 참조

대시보드 패널에서 행의 위치를 조정하려면

  1. 도구 메뉴 [image] 사용자화 [image] 인터페이스를 클릭합니다.명령 프롬프트에서 cui를 입력합니다.
  2. 사용자 인터페이스 사용자화 편집기의 사용자화 탭에 있는 <파일 이름>의 사용자화 창에서 대시보드 패널 옆에 있는 더하기 기호(+)를 클릭하여 확장합니다.
  3. 행의 위치를 조정할 대시보드 패널 옆에 있는 더하기 기호(+)를 클릭합니다.
  4. 대시보드 패널 아래에서 위치를 조정할 행을 끕니다. 뷰 지시자로 스플리터 막대를 사용하여 다른 행 또는 <패널 구분 기호> 항목의 위 또는 아래로 행의 위치를 조정합니다.

  5. 확인을 클릭합니다.


대시보드 패널 작성 및 편집 (절차)

대시보드 패널 작성 및 편집
상위 단계로
대시보드 패널 작성 및 편집
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 대시보드 패널 사용자화 > 대시보드 패널 작성 및 편집 >
대시보드 패널 작성 및 편집
개념 절차 요약 참조

사용자화 창에서 대시보드 패널에 명령을 추가하려면

  1. 도구 메뉴 [image] 사용자화 [image] 인터페이스를 클릭합니다.명령 프롬프트에서 cui를 입력합니다.
  2. 사용자 인터페이스 사용자화 편집기의 사용자화 탭에 있는 <파일 이름>의 사용자화 창에서 대시보드 패널 옆에 있는 더하기 기호(+)를 클릭하여 확장합니다.
  3. 명령을 추가할 대시보드 패널 옆에 있는 더하기 기호(+)를 클릭합니다.
  4. 명령의 새 행을 작성하거나 명령을 추가할 행 옆에 있는 더하기 기호(+)를 클릭합니다.
  5. 명령 리스트 창에서 대시보드 패널로 명령을 끌어놓습니다. 뷰 지시자로 스플리터 막대를 사용하여 명령의 위치를 지정합니다.

  6. 확인을 클릭합니다.


대시보드 패널 작성 및 편집 (절차)

대시보드 패널 작성 및 편집
상위 단계로
대시보드 패널 작성 및 편집
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 대시보드 패널 사용자화 > 대시보드 패널 작성 및 편집 >
대시보드 패널 작성 및 편집
개념 절차 요약 참조

패널 미리보기 창에서 대시보드 패널에 명령을 추가하려면

  1. 도구 메뉴 [image] 사용자화 [image] 인터페이스를 클릭합니다.명령 프롬프트에서 cui를 입력합니다.
  2. 사용자 인터페이스 사용자화 편집기의 사용자화 탭에 있는 <파일 이름>의 사용자화 창에서 대시보드 패널 옆에 있는 더하기 기호(+)를 클릭하여 확장합니다.
  3. 명령을 추가할 대시보드 패널을 선택합니다.
  4. 명령 리스트 창에서 패널 미리보기 창의 대시보드 패널 미리보기로 명령을 끌어 놓습니다. 뷰 지시자로 스플리터 막대를 사용하여 명령의 위치를 지정합니다.

  5. 확인을 클릭합니다.


대시보드 패널 작성 및 편집 (절차)

대시보드 패널 작성 및 편집
상위 단계로
대시보드 패널 작성 및 편집
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 대시보드 패널 사용자화 > 대시보드 패널 작성 및 편집 >
대시보드 패널 작성 및 편집
개념 절차 요약 참조

대시보드 패널의 행에 플라이아웃을 작성하려면

  1. 도구 메뉴 [image] 사용자화 [image] 인터페이스를 클릭합니다.명령 프롬프트에서 cui를 입력합니다.
  2. 사용자 인터페이스 사용자화 편집기의 사용자화 탭에 있는 <파일 이름>의 사용자화 창에서 대시보드 패널 옆에 있는 더하기 기호(+)를 클릭하여 확장합니다.
  3. 플라이아웃을 추가할 대시보드 패널 옆에 있는 더하기 기호(+)를 클릭합니다.
  4. 마우스 오른쪽 버튼으로 플라이아웃을 추가할 행을 클릭합니다. 새 플라이아웃을 클릭합니다.

    Flyout1로 명명된 새 플라이아웃이 행의 맨 처음 위치에서 작성됩니다. 또한 마우스 오른쪽 버튼으로 명령이나 컨트롤을 클릭하고 선택한 항목 아래에 플라이아웃을 추가할 수 있습니다.

  5. Flyout1을 마우스 오른쪽 버튼으로 클릭합니다. 이름 바꾸기를 클릭합니다. 새 이름을 입력합니다.
    주도구막대 이름을 클릭하고 기다린 다음 다시 클릭하여 이름을 내부 편집할 수 있습니다.

  6. 명령 리스트 창에서 추가할 명령을 <파일 이름>의 사용자화 창에 있는 플라이아웃 이름 바로 아래의 위치로 끌어옵니다.

  7. 확인을 클릭합니다.


대시보드 패널 작성 및 편집 (절차)

대시보드 패널 작성 및 편집
상위 단계로
대시보드 패널 작성 및 편집
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 대시보드 패널 사용자화 > 대시보드 패널 작성 및 편집 >
대시보드 패널 작성 및 편집
개념 절차 요약 참조

사용자화 창에서 대시보드 패널의 명령 또는 컨트롤의 위치를 조정하려면

  1. 도구 메뉴 [image] 사용자화 [image] 인터페이스를 클릭합니다.명령 프롬프트에서 cui를 입력합니다.
  2. 사용자 인터페이스 사용자화 편집기의 사용자화 탭에 있는 <파일 이름>의 사용자화 창에서 대시보드 패널 옆에 있는 더하기 기호(+)를 클릭하여 확장합니다.
  3. 명령 또는 컨트롤의 위치를 조정할 대시보드 패널 옆에 있는 더하기 기호(+)를 클릭합니다.
  4. 명령을 추가할 행 옆에 있는 더하기 기호(+)를 클릭합니다.
  5. 명령이나 컨트롤을 행으로 끕니다. 뷰 지시자로 스플리터 막대를 사용하여 명령 또는 컨트롤의 위치를 지정합니다.

  6. 확인을 클릭합니다.


대시보드 패널 작성 및 편집 (절차)

대시보드 패널 작성 및 편집
상위 단계로
대시보드 패널 작성 및 편집
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 대시보드 패널 사용자화 > 대시보드 패널 작성 및 편집 >
대시보드 패널 작성 및 편집
개념 절차 요약 참조

패널 미리보기 창에서 대시보드 패널의 명령 또는 컨트롤의 위치를 조정하려면

  1. 도구 메뉴 [image] 사용자화 [image] 인터페이스를 클릭합니다.명령 프롬프트에서 cui를 입력합니다.
  2. 사용자 인터페이스 사용자화 편집기의 사용자화 탭에 있는 <파일 이름>의 사용자화 창에서 대시보드 패널 옆에 있는 더하기 기호(+)를 클릭하여 확장합니다.
  3. 명령 또는 컨트롤의 위치를 조정할 대시보드 패널을 선택합니다.
  4. 패널 미리보기 창에서 대시보드 패널의 다른 위치로 명령 또는 컨트롤을 끕니다. 뷰 지시자로 스플리터 막대를 사용하여 명령 또는 컨트롤의 위치를 지정합니다.

  5. 확인을 클릭합니다.


대시보드 패널 작성 및 편집 (절차)

대시보드 패널 작성 및 편집
상위 단계로
대시보드 패널 작성 및 편집
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 대시보드 패널 사용자화 > 대시보드 패널 작성 및 편집 >
대시보드 패널 작성 및 편집
개념 절차 요약 참조

사용자화 창에서 대시보드 패널의 명령 또는 컨트롤을 제거하려면

  1. 도구 메뉴 [image] 사용자화 [image] 인터페이스를 클릭합니다.명령 프롬프트에서 cui를 입력합니다.
  2. 사용자 인터페이스 사용자화 편집기의 사용자화 탭에 있는 <파일 이름>의 사용자화 창에서 대시보드 패널 옆에 있는 더하기 기호(+)를 클릭하여 확장합니다.
  3. 명령 또는 컨트롤을 제거할 대시보드 패널 옆에 있는 더하기 기호(+)를 클릭합니다.
  4. 명령 또는 컨트롤을 제거할 행 옆에 있는 더하기 기호(+)를 클릭합니다.
  5. 제거할 명령 또는 컨트롤을 선택합니다.
  6. 마우스 오른쪽 버튼으로 선택한 명령 또는 컨트롤을 클릭합니다. 삭제를 클릭합니다.

  7. [확인]을 클릭합니다.


대시보드 패널 작성 및 편집 (절차)

대시보드 패널 작성 및 편집
상위 단계로
대시보드 컨트롤 추가 또는 전환
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 대시보드 패널 사용자화 > 대시보드 패널 작성 및 편집 >
대시보드 패널 작성 및 편집
개념 절차 요약 참조

패널 미리보기 창에서 대시보드 패널의 명령 또는 컨트롤을 제거하려면

  1. 도구 메뉴 [image] 사용자화 [image] 인터페이스를 클릭합니다.명령 프롬프트에서 cui를 입력합니다.
  2. 사용자 인터페이스 사용자화 편집기의 사용자화 탭에 있는 <파일 이름>의 사용자화 창에서 대시보드 패널 옆에 있는 더하기 기호(+)를 클릭하여 확장합니다.
  3. 명령 또는 컨트롤을 제거할 행 옆에 있는 더하기 기호(+)를 클릭합니다.
  4. 명령이나 컨트롤을 미리보기 바깥 부분으로 끌어놓아서 대시보드 패널에서 제거합니다.

  5. 확인을 클릭합니다.


대시보드 패널 작성 및 편집 (요약 참조)

풀다운 메뉴 교체 및 삽입
대시보드 패널 작성 및 편집
대시보드 컨트롤 추가 또는 전환
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 대시보드 패널 사용자화 > 대시보드 패널 작성 및 편집 >
대시보드 패널 작성 및 편집
개념 절차 요약 참조

명령

CUI

작업공간, 도구막대, 메뉴, 바로 가기 메뉴 및 키보드 바로 가기와 같은 사용자화된 사용자 인터페이스 요소를 관리합니다.

DASHBOARD

대시보드 윈도우를 엽니다.

시스템 변수

항목이 없습니다.

유틸리티

항목이 없습니다.

명령 수정자

항목이 없습니다.


대시보드 컨트롤 추가 또는 전환 (개념)

대시보드 패널 작성 및 편집
대시보드 패널 사용자화
바로 가기 키 및 임시 재지정 키 추가
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 대시보드 패널 사용자화 >
대시보드 컨트롤 추가 또는 전환
개념 절차 요약 참조

대시보드 패널 컨트롤은 드롭다운 리스트, 슬라이더, 텍스트 상자와 그 밖에 선택할 수 있는 대시보드 패널 특정 옵션입니다. 예를 들어, 2D 검색 패널에는 도면의 현재 뷰를 변경하는 컨트롤이 들어 있습니다. 사용자 인터페이스 사용자화 편집기에서 대시보드 패널 내에 컨트롤을 추가하고 제거하며 재배치할 수 있습니다.

다음 테이블은 사용자 인터페이스 사용자화 편집기에 있는 대시보드 패널 컨트롤을 설명합니다. 이 테이블의 왼쪽 열에 있는 컨트롤 요소가 항상 프로그램에서 툴팁으로 표시되는 문자는 아닙니다. 예를 들어, 문자 높이 콤보 컨트롤은 프로그램의 툴팁에서 문자 높이로 표시됩니다. 대시보드 패널 컨트롤 외에도 도구막대에서 사용할 수 있는 많은 컨트롤을 대시보드 패널의 행에 추가할 수도 있습니다. 도구막대 및 대시보드 패널에서 사용할 수 있는 컨트롤에 대한 자세한 정보는 도구막대 컨트롤 추가 또는 전환을 참조하십시오.

대시보드 패널의 컨트롤 요소
컨트롤 요소 | 설명
3D 콤보 컨트롤 검색 | 표준 직교 및 등각투영 뷰와 현재 공간의 명명된 뷰의 드롭다운 리스트입니다.
3D 3중 포인트 1 컨트롤 검색 | 뷰 포인트(카메라의 위치)를 제어하는 3개 텍스트 상자 집합입니다.
3D 3중 포인트 2 컨트롤 검색 | 현재 뷰포트에 대한 카메라의 표적점(중심점)을 제어하는 3개 텍스트 상자의 세트입니다.
3D 스텝 크기 슬라이더 컨트롤 검색 | 도면 단위에서 3DWALK 및 3DFLY 명령과 함께 사용되는 스텝 크기를 제어하는 슬라이더와 텍스트 상자의 조합입니다. 텍스트 상자를 사용하면 슬라이더를 사용할 필요없이 특정 스텝 크기를 입력할 수 있습니다.
3D 초당 스텝 슬라이더 컨트롤 검색 | 3DWALK 및 3DFLY 명령과 함께 초당 발생하는 스텝 수를 제어하는 슬라이더와 텍스트 상자의 조합입니다. 텍스트 상자를 사용하면 슬라이더를 사용할 필요없이 구체적인 초당 스텝 수를 입력할 수 있습니다.
3D 줌 슬라이더 컨트롤 검색 | 투시 투영이 활성화되어 있을 경우 렌즈 길이와 뷰 필드를 제어하는 슬라이더입니다.
도면층 필터 콤보 컨트롤 | 사용 가능한 도면층 필터의 액세스를 제공하는 드롭다운입니다.
도면층 잠금 투명도 슬라이더 컨트롤 | 잠긴 도면층의 투명도 레벨을 제어하는 전환, 슬라이더 및 텍스트 상자의 조합입니다. 전환을 사용하면 잠긴 도면층 투명도를 켜거나 끌 수 있습니다. 잠긴 도면층의 투명도가 켜져 있을 경우 슬라이더를 사용하거나 텍스트 상자에 직접 값을 입력하여 투명도 값을 지정할 수 있습니다.
도면층 상태 콤보 컨트롤 | 사용 가능한 도면층 상태를 관리하고 액세스할 수 있는 드롭다운입니다.
조명 슬라이더 1 컨트롤 | 일영 달력 날짜를 제어하는 슬라이더와 텍스트 상자의 조합입니다. 텍스트 상자는 읽기 전용이며 지정된 달력 날짜를 표시합니다.
조명 슬라이더 2 컨트롤 | 일영 시간을 제어하는 슬라이더와 텍스트 상자의 조합입니다. 텍스트 상자는 읽기 전용이며 지정된 시간을 표시합니다.
조명 슬라이더 3 컨트롤 | 도면 조명의 전역 밝기 승수를 제어하는 슬라이더와 텍스트 상자의 조합입니다. 텍스트 상자는 읽기 전용이며 지정된 승수 값을 표시합니다.
조명 슬라이더 4 컨트롤 | 도면 조명의 전역 대비를 제어하는 슬라이더와 텍스트 상자의 조합입니다. 텍스트 상자는 읽기 전용이며 지정된 대비 값을 표시합니다.
조명 슬라이더 5 컨트롤 | 도면 조명의 전역 중간 톤을 제어하는 슬라이더와 텍스트 상자의 조합입니다. 텍스트 상자는 읽기 전용이며 지정된 중간 톤 값을 표시합니다.
렌더 이미지 품질 컨트롤 | 렌더링에 사용되는 최대 견본을 제어하는 슬라이더입니다.
렌더 출력 파일 컨트롤 | 렌더링이 출력되는 파일을 지정하는 데 사용되는 전환, 텍스트 상자 및 찾아보기 버튼의 조합입니다. 텍스트 상자와 버튼이 사용 가능하도록 하려면 텍스트 상자 앞의 전환이 켜져 있어야 합니다.
렌더 출력 크기 컨트롤 | 렌더 이미지를 생성할 때 사용되는 표준 및 사용자 이미지 크기의 리스트를 제공하는 드롭다운입니다.
렌더 진행 컨트롤 | 현재 렌더링 진행을 표시하고 진행 중인 현재 렌더링을 취소하는 데 사용되는 진행 표시줄입니다.
렌더 스타일 컨트롤 | 사용 가능한 렌더 사전 설정의 드롭다운 리스트입니다.
문자 높이 콤보 컨트롤 | 가장 최근에 사용한 문자 높이의 드롭다운 리스트입니다.
뷰 스타일 콤보 컨트롤 | 사용 가능한 뷰 스타일의 드롭다운 리스트입니다.
뷰 스타일 모서리 색상 컨트롤 | 3D 객체의 모서리와 등각선의 색상을 지정하는 드롭다운입니다.
뷰 스타일 모서리 돌출부 슬라이더 컨트롤 | 모서리 돌출부와 교차점 이상 확장되는 선의 양을 제어하는 데 사용되는 전환 및 슬라이더의 조합입니다.
뷰 스타일 교차 모서리 색상 컨트롤 | 교차하는 3D 객체 모서리의 표시와 색상을 지정하는 데 사용되는 전환 및 드롭다운의 조합입니다.
뷰 스타일 지터 모서리 슬라이더 컨트롤 | 모서리 지터와 선의 지터량을 제어하는 데 사용되는 전환 및 슬라이더의 조합입니다.
뷰 스타일 가려진 모서리 색상 컨트롤 | 가려진 3D 객체 모서리의 표시와 색상을 지정하는 데 사용되는 전환 및 드롭다운의 조합입니다.
뷰 스타일 윤곽 모서리 폭 슬라이더 컨트롤 | 모서리 윤곽과 작성한 윤곽의 폭을 제어하는 데 사용되는 전환 및 슬라이더의 조합입니다.
참고

    • 대시보드 패널 사용자화

    • 사용자화 창에서 대시보드 패널에 컨트롤을 추가하려면 (절차)

    • 패널 미리보기 창에서 대시보드 패널에 컨트롤을 추가하려면 (절차)

    • 대시보드 패널에서 컨트롤을 전환하려면 (절차)


대시보드 컨트롤 추가 또는 전환 (절차)

대시보드 패널 작성 및 편집
상위 단계로
대시보드 컨트롤 추가 또는 전환
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 대시보드 패널 사용자화 > 대시보드 컨트롤 추가 또는 전환 >
대시보드 컨트롤 추가 또는 전환
개념 절차 요약 참조

사용자화 창에서 대시보드 패널에 컨트롤을 추가하려면

패널 미리보기 창에서 대시보드 패널에 컨트롤을 추가하려면

대시보드 패널에서 컨트롤을 전환하려면


대시보드 컨트롤 추가 또는 전환 (절차)

대시보드 컨트롤 추가 또는 전환
상위 단계로
대시보드 컨트롤 추가 또는 전환
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 대시보드 패널 사용자화 > 대시보드 컨트롤 추가 또는 전환 >
대시보드 컨트롤 추가 또는 전환
개념 절차 요약 참조

사용자화 창에서 대시보드 패널에 컨트롤을 추가하려면

  1. 도구 메뉴 [image] 사용자화 [image] 인터페이스를 클릭합니다.명령 프롬프트에서 cui를 입력합니다.
  2. 사용자 인터페이스 사용자화 편집기의 사용자화 탭에 있는 <파일 이름>의 사용자화 창에서 대시보드 패널 옆에 있는 더하기 기호(+)를 클릭하여 확장합니다.
  3. 컨트롤을 추가할 대시보드 패널 옆에 있는 더하기 기호(+)를 클릭합니다.
  4. 필요할 경우 컨트롤의 행을 새로 작성하거나 컨트롤을 추가할 행 옆에 있는 더하기 기호(+)를 클릭합니다.
  5. 명령 리스트 창의 범주 리스트에서 컨트롤 요소를 클릭합니다.

    명령 리스트 창에는 컨트롤 요소만 표시됩니다.

  6. 명령 리스트 창에서 컨트롤을 끌어서 대시보드 패널에 추가합니다. 뷰 지시자로 스플리터 막대를 사용하여 컨트롤의 위치를 지정합니다.

  7. 확인을 클릭합니다.


대시보드 컨트롤 추가 또는 전환 (절차)

대시보드 컨트롤 추가 또는 전환
상위 단계로
대시보드 컨트롤 추가 또는 전환
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 대시보드 패널 사용자화 > 대시보드 컨트롤 추가 또는 전환 >
대시보드 컨트롤 추가 또는 전환
개념 절차 요약 참조

패널 미리보기 창에서 대시보드 패널에 컨트롤을 추가하려면

  1. 도구 메뉴 [image] 사용자화 [image] 인터페이스를 클릭합니다.명령 프롬프트에서 cui를 입력합니다.
  2. 사용자 인터페이스 사용자화 편집기의 사용자화 탭에 있는 <파일 이름>의 사용자화 창에서 대시보드 패널 옆에 있는 더하기 기호(+)를 클릭하여 확장합니다.
  3. 명령을 추가할 대시보드 패널을 선택합니다.
  4. 명령 리스트 창의 범주 리스트에서 컨트롤 요소를 클릭합니다.

    명령 리스트 창에는 컨트롤 요소만 표시됩니다.

  5. 명령 리스트 창에서 컨트롤을 끌어서 패널 미리보기 창의 대시보드 패널 미리보기에 추가합니다. 뷰 지시자로 스플리터 막대를 사용하여 명령의 위치를 지정합니다.

  6. 확인을 클릭합니다.


대시보드 컨트롤 추가 또는 전환 (절차)

대시보드 컨트롤 추가 또는 전환
상위 단계로
바로 가기 키 및 임시 재지정 키 추가
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 대시보드 패널 사용자화 > 대시보드 컨트롤 추가 또는 전환 >
대시보드 컨트롤 추가 또는 전환
개념 절차 요약 참조

대시보드 패널에서 컨트롤을 전환하려면

  1. 도구 메뉴 [image] 사용자화 [image] 인터페이스를 클릭합니다.명령 프롬프트에서 cui를 입력합니다.
  2. 사용자 인터페이스 사용자화 편집기의 사용자화 탭에 있는 <파일 이름>의 사용자화 창에서 대시보드 패널 옆에 있는 더하기 기호(+)를 클릭하여 확장합니다.
  3. 컨트롤을 변경할 대시보드 패널 옆에 있는 더하기 기호(+)를 클릭합니다.
  4. 컨트롤을 변경할 행 옆에 있는 더하기 기호(+)를 클릭합니다.
  5. 컨트롤 요소를 클릭합니다.

  6. 특성 창의 컨트롤 상자에서 화살표를 클릭하여 컨트롤 리스트를 표시합니다.

  7. 원래 컨트롤을 대치할 컨트롤을 클릭합니다.
  8. 확인을 클릭합니다.


대시보드 컨트롤 추가 또는 전환 (요약 참조)

대시보드 패널 작성 및 편집
대시보드 컨트롤 추가 또는 전환
바로 가기 키 및 임시 재지정 키 추가
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 대시보드 패널 사용자화 > 대시보드 컨트롤 추가 또는 전환 >
대시보드 컨트롤 추가 또는 전환
개념 절차 요약 참조

명령

CUI

작업공간, 도구막대, 메뉴, 바로 가기 메뉴 및 키보드 바로 가기와 같은 사용자화된 사용자 인터페이스 요소를 관리합니다.

DASHBOARD

대시보드 윈도우를 엽니다.

시스템 변수

항목이 없습니다.

유틸리티

항목이 없습니다.

명령 수정자

항목이 없습니다.


바로 가기 키 및 임시 재지정 키 추가 (개념)

대시보드 컨트롤 추가 또는 전환
사용자 인터페이스 사용자화
두 번 클릭 동작 작성
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 >
바로 가기 키 및 임시 재지정 키 추가
개념 절차 요약 참조

바로 가기 키(가속키라고도 함)를 자주 사용하는 명령에 지정할 수 있고, 임시 재지정 키를 지정하여 키를 눌렀을 때 명령을 실행하거나 설정을 변경할 수 있습니다.

표시: 바로 가기 키 작성

다음 이미지 아래의 재생 화살표를 클릭하여 애니메이션을 시작합니다.

아래 애니매이션은 사용자 바로 가기 키를 작성하는 방법을 보여줍니다 그러나 사용자 명령을 작성하는 방법을 보여주지는 않습니다. 사용자 명령을 작성하는 방법에 대한 정보는 명령 작성, 편집 및 재사용을 참조하십시오.

바로 가기 키는 키와 명령을 시작하는 키 조합입니다. 예를 들어 Ctrl+O를 눌러 파일을 열 수 있고, Ctrl+S를 눌러 파일을 저장할 수 있습니다. 이것은 파일 메뉴의 열기와 저장을 선택한 결과와 같습니다. 다음 테이블은 특성 창에 나타나는 저장 바로 가기 키 특성을 보여줍니다.

저장 바로 가기 키의 특성
특성 창 항목 | 설명 | 예제
이름 | CUI 편집기에서만 사용되고 사용자 인터페이스에는 표시되지 않는 문자열입니다. | 저장
설명 | 요소를 설명하는 데 사용되는 문자로, 사용자 인터페이스에는 나타나지 않습니다. | 현재 도면 저장: QSAVE
매크로 | 명령 매크로입니다. 표준 매크로 구문을 따릅니다. | ^C^C_qsave
키 | 매크로를 실행하기 위해 사용되는 키 입력 조합을 지정합니다. 타원 [...] 버튼을 클릭하여 바로 가기 키 대화상자를 엽니다. | Ctrl+S
요소 ID | 명령을 고유하게 식별하는 태그입니다. | ID_Save

임시 재지정 키는 제도 설정값 대화상자에서 설정되는 도면 보조 중 하나를 임시로 켜거나 끄는 키입니다. 예를 들어 직교 모드, 객체 스냅 또는 극좌표 모드가 있습니다. 다음 테이블은 특성 창에 나타나는 객체 스냅 재지정: 끝점 임시 재지정 키 특성을 보여줍니다.

객체 스냅 재지정: 끝점 임시 재지정 키 특성
특성 창 항목 | 설명 | 예제
이름 | CUI 편집기에서만 사용되고 사용자 인터페이스에는 표시되지 않는 문자열입니다. | 객체 스냅 재지정: 끝점
설명 | 요소를 설명하는 데 사용되는 문자로, 사용자 인터페이스에는 나타나지 않습니다. | 객체 스냅 재지정: 끝점
키 | 임시 재지정을 실행하기 위해 사용되는 키 입력 조합을 지정합니다. 타원 [...] 버튼을 클릭하여 바로 가기 키 대화상자를 엽니다. | Shift+E
Macro1(아래쪽 화살표) | 키 입력 조합을 사용자가 누르고 있을 때 실행되어야 하는 매크로를 지정합니다. | ^P'_.osmode 1 $(if,$(eq,$(getvar,osnapoverride),0),'_.osnapoverride 1)
Macro2(위쪽 화살표) | 사용자가 키 입력 조합을 해제할 때 실행되어야 하는 매크로를 지정합니다. 비워 두면 AutoCAD는 변수를 이전 상태로 복원합니다. |

바로 가기 키는 명령 리스트의 모든 명령과 연관될 수 있습니다. 새 바로 가기 키를 작성하거나 기존 바로 가기 키를 수정할 수 있습니다.

다음 테이블에서는 바로 가기 키에 대한 기본 동작을 나열합니다.

바로 가기 키 | 설명
Alt+F11 | Visual Basic Editor를 표시합니다.
Alt+F8 | 매크로 대화상자를 표시합니다.
Ctrl+0 | 화면 정리를 전환합니다.
Ctrl+1 | 특성 팔레트를 전환합니다.
Ctrl+2 | DesignCenter를 전환합니다.
Ctrl+3 | 도구 팔레트 윈도우를 전환합니다.
Ctrl+4 | 시트 세트 관리자를 전환합니다.
Ctrl+6 | dbConnect 관리자를 전환합니다.
Ctrl+7 | 표식 세트 관리자를 전환합니다.
Ctrl+8 | QuickCalc 계산기 팔레트를 전환합니다.
Ctrl+9 | 명령 윈도우를 전환합니다.
Ctrl+A | 도면의 객체를 선택합니다.
Ctrl+SHITF+A | 그룹을 전환합니다.
Ctrl+B | 스냅을 전환합니다.
Ctrl+C | 객체를 클립보드에 복사합니다.
Ctrl+Shift+C | 기준점을 사용하여 객체를 클립보드로 복사합니다.
Ctrl+D | 동적 UCS를 전환합니다.
Ctrl+E | 등각투영 평면 사이를 순환합니다
Ctrl+F | 객체 스냅 실행을 전환합니다.
Ctrl+G | 모눈을 전환합니다.
Ctrl+H | PICKSTYLE을 전환합니다.
Ctrl+I | COORDS를 전환합니다.
Ctrl+J | 마지막 명령을 반복합니다.
Ctrl+L | 직교 모드를 전환합니다.
Ctrl+M | 마지막 명령을 반복합니다.
Ctrl+N | 새 도면을 작성합니다.
Ctrl+O | 기존 도면을 엽니다.
Ctrl+P | 현재 도면을 인쇄합니다.
Ctrl+R | 배치 뷰포트를 순환합니다.
Ctrl+S | 현재 도면을 저장합니다.
Ctrl+Shift+S | 다른 이름으로 저장 대화상자를 가져옵니다.
Ctrl+T | 타블렛 모드를 전환합니다.
Ctrl+V | 클립보드에서 데이터를 붙여넣습니다.
Ctrl+Shift+V | 클립보드로부터 블록으로 데이터를 붙여넣습니다.
Ctrl+X | 객체를 클립보드로 잘라넣습니다.
Ctrl+Y | 앞의 명령 취소 작업을 취소합니다.
Ctrl+Z | 마지막 동작을 반전합니다.
Ctrl+[ | 현재 명령을 취소합니다.
Ctrl+\ | 현재 명령을 취소합니다.
Ctrl+PAGE UP | 현재 탭의 왼쪽에 있는 다음 배치 탭으로 이동합니다.
Ctrl+PAGE DOWN | 현재 탭의 오른쪽에 있는 다음 배치 탭으로 이동합니다.
F1 | 도움말을 표시합니다.
F2 | 문자 윈도우 전환
F3 | OSNAP을 전환합니다.
F4 | TABMODE를 전환합니다.
F5 | ISOPLANE을 전환합니다.
F6 | UCSDETECT를 전환합니다.
F7 | GRIDMODE를 전환합니다.
F8 | ORTHOMODE를 전환합니다.
F9 | SNAPMODE를 전환합니다.
F10 | 극좌표 추적을 전환합니다.
F11 | 객체 스냅 추적을 전환합니다.
F12 | 동적 입력을 전환합니다.

다음 테이블은 영어 미국 키보드에서 임시 재지정 키에 대한 기본 동작을 나열합니다. 다른 키보드에서 기본 임시 재지정 키에 대한 자세한 정보는 Override Object Snap Settings을 참조하십시오.

임시 재지정 키 | 설명
F3 | OSNAP을 전환합니다.
F6 | UCSDETECT를 전환합니다.
F8 | ORTHOMODE를 전환합니다.
F9 | SNAPMODE를 전환합니다.
F10 | 극좌표 추적을 전환합니다.
F11 | 객체 스냅 추적을 전환합니다.
F12 | 동적 입력을 전환합니다.
Shift | ORTHOMODE를 전환합니다.
Shift+’ | SNAPMODE를 전환합니다.
Shift+, | 객체 스냅 재지정: 중심점
Shift+. | 극좌표 추적을 전환합니다.
Shift+/ | UCSDETECT를 전환합니다.
Shift+; | 객체 스냅 실행을 사용합니다.
Shift+] | 객체 스냅 추적을 전환합니다.
Shift+A | OSNAP을 전환합니다.
Shift+C | 객체 스냅 재지정: 중심점
Shift+D | 스냅 및 추적 모두 사용 안함
Shift+E | 객체 스냅 재지정: 끝점
Shift+L | 스냅 및 추적 모두 사용 안함
Shift+M | 객체 스냅 재지정: 중간점
Shift+P | 객체 스냅 재지정: 끝점
Shift+Q | 객체 스냅 추적을 전환합니다.
Shift+S | 객체 스냅 실행을 사용합니다.
Shift+V | 객체 스냅 재지정: 중간점
Shift+X | 극좌표 추적을 전환합니다.
Shift+Z | UCSDETECT를 전환합니다.

사용자 인터페이스 사용자화 편집기에서 바로 가기 키의 리스트나 임시 재지정 키의 리스트 또는 두 키 모두의 리스트를 보거나 인쇄 또는 복사할 수 있습니다. 리스트에 있는 바로 가기 키와 임시 재지정 키는 프로그램에서 로드된 CUI 파일이 사용한 키입니다.

참고

    • 사용자 인터페이스 사용자화

    • 매크로 작성

    • 바로 가기 키를 작성하려면 (절차)

    • 바로 가기 키를 수정하려면 (절차)

    • 임시 재지정 키를 작성하려면 (절차)

    • 임시 재지정 키를 수정하려면 (절차)

    • 바로 가기 키 또는 임시 재지정 키의 리스트를 인쇄하려면 (절차)


바로 가기 키 및 임시 재지정 키 추가 (절차)

대시보드 컨트롤 추가 또는 전환
바로 가기 키 및 임시 재지정 키 추가
바로 가기 키 및 임시 재지정 키 추가
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 바로 가기 키 및 임시 재지정 키 추가 >
바로 가기 키 및 임시 재지정 키 추가
개념 절차 요약 참조

바로 가기 키를 작성하려면

바로 가기 키를 수정하려면

임시 재지정 키를 작성하려면

임시 재지정 키를 수정하려면

바로 가기 키 또는 임시 재지정 키의 리스트를 인쇄하려면


바로 가기 키 및 임시 재지정 키 추가 (절차)

바로 가기 키 및 임시 재지정 키 추가
바로 가기 키 및 임시 재지정 키 추가
바로 가기 키 및 임시 재지정 키 추가
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 바로 가기 키 및 임시 재지정 키 추가 >
바로 가기 키 및 임시 재지정 키 추가
개념 절차 요약 참조

바로 가기 키를 작성하려면

  1. 도구 메뉴 [image] 사용자화 [image] 인터페이스를 클릭합니다.명령 프롬프트에서 cui를 입력합니다.
  2. 사용자 인터페이스 사용자화 편집기의 사용자화 탭에서 키보드 바로 가기 옆에 있는 더하기 기호(+)를 클릭하여 확장합니다.
  3. 바로 가기 키 옆에 있는 더하기 기호(+)를 클릭하여 확장합니다.
  4. 명령 리스트 창에서 <파일 이름>의 사용자화 창의 바로 가기 키 노드로 명령을 끌어옵니다.

    작성한 새 바로 가기 키의 특성을 특성 창에 표시합니다.

  5. 키 상자에서 [...] 버튼을 클릭하여 바로 가기 키 대화상자를 엽니다.

  6. 바로 가기 키 대화상자의 새 바로 가기 키 누르기 상자를 클릭하여 상자가 강조되도록 합니다.

  7. 원하는 경우 수정자 키 Ctrl 키를 Shift 및 Alt 키와 조합하여 누른 상태에서 문자, 번호, 기능 키 또는 가상 키를 누릅니다. 유효한 수정자 및 키 조합에는 다음이 포함됩니다.
    • 수정자가 없는 함수(Fn) 키
    • 수정자가 없는 숫자 패드(NUMPADn) 키
    • Ctrl+문자 키, Ctrl+숫자 키, Ctrl+기능 키, Ctrl+가상 키
    • Ctrl+Alt+문자 키, Ctrl+Alt+숫자 키, Ctrl+Alt+기능 키, Ctrl+Alt+가상 키
    • Ctrl+Shift+문자 키, Ctrl+Shift+숫자 키, Ctrl+Shift+기능 키, Ctrl+Shift+가상 키
    • Ctrl+Shift+Alt+문자 키, Ctrl+Shift+Alt+숫자 키, Ctrl+Shift+Alt+기능 키, Ctrl+Shift+Alt+가상 키
      주지원되는 가상 키는 Escape, Insert, Delete, Home, End, Page Up, Page Down, 왼쪽 화살표, 오른쪽 화살표, 위쪽 화살표 및 아래쪽 화살표가 있습니다. 가상 키 Escape는 단독으로 사용되거나 수정자 조합 Ctrl+Shift+Alt와 함께만 사용될 수 있습니다.

    새 바로 가기 키 누르기 상자 아래에서, 현재 지정된 바로 가기가 해당 바로 가기 키에 현재 지정된 사항을 모두 표시합니다.

  8. 현재 지정과 대치하지 않으려면 다른 바로 가기 키를 사용합니다. 그렇지 않으면 확인을 클릭하여 바로 가기 키를 지정하고 바로 가기 키 대화상자를 닫습니다.
  9. 사용자 인터페이스 사용자화 편집기에서 확인을 클릭합니다.


바로 가기 키 및 임시 재지정 키 추가 (절차)

바로 가기 키 및 임시 재지정 키 추가
바로 가기 키 및 임시 재지정 키 추가
바로 가기 키 및 임시 재지정 키 추가
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 바로 가기 키 및 임시 재지정 키 추가 >
바로 가기 키 및 임시 재지정 키 추가
개념 절차 요약 참조

바로 가기 키를 수정하려면

  1. 도구 메뉴 [image] 사용자화 [image] 인터페이스를 클릭합니다.명령 프롬프트에서 cui를 입력합니다.
  2. 사용자 인터페이스 사용자화 편집기의 사용자화 탭에서 키보드 바로 가기 옆에 있는 더하기 기호(+)를 클릭하여 확장합니다.
  3. 바로 가기 키 옆에 있는 더하기 기호(+)를 클릭하여 확장합니다.
  4. 바로 가기 키를 클릭합니다.

    선택한 바로 가기 키의 특성을 특성 창에 표시합니다.

  5. 키 상자에서 [...] 버튼을 클릭하여 바로 가기 키 대화상자를 엽니다.

  6. 원하는 경우 수정자 키 Ctrl 키를 Shift 및 Alt 키와 조합하여 누른 상태에서 문자, 번호, 기능 키 또는 가상 키를 누릅니다. 유효한 수정자 및 키 조합에는 다음이 포함됩니다.
    • 수정자가 없는 함수(Fn) 키
    • 수정자가 없는 숫자 패드(NUMPADn) 키
    • Ctrl+문자 키, Ctrl+숫자 키, Ctrl+기능 키, Ctrl+가상 키
    • Ctrl+Alt+문자 키, Ctrl+Alt+숫자 키, Ctrl+Alt+기능 키, Ctrl+Alt+가상 키
    • Ctrl+Shift+문자 키, Ctrl+Shift+숫자 키, Ctrl+Shift+기능 키, Ctrl+Shift+가상 키
    • Ctrl+Shift+Alt+문자 키, Ctrl+Shift+Alt+숫자 키, Ctrl+Shift+Alt+기능 키, Ctrl+Shift+Alt+가상 키
      주지원되는 가상 키는 Escape, Insert, Delete, Home, End, Page Up, Page Down, 왼쪽 화살표, 오른쪽 화살표, 위쪽 화살표 및 아래쪽 화살표가 있습니다. 가상 키 Escape는 단독으로 사용되거나 수정자 조합 CTRL+Shift+Alt와 함께만 사용될 수 있습니다.

    새 바로 가기 키 누르기 상자 아래에서, [현재 지정된 바로 가기]에 해당 바로 가기 키에 대해 현재 지정된 사항이 모두 표시합니다.

  7. 현재 지정과 대치하지 않으려면 다른 바로 가기 키를 사용합니다. 그렇지 않으면 확인을 클릭하여 바로 가기 키를 지정하고 바로 가기 키 대화상자를 닫습니다.
  8. 사용자 인터페이스 사용자화 편집기에서 확인을 클릭합니다.


바로 가기 키 및 임시 재지정 키 추가 (절차)

바로 가기 키 및 임시 재지정 키 추가
바로 가기 키 및 임시 재지정 키 추가
바로 가기 키 및 임시 재지정 키 추가
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 바로 가기 키 및 임시 재지정 키 추가 >
바로 가기 키 및 임시 재지정 키 추가
개념 절차 요약 참조

임시 재지정 키를 작성하려면

  1. 도구 메뉴 [image] 사용자화 [image] 인터페이스를 클릭합니다.명령 프롬프트에서 cui를 입력합니다.
  2. 사용자 인터페이스 사용자화 편집기의 사용자화 탭에서 키보드 바로 가기 옆에 있는 더하기 기호(+)를 클릭하여 확장합니다.
  3. <파일 이름>의 사용자화 창에서 임시 재지정 키를 마우스 오른쪽 버튼으로 클릭합니다. 새 임시 재지정을 클릭합니다.

    TemporaryOverride1로 명명된 새 임시 재지정은 해당 임시 재지정 트리의 맨 아래에 놓입니다.

  4. 다음 중 하나를 수행합니다.
    • TemporaryOverride1 문자 위에 새 이름을 입력합니다.
    • TemporaryOverride1을 마우스 오른쪽 버튼으로 클릭합니다. 이름 바꾸기를 클릭합니다. 새 임시 재지정 이름을 입력합니다.
    • TemporaryOverride1을 클릭하고 기다린 다음 임시 재지정 이름을 다시 클릭하여 이름을 내부 편집합니다.
  5. 트리 뷰에서 새 임시 재지정을 선택한 다음 특성 창을 업데이트합니다.
    • 설명 상자에 임시 재지정 키에 대한 설명을 입력합니다.
    • 키 상자에서 [...] 버튼을 클릭하여 바로 가기 키 대화상자를 엽니다. 바로 가기 키 대화상자의 새 바로 가기 키 누르기 상자를 클릭하여 상자를 강조하고 키를 누릅니다. 유효한 수정자 키는 수정자 없는 기능(Fn 키) 키, Shift+문자 키 또는 Shift+숫자 키를 포함됩니다.
    • 매크로 1(키 누름) 상자에 해당 임시 재지정 키를 눌렀을 때 실행될 매크로를 입력합니다. 값이 아무 것도 지정되지 않으면 기본 매크로는 c^c^입니다.
    • 매크로 2(키 놓음) 상자에 해당 임시 재지정 키를 놓았을 때 실행될 매크로를 입력합니다. 값이 정의되지 않으면 키 놓음은 해당 응용프로그램을 (임시 재지정이 실행되기 전인) 이전 상태로 복원합니다.
      주매크로 작성에 대한 정보는 매크로 작성을 참고하십시오.


바로 가기 키 및 임시 재지정 키 추가 (절차)

바로 가기 키 및 임시 재지정 키 추가
바로 가기 키 및 임시 재지정 키 추가
바로 가기 키 및 임시 재지정 키 추가
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 바로 가기 키 및 임시 재지정 키 추가 >
바로 가기 키 및 임시 재지정 키 추가
개념 절차 요약 참조

임시 재지정 키를 수정하려면

  1. 도구 메뉴 [image] 사용자화 [image] 인터페이스를 클릭합니다.명령 프롬프트에서 cui를 입력합니다.
  2. 사용자 인터페이스 사용자화 편집기의 사용자화 탭에서 키보드 바로 가기 옆에 있는 더하기 기호(+)를 클릭하여 확장합니다.
  3. 임시 재지정 키 옆에 있는 더하기 기호(+)를 클릭하여 확장합니다.
  4. <파일 이름>의 사용자화 창에서 수정할 임시 재지정 키를 클릭합니다.

  5. 필요에 따라 특성 창을 업데이트합니다.
    • 설명 상자에 임시 재지정 키에 대한 설명을 입력합니다.
    • 키 상자에서 [...] 버튼을 클릭하여 바로 가기 키 대화상자를 엽니다. 바로 가기 키 대화상자의 새 바로 가기 키 누르기 상자를 클릭하여 상자를 강조하고 키를 누릅니다. 새 바로 가기 키 누르기 상자에서, 현재 지정된 바로 가기가 해당 바로 가기 키에 현재 지정된 사항을 모두 표시합니다. 선택한 키가 이미 지정되어 있지 않은 경우 확인을 클릭합니다.
    • 매크로 1(키 누름) 상자에 해당 임시 재지정 키를 눌렀을 때 실행될 매크로를 입력합니다. 값이 아무 것도 지정되지 않으면 기본 매크로는 c^c^입니다.
    • 매크로 2(키 놓음) 상자에 해당 임시 재지정 키를 놓았을 때 실행될 매크로를 입력합니다. 값이 정의되지 않으면 키 놓음은 해당 응용프로그램을 (임시 재지정이 실행되기 전인) 이전 상태로 복원합니다.

      주매크로 작성에 대한 정보는 매크로 작성을 참고하십시오.


바로 가기 키 및 임시 재지정 키 추가 (절차)

바로 가기 키 및 임시 재지정 키 추가
바로 가기 키 및 임시 재지정 키 추가
두 번 클릭 동작 작성
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 바로 가기 키 및 임시 재지정 키 추가 >
바로 가기 키 및 임시 재지정 키 추가
개념 절차 요약 참조

바로 가기 키 또는 임시 재지정 키의 리스트를 인쇄하려면

  1. 도구 메뉴 [image] 사용자화 [image] 인터페이스를 클릭합니다.명령 프롬프트에서 cui를 입력합니다.
  2. <파일 이름>의 사용자화 창에서 키보드 바로 가기 노드를 클릭합니다.

  3. 바로 가기 창에서, 인쇄하려는 키보드 바로 가기의 유형 및 상태를 필터 처리합니다.
    • 유형 드롭다운 리스트에서 리스트에 표시할 키보드 바로 가기의 유형을 선택합니다. 모든 키, 가속키 또는 임시 재지정 키를 선택합니다.
    • 상태 리스트에서, 리스트에 표시된 키보드 바로 가기의 상태를 선택합니다. 모두, 활성화, 비활성화 및 미지정을 선택합니다.
  4. 바로 가기 창에서 인쇄를 클릭합니다.


바로 가기 키 및 임시 재지정 키 추가 (요약 참조)

대시보드 컨트롤 추가 또는 전환
바로 가기 키 및 임시 재지정 키 추가
두 번 클릭 동작 작성
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 바로 가기 키 및 임시 재지정 키 추가 >
바로 가기 키 및 임시 재지정 키 추가
개념 절차 요약 참조

명령

CUI

작업공간, 도구막대, 메뉴, 바로 가기 메뉴 및 키보드 바로 가기와 같은 사용자화된 사용자 인터페이스 요소를 관리합니다.

시스템 변수

TOOLTIPS

도구막대에 툴팁의 표시를 제어합니다.

TEMPOVERRIDES

임시 재지정 키를 끄거나 켭니다

유틸리티

항목이 없습니다.

명령 수정자

항목이 없습니다.


두 번 클릭 동작 작성 (개념)

바로 가기 키 및 임시 재지정 키 추가
사용자 인터페이스 사용자화
마우스 버튼 사용자화
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 >
두 번 클릭 동작 작성
개념 절차 요약 참조

두 번 클릭 동작은 도면에서 커서가 한 객체 위에 있고 두 번 클릭이 좌표 입력 장치에서 등록된 경우 편집 명령을 작성하는 데 사용됩니다. 두 번 클릭 동작은 객체 유형을 구분하므로 특정 객체 유형에 사용할 특정 명령을 설정할 수 있습니다

두 번 클릭 동작은 특성 팔레트 또는 도면에서 두 번 클릭되는 객체 유형에 자주 사용되는 강력하고 편리한 특수 편집기를 표시하는 명령을 실행합니다. 다음 테이블은 CUI 편집기에서 속성 블록 두 번 클릭 동작의 정의를 보여줍니다.

속성 블록 두 번 클릭 동작의 특성
특성 창 항목 | 설명 | 예제
이름 | CUI 편집기에서 두 번 클릭 동작을 식별하는 데 사용되는 문자열입니다. | 속성 블록
설명 | CUI 편집기에서 요소를 설명하는 데 사용되는 문자입니다. |
객체 이름 | 두 번 클릭 동작이 연관되는 객체의 유형을 결정합니다. | ATTBLOCKREF
요소 ID | CUI 편집기에서 두 번 클릭 동작을 고유하게 식별합니다. | DC_0002

두 번 클릭 동작 객체 이름

두 번 클릭 동작은 유효한 도면 교환 형식(DXF™) 이름과 일치해야 하는 객체 이름 특성의 값에 의해 참조됩니다. DXF 이름을 사용하지 않는 일부 예외가 있습니다. 이러한 예외 사항으로는 블록, 동적 블록 및 외부 참조가 있으며 이들은 특수 객체 이름을 사용합니다. 예를 들어, acad.cui 파일에서 “속성 동적 블록”으로 명명된 두 번 클릭 동작은 객체 이름 ATTDYNBLOCKREF를 사용합니다.

다음 테이블은 블록, 동적 블록 및 외부 참조에 해당하는 객체 이름을 보여줍니다.

삽입된 객체에 해당하는 객체 이름
객체 이름 | 설명
BLOCKREF | 속성 없는 블록 참조
ATTBLOCKREF | 속성 있는 블록 참조
DYNBLOCKREF | 속성 없는 동적 블록 참조
ATTDYNBLOCKREF | 속성 있는 동적 블록 참조
XREF | 외부 참조(Xref)
주둘 이상의 객체가 선택되었거나 두 번 클릭 동작이 객체 유형과 연관되어 있지 않은 경우, 사용되는 기본 명령은 PROPERTIES입니다.

다음 테이블은 acad.cui 파일에 설정된 일부 객체 이름을 보여줍니다. 정의된 모든 동작의 전체 리스트를 보려면 사용자 인터페이스 사용자화(CUI) 편집기의 두 번 클릭 동작 노드를 확장합니다.

객체 | 명령(매크로)
ATTDEF | DDEDIT
ATTBLOCKREF | EATTEDIT
ATTDYNBLOCKREF | EATTEDIT
BLOCKREF | $M=$(if,$(and,$(>,$(getvar,blockeditlock),0)),^C^C_properties,^C^C_bedit)
DYNBLOCKREF | $M=$(if,$(and,$(>,$(getvar,blockeditlock),0)),^C^C_properties,^C^C_bedit)
HATCH | HATCHEDIT
IMAGE | IMAGEADJUST
LWPOLYLINE | PEDIT
MLINE | MLEDIT
MTEXT | MTEDIT
POLYLINE | PEDIT
SPLINE | SPLINEDIT
TEXT | DDEDIT
XREF | REFEDIT
주OLE 및 뷰포트 객체에 대해서는 두 번 클릭 동작을 작성할 수 없습니다.
참고

    • 매크로 작성

    • 두 번 클릭 동작을 작성하려면 (절차)

    • 두 번 클릭 동작을 수정하려면 (절차)


두 번 클릭 동작 작성 (절차)

바로 가기 키 및 임시 재지정 키 추가
두 번 클릭 동작 작성
두 번 클릭 동작 작성
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 두 번 클릭 동작 작성 >
두 번 클릭 동작 작성
개념 절차 요약 참조

두 번 클릭 동작을 작성하려면

두 번 클릭 동작을 수정하려면


두 번 클릭 동작 작성 (절차)

두 번 클릭 동작 작성
두 번 클릭 동작 작성
두 번 클릭 동작 작성
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 두 번 클릭 동작 작성 >
두 번 클릭 동작 작성
개념 절차 요약 참조

두 번 클릭 동작을 작성하려면

  1. 도구 메뉴 [image] 사용자화 [image] 인터페이스를 클릭합니다.명령 프롬프트에서 cui를 입력합니다.
  2. 사용자 인터페이스 사용자화 편집기의 사용자화 탭에 있는 <파일 이름>의 사용자화 창에서 두 번 클릭 동작을 마우스 오른쪽 버튼으로 클릭합니다. 새로운 두 번 클릭 동작을 클릭합니다.

    새로운 두 번 클릭 동작(DoubleClick1로 명명됨)은 두 번 클릭 동작 트리의 맨 아래에 위치합니다.

  3. 다음 중 하나를 수행합니다.
    • DoubleClick1 문자 위에 새로운 이름을 입력합니다.
    • DoubleClick1을 마우스 오른쪽 버튼으로 클릭합니다. 이름 바꾸기를 클릭합니다. 새로운 두 번 클릭 동작 이름을 입력합니다.
    • DoubleClick1을 클릭하고 기다린 다음 동작 이름을 다시 클릭하여 이름을 내부 편집합니다.
  4. 특성 창에서 다음을 수행합니다.
    • 설명 상자에 두 번 클릭 동작에 대한 설명을 입력합니다.
    • 객체 이름 상자에 DXF 이름이나 삽입된 객체에 사용되는 특수 객체 이름 중 하나를 입력합니다. 상자가 초점을 잃으면 값은 자동으로 대문자로 전환됩니다.

  5. 명령 리스트 창에서 추가할 명령을 <파일 이름>의 사용자화 창에 있는 두 번 클릭 동작 바로 아래의 위치로 끌어옵니다.

    주한 번에 하나의 명령만 두 번 클릭 동작과 연관될 수 있습니다.
  6. 확인을 클릭합니다.


두 번 클릭 동작 작성 (절차)

두 번 클릭 동작 작성
두 번 클릭 동작 작성
마우스 버튼 사용자화
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 두 번 클릭 동작 작성 >
두 번 클릭 동작 작성
개념 절차 요약 참조

두 번 클릭 동작을 수정하려면

  1. 도구 메뉴 [image] 사용자화 [image] 인터페이스를 클릭합니다.명령 프롬프트에서 cui를 입력합니다.
  2. 사용자 인터페이스 사용자화 편집기의 사용자화 탭에서 두 번 클릭 동작 옆에 있는 더하기 기호(+)를 클릭하여 확장합니다.
  3. 두 번 클릭 동작을 클릭합니다.

    특성 창에 선택한 두 번 클릭 동작의 특성이 표시됩니다.

  4. 객체 이름 상자에 DXF 이름이나 삽입된 객체에 사용되는 특수 객체 이름 중 하나를 입력합니다.

  5. 두 번 클릭 동작에 지정된 현재 명령을 대치할 경우 명령 리스트 창을 클릭하고 <파일 이름>의 사용자화 창에 선택된 두 번 클릭 동작으로 다른 명령을 끌어옵니다.

  6. 사용자 인터페이스 사용자화 편집기에서 확인을 클릭합니다.


두 번 클릭 동작 작성 (요약 참조)

바로 가기 키 및 임시 재지정 키 추가
두 번 클릭 동작 작성
버튼 메뉴에서 좌표 입력 승인
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 두 번 클릭 동작 작성 >
두 번 클릭 동작 작성
개념 절차 요약 참조

명령

CUI

작업공간, 도구막대, 메뉴, 바로 가기 메뉴 및 키보드 바로 가기와 같은 사용자화된 사용자 인터페이스 요소를 관리합니다.

OPTIONS

프로그램 설정값을 사용자화합니다.

시스템 변수

DBLCLKEDIT

도면 영역에서 두 번 클릭 편집 동작을 조정합니다.

PICKFIRST

명령을 호출하기 전에 객체를 선택할지 또는 호출한 후에 선택할지 조정합니다

유틸리티

항목이 없습니다.

명령 수정자

항목이 없습니다.


마우스 버튼 사용자화

두 번 클릭 동작 작성
사용자 인터페이스 사용자화
버튼 메뉴에서 좌표 입력 승인
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 >
마우스 버튼 사용자화
개념 절차

이 프로그램에서 좌표 입력 장치의 표준 동작을 변경할 수 있습니다.

마우스 버튼은 Windows 시스템 좌표 입력 장치의 기능 방법을 정의합니다. 사용자 인터페이스 사용자화 편집기에서 마우스 또는 다른 좌표 입력 장치의 동작을 사용자화할 수 있습니다. 좌표 입력 장치에 세 개 이상의 버튼이 있는 경우 두 번째 버튼과 세 번째 버튼의 동작을 변경할 수 있습니다. 모든 좌표 입력 장치에 있는 첫 번째 버튼은 사용자 인터페이스 사용자화 편집기에서 변경할 수 없습니다.

Shift 키와 Ctrl 키를 사용하면 필요에 맞는 조합의 번호를 작성할 수 있습니다. 사용자 좌표 입력 장치는 해당 좌표 입력 장치가 지정한 버튼의 수만큼 명령을 인식할 수 있습니다. 트리 노드의 마우스 버튼 섹션은 클릭, Shift+클릭, Ctrl+클릭 및 Ctrl+Shift+클릭과 같은 키보드 조합에 따라 구성됩니다. 타블렛 버튼은 순서대로 번호가 매겨집니다. 명령을 끌어 해당 명령을 마우스 버튼에 지정합니다. 명령을 클릭 노드로 끌어 추가 버튼을 작성합니다.

다음 테이블은 특성 창에 나타나는 클릭 마우스 버튼 특성을 보여줍니다.

클릭 마우스 버튼의 특성
특성 창 항목 | 설명 | 예제
별칭 | 마우스 버튼의 별칭을 지정합니다. 타원 버튼 [...]을 클릭하여 별칭 대화상자를 엽니다. CUI 파일의 별칭마다 고유해야 하며 프로그램에 따라서 마우스 버튼을 참조하는 데 사용됩니다. | AUX1

이 단원의 항목

  • 버튼 메뉴에서 좌표 입력 승인

    버튼이 여러 개 있는 좌표 입력 장치의 버튼 중 하나를 클릭하면 프로그램은 버튼 번호 뿐만 아니라 클릭하는 시점의 십자선 좌표도 읽습니다. 매크로를 조심스럽게 구성하여 좌표를 무시할지 해당 버튼으로 활성화된 명령과 함께 사용할지를 선택할 수 있습니다.


마우스 버튼 사용자화 (절차)

두 번 클릭 동작 작성
마우스 버튼 사용자화
버튼 메뉴에서 좌표 입력 승인
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 마우스 버튼 사용자화 >
마우스 버튼 사용자화
개념 절차

마우스 버튼 조합을 추가하려면


버튼 메뉴에서 좌표 입력 승인 (개념)

마우스 버튼 사용자화
마우스 버튼 사용자화
기존 인터페이스 요소 사용자화
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 마우스 버튼 사용자화 >
버튼 메뉴에서 좌표 입력 승인
개념 절차 요약 참조

버튼이 여러 개 있는 좌표 입력 장치의 버튼 중 하나를 클릭하면 프로그램은 버튼 번호 뿐만 아니라 클릭하는 시점의 십자선 좌표도 읽습니다. 매크로를 조심스럽게 구성하여 좌표를 무시할지 해당 버튼으로 활성화된 명령과 함께 사용할지를 선택할 수 있습니다.

매크로에서 사용자 입력을 위해 일시 중지에 설명되어 있는 것처럼 명령에 역슬래쉬(\)를 포함하여 사용자 입력을 위해 일시 중지시킬 수 있습니다. 마우스 및 버튼 디지타이즈 메뉴의 경우 버튼을 클릭하면 십자선의 좌표가 사용자 입력으로 제공됩니다. 이는 명령의 첫 번째 역슬래쉬에 대해서만 적용되며, 해당 항목에 역슬래쉬가 없으면 십자선 좌표가 사용되지 않습니다. 다음과 같은 명령을 고려해 봅시다.

line
line \

첫 번째 버튼은 LINE 명령을 시작하고 첫 번째 점 지정 프롬프트를 표시합니다. 두 번째 버튼도 LINE 명령을 시작하지만 프로그램은 첫 번째 점 지정 프롬프트에서 현재 십자선 위치를 사용하고 다음 점 지정 프롬프트를 표시합니다.

참고

    • 매크로 작성

    • 마우스 버튼 조합을 추가하려면 (절차)


버튼 메뉴에서 좌표 입력 승인 (절차)

마우스 버튼 사용자화
상위 단계로
기존 인터페이스 요소 사용자화
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 마우스 버튼 사용자화 > 버튼 메뉴에서 좌표 입력 승인 >
버튼 메뉴에서 좌표 입력 승인
개념 절차 요약 참조

마우스 버튼 조합을 추가하려면

  1. 도구 메뉴 [image] 사용자화 [image] 인터페이스를 클릭합니다.명령 프롬프트에서 cui를 입력합니다.
  2. 사용자 인터페이스 사용자화 편집기에서 사용자화 탭을 클릭합니다.
  3. <파일 이름>의 사용자화 창에서 마우스 버튼 옆에 있는 더하기 기호(+)를 클릭하여 리스트를 확장합니다.
  4. 마우스 버튼 섹션을 클릭합니다. 신규 버튼을 클릭합니다.

    버튼 n으로 명명된 새 마우스 버튼은 선택한 리스트의 맨 아래에 놓입니다.

  5. 명령 리스트 창에서 추가할 명령을 <파일 이름>의 사용자화 창의 마우스 버튼으로 끌어옵니다.

  6. 확인을 클릭합니다.


버튼 메뉴에서 좌표 입력 승인 (요약 참조)

두 번 클릭 동작 작성
버튼 메뉴에서 좌표 입력 승인
타블렛 메뉴 작성
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 마우스 버튼 사용자화 > 버튼 메뉴에서 좌표 입력 승인 >
버튼 메뉴에서 좌표 입력 승인
개념 절차 요약 참조

명령

CUI

작업공간, 도구막대, 메뉴, 바로 가기 메뉴 및 키보드 바로 가기와 같은 사용자화된 사용자 인터페이스 요소를 관리합니다.

시스템 변수

항목이 없습니다.

유틸리티

항목이 없습니다.

명령 수정자

항목이 없습니다.


기존 인터페이스 요소 사용자화

버튼 메뉴에서 좌표 입력 승인
사용자 인터페이스 사용자화
타블렛 메뉴 작성
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 >
기존 인터페이스 요소 사용자화
개념 절차

“기존”이라는 용어는 보통 프로그램의 현재 버전에서는 사용되지 않지만 현재 제공되는 사용자 인터페이스 요소보다 더 선호하는 사용자를 위해 계속 지원되고 있는 사용자 인터페이스 요소를 의미합니다.

기존 인터페이스 요소에는 다음이 포함되어 있습니다.

  • 타블렛 메뉴
  • 타블렛 버튼
  • 화면 메뉴
  • 이미지 배열 메뉴

이 단원의 항목

  • 타블렛 메뉴 작성

    명령 입력을 위한 메뉴 영역으로 최대 4개의 디지타이징 타블렛 영역을 구성할 수 있습니다.

  • 타블렛 버튼 사용자화

    타블렛 버튼을 사용자화하려면 마우스 버튼을 사용자화하는 방법과 같이 합니다.

  • 화면 메뉴 작성

    화면 메뉴는 기존 인터페이스를 제공하여 팔레트에 메뉴를 표시할 수 있도록 해줍니다. 사용자 인터페이스 사용자화 편집기에서 화면 메뉴를 작성하고 편집합니다.

  • 이미지 배열 메뉴 작성

    이미지 배열 메뉴의 목적은 문자 대신 선택할 수 있는 이미지를 제공하는 것입니다. 이미지 배열 및 이미지 배열 슬라이드를 작성, 편집 또는 추가할 수 있습니다.


기존 인터페이스 요소 사용자화 (절차)

버튼 메뉴에서 좌표 입력 승인
기존 인터페이스 요소 사용자화
타블렛 메뉴 작성
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 기존 인터페이스 요소 사용자화 >
기존 인터페이스 요소 사용자화
개념 절차

타블렛 메뉴의 행과 열을 정의하려면

타블렛 메뉴 지정을 취소하려면

화면 메뉴를 표시하려면

화면 메뉴를 설정하여 현재 명령을 반영하려면

화면 메뉴에 명령을 추가하려면

화면 메뉴에 부 메뉴를 작성하려면

이미지 배열 슬라이드를 작성하려면

이미지 배열 슬라이드를 보려면

이미지 배열 슬라이드 라이브러리를 작성하려면

이미지 배열 메뉴를 작성한 다음 이미지 배열 슬라이드를 지정하려면


타블렛 메뉴 작성 (개념)

기존 인터페이스 요소 사용자화
기존 인터페이스 요소 사용자화
타블렛 버튼 사용자화
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 기존 인터페이스 요소 사용자화 >
타블렛 메뉴 작성
개념 절차 요약 참조

명령 입력을 위한 메뉴 영역으로 최대 4개의 디지타이징 타블렛 영역을 구성할 수 있습니다.

사용자 인터페이스 사용자화 편집기의 노드는 타블렛 메뉴 1에서 타블렛 메뉴 4까지 레이블 표시되며 타블렛 선택과 연관된 매크로를 정의합니다.

TABLET 명령의 구성 옵션으로 정의한 타블렛 메뉴 영역은 각 영역에서 지정한 행과 열의 수에 의해 결정되는 같은 크기의 메뉴 섹션 상자로 나뉩니다. 이들 타블렛 메뉴 선택 상자는 타블렛 섹션 레이블 뒤에 오는 행에 왼쪽에서 오른쪽, 맨 위에서 맨 아래의 순서로 직접 대응됩니다(문자 포함 여부와 관계없음).

예를 들어, 5개의 열과 4개의 행에 맞게 메뉴 영역을 구성하는 경우 행 레이블 바로 뒤에 오는 행의 명령은 맨 위 행의 가장 왼쪽에 있는 선택 상자와 대응됩니다. 모든 타블렛 메뉴에 충분해야 하는 최대 32,766개의 명령을 프로그램의 각 타블렛 섹션에서 인식할 수 있습니다.

사용자의 매크로를 특성 창에 있는 매크로 셀에 추가할 수 있습니다. 이 영역의 명령 레이블은 타블렛 템플릿의 맨 위에 있는 225개의 상자(행 A~I, 열 1~25)에 대응됩니다. 표준 명령 구문을 사용하여 매크로를 추가할 수 있습니다. 다음 테이블은 특성 창에 나타나는 클릭 마우스 버튼 특성을 보여줍니다.

타블렛 메뉴 1의 특성
특성 창 항목 | 설명 | 예제
별칭 | 타블렛 메뉴의 별칭을 지정합니다. 타원 버튼[...]을 클릭하여 별칭 대화상자를 엽니다. CUI 파일의 별칭마다 고유해야 하며 프로그램에 따라서 타블렛 메뉴 참조하는 데 사용됩니다. | TABLET1, TABLET1STD
행 | 타블렛 메뉴를 위해 사용자화될 수 있는 행의 수 | 9
열 | 타블렛 메뉴를 위해 사용자화될 수 있는 열의 수 | 25
참고

    • 매크로 작성

    • 타블렛 메뉴의 행과 열을 정의하려면 (절차)

    • 타블렛 메뉴 지정을 취소하려면 (절차)


타블렛 메뉴 작성 (절차)

기존 인터페이스 요소 사용자화
상위 단계로
타블렛 메뉴 작성
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 기존 인터페이스 요소 사용자화 > 타블렛 메뉴 작성 >
타블렛 메뉴 작성
개념 절차 요약 참조

타블렛 메뉴의 행과 열을 정의하려면

타블렛 메뉴 지정을 취소하려면


타블렛 메뉴 작성 (절차)

타블렛 메뉴 작성
상위 단계로
타블렛 메뉴 작성
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 기존 인터페이스 요소 사용자화 > 타블렛 메뉴 작성 >
타블렛 메뉴 작성
개념 절차 요약 참조

타블렛 메뉴의 행과 열을 정의하려면

  1. 도구 메뉴 [image] 사용자화 [image] 인터페이스를 클릭합니다.명령 프롬프트에서 cui를 입력합니다.
  2. 사용자 인터페이스 사용자화 편집기의 사용자화 탭에 있는 <파일 이름>의 사용자화 창에서 기존 옆에 있는 더하기 기호(+)를 클릭하여 리스트를 확장합니다.
  3. 타블렛 메뉴 옆에 있는 더하기 기호(+)를 클릭하여 리스트를 확장합니다.
  4. 타블렛 메뉴 옆에 있는 더하기 기호(+)를 클릭하여 리스트를 확장합니다.
  5. 정의하려는 행을 클릭합니다.
  6. 명령 리스트 창에 추가하려는 명령을 배치합니다.
  7. 명령을 열로 끌어옵니다.
  8. 확인을 클릭합니다.


타블렛 메뉴 작성 (절차)

타블렛 메뉴 작성
상위 단계로
화면 메뉴 작성
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 기존 인터페이스 요소 사용자화 > 타블렛 메뉴 작성 >
타블렛 메뉴 작성
개념 절차 요약 참조

타블렛 메뉴 지정을 취소하려면

  1. 도구 메뉴 [image] 사용자화 [image] 인터페이스를 클릭합니다.명령 프롬프트에서 cui를 입력합니다.
  2. 사용자 인터페이스 사용자화 편집기의 사용자화 탭에 있는 <파일 이름>의 사용자화 창에서 기존 옆에 있는 더하기 기호(+)를 클릭하여 리스트를 확장합니다.
  3. 타블렛 메뉴 옆에 있는 더하기 기호(+)를 클릭하여 리스트를 확장합니다.
  4. 타블렛 메뉴 옆에 있는 더하기 기호(+)를 클릭하여 리스트를 확장합니다.
  5. 지우려는 행 또는 열을 마우스 오른쪽 버튼으로 클릭합니다. 지정 지우기를 클릭합니다.
  6. 확인을 클릭합니다.


타블렛 메뉴 작성 (요약 참조)

버튼 메뉴에서 좌표 입력 승인
타블렛 메뉴 작성
타블렛 버튼 사용자화
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 기존 인터페이스 요소 사용자화 > 타블렛 메뉴 작성 >
타블렛 메뉴 작성
개념 절차 요약 참조

명령

CUI

작업공간, 도구막대, 메뉴, 바로 가기 메뉴 및 키보드 바로 가기와 같은 사용자화된 사용자 인터페이스 요소를 관리합니다.

TABLET

부착한 디지타이징 타블렛을 조정하고, 구성하며, 켜고 끕니다.

시스템 변수

항목이 없습니다.

유틸리티

항목이 없습니다.

명령 수정자

항목이 없습니다.


타블렛 버튼 사용자화 (개념)

타블렛 메뉴 작성
기존 인터페이스 요소 사용자화
화면 메뉴 작성
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 기존 인터페이스 요소 사용자화 >
타블렛 버튼 사용자화
개념 요약 참조

타블렛 버튼을 사용자화하려면 마우스 버튼을 사용자화하는 방법과 같이 합니다.

타블렛 버튼은 디지타이저 타블렛과 함께 사용되는 퍽이라고도 하는 좌표 입력 장치에 있는 버튼입니다. 퍽은 다양한 쉐이프, 크기 및 버튼 구성으로 되어 있습니다. 첫 번째 버튼을 제외하고 퍽에 있는 모든 버튼을 사용자화할 수 있습니다.

일부 하드웨어 제조업체는 퍽마다 약간 다른 버튼 배치를 사용합니다. 어떤 퍽은 왼쪽 위 구석의 첫 번째 버튼으로 시작해서 1부터 F까지 아래로 세는 반면, 다른 퍽은 왼쪽 위 구석에서 시작하지만 다른 번호 매기기 체계를 가질 수 있습니다.

주버튼을 지정할 때 이를 테스트해서 적절한 버튼이 매핑되도록 하는 것이 중요합니다. 버튼이 배치된 방법에 대해서는 퍽과 함께 제공된 소유자 매뉴얼을 참조할 필요가 있습니다.

타블렛 버튼을 사용자화하려면 마우스 버튼을 사용자화하는 방법과 같이 합니다.

타블렛 버튼을 사용자화하는 방법에 대한 자세한 정보는 마우스 버튼 사용자화를 참고하십시오.


타블렛 버튼 사용자화 (요약 참조)

타블렛 메뉴 작성
타블렛 버튼 사용자화
화면 메뉴 작성
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 기존 인터페이스 요소 사용자화 > 타블렛 버튼 사용자화 >
타블렛 버튼 사용자화
개념 요약 참조

명령

CUI

작업공간, 도구막대, 메뉴, 바로 가기 메뉴 및 키보드 바로 가기와 같은 사용자화된 사용자 인터페이스 요소를 관리합니다.

시스템 변수

항목이 없습니다.

유틸리티

항목이 없습니다.

명령 수정자

항목이 없습니다.


화면 메뉴 작성 (개념)

타블렛 버튼 사용자화
기존 인터페이스 요소 사용자화
이미지 배열 메뉴 작성
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 기존 인터페이스 요소 사용자화 >
화면 메뉴 작성
개념 절차 요약 참조

화면 메뉴는 기존 인터페이스를 제공하여 팔레트에 메뉴를 표시할 수 있도록 해줍니다. 사용자 인터페이스 사용자화 편집기에서 화면 메뉴를 작성하고 편집합니다.

화면 메뉴는 사용할 수 없는 상태가 기본값입니다. 옵션 대화상자의 표시 탭에서 화면 메뉴 표시를 켭니다. 또한 MENUCTL 시스템 변수는 명령 프롬프트에 입력한 명령대로 화면 메뉴를 업데이트할지 여부를 제어합니다.

주제품의 향후 릴리즈에서는 화면 메뉴를 지원하지 않을 것입니다.

사용자 인터페이스 사용자화 편집기에서 각 화면 메뉴는 해당 화면 부 메뉴를 정의하는 여러 개의 메뉴 행으로 구성됩니다. 부 메뉴를 끌어와 사용자화 창의 화면 메뉴에 지정합니다. 명령을 명령 리스트 창에서 메뉴의 번호 매겨진 행으로 끌어와 해당 메뉴에 지정합니다. 지정되지 않은 행은 메뉴에서 빈 상태를 유지합니다.

화면 메뉴 특성 편집

다음 테이블에서 표시된 대로 화면 메뉴 특성을 수정할 수 있습니다.

화면 메뉴의 특성
특성 창 항목 | 설명 | 예제
이름 | 메뉴의 이름을 설정합니다. | SCREEN
설명 | 요소를 설명하는 문자로, 사용자 인터페이스에는 나타나지 않습니다. |
시작 선 | 화면 메뉴 부 메뉴의 시작 선을 설정합니다. | 1
선의 수 | 화면 부 메뉴에서 선의 수를 설정합니다. | 27
별칭 | 화면 메뉴의 별칭을 지정합니다. 이 별칭에 다중 정의가 지정되는 경우 “집합”이 표시됩니다. 타원 버튼[...]을 클릭하여 별칭 대화상자를 엽니다. | SCREEN, S

AutoCAD 화면 메뉴(최상위 메뉴)의 경우, 별칭 상자의 별칭은 화면 메뉴의 시작을 나타내는 Screen 및 부 메뉴 섹션 레이블을 나타내는 S입니다. 다른 메뉴의 행 지정은 메뉴에서 옵션의 순서를 정의합니다. 예를 들어 AutoCAD 화면 메뉴의 트리 뷰에서 행 3에 있는 파일 메뉴는 AutoCAD 화면 메뉴의 세 번째 위치를 나타냅니다.

트리 뷰의 부 메뉴 이름은 첫 번째 부 메뉴 항목 이름에 해당합니다. 예를 들어 새 부 메뉴는 NEW 외에 OPEN, QSAVE 및 SAVEAS—와 같은 명령을 포함합니다. 이들 부 메뉴의 별칭 상자는 부 메뉴를 포함하는 메뉴를 정의하며, 시작 선 상자는 해당 메뉴에서 부 메뉴의 위치를 지정합니다. 새 부 메뉴는 파일 화면 메뉴의 위치 3에 표시됩니다. 그러므로 특성 창에서 시작 선은 3입니다. 별칭을 두 번 클릭하여 별칭 대화상자를 표시할 경우, 메뉴 지정이 01_FILE로 됩니다.

시작 선 설정값을 조정하여 항상 표시되는 메뉴 항목을 지정할 수 있습니다. 예를 들어 새 부 메뉴가 행 3에서 시작하도록 설정되어 있으므로, AutoCAD 화면 메뉴(AutoCAD 및 **** 메뉴 옵션)의 행 1과 2의 메뉴 항목은 새 부 메뉴가 표시될 때 계속 표시됩니다.

이와 유사하게, 빈 줄을 사용하여 메뉴가 다른 메뉴의 메뉴 옵션을 숨기거나 표시하도록 설정할 수 있습니다. 예를 들어 새 부 메뉴에 정의된 행은 22개 뿐입니다(빈 줄 포함). 그러므로 AutoCAD 화면 메뉴의 행 25와 26에서 보조 및 마지막 부 메뉴는 새 부 메뉴가 선택될 때 계속 표시됩니다. 그러나 행 22에서의 옵션은 숨겨집니다.

참고

    • 매크로 작성

    • 화면 메뉴를 표시하려면 (절차)

    • 화면 메뉴를 설정하여 현재 명령을 반영하려면 (절차)

    • 화면 메뉴에 명령을 추가하려면 (절차)

    • 화면 메뉴에 부 메뉴를 작성하려면 (절차)


화면 메뉴 작성 (절차)

타블렛 메뉴 작성
상위 단계로
화면 메뉴 작성
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 기존 인터페이스 요소 사용자화 > 화면 메뉴 작성 >
화면 메뉴 작성
개념 절차 요약 참조

화면 메뉴를 표시하려면

화면 메뉴를 설정하여 현재 명령을 반영하려면

화면 메뉴에 명령을 추가하려면

화면 메뉴에 부 메뉴를 작성하려면


화면 메뉴 작성 (절차)

화면 메뉴 작성
상위 단계로
화면 메뉴 작성
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 기존 인터페이스 요소 사용자화 > 화면 메뉴 작성 >
화면 메뉴 작성
개념 절차 요약 참조

화면 메뉴를 표시하려면

  1. 도구 메뉴 [image] 옵션을 클릭합니다.명령 프롬프트에서 options를 입력합니다.
  2. 옵션 대화상자에 있는 표시 탭의 윈도우 요소 아래에서 화면 메뉴 표시를 선택합니다.
  3. 확인을 클릭합니다.


화면 메뉴 작성 (절차)

화면 메뉴 작성
상위 단계로
화면 메뉴 작성
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 기존 인터페이스 요소 사용자화 > 화면 메뉴 작성 >
화면 메뉴 작성
개념 절차 요약 참조

화면 메뉴를 설정하여 현재 명령을 반영하려면

  1. 명령 프롬프트에서 menuctl을 입력합니다.
  2. 다음 중 하나를 수행합니다.
    • 1을 입력하여 화면 메뉴를 설정하면 현재 명령을 반영합니다.
    • 0을 입력하여 화면 메뉴를 설정하면 현재 명령을 무시합니다.


화면 메뉴 작성 (절차)

화면 메뉴 작성
상위 단계로
화면 메뉴 작성
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 기존 인터페이스 요소 사용자화 > 화면 메뉴 작성 >
화면 메뉴 작성
개념 절차 요약 참조

화면 메뉴에 명령을 추가하려면

  1. 도구 메뉴 [image] 사용자화 [image] 인터페이스를 클릭합니다.명령 프롬프트에서 cui를 입력합니다.
  2. 사용자 인터페이스 사용자화 편집기의 사용자화 탭에 있는 <파일 이름>의 사용자화 창에서 기존 옆에 있는 더하기 기호(+)를 클릭하여 리스트를 확장합니다.
  3. 기존 리스트에서 화면 메뉴 옆에 있는 더하기 기호(+)를 클릭하여 리스트를 확장합니다.
  4. 명령 리스트 창에 추가하려는 명령을 배치합니다. 화면 메뉴로 명령을 끌어옵니다. 명령을 놓을 수 있을 때 화살표가 커서 옆에 표시됩니다.
  5. 확인을 클릭합니다.


화면 메뉴 작성 (절차)

화면 메뉴 작성
상위 단계로
이미지 배열 메뉴 작성
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 기존 인터페이스 요소 사용자화 > 화면 메뉴 작성 >
화면 메뉴 작성
개념 절차 요약 참조

화면 메뉴에 부 메뉴를 작성하려면

  1. 도구 메뉴 [image] 사용자화 [image] 인터페이스를 클릭합니다.명령 프롬프트에서 cui를 입력합니다.
  2. 사용자 인터페이스 사용자화 편집기의 사용자화 탭에 있는 <파일 이름>의 사용자화 창에서 기존 옆에 있는 더하기 기호(+)를 클릭하여 리스트를 확장합니다.
  3. 기존 리스트에서 화면 메뉴를 마우스 오른쪽 버튼으로 클릭합니다. 새 화면 메뉴를 클릭합니다.

    ScreenMenu1이라는 이름의 새 화면 메뉴가 화면 메뉴 트리의 맨 아래 놓입니다.

  4. 다음 중 하나를 수행합니다.
    • ScreenMenu1 문자 위에 새 이름을 입력합니다.
    • ScreenMenu1을 마우스 오른쪽 버튼으로 클릭합니다. 이름 바꾸기를 클릭합니다. 그런 다음 새 메뉴 이름을 입력합니다.
    • ScreenMenu1을 클릭하고 기다린 다음 화면 메뉴 이름을 다시 클릭하여 이름을 내부 편집합니다.
  5. 트리 뷰에서 새 화면 메뉴를 선택하고 다음과 같이 특성 창을 업데이트합니다.
    • 설명 상자에 화면 메뉴에 대한 설명을 입력합니다.
    • 시작 선 상자에 메뉴의 첫 번째 옵션에 대한 행 번호를 입력합니다.
    • 선 개수 상자에 화면 메뉴에서 사용할 수 있는 전체 선의 수를 입력합니다.
    • 별칭 상자에 별칭을 입력합니다.
  6. 명령 리스트 창에서 명령을 <파일 이름>의 사용자화 창에 있는 화면 메뉴 바로 아래의 위치로 끌어옵니다.
  7. 확인을 클릭합니다.


화면 메뉴 작성 (요약 참조)

타블렛 버튼 사용자화
화면 메뉴 작성
이미지 배열 메뉴 작성
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 기존 인터페이스 요소 사용자화 > 화면 메뉴 작성 >
화면 메뉴 작성
개념 절차 요약 참조

명령

CUI

작업공간, 도구막대, 메뉴, 바로 가기 메뉴 및 키보드 바로 가기와 같은 사용자화된 사용자 인터페이스 요소를 관리합니다.

OPTIONS

프로그램 설정값을 사용자화합니다.

시스템 변수

MENUCTL

화면 메뉴의 페이지 전환을 조정합니다

SCREENBOXES

도면 영역의 화면 메뉴 영역에 있는 상자 수를 저장합니다

유틸리티

항목이 없습니다.

명령 수정자

항목이 없습니다.


이미지 배열 메뉴 작성 (개념)

화면 메뉴 작성
기존 인터페이스 요소 사용자화
AutoLISP 파일 로드
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 기존 인터페이스 요소 사용자화 >
이미지 배열 메뉴 작성
개념 절차 요약 참조

이미지 배열 메뉴의 목적은 문자 대신 선택할 수 있는 이미지를 제공하는 것입니다. 이미지 배열 및 이미지 배열 슬라이드를 작성, 편집 또는 추가할 수 있습니다.

이미지 배열 대화상자는 이미지를 20개 그룹으로 표시하며, 연관 슬라이드 파일 이름이나 관련 문자를 표시하는 스크롤링 리스트 상자를 왼쪽에 표시합니다. 이미지 배열 대화상자에 20개 이상의 슬라이드가 포함된 경우, 추가 슬라이드가 새 페이지에 추가됩니다. 다음 및 이전 버튼이 활성화되어 사용자가 이미지의 각 페이지를 찾아볼 수 있습니다.

다음 예제는 선택된 돔 이미지 배열 슬라이드를 포함한 3D 객체 이미지 배열 대화상자입니다.

사용자 인터페이스 사용자화 편집기에서 이미지 배열 메뉴를 정의합니다. 다음 테이블은 특성 창에 나타나는 3D 객체 이미지 배열 메뉴 특성을 보여줍니다.

3D 객체 이미지 배열 메뉴의 특성
특성 창 항목 | 설명 | 예제
이름 | CUI 편집기에서만 사용되고 사용자 인터페이스에는 표시되지 않는 문자열입니다. | 3D 객체
설명 | 요소를 설명하지만 사용자 인터페이스에는 나타나지 않는 문자입니다. |
별칭 | 이미지 배열 메뉴의 별칭을 지정합니다. 타원 버튼[...]을 클릭하여 별칭 대화상자를 엽니다. CUI 파일의 별칭마다 고유해야 하며 프로그램에 따라서 이미지 파일 메뉴를 참조하는 데 사용됩니다. | image, image_3DObjects

다음 테이블은 특성 창에 나타나는 3D 객체 이미지 배열 메뉴의 돔 명령 특성을 보여줍니다.

3D 객체 이미지 배열 메뉴의 돔 명령 특성
특성 창 항목 | 설명 | 예제
이름 | 이미지 배열 메뉴 대화상자의 왼쪽에 있는 리스트 상자에 표시되는 문자열입니다. 문자열에 하이픈(-)이나 밑줄(_) 이외의 영숫자 문자가 구두점 없이 포함되어야 합니다. | 돔
설명 | 요소를 설명하는 문자로, 사용자 인터페이스에는 나타나지 않습니다. | 구형 다각형 메쉬의 윗쪽 반을 작성합니다.
매크로 | 명령 매크로입니다. 표준 매크로 구문을 따릅니다. | ^C^C_ai_dome
요소 ID | 명령을 고유하게 식별하는 태그입니다. | ID_Ai_dome
슬라이드 라이브러리 | 다중 슬라이드로 이루어지고 파일 slidelib.exe를 사용하여 작성된 파일입니다. | acad
슬라이드 레이블 | 슬라이드 라이브러리 파일 혹은 별도로 저장된 슬라이드 이미지에 포함된 슬라이드의 이름입니다. | 돔

AutoCAD로 생성한 모든 슬라이드를 이미지로 사용할 수 있습니다. 이미지 배열 메뉴의 슬라이드를 준비할 때 다음의 제한 사항을 염두에 두십시오.

  • 이미지를 간단하게 유지하십시오.이미지 배열 메뉴가 표시되면 사용자는 모든 이미지가 그려질 때까지 기다린 후 선택을 해야 합니다. 복잡한 여러 기호를 표시하는 경우, 완전한 표현보다는 간단하고 인식 가능한 이미지를 사용합니다.
  • 상자를 채우십시오. 이미지용 슬라이드를 만들 때에는 MSLIDE를 시작하기 전에 이미지로 화면을 채우십시오. 이미지의 폭이 너무 넓고 짧거나 길이가 너무 길고 폭이 좁은 경우, 슬라이드를 만들기 전에 PAN을 사용하여 이미지를 화면 가운데에 오게 하면 이미지 배열 메뉴가 가장 보기 좋은 상태가 됩니다.

    이미지는 3:2의 가로/세로 비율(폭 3 단위, 높이 2 단위)로 표시됩니다. 도면 영역의 가로/세로 비율이 다르면 이미지 배열 메뉴에서 중심에 맞춰진 이미지 슬라이드를 생성하는 것이 어려울 수 있습니다. 가로/세로 비율이 3:2인 배치 뷰포트 내에서 작업하는 경우, 이미지 위치를 지정하여 이미지 배열 메뉴에 표시될 때 똑같이 보이도록 할 수 있습니다.

  • 해당 이미지의 용도를 기억하십시오. 이미지를 사용하여 추상적인 개념을 기호로 인코딩하지 마십시오. 이미지 배열은 주로 그래픽 기호를 선택하는 데 있어서 유용합니다.
참고

    • 이미지 배열 슬라이드를 작성하려면 (절차)

    • 이미지 배열 슬라이드를 보려면 (절차)

    • 이미지 배열 슬라이드 라이브러리를 작성하려면 (절차)

    • 이미지 배열 메뉴를 작성한 다음 이미지 배열 슬라이드를 지정하려면 (절차)


이미지 배열 메뉴 작성 (절차)

화면 메뉴 작성
상위 단계로
이미지 배열 메뉴 작성
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 기존 인터페이스 요소 사용자화 > 이미지 배열 메뉴 작성 >
이미지 배열 메뉴 작성
개념 절차 요약 참조

이미지 배열 슬라이드를 작성하려면

이미지 배열 슬라이드를 보려면

이미지 배열 슬라이드 라이브러리를 작성하려면

이미지 배열 메뉴를 작성한 다음 이미지 배열 슬라이드를 지정하려면


이미지 배열 메뉴 작성 (절차)

이미지 배열 메뉴 작성
상위 단계로
이미지 배열 메뉴 작성
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 기존 인터페이스 요소 사용자화 > 이미지 배열 메뉴 작성 >
이미지 배열 메뉴 작성
개념 절차 요약 참조

이미지 배열 슬라이드를 작성하려면

  1. AutoCAD에서 슬라이드에 나타낼 형상을 그립니다.
  2. 뷰 메뉴 [image] 줌 [image] 중심을 클릭합니다.명령 프롬프트에서 zoom을 입력합니다.
  3. 명령 프롬프트에서 mslide를 입력합니다.
  4. 슬라이드 파일 작성 대화상자에서 파일 이름을 지정합니다.
  5. 원할 경우 저장을 클릭하고 슬라이드 라이브러리 파일에 추가합니다. 이 이미지 슬라이드가 새 이미지 배열에 연관되도록 할 수 있습니다.


이미지 배열 메뉴 작성 (절차)

이미지 배열 메뉴 작성
상위 단계로
이미지 배열 메뉴 작성
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 기존 인터페이스 요소 사용자화 > 이미지 배열 메뉴 작성 >
이미지 배열 메뉴 작성
개념 절차 요약 참조

이미지 배열 슬라이드를 보려면

  1. 명령 프롬프트에서 vslide를 입력합니다.
  2. 슬라이드 파일 선택 대화상자에서 보려는 슬라이드 파일을 찾아 선택합니다.
  3. [열기]를 클릭합니다.

    슬라이드 파일은 도면 윈도우에 표시되어야 합니다. 슬라이드 파일 표시를 지우려면 도면에서 재생성을 수행합니다.


이미지 배열 메뉴 작성 (절차)

이미지 배열 메뉴 작성
상위 단계로
이미지 배열 메뉴 작성
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 기존 인터페이스 요소 사용자화 > 이미지 배열 메뉴 작성 >
이미지 배열 메뉴 작성
개념 절차 요약 참조

이미지 배열 슬라이드 라이브러리를 작성하려면

  1. 슬라이드 라이브러리를 추가하려는 단일 폴더 위치에 모든 슬라이드를 놓습니다.
  2. 시작 메뉴(Windows) [image] 실행을 클릭합니다.
  3. 실행 대화상자의 텍스트 상자에 cmd를 입력합니다.
  4. 확인을 클릭하여 DOS 윈도우를 불러옵니다.
  5. 명령 프롬프트에서 CD <슬라이드의 폴더 위치>를 입력합니다.

    예를 들어: CD"c:\slides"입니다.

  6. 슬라이드 파일 위치에서 dir *.sld /b > <파일 이름>을 입력합니다.

    예를 들어: dir &.sdl /b > "myslides"입니다.

    텍스트 파일은 현재 폴더에 포함된 슬라이드 파일의 이름으로 작성됩니다.

  7. 현재 폴더에 있는 모든 슬라이드 파일에 대해 작성된 텍스트 파일을 이용하여 <AutoCAD 설치 폴더>\slidelib.exe <슬라이드 라이브러리 파일 이름> < <슬라이드 이름을 가진 텍스트 파일>을 입력합니다.

    예: “C:\Program Files\AutoCAD 2008\slidelib.exe”“myslidelib” < “myslides”

  8. 완료되면 DOS 윈도우를 닫습니다.
경고슬라이드 라이브러리를 작성한 후에 개별 슬라이드 파일이 실수로 삭제되지 않도록 안전한 위치에 보관합니다. 이것은 차후에 슬라이드 라이브러리를 재생성할 필요가 있을 경우 중요합니다.


이미지 배열 메뉴 작성 (절차)

이미지 배열 메뉴 작성
상위 단계로
AutoLISP 파일 로드
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 기존 인터페이스 요소 사용자화 > 이미지 배열 메뉴 작성 >
이미지 배열 메뉴 작성
개념 절차 요약 참조

이미지 배열 메뉴를 작성한 다음 이미지 배열 슬라이드를 지정하려면

  1. 도구 메뉴 [image] 사용자화 [image] 인터페이스를 클릭합니다.명령 프롬프트에서 cui를 입력합니다.
  2. 사용자 인터페이스 사용자화 편집기의 사용자화 탭에 있는 <파일 이름>의 사용자화 창에서 기존 옆에 있는 더하기 기호(+)를 클릭하여 리스트를 확장합니다.
  3. 기존 리스트에서 이미지 배열 메뉴를 마우스 오른쪽 버튼으로 클릭합니다. 새 이미지 배열 메뉴를 클릭합니다.

    ImageTileMenu1로 명명된 새 이미지 배열 메뉴는 해당 이미지 배열 메뉴 트리의 맨 아래에 놓입니다.

  4. 다음 중 하나를 수행합니다.
    • ImageTileMenu1 문자 위에 새 이름을 입력합니다.
    • ImageTileMenu1을 마우스 오른쪽 버튼으로 클릭합니다. 이름 바꾸기를 클릭합니다. 그런 다음 새 이미지 배열 이름을 입력합니다.
    • ImageTileMenu1을 클릭하고 기다린 다음 이미지 배열 이름을 다시 클릭하여 이름을 내부 편집합니다.
  5. 명령 리스트 창에서 명령을 <파일 이름>의 사용자화 창의 새 이미지 배열 메뉴로 끌어옵니다.
  6. 특성 창에 다음과 같이 새 이미지 배열 슬라이드에 대한 특성을 입력합니다.
    • 이름 상자에 이미지 배열의 리스트 상자에 표시할 문자를 입력합니다.
    • 설명 상자에 이미지 배열에 대한 설명을 입력합니다.
    • 슬라이드 라이브러리 상자에서 이미지 배열에 대한 슬라이드를 포함하고 있는 이미지 배열 슬라이드 라이브러리의 이름을 입력합니다. 이미지 배열 슬라이드 라이브러리는 지원 파일 검색 경로를 정의하는 폴더 중 하나에 있어야 합니다. 슬라이드 라이브러리는 없지만 이미지 배열 슬라이드 파일이 있는 경우, 이미지 배열 슬라이드 라이브러리 상자에 해당 이름을 입력합니다.
    • 슬라이드 레이블 상자에서, 슬라이드 라이브러리 상자에 나열된 이미지 배열 슬라이드 라이브러리에 포함되어 있는 이미지 배열 슬라이드 파일의 이름을 입력합니다.
  7. 확인을 클릭합니다.


이미지 배열 메뉴 작성 (요약 참조)

화면 메뉴 작성
이미지 배열 메뉴 작성
AutoLISP 파일 로드
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 기존 인터페이스 요소 사용자화 > 이미지 배열 메뉴 작성 >
이미지 배열 메뉴 작성
개념 절차 요약 참조

명령

CUI

작업공간, 도구막대, 메뉴, 바로 가기 메뉴 및 키보드 바로 가기와 같은 사용자화된 사용자 인터페이스 요소를 관리합니다.

MSLIDE

현재 모형 뷰포트 또는 현재 배치의 슬라이드 파일을 작성합니다.

VSLIDE

현재 뷰포트에 이미지 슬라이드 파일을 표시합니다.

시스템 변수

항목이 없습니다.

유틸리티

항목이 없습니다.

명령 수정자

항목이 없습니다.


AutoLISP 파일 로드 (개념)

이미지 배열 메뉴 작성
사용자 인터페이스 사용자화
작업공간 사용자화
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 >
AutoLISP 파일 로드
개념 절차 요약 참조

AutoLISP(LSP 또는 MNL) 파일에는 사용자화 작업 또는 동작을 인터페이스에 추가하는 스크립트가 포함됩니다. 사용자 인터페이스 사용자화 편집기의 사용자화 탭을 사용하여 AutoLISP 파일을 CUI 파일로 로드할 수 있습니다.

AutoLISP 사용에 대한 자세한 정보는 AutoLISP 및 Visual LISP을 참고하십시오.

팁사용자의 주, 엔터프라이즈 또는 부분적 CUI 파일로서 같은 이름 및 위치를 가진 MNL 파일은 자동 로드됩니다. 이 파일을 제거할 수 없습니다.
참고

    • 사용자 인터페이스 사용자화 편집기에서 AutoLISP 파일을 로드하려면 (절차)


AutoLISP 파일 로드 (절차)

이미지 배열 메뉴 작성
AutoLISP 파일 로드
작업공간 사용자화
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > AutoLISP 파일 로드 >
AutoLISP 파일 로드
개념 절차 요약 참조

사용자 인터페이스 사용자화 편집기에서 AutoLISP 파일을 로드하려면

  1. 도구 메뉴 [image] 사용자화 [image] 인터페이스를 클릭합니다.명령 프롬프트에서 cui를 입력합니다.
  2. 사용자 인터페이스 사용자화 편집기의 사용자화 탭에 있는 <파일 이름>의 사용자화 창에서 LISP 파일을 마우스 오른쪽 버튼으로 클릭합니다. LISP 로드를 클릭합니다.

  3. LISP 로드 대화상자에서 로드하려는 AutoLISP 파일을 찾아 선택합니다. LSP 확장자를 가진 파일만 선택할 수 있습니다.
    팁LSP 확장자를 가진 파일만 이 방법으로 로드할 수 있지만 여전히 다른 유형의 사용자 프로그램 파일도 로드할 수 있습니다. 다른 유형의 사용자 프로그램 파일을 로드하려면 NETLOAD, VBALOAD 또는 ARX와 같은 AutoCAD 명령을 사용합니다.
  4. 열기를 클릭합니다.


AutoLISP 파일 로드 (요약 참조)

이미지 배열 메뉴 작성
AutoLISP 파일 로드
작업공간 사용자화
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > AutoLISP 파일 로드 >
AutoLISP 파일 로드
개념 절차 요약 참조

명령

CUI

작업공간, 도구막대, 메뉴, 바로 가기 메뉴 및 키보드 바로 가기와 같은 사용자화된 사용자 인터페이스 요소를 관리합니다.

APPLOAD

응용프로그램을 로드하거나 언로드하고 시작할 때 로드할 응용프로그램을 정의합니다.

시스템 변수

항목이 없습니다.

유틸리티

항목이 없습니다.

명령 수정자

항목이 없습니다.


작업공간 사용자화 (개념)

AutoLISP 파일 로드
사용자 인터페이스 사용자화
사용자 인터페이스 사용자화 FAQ
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 >
작업공간 사용자화
개념 절차 요약 참조

작업공간을 사용자화하여 선택하는 도구막대, 메뉴 및 팔레트만 표시하는 도면 환경을 작성할 수 있습니다.

작업공간에 대한 사용자화 옵션에는 사용자 인터페이스 사용자화 편집기를 사용한 작업공간 작성, 작업공간의 특성 변경 및 모든 작업공간에 도구막대 표시가 있습니다.

사용자 인터페이스 사용자화 편집기를 사용하여 작업공간 작성 또는 수정

사용자가 작업공간을 작성하거나 수정하는 가장 쉬운 방법은 도면 작업에 가장 적합한 도구막대와 팔레트를 설정한 후 프로그램의 작업공간으로 저장하는 것입니다. 사용자가 이 작업공간 환경내에서 그리기 작업을 할 필요가 있을 때마다 이 작업공간에 접근할 수 있습니다.

또한 사용자 인터페이스 사용자화 편집기를 사용하여 작업공간을 설정할 수도 있습니다. 이 대화상자에서 정밀한 특성 및 요소(도구막대, 메뉴 및 팔레트)를 사용하여 사용자가 특정 작업에 액세스하도록 하는 작업공간을 작성하거나 수정할 수 있습니다. 이 작업공간을 포함하는 CUI 파일을 엔터프라이즈 CUI 파일로 지정할 수 있으므로 다른 사용자와 해당 작업공간을 공유할 수 있습니다.

표시: 작업공간 작성

다음 이미지 아래의 재생 화살표를 클릭하여 애니메이션을 시작합니다.

아래 애니매이션은 작업공간을 작성하는 방법을 보여줍니다 이 애니메이션에는 작업공간 작성 방법과 도구막대, 메뉴 및 팔레트의 표시 제어 방법이 나타나 있습니다. 부분적 CUI 파일 작업 방법에 대해서는 나타나 있지 않습니다. 부분적 CUI 파일 작업 방법에 대한 정보는 부분적 CUI 파일 작성 및 로드를 참조하십시오.

엔터프라이즈 CUI 파일 작성에 관한 자세한 정보는 엔터프라이즈 CUI 파일 작성을 참고하십시오.

다음은 사용자 인터페이스 사용자화 편집기의 작업공간 내용 창에 대한 예제입니다. 작업공간 사용자화를 클릭하여 선택한 작업공간을 작성 또는 수정할 수 있습니다.

다음 예제는 작업공간 컨텐츠 창에서 작업공간 사용자화를 클릭한 후 <파일 이름>의 사용자화 창입니다. 작업공간을 추가하려는 각 요소 옆에 확인란을 표시합니다. 선택 상자를 클릭하여 요소를 해당 작업공간에 추가합니다.

작업공간의 특성 변경

작업공간 이름, 설명, 모형 또는 배치 탭에서 표시할 지 여부 등 작업공간 특성을 사용자 인터페이스 사용자화 편집기에서 정의할 수 있습니다. 다음 테이블은 특성 창에 나타나는 AutoCAD Classic 작업공간 특성을 보여줍니다.

AutoCAD Classic 작업공간의 특성
특성 창 항목 | 설명 | 예제
이름 | 도구 메뉴 및 CUI 편집기의 작업공간 메뉴 항목 아래에 있는 WORKSPACE 명령에 대한 명령 프롬프트에서 작업공간 도구막대의 드롭다운 상자에 표시되는 문자열입니다. | AutoCAD Classic
설명 | 작업공간을 설명하지만 사용자 인터페이스에는 나타나지 않는 문자입니다. |
시작하기 | 작업공간이 복원되거나 현재로 설정되는 경우 도면에서 모형 탭, 마지막 활성 배치 탭 또는 현재 활성 탭의 표시 여부를 결정합니다. | 모형
모형/배치 탭 | 작업공간이 복원되거나 현재로 설정되는 경우 도면 윈도우에서 모형/배치 탭을 표시할지 여부를 결정합니다. | 켜기
화면 메뉴 | 작업공간이 복원되고 현재로 설정될 때 화면 메뉴를 표시할 것인지 여부를 결정합니다. | 끄기
스크롤 막대 | 작업공간이 복원되고 현재로 설정될 때 스크롤 막대를 표시할 것인지 여부를 결정합니다. | 끄기

팔레트의 특성 변경

팔레트라고 하는 대부분의 윈도우는 고정, 앵커 또는 부동으로 설정될 수 있습니다. 사용자 인터페이스 사용자화 편집기의 작업공간 내용 창에서 특성을 변경하여 이러한 윈도우의 크기, 위치 또는 모양을 정의할 수 있습니다. 이러한 윈도우에는 다음이 포함됩니다.

  • 고급 렌더 설정
  • 명령행
  • 대시보드
  • dbConnect 관리자
  • DesignCenter
  • 외부 참조
  • 모형의 조명
  • 재료
  • 표식 세트 관리자
  • 특성
  • QuickCalc
  • 시트 세트 관리자
  • 일영 특성
  • 도구 팔레트
  • 뷰 스타일 관리자

다음 테이블은 특성 창에 나타나는 도구 팔레트 특성을 보여줍니다.

도구 팔레트 윈도우의 특성
특성 창 항목 | 설명 | 예제
표시 | 팔레트의 가시성 상태 예, 아니오 또는 변경 안함 등의 옵션을 사용할 수 있습니다. 변경 안함은 작업공간이 복원되거나 현재로 설정될 때 마지막으로 사용된 팔레트의 상태를 유지합니다. | 예
방향 | 팔레트의 화면상 고정 또는 부동 상태. 부동, 왼쪽, 오른쪽 또는 변경 안함 등의 옵션을 사용할 수 있습니다. 변경 안함은 작업공간이 복원되거나 현재로 설정될 때 마지막으로 사용된 팔레트의 상태를 유지합니다. 명령행과 같은 일부 팔레트도 맨 위 또는 맨 아래의 고정 위치를 지원합니다. | 부동
고정 허용 | 사용자가 팔레트를 지정된 고정 영역 중 하나로 끌어 고정할 수 있는지를 제어합니다. 예, 아니오 또는 변경 안함 등의 옵션을 사용할 수 있습니다. 변경 안함은 작업공간이 복원되거나 현재로 설정될 때 마지막으로 사용된 팔레트의 설정을 유지합니다. | 예
자동 숨기기 | 사용 중이 아닐 때 팔레트를 롤업할지를 제어합니다. 켜기, 끄기 또는 변경 안함 등의 옵션을 사용할 수 있습니다. 변경 안함은 작업공간이 복원되거나 현재로 설정될 때 마지막으로 사용된 팔레트의 설정을 유지합니다. | 끄기
투명도 사용 | 팔레트를 투명하게 나타낼 것인지를 제어합니다. 예, 아니오 또는 변경 안함 등의 옵션을 사용할 수 있습니다. 변경 안함은 작업공간이 복원되거나 현재로 설정될 때 마지막으로 사용된 팔레트의 설정을 유지합니다. | 아니오
투명도 양 | 팔레트가 얼마나 불투명하게 표시될 것인지를 제어합니다. 적합한 범위는 0부터 100까지입니다. | 0
기본 그룹 | 어떤 사용자 정의 팔레트 그룹을 표시할 것인지를 조정합니다. | 모든 팔레트
높이 | 팔레트가 부동 상태가 될 때의 높이를 결정합니다. | 598
폭 | 팔레트가 부동 상태가 될 때의 폭을 결정합니다. | 172

도구막대의 특성 변경

도구막대는 고정 또는 부동으로 설정할 수 있습니다. 사용자 인터페이스 사용자화 편집기의 작업공간 내용 창에서 특성을 변경하여 도구막대의 크기, 위치 또는 모양을 정의할 수 있습니다.

주 CUI 파일로 작업공간 가져오기

부분적 CUI 파일이 주 CUI 파일에서 로드될지라도 주 CUI 파일은 부분적 CUI 파일의 작업공간을 무시합니다. 사용자 인터페이스 사용자화 편집기의 전송 탭을 사용하여 작업공간을 주 CUI 파일로 가져올 수 있습니다.

기본 작업공간 설정

CUI 파일의 작업공간이 기본값으로 표시될 수 있습니다. 이것은 CUI 파일이 프로그램에 처음 로드될 때 또는 CUI 파일이 CUILOAD 명령으로 로드된 후에 이 파일에서 어떤 작업공간이 복원되어야 하는지를 나타냅니다.

참고

    • 사용자 안내서의 인터페이스 옵션 설정를 참조하십시오.

    • 사용자 인터페이스 사용자화 편집기를 사용하여 작업공간을 작성하려면 (절차)

    • 작업공간 도구막대를 사용하여 작업공간을 작성하려면 (절차)

    • 작업공간의 특성을 변경하려면 (절차)

    • 메뉴 막대의 풀다운 메뉴를 표시하려면 (절차)

    • 메뉴 막대에서 풀다운 메뉴의 위치를 조정하려면 (절차)

    • 도구막대를 표시하려면 (절차)

    • 도구막대의 특성을 변경하려면 (절차)

    • 대시보드 패널을 표시하려면 (절차)

    • 대시보드 윈도우에서 대시보드 패널의 위치를 조정하려면 (절차)

    • 팔레트의 특성을 변경하려면 (절차)

    • 작업공간을 복제하려면 (절차)

    • 작업공간을 현재로 설정하려면 (절차)

    • 작업공간을 기본으로 설정하려면 (절차)

    • 명령행 스위치로 작업공간을 복원하려면 (절차)

    • 작업공간을 주 CUI 파일로 가져오려면 (절차)


작업공간 사용자화 (절차)

AutoLISP 파일 로드
작업공간 사용자화
작업공간 사용자화
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 작업공간 사용자화 >
작업공간 사용자화
개념 절차 요약 참조

사용자 인터페이스 사용자화 편집기를 사용하여 작업공간을 작성하려면

작업공간 도구막대를 사용하여 작업공간을 작성하려면

작업공간의 특성을 변경하려면

메뉴 막대의 풀다운 메뉴를 표시하려면

메뉴 막대에서 풀다운 메뉴의 위치를 조정하려면

도구막대를 표시하려면

도구막대의 특성을 변경하려면

대시보드 패널을 표시하려면

대시보드 윈도우에서 대시보드 패널의 위치를 조정하려면

팔레트의 특성을 변경하려면

작업공간을 복제하려면

작업공간을 현재로 설정하려면

작업공간을 기본으로 설정하려면

명령행 스위치로 작업공간을 복원하려면

작업공간을 주 CUI 파일로 가져오려면


작업공간 사용자화 (절차)

작업공간 사용자화
작업공간 사용자화
작업공간 사용자화
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 작업공간 사용자화 >
작업공간 사용자화
개념 절차 요약 참조

사용자 인터페이스 사용자화 편집기를 사용하여 작업공간을 작성하려면

  1. 도구 메뉴 [image] 사용자화 [image] 인터페이스를 클릭합니다.명령 프롬프트에서 cui를 입력합니다.
  2. 사용자 인터페이스 사용자화 편집기의 사용자화 탭에 있는 <파일 이름>의 사용자화 창에서 작업공간 트리 노드를 마우스 오른쪽 버튼으로 클릭하고 새 작업공간을 선택합니다.

    새로운 빈 작업공간(Workspace1로 명명됨)은 작업공간 트리의 맨 아래에 위치합니다.

  3. 다음 중 하나를 수행합니다.
    • Workspace1 문자 위에 새 이름을 입력합니다.
    • Workspace1을 마우스 오른쪽 버튼으로 클릭합니다. 이름 바꾸기를 클릭합니다. 그런 다음 새 작업공간 이름을 입력합니다.
    • Workspace1을 클릭하고 기다린 다음 작업공간 이름을 다시 클릭하여 이름을 내부 편집합니다.
  4. 작업공간에서 작업공간 사용자화를 클릭합니다.

  5. <파일 이름>의 사용자화 창에서 도구막대 트리 노드, 메뉴 트리 노드 또는 부분적 CUI 파일 트리 노드 옆에 있는 더하기 기호(+)를 클릭하여 확장합니다.
    주이제 메뉴, 도구막대 및 부분적 CUI 파일 노드가 선택 상자를 표시하여 요소를 해당 작업공간으로 쉽게 추가할 수 있습니다.
  6. 작업공간에 추가하려는 각 메뉴, 도구막대 또는 부분적 CUI 파일 옆에 있는 선택 상자를 클릭합니다.

    작업공간 내용 창에서 선택된 요소가 작업공간으로 추가됩니다.

  7. 작업공간 내용 창에서 종료를 클릭합니다.

  8. 확인을 클릭합니다.


작업공간 사용자화 (절차)

작업공간 사용자화
작업공간 사용자화
작업공간 사용자화
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 작업공간 사용자화 >
작업공간 사용자화
개념 절차 요약 참조

작업공간 도구막대를 사용하여 작업공간을 작성하려면

  1. 현재 AutoCAD 인터페이스에 표시된 도구막대를 마우스 오른쪽 버튼으로 클릭합니다.

    바로 가기 메뉴가 도구막대가 속한 사용자화 그룹 아래에 포함되어 있는 이용 가능한 도구막대와 함께 표시됩니다.

  2. 현재 표시되지 않은 경우 도구막대를 표시할 작업공간을 선택합니다.

    확인 표시는 현재 표시된 임의 도구막대의 왼쪽에 표시됩니다.

  3. 도구막대 및 팔레트의 크기, 위치 및 기타 특성에 대해 필요한 사항을 변경합니다.
  4. 작업공간 도구막대에서 다른 이름으로 현재 항목 저장을 선택합니다.

  5. 작업공간 저장 대화상자에서 텍스트 상자에 이름을 입력하거나 드롭다운 리스트에서 덮어쓸 기존 이름을 선택합니다.

  6. 작업공간을 작성하거나 수정하려면 저장을 클릭합니다.
주작업공간 도구막대는 작업공간이 복원될 때 나타납니다. 작업공간 저장 대화상자를 표시하는 데 작업공간 도구막대가 보이지 않는 경우 도구 메뉴 [image] 작업공간 [image] 다른 이름으로 현재 항목 저장을 클릭합니다.작업공간 저장 대화상자를 표시하는 데 작업공간 도구막대가 보이지 않는 경우 명령 프롬프트에서 WSSAVE를 입력합니다.


작업공간 사용자화 (절차)

작업공간 사용자화
작업공간 사용자화
작업공간 사용자화
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 작업공간 사용자화 >
작업공간 사용자화
개념 절차 요약 참조

작업공간의 특성을 변경하려면

  1. 도구 메뉴 [image] 사용자화 [image] 인터페이스를 클릭합니다.명령 프롬프트에서 cui를 입력합니다.
  2. 사용자 인터페이스 사용자화 편집기에서 사용자화 탭을 클릭합니다.
  3. 사용자화 탭의 <파일 이름>의 사용자화 창에서 변경할 특성이 있는 작업공간을 클릭합니다.

  4. 특성 창에서 다음 중 하나를 실행합니다.
    • 이름 상자에 작업공간의 새 이름을 입력합니다.
    • 설명 상자에 설명을 입력합니다.
    • 시작하기 상자에서 옵션(모형, 배치 또는 변경 안함)을 선택합니다.
    • 모형/배치 탭 상자에서 옵션(켜기, 끄기, 변경 안함)을 선택합니다.
    • 화면 메뉴 상자에서 옵션(켜기, 끄기, 변경 안함)을 선택합니다.
    • 스크롤 막대 상자에서 옵션(켜기, 끄기, 변경 안함)을 선택합니다.

  5. 확인을 클릭합니다.


작업공간 사용자화 (절차)

작업공간 사용자화
작업공간 사용자화
작업공간 사용자화
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 작업공간 사용자화 >
작업공간 사용자화
개념 절차 요약 참조

메뉴 막대의 풀다운 메뉴를 표시하려면

  1. 도구 메뉴 [image] 사용자화 [image] 인터페이스를 클릭합니다.명령 프롬프트에서 cui를 입력합니다.
  2. 사용자 인터페이스 사용자화 편집기의 사용자화 탭에 있는 <파일 이름>의 사용자화 창에서 작업공간 노드 옆에 있는 더하기 기호(+)를 클릭하여 확장합니다.
  3. 수정하려는 작업공간을 선택합니다.

  4. 작업공간 내용 창에서 작업공간 사용자화를 클릭합니다.

  5. <파일 이름>의 사용자화 창에서 메뉴 트리 노드 또는 부분적 CUI 파일 트리 노드 옆에 있는 더하기 기호(+)를 클릭하여 확장합니다.
  6. 작업공간에 추가하려는 각 메뉴 또는 부분적 CUI 파일 옆에 있는 선택 상자를 클릭합니다.

    작업공간 내용 창에서 선택된 요소가 작업공간으로 추가됩니다.

  7. 작업공간 내용 창에서 종료를 클릭합니다.

    주변경 사항이 표시되도록 작업공간을 현재로 설정하여야 합니다.
  8. 확인을 클릭합니다.


작업공간 사용자화 (절차)

작업공간 사용자화
작업공간 사용자화
작업공간 사용자화
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 작업공간 사용자화 >
작업공간 사용자화
개념 절차 요약 참조

메뉴 막대에서 풀다운 메뉴의 위치를 조정하려면

  1. 도구 메뉴 [image] 사용자화 [image] 인터페이스를 클릭합니다.명령 프롬프트에서 cui를 입력합니다.
  2. 사용자 인터페이스 사용자화 편집기의 사용자화 탭에 있는 <파일 이름>의 사용자화 창에서 작업공간 노드 옆에 있는 더하기 기호(+)를 클릭하여 확장합니다.
  3. 수정하려는 작업공간을 선택합니다.

  4. 작업공간 내용 창에서 이동하려는 풀다운 메뉴 위를 포인터 버튼으로 클릭하여 누른 상태에서 풀다운 메뉴를 새로운 위치로 끌어옵니다.

    스플리터 막대는 포인터 버튼을 해제할 때 풀다운 메뉴가 이동할 위치를 나타내도록 풀다운 메뉴 사이에 표시됩니다.

  5. 스플리터 막대가 풀다운 메뉴를 삽입하려는 위치에 있게 되면, 포인터 버튼을 해제하여 풀다운 메뉴의 위치를 조정합니다.
    주변경 사항이 표시되도록 작업공간을 현재로 설정하여야 합니다.
  6. 확인을 클릭합니다.


작업공간 사용자화 (절차)

작업공간 사용자화
작업공간 사용자화
작업공간 사용자화
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 작업공간 사용자화 >
작업공간 사용자화
개념 절차 요약 참조

도구막대를 표시하려면

  1. 도구 메뉴 [image] 사용자화 [image] 인터페이스를 클릭합니다.명령 프롬프트에서 cui를 입력합니다.
  2. 사용자 인터페이스 사용자화 편집기의 사용자화 탭에 있는 <파일 이름>의 사용자화 창에서 작업공간 노드 옆에 있는 더하기 기호(+)를 클릭하여 확장합니다.
  3. 수정하려는 작업공간을 선택합니다.

  4. 작업공간 내용 창에서 작업공간 사용자화를 클릭합니다.

  5. <파일 이름>의 사용자화 창에서 도구막대 트리 노드 또는 부분적 CUI 파일 트리 노드 옆에 있는 더하기 기호(+)를 클릭하여 확장합니다.
  6. 작업공간에 추가하려는 각 도구막대 또는 부분적 CUI 파일 옆에 있는 선택 상자를 클릭합니다.

    작업공간 내용 창에서 선택된 요소가 작업공간으로 추가됩니다.

  7. 작업공간 내용 창에서 종료를 클릭합니다.

    주변경 사항이 표시되도록 작업공간을 현재로 설정하여야 합니다.
  8. 확인을 클릭합니다.


작업공간 사용자화 (절차)

작업공간 사용자화
작업공간 사용자화
작업공간 사용자화
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 작업공간 사용자화 >
작업공간 사용자화
개념 절차 요약 참조

도구막대의 특성을 변경하려면

  1. 도구 메뉴 [image] 사용자화 [image] 인터페이스를 클릭합니다.명령 프롬프트에서 cui를 입력합니다.
  2. 사용자 인터페이스 사용자화 편집기의 사용자화 탭에 있는 <파일 이름>의 사용자화 창에서 수정할 도구막대가 포함된 작업공간을 클릭합니다.

  3. 작업공간 내용 창에서 도구막대 옆에 있는 더하기 기호(+)를 클릭하여 리스트를 확장합니다.
  4. 수정하려는 도구막대를 클릭합니다.

  5. 특성 창에서 다음 중 하나를 실행합니다.
    • 방향 상자에서 옵션(부동, 맨 위, 맨 아래, 왼쪽 또는 오른쪽)을 선택합니다.
    • (방향이 부동으로 설정된 경우에만) 기본 X 위치 상자에 숫자를 입력합니다. 숫자가 도구막대가 놓인 왼쪽에서부터 증가하므로 0 값은 화면의 왼쪽 모서리에서 도구막대의 위치를시작합니다.
    • (방향이 부동으로 설정된 경우에만) 기본 Y 위치 상자에 숫자를 입력합니다. 숫자가 도구막대가 놓인 맨 위에서부터 증가하므로 0 값은 화면의 맨 위 모서리에서 도구막대의 위치를시작합니다.
    • (방향이 부동으로 설정된 경우에만) 행 상자에 숫자를 입력합니다. 가능한 경우 도구막대의 버튼이 랩되어 행의 수를 정하는 숫자를 입력합니다. 0이 기본값입니다.

  6. 확인을 클릭합니다.


작업공간 사용자화 (절차)

작업공간 사용자화
작업공간 사용자화
작업공간 사용자화
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 작업공간 사용자화 >
작업공간 사용자화
개념 절차 요약 참조

대시보드 패널을 표시하려면

  1. 도구 메뉴 [image] 사용자화 [image] 인터페이스를 클릭합니다.명령 프롬프트에서 cui를 입력합니다.
  2. 사용자 인터페이스 사용자화 편집기의 사용자화 탭에 있는 <파일 이름>의 사용자화 창에서 작업공간 노드 옆에 있는 더하기 기호(+)를 클릭하여 확장합니다.
  3. 수정하려는 작업공간을 선택합니다.

  4. 작업공간 내용 창에서 작업공간 사용자화를 클릭합니다.

  5. <파일 이름>의 사용자화 창에서 대시보드 패널 트리 노드 또는 부분적 CUI 파일 트리 노드 옆에 있는 더하기 기호(+)를 클릭하여 확장합니다.
  6. 작업공간에 추가하려는 각 대시보드 패널 또는 부분적 CUI 파일 옆에 있는 확인란을 클릭합니다.

    작업공간 내용 창에서 선택된 요소가 작업공간으로 추가됩니다.

  7. 작업공간 내용 창에서 종료를 클릭합니다.

    주변경 사항이 표시되도록 작업공간을 현재로 설정하여야 합니다.
  8. 확인을 클릭합니다.


작업공간 사용자화 (절차)

작업공간 사용자화
작업공간 사용자화
작업공간 사용자화
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 작업공간 사용자화 >
작업공간 사용자화
개념 절차 요약 참조

대시보드 윈도우에서 대시보드 패널의 위치를 조정하려면

  1. 도구 메뉴 [image] 사용자화 [image] 인터페이스를 클릭합니다.명령 프롬프트에서 cui를 입력합니다.
  2. 사용자 인터페이스 사용자화 편집기의 사용자화 탭에 있는 <파일 이름>의 사용자화 창에서 작업공간 노드 옆에 있는 더하기 기호(+)를 클릭하여 확장합니다.
  3. 수정하려는 작업공간을 선택합니다.
  4. 작업공간 컨텐츠 창에서 이동할 대시보드 패널을 포인터 버튼으로 클릭한 채로 있습니다. 대시보드 패널을 새 위치로 끌어놓습니다.

    스플리터 막대는 대시보드 패널의 위치를 나타냅니다.

  5. 스플리터 막대가 대시보드 패널을 삽입하려는 위치에 있게 되면 포인터 버튼을 놓아서 대시보드 패널의 위치를 조정합니다.
    주변경 사항이 표시되도록 작업공간을 현재로 설정해야 합니다.
  6. 확인을 클릭합니다.


작업공간 사용자화 (절차)

작업공간 사용자화
작업공간 사용자화
작업공간 사용자화
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 작업공간 사용자화 >
작업공간 사용자화
개념 절차 요약 참조

팔레트의 특성을 변경하려면

  1. 도구 메뉴 [image] 사용자화 [image] 인터페이스를 클릭합니다.명령 프롬프트에서 cui를 입력합니다.
  2. 사용자 인터페이스 사용자화 편집기의 사용자화 탭에 있는 <파일 이름>의 사용자화 창에서 수정할 팔레트가 포함된 작업공간을 클릭합니다.

  3. 작업공간 컨텐츠 창에서 팔레트 옆에 있는 더하기 기호(+)를 클릭하여 리스트를 확장합니다.
  4. 수정하려는 윈도우를 클릭합니다.

  5. 특성 창에서 다음 중 하나를 실행합니다.
    • 표시 상자에서 옵션(예, 아니오 또는 변경 안함)을 선택합니다.
    • 방향 상자에서 옵션(부동, 맨 위, 맨 아래, 왼쪽 또는 오른쪽)을 선택합니다.
    • 고정 허용 상자에서 옵션(예, 아니오 또는 변경 안함)을 선택합니다.
      주윈도우가 앵커될 것인지, 방향을 왼쪽, 오른쪽, 맨 위 또는 맨 아래로 설정할 것인지, 자동 숨기기를 켜기로 설정할 것인지를 지정하려면
    • 자동 숨기기 상자에서 옵션(켜기, 끄기 또는 변경 안함)을 선택합니다.
    • 투명도 사용 상자에서 옵션(예, 아니오 또는 변경 안함)을 선택합니다.
    • 투명도 양 상자에 숫자를 입력합니다.
    • (도구 팔레트 전용)기본 그룹 상자에서 도구 팔레트 그룹을 선택합니다.
    • 높이 상자에 숫자를 입력합니다. 0(영) 값은 [변경 안함]과 같습니다.
    • 폭 상자에 숫자를 입력합니다. 0(영) 값은 [변경 안함]과 같습니다.

  6. 확인을 클릭합니다.


작업공간 사용자화 (절차)

작업공간 사용자화
작업공간 사용자화
작업공간 사용자화
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 작업공간 사용자화 >
작업공간 사용자화
개념 절차 요약 참조

작업공간을 복제하려면

  1. 도구 메뉴 [image] 사용자화 [image] 인터페이스를 클릭합니다.명령 프롬프트에서 cui를 입력합니다.
  2. 사용자 인터페이스 사용자화 편집기의 사용자화 탭에 있는 <파일 이름>의 사용자화 창에서 작업공간 옆에 있는 더하기 기호(+)를 클릭하여 확장합니다.
  3. 해당 작업공간을 마우스 오른쪽 버튼으로 클릭합니다. 작업 공간 복사를 클릭하십시오.

    중복 작업공간(<작업공간 이름>의 명명된 복사본)은 작업공간 트리의 맨 아래에 위치합니다.

  4. 다음 중 하나를 수행합니다.
    • <작업공간 이름>의 복사본 문자 위에 새로운 이름을 입력합니다.
    • <작업공간 이름>의 복사본을 마우스 오른쪽 버튼으로 클릭합니다. 이름 바꾸기를 클릭합니다. 새 작업공간의 이름을 입력합니다.
    • <작업공간 이름>의 사본을 클릭하고 기다린 다음 작업 공간 이름을 다시 클릭하여 이름을 내부 편집합니다.
  5. 필요에 따라 작업공간을 수정합니다.
  6. 확인을 클릭합니다.


작업공간 사용자화 (절차)

작업공간 사용자화
작업공간 사용자화
작업공간 사용자화
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 작업공간 사용자화 >
작업공간 사용자화
개념 절차 요약 참조

작업공간을 현재로 설정하려면

  1. 도구 메뉴 [image] 사용자화 [image] 인터페이스를 클릭합니다.명령 프롬프트에서 cui를 입력합니다.
  2. 사용자 인터페이스 사용자화 편집기의 사용자화 탭에서 작업공간 옆에 있는 더하기 기호(+)를 클릭하여 확장합니다.
  3. 현재로 설정하려는 작업공간을 마우스 오른쪽 버튼으로 클릭합니다. 현재로 설정을 클릭합니다.

  4. 확인을 클릭합니다.


작업공간 사용자화 (절차)

작업공간 사용자화
작업공간 사용자화
작업공간 사용자화
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 작업공간 사용자화 >
작업공간 사용자화
개념 절차 요약 참조

작업공간을 기본으로 설정하려면

  1. 도구 메뉴 [image] 사용자화 [image] 인터페이스를 클릭합니다.명령 프롬프트에서 cui를 입력합니다.
  2. 사용자 인터페이스 사용자화 편집기의 사용자화 탭에서 작업공간 옆에 있는 더하기 기호(+)를 클릭하여 확장합니다.
  3. 기본값으로 설정하려는 작업공간을 마우스 오른쪽 버튼으로 클릭합니다. 기본값 설정을 클릭합니다.

  4. 확인을 클릭합니다.
주네트워크 배치 마법사에서 주 및 엔터프라이즈 CUI 파일을 지정할 수 있습니다. 주 CUI 파일에 기본 작업공간 세트가 있을 경우 기본 작업공간은 파일이 AutoCAD에 처음 로드될 때 현재 작업공간으로 설정됩니다.


작업공간 사용자화 (절차)

작업공간 사용자화
작업공간 사용자화
작업공간 사용자화
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 작업공간 사용자화 >
작업공간 사용자화
개념 절차 요약 참조

명령행 스위치로 작업공간을 복원하려면

  1. Windows 바탕 화면에서 프로그램 아이콘을 마우스 오른쪽 버튼으로 클릭합니다. 특성을 클릭합니다.

  2. AutoCAD 특성 대화상자의 바로 가기 탭, 대상 상자에서 다음의 구문을 사용한 스위치의 매개변수를 편집합니다.

    “드라이브:경로 이름\acad.exe” [“도면 이름”] [/스위치 “이름”]

    예를 들어, “d:\AutoCAD 2008\acad.exe” /w “MyWorkspace”를 입력합니다.

  3. 확인을 클릭합니다.


작업공간 사용자화 (절차)

작업공간 사용자화
작업공간 사용자화
슬라이드 작성
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 작업공간 사용자화 >
작업공간 사용자화
개념 절차 요약 참조

작업공간을 주 CUI 파일로 가져오려면

  1. 도구 메뉴 [image] 사용자화 [image] 사용자화 가져오기를 클릭합니다.명령 프롬프트에서 cuiimport를 입력합니다.

    사용자화 창(왼쪽)에 표시된 주 CUI 파일과 함께 전송 탭이 표시됩니다.

  2. 전송 탭의 <파일 이름>의 사용자화 창(오른쪽)에서 사용자화 파일 열기 버튼을 클릭합니다.

  3. 열기 대화상자에서 추가하려는 작업공간이 포함된 사용자화 파일을 찾아 선택합니다
  4. 오른쪽 창에서 작업공간을 CUI 파일로부터 주 CUI 파일의 작업공간 노드(왼쪽 창)로 끌어옵니다.

  5. 확인을 클릭합니다.


작업공간 사용자화 (요약 참조)

AutoLISP 파일 로드
작업공간 사용자화
사용자 인터페이스 사용자화 FAQ
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 작업공간 사용자화 >
작업공간 사용자화
개념 절차 요약 참조

명령

CUI

작업공간, 도구막대, 메뉴, 바로 가기 메뉴 및 키보드 바로 가기와 같은 사용자화된 사용자 인터페이스 요소를 관리합니다.

CUIEXPORT

사용자화된 설정을 acad.cui에서 엔터프라이즈 또는 부분적 CUI 파일로 내보냅니다.

CUIIMPORT

사용자화된 설정을 엔터프라이즈 또는 부분적 CUI 파일에서 acad.cui로 가져옵니다.

CUILOAD

CUI 파일 로드

CUIUNLOAD

CUI 파일 언로드

WORKSPACE

작업공간을 작성, 수정 및 저장하고 작업공간을 현재로 만듭니다.

시스템 변수

WSCURRENT

명령행 인터페이스에 현재 작업 영역 이름을 반환하고 작업공간을 현재로 설정합니다

유틸리티

항목이 없습니다.

명령 수정자

항목이 없습니다.


사용자 인터페이스 사용자화 FAQ (개념)

작업공간 사용자화
사용자 인터페이스 사용자화
DIESEL
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 >
사용자 인터페이스 사용자화 FAQ
개념 요약 참조

FAQ는 사용자 인터페이스 사용자화(CUI) 편집기 사용에 관해 가장 자주 묻는 질문에 대한 답을 찾는데 도움이 됩니다.

마이그레션/업그레이드

질문: 새로운 릴리즈에서 작업하기 위해 이전 릴리즈에서 사용자의 메뉴 사용자화 항목을 어떻게 가져옵니까?

대답: 이전 릴리즈에는 메모장과 같은 문자 편집기를 사용해야만 했습니다. CUI 편집기를 이용하면 자신의 메뉴 사용자화를 포함하고 있는 MNS/MNU 또는 CUI 파일을 찾아서 선택하는 전송 탭을 사용할 수 있습니다. 이전 사용자화 파일이 선택되면 두 CUI 파일 간에 사용자 인터페이스 요소를 끌어올 수 있습니다. 자세한 정보는 사용자화를 전송하려면을 참고하십시오.

명령

질문: 어떻게 새로운 명령을 만들고 풀다운 메뉴와 같은 사용자 인터페이스 요소에 추가합니까?

대답: 명령은 CUI 편집기의 사용자화 탭의 아래 왼쪽 구석에 있는 명령 리스트 창을 통해 작성하고 관리합니다. 자세한 정보는 명령을 작성하려면을 참고하십시오.

명령이 작성되면 여러 다른 사용자 인터페이스 요소를 작성하기 위해 이 명령을 추가하거나 사용할 수 있습니다. 예를 들어, 명령을 풀다운 메뉴에 추가하려면 명령을 추가할 <파일 이름>의 사용자화 창에서 메뉴 노드 아래에 있는 메뉴를 확장한 다음 명령을 메뉴 아래로 끌어옵니다. 자세한 정보는 풀다운 메뉴를 작성하려면을 참고하십시오.

풀다운 메뉴

질문: 왜 사용자 풀다운 메뉴가 메뉴 막대에 표시되지 않습니까?

대답: 작업공간은 메뉴 막대의 풀다운 메뉴 표시를 조정하기 위해 사용합니다. 자세한 정보는 메뉴 막대의 풀다운 메뉴를 표시하려면을 참고하십시오.

질문: 풀다운 메뉴의 순서를 어떻게 변경합니까?

대답: 작업공간은 메뉴 막대에서 풀다운 메뉴의 위치를 조정하기 위해 사용합니다. 자세한 정보는 메뉴 막대에서 풀다운 메뉴의 위치를 조정하려면을 참고하십시오.

도구막대

질문: AutoCAD 2008을 닫고 재시작한 후에 왜 사용자 도구막대가 동일한 위치에 있지 않습니까?

대답: 이것은 시작 시 AutoCAD에 메뉴가 로드되는 방식 때문입니다. 이러한 문제는 부분적 및 엔터프라이즈 CUI 파일이 사용될 경우에만 발생합니다. 이러한 문제를 해결하기 위해 새로운 /w 명령행 스위치를 사용할 수 있습니다. 이것은 AutoCAD 2008 시작 시 작업공간을 다시 초기화하도록 하며 도구막대를 올바른 위치에 놓습니다. 자세한 정보는 명령행 스위치로 작업공간을 복원하려면을 참고하십시오.

질문: CUI 편집기의 전송 탭을 이용하여 아이콘을 마이그레이션 한 후에 도구막대에 있는 아이콘이 왜 물음표를 가진 구름 모양으로 나타납니까?

대답: 이것은 AutoCAD 지원 파일 경로에 사용자 아이콘 이미지가 없기 때문입니다. Windows 탐색기를 사용하여 이미지를 찾고 옵션 대화상자의 파일 탭 아래에 있는 지원 파일 검색 경로 노드에 이미지가 있는 위치를 추가하거나, 파일을 C:\Documents and Settings\<사용자 프로파일 이름>\Application Data\Autodesk\<제품 이름>\<릴리즈 번호>\<언어>\Support\Icons 폴더로 복사합니다.

질문: 왜 도구막대 플라이아웃이 작동되지 않습니까?

대답: 몇 가지 이유로 인해 플라이아웃이 작동되지 않을 수 있습니다. 참조 중인 도구막대에 현재 지정된 명령이 없거나 컨트롤이 도구막대 플라이아웃에 대해 참조되고 있는 도구막대의 일부입니다. CUI 편집기를 시작하고 도구막대에서 참조되고 있는 명령이 있는지 확인하며, 명령이 있을 경우 도구막대에 도면층 리스트 컨트롤과 같은 컨트롤이 없는지 확인하십시오.

질문: 도구막대 플라이아웃을 사용하려고 할 때 왜 AutoCAD 메시지 상자가 표시됩니까?

대답: AutoCAD 도구막대 플라이아웃에 대해 참조되고 있는 도구막대가 없기 때문에 메시지 상자가 표시됩니다. AutoCAD는 도구막대를 찾을 수 없습니다. 도구막대가 없거나 포함된 부분적 CUI 파일이 로드되지 않았기 때문에 도구막대가 현재 로드되지 않았거나 도구막대의 별칭이 변경되었기 때문입니다.

CUI 편집기를 시작하고 도구막대에서 현재 제대로 작동하지 않는 플라이아웃을 선택합니다. 특성 창에서 원본 도구막대 특성을 살펴보십시오. 찾기 옵션을 사용하여 작동하지 않는 플라이아웃의 원본 도구막대 특성에서 텍스트 문자열과 일치하는 별칭이 포함된 도구막대 요소를 찾습니다. 도구막대 요소가 없을 경우 도구막대에서 플라이아웃을 제거하고 도구막대에서 플라이아웃으로 참조할 도구막대를 끕니다. CUI 편집기를 닫습니다. 플라이아웃은 다시 한 번 제대로 작동됩니다.

두 번 클릭 동작

질문: 객체를 두 번 클릭하면 아무 것도 발생하지 않습니다. 왜 그럽니까?

대답: 도면에서 객체를 두 번 클릭할 때 아무 것도 발생하지 않는 몇 가지 이유가 있습니다. 첫 번째 가장 일반적인 문제점은 시스템 변수 PICKFIRST가 0으로 설정되었기 때문입니다. 두 번 클릭 편집이 작동되려면 PICKFIRST가 1로 설정되어야 합니다. 그 다음 가능한 해결 방법은 두 번 클릭 편집을 사용 불가능하게 하는 것입니다. 두 번 클릭 편집은 시스템 변수 DBLCLKEDIT에 의해 제어됩니다. 0으로 설정될 경우 현재 꺼져 있습니다. DBLCLKEDIT는 1로 설정되어야 합니다.

작업공간

질문: 왜 적용을 클릭한 후 변경사항이 나타나지 않습니까?

대답: 이것은 변경을 수행한 작업공간이 현재 작업공간이 아니기 때문입니다. 이 문제를 해결하기 위해 작업공간을 현재로 설정하고 변경을 적용하면 변경 사항이 나타납니다. 자세한 정보는 작업공간을 현재로 설정하려면을 참고하십시오.

엔터프라이즈 CUI 파일

질문: 엔터프라이즈 CUI 파일이 CUI 편집기에서 읽기 전용일 때 어떻게 이것을 편집합니까?

대답: 엔터프라이즈 CUI 파일은 주 CUI 파일로 로드되거나 주 CUI 파일에 대한 부분적 CUI 파일로 로드될 경우에만 편집할 수 있습니다. 편집할 필요가 있을 경우에는 주 CUI 파일로 로드하는 것이 좋습니다. 일반적으로 주 CUI 파일로 지정된 CUI 파일로부터 사용자 인터페이스 요소를 포함해야 하는 작업공간을 작성하는 경우 주 CUI 파일을 엔터프라이즈 CUI 파일로 로드합니다. 엔터프라이즈 CUI 파일을 편집합니다. 자세한 정보는 엔터프라이즈 CUI 파일을 수정하려면을 참고하십시오.


사용자 인터페이스 사용자화 FAQ (요약 참조)

작업공간 사용자화
사용자 인터페이스 사용자화 FAQ
MODEMACRO 시스템 변수에 대한 개요
AutoCAD 2008 사용자화 안내서 > 사용자 인터페이스 사용자화 > 사용자 인터페이스 사용자화 FAQ >
사용자 인터페이스 사용자화 FAQ
개념 요약 참조

명령

CUI

작업공간, 도구막대, 메뉴, 바로 가기 메뉴 및 키보드 바로 가기와 같은 사용자화된 사용자 인터페이스 요소를 관리합니다.

CUIEXPORT

사용자화된 설정을 acad.cui에서 엔터프라이즈 또는 부분적 CUI 파일로 내보냅니다.

CUILOAD

CUI 파일 로드

CUIUNLOAD

CUI 파일 언로드

CUIUNLOAD

CUI 파일 언로드

MENU

사용자화 파일 로드

OPTIONS

프로그램 설정값을 사용자화합니다.

QUICKCUI

사용자 인터페이스 사용자화 대화상자를 축소된 상태로 표시합니다.

WORKSPACE

작업공간을 작성, 수정 및 저장하고 작업공간을 현재로 만듭니다.

시스템 변수

ENTERPRISEMENU

파일 이름의 경로를 포함하여 엔터프라이즈 CUI(정의된 경우)에 대한 파일 이름을 표시합니다.

MENUNAME

파일 이름의 경로를 포함하여 사용자화 파일 이름을 저장합니다

WSCURRENT

명령행 인터페이스에 현재 작업 영역 이름을 반환하고 작업공간을 현재로 설정합니다

유틸리티

항목이 없습니다.

명령 수정자

항목이 없습니다.


DIESEL

사용자 인터페이스 사용자화 FAQ
상태 행 사용자화
AutoCAD 2008 사용자화 안내서 >
DIESEL

DIESEL(Direct Interpretively Evaluated String Expression Language)의 표현식은 입력으로 문자열을 받아 결과 문자열을 생성합니다. DIESEL을 메뉴 매크로에 사용하거나 상태 행에 문자를 표시할 수 있습니다.

이 단원의 항목

  • 상태 행 사용자화

    MODEMACRO 시스템 변수를 사용하여 상태 행에 정보를 표시할 수 있습니다.

  • 매크로의 DIESEL 표현식

    사용자화(CUI) 파일에서 DIESEL 문자열 표현식을 매크로를 작성하는 또 다른 방법으로 사용할 수 있습니다.

  • DIESEL 함수 카탈로그

    상태 검색, 계산 및 표시는 DIESEL 함수로 수행합니다. 모든 함수에는 함수 이름 자체를 포함하여 10개의 매개변수만 사용할 수 있습니다. 이 한계를 초과하면 DIESEL 오류 메시지가 나타납니다.

  • DIESEL 오류 메시지

    일반적으로 DIESEL 표현식에서 실수한 경우 잘못된 부분이 분명하게 드러납니다. DIESEL은 오류의 유형에 따라 오류 표시를 출력 스트림에 삽입합니다.


상태 행 사용자화

DIESEL
DIESEL
MODEMACRO 시스템 변수에 대한 개요
AutoCAD 2008 사용자화 안내서 > DIESEL >
상태 행 사용자화

MODEMACRO 시스템 변수를 사용하여 상태 행에 정보를 표시할 수 있습니다.

이 단원의 항목

  • MODEMACRO 시스템 변수에 대한 개요
  • MODEMACRO 값 설정

    문자열과 DIESEL을 사용하여 상태 행의 사용자 정의 구역에 메시지를 표시할 수 있습니다.

  • AutoLISP로 MODEMACRO 설정

    MODEMACRO 값을 설정하는 다른 방법은 AutoLISP를 사용하는 것입니다.


MODEMACRO 시스템 변수에 대한 개요 (개념)

상태 행 사용자화
상태 행 사용자화
MODEMACRO 값 설정
AutoCAD 2008 사용자화 안내서 > DIESEL > 상태 행 사용자화 >
MODEMACRO 시스템 변수에 대한 개요
개념 요약 참조

상태 행은 작업 흐름을 방해하지 않으면서 중요한 정보를 제공합니다. MODEMACRO 시스템 변수는 상태 행의 사용자 정의 영역을 조정합니다. MODEMACRO 시스템 변수의 계산된 값은 AutoCAD® 윈도우 맨 아래에 있는 상태 막대의 왼쪽 정렬된 패널에 표시됩니다. 이 변수는 AutoCAD를 시작할 때 null 문자열로 설정됩니다. 이 변수의 값은 도면, 구성 파일 또는 기타 다른 곳에 저장되지 않습니다.

상태 행에 표시되는 문자 수는 AutoCAD 윈도우 및 모니터 크기에 의해서만 제한됩니다. 기본 패널은 MODEMACRO 패널의 내용이 많아짐에 따라 오른쪽으로 이동합니다. 원하는 경우 기본 패널을 화면에서 완전히 보이지 않게 밀어낼 수도 있습니다.

MODEMACRO 시스템 변수를 사용하여 AutoCAD에 알려진 대부분의 데이터를 상태 행에 표시할 수 있습니다. 이 변수의 계산, 결정 및 편집 기능을 사용하여 상태 행을 사용자의 정밀한 지정에 따라 구성할 수 있습니다.

MODEMACRO는 사용자 문자열 변수입니다. 이 변수는 임의의 문자열 값으로 설정할 수 있습니다. 최대 문자열 값은 4095자입니다. SETVAR을 사용하거나 명령 프롬프트에 modemacro를 입력하여 MODEMACRO를 설정할 수 있습니다. MODEMACRO 설정을 수정하는 경우, 여러 상태 행 형식으로 실험해 볼 수 있지만 이 방식으로 입력할 수 있는 최대 문자는 255자로 제한됩니다.

마침표(.)를 입력하여 MODEMACRO를 null 문자열로 설정하면 AutoCAD는 표준 상태 행을 표시합니다.


MODEMACRO 시스템 변수에 대한 개요 (요약 참조)

사용자 인터페이스 사용자화 FAQ
MODEMACRO 시스템 변수에 대한 개요
MODEMACRO 값 설정
AutoCAD 2008 사용자화 안내서 > DIESEL > 상태 행 사용자화 > MODEMACRO 시스템 변수에 대한 개요 >
MODEMACRO 시스템 변수에 대한 개요
개념 요약 참조

명령

SETVAR

시스템 변수의 값을 나열하거나 변경합니다.

시스템 변수

MODEMACRO

현재 도면의 이름, 시간/날짜 스탬프 또는 특수 모드와 같은 상태 행의 문자열을 표시합니다

유틸리티

항목이 없습니다.

명령 수정자

항목이 없습니다.


MODEMACRO 값 설정 (개념)

MODEMACRO 시스템 변수에 대한 개요
상태 행 사용자화
AutoLISP로 MODEMACRO 설정
AutoCAD 2008 사용자화 안내서 > DIESEL > 상태 행 사용자화 >
MODEMACRO 값 설정
개념 요약 참조

문자열과 DIESEL을 사용하여 상태 행의 사용자 정의 구역에 메시지를 표시할 수 있습니다.

MODEMACRO의 값은 모드 상태 행에 표시되는 내용을 결정합니다. 가장 간단하지만 유용하지 않은 MODEMACRO는 상수 문자로 구성됩니다. 예를 들어, 상태 행에 회사 이름을 표시하려면 다음을 입력하십시오.

명령: modemacro

MODEMACRO의 새 값 또는 없는 경우 . <"">: Greg's Bank and Grill

이 MODEMACRO 값은 항상 동일한 문자를 표시하고, 상태 행은 AutoCAD 내부 상태에 대한 변경 사항을 반영하지 않습니다. 이 값은 사용자가 MODEMACRO를 변경하기 전에는 변경되지 않습니다.

상태 행이 AutoCAD의 현재 상태를 반영하게 하려면 DIESEL 언어를 사용하여 다음 형식으로 매크로 표현식을 입력합니다.

$(somefun, arg1, arg2, ...)

매크로 표현식에서 somefun은 DIESEL 함수(AutoLISP 함수 이름과 유사)의 이름이며 arg1, arg2 등은 함수에 대한 인수로 함수의 정의에 따라 해석됩니다. AutoLISP와 달리 DIESEL 매크로 표현식에는 데이터 형식이 문자열 하나밖에 없습니다. 숫자에 대해 작동하는 매크로는 숫자를 문자열로 표시하고 필요에 따라 숫자를 문자열로 또는 문자열을 숫자로 변환합니다.

DIESEL 함수에 대한 설명은 DIESEL 함수 카탈로그를 참고하십시오.

현재 문자 스타일 이름을 표시하는 것처럼 보다 흥미 있는 상태 행을 정의해 보십시오.

명령: modemacro

MODEMACRO의 새 값 또는 없는 경우 . <"">: Style: $(getvar, textstyle)

  • Style:은 상태 행에 표시될 문자열입니다.
  • $(getvar,textstyle)은 DIESEL 함수(getvar)와 TEXTSTYLE 시스템 변수의 현재 값을 검색하는 인수입니다.
주이 항목의 예제에 MODEMACRO 문자열이 한 행 이상의 문자로 표시될 수 있습니다. 프롬프트에 하나의 긴 문자열로 입력합니다.

$(getvar, varname)을 입력하여 시스템 변수를 검색할 수 있습니다. 시스템 변수의 현재 설정값이 상태 행의 매크로 표현식을 대치합니다. 그런 다음, 문자 스타일을 전환하면 MODEMACRO가 다시 계산됩니다. 변수의 값이 변경되면 새 문자 스타일 이름이 상태 행에 표시됩니다.

표현식은 내포할 수 있으며 원하는 만큼 복잡하게 만들 수 있습니다. 다음 예는 현재 스냅 값과 각도(도 단위)를 상태 행에 표시합니다. 이 예제에서는 내포된 표현식을 사용하여 스냅 각도를 라디안에서 도로 변환하고 끝수를 버리고 값을 정수로 만듭니다.

명령: modemacro

MODEMACRO의 새 값 또는 없는 경우 . <"">: Snap: $(getvar, snapunit) $(fix,$(*,$(getvar,snapang),$(/,180,3.14159)))

또한 현재 선형 및 각도 단위 모드로 값을 표시할 수 있습니다.

명령: modemacro

MODEMACRO의 새 값 또는 없는 경우 . <"">: Snap: $(rtos,$(index,0,

$(getvar,snapunit))),$(rtos,$(index,1,$(getvar,snapunit))) $(angtos,

$(getvar,snapang))

DIESEL은 달러 기호 문자($)나 인용된 문자열이 나올 때까지 입력 내용을 출력에 직접 복사합니다. DIESEL 함수로 해석되는 문자열의 계산을 따옴표 안의 문자열을 사용하여 억제할 수 있습니다. 두 개의 인용 부호를 붙여서 사용하면 인용된 문자열 안에 인용 부호를 포함시킬 수 있습니다. 다음 예제에서 현재 도면층은 LAYOUT로 설정되고 MODEMACRO는 문자열로 설정됩니다.

명령:modemacro

MODEMACRO의 새 값 또는 없는 경우 . <"">: "$(getvar,clayer)= """$(getvar,clayer)""""

상태 행은 다음과 같이 표시됩니다.

$(getvar,clayer)="LAYOUT"


MODEMACRO 값 설정 (요약 참조)

MODEMACRO 시스템 변수에 대한 개요
MODEMACRO 값 설정
AutoLISP로 MODEMACRO 설정
AutoCAD 2008 사용자화 안내서 > DIESEL > 상태 행 사용자화 > MODEMACRO 값 설정 >
MODEMACRO 값 설정
개념 요약 참조

명령

SETVAR

시스템 변수의 값을 나열하거나 변경합니다.

시스템 변수

MODEMACRO

현재 도면의 이름, 시간/날짜 스탬프 또는 특수 모드와 같은 상태 행의 문자열을 표시합니다

유틸리티

항목이 없습니다.

명령 수정자

항목이 없습니다.


AutoLISP로 MODEMACRO 설정 (개념)

MODEMACRO 값 설정
상태 행 사용자화
매크로의 DIESEL 표현식
AutoCAD 2008 사용자화 안내서 > DIESEL > 상태 행 사용자화 >
AutoLISP로 MODEMACRO 설정
개념 요약 참조

MODEMACRO 값을 설정하는 다른 방법은 AutoLISP를 사용하는 것입니다.

여기에 나온 코드 예제를 ASCII 형식 텍스트 파일로 저장하고 AutoLISP의 load 함수를 사용하여 로드할 수 있습니다.

다음 AutoLISP 명령은 내장된 상태 행에 있는 정보와 유사한 정보를 제공하는 MODEMACRO 문자열을 정의합니다. AutoLISP는 행 사이에서 문자열을 연결할 수 없기 때문에 AutoLISP strcat 함수를 사용하여 짧은 구성요소 문자열에서 전체 MODEMACRO 문자열을 구성해야 합니다.

(defun C:ACADMODE ( )
            (setvar "modemacro"
                (strcat
                 "Layer $(substr,$(getvar,clayer),1,8)"
                 "$(if,$(getvar,orthomode), Ortho)"
                 "$(if,$(getvar,snapmode), Snap)"
                 "$(if,$(getvar,tabmode), Tablet)"
                 "$(if,$(=,$(getvar,tilemode),0),"
                   "$(if,$(=,$(getvar,cvport),1), P)"
                 ")"
              )
            )
)

이 AutoLISP 루틴을 acadmode.lsp라는 파일에 저장하십시오. 루틴을 로드한 다음 실행하면 상태 행에 정보가 표시됩니다. 이상은 예제로만 제공될 뿐 이 기능을 가장 유용하게 적용한 경우에는 해당되지 않습니다.

다음 예제 파일 acad.lsp는 S::STARTUP 함수를 사용하여 MODEMACRO 변수를 AutoLISP 파일 mode1.lsp에 정의되어 있는 문자열로 설정합니다.

;;; Sample acad.lsp file that uses S::STARTUP to load the
;;; file MODE1.LSP which defines a MODEMACRO string
(defun S::STARTUP()
            (load "mode1")
            (princ)
)
;;; Additional AutoLISP files can also be defined or
;;; loaded here

AutoLISP 파일(mode1.lsp) 로드 시 MODEMACRO 시스템 변수를 사용하여 L:과 그 뒤에 도면층 이름의 처음 8개 문자, 도면 이름과 경로의 일부 및 현재 활성 모드에 대한 각 이름의 첫 문자로 표시되는 상태 행을 정의합니다. 도면 이름의 위치는 도면층 이름의 길이와 관계없이 변하지 않고 일정합니다.

;;; MODE1.LSP
;;;
(setvar "modemacro"
  (strcat
    "L:$(substr,$(getvar,clayer),1,30)"
    "$(substr, ,1,$(-,30,$(strlen,$(getvar,clayer)))) "
;; ^^^^^^^^ 여기에 공백이 8칸 있습니다.
    "<.."
      "$(if,$(eq,$(getvar,dwgname),UNNAMED),UNNAMED,"
        "$(substr,$(getvar,dwgname),"
          "$(if,$(>,$(strlen,$(getvar,dwgprefix)),29),"
            "$(-,$(strlen,$(getvar,dwgprefix)),29),1"
          "),"
          "$(strlen,$(getvar,dwgname))"
        ")"
      ")"
    ">"
    "$(if,$(getvar,orthomode), O, )"
    "$(if,$(getvar,snapmode), S, )"
    "$(if,$(getvar,tabmode), T, )"
    "$(if,$(and,"
      "$(=,$(getvar,tilemode),0),$(=,$(getvar,cvport),1)),P)"
  )
)

코드를 들여쓰면 AutoLISP 파일과 DIESEL 문자열을 쉽게 읽을 수 있습니다.


AutoLISP로 MODEMACRO 설정 (요약 참조)

MODEMACRO 값 설정
AutoLISP로 MODEMACRO 설정
매크로의 DIESEL 표현식
AutoCAD 2008 사용자화 안내서 > DIESEL > 상태 행 사용자화 > AutoLISP로 MODEMACRO 설정 >
AutoLISP로 MODEMACRO 설정
개념 요약 참조

명령

SETVAR

시스템 변수의 값을 나열하거나 변경합니다.

시스템 변수

MODEMACRO

현재 도면의 이름, 시간/날짜 스탬프 또는 특수 모드와 같은 상태 행의 문자열을 표시합니다

유틸리티

항목이 없습니다.

명령 수정자

항목이 없습니다.


매크로의 DIESEL 표현식 (개념)

AutoLISP로 MODEMACRO 설정
DIESEL
DIESEL 함수 카탈로그
AutoCAD 2008 사용자화 안내서 > DIESEL >
매크로의 DIESEL 표현식
개념 요약 참조

사용자화(CUI) 파일에서 DIESEL 문자열 표현식을 매크로를 작성하는 또 다른 방법으로 사용할 수 있습니다.

이러한 표현식은 표준 AutoCAD 명령, AutoLISP 및 ObjectARX® 루틴, 그리고 기타 메뉴 매크로에 대한 응답으로 문자열 값(문자열)을 반환할 수 있습니다. 또한 문자열 값을 메뉴 자체로 반환하여 메뉴 레이블의 모양이나 내용을 변경할 수 있습니다.

이 문자열은 TILEMODE가 0으로 설정된 경우 도면 공간과 모형 공간 사이를 전환할 수 있는 방법을 제공합니다. 이 표현식은 투명하게 계산됩니다. MENUECHO를 켜고 끄는 특수 문자 ^P는 생략됩니다. 표현식은 실행된 명령만 표시합니다.

메뉴 항목에서 사용하는 DIESEL 표현식은 $섹션=하위 메뉴 형식을 따라야 합니다. 여기에서 섹션 이름은 M이고 하위 메뉴는 원하는 DESEL 표현식입니다. 종종 AutoLISP을 사용해서 쉽게 메뉴 매크로를 구현할 수 있습니다.

다음 예제에서는 같은 결과를 만드는 두 개의 메뉴 항목, 즉 DIESEL을 사용하는 메뉴 항목과 AutoLISP을 사용하는 메뉴 항목을 보여 줍니다.

이 메뉴 항목은 DIESEL 표현식을 사용합니다.

^C^C^P$M=$(if,$(=,$(getvar,cvport),1),mspace,pspace)

이 메뉴 항목은 AutoLISP 표현식을 사용합니다.

^C^C^P(if (= (getvar "cvport") 1)(command "mspace")+
(command "pspace"))(princ) ^P

두 메뉴 항목 모두 도면 공간과 모형 공간 사이를 전환하는 방법을 제공하지만(TILEMODE가 0으로 설정된 경우) DIESEL 표현식이 더 짧고 투명하게 계산되기 때문에 AutoLISP princ 함수를 호출할 필요가 없습니다. 특수 문자 ^P(MENUECH를 켜고 끄는 문자)가 두 가지 표현식에서 생략된 경우 DIESEL 표현식은 실행된 명령만 표시하지만 AutoLISP 표현식은 코드의 전체 행을 표시합니다.

DIESEL 표현식에서 반환한 값이 문자열이기 때문에 AutoLISP의 getxxx 함수 호출에 대한 응답으로 사용될 수 있습니다. 이 기능을 사용하면 메뉴 항목이 현재 도면 조건을 평가하고 AutoLISP 루틴으로 값을 반환합니다.

다음 예제는 이러한 가정을 기반으로 합니다.

  • AutoLISP 루틴이 메모리로 로드됩니다.
  • CUI 인용구가 현재 사용자화 파일에 포함됩니다
  • 삽입할 기호의 크기는 1단위 높이 x 1단위 폭입니다.
  • DIMSCALE 변수는 도면의 축척 비율로 설정됩니다. 즉, 1" = 10'의 축척으로 플롯할 도면의 축척 비율은 120이며, 1/4" = 1' 축척 도면의 축척 비율은 48입니다.

예제 AutoLISP 루틴을 로드해서 실행하는 경우, AutoCAD는 기호를 지정된 크기로 지정 위치에 삽입합니다. 플롯할 때 기호는 지정된 크기가 됩니다(도면이 DIMSCALE에서 지정한 축척으로 플롯되는 경우).

다음은 AutoLISP 루틴 예제입니다.

(defun C:GPath ()
  (setq sym
    (getstring
      "\n기호 이름 입력: ") ; 기호 이름에 대한 프롬프트
  )
  (menucmd "s=symsize") ; 화면 메뉴 변경
                               ; symsize 하위 메뉴로
  (setq
    siz (getreal
      "\nSelect symbol size: ") ; 기호 크기에 대한 프롬프트
    p1 (getpoint
      "\n삽입점: ") ; 삽입점 프롬프트
  )
  (명령 "insert" ; INSERT 명령 실행
    sym ; 원하는 기호 사용
    p1 siz siz 0) ; 삽입점 및 크기
  (menucmd "s=") ; 이전으로 변경
                               ; 화면 메뉴
  (princ) ; 조용히 종료
)
주정기적으로 사용하는 AutoLISP 루틴에는 사용자 입력의 유효성을 검사하는 오류 확인 기능이 포함되어야 합니다.

다음 예제에서 DIESEL 표현식은 DIMSCALE의 현재 값에 지정된 값을 곱하고 적합한 축척 비율을 반환합니다.

이 작업은 유사한 AutoLISP 코드로 수행할 수 없습니다. AutoLISP 표현식에서 반환한 값은 일반적으로 getxxx 함수 호출(예: 앞 예제에서의 getreal 함수)에 대한 응답으로 사용됩니다.

$M=$(*,$(getvar,dimscale),0.375)
$M=$(*,$(getvar,dimscale),0.5)
$M=$(*,$(getvar,dimscale),0.625)

DIESEL 표현식은 또한 메뉴를 사용할 수 없게 만들거나 메뉴 표시 방법을 변경할 수 있도록 문자열 값을 풀다운 메뉴 항목 레이블로 반환할 수 있습니다. 풀다운 메뉴 레이블에서 DIESEL 표현식을 사용하려면 첫 번째 문자가 $ 문자인지 확인하십시오.

다음 예제에서 현재 도면층은 BASE로 설정되고 그 다음의 DIESEL 표현식은 레이블로 사용됩니다.

$(eval,"Current layer: " $(getvar,clayer))

결과적으로 현재 도면층이 변경될 때마다 적절한 풀다운 메뉴가 표시되고 업데이트됩니다.

Current Layer: BASE

이 방법을 사용하여 풀다운 메뉴에 표시되는 문자를 대화식으로 변경할 수도 있습니다. USERS1-5 시스템 변수를 선택한 문자로 설정하는 AutoLISP 루틴을 사용합니다. 이 문자는 메뉴 레이블에서 DIESEL 매크로로 검색할 수 있습니다.

주풀다운 및 바로 가기 메뉴의 폭은 사용자화 파일이 로드될 때 결정됩니다. 메뉴가 로드된 후에 DIESEL 표현식에 의해 생성되거나 변경되는 메뉴 레이블은 기존 메뉴 폭에 맞게 부분적으로 생략됩니다.

DIESEL 생성 메뉴 레이블이 너무 넓을 것이라고 예상되면 다음 예제를 사용하여 메뉴 폭을 레이블 크기에 맞출 수 있습니다. 이 예제는 USERS3(USERS1-5) 시스템 변수의 현재 값에서 처음 10개의 문자를 표시합니다.

$(eval,"Current value: " $(getvar,users3))+
 $(if, $(eq,$(getvar,users3),""), 10 spaces )]^C^Cusers3

메뉴가 로드되는 동안 뒤에 오는 공백이 무시되기 때문에 메뉴 레이블에 후행 공백을 사용하여 메뉴 폭을 늘릴 수 없습니다. 메뉴 레이블의 폭을 늘리는 데 사용되는 공간은 DIESEL 표현식 안에 있어야 합니다.

다음 예제에서는 메뉴 항목의 일부 및 레이블과 동일한 DIESEL 표현식을 사용합니다. 이 표현식은 현재의 요일과 날짜를 도면에 입력하는 실용적인 방법을 제공합니다.

$(edtime,$(getvar,date),DDD", "D MON YYYY)]^C^Ctext +
\\\ $M=$(edtime,$(getvar,date),DDD", "D MON YYYY);

또한 DIESEL 매크로를 사용하여 풀다운 메뉴 레이블을 표시하거나 사용할 수 없도록 만들 수 있습니다. 다음 풀다운 메뉴 레이블은 명령이 활성 상태인 동안 사용할 수 없는 ERASE를 표시합니다. 일반적으로는 명령이 활성 상태가 아닐 때 문자가 표시됩니다.

$(if,$(getvar,cmdactive),~)ERASE

비슷한 접근 방법으로 표식을 풀다운 메뉴 항목 옆에 넣거나 표식에 사용된 문자를 대화식으로 변경할 수 있습니다.


매크로의 DIESEL 표현식 (요약 참조)

AutoLISP로 MODEMACRO 설정
매크로의 DIESEL 표현식
+(더하기)
AutoCAD 2008 사용자화 안내서 > DIESEL > 매크로의 DIESEL 표현식 >
매크로의 DIESEL 표현식
개념 요약 참조

명령

항목이 없습니다.

시스템 변수

MENUECHO

메뉴 반향 및 프롬프트 조정 비트를 설정합니다

USERS1-5

문자열 데이터의 저장 및 가져오기를 제공합니다

유틸리티

항목이 없습니다.

명령 수정자

항목이 없습니다.


DIESEL 함수 카탈로그

매크로의 DIESEL 표현식
DIESEL
+(더하기)
AutoCAD 2008 사용자화 안내서 > DIESEL >
DIESEL 함수 카탈로그

상태 검색, 계산 및 표시는 DIESEL 함수로 수행합니다. 모든 함수에는 함수 이름 자체를 포함하여 10개의 매개변수만 사용할 수 있습니다. 이 한계를 초과하면 DIESEL 오류 메시지가 나타납니다.

이 단원의 항목

  • +(더하기)
  • -(빼기)
  • *(곱하기)
  • /(나누기)
  • =(같음)
  • <(작음)
  • >(큼)
  • !=(같지 않음)
  • <=(작거나 같음)
  • >=(크거나 같음)
  • and
  • angtos
  • edtime
  • eq
  • eval
  • fix
  • getenv
  • getvar
  • if
  • index
  • nth
  • or
  • rtos
  • strlen
  • substr
  • upper
  • xor


+(더하기) (개념)

DIESEL 함수 카탈로그
DIESEL 함수 카탈로그
-(빼기)
AutoCAD 2008 사용자화 안내서 > DIESEL > DIESEL 함수 카탈로그 >
+(더하기)
개념 요약 참조

숫자 val1, val2, …, val9를 합한 결과를 반환합니다.

$(+, val1 [, val2, …, val9])

현재 두께가 5로 설정된 경우 다음 DIESEL 문자열은 15를 반환합니다.

$(+, $(getvar,thickness),10)


+(더하기) (요약 참조)

매크로의 DIESEL 표현식
+(더하기)
-(빼기)
AutoCAD 2008 사용자화 안내서 > DIESEL > DIESEL 함수 카탈로그 > +(더하기) >
+(더하기)
개념 요약 참조

명령

항목이 없습니다.

시스템 변수

MENUECHO

메뉴 반향 및 프롬프트 조정 비트를 설정합니다

유틸리티

항목이 없습니다.

명령 수정자

항목이 없습니다.


-(빼기) (개념)

+(더하기)
DIESEL 함수 카탈로그
*(곱하기)
AutoCAD 2008 사용자화 안내서 > DIESEL > DIESEL 함수 카탈로그 >
-(빼기)
개념 요약 참조

숫자 val2에서 val9를 val1에서 뺀 결과를 반환합니다.

$(+, val1 [, val2, …, val9])


-(빼기) (요약 참조)

+(더하기)
-(빼기)
*(곱하기)
AutoCAD 2008 사용자화 안내서 > DIESEL > DIESEL 함수 카탈로그 > -(빼기) >
-(빼기)
개념 요약 참조

명령

항목이 없습니다.

시스템 변수

MENUECHO

메뉴 반향 및 프롬프트 조정 비트를 설정합니다

유틸리티

항목이 없습니다.

명령 수정자

항목이 없습니다.


*(곱하기) (개념)

-(빼기)
DIESEL 함수 카탈로그
/(나누기)
AutoCAD 2008 사용자화 안내서 > DIESEL > DIESEL 함수 카탈로그 >
*(곱하기)
개념 요약 참조

숫자 val1, val2, …, val9를 곱한 결과를 반환합니다.

$(+, val1 [, val2, …, val9])


*(곱하기) (요약 참조)

-(빼기)
*(곱하기)
/(나누기)
AutoCAD 2008 사용자화 안내서 > DIESEL > DIESEL 함수 카탈로그 > *(곱하기) >
*(곱하기)
개념 요약 참조

명령

항목이 없습니다.

시스템 변수

MENUECHO

메뉴 반향 및 프롬프트 조정 비트를 설정합니다

유틸리티

항목이 없습니다.

명령 수정자

항목이 없습니다.


/(나누기) (개념)

*(곱하기)
DIESEL 함수 카탈로그
=(같음)
AutoCAD 2008 사용자화 안내서 > DIESEL > DIESEL 함수 카탈로그 >
/(나누기)
개념 요약 참조

숫자 val1을 val2, …, val9로 나눈 결과를 반환합니다.

$(+, val1 [, val2, …, val9])


/(나누기) (요약 참조)

*(곱하기)
/(나누기)
=(같음)
AutoCAD 2008 사용자화 안내서 > DIESEL > DIESEL 함수 카탈로그 > /(나누기) >
/(나누기)
개념 요약 참조

명령

항목이 없습니다.

시스템 변수

MENUECHO

메뉴 반향 및 프롬프트 조정 비트를 설정합니다

유틸리티

항목이 없습니다.

명령 수정자

항목이 없습니다.


=(같음) (개념)

/(나누기)
DIESEL 함수 카탈로그
<(작음)
AutoCAD 2008 사용자화 안내서 > DIESEL > DIESEL 함수 카탈로그 >
=(같음)
개념 요약 참조

숫자 val1과 val2가 같으면 문자열이 1을 반환하고, 그렇지 않으면 0을 반환합니다.

$(=, val1, val2)


=(같음) (요약 참조)

/(나누기)
=(같음)
<(작음)
AutoCAD 2008 사용자화 안내서 > DIESEL > DIESEL 함수 카탈로그 > =(같음) >
=(같음)
개념 요약 참조

명령

항목이 없습니다.

시스템 변수

MENUECHO

메뉴 반향 및 프롬프트 조정 비트를 설정합니다

유틸리티

항목이 없습니다.

명령 수정자

항목이 없습니다.


<(작음) (개념)

=(같음)
DIESEL 함수 카탈로그
>(큼)
AutoCAD 2008 사용자화 안내서 > DIESEL > DIESEL 함수 카탈로그 >
<(작음)
개념 요약 참조

숫자 val1이 val2보다 작으면 문자열이 1을 반환하고, 그렇지 않으면 0을 반환합니다.

$(< , val1, val2)

다음 표현식으로 HPANG의 현재 값을 얻습니다. 이 값이 USERR1 시스템 변수에 저장된 값보다 작으면 1을 반환합니다. 10.0 값이 USERR1에 저장되어 있고 HPANG의 현재 설정값이 15.5이면 다음 문자열은 0을 반환합니다.

$(<, $(getvar,hpang),$(getvar,userr1))


<(작음) (요약 참조)

=(같음)
<(작음)
>(큼)
AutoCAD 2008 사용자화 안내서 > DIESEL > DIESEL 함수 카탈로그 > <(작음) >
<(작음)
개념 요약 참조

명령

항목이 없습니다.

시스템 변수

MENUECHO

메뉴 반향 및 프롬프트 조정 비트를 설정합니다

유틸리티

항목이 없습니다.

명령 수정자

항목이 없습니다.


>(큼) (개념)

<(작음)
DIESEL 함수 카탈로그
!=(같지 않음)
AutoCAD 2008 사용자화 안내서 > DIESEL > DIESEL 함수 카탈로그 >
>(큼)
개념 요약 참조

숫자 val1이 val2보다 크면 문자열이 1을 반환하고, 그렇지 않으면 0을 반환합니다.

$(>, val1, val2)


>(큼) (요약 참조)

<(작음)
>(큼)
!=(같지 않음)
AutoCAD 2008 사용자화 안내서 > DIESEL > DIESEL 함수 카탈로그 > >(큼) >
>(큼)
개념 요약 참조

명령

항목이 없습니다.

시스템 변수

MENUECHO

메뉴 반향 및 프롬프트 조정 비트를 설정합니다

유틸리티

항목이 없습니다.

명령 수정자

항목이 없습니다.


!=(같지 않음) (개념)

>(큼)
DIESEL 함수 카탈로그
<=(작거나 같음)
AutoCAD 2008 사용자화 안내서 > DIESEL > DIESEL 함수 카탈로그 >
!=(같지 않음)
개념 요약 참조

숫자 val1과 val2가 같으면 문자열이 1을 반환하고, 같지 않으면 0을 반환합니다.

$(!=, val1, val2)


!=(같지 않음) (요약 참조)

>(큼)
!=(같지 않음)
<=(작거나 같음)
AutoCAD 2008 사용자화 안내서 > DIESEL > DIESEL 함수 카탈로그 > !=(같지 않음) >
!=(같지 않음)
개념 요약 참조

명령

항목이 없습니다.

시스템 변수

MENUECHO

메뉴 반향 및 프롬프트 조정 비트를 설정합니다

유틸리티

항목이 없습니다.

명령 수정자

항목이 없습니다.


<=(작거나 같음) (개념)

!=(같지 않음)
DIESEL 함수 카탈로그
>=(크거나 같음)
AutoCAD 2008 사용자화 안내서 > DIESEL > DIESEL 함수 카탈로그 >
<=(작거나 같음)
개념 요약 참조

숫자 val1이 val2보다 크거나 같으면 문자열이 1을 반환하고 그렇지 않으면 0을 반환합니다.

$(<=, val1, val2)


<=(작거나 같음) (요약 참조)

!=(같지 않음)
<=(작거나 같음)
>=(크거나 같음)
AutoCAD 2008 사용자화 안내서 > DIESEL > DIESEL 함수 카탈로그 > <=(작거나 같음) >
<=(작거나 같음)
개념 요약 참조

명령

항목이 없습니다.

시스템 변수

MENUECHO

메뉴 반향 및 프롬프트 조정 비트를 설정합니다

유틸리티

항목이 없습니다.

명령 수정자

항목이 없습니다.


>=(크거나 같음) (개념)

<=(작거나 같음)
DIESEL 함수 카탈로그
and
AutoCAD 2008 사용자화 안내서 > DIESEL > DIESEL 함수 카탈로그 >
>=(크거나 같음)
개념 요약 참조

숫자 val1이 val2보다 크거나 같으면 문자열이 1을 반환하고 그렇지 않으면 0을 반환합니다.

$(>=, val1, val2)


>=(크거나 같음) (요약 참조)

<=(작거나 같음)
>=(크거나 같음)
and
AutoCAD 2008 사용자화 안내서 > DIESEL > DIESEL 함수 카탈로그 > >=(크거나 같음) >
>=(크거나 같음)
개념 요약 참조

명령

항목이 없습니다.

시스템 변수

MENUECHO

메뉴 반향 및 프롬프트 조정 비트를 설정합니다

유틸리티

항목이 없습니다.

명령 수정자

항목이 없습니다.


and (개념)

>=(크거나 같음)
DIESEL 함수 카탈로그
angtos
AutoCAD 2008 사용자화 안내서 > DIESEL > DIESEL 함수 카탈로그 >
and
개념 요약 참조

val1과 val9 사이의 정수에서 비트와이즈 논리적 AND를 반환합니다.

$(and, val1 [, val2,…, val9])


and (요약 참조)

>=(크거나 같음)
and
angtos
AutoCAD 2008 사용자화 안내서 > DIESEL > DIESEL 함수 카탈로그 > and >
and
개념 요약 참조

명령

항목이 없습니다.

시스템 변수

MENUECHO

메뉴 반향 및 프롬프트 조정 비트를 설정합니다

유틸리티

항목이 없습니다.

명령 수정자

항목이 없습니다.


angtos (개념)

and
DIESEL 함수 카탈로그
edtime
AutoCAD 2008 사용자화 안내서 > DIESEL > DIESEL 함수 카탈로그 >
angtos
개념 요약 참조

지정한 형식과 정밀도로 표시된 각도 값을 반환합니다.

$(angtos, value [, mode, precision])

주어진 value를 유사한 AutoLISP 함수에 대해 정의한 대로 mode 및 precision에서 지정한 형식의 각도로 편집합니다. mode에 대한 값은 다음 표에 나와 있습니다. mode와 precision가 생략되면 UNITS 명령을 사용하여 선택된 현재 값이 사용됩니다.

모드 값 | 문자열 형식
0 | 각도
1 | 도/분/초
2 | 그래드
3 | 라디안
4 | 측량사 단위


angtos (요약 참조)

and
angtos
edtime
AutoCAD 2008 사용자화 안내서 > DIESEL > DIESEL 함수 카탈로그 > angtos >
angtos
개념 요약 참조

명령

항목이 없습니다.

시스템 변수

MENUECHO

메뉴 반향 및 프롬프트 조정 비트를 설정합니다

유틸리티

항목이 없습니다.

명령 수정자

항목이 없습니다.


edtime (개념)

angtos
DIESEL 함수 카탈로그
eq
AutoCAD 2008 사용자화 안내서 > DIESEL > DIESEL 함수 카탈로그 >
edtime
개념 요약 참조

주어진 그림에 따라 형식화된 날짜와 시간을 반환합니다.

$(edtime, time, picture)

time에 따라 부여된 AutoCAD 율리우스력 날짜(예: 주어진 picture에 따라 $(getvar,date)에서 얻음)를 편집합니다). picture는 날짜와 시간에 대한 특정 표현으로 대치되는 형식 구로 이루어집니다. 형식 구로 해석할 수 없는 문자는 글자 그대로 $(edtime)의 결과에 복사됩니다. 형식 구는 다음 표에 표시된 것처럼 정의됩니다. 날짜와 시간은 Saturday, 5 September 1998 4:53:17.506이라고 가정합니다.

형식 | Output | 형식 | Output
D | 5 | H | 4
DD | 05 | HH | 04
DDD | Sat | MM | 53
DDDD | Saturday | SS | 17
M | 9 | MSEC | 506
MO | 09 | AM/PM | AM
MON | Sep | am/pm | am
MONTH | September | A/P | A
YY | 98 | a/p | a
YYYY | 1998 |  |

앞의 표에 표시된 것과 같이 전체 AM/PM 구를 입력합니다. AM만 사용되면 A가 글자 그대로 읽히고 M은 현재 달을 반환합니다.

AM/PM 구가 그림에 나타나면 H 및 HH 구는 24시간 시계(00:00-23:59) 대신 12시간 시계(12:00-12:59 1:00-11:59)에 따라 시간을 편집합니다.

다음 예제에서는 앞의 표에 있는 날짜와 시간을 사용합니다. 쉼표는 인수 구분자로 읽히기 때문에, 쉼표를 사용하려면 인용 부호 안에 넣어야 합니다.

$(edtime, $(getvar,date),DDD"," DD MON YYYY - H:MMam/pm)

다음을 반환합니다.

1998년 9월 5일 토요일 오전 4:53

time이 0이면 맨 끝에 있는 매크로가 실행될 때의 시간과 날짜가 사용됩니다. 그러면 $(getvar,date)에 대해 길고 시간이 오래 걸리는 다중 호출이 방지되고 다중 $(edtime) 매크로로 구성된 문자열이 모두 같은 시간을 사용하게 됩니다.


edtime (요약 참조)

angtos
edtime
eq
AutoCAD 2008 사용자화 안내서 > DIESEL > DIESEL 함수 카탈로그 > edtime >
edtime
개념 요약 참조

명령

항목이 없습니다.

시스템 변수

MENUECHO

메뉴 반향 및 프롬프트 조정 비트를 설정합니다

유틸리티

항목이 없습니다.

명령 수정자

항목이 없습니다.


eq (개념)

edtime
DIESEL 함수 카탈로그
eval
AutoCAD 2008 사용자화 안내서 > DIESEL > DIESEL 함수 카탈로그 >
eq
개념 요약 참조

문자열 val1과 val2가 같으면 문자열이 1을 반환하고 같지 않으면 0을 반환합니다.

$(eq, val1, val2)

다음 표현식으로 현재 도면층의 이름을 얻습니다. 이름이 USERS1(USERS1-5) 시스템 변수에 저장된 문자열 값과 일치하면 1을 반환합니다. 문자열 "PART12"가 USERS1에 저장되어 있고 현재 도면층이 같은 것으로 가정합니다.

$(eq, $(getvar,users1),$(getvar,clayer)) Returns 1


eq (요약 참조)

edtime
eq
eval
AutoCAD 2008 사용자화 안내서 > DIESEL > DIESEL 함수 카탈로그 > eq >
eq
개념 요약 참조

명령

항목이 없습니다.

시스템 변수

MENUECHO

메뉴 반향 및 프롬프트 조정 비트를 설정합니다

유틸리티

항목이 없습니다.

명령 수정자

항목이 없습니다.


eval (개념)

eq
DIESEL 함수 카탈로그
fix
AutoCAD 2008 사용자화 안내서 > DIESEL > DIESEL 함수 카탈로그 >
eval
개념 요약 참조

문자열 str을 DIESEL 계산기로 전달되고 계산 결과를 반환합니다.

$(eval, str)


eval (요약 참조)

eq
eval
fix
AutoCAD 2008 사용자화 안내서 > DIESEL > DIESEL 함수 카탈로그 > eval >
eval
개념 요약 참조

명령

항목이 없습니다.

시스템 변수

MENUECHO

메뉴 반향 및 프롬프트 조정 비트를 설정합니다

유틸리티

항목이 없습니다.

명령 수정자

항목이 없습니다.


fix (개념)

eval
DIESEL 함수 카탈로그
getenv
AutoCAD 2008 사용자화 안내서 > DIESEL > DIESEL 함수 카탈로그 >
fix
개념 요약 참조

실수 value를 끊어 소수 부분을 버리고 정수로 만듭니다.

$(fix, value)


fix (요약 참조)

eval
fix
getenv
AutoCAD 2008 사용자화 안내서 > DIESEL > DIESEL 함수 카탈로그 > fix >
fix
개념 요약 참조

명령

항목이 없습니다.

시스템 변수

MENUECHO

메뉴 반향 및 프롬프트 조정 비트를 설정합니다

유틸리티

항목이 없습니다.

명령 수정자

항목이 없습니다.


getenv (개념)

fix
DIESEL 함수 카탈로그
getvar
AutoCAD 2008 사용자화 안내서 > DIESEL > DIESEL 함수 카탈로그 >
getenv
개념 요약 참조

환경 변수 varname의 값을 반환합니다.

$(getenv, varname)

해당 이름의 변수가 정의되어 있지 않으면 빈 문자열을 반환합니다.


getenv (요약 참조)

fix
getenv
getvar
AutoCAD 2008 사용자화 안내서 > DIESEL > DIESEL 함수 카탈로그 > getenv >
getenv
개념 요약 참조

명령

항목이 없습니다.

시스템 변수

MENUECHO

메뉴 반향 및 프롬프트 조정 비트를 설정합니다

유틸리티

항목이 없습니다.

명령 수정자

항목이 없습니다.


getvar (개념)

getenv
DIESEL 함수 카탈로그
if
AutoCAD 2008 사용자화 안내서 > DIESEL > DIESEL 함수 카탈로그 >
getvar
개념 요약 참조

주어진 varname을 사용하여 환경 변수 값을 반환합니다.

$(getvar, varname)


getvar (요약 참조)

getenv
getvar
if
AutoCAD 2008 사용자화 안내서 > DIESEL > DIESEL 함수 카탈로그 > getvar >
getvar
개념 요약 참조

명령

항목이 없습니다.

시스템 변수

MENUECHO

메뉴 반향 및 프롬프트 조정 비트를 설정합니다

유틸리티

항목이 없습니다.

명령 수정자

항목이 없습니다.


if (개념)

getvar
DIESEL 함수 카탈로그
index
AutoCAD 2008 사용자화 안내서 > DIESEL > DIESEL 함수 카탈로그 >
if
개념 요약 참조

표현식을 조건부로 계산합니다.

$(if, expr, dotrue [, dofalse])

expr가 0이 아닌 경우 계산하여 dotrue를 반환합니다. 0인 경우 계산하여 dofalse를 반환합니다. expr에 의해 선택되지 않은 분기는 계산되지 않습니다.


if (요약 참조)

getvar
if
index
AutoCAD 2008 사용자화 안내서 > DIESEL > DIESEL 함수 카탈로그 > if >
if
개념 요약 참조

명령

항목이 없습니다.

시스템 변수

MENUECHO

메뉴 반향 및 프롬프트 조정 비트를 설정합니다

유틸리티

항목이 없습니다.

명령 수정자

항목이 없습니다.


index (개념)

if
DIESEL 함수 카탈로그
nth
AutoCAD 2008 사용자화 안내서 > DIESEL > DIESEL 함수 카탈로그 >
index
개념 요약 참조

쉼표 구분 문자열로 된 지정된 구성원을 반환합니다.

$(index, which, string)

string 인수에 매크로 인수 구분 문자, 즉 쉼표로 구분되는 값이 하나 이상 있다고 가정합니다. which 인수는 추출된 값 중에서 하나를 선택하는 데, 첫 번째 항목 번호는 0입니다. 이 함수는 $(getvar)에서 반환한 점 좌표에서 X, Y 또는 Z 좌표를 계산하는 데 가장 빈번하게 사용됩니다.

응용프로그램은 이 함수를 사용하여 USERS1-5 시스템 변수에서 쉼표 구분 문자열로 저장된 값을 검색할 수 있습니다.


index (요약 참조)

if
index
nth
AutoCAD 2008 사용자화 안내서 > DIESEL > DIESEL 함수 카탈로그 > index >
index
개념 요약 참조

명령

항목이 없습니다.

시스템 변수

MENUECHO

메뉴 반향 및 프롬프트 조정 비트를 설정합니다

유틸리티

항목이 없습니다.

명령 수정자

항목이 없습니다.


nth (개념)

index
DIESEL 함수 카탈로그
or
AutoCAD 2008 사용자화 안내서 > DIESEL > DIESEL 함수 카탈로그 >
nth
개념 요약 참조

which에 의해 선택된 인수를 계산하고 반환합니다.

$(nth, which, arg0 [, arg1,…, arg7])

which가 0이면 nth는 arg0을 반환하는 방식입니다. $(nth)와 $(index)의 차이점에 주의하십시오. $(nth)은 일련의 인수 중 하나를 함수에 반환하지만 $(index)는 단일 인수로 전달된 쉼표 구분 문자열에서 값을 추출합니다. which에서 선택되지 않은 인수는 계산되지 않습니다.


nth (요약 참조)

index
nth
or
AutoCAD 2008 사용자화 안내서 > DIESEL > DIESEL 함수 카탈로그 > nth >
nth
개념 요약 참조

명령

항목이 없습니다.

시스템 변수

MENUECHO

메뉴 반향 및 프롬프트 조정 비트를 설정합니다

유틸리티

항목이 없습니다.

명령 수정자

항목이 없습니다.


or (개념)

nth
DIESEL 함수 카탈로그
rtos
AutoCAD 2008 사용자화 안내서 > DIESEL > DIESEL 함수 카탈로그 >
or
개념 요약 참조

val1과 val9사이의 정수에서 비트와이즈 논리적 OR을 반환합니다.

$(and, val1 [, val2,…, val9])


or (요약 참조)

nth
or
rtos
AutoCAD 2008 사용자화 안내서 > DIESEL > DIESEL 함수 카탈로그 > or >
or
개념 요약 참조

명령

항목이 없습니다.

시스템 변수

MENUECHO

메뉴 반향 및 프롬프트 조정 비트를 설정합니다

유틸리티

항목이 없습니다.

명령 수정자

항목이 없습니다.


rtos (개념)

or
DIESEL 함수 카탈로그
strlen
AutoCAD 2008 사용자화 안내서 > DIESEL > DIESEL 함수 카탈로그 >
rtos
개념 요약 참조

지정된 형식과 정밀도로 표시된 실수 값을 반환합니다.

$(rtos, value [, mode, precision])

주어진 value를 유사한 AutoLISP 함수에서 정의한 대로 mode 및 precision에서 지정한 형식의 실수로 편집합니다. 모드와 정밀도가 생략되면 UNITS 명령을 사용하여 선택된 현재 값이 사용됩니다.

주어진 value를 mode 및 precision에서 지정한 형식의 실수로 편집합니다.mode와 precision이 생략되면 UNITS 명령을 사용하여 선택된 현재 값이 사용됩니다.


rtos (요약 참조)

or
rtos
strlen
AutoCAD 2008 사용자화 안내서 > DIESEL > DIESEL 함수 카탈로그 > rtos >
rtos
개념 요약 참조

명령

항목이 없습니다.

시스템 변수

MENUECHO

메뉴 반향 및 프롬프트 조정 비트를 설정합니다

유틸리티

항목이 없습니다.

명령 수정자

항목이 없습니다.


strlen (개념)

rtos
DIESEL 함수 카탈로그
substr
AutoCAD 2008 사용자화 안내서 > DIESEL > DIESEL 함수 카탈로그 >
strlen
개념 요약 참조

string의 길이를 반환합니다.

$(strlen, string)


strlen (요약 참조)

rtos
strlen
substr
AutoCAD 2008 사용자화 안내서 > DIESEL > DIESEL 함수 카탈로그 > strlen >
strlen
개념 요약 참조

명령

항목이 없습니다.

시스템 변수

MENUECHO

메뉴 반향 및 프롬프트 조정 비트를 설정합니다

유틸리티

항목이 없습니다.

명령 수정자

항목이 없습니다.


substr (개념)

strlen
DIESEL 함수 카탈로그
upper
AutoCAD 2008 사용자화 안내서 > DIESEL > DIESEL 함수 카탈로그 >
substr
개념 요약 참조

문자 start에서 시작하고 length 문자로 연장하는 string의 하위 문자열을 반환합니다.

$(substr, string, start [, length])

문자열의 문자는 1부터 번호가 매겨집니다. length가 생략되면 문자열의 남아있는 전체 길이를 반환합니다.


substr (요약 참조)

strlen
substr
upper
AutoCAD 2008 사용자화 안내서 > DIESEL > DIESEL 함수 카탈로그 > substr >
substr
개념 요약 참조

명령

항목이 없습니다.

시스템 변수

MENUECHO

메뉴 반향 및 프롬프트 조정 비트를 설정합니다

유틸리티

항목이 없습니다.

명령 수정자

항목이 없습니다.


upper (개념)

substr
DIESEL 함수 카탈로그
xor
AutoCAD 2008 사용자화 안내서 > DIESEL > DIESEL 함수 카탈로그 >
upper
개념 요약 참조

현재 로케일의 규칙에 따라 대문자로 변환된 string을 반환합니다.

$(upper, string)


upper (요약 참조)

substr
upper
xor
AutoCAD 2008 사용자화 안내서 > DIESEL > DIESEL 함수 카탈로그 > upper >
upper
개념 요약 참조

명령

항목이 없습니다.

시스템 변수

MENUECHO

메뉴 반향 및 프롬프트 조정 비트를 설정합니다

유틸리티

항목이 없습니다.

명령 수정자

항목이 없습니다.


xor (개념)

upper
DIESEL 함수 카탈로그
DIESEL 오류 메시지
AutoCAD 2008 사용자화 안내서 > DIESEL > DIESEL 함수 카탈로그 >
xor
개념 요약 참조

val1과 val9 사이의 정수에서 비트와이즈 논리적 XOR을 반환합니다.

$(and, val1 [, val2,…, val9])


xor (요약 참조)

upper
xor
DIESEL 오류 메시지
AutoCAD 2008 사용자화 안내서 > DIESEL > DIESEL 함수 카탈로그 > xor >
xor
개념 요약 참조

명령

항목이 없습니다.

시스템 변수

MENUECHO

메뉴 반향 및 프롬프트 조정 비트를 설정합니다

유틸리티

항목이 없습니다.

명령 수정자

항목이 없습니다.


DIESEL 오류 메시지 (개념)

xor
DIESEL
슬라이드 및 명령 스크립트
AutoCAD 2008 사용자화 안내서 > DIESEL >
DIESEL 오류 메시지
개념 요약 참조

일반적으로 DIESEL 표현식에서 실수한 경우 잘못된 부분이 분명하게 드러납니다. DIESEL은 오류의 유형에 따라 오류 표시를 출력 스트림에 삽입합니다.

오류 메시지 | 설명
$? | 구문 오류(보통 오른쪽 괄호 누락 또는 런어웨이 문자열)
$(func,??) | func에 인수가 부적합함
$(func)?? | 알 수 없는 함수 func
$(++) | 출력 문자열이 너무 김—끝수 잘림


DIESEL 오류 메시지 (요약 참조)

xor
DIESEL 오류 메시지
슬라이드의 개요
AutoCAD 2008 사용자화 안내서 > DIESEL > DIESEL 오류 메시지 >
DIESEL 오류 메시지
개념 요약 참조

명령

항목이 없습니다.

시스템 변수

MENUECHO

메뉴 반향 및 프롬프트 조정 비트를 설정합니다

유틸리티

항목이 없습니다.

명령 수정자

항목이 없습니다.


슬라이드 및 명령 스크립트

DIESEL 오류 메시지
슬라이드 작성
AutoCAD 2008 사용자화 안내서 >
슬라이드 및 명령 스크립트

슬라이드는 여러 가지 방법으로 사용할 수 있는 도면 파일의 스냅샷입니다. 스크립트는 텍스트 파일에서 명령을 읽어와 실행합니다. 스크립트를 사용하는 방법 중 하나는 슬라이드 쇼를 작성하는 것입니다.

이 단원의 항목

  • 슬라이드 작성

    슬라이드는 도면 파일의 스냅샷입니다. 프리젠테이션을 제공하거나 사용자 이미지 배열 메뉴를 작성하거나 작업 중에 다른 도면의 이미지를 볼 때 슬라이드를 사용할 수 있습니다.

  • 명령 스크립트 작성

    스크립트는 일련의 명령들이 포함되어 있는 텍스트 파일입니다. 주로 시작을 사용자화하고 슬라이드 쇼를 실행할 때 스크립트를 사용합니다.


슬라이드 작성

슬라이드 및 명령 스크립트
슬라이드 및 명령 스크립트
슬라이드의 개요
AutoCAD 2008 사용자화 안내서 > 슬라이드 및 명령 스크립트 >
슬라이드 작성
개념 절차

슬라이드는 도면 파일의 스냅샷입니다. 프리젠테이션을 제공하거나 사용자 이미지 배열 메뉴를 작성하거나 작업 중에 다른 도면의 이미지를 볼 때 슬라이드를 사용할 수 있습니다.

이 단원의 항목

  • 슬라이드의 개요

    슬라이드는 도면의 스냅샷입니다. 주어진 어느 순간에 도면 그림이 포함되더라도 이것이 도면 파일은 아닙니다.

  • 슬라이드 보기

    VSLIDE를 사용하여 슬라이드를 하나씩 볼 수 있습니다. 프리젠테이션을 위해 일련의 슬라이드를 보려면 스크립트 파일을 사용하십시오.

  • 슬라이드 라이브러리 작성 및 보기

    슬라이드 라이브러리는 하나 이상의 슬라이드가 포함된 파일입니다. 슬라이드 라이브러리 파일은 사용자 이미지 배열 메뉴를 작성하는 데 사용되거나 편리한 파일 관리를 위해 여러 슬라이드 파일을 결합하는 데 사용됩니다.


슬라이드 작성 (절차)

작업공간 사용자화
슬라이드 작성
슬라이드의 개요
AutoCAD 2008 사용자화 안내서 > 슬라이드 및 명령 스크립트 > 슬라이드 작성 >
슬라이드 작성
개념 절차

슬라이드를 만들려면

슬라이드를 보려면

슬라이드 라이브러리를 작성하려면

슬라이드 라이브러리의 슬라이드를 보려면


슬라이드의 개요 (개념)

슬라이드 작성
슬라이드 작성
슬라이드 보기
AutoCAD 2008 사용자화 안내서 > 슬라이드 및 명령 스크립트 > 슬라이드 작성 >
슬라이드의 개요
개념 절차 요약 참조

슬라이드는 도면의 스냅샷입니다. 주어진 어느 순간에 도면 그림이 포함되더라도 이것이 도면 파일은 아닙니다.

슬라이드 파일은 현재 도면에 가져올 수 없으며 슬라이드를 편집하거나 인쇄할 수도 없습니다. 슬라이드는 보는 것만 가능합니다.

다음과 같은 용도로 슬라이드를 사용할 수 있습니다.

  • AutoCAD® 내에서 프리젠테이션 만들기
  • 다른 도면에 대한 작업을 하면서 도면의 스냅샷 보기
  • 대화상자 내에서 이미지 배열 메뉴 작성

현재 뷰를 슬라이드 형식으로 저장하여 슬라이드를 작성할 수 있습니다. 모형 공간에서 작성된 슬라이드에는 현재 뷰포트만 표시됩니다. 도면 공간에서 작성된 슬라이드에는 보이는 모든 뷰포트와 그 내용이 표시됩니다. 슬라이드에는 보이는 내용만 표시됩니다. 꺼지거나 동결된 도면층의 객체 또는 꺼진 뷰포트의 객체는 슬라이드에 표시되지 않습니다.

슬라이드 파일을 볼 때 임시로 화면의 객체가 슬라이드 파일로 바뀝니다. 해당 뷰 위에 그릴 수 있지만, 다시 그리거나 초점이동하거나 줌 확대/축소하여 뷰를 변경하면 슬라이드 파일이 사라지고 AutoCAD는 사용자가 그린 객체와 사전 존재하는 객체만 다시 표시합니다.

슬라이드를 하나씩 표시하거나, 스크립트를 사용하여 슬라이드를 순서대로 표시할 수 있습니다. 사용자 메뉴에서도 슬라이드를 사용할 수 있습니다. 예를 들어, 자주 사용하는 기계 부품이 포함된 블록을 삽입한 스크립트를 작성하는 경우, 각 부품의 슬라이드를 표시하는 사용자 이미지 배열 메뉴를 설계할 수 있습니다. 메뉴에서 슬라이드 이미지를 클릭하면 AutoCAD가 블록을 도면에 삽입합니다.

슬라이드 라이브러리는 하나 이상의 슬라이드가 포함된 파일입니다. 슬라이드 라이브러리 파일은 사용자 이미지 배열 메뉴를 작성하는 데 사용되거나 편리한 파일 관리를 위해 여러 슬라이드 파일을 결합하는 데 사용됩니다.

슬라이드를 편집할 수는 없습니다. 원본 도면을 변경하고 슬라이드를 다시 만들어야 합니다. 슬라이드 파일을 작성할 때 저해상도 그래픽 모니터를 사용하고 나중에 고해상도 모니터로 업그레이드해도 여전히 슬라이드를 볼 수 있습니다. AutoCAD는 상황에 따라 이미지를 조정하지만, 원본 도면에서 슬라이드 파일을 다시 만들 때까지 슬라이드는 새 모니터를 완전히 이용하지 않습니다.


슬라이드의 개요 (절차)

슬라이드 작성
상위 단계로
슬라이드 보기
AutoCAD 2008 사용자화 안내서 > 슬라이드 및 명령 스크립트 > 슬라이드 작성 > 슬라이드의 개요 >
슬라이드의 개요
개념 절차 요약 참조

슬라이드를 만들려면

  1. 슬라이드에 사용할 뷰를 표시합니다.
  2. 명령 프롬프트에 mslide를 입력합니다.
  3. 슬라이드 파일 작성 대화상자에서 슬라이드의 이름을 입력하고 슬라이드 위치를 선택합니다.

    AutoCAD는 도면의 현재 이름을 슬라이드의 기본 이름으로 제공하고 .sld 파일 확장자를 자동으로 추가합니다.

  4. [저장]을 클릭합니다.

    현재 도면은 화면에 그대로 있고 지정한 폴더에 슬라이드 파일이 저장됩니다.


슬라이드의 개요 (요약 참조)

DIESEL 오류 메시지
슬라이드의 개요
슬라이드 보기
AutoCAD 2008 사용자화 안내서 > 슬라이드 및 명령 스크립트 > 슬라이드 작성 > 슬라이드의 개요 >
슬라이드의 개요
개념 절차 요약 참조

명령

MSLIDE

현재 모형 뷰포트 또는 현재 배치의 슬라이드 파일을 작성합니다.

REDRAW

현재 뷰포트의 화면표시를 갱신합니다.

VSLIDE

현재 뷰포트에 이미지 슬라이드 파일을 표시합니다.

시스템 변수

FILEDIA

파일 검색 대화상자의 표시를 억제합니다

유틸리티

SLIDELIB

ASCII 파일에 나열된 슬라이드 파일을 슬라이드 라이브러리 파일로 컴파일함

명령 수정자

항목이 없습니다.


슬라이드 보기 (개념)

슬라이드의 개요
슬라이드 작성
슬라이드 라이브러리 작성 및 보기
AutoCAD 2008 사용자화 안내서 > 슬라이드 및 명령 스크립트 > 슬라이드 작성 >
슬라이드 보기
개념 절차 요약 참조

VSLIDE를 사용하여 슬라이드를 하나씩 볼 수 있습니다. 프리젠테이션을 위해 일련의 슬라이드를 보려면 스크립트 파일을 사용하십시오.

일반적인 도면처럼 보이는 슬라이드를 보고 편집 명령을 사용할 때는 주의해야 합니다. 편집 명령은 슬라이드의 바탕이 되는 현재 도면에 영향을 주며 슬라이드 자체에는 영향을 주지 않습니다.

일부 명령은 도면이 다시 그려지게 할 수도 있도 있으며 이로 인해 화면에서 슬라이드가 제거됩니다.


슬라이드 보기 (절차)

슬라이드의 개요
상위 단계로
슬라이드 라이브러리 작성 및 보기
AutoCAD 2008 사용자화 안내서 > 슬라이드 및 명령 스크립트 > 슬라이드 작성 > 슬라이드 보기 >
슬라이드 보기
개념 절차 요약 참조

슬라이드를 보려면

  1. 명령 프롬프트에서 vslide를 입력합니다.
  2. 슬라이드 파일 선택 대화상자에서 보려는 슬라이드를 선택한 다음 [확인]을 클릭합니다.

    슬라이드 이미지가 도면 영역에 표시됩니다.

  3. 뷰 메뉴 [image] 다시 그리기를 클릭합니다.명령 프롬프트에서 redrawall을 입력합니다.

    슬라이드 이미지가 사라집니다.


슬라이드 보기 (요약 참조)

슬라이드의 개요
슬라이드 보기
슬라이드 라이브러리 작성 및 보기
AutoCAD 2008 사용자화 안내서 > 슬라이드 및 명령 스크립트 > 슬라이드 작성 > 슬라이드 보기 >
슬라이드 보기
개념 절차 요약 참조

명령

REDRAW

현재 뷰포트의 화면표시를 갱신합니다.

VSLIDE

현재 뷰포트에 이미지 슬라이드 파일을 표시합니다.

시스템 변수

항목이 없습니다.

유틸리티

항목이 없습니다.

명령 수정자

항목이 없습니다.


슬라이드 라이브러리 작성 및 보기 (개념)

슬라이드 보기
슬라이드 작성
명령 스크립트 작성
AutoCAD 2008 사용자화 안내서 > 슬라이드 및 명령 스크립트 > 슬라이드 작성 >
슬라이드 라이브러리 작성 및 보기
개념 절차 요약 참조

슬라이드 라이브러리는 하나 이상의 슬라이드가 포함된 파일입니다. 슬라이드 라이브러리 파일은 사용자 이미지 배열 메뉴를 작성하는 데 사용되거나 편리한 파일 관리를 위해 여러 슬라이드 파일을 결합하는 데 사용됩니다.

SLIDELIB 유틸리티를 사용하여 슬라이드 파일에서 슬라이드 라이브러리를 작성할 수 있습니다. 슬라이드 라이브러리를 설정하고 나면 슬라이드 라이브러리 이름과 슬라이드를 지정하여 슬라이드를 볼 수 있습니다.

슬라이드 라이브러리를 작성한 후에 원본 슬라이드를 삭제하지 마십시오. 슬라이드 라이브러리가 작성되고 나면 SLIDELIB 유틸리티를 사용하여 슬라이드 라이브러리를 업데이트할 수 없습니다. 슬라이드를 추가하거나 삭제하려면 슬라이드 리스트 파일을 업데이트하고 SLIDELIB를 사용하여 라이브러리를 다시 만듭니다. 슬라이드 라이브러리를 다시 만들 때 포함시키려는 모든 슬라이드 파일이 사용 가능해야 합니다.


슬라이드 라이브러리 작성 및 보기 (절차)

슬라이드 보기
상위 단계로
슬라이드 라이브러리 작성 및 보기
AutoCAD 2008 사용자화 안내서 > 슬라이드 및 명령 스크립트 > 슬라이드 작성 > 슬라이드 라이브러리 작성 및 보기 >
슬라이드 라이브러리 작성 및 보기
개념 절차 요약 참조

슬라이드 라이브러리를 작성하려면

슬라이드 라이브러리의 슬라이드를 보려면


슬라이드 라이브러리 작성 및 보기 (절차)

슬라이드 라이브러리 작성 및 보기
상위 단계로
슬라이드 라이브러리 작성 및 보기
AutoCAD 2008 사용자화 안내서 > 슬라이드 및 명령 스크립트 > 슬라이드 작성 > 슬라이드 라이브러리 작성 및 보기 >
슬라이드 라이브러리 작성 및 보기
개념 절차 요약 참조

슬라이드 라이브러리를 작성하려면

  1. Windows ASCII 문자 편집기를 사용하여 라이브러리에 포함시킬 슬라이드 파일의 리스트를 작성합니다. 파일은 다음 예제와 비슷한 형태입니다.

    entrance.sld

    hall.sld

    stairs.sld

    study.sld

    balcony.sld

  2. 파일 확장명이 .txt인 텍스트 파일로 파일 이름을 지정하고 저장합니다.
  3. 시작 메뉴(Windows) [image] 모든 프로그램(또는 프로그램) [image] 보조프로그램 [image] 명령 프롬프트를 클릭합니다.
  4. 명령 프롬프트 윈도우의 프롬프트에서 폴더를 변경할 CD <슬라이드의 폴더 위치>를 입력합니다.

    예를 들어: CD "c:\slides"입니다.

  5. 프롬프트에서 다음 구문을 입력하여 슬라이드 라이브러리를 작성합니다.

    slidelib라이브러리 이름< list.txt

    예를 들어, 텍스트 파일의 이름을 areas.txt로 지정한 경우 slidelib house<areas.txt를 입력하여 house.slb라는 라이브러리를 작성할 수 있습니다. SLIDELIB 유틸리티가 슬라이드 라이브러리 파일에 파일 확장자 .slb를 추가합니다.


슬라이드 라이브러리 작성 및 보기 (절차)

슬라이드 라이브러리 작성 및 보기
상위 단계로
명령 스크립트 작성
AutoCAD 2008 사용자화 안내서 > 슬라이드 및 명령 스크립트 > 슬라이드 작성 > 슬라이드 라이브러리 작성 및 보기 >
슬라이드 라이브러리 작성 및 보기
개념 절차 요약 참조

슬라이드 라이브러리의 슬라이드를 보려면

  1. 명령 프롬프트에서 filedia를 입력합니다.
  2. 0을 입력하고 ENTER 키를 누릅니다.
  3. 명령 프롬프트에서 vslide를 입력합니다.
  4. library(slidename)을 입력하여 슬라이드를 지정합니다.

    예를 들어, house 슬라이드 라이브러리 파일에 저장되어 있는 balcony 슬라이드를 열려면 house(balcony)를 입력합니다.

  5. 표시에서 슬라이드를 제거하려면 뷰 메뉴 [image] 다시 그리기를 클릭합니다.표시에서 슬라이드를 제거하려면 명령 프롬프트에서 redrawall을 입력합니다.


슬라이드 라이브러리 작성 및 보기 (요약 참조)

슬라이드 보기
슬라이드 라이브러리 작성 및 보기
명령 스크립트의 개요
AutoCAD 2008 사용자화 안내서 > 슬라이드 및 명령 스크립트 > 슬라이드 작성 > 슬라이드 라이브러리 작성 및 보기 >
슬라이드 라이브러리 작성 및 보기
개념 절차 요약 참조

명령

MSLIDE

현재 모형 뷰포트 또는 현재 배치의 슬라이드 파일을 작성합니다.

REDRAW

현재 뷰포트의 화면표시를 갱신합니다.

VSLIDE

현재 뷰포트에 이미지 슬라이드 파일을 표시합니다.

시스템 변수

항목이 없습니다.

유틸리티

SLIDELIB

ASCII 파일에 나열된 슬라이드 파일을 슬라이드 라이브러리 파일로 컴파일함

명령 수정자

항목이 없습니다.


명령 스크립트 작성

슬라이드 라이브러리 작성 및 보기
슬라이드 및 명령 스크립트
명령 스크립트의 개요
AutoCAD 2008 사용자화 안내서 > 슬라이드 및 명령 스크립트 >
명령 스크립트 작성
개념 절차

스크립트는 일련의 명령들이 포함되어 있는 텍스트 파일입니다. 주로 시작을 사용자화하고 슬라이드 쇼를 실행할 때 스크립트를 사용합니다.

이 단원의 항목

  • 명령 스크립트의 개요
  • 시작 시 스크립트 실행

    시작 시 실행할 수 있는 스크립트는 도면을 열고 도면의 설정을 변경할 수 있습니다.

  • 스크립트로 슬라이드 쇼 실행

    스크립트는 슬라이드 쇼를 작성하는 데 유용합니다.


명령 스크립트 작성 (절차)

슬라이드 라이브러리 작성 및 보기
명령 스크립트 작성
명령 스크립트의 개요
AutoCAD 2008 사용자화 안내서 > 슬라이드 및 명령 스크립트 > 명령 스크립트 작성 >
명령 스크립트 작성
개념 절차

도면에서 설정을 변경하는 스크립트를 작성하려면

시작 시 스크립트를 실행하려면

스크립트로 슬라이드 쇼를 실행하려면

슬라이드를 미리 로드하는 스크립트를 작성하려면


명령 스크립트의 개요 (개념)

명령 스크립트 작성
명령 스크립트 작성
시작 시 스크립트 실행
AutoCAD 2008 사용자화 안내서 > 슬라이드 및 명령 스크립트 > 명령 스크립트 작성 >
명령 스크립트의 개요
개념 절차 요약 참조

스트립트는 각 행마다 하나의 명령이 있는 텍스트 파일입니다.

시작 시 스크립트를 호출하거나, SCRIPT 명령을 사용하여 작업 세션 중에 스크립트를 실행할 수 있습니다. 또한 스크립트는 제품 데모나 전시회에서 연속적으로 실행되는 화면을 쉽게 만드는 방법을 제공합니다.

스크립트가 다중 작업을 플롯하려면 BACKGROUNDPLOT 시스템 변수를 0으로 설정해야 합니다.

Microsoft® Windows® 메모장과 같은 문자 편집기 또는 ASCII 형식으로 파일을 저장할 수 있는 Microsoft Word와 같은 워드 프로세서를 사용하여 프로그램 외부에서 스크립트 파일을 작성합니다. 파일 확장명은 .scr이여야 합니다.

스크립트 파일의 각 행에 명령이 하나씩 포함됩니다. SPACEBAR는 명령 또는 데이터 필드 종결자로 승인되므로 스크립트 파일에서 각 공백은 중요합니다. 스크립트 파일에서 적절한 응답 순서를 제공하려면 프롬프트 순서를 잘 알고 있어야 합니다.

주프롬프트 및 명령 이름은 이후 릴리즈에서 변경될 수 있으므로, 이 프로그램의 이후 버전으로 업그레이드할 때 스크립트를 수정해야 할 수 있음을 염두에 두십시오. 이와 비슷한 이유로 축약어를 사용하지 말도록 하십시오. 나중에 명령이 추가되면 모호해 질 수 있기 때문입니다.

스크립트는 대화상자가 표시되는 명령을 제외한 모든 명령을 명령 프롬프트에서 실행할 수 있습니다. 대부분의 경우 대화상자를 표시하는 명령은 대화상자 대신 명령 프롬프트를 표시하는 다른 버전의 명령을 갖습니다.

스크립트 파일에는 주석이 포함될 수 있습니다. 세미콜론(;)으로 시작하는 행은 주석으로 간주되고, 스크립트 파일을 처리하는 중에 이 행은 무시됩니다. 파일의 마지막 행은 비어 있어야 합니다.

공백이 포함된 긴 파일 이름을 가리킬 때는 큰따옴표로 묶어야 합니다. 예를 들어, 스크립트에서 my house.dwg 도면을 열려면 다음 구문을 사용해야 합니다.

open "my house"

다음 명령은 스크립트에서 유용하게 사용할 수 있습니다.

'DELAY

스크립트 내에서 일정 시간 동안 일시 중지되게 하는 기능을 제공합니다(밀리초 단위).

'GRAPHSCR

문자 윈도우에서 도면 영역으로 전환합니다.

RESUME

중단된 스크립트를 계속합니다.

RSCRIPT

스크립트 파일을 반복합니다.

'TEXTSCR

문자 윈도우로 전환합니다.

스크립트에서 명령 입력을 제공할 때 PICKADD 및 PICKAUTO 시스템 변수의 설정은 각각 1과 0인 것으로 간주되므로 이들 변수의 설정을 확인할 필요가 없습니다.

스크립트는 단일 U 명령으로 되돌릴 수 있는 명령 단위인 그룹으로 취급됩니다. 그러나 스크립트의 각 명령마다 명령 취소 로그에 항목을 생성하기 때문에 스크립트 처리 속도가 느려질 수 있습니다. 원한다면 [UNDO 컨트롤 없음]을 사용하여 스크립트를 실행하기 전에 명령 취소 기능을 끄거나, 스크립트 시작 부분에 이 항목을 쓸 수 있습니다. 스크립트가 완료되면 UNDO 모두 컨트롤을 사용하여 다시 켜십시오.

실행 중인 스크립트는 다른 스크립트 명령이 호출되면 중지됩니다.


명령 스크립트의 개요 (절차)

명령 스크립트 작성
상위 단계로
시작 시 스크립트 실행
AutoCAD 2008 사용자화 안내서 > 슬라이드 및 명령 스크립트 > 명령 스크립트 작성 > 명령 스크립트의 개요 >
명령 스크립트의 개요
개념 절차 요약 참조

이 스크립트는 모눈을 켜고 전역 선종류 축척을 3.0으로 설정하고 도면층 0을 색상이 빨간색인 현재 도면층으로 설정합니다.

도면에서 설정을 변경하는 스크립트를 작성하려면

  1. 문자 편집기에서 grid on을 입력합니다.
  2. 다음 행에 ltscale 3.0을 입력합니다.
  3. 다음 행에 layer set 0 color red 0을 입력합니다.
  4. 빈 행을 추가합니다.
  5. 파일을 확장명이 .scr인 ASCII 텍스트(TXT 파일)로 저장합니다.

    스크립트 파일에는 다음과 같이 주석이 포함될 수 있습니다.

; Turn grid on
grid on
; Set scale for linetypes
ltscale 3.0
; Set current layer and its color
layer set 0 color red 0
; Blank line above to end LAYER command


명령 스크립트의 개요 (요약 참조)

슬라이드 라이브러리 작성 및 보기
명령 스크립트의 개요
시작 시 스크립트 실행
AutoCAD 2008 사용자화 안내서 > 슬라이드 및 명령 스크립트 > 명령 스크립트 작성 > 명령 스크립트의 개요 >
명령 스크립트의 개요
개념 절차 요약 참조

명령

DELAY

스크립트에서 일정 시간 동안 일시 중지되게 하는 기능을 제공합니다.

GRAPHSCR

문자 윈도우에서 도면 영역으로 전환합니다.

RESUME

중단된 스크립트를 계속합니다.

RSCRIPT

스크립트 파일을 반복합니다.

SCRIPT

스크립트 파일로 일련의 명령을 실행합니다.

TEXTSCR

문자 윈도우를 엽니다.

VSLIDE

현재 뷰포트에 이미지 슬라이드 파일을 표시합니다.

시스템 변수

항목이 없습니다.

유틸리티

항목이 없습니다.

명령 수정자

항목이 없습니다.


시작 시 스크립트 실행 (개념)

명령 스크립트의 개요
명령 스크립트 작성
스크립트로 슬라이드 쇼 실행
AutoCAD 2008 사용자화 안내서 > 슬라이드 및 명령 스크립트 > 명령 스크립트 작성 >
시작 시 스크립트 실행
개념 절차 요약 참조

시작 시 실행할 수 있는 스크립트는 도면을 열고 도면의 설정을 변경할 수 있습니다.

새로운 도면을 시작할 때마다 모눈을 켜고 전역 선종류 축척을 3.0으로 설정하고 도면층 0을 색상이 빨간색인 현재 도면층으로 설정한다고 가정해 보십시오. 도면 템플릿을 사용하여 설정할 수 있지만, 다음 스크립트를 사용하는 대신 이러한 값을 설정한 다음 setup.scr라는 텍스트 파일에 저장할 수 있습니다.

grid on
ltscale 3.0
layer set 0 color red 0

첫 번째 행은 모눈을 켭니다. 두 번째 행은 전역 선종류 축척을 설정합니다. 세 번째 행은 현재 도면층을 도면층 0으로 설정하고 도면층의 기본 색상을 빨간색으로 설정합니다. AutoCAD는 스크립트에서 대화상자 버전이 아닌 LAYER 명령 버전을 사용하는 것으로 가정합니다. 명령 프롬프트에서 -layer를 입력하는 것과 결과가 같습니다. 네 번째 행은 공백이며 LAYER로 끝납니다.

주시작 시 실행되는 VBA 및 AutoLISP® 스크립트에서 AutoCAD 프로세스의 표시 여부를 확인해야 합니다. 프로세스가 보이지 않을 경우 프로세스는 배경 플롯 또는 게시 작업을 수행하는 중이므로 스크립트를 실행해서는 안됩니다. AutoCAD 프로세스의 표시 여부를 확인하려면 AutoCAD 객체 모형에서 응용프로그램 객체의 표시 특성을 사용할 수 있습니다.

실행 대화상자에서 다음 구문을 사용하면 시작 시 스크립트를 실행하여 도면을 열 수 있습니다.

ACAD drawing_name /b setup

공백이 포함된 파일 이름은 모두 “guest house”처럼 큰따옴표로 묶어야 합니다. /v 스위치와 뷰 이름을 사용하여 도면을 열 때 표시할 뷰를 지정할 수도 있습니다. /b 스위치와 스크립트 파일은 표시되는 마지막 매개변수여야 합니다.

파일 확장명 .exe, .dwg, .dwt 및 .scr을 선택적으로 포함할 수 있습니다. AutoCAD가 스크립트 파일을 찾을 수 없는 경우 AutoCAD는 파일을 열수 없다고 보고합니다.

시작할 때 같은 스크립트를 실행하되, MyTemplate.dwt 파일을 템플릿으로 사용하여 새 도면을 작성하려면 실행 대화상자에서 다음과 같이 입력합니다.

ACAD /t MyTemplate /b setup

이 명령은 새 도면을 작성하고 setup.scr 파일로부터 일련의 설정 명령을 실행합니다. 스크립트의 실행이 끝나면 명령 프롬프트가 표시됩니다. 새 도면에 기본 템플릿을 사용하려는 경우에는 /t 스위치와 템플릿 파일 이름을 생략할 수 있습니다.

주이제 이 방법을 사용하여 새 도면을 시작하고 이름을 지정할 수 없습니다. 도면을 저장할 때 도면의 이름을 지정합니다.


시작 시 스크립트 실행 (절차)

명령 스크립트의 개요
상위 단계로
스크립트로 슬라이드 쇼 실행
AutoCAD 2008 사용자화 안내서 > 슬라이드 및 명령 스크립트 > 명령 스크립트 작성 > 시작 시 스크립트 실행 >
시작 시 스크립트 실행
개념 절차 요약 참조

시작 시 스크립트를 실행하려면

  1. 시작 메뉴(Windows) [image] 실행을 클릭합니다.
  2. 실행 대화상자에서 acaddrawing_name /b script_name 을 입력합니다.

    도면 파일 이름 대신 새 파일을 시작하려면 /t 스위치와 템플릿 파일의 이름을 입력합니다(/t template_drawing).

    특정 뷰로 도면 파일을 열려면 도면 이름 뒤에 /v 스위치와 뷰의 이름을 입력합니다(/v view_name).

    스크립트 파일의 이름은 표시되는 마지막 매개변수여야 합니다. 파일 확장명은 선택 사항입니다.

  3. [확인]을 클릭합니다.

    AutoCAD는 도면을 열고 스크립트 파일에서 명령을 실행합니다. 스크립트가 완료되면 명령 프롬프트가 표시됩니다.


시작 시 스크립트 실행 (요약 참조)

명령 스크립트의 개요
시작 시 스크립트 실행
스크립트로 슬라이드 쇼 실행
AutoCAD 2008 사용자화 안내서 > 슬라이드 및 명령 스크립트 > 명령 스크립트 작성 > 시작 시 스크립트 실행 >
시작 시 스크립트 실행
개념 절차 요약 참조

명령

항목이 없습니다.

시스템 변수

항목이 없습니다.

유틸리티

항목이 없습니다.

명령 수정자

항목이 없습니다.


스크립트로 슬라이드 쇼 실행 (개념)

시작 시 스크립트 실행
명령 스크립트 작성
프로그래밍 인터페이스 소개
AutoCAD 2008 사용자화 안내서 > 슬라이드 및 명령 스크립트 > 명령 스크립트 작성 >
스크립트로 슬라이드 쇼 실행
개념 절차 요약 참조

스크립트는 슬라이드 쇼를 작성하는 데 유용합니다.

스크립트는 슬라이드 쇼를 작성하는 데 유용합니다. 보통 슬라이드를 표시할 수 있는 속도는 AutoCAD가 슬라이드 파일을 읽기 위해 디스크에 접근해야 하는 횟수에 의해 제한됩니다. 그러나 청중이 현재 슬라이드를 보는 동안 다음 슬라이드를 메모리에 미리 로드한 다음, 메모리에 있던 새로운 슬라이드를 신속하게 표시할 수 있습니다.

슬라이드를 미리 로드하려면 VSLIDE의 파일 이름 앞에 별표를 넣습니다. 그러면 다음에 실행되는 VSLIDE 명령이 슬라이드가 미리 로드되었음을 탐지하고 파일 이름을 묻지 않고 슬라이드를 표시합니다.

다음 슬라이드를 로드할 때의 디스크 접근 시점이 현재 슬라이드를 보는 시점과 겹칩니다. DELAY 명령으로 추가 지연 시간을 지정할 수 있습니다. 각 지연 시간 단위는 1밀리초입니다.

반복되는 스크립트를 중지하려면 Esc 키를 누릅니다. RESUME으로 스크립트를 계속 실행할 수 있습니다.

장시간 스크립트를 실행할 경우 [UNDO 컨트롤 없음]을 사용하여 명령 취소 로그 파일을 끄는 것이 좋습니다.


스크립트로 슬라이드 쇼 실행 (절차)

시작 시 스크립트 실행
상위 단계로
스크립트로 슬라이드 쇼 실행
AutoCAD 2008 사용자화 안내서 > 슬라이드 및 명령 스크립트 > 명령 스크립트 작성 > 스크립트로 슬라이드 쇼 실행 >
스크립트로 슬라이드 쇼 실행
개념 절차 요약 참조

스크립트로 슬라이드 쇼를 실행하려면

슬라이드를 미리 로드하는 스크립트를 작성하려면


스크립트로 슬라이드 쇼 실행 (절차)

스크립트로 슬라이드 쇼 실행
상위 단계로
스크립트로 슬라이드 쇼 실행
AutoCAD 2008 사용자화 안내서 > 슬라이드 및 명령 스크립트 > 명령 스크립트 작성 > 스크립트로 슬라이드 쇼 실행 >
스크립트로 슬라이드 쇼 실행
개념 절차 요약 참조

스크립트로 슬라이드 쇼를 실행하려면

  1. 슬라이드 라이브러리를 작성하려면 에 설명되어 있는 대로 슬라이드 라이브러리 파일을 작성합니다.
  2. 슬라이드를 미리 로드하는 스크립트를 작성하려면에서와 같이 ASCII 문자 편집기를 사용하여 스크립트 파일을 작성합니다.
  3. 명령 프롬프트에서 script를 입력합니다.
  4. 스크립트 파일 선택 대화상자에서 스크립트 파일을 선택하고 [열기]를 클릭합니다.


스크립트로 슬라이드 쇼 실행 (절차)

스크립트로 슬라이드 쇼 실행
상위 단계로
쉐이프 파일의 개요
AutoCAD 2008 사용자화 안내서 > 슬라이드 및 명령 스크립트 > 명령 스크립트 작성 > 스크립트로 슬라이드 쇼 실행 >
스크립트로 슬라이드 쇼 실행
개념 절차 요약 참조

슬라이드를 미리 로드하는 스크립트를 작성하려면

3개의 슬라이드(slide1.sld, slide2.sld 및 slide3.sld 파일)를 표시하는 이 스크립트 예제에서는 디스크 드라이브에 접근하여 다음 슬라이드를 메모리에 로드하는 데 걸리는 시간이 현재 슬라이드를 보는 시간과 겹칩니다.

  1. 스크립트의 첫 번째 행에 vslide slide1을 입력합니다.

    첫 번째 행은 슬라이드 쇼를 시작하고 slide1을 로드합니다.

  2. 두 번째 행에 vslide *slide2를 입력합니다.

    두 번째 행의 슬라이드 이름 앞에 오는 별표(*)로 인해 slide2가 미리 로드됩니다.

  3. 세 번째 행에 delay 2000을 입력합니다.

    세 번째 행은 청중이 slide1을 볼 수 있도록 2000밀리초 동안의 지연 시간을 지정합니다.

  4. 네 번째 행에 vslide를 입력합니다. 다섯 번째 행에 vslide *slide3를 입력합니다. 여섯 번째 행에 delay 2000을 입력합니다.

    네 번째, 다섯 번째, 여섯 번째 행은 slide2를 표시하고 slide3를 미리 로드하고 slide2를 보기 위한 지연 시간을 지정합니다.

  5. 일곱 번째 행에 vslide를 입력합니다. 여덟 번째 행에 delay 3000을 입력합니다.

    일곱 번째와 여덟 번째 행은 slide3를 표시하고 slide3를 보기 위한 지연 시간을 지정합니다.

  6. 마지막 행에 rscript를 입력하여 스크립트를 반복합니다.
  7. 반복되는 스크립트를 중지하려면 Esc 키를 누릅니다. 스크립트를 계속하려면 resume을 입력합니다.

    스크립트에는 다음과 같이 주석이 포함될 수 있습니다.

; Begin slide show, load SLIDE1
VSLIDE SLIDE1
; Preload SLIDE2
VSLIDE *SLIDE2
; Let audience view SLIDE1
DELAY 2000
; Display SLIDE2
VSLIDE
; Preload SLIDE3
VSLIDE *SLIDE3
; Let audience view SLIDE2
DELAY 2000
; Display SLIDE3
VSLIDE
; Let audience view SLIDE3
DELAY 3000
; Cycle
RSCRIPT


스크립트로 슬라이드 쇼 실행 (요약 참조)

시작 시 스크립트 실행
스크립트로 슬라이드 쇼 실행
ActiveX의 개요
AutoCAD 2008 사용자화 안내서 > 슬라이드 및 명령 스크립트 > 명령 스크립트 작성 > 스크립트로 슬라이드 쇼 실행 >
스크립트로 슬라이드 쇼 실행
개념 절차 요약 참조

명령

DELAY

스크립트에서 일정 시간 동안 일시 중지되게 하는 기능을 제공합니다.

GRAPHSCR

문자 윈도우에서 도면 영역으로 전환합니다.

RESUME

중단된 스크립트를 계속합니다.

RSCRIPT

스크립트 파일을 반복합니다.

SCRIPT

스크립트 파일로 일련의 명령을 실행합니다.

TEXTSCR

문자 윈도우를 엽니다.

VSLIDE

현재 뷰포트에 이미지 슬라이드 파일을 표시합니다.

시스템 변수

항목이 없습니다.

유틸리티

항목이 없습니다.

명령 수정자

항목이 없습니다.


프로그래밍 인터페이스 소개

스크립트로 슬라이드 쇼 실행
ActiveX Automation
AutoCAD 2008 사용자화 안내서 >
프로그래밍 인터페이스 소개

AutoCAD는 명령 프롬프트 및 메뉴 인터페이스뿐만 아니라 도면과 데이터베이스를 제어하는 데 사용할 수 있는 응용프로그램 프로그래밍 인터페이스(API)도 제공합니다. 응용프로그램 요구사항 및 프로그래밍 경험에 따라 사용할 인터페이스 유형을 결정하게 됩니다.

여기서 소개되는 프로그래밍 인터페이스는 ActiveX® Automation, VBA(Visual Basic® for Applications), AutoLISP®, Visual LISP™ , ObjectARX™ 및 .NET입니다. 응용프로그램 요구사항 및 프로그래밍 경험에 따라 사용할 인터페이스 유형을 결정하게 됩니다.

이 단원의 항목

  • ActiveX Automation

    ActiveX Automation은 Microsoft®에서 개발한 기술로서 COM(Component Object Model) 아키텍처를 기반으로 합니다. ActiveX Automation을 사용하여 AutoCAD를 사용자화하고 다른 응용프로그램과 도면 데이터를 공유하고 작업을 자동화할 수 있습니다.

  • AutoCAD VBA

    Microsoft Visual Basic for Applications(VBA)는 풍부한 개발 기능을 제공하도록 설계된 객체 기반 프로그래밍 환경입니다. VBA와 VB(Visual Basic 6)의 주요한 차이는 VBA는 AutoCAD와 동일한 프로세스 공간에서 실행되므로 AutoCAD의 지능적이고 매우 신속한 프로그래밍 환경을 제공한다는 점입니다.

  • AutoLISP 및 Visual LISP

    AutoLISP은 배우기 쉽고 아주 강력한 기능의 LISP 프로그래밍 언어를 기반으로 합니다. AutoCAD에는 내장 LISP 번역기가 있어 명령 프롬프트에 AutoLISP 코드를 입력하거나 외부 파일로부터 AutoLISP 코드를 로드할 수 있습니다. Visual LISP(VLISP)은 AutoLISP 프로그램 개발을 돕기 위해 만들어진 소프트웨어 도구입니다.

  • ObjectARX

    ObjectARX 기술은 지능적 객체 데이터를 공유하기 위한 응용프로그램 설계의 기초를 제공합니다. 외부 ObjectARX 응용프로그램을 실행하거나 사용자 자신의 프로그램을 작성할 수 있습니다.

  • .NET

    Microsoft .NET Framework를 사용하면 VB. NET나 C# 등의 프로그래밍 언어를 통해 AutoCAD와 상호작용하는 응용프로그램을 작성할 수 있습니다.


ActiveX Automation

프로그래밍 인터페이스 소개
프로그래밍 인터페이스 소개
ActiveX의 개요
AutoCAD 2008 사용자화 안내서 > 프로그래밍 인터페이스 소개 >
ActiveX Automation

ActiveX Automation은 Microsoft®에서 개발한 기술로서 COM(Component Object Model) 아키텍처를 기반으로 합니다. ActiveX Automation을 사용하여 AutoCAD를 사용자화하고 다른 응용프로그램과 도면 데이터를 공유하고 작업을 자동화할 수 있습니다.

이 단원의 항목

  • ActiveX의 개요

    응용프로그램의 종류에 관계없이 Automation 컨트롤러 역할을 하는 응용프로그램으로 AutoCAD 객체를 작성하고 조정할 수 있습니다. 따라서 Automation을 사용하면 AutoLISP에는 없는 기능인 응용프로그램 간의 매크로 프로그래밍이 가능합니다.

  • 응용프로그램을 시작하기 위한 명령 정의

    acad.pgp 파일을 사용하여 응용프로그램을 시작하기 위한 외부 명령을 실행하는 새 AutoCAD 명령을 정의할 수 있습니다.

  • 메뉴 또는 도구막대에서 응용프로그램 시작

    응용프로그램을 시작하는 새로운 명령을 정의한 후 그 명령을 메뉴 또는 도구막대에서 사용 가능하게 할 수 있습니다.


ActiveX의 개요 (개념)

ActiveX Automation
ActiveX Automation
응용프로그램을 시작하기 위한 명령 정의
AutoCAD 2008 사용자화 안내서 > 프로그래밍 인터페이스 소개 > ActiveX Automation >
ActiveX의 개요
개념 요약 참조

응용프로그램의 종류에 관계없이 Automation 컨트롤러 역할을 하는 응용프로그램으로 AutoCAD 객체를 작성하고 조정할 수 있습니다. 따라서 Automation을 사용하면 AutoLISP에는 없는 기능인 응용프로그램 간의 매크로 프로그래밍이 가능합니다.

AutoCAD는 Automation을 통해 AutoCAD 객체 모형에 의해 설명된 프로그래밍 가능 객체를 나타냅니다. 이러한 객체는 다른 응용프로그램에서 작성, 편집 및 조정이 가능합니다. AutoCAD 객체 모형에 접근할 수 있는 응용프로그램은 Automation 컨트롤러이고, Automation을 사용하여 다른 응용프로그램을 조정하는 데 가장 많이 사용되는 도구는 VBA(Visual Basic for Applications)입니다. VBA는 수많은 Microsoft Office 응용프로그램에서 구성요소로 사용됩니다. 이러한 응용프로그램 또는 다른 Automation 컨트롤러(예: Visual Basic, .NET 및 Delphi)를 사용하여 AutoCAD를 실행할 수 있습니다.

AutoCAD용 ActiveX 인터페이스를 구현하면 다음 두 가지 이점을 얻을 수 있습니다.

  • AutoCAD 도면에 대한 프로그래밍 접근 방식이 보다 많은 프로그래밍 환경에 개방되어 있습니다. ActiveX Automation 이전에는 개발자가 AutoLISP 또는 C++ 인터페이스로 제한되었습니다.
  • Microsoft Excel이나 Microsoft Word와 같은 다른 Windows 응용프로그램과 훨씬 쉽게 데이터를 공유할 수 있습니다.

예를 들어, 입력 프롬프트를 표시하거나 기본 설정을 설정하거나 선택 세트를 작성하거나 도면 데이터 검색 등의 작업을 해야 할 수 있습니다. 작업 유형에 따라 사용할 컨트롤러를 결정합니다.

Automation을 사용하면 응용프로그램의 종류에 관계없이 Automation 컨트롤러 역할을 하는 응용프로그램으로 AutoCAD 객체를 작성하고 조정할 수 있습니다. 따라서 Automation을 사용하면 AutoLISP에는 없는 기능인 응용프로그램 간의 매크로 프로그래밍이 가능합니다. Automation을 사용하여 여러 응용프로그램의 기능을 하나의 응용프로그램으로 통합할 수 있습니다.

표시되는 객체를 Automation 객체라고 합니다. Automation 객체는 메서드, 속성 및 이벤트를 사용 가능한 상태로 만듭니다 메서드는 객체에 대한 동작을 수행하는 함수입니다. 속성은 객체 상태에 대한 정보를 설정하거나 반환하는 함수입니다. 이벤트는 프로그램이 응답할 사용자 초기화 동작 또는 사건입니다.

사실상 종류에 관계없이 응용프로그램을 사용하여 AutoCAD 내에서 표시되는 Automation 객체에 접근할 수 있습니다. 이러한 응용프로그램은 독립 실행형 파일과 DLL(동적 연결 라이브러리) 파일, 그리고 Microsoft Word나 Microsoft Excel과 같은 응용프로그램 내의 매크로일 수 있습니다. 이 중 가장 일반적인 형태는 독립 실행형 파일입니다. 응용프로그램 개발업체의 응용프로그램을 사용할 경우에는 해당 개발업체의 지침에 따라 응용프로그램을 설치 및 사용하십시오.

참고

    • ActiveX 및 VBA 개발자 안내서

    • ActiveX and VBA Reference


ActiveX의 개요 (요약 참조)

스크립트로 슬라이드 쇼 실행
ActiveX의 개요
응용프로그램을 시작하기 위한 명령 정의
AutoCAD 2008 사용자화 안내서 > 프로그래밍 인터페이스 소개 > ActiveX Automation > ActiveX의 개요 >
ActiveX의 개요
개념 요약 참조

명령

NETLOAD

.NET 응용프로그램 로드

시스템 변수

항목이 없습니다.

유틸리티

항목이 없습니다.

명령 수정자

항목이 없습니다.


응용프로그램을 시작하기 위한 명령 정의 (개념)

ActiveX의 개요
ActiveX Automation
메뉴 또는 도구막대에서 응용프로그램 시작
AutoCAD 2008 사용자화 안내서 > 프로그래밍 인터페이스 소개 > ActiveX Automation >
응용프로그램을 시작하기 위한 명령 정의
개념 요약 참조

acad.pgp 파일을 사용하여 응용프로그램을 시작하기 위한 외부 명령을 실행하는 새 AutoCAD 명령을 정의할 수 있습니다.

acad.pgp 파일을 사용하여 응용프로그램을 시작하기 위한 외부 명령을 실행하는 새 AutoCAD 명령을 정의할 수 있습니다. 다음 예제는 c:\vbapps\ 디렉토리에서 app1.exe 응용프로그램을 실행하는 RUNAPP1 명령을 정의합니다 이 코드를 acad.pgp 파일의 외부 명령 섹션에 추가합니다.

RUNAPP1, start c:\vbapps\app1, 0

명령행 매개변수가 필요한 응용프로그램에서 다음 코드를 사용할 수 있습니다.

RUNAPP2, start c:\vbapps\app2, 0, *Parameters: ,

이 예제는 매개변수를 지정하라는 프롬프트를 표시하고 지정한 매개변수를 응용프로그램에 전달하는 RUNAPP2 명령을 정의합니다.

AutoLISP startapp 함수를 사용하여 Automation을 이용하는 응용프로그램을 시작할 수도 있습니다. AutoLISP가 외부 응용프로그램을 시작하고 나면 AutoLISP은 이 응용프로그램의 동작을 더 이상 조정하지 못합니다. 그러나 AutoLISP을 사용하여 특정 매개변수를 기반으로 하는 다른 응용프로그램을 찾아 실행할 수 있습니다.


응용프로그램을 시작하기 위한 명령 정의 (요약 참조)

ActiveX의 개요
응용프로그램을 시작하기 위한 명령 정의
메뉴 또는 도구막대에서 응용프로그램 시작
AutoCAD 2008 사용자화 안내서 > 프로그래밍 인터페이스 소개 > ActiveX Automation > 응용프로그램을 시작하기 위한 명령 정의 >
응용프로그램을 시작하기 위한 명령 정의
개념 요약 참조

명령

항목이 없습니다.

시스템 변수

항목이 없습니다.

유틸리티

항목이 없습니다.

명령 수정자

항목이 없습니다.


메뉴 또는 도구막대에서 응용프로그램 시작 (개념)

응용프로그램을 시작하기 위한 명령 정의
ActiveX Automation
AutoCAD VBA
AutoCAD 2008 사용자화 안내서 > 프로그래밍 인터페이스 소개 > ActiveX Automation >
메뉴 또는 도구막대에서 응용프로그램 시작
개념 요약 참조

응용프로그램을 시작하는 새로운 명령을 정의한 후 그 명령을 메뉴 또는 도구막대에서 사용 가능하게 할 수 있습니다.

사용자화(CUI) 파일의 인터페이스 요소로부터 매크로를 호출할 수 있습니다. 하나 또는 두 개의 응용프로그램만을 사용하는 경우, 표준 풀다운 메뉴 중 하나에 응용프로그램을 추가할 수 있습니다. 응용프로그램 그룹의 경우에는 해당 응용프로그램 전용 풀다운 메뉴 또는 도구막대를 추가할 수 있습니다. 사용자화 파일을 작성, 편집 및 로드하는 데 대한 정보는 사용자 인터페이스 사용자화을 참고하십시오.


메뉴 또는 도구막대에서 응용프로그램 시작 (요약 참조)

응용프로그램을 시작하기 위한 명령 정의
메뉴 또는 도구막대에서 응용프로그램 시작
AutoCAD VBA 개요
AutoCAD 2008 사용자화 안내서 > 프로그래밍 인터페이스 소개 > ActiveX Automation > 메뉴 또는 도구막대에서 응용프로그램 시작 >
메뉴 또는 도구막대에서 응용프로그램 시작
개념 요약 참조

명령

MENULOAD

구형

시스템 변수

항목이 없습니다.

유틸리티

항목이 없습니다.

명령 수정자

항목이 없습니다.


AutoCAD VBA

메뉴 또는 도구막대에서 응용프로그램 시작
프로그래밍 인터페이스 소개
AutoCAD VBA 개요
AutoCAD 2008 사용자화 안내서 > 프로그래밍 인터페이스 소개 >
AutoCAD VBA

Microsoft Visual Basic for Applications(VBA)는 풍부한 개발 기능을 제공하도록 설계된 객체 기반 프로그래밍 환경입니다. VBA와 VB(Visual Basic 6)의 주요한 차이는 VBA는 AutoCAD와 동일한 프로세스 공간에서 실행되므로 AutoCAD의 지능적이고 매우 신속한 프로그래밍 환경을 제공한다는 점입니다.

이 단원의 항목

  • AutoCAD VBA 개요
  • AutoCAD VBA 응용프로그램

    VBALOAD 명령을 사용하여 VBA 프로젝트를 로드합니다. VBA 프로젝트가 로드되면 매크로 대화상자에서 해당 VBA 프로젝트의 모듈 및 매크로를 사용할 수 있습니다.

  • 자동으로 VBA 프로젝트 로드 및 실행

    AutoCAD를 실행할 때마다 자동으로 VBA 프로젝트를 로드할 수 있습니다.


AutoCAD VBA 개요 (개념)

AutoCAD VBA
AutoCAD VBA
AutoCAD VBA 응용프로그램
AutoCAD 2008 사용자화 안내서 > 프로그래밍 인터페이스 소개 > AutoCAD VBA >
AutoCAD VBA 개요
개념 요약 참조

VBA는 VBA를 사용할 수 있는 다른 응용프로그램과의 통합 기능도 제공합니다. 이는 다른 응용프로그램 객체 라이브러리를 사용하는 AutoCAD가 Microsoft Word나 Excel과 같은 다른 응용프로그램의 Automation 컨트롤러가 될 수 있다는 것을 의미합니다.

별도로 구입해야 하는 Visual Basic 6 독립 실행형 개발 버전은 외부 데이터베이스 엔진과 보고서 기록 기능과 같은 추가 구성요소를 제공함으로써 AutoCAD VBA를 보완합니다.

AutoCAD VBA를 사용하여 개발

VBA는 AutoCAD ActiveX Automation 인터페이스로 AutoCAD에 메시지를 보냅니다. AutoCAD VBA에서는 Visual Basic 환경이 AutoCAD와 동시에 실행될 수 있으며, ActiveX Automation 인터페이스를 통해 AutoCAD에 대한 프로그래밍 조정을 제공합니다 AutoCAD, ActiveX Automation 및 VBA 사이의 이러한 연결성은 매우 강력한 인터페이스를 제공합니다. AutoCAD 객체를 조정할 수 있을 뿐 아니라 다른 응용프로그램과 데이터를 주고받을 수도 있습니다.

VBA는 AutoCAD에 통합되어 AutoCAD를 사용자화하기 위한 사용하기 쉬운 시각적 도구를 제공합니다 예를 들어, 자동으로 속성 정보를 추출하고 그 결과를 Excel 스프레드시트에 직접 삽입하며 필요한 데이터 변환을 수행하는 응용프로그램을 작성할 수 있습니다.

3개의 기본 요소로 AutoCAD에서의 VBA 프로그래밍을 정의합니다. 첫 번째 요소는 AutoCAD로, 여기에는 AutoCAD 도면요소, 데이터, 명령을 포함하는 다양한 객체 세트가 포함되어 있습니다. AutoCAD는 다중 레벨 인터페이스가 있는 개방형 아키텍처 응용프로그램입니다. VBA를 효율적으로 사용하려면 AutoCAD 프로그래밍에 익숙해져야 합니다. 그러나 VBA 객체 기반 접근 방법은 AutoLISP에서의 접근 방법과 크게 다릅니다.

두 번째 요소는 AutoCAD 객체와의 메시지(커뮤니케이션) 기능을 설정하는 AutoCAD ActiveX Automation 인터페이스입니다. VBA에서 프로그래밍하려면 기본적으로 ActiveX Automation에 대해 알고 있어야 합니다. 도움말 시스템의 ActiveX 및 VBA 개발자 안내서에서 AutoCAD ActiveX 자동화 인터페이스의 설명을 찾을 수 있습니다. 개발자 도움말을 표시하려면 도움말 메뉴 [image] 추가 리소스 [image] 개발자 도움말을 클릭하십시오.

VBA 프로그래밍을 정의하는 세 번째 요소는 VBA 자체입니다. VBA에는 프로그램 흐름, 조정, 디버깅 및 실행을 제공하는 일련의 객체, 키워드, 상수 등이 포함되어 있습니다. VBA용의 광범위한 Microsoft 도움말 시스템이 AutoCAD VBA에 포함되어 있습니다.

AutoCAD ActiveX/VBA 인터페이스는 다른 AutoCAD API 환경에 다음과 같은 여러 가지 이점을 제공합니다

  • 속도 VBA와 함께 ActiveX 응용프로그램을 실행하면 AutoLISP 응용프로그램보다 속도가 빠릅니다.
  • 편이성 프로그래밍 언어와 개발 환경이 사용하기 쉽고 AutoCAD와 함께 설치됩니다.
  • Windows 상호 운용성 ActiveX와 VBA는 다른 Windows 응용프로그램과 함께 사용하도록 설계되었으며 응용프로그램 간의 커뮤니케이션을 위한 탁월한 수단을 제공합니다.
  • 신속한 원형 제작 VBA 인터페이스를 신속하게 개발할 수 있으므로 응용프로그램이 다른 언어로 개발되는 경우에도 응용프로그램 원형을 제작할 수 있는 완벽한 환경이 제공됩니다.
  • 프로그래머 기반 프로그래머들은 이미 Visual Basic 6를 사용하고 있습니다. AutoCAD ActiveX와 VBA는 이들 프로그래머와 앞으로 Visual Basic 6를 배울 더 많은 사람들이 AutoCAD를 사용자화하고 응용프로그램을 개발할 수 있도록 개방되어 있습니다.


AutoCAD VBA 개요 (요약 참조)

메뉴 또는 도구막대에서 응용프로그램 시작
AutoCAD VBA 개요
AutoCAD VBA 응용프로그램
AutoCAD 2008 사용자화 안내서 > 프로그래밍 인터페이스 소개 > AutoCAD VBA > AutoCAD VBA 개요 >
AutoCAD VBA 개요
개념 요약 참조

명령

VBAIDE

Visual Basic Editor를 표시합니다.

VBALOAD

전체 VBA 프로젝트를 현재 작업 세션에 로드합니다.

VBAMAN

VBA 프로젝트를 로드, 언로드, 저장, 작성, 포함 및 추출합니다.

VBARUN

VBA 매크로를 실행합니다.

VBASTMT

AutoCAD 명령행에서 VBA문을 실행합니다.

VBAUNLOAD

전체 VBA 프로젝트를 언로드합니다.

시스템 변수

항목이 없습니다.

유틸리티

항목이 없습니다.

명령 수정자

항목이 없습니다.


AutoCAD VBA 응용프로그램 (개념)

AutoCAD VBA 개요
AutoCAD VBA
자동으로 VBA 프로젝트 로드 및 실행
AutoCAD 2008 사용자화 안내서 > 프로그래밍 인터페이스 소개 > AutoCAD VBA >
AutoCAD VBA 응용프로그램
개념 요약 참조

VBALOAD 명령을 사용하여 VBA 프로젝트를 로드합니다. VBA 프로젝트가 로드되면 매크로 대화상자에서 해당 VBA 프로젝트의 모듈 및 매크로를 사용할 수 있습니다.

Microsoft 응용프로그램이 VBA 프로젝트, 매크로 및 프로그램을 특정 문서 안에 저장하기는 하지만, AutoCAD는 확장명이 .dvb인 별도의 파일을 사용합니다. 이처럼 VBA는 많은 면에서 AutoLISP와 ObjectARX의 인터페이스 방식과 동일한 방식으로 AutoCAD와 상호 작용합니다. VBA 프로젝트가 별도의 파일에 저장되기 때문에 VBA 프로젝트는 AutoCAD 세션 동안 서로 다른 AutoCAD 도면을 열고 닫을 수 있습니다.

주AutoCAD VBA 프로젝트는 독립 실행형 Visual Basic 6 프로젝트(VBP 파일)와 호환되는 이진 형식이 아닙니다. 그러나 폼, 모듈 및 클래스는 VBA IDE(통합 개발 환경)에서 IMPORT 및 EXPORT VBA 명령을 사용하여 서로 다른 프로젝트 사이에서 교환될 수 있습니다.

VBALOAD 명령을 사용하여 VBA 프로젝트를 로드합니다. VBA 프로젝트가 로드되면 매크로 대화상자에서 해당 VBA 프로젝트의 모듈 및 매크로를 사용할 수 있습니다. VBA 모듈을 실행하려면 VBARUN 명령을 사용하십시오. 로드된 VBA 프로젝트가 없으면 옵션을 사용할 수 없습니다. 매크로 이름 상자에 표시된 절차는 다음 구문을 사용합니다.

module.macro

매크로 대화상자에서 매크로 범위를 선택하고, 표시되는 모듈 중에서 선택합니다.

명령 프롬프트를 사용하여 VBA 매크로 실행

명령 프롬프트에서 매크로를 실행하는 데 -VBARUN 명령을 사용할 수 있습니다. 이 명령을 사용하면 명령 프롬프트, 스크립트 및 기타 AutoCAD 프로그래밍 환경에서 VBA 매크로를 실행할 수 있습니다. 명령의 유일한 인수는 module.macro 구문을 사용하는 모듈 이름입니다. 이 구문은 다음과 같습니다.

–vbarun <module.macro>

이름이 같은 매크로가 모듈에서 중복될 수 있으므로 module.macro 구문을 사용하면 매크로가 구분되고 고유한 선택이 가능합니다.


AutoCAD VBA 응용프로그램 (요약 참조)

AutoCAD VBA 개요
AutoCAD VBA 응용프로그램
자동으로 VBA 프로젝트 로드 및 실행
AutoCAD 2008 사용자화 안내서 > 프로그래밍 인터페이스 소개 > AutoCAD VBA > AutoCAD VBA 응용프로그램 >
AutoCAD VBA 응용프로그램
개념 요약 참조

명령

VBAIDE

Visual Basic Editor를 표시합니다.

VBALOAD

전체 VBA 프로젝트를 현재 작업 세션에 로드합니다.

VBAMAN

VBA 프로젝트를 로드, 언로드, 저장, 작성, 포함 및 추출합니다.

VBARUN

VBA 매크로를 실행합니다.

VBASTMT

AutoCAD 명령행에서 VBA문을 실행합니다.

VBAUNLOAD

전체 VBA 프로젝트를 언로드합니다.

시스템 변수

항목이 없습니다.

유틸리티

항목이 없습니다.

명령 수정자

항목이 없습니다.


자동으로 VBA 프로젝트 로드 및 실행 (개념)

AutoCAD VBA 응용프로그램
AutoCAD VBA
AutoLISP 및 Visual LISP
AutoCAD 2008 사용자화 안내서 > 프로그래밍 인터페이스 소개 > AutoCAD VBA >
자동으로 VBA 프로젝트 로드 및 실행
개념 요약 참조

AutoCAD를 실행할 때마다 자동으로 VBA 프로젝트를 로드할 수 있습니다.

많은 VBA 프로젝트를 작성한 경우, AutoCAD를 실행할 때마다 자동으로 VBA 프로젝트를 로드할 수 있습니다. VBA 프로젝트에 포함된 매크로를 즉시 사용할 수 있습니다. 또한 APPLOAD명령은 지정된 응용프로그램을 자동으로 로드하는 시작하기 세트 옵션을 제공합니다.

acvba.arx— 자동으로 VBA 로드

AutoCAD VBA 명령을 실행할 때까지 VBA를 로드할 수 없습니다. AutoCAD를 시작할 때마다 자동으로 VBA를 로드하려면 acad.rx 파일에 다음 행을 포함시킵니다.

acvba.arx

매크로의 이름을 AcadStartup으로 정하면 acad.dvb 파일의 매크로가 자동으로 실행됩니다. VBA가 로드되면 acad.dvb 파일에 있는 AcadStartup이라는 매크로가 자동으로 실행됩니다.

acad.dvb — 자동으로 VBA 프로젝트 로드

AutoCAD가 시작될 때마다 원하는 매크로가 포함된 특정 VBA 프로젝트를 로드하려는 경우 acad.dvb 파일이 AutoCAD에 유용합니다. 새로운 AutoCAD 도면 세션을 시작할 때마다 AutoCAD는 acad.dvb 파일을 검색하여 로드합니다.

새 도면을 시작하거나 또는 기존 도면을 열 때마다 acad.dvb 파일에 있는 매크로가 실행되게 하려면 acaddoc.lsp 파일에 다음 코드를 추가하십시오.

(defun S::STARTUP()
  (command "_-vbarun" "updatetitleblock")
)

예제에서 프로젝트 이름은 updatetitleblock입니다.


자동으로 VBA 프로젝트 로드 및 실행 (요약 참조)

AutoCAD VBA 응용프로그램
자동으로 VBA 프로젝트 로드 및 실행
AutoLISP 및 Visual LISP의 개요
AutoCAD 2008 사용자화 안내서 > 프로그래밍 인터페이스 소개 > AutoCAD VBA > 자동으로 VBA 프로젝트 로드 및 실행 >
자동으로 VBA 프로젝트 로드 및 실행
개념 요약 참조

명령

APPLOAD

응용프로그램을 로드하거나 언로드하고 시작할 때 로드할 응용프로그램을 정의합니다.

VBAIDE

Visual Basic Editor를 표시합니다.

VBALOAD

전체 VBA 프로젝트를 현재 작업 세션에 로드합니다.

VBAMAN

VBA 프로젝트를 로드, 언로드, 저장, 작성, 포함 및 추출합니다.

VBARUN

VBA 매크로를 실행합니다.

VBASTMT

AutoCAD 명령행에서 VBA문을 실행합니다.

VBAUNLOAD

전체 VBA 프로젝트를 언로드합니다.

시스템 변수

항목이 없습니다.

유틸리티

항목이 없습니다.

명령 수정자

항목이 없습니다.


AutoLISP 및 Visual LISP

자동으로 VBA 프로젝트 로드 및 실행
프로그래밍 인터페이스 소개
AutoLISP 및 Visual LISP의 개요
AutoCAD 2008 사용자화 안내서 > 프로그래밍 인터페이스 소개 >
AutoLISP 및 Visual LISP

AutoLISP은 배우기 쉽고 아주 강력한 기능의 LISP 프로그래밍 언어를 기반으로 합니다. AutoCAD에는 내장 LISP 번역기가 있어 명령 프롬프트에 AutoLISP 코드를 입력하거나 외부 파일로부터 AutoLISP 코드를 로드할 수 있습니다. Visual LISP(VLISP)은 AutoLISP 프로그램 개발을 돕기 위해 만들어진 소프트웨어 도구입니다.

이 단원의 항목

  • AutoLISP 및 Visual LISP의 개요
  • AutoLISP 응용프로그램 사용

    AutoLISP 응용프로그램은 편집할 수 있는 ASCII 텍스트 파일로 저장됩니다. AutoLISP 응용프로그램을 사용하려면 먼저 AutoLISP 응용프로그램을 로드해야 합니다.

  • 자동으로 AutoLISP 루틴 로드 및 실행

    AutoCAD를 실행할 때마다 AutoLISP 루틴을 로드할 수 있습니다. 도면 세션 동안 특정 시간에 특정 명령 또는 함수를 실행할 수도 있습니다.


AutoLISP 및 Visual LISP의 개요 (개념)

AutoLISP 및 Visual LISP
AutoLISP 및 Visual LISP
AutoLISP 응용프로그램 사용
AutoCAD 2008 사용자화 안내서 > 프로그래밍 인터페이스 소개 > AutoLISP 및 Visual LISP >
AutoLISP 및 Visual LISP의 개요
개념 요약 참조

AutoLISP은 생산성 향상을 위한 컴파일러, 디버거 및 기타 개발 도구가 포함된 통합 개발 환경(IDE)을 제공하는 VLISP(Visual LISP)을 통해 향상되었습니다. VLISP에는 더 많은 기능이 추가되고, ActiveX를 사용하는 객체와 상호 작용하도록 언어가 확장되었습니다. 또한 VLISP을 사용하면 AutoLISP이 객체 리액터를 통해 이벤트에 응답할 수 있습니다.

ObjectARX나 VBA에서와 달리 다중 설계 환경(MDE)에서 열리는 각 문서에는 고유의 Visual LISP 이름 공간과 환경이 있습니다. 이름 공간은 각 문서마다 고유한 AutoLISP 루틴이 다른 문서와 충돌되는 기호나 변수 이름 및 값을 갖지 않도록 해 주는 단절된 환경입니다. 예를 들어, 다음 코드 행은 a기호에 문서마다 각각 다른 값을 설정합니다.

(setq a (getvar "DWGNAME"))

Visual LISP은 기호와 변수를 하나의 이름 공간에서 다른 이름 공간으로 로드하는 메커니즘을 제공합니다. 이름 공간에 대한 자세한 정보는 도움말 시스템의 AutoLISP 개발자 안내서를 참조하십시오. 개발자 도움말을 표시하려면 도움말 메뉴 [image] 추가 리소스 [image] 개발자 도움말을 클릭하십시오.

AutoLISP 응용프로그램 또는 루틴은 여러 가지 방식으로 AutoCAD와 상호 작용할 수 있습니다. 이러한 루틴은 사용자에게 입력을 요청하고, 내장된 AutoCAD 명령에 직접 접근하고, 도면 데이터베이스의 객체를 작성하거나 수정할 수 있습니다. AutoLISP 루틴을 작성함으로써 AutoCAD에 분야별 명령을 추가할 수 있습니다. 일부 AutoCAD 표준 명령은 실제로 AutoLISP 응용프로그램입니다.

Visual LISP은 AutoLISP 응용프로그램을 위해 다음과 같은 3가지 파일 형식 옵션을 제공합니다.

  • AutoLISP 프로그램 코드가 포함된 ASCII 텍스트 파일인 LSP 파일(.lsp)—AutoLISP 프로그램 코드를 포함하는 ASCII 문자 파일.
  • 단일 LSP 프로그램 파일의 컴파일된 이진 버전인 FAS 파일(.fas)—단일 LSP 프로그램 이진 파일의 컴파일된 버전.
  • 하나 이상의 LSP 및 DCL(dialog control language) 파일인 VLX 파일(.vlx)— 하나 이상의 LSP 및/또는 DCL(Dialog Control Language) 파일의 컴파일된 세트.
주명명된 AutoLISP 응용프로그램 파일이 수정된 날짜 시간 스탬프를 기준으로 로드되는 것처럼 전체 파일 이름(파일 이름 확장명 포함)을 지정하지 않으면 가장 최근 시간 스탬프가 있는 LSP, FAS 또는 VLX 파일이 로드됩니다.

AutoCAD가 AutoLISP 코드를 직접 읽을 수 있기 때문에 컴파일 작업이 필요 없습니다. Visual LISP에서 IDE를 제공하기는 하지만 바로 결과를 확인하기 위해 명령 프롬프트에서 코드를 입력하여 시험해 볼 수도 있습니다. 이러한 기능이 있어 사용자의 프로그래밍 경험과 관계없이 AutoLISP 언어를 쉽게 시험해 볼 수 있습니다.

AutoLISP 응용프로그램 작성에 관심이 없는 사람도 AutoCAD 패키지에 포함된 많은 유용한 루틴을 활용할 수 있습니다. 다른 개발업체를 통해 쉐어웨어로 제공된 루틴도 사용할 수 있습니다. 이러한 루틴을 로드하고 사용하는 방법을 알면 생산성을 높일 수 있습니다.

주명령 입력이 AutoLISP command 함수에서 나온 것일 경우 PICKADD 및 PICKAUTO 시스템 변수의 설정은 각각 1과 0으로 간주됩니다. 이로 인해 이전 AutoCAD 릴리즈와의 호환성이 유지되며, 이들 변수의 설정을 검사하지 않아도 되기 때문에 더 쉽게 사용자화할 수 있습니다.

AutoLISP 프로그래밍에 대한 정보는 도움말 시스템의 AutoLISP 개발자 안내서를, AutoLISP 및 Visual LISP 기능에 대한 정보는 AutoLISP Reference를 참조하십시오. 개발자 도움말을 표시하려면 도움말 메뉴 [image] 추가 리소스 [image] 개발자 도움밀을 클릭하십시오. AutoLISP 프로그램은 해당 응용프로그램에 대화상자를 사용할 수 있습니다. 프로그래밍 가능한 대화상자는 AutoLISP 개발자 안내서에만 설명되어 있습니다.


AutoLISP 및 Visual LISP의 개요 (요약 참조)

자동으로 VBA 프로젝트 로드 및 실행
AutoLISP 및 Visual LISP의 개요
AutoLISP 응용프로그램 사용
AutoCAD 2008 사용자화 안내서 > 프로그래밍 인터페이스 소개 > AutoLISP 및 Visual LISP > AutoLISP 및 Visual LISP의 개요 >
AutoLISP 및 Visual LISP의 개요
개념 요약 참조

명령

항목이 없습니다.

시스템 변수

PICKADD

이후의 선택 사항이 현재 선택 세트를 대체할지 또는 현재 선택 세트에 추가할지 조정합니다

PICKAUTO

객체 선택 프롬프트에서 자동 윈도우 기능을 조정합니다

유틸리티

항목이 없습니다.

명령 수정자

항목이 없습니다.


AutoLISP 응용프로그램 사용 (개념)

AutoLISP 및 Visual LISP의 개요
AutoLISP 및 Visual LISP
자동으로 AutoLISP 루틴 로드 및 실행
AutoCAD 2008 사용자화 안내서 > 프로그래밍 인터페이스 소개 > AutoLISP 및 Visual LISP >
AutoLISP 응용프로그램 사용
개념 요약 참조

AutoLISP 응용프로그램은 편집할 수 있는 ASCII 텍스트 파일로 저장됩니다. AutoLISP 응용프로그램을 사용하려면 먼저 AutoLISP 응용프로그램을 로드해야 합니다.

AutoLISP 응용프로그램은 확장명이 .lsp인 ASCII 텍스트 파일로 저장됩니다. 일반적으로 이러한 파일에는 루틴, 용도, 특정 지시 사항 등을 설명하는 헤더 부분이 있습니다. 이 헤더에는 루틴의 사용과 관련하여 작성자 및 법률 정보에 대한 주석이 포함될 수도 있습니다. 주석은 앞에 세미콜론(;)이 옵니다. ASCII 텍스트 파일을 생성할 수 있는 문자 편집기나 워드 프로세서를 사용하여 이러한 파일을 보고 편집할 수 있습니다.

AutoLISP 응용프로그램을 사용하려면 먼저 AutoLISP 응용프로그램을 로드해야 합니다. APPLOAD 명령 또는 AutoLISP load 함수를 사용하여 응용프로그램을 로드할 수 있습니다. AutoLISP 응용프로그램을 로드하면 LSP 파일의 AutoLISP 코드가 시스템 메모리에 로드됩니다.

load 함수를 사용하여 응용프로그램을 로드하려면 명령 프롬프트에서 AutoLISP 코드를 입력해야 합니다. load 함수가 성공적으로 실행되면 명령 프롬프트에 파일의 마지막 표현식 값이 표시됩니다. 이 값은 대개 파일에 정의된 마지막 함수의 이름이거나 새로 로드된 함수의 사용법에 대한 지시 사항입니다. load 함수가 실패하면 AutoLISP 오류 메시지가 반환됩니다. 파일에서 코딩이 잘못되었거나 명령 프롬프트에 잘못된 파일 이름을 입력한 경우 load 실행이 실패할 수 있습니다. load 함수의 구문은 다음과 같습니다.

(load filename [onfailure])

이 구문을 보면 load 함수에 두 개의 인수가 있음을 알 수 있습니다. filename은 필수 onfailure은 선택사항. 명령 프롬프트에서 AutoLISP 파일을 로드할 때 일반적으로 filename 인수만 제공합니다. 다음 예제는 AutoLISP 파일 newfile.lsp를 로드합니다.

명령: (load "newfile")

.lsp 확장명은 필요 없습니다. 이 형식은 현재 라이브러리 경로의 모든 LSP 파일에 적용됩니다.

라이브러리 경로에 있지 않은 AutoLISP 파일을 로드하려면 전체 경로와 파일 이름을 filename 인수로 제공해야 합니다.

명령: (load "d:/files/morelisp/newfile")

주디렉토리 경로를 지정할 때 단일 역슬래쉬는 AutoLISP에서 특별한 의미를 갖기 때문에 구분 기호로 슬래쉬(/) 또는 이중 역슬래쉬(\\)를 사용해야 합니다.
참고

    • 파일 구성에 대한 개요


AutoLISP 응용프로그램 사용 (요약 참조)

AutoLISP 및 Visual LISP의 개요
AutoLISP 응용프로그램 사용
AutoLISP 자동 로드의 개요
AutoCAD 2008 사용자화 안내서 > 프로그래밍 인터페이스 소개 > AutoLISP 및 Visual LISP > AutoLISP 응용프로그램 사용 >
AutoLISP 응용프로그램 사용
개념 요약 참조

명령

APPLOAD

응용프로그램을 로드하거나 언로드하고 시작할 때 로드할 응용프로그램을 정의합니다.

시스템 변수

항목이 없습니다.

유틸리티

항목이 없습니다.

명령 수정자

항목이 없습니다.


자동으로 AutoLISP 루틴 로드 및 실행

AutoLISP 응용프로그램 사용
AutoLISP 및 Visual LISP
AutoLISP 자동 로드의 개요
AutoCAD 2008 사용자화 안내서 > 프로그래밍 인터페이스 소개 > AutoLISP 및 Visual LISP >
자동으로 AutoLISP 루틴 로드 및 실행

AutoCAD를 실행할 때마다 AutoLISP 루틴을 로드할 수 있습니다. 도면 세션 동안 특정 시간에 특정 명령 또는 함수를 실행할 수도 있습니다.

이 단원의 항목

  • AutoLISP 자동 로드의 개요
  • ACAD.LSP 파일

    특정 AutoLISP 루틴을 정기적으로 사용하는 경우 acad.lsp 파일을 작성할 수 있습니다. AutoCAD를 시작할 때 acad.lsp 파일의 지원 파일 검색 경로가 검색됩니다. acad.lsp 파일을 찾으면 메모리에 로드합니다.

  • acaddoc.lsp 파일

    acaddoc.lsp 파일은 각 문서(또는 도면) 초기화와 연관시킬 목적으로 만들어졌습니다. 이 파일은 새 도면을 시작할 때마다(또는 기존 도면을 열 때마다) AutoLISP 루틴 라이브러리를 사용 가능한 상태로 로드하려는 경우에 유용합니다.

  • AutoLISP 메뉴에 대한 MNL 파일

    AutoCAD는 사용자화 파일을 로드할 때 파일 이름이 일치하는 MNL 파일을 검색합니다. 하나의 파일을 찾으면 그 파일이 메모리에 로드됩니다. 이 함수를 사용하면 AutoCAD가 적절한 메뉴 작업에 필요한 AutoLISP 함수를 로드합니다.

  • 시작 파일을 로드할 때 AutoLISP 오류 방지

    시작 파일을 로드할 때 AutoLISP 오류가 발생하면 파일의 나머지 부분이 무시되고 로드되지 않습니다.

  • S::STARTUP Function: Postinitialization Execution

    S::STARTUP 함수를 정의하여 도면이 초기화된 후에 임의의 필요한 설정 작업을 수행할 수 있습니다.


AutoLISP 자동 로드의 개요 (개념)

자동으로 AutoLISP 루틴 로드 및 실행
자동으로 AutoLISP 루틴 로드 및 실행
ACAD.LSP 파일
AutoCAD 2008 사용자화 안내서 > 프로그래밍 인터페이스 소개 > AutoLISP 및 Visual LISP > 자동으로 AutoLISP 루틴 로드 및 실행 >
AutoLISP 자동 로드의 개요
개념 요약 참조

AutoCAD는 3개의 사용자 정의 가능 파일의 컨텐츠를 자동으로 로드합니다. 현재 사용자화 파일과 함께인 acad.lsp, acaddoc.lsp, 및 MNL 파일. 기본적으로 acad.lsp 파일은 AutoCAD가 시작될 때 한 번만 로드되는 반면 acaddoc.lsp는 각 문서(또는 도면)마다 로드됩니다. 따라서 acad.lsp 파일의 로드를 응용프로그램의 시작과 연관시키고, acaddoc.lsp 파일의 로드를 문서(또는 도면)의 시작과 연관시킬 수 있습니다. 이러한 시작 파일을 로드하는 기본 방법은 ACADLSPASDOC 시스템 변수의 설정을 변경하여 수정할 수 있습니다.

이러한 파일 중 하나가 특수한 유형의 함수인 S::STARTUP을 정의하는 경우, 이 루틴은 도면이 완전히 초기화되는 즉시 실행됩니다. S::STARTUP 함수 설명은 S::STARTUP Function: Postinitialization Execution에 있습니다. 대안으로 APPLOAD 명령은 파일을 편집하지 않고도 지정된 응용프로그램을 로드하는 시작하기 세트 옵션을 제공합니다.

acad.lsp 및 acaddoc.lsp 시작 파일은 AutoCAD와 함께 제공되지 않습니다. 이들 파일은 사용자가 작성하고 유지할 수 있습니다.

명령 Autoloader

load 또는 command 함수를 사용하여 자동으로 명령을 로드한 경우 실제로 명령을 사용했는지 여부와 관계없이 명령의 정의가 메모리를 차지합니다. AutoLISP autoload 함수는 전체 루틴을 메모리에 로드하지 않고 명령을 사용할 수 있게 합니다. 다음 코드를 acaddoc.lsp 파일에 추가하면 명령CMD1, CMD2 및 CMD3이 cmds.lsp 파일로부터 로드되고 NEWCMD 명령이 newcmd.lsp 파일로부터 자동으로 로드됩니다.

(autoload "CMDS" '("CMD1" "CMD2" "CMD3"))
(autoload "NEWCMD" '("NEWCMD"))

자동으로 로드되는 명령을 처음 명령 프롬프트에서 입력하면 AutoLISP은 연관된 파일에서 전체 명령 정의를 로드합니다. AutoLISP은 ObjectARX 응용프로그램을 위해 autoarxload 함수도 제공합니다. 도움말 시스템의 AutoLISP Reference에서 autoload 및 autoarxload를 참조하십시오. 개발자 도움말을 표시하려면 도움말 메뉴 [image] 추가 리소스 [image] 개발자 도움말을 클릭하십시오.

주명명된 AutoLISP 시작 파일이 수정된 날짜 시간 스탬프를 기준으로 로드되는 것처럼 전체 파일 이름(파일 이름 확장명 포함)을 지정하지 않으면 가장 최근 시간 스탬프가 있는 LSP 파일이 로드됩니다.
참고

    • AutoLISP 파일 로드

    • S::STARTUP Function: Postinitialization Execution


AutoLISP 자동 로드의 개요 (요약 참조)

AutoLISP 응용프로그램 사용
AutoLISP 자동 로드의 개요
ACAD.LSP 파일
AutoCAD 2008 사용자화 안내서 > 프로그래밍 인터페이스 소개 > AutoLISP 및 Visual LISP > 자동으로 AutoLISP 루틴 로드 및 실행 > AutoLISP 자동 로드의 개요 >
AutoLISP 자동 로드의 개요
개념 요약 참조

명령

APPLOAD

응용프로그램을 로드하거나 언로드하고 시작할 때 로드할 응용프로그램을 정의합니다.

시스템 변수

ACADLSPASDOC

acad.lsp 파일이 모든 도면에 로드될지 또는 세션에 열린 첫 번째 도면에만 로드될지 여부를 조정합니다

유틸리티

항목이 없습니다.

명령 수정자

항목이 없습니다.


ACAD.LSP 파일 (개념)

AutoLISP 자동 로드의 개요
자동으로 AutoLISP 루틴 로드 및 실행
acaddoc.lsp 파일
AutoCAD 2008 사용자화 안내서 > 프로그래밍 인터페이스 소개 > AutoLISP 및 Visual LISP > 자동으로 AutoLISP 루틴 로드 및 실행 >
ACAD.LSP 파일
개념 요약 참조

특정 AutoLISP 루틴을 정기적으로 사용하는 경우 acad.lsp 파일을 작성할 수 있습니다. AutoCAD를 시작할 때 acad.lsp 파일의 지원 파일 검색 경로가 검색됩니다. acad.lsp 파일을 찾으면 메모리에 로드합니다.

acad.lsp 파일은 AutoCAD 시작시 도면 세션이 시작할 때마다 로드됩니다. acad.lsp 파일은 응용프로그램 고유의 시작 루틴에 사용되도록 만들어졌기 때문에 acad.lsp 파일에 정의된 모든 함수와 변수는 첫 번째 도면에서만 사용 가능합니다. 사용자는 모든 문서에서 사용할 수 있는 루틴을 acad.lsp 파일에서 acaddoc.lsp 파일로 이동하려고 할 것입니다.

acad.lsp 및 acaddoc.lsp의 권장되는 기능은 ACADLSPASDOC 시스템 변수를 사용하여 재지정될 수 있습니다. ACADLSPASDOC 시스템 변수가 0(기본 설정)으로 설정되었으면 acad.lsp 파일은 응용프로그램 시작 시 한 번만 로드됩니다. ACADLSPASDOC가 1로 설정된 경우, acad.lsp 파일은 새 도면을 시작할 때마다 다시 로드됩니다.

acad.lsp 파일에는 하나 이상의 루틴에 대한 AutoLISP 코드 또는 일련의 load 함수 호출이 포함될 수 있습니다. 수정하기가 쉽기 때문에 두 번째 방법이 더 선호됩니다. 다음 코드를 acad.lsp 파일로 저장하면 AutoCAD를 시작할 때마다 mysessionapp1.lsp, databasesynch.lsp 및 drawingmanager.lsp 파일이 로드됩니다.

(load "mysessionapp1")
(load "databasesynch")
(load "drawingmanager")
경고예약된 acad2008.lsp 파일은 수정하지 마십시오. Autodesk는 acad2008을 제공합니다.lsp 파일(AutoCAD에서 필요한 AutoLISP 정의 기능 포함)을 제공합니다. 이 파일은 acad.lsp 파일이 로드되기 직전에 메모리에 로드됩니다.
참고

    • 파일 구성에 대한 개요

    • 시작 파일을 로드할 때 AutoLISP 오류 방지


ACAD.LSP 파일 (요약 참조)

AutoLISP 자동 로드의 개요
ACAD.LSP 파일
acaddoc.lsp 파일
AutoCAD 2008 사용자화 안내서 > 프로그래밍 인터페이스 소개 > AutoLISP 및 Visual LISP > 자동으로 AutoLISP 루틴 로드 및 실행 > ACAD.LSP 파일 >
ACAD.LSP 파일
개념 요약 참조

명령

APPLOAD

응용프로그램을 로드하거나 언로드하고 시작할 때 로드할 응용프로그램을 정의합니다.

시스템 변수

ACADLSPASDOC

acad.lsp 파일이 모든 도면에 로드될지 또는 세션에 열린 첫 번째 도면에만 로드될지 여부를 조정합니다

유틸리티

항목이 없습니다.

명령 수정자

항목이 없습니다.


acaddoc.lsp 파일 (개념)

ACAD.LSP 파일
자동으로 AutoLISP 루틴 로드 및 실행
AutoLISP 메뉴에 대한 MNL 파일
AutoCAD 2008 사용자화 안내서 > 프로그래밍 인터페이스 소개 > AutoLISP 및 Visual LISP > 자동으로 AutoLISP 루틴 로드 및 실행 >
acaddoc.lsp 파일
개념 요약 참조

acaddoc.lsp 파일은 각 문서(또는 도면) 초기화와 연관시킬 목적으로 만들어졌습니다. 이 파일은 새 도면을 시작할 때마다(또는 기존 도면을 열 때마다) AutoLISP 루틴 라이브러리를 사용 가능한 상태로 로드하려는 경우에 유용합니다.

도면이 열릴 때마다 AutoCAD는 라이브러리 경로에 acaddoc.lsp 파일이 있는지 검색합니다. 하나의 파일을 찾으면 그 파일이 메모리에 로드됩니다. ACADLSPASDOC의 설정과 관계없이 각 도면마다 항상 acaddoc.lsp 파일이 로드됩니다.

대부분 사용자는 모든 문서 기반 AutoLISP 루틴에 대해 단일 acaddoc.lsp 파일을 갖습니다. AutoCAD는 라이브러리 경로에 정의된 순서대로 acaddoc.lsp 파일을 검색합니다. 따라서 이 기능을 사용하면 각 도면 디렉토리에 여러 가지 다른 acaddoc.lsp 파일을 가질 수 있습니다. 이 디렉토리는 특정 유형의 도면이나 작업에 대해 특정 AutoLISP 루틴을 로드합니다.

acaddoc.lsp 파일에는 하나 이상의 루틴에 대한 AutoLISP 코드 또는 일련의 load 함수 호출이 포함될 수 있습니다. 수정하기가 쉽기 때문에 두 번째 방법이 더 선호됩니다. 다음 코드를 acaddoc.lsp 파일로 저장하면 새 도면을 열 때마다 mydocumentapp1.lsp, build.lsp 및 counter.lsp 파일이 로드됩니다.

(load "mydocumentapp1")
(load "build")
(load "counter")
경고예약된 acad2008doc.lsp 파일은 수정하지 마십시오. Autodesk는 acad2008doc.lsp 파일(AutoCAD에서 필요한 AutoLISP 정의 기능을 포함)을 제공합니다. 이 파일은 acaddoc.lsp 파일이 로드되기 직전에 메모리에 로드됩니다.
참고

    • 파일 구성에 대한 개요

    • 시작 파일을 로드할 때 AutoLISP 오류 방지


acaddoc.lsp 파일 (요약 참조)

ACAD.LSP 파일
acaddoc.lsp 파일
AutoLISP 메뉴에 대한 MNL 파일
AutoCAD 2008 사용자화 안내서 > 프로그래밍 인터페이스 소개 > AutoLISP 및 Visual LISP > 자동으로 AutoLISP 루틴 로드 및 실행 > acaddoc.lsp 파일 >
acaddoc.lsp 파일
개념 요약 참조

명령

APPLOAD

응용프로그램을 로드하거나 언로드하고 시작할 때 로드할 응용프로그램을 정의합니다.

시스템 변수

ACADLSPASDOC

acad.lsp 파일이 모든 도면에 로드될지 또는 세션에 열린 첫 번째 도면에만 로드될지 여부를 조정합니다

유틸리티

항목이 없습니다.

명령 수정자

항목이 없습니다.


AutoLISP 메뉴에 대한 MNL 파일 (개념)

acaddoc.lsp 파일
자동으로 AutoLISP 루틴 로드 및 실행
시작 파일을 로드할 때 AutoLISP 오류 방지
AutoCAD 2008 사용자화 안내서 > 프로그래밍 인터페이스 소개 > AutoLISP 및 Visual LISP > 자동으로 AutoLISP 루틴 로드 및 실행 >
AutoLISP 메뉴에 대한 MNL 파일
개념 요약 참조

AutoCAD는 사용자화 파일을 로드할 때 파일 이름이 일치하는 MNL 파일을 검색합니다. 하나의 파일을 찾으면 그 파일이 메모리에 로드됩니다. 이 함수를 사용하면 AutoCAD가 적절한 메뉴 작업에 필요한 AutoLISP 함수를 로드합니다.

이 함수를 사용하면 AutoCAD가 적절한 메뉴 작업에 필요한 AutoLISP 함수를 로드합니다. 예를 들어 기본 AutoCAD 사용자화 파일 acad.cui은 파일 acad.mnl를 따릅니다.이 파일은 메뉴에서 사용되는 많은 AutoLISP 함수를 정의합니다. MNL 파일은 acaddoc.lsp 파일 다음에 로드됩니다.

주명령 "menu" "newmenu"와 유사한 구문으로 AutoLISP command 함수를 사용하여 사용자화 파일을 로드하면 전체 AutoLISP 루틴이 실행될 때까지 연관된 MNL 파일이 로드되지 않습니다.

이 예제에서 princ 함수에 대한 호출을 사용하여 상태 메시지를 표시할 수 있습니다. princ를 처음 사용하면 명령 프롬프트에 다음과 같이 표시됩니다.

새 메뉴 유틸리티… 로드됨.

princ를 두 번째 호출하면 AutoLISP 함수가 종료됩니다. princ에 대한 두 번째 호출을 하지 않으면 메시지가 두 번 표시됩니다. 앞에서 설명한 대로 보다 신중한 사전 예방 조치를 위해 load 함수에 대한 호출에 onfailure 인수를 포함시킬 수 있습니다.


AutoLISP 메뉴에 대한 MNL 파일 (요약 참조)

acaddoc.lsp 파일
AutoLISP 메뉴에 대한 MNL 파일
시작 파일을 로드할 때 AutoLISP 오류 방지
AutoCAD 2008 사용자화 안내서 > 프로그래밍 인터페이스 소개 > AutoLISP 및 Visual LISP > 자동으로 AutoLISP 루틴 로드 및 실행 > AutoLISP 메뉴에 대한 MNL 파일 >
AutoLISP 메뉴에 대한 MNL 파일
개념 요약 참조

명령

항목이 없습니다.

시스템 변수

항목이 없습니다.

유틸리티

항목이 없습니다.

명령 수정자

항목이 없습니다.


시작 파일을 로드할 때 AutoLISP 오류 방지 (개념)

AutoLISP 메뉴에 대한 MNL 파일
자동으로 AutoLISP 루틴 로드 및 실행
S::STARTUP Function: Postinitialization Execution
AutoCAD 2008 사용자화 안내서 > 프로그래밍 인터페이스 소개 > AutoLISP 및 Visual LISP > 자동으로 AutoLISP 루틴 로드 및 실행 >
시작 파일을 로드할 때 AutoLISP 오류 방지
개념 요약 참조

시작 파일을 로드할 때 AutoLISP 오류가 발생하면 파일의 나머지 부분이 무시되고 로드되지 않습니다.

일반적으로 시작 파일에 지정된 파일 중 존재하지 않거나 AutoCAD 라이브러리 경로에 있지 않는 파일은 오류의 원인이 됩니다. 따라서 load 함수에 onfailure 인수를 사용할 수 있습니다. 다음 예제는 onfailure 인수를 사용합니다.

(princ (load "mydocapp1" "\nMYDOCAPP1.LSP file not loaded."))
(princ (load "build" "\nBUILD.LSP file not loaded."))
(princ (load "counter" "\nCOUNTER.LSP file not loaded."))
(princ)

load 함수에 대한 호출이 성공하면 파일의 마지막 표현식 값(보통 마지막에 정의된 함수의 이름이나 함수 사용에 관한 메시지)이 반환됩니다. 호출이 실패하면 onfailure 인수의 값이 반환됩니다. 앞의 예제에서 load 함수에 의해 반환된 값은 princ 함수에 전달되어 명령 프롬프트에 해당 값이 표시됩니다.

예를 들어, AutoCAD가 mydocapp1.lsp 파일을 로드하는 중에 오류가 발생하면 princ 함수가 다음 메시지를 표시하고 AutoCAD는 계속해서 나머지 두 파일을 로드합니다.

MYDOCAPP1.LSP 파일은 로드되지 않습니다.

acad.lsp, acaddoc.lsp 또는 MNL 파일에서 command 함수를 사용한 경우, 이 함수는 defun 문에서만 호출되어야 합니다. 도면 세션을 시작한 직후에 실행되어야 하는 명령을 정의하려면 S::STARTUP 함수를 사용하십시오.

참고

    • S::STARTUP Function: Postinitialization Execution


시작 파일을 로드할 때 AutoLISP 오류 방지 (요약 참조)

AutoLISP 메뉴에 대한 MNL 파일
시작 파일을 로드할 때 AutoLISP 오류 방지
S::STARTUP Function: Postinitialization Execution
AutoCAD 2008 사용자화 안내서 > 프로그래밍 인터페이스 소개 > AutoLISP 및 Visual LISP > 자동으로 AutoLISP 루틴 로드 및 실행 > 시작 파일을 로드할 때 AutoLISP 오류 방지 >
시작 파일을 로드할 때 AutoLISP 오류 방지
개념 요약 참조

명령

항목이 없습니다.

시스템 변수

항목이 없습니다.

유틸리티

항목이 없습니다.

명령 수정자

항목이 없습니다.


S::STARTUP Function: Postinitialization Execution (개념)

시작 파일을 로드할 때 AutoLISP 오류 방지
자동으로 AutoLISP 루틴 로드 및 실행
ObjectARX
AutoCAD 2008 사용자화 안내서 > 프로그래밍 인터페이스 소개 > AutoLISP 및 Visual LISP > 자동으로 AutoLISP 루틴 로드 및 실행 >
S::STARTUP Function: Postinitialization Execution
개념 요약 참조

S::STARTUP 함수를 정의하여 도면이 초기화된 후에 임의의 필요한 설정 작업을 수행할 수 있습니다.

시작 LISP 파일(acad.lsp, acaddoc.lsp 및 MNL)은 도면이 완전히 초기화되기 전에 모두 메모리에 로드됩니다. 도면이 초기화된 후까지 올바르게 작동한다는 보장이 없는 command 함수를 사용하지만 않으면 일반적으로 이로 인해 문제가 발생하지 않습니다.

사용자 정의 함수 S::STARTUP이 acad.lsp, acaddoc.lsp또는 MNL 파일에 포함되어 있을 경우, 새 도면을 입력하거나 기존 도면을 열 때 이 함수가 호출됩니다. 따라서 S::STARTUP의 정의를 LISP 시작 파일에 포함시켜 설정 작업을 수행할 수 있습니다.

예를 들어, 메시지를 추가한 다음 BHATCH 명령으로 전환하여 표준 HATCH 명령을 재지정하려는 경우 다음 코드가 포함된 acaddoc.lsp 파일을 사용하십시오.

(defun C:HATCH ( )
  (alert "Using the BHATCH command!")
  (princ "\nEnter OLDHATCH to get to real HATCH command.\n")
  (command "BHATCH")
  (princ)
)
(defun C:OLDHATCH ( )
  (command ".HATCH")
  (princ)
)
(defun-q S::STARTUP ( )
  (command "undefine" "hatch")
  (princ "\nRedefined HATCH to BHATCH!\n")
)

도면이 초기화되기 전에 defun 함수를 사용하여 HATCH 및 OLDHATCH의 새로운 정의가 정의됩니다. 도면이 초기화되고 난 후에는 S::STARTUP 함수가 호출되고 HATCH의 표준 정의가 해제됩니다.

주S::STARTUP 함수를 추가하려면 defun 대신 defun-q 함수를 사용하여 정의했어야 합니다.

S::STARTUP 함수는 여러 위치(acad.lsp, acaddoc.lsp, MNL 파일 또는 이러한 파일로부터 로드된 다른 AutoLISP 파일)에 정의할 수 있기 때문에 이전에 정의된 S::STARTUP 함수를 덮어쓸 수 있습니다. 다음 예제에서는 시작 함수가 다른 함수와 함께 작동하게 해 주는 확실한 방법을 보여 줍니다.

(defun-q MYSTARTUP ( )

... your startup function ...

)
(setq S::STARTUP (append S::STARTUP MYSTARTUP))

앞에 나온 코드는 기존의 S::STARTUP 함수에 시작 함수를 추가한 다음, S::STARTUP 함수를 재정의하여 시작 코드를 포함시킵니다. 이 작업은 S::STARTUP 함수가 존재하는지 여부에 관계없이 올바르게 작동합니다.


S::STARTUP Function: Postinitialization Execution (요약 참조)

시작 파일을 로드할 때 AutoLISP 오류 방지
S::STARTUP Function: Postinitialization Execution
ObjectARX의 개요
AutoCAD 2008 사용자화 안내서 > 프로그래밍 인터페이스 소개 > AutoLISP 및 Visual LISP > 자동으로 AutoLISP 루틴 로드 및 실행 > S::STARTUP Function: Postinitialization Execution >
S::STARTUP Function: Postinitialization Execution
개념 요약 참조

명령

항목이 없습니다.

시스템 변수

항목이 없습니다.

유틸리티

항목이 없습니다.

명령 수정자

항목이 없습니다.


ObjectARX

S::STARTUP Function: Postinitialization Execution
프로그래밍 인터페이스 소개
ObjectARX의 개요
AutoCAD 2008 사용자화 안내서 > 프로그래밍 인터페이스 소개 >
ObjectARX

ObjectARX 기술은 지능적 객체 데이터를 공유하기 위한 응용프로그램 설계의 기초를 제공합니다. 외부 ObjectARX 응용프로그램을 실행하거나 사용자 자신의 프로그램을 작성할 수 있습니다.

이 단원의 항목

  • ObjectARX의 개요
  • ObjectARX 응용프로그램 사용

    ObjectARX 응용프로그램을 로드하려면 ARX 명령의 로드 옵션을 사용합니다. 로드되고 나면 이 응용프로그램이 정의한 모든 명령을 명령 프롬프트에서 사용할 수 있습니다.

  • 자동으로 ObjectARX 응용프로그램 로드

    일부 ObjectARX 예제에는 AutoCAD를 시작할 때 자동으로 로드되는 ObjectARX 프로그램 파일 리스트가 들어 있는 acad.rx 파일이 포함되어 있습니다.


ObjectARX의 개요 (개념)

ObjectARX
ObjectARX
ObjectARX 응용프로그램 사용
AutoCAD 2008 사용자화 안내서 > 프로그래밍 인터페이스 소개 > ObjectARX >
ObjectARX의 개요
개념 요약 참조

ObjectARX®(AutoCAD Rx)는 AutoCAD 응용프로그램 개발을 위한 컴파일 언어 프로그래밍 환경입니다. ObjectARX 프로그래밍 환경은 AutoCAD와 동일한 주소 공간에서 실행되고 핵심적인 AutoCAD 데이터 구조 및 코드와 함께 직접 작동되는 많은 수의 동적 링크 라이브러리(DLL)를 포함하고 있습니다. 이러한 라이브러리는 AutoCAD의 개방형 아키텍처를 이용하므로 AutoCAD 데이터베이스 구조, 그래픽 시스템 및 AutoCAD 형상 엔진에 직접 접근하여 실행할 때 AutoCAD 클래스와 기능을 확장할 수 있습니다. 또한 DLL을 사용하여 원시 AutoCAD 명령과 똑같은 방식으로 작동되는 새로운 명령을 만들 수 있습니다.

AutoLISP 또는 VBA와 같은 다른 AutoCAD 프로그래밍 인터페이스와 함께 ObjectARX 라이브러리를 사용할 수 있으므로 상호 API 통합이 가능합니다.

ObjectARX 프로그래밍 환경은 ObjectARX 개발자 안내서에 설명되어 있습니다. 관련 문서는 Autodesk 웹 사이트의 개발 도구 섹션에서 다운로드할 수 있는 ObjectARX SDK에 포함되어 있습니다. 자세한 정보를 보려면 도움말 메뉴 [image] 추가 리소스 [image] 개발자 도움말을 클릭하십시오. ObjectARX를 한 번 클릭하면 도움말 시스템이 열립니다.


ObjectARX의 개요 (요약 참조)

S::STARTUP Function: Postinitialization Execution
ObjectARX의 개요
ObjectARX 응용프로그램 사용
AutoCAD 2008 사용자화 안내서 > 프로그래밍 인터페이스 소개 > ObjectARX > ObjectARX의 개요 >
ObjectARX의 개요
개념 요약 참조

명령

항목이 없습니다.

시스템 변수

항목이 없습니다.

유틸리티

항목이 없습니다.

명령 수정자

항목이 없습니다.


ObjectARX 응용프로그램 사용 (개념)

ObjectARX의 개요
ObjectARX
자동으로 ObjectARX 응용프로그램 로드
AutoCAD 2008 사용자화 안내서 > 프로그래밍 인터페이스 소개 > ObjectARX >
ObjectARX 응용프로그램 사용
개념 요약 참조

ObjectARX 응용프로그램을 로드하려면 ARX 명령의 로드 옵션을 사용합니다. 로드되고 나면 이 응용프로그램이 정의한 모든 명령을 명령 프롬프트에서 사용할 수 있습니다.

일부 ObjectARX 응용프로그램은 많은 양의 시스템 메모리를 사용합니다. 응용프로그램 사용을 마치고 메모리에서 이 응용프로그램을 제거하려면 ARX의 언로드 옵션을 사용하십시오.

arxload AutoLISP 함수를 사용하여 ObjectARX 응용프로그램을 로드할 수도 있습니다. arxload 함수의 구문은 AutoLISP 파일에 사용되는 load 함수의 구문과 거의 같습니다. arxload 함수가 ObjectARX 프로그램을 성공적으로 로드하면 프로그램 이름을 반환합니다. arxload 함수의 구문은 다음과 같습니다.

(arxload filename [onfailure])

arxload 함수의 두 인수는 filename과 onfailure입니다. load 함수에서와 마찬가지로 filename 인수는 필수 인수이며, 이 인수는 로드할 ObjectARX 프로그램 파일에 대한 전체 경로 이름 설명이어야 합니다. onfailure 인수는 선택적 인수로서 보통 명령 프롬프트에서 ObjectARX 프로그램을 로드할 때는 사용되지 않습니다. 다음 예제는 ObjectARX 응용프로그램 myapp.arx를 로드합니다.

(arxload "myapp")

AutoLISP 파일의 경우와 마찬가지로 AutoCAD는 지정된 파일이 라이브러리 경로에 있는지 검색합니다. 라이브러리 경로에 없는 파일을 로드해야 하는 경우에는 파일의 전체 경로 이름 설명을 제공해야 합니다.

주디렉토리 경로를 지정할 때 단일 역슬래쉬는 AutoLISP에서 특별한 의미를 갖기 때문에 구분 기호로 슬래쉬(/) 또는 이중 역슬래쉬(\\)를 사용해야 합니다.

이미 로드된 응용프로그램을 로드하려고 시도하면 오류가 발생합니다. arxload를 사용하기 전에 arx 함수를 사용하여 현재 로드된 응용프로그램을 확인해야 합니다.

AutoLISP과 함께 응용프로그램을 언로드하려면 arxunload 함수를 사용하십시오. 다음 예제는 myapp 응용프로그램을 언로드합니다.

(arxunload "myapp")

arxunload 함수를 사용하면 메모리에서 응용프로그램이 제거될 뿐만 아니라 그 응용프로그램과 연관된 명령 정의도 함께 제거됩니다.

참고

    • 파일 구성에 대한 개요


ObjectARX 응용프로그램 사용 (요약 참조)

ObjectARX의 개요
ObjectARX 응용프로그램 사용
자동으로 ObjectARX 응용프로그램 로드
AutoCAD 2008 사용자화 안내서 > 프로그래밍 인터페이스 소개 > ObjectARX > ObjectARX 응용프로그램 사용 >
ObjectARX 응용프로그램 사용
개념 요약 참조

명령

ARX

ObjectARX 응용프로그램을 로드하거나 언로드하며 ObjectARX 응용프로그램에 대한 정보를 제공합니다.

시스템 변수

항목이 없습니다.

유틸리티

항목이 없습니다.

명령 수정자

항목이 없습니다.


자동으로 ObjectARX 응용프로그램 로드 (개념)

ObjectARX 응용프로그램 사용
ObjectARX
.NET
AutoCAD 2008 사용자화 안내서 > 프로그래밍 인터페이스 소개 > ObjectARX >
자동으로 ObjectARX 응용프로그램 로드
개념 요약 참조

일부 ObjectARX 예제에는 AutoCAD를 시작할 때 자동으로 로드되는 ObjectARX 프로그램 파일 리스트가 들어 있는 acad.rx 파일이 포함되어 있습니다.

ASCII 텍스트 형식의 파일을 만드는 문자 편집기나 워드 프로세서로 이 파일을 작성하거나 편집하여 내용을 파일에 추가하거나 삭제함으로써 적절한 ObjectARX 프로그램이 사용되도록 할 수 있습니다. 대안으로 APPLOAD 명령은 파일을 편집하지 않고도 지정된 응용프로그램을 로드하는 시작하기 세트 옵션을 제공합니다.

AutoCAD는 라이브러리 경로에 지정된 순서대로 acad.rx 파일을 검색하기 때문에 각 도면 디렉토리에 다른 acad.rx 파일이 있을 수 있습니다. 따라서 특정 유형의 도면에 특정 ObjectARX 프로그램을 사용할 수 있습니다. 예를 들어, AcadJobs/3d_dwgs라는 디렉토리에 3D 도면을 보관할 수 있습니다. 이 디렉토리가 현재 디렉토리로 설정되어 있으면 acad.rx 파일을 이 디렉토리에 복사하고 다음과 같이 수정할 수 있습니다.

myapp1
otherapp

새로운 acad.rx 파일을 AcadJobs/3d_dwgs 디렉토리에 두고 이 디렉토리가 현재 디렉토리인 상태에서 AutoCAD를 시작하면 새로운 ObjectARX 프로그램이 로드되고 AutoCAD 명령 프롬프트에서 사용할 수 있게 됩니다. 원본 acad.rx 파일이 여전히 AutoCAD 프로그램 파일이 있는 디렉토리에 있기 때문에 acad.rx 파일이 포함되어 있지 않은 다른 디렉토리에서 AutoCAD를 시작하면 기본 acad.rx 파일이 로드됩니다.

arxload 함수를 사용하여 MNL 파일로부터 ObjectARX 프로그램을 로드할 수 있습니다. 이렇게 하면 메뉴 파일이 로드될 때 올바른 메뉴 동작을 위해 필요한 ObjectARX 프로그램이 로드됩니다.

많은 ObjectARX 정의 AutoCAD 명령을 자동 로드할 수도 있습니다. AutoLISP 자동 로드의 개요 와 도움말 시스템의 AutoLISP Reference에서 autoarxload를 참조하십시오. 개발자 도움말을 표시하려면 도움말 메뉴 [image] 추가 리소스 [image] 개발자 도움말을 클릭하십시오.

참고

    • AutoLISP 자동 로드의 개요


자동으로 ObjectARX 응용프로그램 로드 (요약 참조)

ObjectARX 응용프로그램 사용
자동으로 ObjectARX 응용프로그램 로드
.NET의 개요
AutoCAD 2008 사용자화 안내서 > 프로그래밍 인터페이스 소개 > ObjectARX > 자동으로 ObjectARX 응용프로그램 로드 >
자동으로 ObjectARX 응용프로그램 로드
개념 요약 참조

명령

APPLOAD

응용프로그램을 로드하거나 언로드하고 시작할 때 로드할 응용프로그램을 정의합니다.

시스템 변수

항목이 없습니다.

유틸리티

항목이 없습니다.

명령 수정자

항목이 없습니다.


.NET

자동으로 ObjectARX 응용프로그램 로드
프로그래밍 인터페이스 소개
.NET의 개요
AutoCAD 2008 사용자화 안내서 > 프로그래밍 인터페이스 소개 >
.NET

Microsoft .NET Framework를 사용하면 VB. NET나 C# 등의 프로그래밍 언어를 통해 AutoCAD와 상호작용하는 응용프로그램을 작성할 수 있습니다.

이 단원의 항목

  • .NET의 개요
  • AutoCAD에서 관리된 응용프로그램 로드하기

    관리된 응용프로그램을 로드하려면, AutoCAD 명령 프롬프트에 NETLOAD를 입력하고 원하는 DDL파일을 찾아봅니다. 관리된 응용프로그램은 AutoCAD가 존재할 경우에만 언로드됩니다.


.NET의 개요 (개념)

.NET
.NET
AutoCAD에서 관리된 응용프로그램 로드하기
AutoCAD 2008 사용자화 안내서 > 프로그래밍 인터페이스 소개 > .NET >
.NET의 개요
개념 요약 참조

.NET Framework는 Microsoft가 개발한 언어에 상관없는 프로그래밍 환경입니다. 런타임 환경 외에 Framework는 상호작용이 가능하고 안전한 Windows 및 Web 기반의 응용프로그램 개발을 용이하게 하는 클래스 라이브러리를 제공합니다.

AutoCAD는 ObjectARX 관리 래퍼 클래스와 함께 .NET 응용프로그램 개발을 지원합니다. 사용 가능한 관리 래퍼 클래스의 완전한 리스트는 ObjectARX SDK에 있는 ObjectARX 개발자 안내서의 “AutoCAD 관리 클래스 참고” 및 “ObjectARX 관리 래퍼 클래스” 섹션을 참고하십시오. .NET Framework에 대한 자세한 정보는 Microsoft 문서를 참고하십시오

관리 래퍼 클래스는 대부분의 ObjectARX SDK에 제공되며 .NET Framework이 지원하는 모든 언어(예: VB.NET 및 C#)로 응용프로그램을 작성할 수 있게 합니다. 관리된 클래스는 데이터베이스 기능을 구현하며 도면 형식(DWG) 파일을 읽고 쓰는 응용프로그램을 작성할 수 있게 합니다. 또한 명령 프롬프트와 기능 대화상자, AutoCAD 편집기, 게시 및 플로팅 구성요소를 포함하는 AutoCAD 사용자 인터페이스 요소에 액세스할 수 있도록 합니다.


.NET의 개요 (요약 참조)

자동으로 ObjectARX 응용프로그램 로드
.NET의 개요
AutoCAD에서 관리된 응용프로그램 로드하기
AutoCAD 2008 사용자화 안내서 > 프로그래밍 인터페이스 소개 > .NET > .NET의 개요 >
.NET의 개요
개념 요약 참조

명령

항목이 없습니다.

시스템 변수

항목이 없습니다.

유틸리티

항목이 없습니다.

명령 수정자

항목이 없습니다.


AutoCAD에서 관리된 응용프로그램 로드하기 (개념)

.NET의 개요
.NET
쉐이프 및 쉐이프 글꼴
AutoCAD 2008 사용자화 안내서 > 프로그래밍 인터페이스 소개 > .NET >
AutoCAD에서 관리된 응용프로그램 로드하기
개념 요약 참조

관리된 응용프로그램을 로드하려면, AutoCAD 명령 프롬프트에 NETLOAD를 입력하고 원하는 DDL파일을 찾아봅니다. 관리된 응용프로그램은 AutoCAD가 존재할 경우에만 언로드됩니다.


AutoCAD에서 관리된 응용프로그램 로드하기 (요약 참조)

.NET의 개요
AutoCAD에서 관리된 응용프로그램 로드하기
쉐이프 파일의 개요
AutoCAD 2008 사용자화 안내서 > 프로그래밍 인터페이스 소개 > .NET > AutoCAD에서 관리된 응용프로그램 로드하기 >
AutoCAD에서 관리된 응용프로그램 로드하기
개념 요약 참조

명령

NETLOAD

.NET 응용프로그램 로드

시스템 변수

항목이 없습니다.

유틸리티

항목이 없습니다.

명령 수정자

항목이 없습니다.


쉐이프 및 쉐이프 글꼴

AutoCAD에서 관리된 응용프로그램 로드하기
쉐이프 파일의 개요
AutoCAD 2008 사용자화 안내서 >
쉐이프 및 쉐이프 글꼴

도면 기호 및 문자 글꼴로 사용할 쉐이프를 정의할 수 있습니다. 이 절에서는 사용자 자신의 쉐이프와 글꼴 파일을 작성하고 컴파일하는 방법에 대해 설명합니다.

이 단원의 항목

  • 쉐이프 파일의 개요
  • 쉐이프 정의 파일 작성

    AutoCAD 글꼴 및 쉐이프 파일(SHX)은 쉐이프 정의 파일(SHP)에서 컴파일됩니다. ASCII 형식으로 파일을 저장하는 문자 편집기나 워드 프로세서를 사용하여 쉐이프 정의 파일을 작성하거나 수정할 수 있습니다.


쉐이프 파일의 개요 (개념)

쉐이프 및 쉐이프 글꼴
쉐이프 및 쉐이프 글꼴
쉐이프 정의 파일 작성
AutoCAD 2008 사용자화 안내서 > 쉐이프 및 쉐이프 글꼴 >
쉐이프 파일의 개요
개념 절차 요약 참조

쉐이프는 블록과 유사하게 사용되는 객체입니다. 먼저 LOAD 명령을 사용하여 쉐이프 정의가 들어 있는 컴파일된 쉐이프 파일을 로드합니다. 그런 다음 SHAPE 명령을 사용하여 파일의 쉐이프를 도면에 삽입합니다. 추가할 때 각 쉐이프마다 사용할 축척과 회전을 지정할 수 있습니다. AutoCAD SHP 글꼴은 쉐이프 파일의 특수한 형태로, 쉐이프 파일과 동일한 방식으로 정의됩니다

블록은 쉐이프보다 사용과 적용이 쉽고 용도가 다양합니다. 그러나 AutoCAD에서 저장하고 그리기에는 쉐이프가 더 효과적입니다. 간단한 부분을 여러 번 삽입해야 하고 속도가 중요할 경우 사용자 정의 쉐이프가 도움이 됩니다.

쉐이프/글꼴 파일 컴파일

파일 확장명이.shp인 특수한 형식의 텍스트 파일에 쉐이프에 대한 설명을 입력합니다. 이 파일을 작성하려면 ASCII 형식으로 저장할 수 있는 문자 편집기나 워드 프로세서를 사용하여 ASCII 파일을 컴파일합니다. 쉐이프 정의 파일(SHP)을 컴파일하면 컴파일된 쉐이프 파일(SHX)이 생성됩니다.

컴파일된 파일의 이름은 쉐이프 정의 파일의 이름과 같지만 파일 형식은 SHX입니다. 쉐이프 정의 파일이 글꼴을 정의하는 경우, STYLE 명령을 사용하여 문자 스타일을 정의합니다. 그런 다음, 문자 배치 명령(TEXT 또는 MTEXT) 중 하나를 사용하여 도면에 문자를 배치합니다. 쉐이프 정의 파일이 쉐이프를 정의하는 경우, LOAD 명령을 사용하여 도면에 쉐이프 파일을 로드합니다. 그런 다음 SHAPE 명령을 사용하여 각 쉐이프를 도면에 배치합니다(INSERT 명령과 개념이 유사함).

PostScript 글꼴 컴파일

AutoCAD에서 Type 1 PostScript 글꼴을 사용하려면 먼저 해당 글꼴을 AutoCAD 쉐이프 파일로 컴파일해야 합니다. COMPILE 명령은 입력으로 SHP 및 PFB 파일을 둘 다 허용하며 SHX 파일을 생성합니다. 컴파일된 PostScript 글꼴 버전은 디스크 공간을 많이 차지할 수 있으므로 자주 사용하는 글꼴만 컴파일하십시오.

AutoCAD에서 모든 Type 1 글꼴을 컴파일하고 로드할 수는 없습니다. AutoCAD의 PostScript 글꼴 기능은 Adobe 글꼴의 하위 세트를 처리하는 데 사용됩니다. PostScript 글꼴을 컴파일하는 동안 오류가 발생하면 그로 인해 SHX 파일(생성된 경우)이 AutoCAD로 로드되지 않을 수 있습니다.

Adobe Type 1 글꼴 형식에 대한 자세한 정보는 Adobe Type1 글꼴 형식 버전 1.1을 참고하십시오. 이러한 글꼴을 구입 및 설치했을 경우 AutoCAD에서 이러한 글꼴 사용을 시작할 수 있습니다.

주사용하는 PostScript 글꼴과 함께 제공된 저작권 내용을 잘 읽어 보십시오. 일반적으로 컴파일한 글꼴의 SHX 형식에도 동일한 저작권 제한 사항이 적용됩니다.


쉐이프 또는 글꼴 파일을 컴파일하려면 (절차)

스크립트로 슬라이드 쇼 실행
쉐이프 파일의 개요
쉐이프 정의 파일 작성
AutoCAD 2008 사용자화 안내서 > 쉐이프 및 쉐이프 글꼴 > 쉐이프 파일의 개요 >
쉐이프 또는 글꼴 파일을 컴파일하려면
개념 절차 요약 참조

쉐이프 또는 글꼴 파일을 컴파일하려면

  • 명령 프롬프트에서 compile을 입력합니다.

쉐이프 파일 선택 대화상자에서 쉐이프 정의 파일(SHP)이나 PostScript 글꼴 파일(PFB)을 선택할 수 있습니다. 파일 이름을 선택하면 컴파일이 시작됩니다. AutoCAD에서 쉐이프 설명에 오류가 있음을 발견한 경우, 오류의 유형과 행 번호를 알리는 메시지가 표시됩니다. 컴파일이 끝나면 다음 메시지가 표시됩니다.

컴파일이 성공적으로 완료됨.

출력 파일 name.shx는 nnn바이트를 포함합니다.


쉐이프 파일의 개요 (요약 참조)

AutoCAD에서 관리된 응용프로그램 로드하기
쉐이프 파일의 개요
쉐이프 설명
AutoCAD 2008 사용자화 안내서 > 쉐이프 및 쉐이프 글꼴 > 쉐이프 파일의 개요 >
쉐이프 파일의 개요
개념 절차 요약 참조

명령

COMPILE

쉐이프 파일과 PostScript 글꼴 파일을 SHX 파일로 컴파일합니다.

LOAD

쉐이프를 SHAPE 명령에 사용할 수 있게 만듭니다.

SHAPE

LOAD를 사용하여 로드된 쉐이프 파일의 쉐이프를 삽입합니다.

시스템 변수

항목이 없습니다.

유틸리티

항목이 없습니다.

명령 수정자

항목이 없습니다.


쉐이프 정의 파일 작성

쉐이프 파일의 개요
쉐이프 및 쉐이프 글꼴
쉐이프 설명
AutoCAD 2008 사용자화 안내서 > 쉐이프 및 쉐이프 글꼴 >
쉐이프 정의 파일 작성

AutoCAD 글꼴 및 쉐이프 파일(SHX)은 쉐이프 정의 파일(SHP)에서 컴파일됩니다. ASCII 형식으로 파일을 저장하는 문자 편집기나 워드 프로세서를 사용하여 쉐이프 정의 파일을 작성하거나 수정할 수 있습니다.

이 단원의 항목

  • 쉐이프 설명

    AutoCAD 글꼴 및 쉐이프 파일(SHX)은 쉐이프 정의 파일(SHP)에서 컴파일됩니다. ASCII 형식으로 파일을 저장하는 문자 편집기나 워드 프로세서를 사용하여 쉐이프 정의 파일을 작성하거나 수정할 수 있습니다.

  • 벡터 길이 및 방향 코드

    간단한 쉐이프 지정 바이트에는 하나의 지정 바이트로 인코드된 벡터 길이 및 방향이 포함됩니다.

  • 특수 코드

    지정 바이트는 벡터를 정의하는 것 외에도 특수 코드를 사용하여 추가 양식을 작성하고 특정 동작을 지정할 수 있습니다.

  • 문자 글꼴 설명

    문자 글꼴에는 글꼴에 관한 정보를 제공하는 특수 쉐이프 번호 0이 포함되어야 합니다.

  • 예제 파일

    이 항목에는 AutoCAD와 함께 제공된 글꼴 문자를 확장하는 데 도움을 주는 샘플 파일이 있습니다.

  • 큰 글꼴 설명

    일본어 같은 일부 언어에서는 수천 가지의 비 ASCII 문자 글꼴을 사용합니다. 도면에 이러한 문자를 포함하기 위해 AutoCAD는 큰 글꼴 파일이라는 쉐이프 정의 파일의 특수 양식을 지원합니다.

  • 유니코드 글꼴 설명

    큰 문자 세트로 인해 하나의 유니코드 글꼴이 모든 언어와 플랫폼을 지원할 수 있습니다. 유니코드 쉐이프 정의 파일은 실제로 일반 AutoCAD 쉐이프 정의 파일과 형식과 구문이 동일합니다.

  • SHX 파일의 위 첨자 및 아래 첨자

    쉐이프 정의 파일을 수정하여 위 첨자와 아래 첨자가 표시되도록 기능을 향상시킬 수 있습니다.


쉐이프 설명 (개념)

쉐이프 정의 파일 작성
쉐이프 정의 파일 작성
벡터 길이 및 방향 코드
AutoCAD 2008 사용자화 안내서 > 쉐이프 및 쉐이프 글꼴 > 쉐이프 정의 파일 작성 >
쉐이프 설명
개념 요약 참조

AutoCAD 글꼴 및 쉐이프 파일(SHX)은 쉐이프 정의 파일(SHP)에서 컴파일됩니다. ASCII 형식으로 파일을 저장하는 문자 편집기나 워드 프로세서를 사용하여 쉐이프 정의 파일을 작성하거나 수정할 수 있습니다.

각 쉐이프나 문자에 대한 쉐이프 설명 구문은 해당 쉐이프 설명에 대한(쉐이프 또는 글꼴의) 마지막 사용 여부에 관계없이 동일합니다. 쉐이프 정의 파일이 글꼴 파일로 사용될 경우, 파일의 첫 번째 항목은 파일 내의 쉐이프가 아닌 글꼴 자체를 설명합니다. 이 초기 항목에서 쉐이프를 설명할 경우, 그 파일은 쉐이프 파일로 사용됩니다.

사용자 자신의 쉐이프 정의를 작성할 수 있다는 것은 매우 유용한 일이지만 배우기가 복잡하므로 인내심이 필요합니다.

쉐이프 정의 파일의 각 행은 최대 128자까지 포함할 수 있습니다. 더 긴 행은 컴파일되지 않습니다. AutoCAD는 빈 행과 세미콜론 오른쪽에 있는 문자를 무시하므로 쉐이프 정의 파일에 주석을 포함할 수 있습니다.

각 쉐이프 설명에는 다음과 같은 형식의 헤더 행이 있으며, 그 다음에 쉼표로 구분되고 0으로 종료되는 지정 바이트가 포함된 하나 이상의 행이 옵니다.

*shapenumber,defbytes,shapename
specbyte1,specbyte2,specbyte3,...,0

다음 리스트는 쉐이프 설명의 필드에 대해 설명합니다.

shapenumber

파일별로 고유한 1과 258 사이의 숫자(유니코드 글꼴의 경우 최대 32768)로, 앞에 별표(*)가 붙습니다. 비유니코드 글꼴 파일은 기호 식별자 Degree_Sign, Plus_Or_Minus_Sign 및 Diameter_Symbol에 대해 쉐이프 번호 256, 257 및 258을 사용합니다. 유니코드 글꼴의 경우, 이러한 그림 문자는 “Latin Extended-A” 부세트의 일부이며 U+00B0, U+00B1 및 U+2205 쉐이프 번호에 나타납니다.

문자 글꼴(각 문자에 대한 쉐이프 정의를 포함하는 파일)에는 ASCII 코드의 각 문자 값에 해당하는 특정 숫자가 필요하며, 다른 쉐이프에는 어떠한 숫자든지 할당할 수 있습니다.

defbytes

종료 0을 포함하여 쉐이프를 설명하는 데 필요한 데이터 바이트 수(specbytes)입니다. 한계는 쉐이프당 2,000바이트입니다.

shapename

쉐이프 이름입니다. 쉐이프 이름에는 대문자를 사용해야 합니다. 소문자로 된 이름은 무시되며, 보통 소문자 이름은 글꼴 쉐이프 정의에 레이블을 부착할 때 사용됩니다.

specbyte

쉐이프 지정 바이트입니다. 각 지정 바이트는 벡터 길이와 방향 또는 특수 코드 번호 중 하나를 정의하는 코드입니다. 지정 바이트는 쉐이프 정의 파일에서 10진수나 16진수 값으로 표시할 수 있습니다. 다른 많은 쉐이프 정의 파일이 그러하듯 이 섹션의 예제에서도 10진수와 16진수 지정 바이트 값을 모두 사용합니다. 지정 바이트의 첫 번째 문자가 0이면 그 다음 두 문자는 16진수 값으로 해석됩니다.


쉐이프 설명 (요약 참조)

쉐이프 파일의 개요
쉐이프 설명
벡터 길이 및 방향 코드
AutoCAD 2008 사용자화 안내서 > 쉐이프 및 쉐이프 글꼴 > 쉐이프 정의 파일 작성 > 쉐이프 설명 >
쉐이프 설명
개념 요약 참조

명령

LOAD

쉐이프를 SHAPE 명령에 사용할 수 있게 만듭니다.

SHAPE

LOAD를 사용하여 로드된 쉐이프 파일의 쉐이프를 삽입합니다.

시스템 변수

항목이 없습니다.

유틸리티

항목이 없습니다.

명령 수정자

항목이 없습니다.


벡터 길이 및 방향 코드 (개념)

쉐이프 설명
쉐이프 정의 파일 작성
특수 코드
AutoCAD 2008 사용자화 안내서 > 쉐이프 및 쉐이프 글꼴 > 쉐이프 정의 파일 작성 >
벡터 길이 및 방향 코드
개념 요약 참조

간단한 쉐이프 지정 바이트에는 하나의 지정 바이트로 인코드된 벡터 길이 및 방향이 포함됩니다.

간단한 쉐이프 지정 바이트에는 하나의 지정 바이트(하나의 specbyte 필드)로 인코드된 벡터 길이 및 방향이 포함됩니다. 각 벡터 길이와 방향 코드는 3자리 문자열입니다. 첫 번째 문자는 0이어야 하며, 이는 다음 두 문자가 16진수 값으로 해석됨을 AutoCAD에 알려 줍니다. 두 번째 문자는 벡터의 길이를 단위로 지정합니다. 유효한 16진수 값의 범위는 1(1단위 길이)에서 F(15단위 길이)까지입니다. 세 번째 문자는 벡터의 방향을 지정합니다. 다음 그림은 방향 코드를 보여줍니다.

앞의 그림에 있는 모든 벡터에는 동일한 길이 지정이 사용되었습니다. 대각선 벡터는 가장 가까운 직교 벡터의 X 또는 Y 변위에 맞게 신축됩니다. 이것은 AutoCAD에서 스냅 모눈의 동작과 유사합니다.

다음 예는 임의로 쉐이프 번호 230이 지정된 DBOX라는 쉐이프를 구성합니다.

*230,6,DBOX
014,010,01C,018,012,0

지정 바이트의 선행 순서는 왼쪽 아래에서 오른쪽 위로 실행하는 대각선이 있는 1단위 높이 x 1단위 폭의 상자를 정의합니다 파일을 dbox.shp로 저장한 후 COMPILE 명령을 사용하여 dbox.shx 파일을 생성합니다. LOAD 명령을 사용하여 이 정의를 포함하는 쉐이프 파일을 로드한 다음 SHAPE 명령을 다음과 같이 사용합니다.

명령: shape

쉐이프 번호 입력 또는 [?]: dbox

삽입점 지정: 1,1

높이 지정 <현재값>: 2

회전 각도 지정 <현재값>: 0

결과적으로 다음 그림과 같은 쉐이프가 만들어집니다.


벡터 길이 및 방향 코드 (요약 참조)

쉐이프 설명
벡터 길이 및 방향 코드
코드 0, 1 및 2: 쉐이프의 끝 및 그리기 모드 조정
AutoCAD 2008 사용자화 안내서 > 쉐이프 및 쉐이프 글꼴 > 쉐이프 정의 파일 작성 > 벡터 길이 및 방향 코드 >
벡터 길이 및 방향 코드
개념 요약 참조

명령

LOAD

쉐이프를 SHAPE 명령에 사용할 수 있게 만듭니다.

SHAPE

LOAD를 사용하여 로드된 쉐이프 파일의 쉐이프를 삽입합니다.

시스템 변수

항목이 없습니다.

유틸리티

항목이 없습니다.

명령 수정자

항목이 없습니다.


특수 코드

벡터 길이 및 방향 코드
쉐이프 정의 파일 작성
코드 0, 1 및 2: 쉐이프의 끝 및 그리기 모드 조정
AutoCAD 2008 사용자화 안내서 > 쉐이프 및 쉐이프 글꼴 > 쉐이프 정의 파일 작성 >
특수 코드

지정 바이트는 벡터를 정의하는 것 외에도 특수 코드를 사용하여 추가 양식을 작성하고 특정 동작을 지정할 수 있습니다.

지정 바이트는 벡터를 정의하는 것 외에도 특수 코드를 사용하여 추가 양식을 작성하고 특정 동작을 지정할 수 있습니다. 특수 코드를 사용하려면 3자리 문자열(벡터 길이 지정)에서 두 번째 문자가 0이어야 합니다. 그렇지 않으면 코드 번호만 지정할 수 있습니다. 예를 들어, 008과 8은 모두 유효한 지정입니다.

지정 바이트 코드
코드 | 설명
000 | 쉐이프 정의의 끝
001 | 그리기 모드 활성화(펜 다운)
002 | 그리기 모드 비활성화(펜 업)
003 | 벡터 길이를 다음 바이트로 나누기
004 | 벡터 길이와 다음 바이트를 곱하기
005 | 스택에 현재 위치 넣기
006 | 스택에서 현재 위치 팝
007 | 다음 바이트로 제공된 하위 세이프 번호 그리기
008 | 다음 두 바이트로 제공된 X-Y 변위
009 | (0,0)으로 종결된 다중 X-Y 변위
00A | 다음 두 바이트로 정의된 8분원 호
00B | 다음 다섯 바이트로 정의된 분수 호
00C | X-Y 변위 및 돌출로 정의된 호
00D | 다중 돌출 지정 호
00E | 수직 문자인 경우에만 다음 명령 처리

이 단원의 항목

  • 코드 0, 1 및 2: 쉐이프의 끝 및 그리기 모드 조정
  • 코드 3 및 4: 크기 조정
  • 코드 5 및 6: 위치 저장/복원
  • 코드 7: 하위 쉐이프
  • 코드 8 및 9: X-Y 변위
  • 코드 00A: 8분원 호
  • 코드 00B: 분수 호
  • 코드 00C 및 00D: 돌출 지정 호
  • 코드 00E: 플래그 세로 문자 명령


코드 0, 1 및 2: 쉐이프의 끝 및 그리기 모드 조정 (개념)

특수 코드
특수 코드
코드 3 및 4: 크기 조정
AutoCAD 2008 사용자화 안내서 > 쉐이프 및 쉐이프 글꼴 > 쉐이프 정의 파일 작성 > 특수 코드 >
코드 0, 1 및 2: 쉐이프의 끝 및 그리기 모드 조정
개념 요약 참조

코드 0은 쉐이프 정의의 끝을 표시합니다.

코드 1과 2는 그리기 모드를 조정합니다. 그리기는 각 쉐이프가 시작할 때 활성화됩니다. 그리기 모드가 켜지면(코드 1) 벡터가 선을 그립니다. 그리기 모드가 꺼지면(코드 2) 벡터가 그리지 않고 새로운 위치로 이동합니다.


코드 0, 1 및 2: 쉐이프의 끝 및 그리기 모드 조정 (요약 참조)

벡터 길이 및 방향 코드
코드 0, 1 및 2: 쉐이프의 끝 및 그리기 모드 조정
코드 3 및 4: 크기 조정
AutoCAD 2008 사용자화 안내서 > 쉐이프 및 쉐이프 글꼴 > 쉐이프 정의 파일 작성 > 특수 코드 > 코드 0, 1 및 2: 쉐이프의 끝 및 그리기 모드 조정 >
코드 0, 1 및 2: 쉐이프의 끝 및 그리기 모드 조정
개념 요약 참조

명령

LOAD

쉐이프를 SHAPE 명령에 사용할 수 있게 만듭니다.

SHAPE

LOAD를 사용하여 로드된 쉐이프 파일의 쉐이프를 삽입합니다.

시스템 변수

항목이 없습니다.

유틸리티

항목이 없습니다.

명령 수정자

항목이 없습니다.


코드 3 및 4: 크기 조정 (개념)

코드 0, 1 및 2: 쉐이프의 끝 및 그리기 모드 조정
특수 코드
코드 5 및 6: 위치 저장/복원
AutoCAD 2008 사용자화 안내서 > 쉐이프 및 쉐이프 글꼴 > 쉐이프 정의 파일 작성 > 특수 코드 >
코드 3 및 4: 크기 조정
개념 요약 참조

코드 3과 4는 각 벡터의 상대 크기를 조정합니다. SHAPE 명령으로 지정된 높이는 처음에 단일 직교 벡터(방향 0, 4, 8 또는 C)의 길이로 간주됩니다. 코드 3는 벡터 길이를 다음 바이트로 나눕니다. 코드 4는 다중 벡터 길이를 다음 바이트로 나눕니다. 코드 3과 4 뒤에는 정수 축척 비율(1~255)이 포함된 지정 바이트가 옵니다. 쉐이프 높이로 전체 쉐이프 크기를 지정하고 10 벡터 길이를 사용하여 쉐이프를 그리려는 경우 3,10을 사용하여 높이 지정을 축척할 수 있습니다. 쉐이프 내에서 축척 비율은 누적됩니다. 즉, 2를 곱하고 다시 6을 곱하면 축척 비율이 12가 됩니다. 보통 쉐이프 끝에서 축척 비율의 효과는 반대로 나타납니다(특히, 부 쉐이프와 문자 글꼴 쉐이프의 경우). AutoCAD는 축척 비율을 재설정하지 않습니다.


코드 3 및 4: 크기 조정 (요약 참조)

코드 0, 1 및 2: 쉐이프의 끝 및 그리기 모드 조정
코드 3 및 4: 크기 조정
코드 5 및 6: 위치 저장/복원
AutoCAD 2008 사용자화 안내서 > 쉐이프 및 쉐이프 글꼴 > 쉐이프 정의 파일 작성 > 특수 코드 > 코드 3 및 4: 크기 조정 >
코드 3 및 4: 크기 조정
개념 요약 참조

명령

LOAD

쉐이프를 SHAPE 명령에 사용할 수 있게 만듭니다.

SHAPE

LOAD를 사용하여 로드된 쉐이프 파일의 쉐이프를 삽입합니다.

시스템 변수

항목이 없습니다.

유틸리티

항목이 없습니다.

명령 수정자

항목이 없습니다.


코드 5 및 6: 위치 저장/복원 (개념)

코드 3 및 4: 크기 조정
특수 코드
코드 7: 하위 쉐이프
AutoCAD 2008 사용자화 안내서 > 쉐이프 및 쉐이프 글꼴 > 쉐이프 정의 파일 작성 > 특수 코드 >
코드 5 및 6: 위치 저장/복원
개념 요약 참조

이후의 쉐이프 점에서 복귀할 수 있도록 쉐이프를 그리는 동안 코드 5가 현재의 좌표 위치를 넣었다가(저장) 코드 6이 꺼냅니다(복원). 넣은 것은 모두 꺼내야 합니다. 위치 스택의 깊이는 4 위치에 불과합니다. 너무 많이 넣었거나 넣은 만큼 꺼내기 작업을 하지 않으면 스택 오버플로우가 발생하여 쉐이프를 그릴 때 다음 메시지가 표시됩니다.

Position stack overflow in shape nnn

마찬가지로 스택에 넣은 위치보다 더 많은 위치를 꺼내려고 하면 쉐이프를 그릴 때 다음 메시지가 표시됩니다.

Position stack underflow in shape nnn


코드 5 및 6: 위치 저장/복원 (요약 참조)

코드 3 및 4: 크기 조정
코드 5 및 6: 위치 저장/복원
코드 7: 하위 쉐이프
AutoCAD 2008 사용자화 안내서 > 쉐이프 및 쉐이프 글꼴 > 쉐이프 정의 파일 작성 > 특수 코드 > 코드 5 및 6: 위치 저장/복원 >
코드 5 및 6: 위치 저장/복원
개념 요약 참조

명령

LOAD

쉐이프를 SHAPE 명령에 사용할 수 있게 만듭니다.

SHAPE

LOAD를 사용하여 로드된 쉐이프 파일의 쉐이프를 삽입합니다.

시스템 변수

항목이 없습니다.

유틸리티

항목이 없습니다.

명령 수정자

항목이 없습니다.


코드 7: 하위 쉐이프 (개념)

코드 5 및 6: 위치 저장/복원
특수 코드
코드 8 및 9: X-Y 변위
AutoCAD 2008 사용자화 안내서 > 쉐이프 및 쉐이프 글꼴 > 쉐이프 정의 파일 작성 > 특수 코드 >
코드 7: 하위 쉐이프
개념 요약 참조

코드 7은 다음 바이트가 제공하는 하위 쉐이프 번호를 그립니다. 비유니코드 글꼴의 경우, 코드 7 뒤의 지정 바이트는 1에서 255까지의 쉐이프 번호입니다. 유니코드 글꼴의 경우에는 코드 7 뒤에 1에서 65535까지의 유니코드 쉐이프 번호가 옵니다. 유니코드 쉐이프 번호는 2바이트로 계산됩니다. 유니코드와 비유니코드 글꼴의 차이점에 대한 내용은 유니코드 글꼴 설명을 참고하십시오. 이때 같은 쉐이프 파일에서 해당 번호의 쉐이프가 그려집니다. 새 쉐이프의 경우에는 그리기 모드가 재설정되지 않습니다. 하위 쉐이프가 완료되면 현재 쉐이프 그리기가 계속 진행됩니다.


코드 7: 하위 쉐이프 (요약 참조)

코드 5 및 6: 위치 저장/복원
코드 7: 하위 쉐이프
코드 8 및 9: X-Y 변위
AutoCAD 2008 사용자화 안내서 > 쉐이프 및 쉐이프 글꼴 > 쉐이프 정의 파일 작성 > 특수 코드 > 코드 7: 하위 쉐이프 >
코드 7: 하위 쉐이프
개념 요약 참조

명령

LOAD

쉐이프를 SHAPE 명령에 사용할 수 있게 만듭니다.

SHAPE

LOAD를 사용하여 로드된 쉐이프 파일의 쉐이프를 삽입합니다.

시스템 변수

항목이 없습니다.

유틸리티

항목이 없습니다.

명령 수정자

항목이 없습니다.


코드 8 및 9: X-Y 변위 (개념)

코드 7: 하위 쉐이프
특수 코드
코드 00A: 8분원 호
AutoCAD 2008 사용자화 안내서 > 쉐이프 및 쉐이프 글꼴 > 쉐이프 정의 파일 작성 > 특수 코드 >
코드 8 및 9: X-Y 변위
개념 요약 참조

보통 벡터 지정 바이트는 사전에 정의된 16개의 방향으로만 그리며 가장 긴 길이는 15입니다. 이러한 제한 사항으로 쉐이프를 효율적으로 정의할 수 있지만, 간혹 이러한 효율성에도 한계가 있습니다. 코드 8과 9를 사용하면 X-Y 변위를 사용하여 비표준 벡터를 그릴 수 있습니다. 코드 8은 다음에 오는 2바이트가 제공하는 X-Y 변위를 지정합니다. 코드 8 뒤에는 다음 형식의 두 가지 지정 바이트가 와야 합니다.

8,X-변위,Y-변위

X-Y 변위의 범위는 –128에서 +127까지입니다. 앞의 +는 선택적이며 괄호를 사용하여 보기 편하게 만들 수 있습니다. 다음 보기에서는 왼쪽에 10 단위, 위쪽에 3 단위를 그리는(또는 이동하는) 벡터가 만들어졌습니다.

8,(-10,3)

2 변위 지정 바이트 후에 쉐이프는 법선 벡터 모드로 복귀합니다.

코드 9를 사용하여 비표준 벡터 순서를 그릴 수 있습니다. 코드 9는 개수에 관계없이 X-Y 변위 쌍을 지정합니다. 코드 순서는 (0,0) 쌍에 의해 종료됩니다. 다음 보기에서는 3개의 비표준 벡터를 그리고 법선 벡터 모드로 복귀합니다.

9,(3,1),(3,2),(2,-3),(0,0)

AutoCAD가 법선 벡터 또는 그 뒤에 오는 특수 코드를 인식하려면 X-Y 변위 쌍의 순서를 (0,0) 쌍으로 종료해야 합니다.


코드 8 및 9: X-Y 변위 (요약 참조)

코드 7: 하위 쉐이프
코드 8 및 9: X-Y 변위
코드 00A: 8분원 호
AutoCAD 2008 사용자화 안내서 > 쉐이프 및 쉐이프 글꼴 > 쉐이프 정의 파일 작성 > 특수 코드 > 코드 8 및 9: X-Y 변위 >
코드 8 및 9: X-Y 변위
개념 요약 참조

명령

LOAD

쉐이프를 SHAPE 명령에 사용할 수 있게 만듭니다.

SHAPE

LOAD를 사용하여 로드된 쉐이프 파일의 쉐이프를 삽입합니다.

시스템 변수

항목이 없습니다.

유틸리티

항목이 없습니다.

명령 수정자

항목이 없습니다.


코드 00A: 8분원 호 (개념)

코드 8 및 9: X-Y 변위
특수 코드
코드 00B: 분수 호
AutoCAD 2008 사용자화 안내서 > 쉐이프 및 쉐이프 글꼴 > 쉐이프 정의 파일 작성 > 특수 코드 >
코드 00A: 8분원 호
개념 요약 참조

특수 코드 00A(또는 10)는 다음에 오는 2개의 지정 바이트를 사용하여 호를 정의합니다. 하나 이상의 45도 8분원에 걸쳐 있으며, 8분원 경계에서 시작되고 끝나기 때문에 이를 8분원 호라고 합니다. 8분원은 다음 그림과 같이 3시 위치에서 시계 반대 방향으로 번호가 매겨집니다.

호 지정은 다음과 같습니다.

10,radius,(–)0SC

radius는 1에서 255 사이의 값 중 어느 값이든 될 수 있습니다. 두 번째 지정 바이트는 호의 방향(양수일 경우 시계 반대 방향, 음수일 경우 시계 방향임), 호의 시작 8분원(s, 0~7 사이의 값) 및 걸쳐진 8분원 수(c, 0~7 사이의 값. 0은 8개의 8분원 또는 전체 원임)를 나타냅니다. 읽기 쉽게 하기 위해 괄호를 사용할 수 있습니다. 예를 들어, 다음과 같은 쉐이프 정의 단편을 고려해 보십시오.

...012,10,(1,-032),01E,...

이 코드는 다음 그림처럼 오른쪽 위로 1단위 벡터를 그리고, 8분원 3(두 개의 8분원에 대해 1단위 반지름)에서 시계 방향의 호를 그린 다음, 오른쪽 아래로 1단위 벡터를 그립니다.


코드 00A: 8분원 호 (요약 참조)

코드 8 및 9: X-Y 변위
코드 00A: 8분원 호
코드 00B: 분수 호
AutoCAD 2008 사용자화 안내서 > 쉐이프 및 쉐이프 글꼴 > 쉐이프 정의 파일 작성 > 특수 코드 > 코드 00A: 8분원 호 >
코드 00A: 8분원 호
개념 요약 참조

명령

LOAD

쉐이프를 SHAPE 명령에 사용할 수 있게 만듭니다.

SHAPE

LOAD를 사용하여 로드된 쉐이프 파일의 쉐이프를 삽입합니다.

시스템 변수

항목이 없습니다.

유틸리티

항목이 없습니다.

명령 수정자

항목이 없습니다.


코드 00B: 분수 호 (개념)

코드 00A: 8분원 호
특수 코드
코드 00C 및 00D: 돌출 지정 호
AutoCAD 2008 사용자화 안내서 > 쉐이프 및 쉐이프 글꼴 > 쉐이프 정의 파일 작성 > 특수 코드 >
코드 00B: 분수 호
개념 요약 참조

특수 코드 00B(11)는 반드시 8분원 경계에서 시작되거나 끝나지는 않는 호를 그립니다. 정의에서는 5개의 지정 바이트를 사용합니다.

11,start_offset,end_offset,high_radius,radius,(-)0SC

start_offset 및 end_offset는 호가 8분원 경계에서 얼마나 떨어진 위치에서 시작하고 끝나는지 나타냅니다. high_radius는 최상위 8비트를 나타내며 radius가 255 단위보다 크지 않으면 이 값은 0입니다. high_radius 값에 256를 곱해서 그 값을 radius 값에 더하면 255보다 큰 호 반지름이 생성됩니다. 8분원 호 지정의 radius 및 끝 지정 바이트(앞에서 설명한 코드 00A)는 같습니다.

시작 8분원 경계(45도의 배수)와 호 시작점 사이의 각도 차이를 계산하면startoffset이 결정됩니다. 그런 다음, 이 차이 값에 256를 곱하고 45로 나누십시오. 호가 8분원 경계에서 시작되면 start offset은 0입니다.

end offset도 비슷한 방법으로 계산되지만 호의 끝을 교차하는 마지막 8분원 경계를 기준으로 하는 각도를 사용해야 합니다. 호가 8분원 경계에서 끝나면 end offset은 0입니다.

예들 들어, 반지름이 3 단위인 55도에서 95도까지의 분수 호는 다음과 같이 코드화됩니다.

11,(56,28,0,3,012)

다음은 이에 대한 설명입니다.

start_offset = 56 이므로 ((55 - 45) * 256 / 45) = 56
end_offset = 28 이므로 ((95 - 90) * 256 / 45) = 28
high_radius = 0 이므로 (radius < 255)
radius = 3
starting octant = 1 호가 45도 8분원에서 시작하므로
ending octant = 2 호가 90도 8분원에서 끝나므로


코드 00B: 분수 호 (요약 참조)

코드 00A: 8분원 호
코드 00B: 분수 호
코드 00C 및 00D: 돌출 지정 호
AutoCAD 2008 사용자화 안내서 > 쉐이프 및 쉐이프 글꼴 > 쉐이프 정의 파일 작성 > 특수 코드 > 코드 00B: 분수 호 >
코드 00B: 분수 호
개념 요약 참조

명령

LOAD

쉐이프를 SHAPE 명령에 사용할 수 있게 만듭니다.

SHAPE

LOAD를 사용하여 로드된 쉐이프 파일의 쉐이프를 삽입합니다.

시스템 변수

항목이 없습니다.

유틸리티

항목이 없습니다.

명령 수정자

항목이 없습니다.


코드 00C 및 00D: 돌출 지정 호 (개념)

코드 00B: 분수 호
특수 코드
코드 00E: 플래그 세로 문자 명령
AutoCAD 2008 사용자화 안내서 > 쉐이프 및 쉐이프 글꼴 > 쉐이프 정의 파일 작성 > 특수 코드 >
코드 00C 및 00D: 돌출 지정 호
개념 요약 참조

특수 코드 00C와 00D(12와 13)는 쉐이프 설명에 호 세그먼트를 포함시키기 위한 다른 메커니즘을 제공합니다. 이러한 코드는 X-Y 변위를 지정할 수 있다는 점에서 코드 8 및 9와 비슷합니다. 그러나 코드 00C와 00D는 변위 벡터에 돌출 비율을 적용하여 호를 그립니다. 코드 00C는 하나의 호 세그먼트를 그리는 반면, 코드 00D는 (0,0) 변위로 종료될 때까지 다중 호 세그먼트(polyarcs)를 그립니다.

코드 00C 뒤에는 호에 대해 설명하는 3바이트가 와야 합니다.

0C,X-변위,Y-변위,돌출

호의 곡률을 지정하는 X 및 Y 변위와 돌출의 범위는 둘 다 -127에서 +127까지입니다. 변위로 지정된 선 세그먼트의 길이가 D이고, 이 세그먼트의 중간 점에서 수직 거리의 높이가 H인 경우, 돌출의 크기는 ((2* H / D) * 127)입니다. 현재 위치에서 새 위치까지 호가 시계 방향으로 그려진 경우, 부호는 음수입니다.

반원은 돌출 127(또는 –127)을 가지며, 이러한 코드를 사용하여 단일 호 세그먼트로 나타낼 수 있는 가장 큰 호입니다(더 큰 호는 두 개의 연속 호 세그먼트를 사용함). 돌출 지정 0은 유효하며 직선 세그먼트를 나타냅니다. 그러나 직선 세그먼트에 코드 8을 사용하면 바이트가 쉐이프 설명에 저장된다는 점을 주의하십시오.

폴리호 코드(00D 또는 13) 뒤에는 0 또는 추가로 3중 호 세그먼트가 오며 (0,0) 변위로 종료됩니다. 마지막 변위 다음에는 돌출이 지정되지 않음을 주의하십시오. 예를 들어, 문자 S는 다음 순서로 정의될 수 있습니다.

13,(0,5,127),(0,5,-127),(0,0)

0 돌출 세그먼트는 폴리호 내에서 직선 세그먼트를 나타내는 데 유용하며, 폴리호를 종료하고 하나의 직선 세그먼트를 삽입한 다음 다른 폴리호를 시작하는 것보다 훨씬 효과적입니다.

호 세그먼트 및 폴리호 정의에서는 숫자 –128을 사용할 수 없습니다.


코드 00C 및 00D: 돌출 지정 호 (요약 참조)

코드 00B: 분수 호
코드 00C 및 00D: 돌출 지정 호
코드 00E: 플래그 세로 문자 명령
AutoCAD 2008 사용자화 안내서 > 쉐이프 및 쉐이프 글꼴 > 쉐이프 정의 파일 작성 > 특수 코드 > 코드 00C 및 00D: 돌출 지정 호 >
코드 00C 및 00D: 돌출 지정 호
개념 요약 참조

명령

LOAD

쉐이프를 SHAPE 명령에 사용할 수 있게 만듭니다.

SHAPE

LOAD를 사용하여 로드된 쉐이프 파일의 쉐이프를 삽입합니다.

시스템 변수

항목이 없습니다.

유틸리티

항목이 없습니다.

명령 수정자

항목이 없습니다.


코드 00E: 플래그 세로 문자 명령 (개념)

코드 00C 및 00D: 돌출 지정 호
특수 코드
문자 글꼴 설명
AutoCAD 2008 사용자화 안내서 > 쉐이프 및 쉐이프 글꼴 > 쉐이프 정의 파일 작성 > 특수 코드 >
코드 00E: 플래그 세로 문자 명령
개념 요약 참조

특수 코드 00E(14)는 글꼴이 가로와 세로 방향 모두에서 사용되는 양방향 문자 글꼴 설명에서만 사용됩니다. 이 특수 코드가 문자 정의에 사용되면 방향에 따라 그 다음 코드를 처리하거나 건너뜁니다. 세로 방향이면 다음 코드를 처리하고, 가로 방향이면 다음 코드를 건너뜁니다.

가로 문자에서 각 문자의 시작점은 기준선의 왼쪽 끝입니다. 세로 문자에서 시작점은 문자의 맨 위쪽 중심으로 간주됩니다. 각 문자의 끝에는 보통 펜 업 세그먼트가 그려져 그 다음 문자의 시작점을 지정합니다. 가로 문자에서 시작점은 오른쪽이고, 세로 문자에서는 아래쪽입니다. 특수 코드 00E(14)는 주로 시작점과 끝점의 차이를 조절하는 데 사용되며, 동일한 문자 쉐이프 정의를 가로와 세로로 모두 사용할 수 있게 합니다. 예를 들어, 다음과 같은 대문자 D의 정의를 가로 또는 세로 문자에 사용할 수 있습니다.

*68,22,ucd
2,14,8,(-2, 6),1,030,012,044,016,038,2,010,1,06C,2,050,
14,8,(-4,-3),0


코드 00E: 플래그 세로 문자 명령 (요약 참조)

코드 00C 및 00D: 돌출 지정 호
코드 00E: 플래그 세로 문자 명령
문자 글꼴 설명
AutoCAD 2008 사용자화 안내서 > 쉐이프 및 쉐이프 글꼴 > 쉐이프 정의 파일 작성 > 특수 코드 > 코드 00E: 플래그 세로 문자 명령 >
코드 00E: 플래그 세로 문자 명령
개념 요약 참조

명령

LOAD

쉐이프를 SHAPE 명령에 사용할 수 있게 만듭니다.

SHAPE

LOAD를 사용하여 로드된 쉐이프 파일의 쉐이프를 삽입합니다.

시스템 변수

항목이 없습니다.

유틸리티

항목이 없습니다.

명령 수정자

항목이 없습니다.


문자 글꼴 설명 (개념)

코드 00E: 플래그 세로 문자 명령
쉐이프 정의 파일 작성
예제 파일
AutoCAD 2008 사용자화 안내서 > 쉐이프 및 쉐이프 글꼴 > 쉐이프 정의 파일 작성 >
문자 글꼴 설명
개념 요약 참조

문자 글꼴에는 글꼴에 관한 정보를 제공하는 특수 쉐이프 번호 0이 포함되어야 합니다.

AutoCAD 패키지에는 다양한 문자 글꼴이 들어 있습니다. STYLE 명령으로 확장, 압축 또는 기울기를 이러한 글꼴에 적용하여 문자를 필요에 따라 맞출 수 있습니다. 이러한 글꼴을 사용하여 기준선 각도에서 어떠한 높이의 문자도 그릴 수 있으며, 가로나 세로 방향으로 그릴 수 있습니다.

AutoCAD 문자 글꼴은 각 문자의 ASCII 코드에 해당하는 쉐이프 번호를 가지는 쉐이프 정의의 파일입니다. 코드 1~31은 조정 문자에 대한 것이며, 이 중 하나만 AutoCAD 문자 글꼴에서 사용됩니다.

10 (LF)

줄 바꿈(LF)은 그리기 작업을 하지 않고 한 줄 아래로 내려야 합니다. 이 코드는 반복되는 TEXT 명령에 사용되어 첫 번째 행 아래에 그 다음 행을 놓습니다.

*10,5,lf

2,8,(0,-10),0

LF 쉐이프 정의에 지정된 아래쪽 이동을 조정하여 줄 간격을 수정할 수 있습니다.

문자 글꼴에는 글꼴에 관한 정보를 제공하는 특수 쉐이프 번호 0이 포함되어야 합니다. 이에 대한 구문은 다음과 같습니다.

*0,4,font-name
above,below,modes,0

above 값은 기준선 위로 대문자가 확장되는 벡터 길이의 숫자를 지정하고 below는 소문자가 기준선 아래로 내려가는 길이를 나타냅니다. 기준선은 필기 용지에 그려진 선과 개념이 비슷합니다. 이러한 값은 기본 문자 크기를 정의하며 TEXT 명령에서 지정된 높이의 축척 비율로 사용됩니다.

modes 바이트는 가로 방향 글꼴의 경우 0이고, 양방향(가로나 세로) 글꼴의 경우 2여야 합니다. 특수 00E(14) 명령 코드는 modes가 2로 설정되어 있을 경우에만 사용할 수 있습니다.

AutoCAD와 함께 제공된 표준 글꼴에는 AutoCAD 치수 지정 기능에 필요한 몇 가지 추가 문자가 있습니다.

%%d 도 기호(°)

%%p 더하기/빼기 공차 기호(±)

%%c 원 지름 치수기입 기호

명령 참조서의 TEXT에 설명된 대로 이러한 기호와 %%nnn 조정 시퀀스를 사용할 수 있습니다.

주AutoCAD는 이름이 아닌 ASCII 코드(쉐이프 번호)로 문자를 그립니다. 메모리를 저장하려면 각 문자 쉐이프 정의의 쉐이프 이름 부분을 다음 보기에서와 같이 소문자로 지정하십시오. 소문자 이름은 메모리에 저장되지 않습니다.
*65,11,uca
024,043,04d,02c,2,047,1,040,2,02e,0

쉐이프 이름 uca는 소문자를 포함하므로 AutoCAD는 해당 이름을 메모리에 저장하지 않습니다. 그러나 글꼴 정의 파일을 편집할 때는 참조용으로 이 이름을 사용할 수 있습니다. 이 예제에서 uca는 대문자 A를 나타냅니다.


문자 글꼴 설명 (요약 참조)

코드 00E: 플래그 세로 문자 명령
문자 글꼴 설명
확장된 Simplex Roman
AutoCAD 2008 사용자화 안내서 > 쉐이프 및 쉐이프 글꼴 > 쉐이프 정의 파일 작성 > 문자 글꼴 설명 >
문자 글꼴 설명
개념 요약 참조

명령

LOAD

쉐이프를 SHAPE 명령에 사용할 수 있게 만듭니다.

SHAPE

LOAD를 사용하여 로드된 쉐이프 파일의 쉐이프를 삽입합니다.

STYLE

명명된 문자 스타일을 작성, 수정 또는 설정합니다.

시스템 변수

항목이 없습니다.

유틸리티

항목이 없습니다.

명령 수정자

항목이 없습니다.


예제 파일

문자 글꼴 설명
쉐이프 정의 파일 작성
확장된 Simplex Roman
AutoCAD 2008 사용자화 안내서 > 쉐이프 및 쉐이프 글꼴 > 쉐이프 정의 파일 작성 >
예제 파일

이 항목에는 AutoCAD와 함께 제공된 글꼴 문자를 확장하는 데 도움을 주는 샘플 파일이 있습니다.

이 단원의 항목

  • 확장된 Simplex Roman
  • UNICODE를 위한 확장된 표준 글꼴


확장된 Simplex Roman (개념)

예제 파일
예제 파일
UNICODE를 위한 확장된 표준 글꼴
AutoCAD 2008 사용자화 안내서 > 쉐이프 및 쉐이프 글꼴 > 쉐이프 정의 파일 작성 > 예제 파일 >
확장된 Simplex Roman
개념 요약 참조
;;
;; romans.shp - Extended Simplex Roman
;;
;; Copyright 1997 by Autodesk, Inc.
;;
;; Permission to use, copy, modify, and distribute this software for
;; any purpose and without fee is hereby granted, provided that the
;; above copyright notice appears in all copies and that the restricted
;; rights notice below appear in all supporting documentation.
;;
;; Use, duplication, or disclosure by the U.S. Government is subject
;; to restrictions set forth in FAR 52.227-19 (Commercial Computer
;; Software - Restricted Rights) and DFAR 252.227-7013(c)(1)(ii)
;; (Rights in Technical Data and Computer Software), as applicable.
;;
*UNIFONT,6,ROMANS Copyright 1997 by Autodesk, Inc.
21,7,2,0,0,0
*0000A,9,lf
2,8,(0,-34),14,8,(30,34),0
*00020,9,spc
2,8,(21,0),14,8,(-21,-30),0
*00021,30,kexc
2,14,8,(-5,-21),14,5,8,(5,21),1,0EC,2,05C,1,01A,01E,012,016,2,
8,(5,-2),14,6,14,8,(5,-9),0
*00022,41,kdblqt
2,14,8,(-8,-25),14,5,8,(6,24),1,01A,016,012,01E,02C,02B,01A,2,
8,(8,5),1,01A,016,012,01E,02C,02B,01A,2,8,(4,-19),14,6,
14,8,(8,-9),0
*00023,57,kns
2,14,3,2,14,8,(-21,-50),14,4,2,14,5,8,(11,25),1,8,(-7,-32),2,
8,(13,32),1,8,(-7,-32),2,8,(-6,19),1,0E0,2,8,(-15,-6),1,0E0,2,
8,(4,-6),14,6,14,3,2,14,8,(21,-32),14,4,2,0
*00024,67,kds
2,14,8,(-10,-25),14,5,8,(8,25),1,8,(0,-29),2,8,(4,29),1,
8,(0,-29),2,8,(5,22),1,026,8,(-3,1),048,8,(-3,-1),02A,02C,02D,
01E,02F,8,(6,-2),02F,01E,02D,03C,02A,8,(-3,-1),048,8,(-3,1),026,
2,8,(17,-3),14,6,14,8,(10,-13),0
*00025,64,kpc
2,14,8,(-12,-21),14,5,8,(21,21),1,8,(-18,-21),2,8,(5,21),1,02E,
02C,02B,029,028,026,024,023,021,020,02F,8,(3,-1),030,8,(3,1),021,
2,8,(-4,-14),1,029,02B,02C,02E,020,021,023,024,026,028,2,
8,(7,-7),14,6,14,8,(12,-9),0
*00026,67,kand
2,14,8,(-13,-21),14,5,8,(23,12),1,014,016,018,01A,02B,8,(-2,-5),
8,(-2,-3),02A,029,048,027,016,025,024,023,012,8,(7,4),012,023,
024,025,027,029,02B,02C,8,(1,-3),8,(2,-3),8,(5,-7),02E,02F,020,
012,014,2,8,(3,-2),14,6,14,8,(13,-9),0
*00027,29,kapos
2,14,8,(-5,-25),14,5,8,(6,24),1,01A,016,012,01E,02C,02B,01A,2,
8,(6,-19),14,6,14,8,(5,-9),0
*00028,39,klp
2,14,8,(-7,-25),14,5,8,(11,25),1,02A,8,(-2,-3),04B,8,(-1,-5),04C,
8,(1,-5),04D,8,(2,-3),02E,2,8,(3,7),14,6,14,8,(7,-16),0
*00029,39,krp
2,14,8,(-7,-25),14,5,8,(3,25),1,02E,8,(2,-3),04D,8,(1,-5),04C,
8,(-1,-5),04B,8,(-2,-3),02A,2,8,(11,7),14,6,14,8,(7,-16),0
*0002A,37,kas
2,14,8,(-8,-21),14,5,8,(8,21),1,0CC,2,8,(-5,9),1,8,(10,-6),2,064,
1,8,(-10,-6),2,8,(13,-12),14,6,14,8,(8,-9),0
*0002B,31,kpls
2,14,8,(-13,-18),14,5,8,(13,18),1,8,(0,-18),2,096,1,8,(18,0),2,
8,(4,-9),14,6,14,8,(13,-9),0
*0002C,29,kcma
2,14,8,(-5,-2),14,5,8,(6,1),1,01A,016,012,01E,02C,02B,01A,2,
8,(6,4),14,6,14,8,(5,-13),0
*0002D,25,ksub
2,14,8,(-13,-9),14,5,8,(4,9),1,8,(18,0),2,8,(4,-9),14,6,
14,8,(13,-9),0
*0002E,26,kper
2,14,8,(-5,-2),14,5,8,(5,2),1,01A,01E,012,016,2,8,(5,-2),14,6,
14,8,(5,-9),0
*0002F,25,kdiv
2,14,8,(-11,-25),14,5,8,(20,25),1,8,(-18,-32),2,8,(20,7),14,6,
14,8,(11,-16),0
*00030,62,n0
2,14,8,(-10,-21),14,5,8,(9,21),1,8,(-3,-1),8,(-2,-3),8,(-1,-5),
03C,8,(1,-5),8,(2,-3),8,(3,-1),020,8,(3,1),8,(2,3),8,(1,5),034,
8,(-1,5),8,(-2,3),8,(-3,1),028,2,8,(11,-21),14,6,14,8,(10,-9),0
*00031,27,n1
2,14,8,(-10,-21),14,5,8,(6,17),1,021,032,8,(0,-21),2,8,(9,0),
14,6,14,8,(10,-9),0
*00032,37,n2
2,14,8,(-10,-21),14,5,8,(4,16),1,014,023,012,021,040,02F,01E,02D,
02C,02B,8,(-2,-3),0AA,0E0,2,8,(3,0),14,6,14,8,(10,-9),0
*00033,46,n3
2,14,8,(-10,-21),14,5,8,(5,21),1,0B0,8,(-6,-8),030,02F,01E,
8,(1,-3),02C,8,(-1,-3),02A,8,(-3,-1),038,8,(-3,1),016,025,2,
8,(17,-4),14,6,14,8,(10,-9),0
*00034,34,n4
2,14,8,(-10,-21),14,5,8,(13,21),1,8,(-10,-14),0F0,2,8,(-5,14),1,
8,(0,-21),2,8,(7,0),14,6,14,8,(10,-9),0
*00035,52,n5
2,14,8,(-10,-21),14,5,8,(15,21),1,0A8,8,(-1,-9),012,8,(3,1),030,
8,(3,-1),02E,8,(1,-3),02C,8,(-1,-3),02A,8,(-3,-1),038,8,(-3,1),
016,025,2,8,(17,-4),14,6,14,8,(10,-9),0
*00036,68,n6
2,14,8,(-10,-21),14,5,8,(16,18),1,025,8,(-3,1),028,8,(-3,-1),
8,(-2,-3),8,(-1,-5),05C,8,(1,-4),02E,8,(3,-1),010,8,(3,1),022,
8,(1,3),014,8,(-1,3),026,8,(-3,1),018,8,(-3,-1),02A,8,(-1,-3),2,
8,(16,-7),14,6,14,8,(10,-9),0
*00037,31,n7
2,14,8,(-10,-21),14,5,8,(17,21),1,8,(-10,-21),2,8,(-4,21),1,0E0,
2,8,(3,-21),14,6,14,8,(10,-9),0
*00038,66,n8
2,14,8,(-10,-21),14,5,8,(8,21),1,8,(-3,-1),02B,02C,02D,02F,
8,(4,-1),8,(3,-1),02E,02D,03C,02B,01A,8,(-3,-1),048,8,(-3,1),016,
025,034,023,022,8,(3,1),8,(4,1),021,023,024,025,8,(-3,1),048,2,
8,(12,-21),14,6,14,8,(10,-9),0
*00039,68,n9
2,14,8,(-10,-21),14,5,8,(16,14),1,8,(-1,-3),02A,8,(-3,-1),018,
8,(-3,1),026,8,(-1,3),014,8,(1,3),022,8,(3,1),010,8,(3,-1),02E,
8,(1,-4),05C,8,(-1,-5),8,(-2,-3),8,(-3,-1),028,8,(-3,1),025,2,
8,(16,-3),14,6,14,8,(10,-9),0
*0003A,33,kcol
2,14,8,(-5,-14),14,5,8,(5,14),1,01A,01E,012,016,2,0CC,1,01A,01E,
012,016,2,8,(5,-2),14,6,14,8,(5,-9),0
*0003B,38,ksmc
2,14,8,(-5,-14),14,5,8,(5,14),1,01A,01E,012,016,2,8,(1,-13),1,
01A,016,012,01E,02C,02B,01A,2,8,(6,4),14,6,14,8,(5,-13),0
*0003C,28,klt
2,14,8,(-12,-18),14,5,8,(20,18),1,8,(-16,-9),8,(16,-9),2,8,(4,0),
14,6,14,8,(12,-9),0
*0003D,33,keq
2,14,8,(-13,-12),14,5,8,(4,12),1,8,(18,0),2,8,(-18,-6),1,
8,(18,0),2,8,(4,-6),14,6,14,8,(13,-9),0
*0003E,28,kgt2
2,14,8,(-12,-18),14,5,8,(4,18),1,8,(16,-9),8,(-16,-9),2,8,(20,0),
14,6,14,8,(12,-9),0
*0003F,42,kqm
2,14,8,(-9,-21),14,5,8,(3,16),1,014,023,012,021,040,02F,01E,02D,
02C,02B,01A,049,03C,2,05C,1,01A,01E,012,016,2,8,(9,-2),14,6,
14,8,(9,-9),0
*00040,93,kea
2,14,3,2,14,8,(-27,-42),14,4,2,14,5,8,(18,13),1,025,027,038,029,
01A,02B,03C,02D,01E,02F,030,021,023,2,084,1,0AC,01E,020,022,
8,(1,3),024,8,(-1,3),025,026,027,8,(-3,1),038,8,(-3,-1),029,02A,
02B,8,(-1,-3),03C,8,(1,-3),02D,02E,02F,8,(3,-1),030,8,(3,1),021,
012,2,8,(6,-3),14,6,14,3,2,14,8,(27,-18),14,4,2,0
*00041,39,uca
2,14,8,(-9,-21),14,5,8,(9,21),1,8,(-8,-21),2,8,(8,21),1,
8,(8,-21),2,8,(-13,7),1,0A0,2,8,(4,-7),14,6,14,8,(9,-9),0
*00042,70,ucb
2,14,3,2,14,8,(-21,-42),14,4,2,14,5,8,(4,21),1,8,(0,-21),2,
8,(0,21),1,090,8,(3,-1),01E,02D,02C,02B,01A,8,(-3,-1),2,098,1,
090,8,(3,-1),01E,02D,03C,02B,01A,8,(-3,-1),098,2,8,(17,0),14,6,
14,3,2,14,8,(21,-18),14,4,2,0
*00043,55,ucc
2,14,3,2,14,8,(-21,-42),14,4,2,14,5,8,(18,16),1,025,026,027,048,
029,02A,02B,8,(-1,-3),05C,8,(1,-3),02D,02E,02F,040,021,022,023,2,
8,(3,-5),14,6,14,3,2,14,8,(21,-18),14,4,2,0
*00044,61,ucd
2,14,3,2,14,8,(-21,-42),14,4,2,14,5,8,(4,21),1,8,(0,-21),2,
8,(0,21),1,070,8,(3,-1),02E,02D,8,(1,-3),05C,8,(-1,-3),02B,02A,
8,(-3,-1),078,2,8,(17,0),14,6,14,3,2,14,8,(21,-18),14,4,2,0
*00045,55,uce
2,14,3,2,14,8,(-19,-42),14,4,2,14,5,8,(4,21),1,8,(0,-21),2,
8,(0,21),1,0D0,2,8,(-13,-10),1,080,2,8,(-8,-11),1,0D0,2,8,(2,0),
14,6,14,3,2,14,8,(19,-18),14,4,2,0
*00046,37,ucf
2,14,8,(-9,-21),14,5,8,(4,21),1,8,(0,-21),2,8,(0,21),1,0D0,2,
8,(-13,-10),1,080,2,8,(6,-11),14,6,14,8,(9,-9),0
*00047,60,ucg
2,14,3,2,14,8,(-21,-42),14,4,2,14,5,8,(18,16),1,025,026,027,048,
029,02A,02B,8,(-1,-3),05C,8,(1,-3),02D,02E,02F,040,021,022,023,
034,2,058,1,050,2,8,(3,-8),14,6,14,3,2,14,8,(21,-18),14,4,2,0
*00048,39,uch
2,14,8,(-11,-21),14,5,8,(4,21),1,8,(0,-21),2,8,(14,21),1,
8,(0,-21),2,8,(-14,11),1,0E0,2,8,(4,-11),14,6,14,8,(11,-9),0
*00049,25,uci
2,14,8,(-4,-21),14,5,8,(4,21),1,8,(0,-21),2,8,(4,0),14,6,
14,8,(4,-9),0
*0004A,37,ucj
2,14,8,(-8,-21),14,5,8,(12,21),1,8,(0,-16),8,(-1,-3),01A,029,028,
027,016,8,(-1,3),024,2,8,(14,-7),14,6,14,8,(8,-9),0
*0004B,49,uck
2,14,3,2,14,8,(-21,-42),14,4,2,14,5,8,(4,21),1,8,(0,-21),2,
8,(14,21),1,0EA,2,052,1,8,(9,-12),2,8,(3,0),14,6,14,3,2,
14,8,(21,-18),14,4,2,0
*0004C,43,ucl
2,14,3,2,14,8,(-17,-42),14,4,2,14,5,8,(4,21),1,8,(0,-21),2,
8,(0,0),1,0C0,2,8,(1,0),14,6,14,3,2,14,8,(17,-18),14,4,2,0
*0004D,49,ucm
2,14,8,(-12,-21),14,5,8,(4,21),1,8,(0,-21),2,8,(0,21),1,
8,(8,-21),2,8,(8,21),1,8,(-8,-21),2,8,(8,21),1,8,(0,-21),2,
8,(4,0),14,6,14,8,(12,-9),0
*0004E,41,ucn
2,14,8,(-11,-21),14,5,8,(4,21),1,8,(0,-21),2,8,(0,21),1,
8,(14,-21),2,8,(0,21),1,8,(0,-21),2,8,(4,0),14,6,14,8,(11,-9),0
*0004F,50,uco
2,14,8,(-11,-21),14,5,8,(9,21),1,029,02A,02B,8,(-1,-3),05C,
8,(1,-3),02D,02E,02F,040,021,022,023,8,(1,3),054,8,(-1,3),025,
026,027,048,2,8,(13,-21),14,6,14,8,(11,-9),0
*00050,55,ucp
2,14,3,2,14,8,(-21,-42),14,4,2,14,5,8,(4,21),1,8,(0,-21),2,
8,(0,21),1,090,8,(3,-1),01E,02D,03C,02B,01A,8,(-3,-1),098,2,
8,(17,-10),14,6,14,3,2,14,8,(21,-18),14,4,2,0
*00051,56,ucq
2,14,8,(-11,-21),14,5,8,(9,21),1,029,02A,02B,8,(-1,-3),05C,
8,(1,-3),02D,02E,02F,040,021,022,023,8,(1,3),054,8,(-1,3),025,
026,027,048,2,8,(3,-17),1,06E,2,8,(4,2),14,6,14,8,(11,-11),0
*00052,61,ucr
2,14,3,2,14,8,(-21,-42),14,4,2,14,5,8,(4,21),1,8,(0,-21),2,
8,(0,21),1,090,8,(3,-1),01E,02D,02C,02B,01A,8,(-3,-1),098,2,070,
1,8,(7,-11),2,8,(3,0),14,6,14,3,2,14,8,(21,-18),14,4,2,0
*00053,51,ucs
2,14,8,(-10,-21),14,5,8,(17,18),1,026,8,(-3,1),048,8,(-3,-1),02A,
02C,02D,01E,02F,8,(6,-2),02F,01E,02D,03C,02A,8,(-3,-1),048,
8,(-3,1),026,2,8,(17,-3),14,6,14,8,(10,-9),0
*00054,31,uct
2,14,8,(-8,-21),14,5,8,(8,21),1,8,(0,-21),2,8,(-7,21),1,0E0,2,
8,(1,-21),14,6,14,8,(8,-9),0
*00055,39,ucu
2,14,8,(-11,-21),14,5,8,(4,21),1,0FC,8,(1,-3),02E,8,(3,-1),020,
8,(3,1),022,8,(1,3),0F4,2,8,(4,-21),14,6,14,8,(11,-9),0
*00056,33,ucv
2,14,8,(-9,-21),14,5,8,(1,21),1,8,(8,-21),2,8,(8,21),1,
8,(-8,-21),2,8,(9,0),14,6,14,8,(9,-9),0
*00057,49,ucw
2,14,8,(-12,-21),14,5,8,(2,21),1,8,(5,-21),2,8,(5,21),1,
8,(-5,-21),2,8,(5,21),1,8,(5,-21),2,8,(5,21),1,8,(-5,-21),2,
8,(7,0),14,6,14,8,(12,-9),0
*00058,33,ucx
2,14,8,(-10,-21),14,5,8,(3,21),1,8,(14,-21),2,8,(0,21),1,
8,(-14,-21),2,8,(17,0),14,6,14,8,(10,-9),0
*00059,34,ucy
2,14,8,(-9,-21),14,5,8,(1,21),1,8,(8,-10),0BC,2,8,(8,21),1,
8,(-8,-10),2,8,(9,-11),14,6,14,8,(9,-9),0
*0005A,37,ucz
2,14,8,(-10,-21),14,5,8,(17,21),1,8,(-14,-21),2,8,(0,21),1,0E0,2,
8,(-14,-21),1,0E0,2,8,(3,0),14,6,14,8,(10,-9),0
*0005B,37,klb
2,14,8,(-7,-25),14,5,8,(4,25),1,8,(0,-32),2,8,(0,32),1,070,2,
8,(-7,-32),1,070,2,8,(3,7),14,6,14,8,(7,-16),0
*0005C,25,kbkslsh
2,14,8,(-11,-25),14,5,8,(2,25),1,8,(18,-32),2,8,(2,7),14,6,
14,8,(11,-16),0
*0005D,37,krb
2,14,8,(-7,-25),14,5,8,(9,25),1,8,(0,-32),2,8,(-7,32),1,070,2,
8,(-7,-32),1,070,2,8,(4,7),14,6,14,8,(7,-16),0
*0005E,28,kcaret
2,14,8,(-11,-25),14,5,8,(3,20),1,8,(8,5),8,(8,-5),2,8,(3,-20),
14,6,14,8,(11,-9),0
*0005F,21,kundrl
2,14,8,(-12,-14),14,5,02E,1,8,(20,0),2,022,14,6,14,8,(12,-11),0
*00060,29,krvap
2,14,8,(-5,-25),14,5,8,(4,24),1,01E,012,016,01A,02C,02D,01E,2,
8,(6,-19),14,6,14,8,(5,-9),0
*00061,55,lca
2,14,3,2,14,8,(-19,-28),14,4,2,14,5,8,(15,14),1,0EC,2,0B4,1,026,
027,038,029,02A,8,(-1,-3),02C,8,(1,-3),02E,02F,030,021,022,2,
8,(4,-3),14,6,14,3,2,14,8,(19,-18),14,4,2,0
*00062,57,lcb
2,14,3,2,14,8,(-19,-42),14,4,2,14,5,8,(4,21),1,8,(0,-21),2,0B4,1,
022,021,030,02F,02E,8,(1,-3),02C,8,(-1,-3),02A,029,038,027,026,2,
8,(15,-3),14,6,14,3,2,14,8,(19,-18),14,4,2,0
*00063,39,lcc
2,14,8,(-9,-14),14,5,8,(15,11),1,026,027,038,029,02A,8,(-1,-3),
02C,8,(1,-3),02E,02F,030,021,022,2,8,(3,-3),14,6,14,8,(9,-9),0
*00064,57,lcd
2,14,3,2,14,8,(-19,-42),14,4,2,14,5,8,(15,21),1,8,(0,-21),2,0B4,
1,026,027,038,029,02A,8,(-1,-3),02C,8,(1,-3),02E,02F,030,021,022,
2,8,(4,-3),14,6,14,3,2,14,8,(19,-18),14,4,2,0
*00065,42,lce
2,14,8,(-9,-14),14,5,8,(3,8),1,0C0,024,025,016,027,038,029,02A,
8,(-1,-3),02C,8,(1,-3),02E,02F,030,021,022,2,8,(3,-3),14,6,
14,8,(9,-9),0
*00066,36,lcf
2,14,8,(-6,-21),14,5,8,(10,21),1,028,029,8,(-1,-3),8,(0,-17),2,
8,(-3,14),1,070,2,8,(3,-14),14,6,14,8,(6,-9),0
*00067,66,lcg
2,14,3,2,14,8,(-19,-28),14,4,2,14,5,8,(15,14),1,8,(0,-16),
8,(-1,-3),01A,029,038,027,2,8,(9,17),1,026,027,038,029,02A,
8,(-1,-3),02C,8,(1,-3),02E,02F,030,021,022,2,8,(4,-3),14,6,14,3,
2,14,8,(19,-32),14,4,2,0
*00068,48,lch
2,14,3,2,14,8,(-19,-42),14,4,2,14,5,8,(4,21),1,8,(0,-21),2,0A4,1,
032,021,030,02F,8,(1,-3),0AC,2,8,(4,0),14,6,14,3,2,14,8,(19,-18),
14,4,2,0
*00069,32,lci
2,14,8,(-4,-21),14,5,8,(3,20),1,01E,012,016,01A,2,8,(1,-7),1,0DC,
2,8,(4,0),14,6,14,8,(4,-9),0
*0006A,39,lcj
2,14,8,(-5,-21),14,5,8,(5,20),1,01E,012,016,01A,2,8,(1,-7),1,
8,(0,-16),8,(-1,-3),029,028,2,8,(9,7),14,6,14,8,(5,-16),0
*0006B,49,lck
2,14,3,2,14,8,(-17,-42),14,4,2,14,5,8,(4,21),1,8,(0,-21),2,
8,(10,14),1,0AA,2,042,1,8,(7,-8),2,8,(2,0),14,6,14,3,2,
14,8,(17,-18),14,4,2,0
*0006C,25,lcl
2,14,8,(-4,-21),14,5,8,(4,21),1,8,(0,-21),2,8,(4,0),14,6,
14,8,(4,-9),0
*0006D,45,lcm
2,14,8,(-15,-14),14,5,8,(4,14),1,0EC,2,0A4,1,032,021,030,02F,
8,(1,-3),0AC,2,0A4,1,032,021,030,02F,8,(1,-3),0AC,2,8,(4,0),14,6,
14,8,(15,-9),0
*0006E,46,lcn
2,14,3,2,14,8,(-19,-28),14,4,2,14,5,8,(4,14),1,0EC,2,0A4,1,032,
021,030,02F,8,(1,-3),0AC,2,8,(4,0),14,6,14,3,2,14,8,(19,-18),
14,4,2,0
*0006F,58,lco
2,14,3,2,14,8,(-19,-28),14,4,2,14,5,8,(8,14),1,029,02A,8,(-1,-3),
02C,8,(1,-3),02E,02F,030,021,022,8,(1,3),024,8,(-1,3),026,027,
038,2,8,(11,-14),14,6,14,3,2,14,8,(19,-18),14,4,2,0
*00070,59,lcp
2,14,3,2,14,8,(-19,-28),14,4,2,14,5,8,(4,14),1,8,(0,-21),2,
8,(0,18),1,022,021,030,02F,02E,8,(1,-3),02C,8,(-1,-3),02A,029,
038,027,026,2,8,(15,-3),14,6,14,3,2,14,8,(19,-32),14,4,2,0
*00071,59,lcq
2,14,3,2,14,8,(-19,-28),14,4,2,14,5,8,(15,14),1,8,(0,-21),2,
8,(0,18),1,026,027,038,029,02A,8,(-1,-3),02C,8,(1,-3),02E,02F,
030,021,022,2,8,(4,-3),14,6,14,3,2,14,8,(19,-32),14,4,2,0
*00072,44,lcr
2,14,3,2,14,8,(-13,-28),14,4,2,14,5,8,(4,14),1,0EC,2,084,1,
8,(1,3),022,021,030,2,8,(1,-14),14,6,14,3,2,14,8,(13,-18),14,4,2,
0
*00073,60,lcs
2,14,3,2,14,8,(-17,-28),14,4,2,14,5,8,(14,11),1,025,8,(-3,1),038,
8,(-3,-1),02B,02D,02F,8,(5,-1),02F,02D,01C,02B,8,(-3,-1),038,
8,(-3,1),025,2,8,(14,-3),14,6,14,3,2,14,8,(17,-18),14,4,2,0
*00074,36,lct
2,14,8,(-6,-21),14,5,8,(5,21),1,8,(0,-17),8,(1,-3),02F,020,2,
8,(-8,14),1,070,2,8,(3,-14),14,6,14,8,(6,-9),0
*00075,46,lcu
2,14,3,2,14,8,(-19,-28),14,4,2,14,5,8,(4,14),1,0AC,8,(1,-3),02F,
030,021,032,2,0A4,1,0EC,2,8,(4,0),14,6,14,3,2,14,8,(19,-18),14,4,
2,0
*00076,33,lcv
2,14,8,(-8,-14),14,5,8,(2,14),1,8,(6,-14),2,8,(6,14),1,
8,(-6,-14),2,8,(8,0),14,6,14,8,(8,-9),0
*00077,49,lcw
2,14,8,(-11,-14),14,5,8,(3,14),1,8,(4,-14),2,8,(4,14),1,
8,(-4,-14),2,8,(4,14),1,8,(4,-14),2,8,(4,14),1,8,(-4,-14),2,
8,(7,0),14,6,14,8,(11,-9),0
*00078,43,lcx
2,14,3,2,14,8,(-17,-28),14,4,2,14,5,8,(3,14),1,8,(11,-14),2,0E4,
1,8,(-11,-14),2,8,(14,0),14,6,14,3,2,14,8,(17,-18),14,4,2,0
*00079,37,lcy
2,14,8,(-8,-14),14,5,8,(2,14),1,8,(6,-14),2,8,(6,14),1,
8,(-6,-14),04B,02A,029,018,2,8,(15,7),14,6,14,8,(8,-16),0
*0007A,47,lcz
2,14,3,2,14,8,(-17,-28),14,4,2,14,5,8,(14,14),1,8,(-11,-14),2,
0E4,1,0B0,2,8,(-11,-14),1,0B0,2,8,(3,0),14,6,14,3,2,
14,8,(17,-18),14,4,2,0
*0007B,54,klbr
2,14,3,2,14,8,(-13,-50),14,4,2,14,5,8,(9,25),1,029,01A,02B,02C,
02D,01E,02D,02C,02A,029,02F,02E,02C,02B,01A,02B,02C,02D,01E,02F,
2,8,(5,7),14,6,14,3,2,14,8,(13,-32),14,4,2,0
*0007C,25,kvbar
2,14,8,(-4,-25),14,5,8,(4,25),1,8,(0,-32),2,8,(4,7),14,6,
14,8,(4,-16),0
*0007D,54,krbr
2,14,3,2,14,8,(-15,-50),14,4,2,14,5,8,(5,25),1,02F,01E,02D,02C,
02B,01A,02B,02C,02E,02F,029,02A,02C,02D,01E,02D,02C,02B,01A,029,
2,8,(9,7),14,6,14,3,2,14,8,(15,-32),14,4,2,0
*0007E,37,ktlde
2,14,8,(-13,-14),14,5,8,(4,6),1,024,8,(1,3),021,020,02F,8,(4,-3),
02F,020,021,023,024,2,8,(4,-12),14,6,14,8,(13,-9),0
*00080,4,keuroRef
7,020AC,0
*000A0,9,spc
2,8,(21,0),14,8,(-21,-30),0
*000A1,28,kiexc
2,14,8,(-5,-21),14,5,050,1,0E4,2,054,1,012,016,01A,01E,2,
8,(8,-19),14,6,14,8,(5,-9),0
*000A2,43,kcent
2,14,8,(-9,-17),14,5,03E,1,8,(12,20),2,06C,1,026,027,038,029,02A,
8,(-1,-3),02C,8,(1,-3),02E,02F,030,021,022,2,8,(3,-3),14,6,
14,8,(9,-9),0
*000A3,37,kpound
2,14,8,(-10,-21),14,5,8,(12,18),1,025,027,029,02B,0FC,03A,0E0,2,
8,(-8,10),1,068,014,060,2,8,(9,-11),14,6,14,8,(10,-9),0
*000A5,44,kyen
2,14,8,(-12,-21),14,5,8,(1,21),1,8,(8,-10),0BC,2,8,(8,21),1,
8,(-8,-10),2,078,1,0E0,2,8,(-14,-3),1,0E0,2,8,(6,-8),14,6,
14,8,(12,-9),0
*000A7,78,kpar
2,14,8,(-10,-25),14,5,060,1,012,016,01A,01C,02D,01E,02F,020,021,
012,023,014,025,016,8,(-8,4),016,025,014,023,012,021,010,
8,(8,-4),2,094,028,1,01A,01E,012,014,025,016,027,028,029,01A,02B,
01C,02D,01E,8,(8,-4),01E,02D,01C,02B,01A,029,018,8,(-8,4),2,
8,(16,-9),14,6,14,8,(10,-13),0
*000AA,51,lcau
2,14,8,-7,-21,14,5,8,4,14,3,2,1,0A0,2,054,1,02A,029,028,027,016,
8,-1,3,024,8,1,3,012,021,020,02F,02E,2,034,1,0CC,2,4,2,8,4,-15,
14,6,14,8,7,-9,0
*000AB,25,kfrew
2,14,8,(-9,-14),14,5,0A0,1,076,072,2,050,1,07A,07E,2,030,14,6,
14,8,(9,-9),0
*000B0,25,kdeg
2,14,8,(-3,-21),14,5,8,(1,19),1,10,(2,64),2,8,(8,-19),14,6,
14,8,(3,-9),0
*000B1,39,kpls-min
2,14,8,(-13,-21),14,5,8,(13,21),1,8,(0,-18),2,096,1,8,(18,0),2,
8,(-18,-11),1,8,(18,0),2,8,(4,-1),14,6,14,8,(13,-9),0
*000B5,48,kmicro
2,14,3,2,14,8,(-19,-28),14,4,2,14,5,07C,1,022,8,(3,19),0AC,
8,(1,-3),02F,030,021,032,2,0A4,1,0EC,2,8,(4,0),14,6,14,3,2,
14,8,(19,-32),14,4,2,0
*000BA,56,lcou
2,14,8,-7,-21,14,5,8,4,14,3,2,1,0A0,2,8,-4,14,1,028,029,01A,8,-1,
-3,02C,8,1,-3,01E,02F,020,021,012,8,1,3,024,8,-1,3,016,027,2,4,2,
8,6,-21,14,6,14,8,7,-9,0
*000BB,25,kffrw
2,14,8,(-9,-14),14,5,030,1,072,076,2,050,1,07E,07A,2,0A0,14,6,
14,8,(9,-9),0
*000BC,43,kquart
2,14,8,(-14,-25),14,5,8,(4,21),1,021,022,0EC,2,8,(-2,-14),1,
8,(16,29),2,8,(2,-23),1,0A8,8,(7,9),0EC,2,8,(7,3),14,6,
14,8,(14,-13),0
*000BD,50,khalf
2,14,8,(-14,-25),14,5,8,(4,21),1,021,022,0EC,2,8,(-2,-14),1,
8,(16,29),2,8,(-6,-18),1,014,023,021,020,02F,02D,01C,02B,
8,(-7,-8),080,2,8,(4,3),14,6,14,8,(14,-13),0
*000BF,47,kiqm
2,14,8,(-9,-21),14,5,8,(13,4),1,016,012,01E,01C,02B,01A,029,038,
8,(-3,1),025,024,023,012,021,022,034,2,054,1,012,016,01A,01E,2,
8,(8,-19),14,6,14,8,(9,-9),0
*000C0,43,uc^
2,14,8,(-9,-25),14,5,8,(9,23),1,047,2,04E,1,8,(-8,-21),2,
8,(8,21),1,8,(8,-21),2,8,(-13,7),1,0A0,2,8,(4,-7),14,6,
14,8,(9,-9),0
*000C1,43,uc^
2,14,8,(-9,-25),14,5,8,(9,23),1,041,2,04A,1,8,(-8,-21),2,
8,(8,21),1,8,(8,-21),2,8,(-13,7),1,0A0,2,8,(4,-7),14,6,
14,8,(9,-9),0
*000C2,44,uc
2,14,8,(-9,-25),14,5,8,(5,23),1,041,04F,2,049,1,8,(-8,-21),2,
8,(8,21),1,8,(8,-21),2,8,(-13,7),1,0A0,2,8,(4,-7),14,6,
14,8,(9,-9),0
*000C3,55,uc^
2,14,8,(-9,-25),14,5,8,(4,22),5,1,023,10,(2,-50),01E,10,(2,82),
023,2,6,8,(5,-1),1,8,(-8,-21),2,8,(8,21),1,8,(8,-21),2,8,(-13,7),
1,0A0,2,8,(4,-7),14,6,14,8,(9,-9),0
*000C4,53,uc„
2,14,8,(-9,-25),14,5,8,(4,24),1,01E,012,016,01A,2,080,1,01E,012,
016,01A,2,03A,1,8,(-8,-21),2,8,(8,21),1,8,(8,-21),2,8,(-13,7),1,
0A0,2,8,(4,-7),14,6,14,8,(9,-9),0
*000C5,45,uc^
2,14,8,(-9,-25),14,5,8,(7,23),1,10,(2,64),2,02E,1,8,(-8,-21),2,
8,(8,21),1,8,(8,-21),2,8,(-13,7),1,0A0,2,8,(4,-7),14,6,
14,8,(9,-9),0
*000C6,45,uc^
2,14,8,(-9,-21),14,5,010,1,8,(8,21),8,(0,-21),080,2,8,(-8,7),1,
058,2,8,(5,4),1,050,2,8,(-5,10),1,080,2,8,(2,-21),14,6,
14,8,(9,-9),0
*000C7,65,uc‡
2,14,3,2,14,8,(-21,-42),14,4,2,14,5,8,(18,16),1,025,026,027,048,
029,02A,02B,8,(-1,-3),05C,8,(1,-3),02D,02E,02F,040,021,022,023,2,
8,(-9,-11),1,01E,030,012,024,016,028,034,2,0A0,14,6,14,3,2,
14,8,(21,-32),14,4,2,0
*000C8,53,uc^
2,14,3,2,14,8,(-19,-50),14,4,2,14,5,8,(6,25),1,8,(9,-4),2,
8,(2,-2),1,0D8,8,(0,-19),0D0,2,8,(-13,10),1,080,2,8,(7,-10),14,6,
14,3,2,14,8,(19,-18),14,4,2,0
*000C9,53,uc^
2,14,3,2,14,8,(-19,-50),14,4,2,14,5,8,(6,21),1,8,(9,4),2,
8,(2,-6),1,0D8,8,(0,-19),0D0,2,8,(-13,10),1,080,2,8,(7,-10),14,6,
14,3,2,14,8,(19,-18),14,4,2,0
*000CA,53,uc^
2,14,3,2,14,8,(-19,-50),14,4,2,14,5,8,(6,23),1,041,010,04F,2,
8,(2,-2),1,0D8,8,(0,-21),0D0,2,8,(-13,11),1,080,2,8,(7,-11),14,6,
14,3,2,14,8,(19,-18),14,4,2,0
*000CB,61,uc^
2,14,3,2,14,8,(-19,-50),14,4,2,14,5,8,(6,24),1,01E,012,016,01A,2,
070,1,01E,012,016,01A,2,8,(4,-3),1,0D8,8,(0,-21),0D0,2,
8,(-13,11),1,080,2,8,(7,-11),14,6,14,3,2,14,8,(19,-18),14,4,2,0
*000CC,29,uc^
2,14,8,(-4,-25),14,5,8,(4,23),1,026,2,04D,1,8,(0,-21),2,8,(4,0),
14,6,14,8,(4,-9),0
*000CD,29,uc^
2,14,8,(-4,-25),14,5,8,(4,23),1,022,2,04B,1,8,(0,-21),2,8,(4,0),
14,6,14,8,(4,-9),0
*000CE,30,uc^
2,14,8,(-4,-25),14,5,8,(2,23),1,022,02E,2,02A,1,8,(0,-21),2,
8,(4,0),14,6,14,8,(4,-9),0
*000CF,41,uc^
2,14,8,(-4,-25),14,5,8,(1,24),1,01E,012,016,01A,2,040,1,01E,012,
016,01A,2,8,(-1,-3),1,8,(0,-21),2,8,(4,0),14,6,14,8,(4,-9),0
*000D1,41,uc
2,14,8,(-11,-25),14,5,040,1,8,(0,19),8,(14,-19),8,(0,19),2,
8,(-13,3),1,032,010,8,(4,-3),010,032,2,8,(5,-25),14,6,
14,8,(11,-9),0
*000D2,44,uc^
2,14,8,(-11,-25),14,5,8,(6,25),1,08F,2,8,(-6,-2),1,029,02A,04B,
05C,04D,02E,02F,040,021,022,043,054,045,026,027,048,2,8,(13,-19),
14,6,14,8,(11,-9),0
*000D3,42,uc^
2,14,8,(-11,-25),14,5,8,(6,21),1,081,2,06A,1,029,02A,04B,05C,04D,
02E,02F,040,021,022,043,054,045,026,027,048,2,8,(13,-19),14,6,
14,8,(11,-9),0
*000D4,57,uc^
2,14,8,(-11,-25),14,5,8,(6,23),1,041,04F,2,8,(-6,-2),1,029,02A,
02B,8,(-1,-3),05C,8,(1,-3),02D,02E,02F,040,021,022,023,8,(1,3),
054,8,(-1,3),025,026,027,048,2,8,(13,-21),14,6,14,8,(11,-9),0
*000D5,66,uc^
2,14,8,(-11,-25),14,5,8,(6,22),5,1,023,10,(2,-50),01E,10,(2,82),
023,2,6,8,(3,-1),1,029,02A,02B,8,(-1,-3),05C,8,(1,-3),02D,02E,
02F,040,021,022,023,8,(1,3),054,8,(-1,3),025,026,027,048,2,
8,(13,-21),14,6,14,8,(11,-9),0
*000D6,66,uc^
2,14,8,(-11,-25),14,5,8,(6,24),1,01E,012,016,01A,2,080,1,01E,012,
016,01A,2,8,(-5,-3),1,029,02A,02B,8,(-1,-3),05C,8,(1,-3),02D,02E,
02F,040,021,022,023,8,(1,3),054,8,(-1,3),025,026,027,048,2,
8,(13,-21),14,6,14,8,(11,-9),0
*000D8,54,uc›
2,14,8,(-11,-21),8,(9,21),1,029,02A,02B,8,(-1,-3),05C,8,(1,-3),
02D,02E,02F,040,021,022,023,8,(1,3),054,8,(-1,3),025,026,027,048,
2,8,(-6,-21),1,8,(16,21),2,8,(3,-21),14,8,(-11,-9),0
*000D9,43,uc^
2,14,8,(-11,-25),14,5,8,(15,21),1,087,2,06B,1,0DC,8,(1,-3),02E,
8,(3,-1),020,8,(3,1),022,8,(1,3),0D4,2,8,(4,-19),14,6,
14,8,(11,-9),0
*000DA,45,uc^
2,14,8,(-11,-25),14,5,8,(15,25),1,089,2,8,(-3,-2),1,0DC,8,(1,-3),
02E,8,(3,-1),020,8,(3,1),022,8,(1,3),0D4,2,8,(4,-19),14,6,
14,8,(11,-9),0
*000DB,46,uc^
2,14,8,(-11,-25),14,5,8,(15,23),1,047,049,2,8,(-3,-2),1,0FC,
8,(1,-3),02E,8,(3,-1),020,8,(3,1),022,8,(1,3),0F4,2,8,(4,-21),
14,6,14,8,(11,-9),0
*000DC,55,uc^
2,14,8,(-11,-25),14,5,8,(14,24),1,01E,012,016,01A,2,088,1,01E,
012,016,01A,2,8,(-2,-3),1,0FC,8,(1,-3),02E,8,(3,-1),020,8,(3,1),
022,8,(1,3),0F4,2,8,(4,-21),14,6,14,8,(11,-9),0
*000DD,38,uc^
2,14,8,(-9,-25),14,5,8,(13,25),1,089,2,049,1,8,(8,-9),0AC,2,
8,(8,19),1,8,(-8,-9),2,8,(9,-10),14,6,14,8,(9,-9),0
*000DF,53,kgers
2,14,8,(-9,-21),14,5,030,1,012,8,(0,16),023,012,021,020,02F,01E,
02D,02C,02B,01A,029,028,2,020,1,8,(3,-1),01E,02D,03C,02B,01A,029,
028,027,016,012,01E,2,8,(10,-2),14,6,14,8,(9,-9),0
*000E0,63,lc…
2,14,3,2,14,8,(-19,-42),14,4,2,14,5,8,(5,21),1,8,(8,-4),2,
8,(2,-3),1,0EC,2,0B4,1,026,027,038,029,02A,8,(-1,-3),02C,
8,(1,-3),02E,02F,030,021,022,2,8,(4,-3),14,6,14,3,2,
14,8,(19,-18),14,4,2,0
*000E1,63,lc
2,14,3,2,14,8,(-19,-42),14,4,2,14,5,8,(5,17),1,8,(8,4),2,
8,(2,-7),1,0EC,2,0B4,1,026,027,038,029,02A,8,(-1,-3),02C,
8,(1,-3),02E,02F,030,021,022,2,8,(4,-3),14,6,14,3,2,
14,8,(19,-18),14,4,2,0
*000E2,64,lc^
2,14,3,2,14,8,(-19,-42),14,4,2,14,5,8,(5,18),1,8,(4,3),8,(4,-3),
2,04D,1,0EC,2,0B4,1,026,027,038,029,02A,8,(-1,-3),02C,8,(1,-3),
02E,02F,030,021,022,2,8,(4,-3),14,6,14,3,2,14,8,(19,-18),14,4,2,0
*000E3,63,lcƒ
2,14,3,2,14,8,(-19,-42),14,4,2,14,5,8,(4,18),1,032,010,03E,010,
032,2,07C,1,0EC,2,0B4,1,026,027,038,029,02A,8,(-1,-3),02C,
8,(1,-3),02E,02F,030,021,022,2,8,(4,-3),14,6,14,3,2,
14,8,(19,-18),14,4,2,0
*000E4,71,lc„
2,14,3,2,14,8,(-19,-42),14,4,2,14,5,8,(4,20),1,01E,012,016,01A,2,
090,1,01E,012,016,01A,2,8,(2,-6),1,0EC,2,0B4,1,026,027,038,029,
02A,8,(-1,-3),02C,8,(1,-3),02E,02F,030,021,022,2,8,(4,-3),14,6,
14,3,2,14,8,(19,-18),14,4,2,0
*000E5,63,lc†
2,14,3,2,14,8,(-19,-42),14,4,2,14,5,8,(7,19),1,10,(2,64),2,
8,(8,-5),1,0EC,2,0B4,1,026,027,038,029,02A,8,(-1,-3),02C,
8,(1,-3),02E,02F,030,021,022,2,8,(4,-3),14,6,14,3,2,
14,8,(19,-18),14,4,2,0
*000E6,51,lc
2,14,8,(-10,-14),14,5,8,(10,8),1,070,014,8,(-1,3),026,028,02A,
026,028,02A,8,(-1,-3),04C,8,(1,-3),02E,020,022,02E,020,021,023,2,
8,(-7,11),1,0EC,2,0A0,14,6,14,8,(10,-9),0
*000E7,49,lc‡
2,14,8,(-9,-14),14,5,8,(15,11),1,026,027,038,029,02A,8,(-1,-3),
02C,8,(1,-3),02E,02F,030,021,022,2,8,(-8,-9),1,01E,030,012,024,
016,028,034,2,090,14,6,14,8,(9,-16),0
*000E8,48,lcŠ
2,14,8,(-9,-21),14,5,8,(5,21),1,08F,2,8,(-10,-9),1,0C0,024,025,
016,027,038,029,02A,8,(-1,-3),02C,8,(1,-3),02E,02F,030,021,022,2,
8,(3,-3),14,6,14,8,(9,-9),0
*000E9,48,lc‚
2,14,8,(-9,-21),14,5,8,(5,17),1,081,2,8,(-10,-13),1,0C0,024,025,
016,027,038,029,02A,8,(-1,-3),02C,8,(1,-3),02E,02F,030,021,022,2,
8,(3,-3),14,6,14,8,(9,-9),0
*000EA,51,lcˆ
2,14,8,(-9,-21),14,5,8,(5,18),1,8,(4,3),8,(4,-3),2,0AA,1,0C0,024,
025,016,027,038,029,02A,8,(-1,-3),02C,8,(1,-3),02E,02F,030,021,
022,2,8,(3,-3),14,6,14,8,(9,-9),0
*000EB,58,lc‰
2,14,8,(-9,-21),14,5,8,(4,20),1,01E,012,016,01A,2,080,1,01E,012,
016,01A,2,8,(-9,-12),1,0C0,024,025,016,027,038,029,02A,8,(-1,-3),
02C,8,(1,-3),02E,02F,030,021,022,2,8,(3,-3),14,6,14,8,(9,-9),0
*000EC,27,lc_
2,14,8,(-7,-21),14,5,8,(3,21),1,08F,2,04A,1,0DC,2,8,(4,0),14,6,
14,8,(7,-9),0
*000ED,27,lc
2,14,8,(-7,-21),14,5,8,(3,17),1,081,2,08B,1,0DC,2,8,(4,0),14,6,
14,8,(7,-9),0
*000EE,34,lcŒ
2,14,8,(-7,-21),14,5,8,(3,18),1,8,(4,3),8,(4,-3),2,8,(-4,-5),1,
0DC,2,8,(4,0),14,6,14,8,(7,-9),0
*000EF,39,lc‹
2,14,8,(-7,-21),14,5,8,(3,20),1,01E,012,016,01A,2,060,1,01E,012,
016,01A,2,8,(-2,-7),1,0DC,2,8,(4,0),14,6,14,8,(7,-9),0
*000F1,56,lc
2,14,3,2,14,8,(-19,-42),14,4,2,14,5,8,(4,18),1,032,010,03E,010,
032,2,8,(-11,-7),1,0EC,2,0A4,1,032,021,030,02F,8,(1,-3),0AC,2,
8,(4,0),14,6,14,3,2,14,8,(19,-18),14,4,2,0
*000F2,64,lc•
2,14,3,2,14,8,(-19,-42),14,4,2,14,5,8,(5,21),1,8,(9,-4),2,069,1,
029,02A,8,(-1,-3),02C,8,(1,-3),02E,02F,030,021,022,8,(1,3),024,
8,(-1,3),026,027,038,2,8,(11,-14),14,6,14,3,2,14,8,(19,-18),14,4,
2,0
*000F3,66,lc
2,14,3,2,14,8,(-19,-42),14,4,2,14,5,8,(5,17),1,8,(9,4),2,
8,(-6,-7),1,029,02A,8,(-1,-3),02C,8,(1,-3),02E,02F,030,021,022,
8,(1,3),024,8,(-1,3),026,027,038,2,8,(11,-14),14,6,14,3,2,
14,8,(19,-18),14,4,2,0
*000F4,73,lc“
2,14,3,2,14,8,(-19,-42),14,4,2,14,5,8,(5,18),3,2,1,8,(9,6),
8,(9,-6),2,4,2,8,(-6,-4),1,029,02A,8,(-1,-3),02C,8,(1,-3),02E,
02F,030,021,022,8,(1,3),024,8,(-1,3),026,027,038,2,8,(11,-14),
14,6,14,3,2,14,8,(19,-18),14,4,2,0
*000F5,68,lc^
2,14,3,2,14,8,(-19,-42),14,4,2,14,5,8,(4,18),1,032,010,03E,010,
032,2,8,(-7,-7),1,029,02A,8,(-1,-3),02C,8,(1,-3),02E,02F,030,021,
022,8,(1,3),024,8,(-1,3),026,027,038,2,8,(11,-14),14,6,14,3,2,
14,8,(19,-18),14,4,2,0
*000F6,74,lc”
2,14,3,2,14,8,(-19,-42),14,4,2,14,5,8,(4,20),1,01E,012,016,01A,2,
090,1,01E,012,016,01A,2,8,(-5,-6),1,029,02A,8,(-1,-3),02C,
8,(1,-3),02E,02F,030,021,022,8,(1,3),024,8,(-1,3),026,027,038,2,
8,(11,-14),14,6,14,3,2,14,8,(19,-18),14,4,2,0
*000F7,41,kto
2,14,8,(-9,-14),14,5,8,(8,13),1,01E,012,016,01A,2,8,(-5,-6),1,
0C0,2,8,(-7,-6),1,01E,012,016,01A,2,8,(10,-1),14,6,14,8,(9,-9),0
*000F8,24,lc›
7,06F,2,8,(-3,14),14,8,(9,9),1,8,(-13,-14),2,8,(17,0),
14,8,(-10,-9),0
*000F9,54,lc—
2,14,3,2,14,8,(-19,-42),14,4,2,14,5,8,(5,21),1,8,(9,-4),2,
8,(-10,-3),1,0AC,8,(1,-3),02F,030,021,032,2,0A4,1,0EC,2,8,(4,0),
14,6,14,3,2,14,8,(19,-18),14,4,2,0
*000FA,54,lc
2,14,3,2,14,8,(-19,-42),14,4,2,14,5,8,(5,17),1,8,(9,4),2,
8,(-10,-7),1,0AC,8,(1,-3),02F,030,021,032,2,0A4,1,0EC,2,8,(4,0),
14,6,14,3,2,14,8,(19,-18),14,4,2,0
*000FB,61,lc-
2,14,3,2,14,8,(-19,-42),14,4,2,14,5,8,(5,18),3,2,1,8,(9,6),
8,(9,-6),4,2,2,8,(-10,-4),1,0AC,8,(1,-3),02F,030,021,032,2,0A4,1,
0EC,2,8,(4,0),14,6,14,3,2,14,8,(19,-18),14,4,2,0
*000FC,62,lc_
2,14,3,2,14,8,(-19,-42),14,4,2,14,5,8,(4,20),1,01E,012,016,01A,2,
090,1,01E,012,016,01A,2,8,(-9,-6),1,0AC,8,(1,-3),02F,030,021,032,
2,0A4,1,0EC,2,8,(4,0),14,6,14,3,2,14,8,(19,-18),14,4,2,0
*000FD,43,lc^
2,14,8,(-8,-14),14,5,8,(2,14),5,032,1,8,(9,4),6,8,(6,-14),2,
8,(6,14),1,8,(-6,-14),04B,02A,029,018,2,8,(15,7),14,6,
14,8,(8,-16),0
*000FF,53,lc˜
2,14,8,(-8,-21),14,5,8,(3,20),1,01E,012,016,01A,2,080,1,01E,012,
016,01A,2,8,(-9,-6),1,8,(6,-14),2,8,(6,14),1,8,(-6,-14),04B,02A,
029,018,2,8,(15,7),14,6,14,8,(8,-16),0
*00104,50,c164
2,14,8,(-9,-21),14,5,8,(9,21),1,8,(-8,-21),2,8,(8,21),1,
8,(8,-21),3,2,10,(5,36),1,10,(5,-100),4,2,2,8,(-13,7),1,0A0,2,
8,(4,-7),14,6,14,8,(9,-9),0
*00105,66,c165
2,14,3,2,14,8,(-19,-28),14,4,2,14,5,8,(15,14),1,0EC,3,2,10,
(5,36),2,10,(5,-100),4,2,2,0B4,1,026,027,038,029,02A,8,(-1,-3),
02C,8,(1,-3),02E,02F,030,021,022,2,8,(4,-3),14,6,14,3,2,
14,8,(19,-18),14,4,2,0
*00106,71,c143
2,14,3,2,14,8,(-21,-42),14,4,2,14,5,3,2,2,8,(18,48),1,8,(8,6),2,
8,(-26,-54),4,2,8,(18,16),1,025,026,027,048,029,02A,02B,
8,(-1,-3),05C,8,(1,-3),02D,02E,02F,040,021,022,023,2,8,(3,-5),
14,6,14,3,2,14,8,(21,-18),14,4,2,0
*00107,54,c134
2,14,8,(-9,-14),14,5,8,(15,11),3,2,8,(-15,10),1,8,(6,4),2,
8,(9,-14),4,2,1,026,027,038,029,02A,8,(-1,-3),02C,8,(1,-3),02E,
02F,030,021,022,2,8,(3,-3),14,6,14,8,(9,-9),0
*0010C,49,c172
2,14,8,(-11,-27),8,(18,16),1,025,026,027,048,029,02A,02B,
8,(-1,-3),05C,8,(1,-3),02D,02E,02F,040,021,022,023,2,8,(-7,18),1,
042,2,04A,1,046,2,8,(14,-27),14,8,(-10,-9),0
*0010D,41,c159
2,14,8,(-9,-20),0F0,0B4,1,026,027,038,029,02A,8,(-1,-3),02C,
8,(1,-3),02E,02F,030,021,022,2,068,0D4,1,042,2,04A,1,046,2,
8,(13,-20),14,09A,0
*0010E,53,c210
2,14,8,(-11,-27),8,(4,21),1,0FC,06C,2,0F4,064,1,070,8,(3,-1),02E,
02D,8,(1,-3),05C,8,(-1,-3),02B,02A,8,(-3,-1),078,2,8,(7,23),1,
042,2,04A,1,046,2,8,(14,-27),14,8,(-10,-9),0
*0010F,46,c212
2,14,8,(-10,-21),8,(15,21),1,0FC,06C,2,0B4,1,026,027,038,029,02A,
8,(-1,-3),02C,8,(1,-3),02E,02F,030,021,022,2,8,(4,18),1,
8,(-3,-4),2,8,(3,-17),14,09A,0
*00118,66,c168
2,14,3,2,14,8,(-19,-42),14,4,2,14,5,8,(4,21),1,8,(0,-21),2,
8,(0,21),1,0D0,2,8,(-13,-10),1,080,2,8,(-8,-11),1,0D0,3,2,10,
(5,36),1,10,(5,-100),4,2,2,8,(2,0),14,6,14,3,2,14,8,(19,-18),
14,4,2,0
*00119,66,c169
2,14,8,(-9,-14),14,5,8,(3,8),1,0C0,024,025,016,027,038,029,02A,
8,(-1,-3),02C,8,(1,-3),02E,02F,030,3,2,10,(5,36),2,10,(5,-100),1,
4,2,021,022,2,3,2,10,(5,36),2,10,(5,-100),4,2,2,8,(3,-3),14,6,
14,8,(9,-9),0
*0011A,43,c183
2,14,8,(-10,-27),8,(4,21),1,0FC,06C,2,0F4,064,1,0D0,2,0D8,0AC,1,
080,2,088,0BC,1,0D0,2,8,(-7,23),1,042,2,04A,1,046,2,8,(13,-27),
14,09A,0
*0011B,44,c216
2,14,8,(-9,-20),030,084,1,0C0,024,025,016,027,038,029,02A,
8,(-1,-3),02C,8,(1,-3),02E,02F,030,021,022,2,068,0D4,1,042,2,04A,
1,046,2,8,(13,-20),14,09A,0
*00141,51,c157
2,14,3,2,14,8,(-17,-42),14,4,2,14,5,8,(3,21),1,8,(0,-21),2,
8,(-1,11),1,8,(7,8),2,8,(-6,-19),1,0C0,2,8,(3,0),14,6,14,3,2,
14,8,(17,-18),14,4,2,0
*00142,33,c136
2,14,8,(-4,-21),14,5,8,(5,21),1,8,(0,-21),2,8,(-1,10),1,8,(4,6),
2,8,(3,-16),14,6,14,8,(4,-9),0
*00143,52,c227
2,14,8,(-11,-21),14,5,8,(4,21),8,(5,3),1,8,(4,3),2,8,(-9,-6),1,
8,(0,-21),2,8,(0,21),1,8,(14,-21),2,8,(0,21),1,8,(0,-21),2,
8,(4,0),14,6,14,8,(11,-9),0
*00144,57,c228
2,14,3,2,14,8,(-19,-28),14,4,2,14,5,8,(4,14),8,(4,2),1,8,(3,2),2,
8,(-7,-4),1,0EC,2,0A4,1,032,021,030,02F,8,(1,-3),0AC,2,8,(4,0),
14,6,14,3,2,14,8,(19,-18),14,4,2,0
*00147,38,c213
2,14,8,(-11,-27),8,(4,21),1,0FC,06C,2,0F4,064,1,8,(14,-21),0F4,
064,2,078,024,1,042,2,04A,1,046,2,8,(15,-27),14,8,(-11,-9),0
*00148,37,c229
2,14,8,(-10,-20),040,0E4,1,0EC,2,0A4,1,032,021,030,02F,8,(1,-3),
0AC,2,8,(-5,16),1,042,2,04A,1,046,2,8,(13,-20),14,09A,0
*00150,58,c138
2,14,8,(-11,-21),14,5,8,(9,21),1,029,02A,02B,8,(-1,-3),05C,
8,(1,-3),02D,02E,02F,040,021,022,023,8,(1,3),054,8,(-1,3),025,
026,027,048,2,034,1,044,2,040,1,04C,2,8,(9,-24),14,6,
14,8,(11,-9),0
*00151,68,c139
2,14,3,2,14,8,(-19,-28),14,4,2,14,5,8,(8,14),1,029,02A,8,(-1,-3),
02C,8,(1,-3),02E,02F,030,021,022,8,(1,3),024,8,(-1,3),026,027,
038,2,8,(4,4),1,044,2,058,1,04C,2,8,(12,-18),14,6,14,3,2,
14,8,(19,-18),14,4,2,0
*00158,53,c252
2,14,8,(-11,-27),8,(4,21),1,0FC,06C,2,0F4,064,1,090,8,(3,-1),01E,
02D,02C,02B,01A,8,(-3,-1),098,2,070,1,8,(7,-11),2,8,(-7,23),1,
042,2,04A,1,046,2,8,(14,-27),14,8,(-10,-9),0
*00159,35,c253
2,14,8,(-7,-20),040,0E4,1,0EC,2,084,1,8,(1,3),022,021,030,2,058,
024,1,042,2,04A,1,046,2,0FD,05D,14,8,(-6,-9),0
*0015A,62,c151
2,14,8,(-10,-21),14,5,8,(17,18),8,(-9,6),1,8,(4,3),2,8,(5,-9),1,
026,8,(-3,1),048,8,(-3,-1),02A,02C,02D,01E,02F,8,(6,-2),02F,01E,
02D,03C,02A,8,(-3,-1),048,8,(-3,1),026,2,8,(17,-3),14,6,
14,8,(10,-9),0
*0015B,71,c152
2,14,3,2,14,8,(-17,-28),14,4,2,14,5,8,(14,11),8,(-7,5),1,8,(3,2),
2,8,(4,-7),1,025,8,(-3,1),038,8,(-3,-1),02B,02D,02F,8,(5,-1),02F,
02D,01C,02B,8,(-3,-1),038,8,(-3,1),025,2,8,(14,-3),14,6,14,3,2,
14,8,(17,-18),14,4,2,0
*00160,57,c230
2,14,8,(-10,-27),8,(17,18),1,026,8,(-3,1),048,8,(-3,-1),02A,02C,
02D,01E,02F,8,(6,-2),02F,01E,02D,03C,02A,8,(-3,-1),048,8,(-3,1),
026,2,8,(7,20),1,042,2,04A,1,046,2,8,(14,-27),14,8,(-10,-9),0
*00161,52,c231
2,14,8,(-9,-20),0E0,0B4,1,025,8,(-3,1),038,8,(-3,-1),02B,02D,02F,
8,(5,-1),02F,02D,01C,02B,8,(-3,-1),038,8,(-3,1),025,2,060,0D4,1,
042,2,04A,1,046,2,8,(12,-20),14,8,(-8,-9),0
*00164,35,c155
2,14,8,(-8,-27),8,(8,21),1,0FC,06C,2,8,(-7,21),1,0E0,2,078,024,1,
042,2,04A,1,046,2,8,(12,-27),14,8,(-8,-9),0
*00165,36,c156
2,14,8,(-6,-21),8,(5,21),1,0FC,02C,8,(1,-3),02F,020,2,088,0E4,1,
070,2,074,1,8,(-3,-4),2,8,(6,-17),14,8,(-6,-9),0
*0016E,45,c222
2,14,8,(-11,-27),8,(4,21),1,0FC,8,(1,-3),02E,8,(3,-1),020,
8,(3,1),022,8,(1,3),0F4,2,078,024,1,021,024,027,029,02C,02F,2,
8,(11,-23),14,8,(-11,-9),0
*0016F,38,c133
2,14,8,(-10,-20),040,0E4,1,0AC,8,(1,-3),02F,030,021,032,2,0A4,1,
0EC,2,8,(-5,16),1,021,024,027,029,02C,02F,2,8,(9,-16),14,09A,0
*00170,52,c235
2,14,8,(-11,-21),14,5,8,(4,21),1,0FC,8,(1,-3),02E,8,(3,-1),020,
8,(3,1),022,8,(1,3),0F4,2,058,034,1,044,2,048,1,04C,2,8,(9,-2),2,
8,(4,-22),14,6,14,8,(11,-9),0
*00171,60,c251
2,14,3,2,14,8,(-19,-28),14,4,2,14,5,8,(4,14),1,0AC,8,(1,-3),02F,
030,021,032,2,0A4,1,0EC,2,8,(-8,18),1,044,2,050,1,04C,2,
8,(3,-18),2,8,(4,0),14,6,14,3,2,14,8,(19,-20),14,4,2,0
*00179,45,c141
2,14,8,(-10,-21),14,5,8,(17,21),1,8,(-14,-21),2,8,(5,24),1,
8,(4,3),2,8,(-9,-6),1,0E0,2,8,(-14,-21),1,0E0,2,8,(3,0),14,6,
14,8,(10,-9),0
*0017A,58,c171
2,14,3,2,14,8,(-17,-28),14,4,2,14,5,8,(14,14),8,(-7,2),1,8,(3,2),
2,8,(4,-4),1,8,(-11,-14),2,0E4,1,0B0,2,8,(-11,-14),1,0B0,2,
8,(3,0),14,6,14,3,2,14,8,(17,-18),14,4,2,0
*0017B,45,c189
2,14,8,(-10,-21),14,5,8,(17,21),5,3,2,8,(-13,6),1,10,(2,96),4,2,
6,1,8,(-14,-21),0E0,2,8,(-14,21),1,0E0,2,8,(3,-21),14,6,
14,8,(10,-9),0
*0017C,59,c190
2,14,3,2,14,8,(-17,-28),14,4,2,14,5,8,(14,14),5,3,2,8,(-11,5),1,
10,(1,96),4,2,6,8,(-11,-14),2,0E4,1,0B0,2,8,(-11,-14),1,0B0,2,
8,(3,0),14,6,14,3,2,14,8,(17,-18),14,4,2,0
*0017D,42,c166
2,14,8,(-10,-27),8,(17,21),1,8,(-14,-21),2,0F4,064,1,0E0,2,
8,(-14,-21),1,0E0,2,8,(-7,23),1,042,2,04A,1,046,2,8,(14,-27),
14,8,(-10,-9),0
*0017E,38,c167
2,14,8,(-9,-20),0E2,1,8,(-11,-14),2,0E4,1,0B0,2,0B8,0EC,1,0B0,2,
8,(-5,16),1,042,2,04A,1,046,2,8,(12,-20),14,8,(-8,-9),0
*00410,38,_
2,14,8,(-9,-21),2,8,(4,7),1,9,(10,0),(0,0),2,8,(-13,-7),1,9,
(8,21),(8,-21),(0,0),2,8,(1,0),1,2,14,8,(-9,-9),0
*00411,46,_
2,14,8,(-10,-21),2,8,(15,21),1,9,(-11,0),(0,-21),(9,0),(3,1),
(1,1),(1,2),(0,3),(-1,2),(-1,1),(-3,1),(-9,0),(0,0),2,8,(17,-11),
1,2,14,8,(-11,-9),0
*00412,68,‚
2,14,8,(-11,-21),2,8,(13,21),1,9,(-9,0),(0,-21),(9,0),(3,1),
(1,1),(1,2),(0,3),(-1,2),(-1,1),(-3,1),(-9,0),(0,0),2,8,(9,10),1,
9,(3,-1),(1,-1),(1,-2),(0,-2),(-1,-2),(-1,-1),(-3,-1),(0,0),2,
8,(9,-11),1,2,14,8,(-11,-9),0
*00413,28,ƒ
2,14,8,(-8,-21),2,8,(16,21),1,9,(-12,0),(0,-21),(0,0),2,8,(13,0),
1,2,14,8,(-9,-9),0
*00414,50,„
2,14,8,(-12,-21),2,8,(22,-4),1,9,(0,4),(-20,0),(0,-4),(0,0),2,
8,(2,4),1,9,(3,3),(1,2),(1,4),(0,12),(11,0),(0,-21),(0,0),2,
8,(4,0),1,2,14,8,(-12,-13),0
*00415,40,…
2,14,8,(-9,-21),2,8,(17,21),1,9,(-13,0),(0,-21),(13,0),(0,0),2,
8,(-1,11),1,9,(-12,0),(0,0),2,8,(15,-11),1,2,14,8,(-10,-9),0
*00416,66,†
2,14,8,(-12,-21),2,8,(1,0),1,9,(9,12),(0,0),2,8,(2,9),1,9,
(0,-21),(0,0),2,8,(11,21),1,9,(-11,-11),(0,0),2,8,(-11,11),1,9,
(11,-11),(0,0),2,8,(11,-10),1,9,(-9,12),(0,0),2,8,(10,-12),1,2,
14,8,(-12,-9),0
*00417,68,‡
2,14,8,(-9,-21),2,8,(3,20),1,9,(4,1),(3,0),(3,-1),(1,-2),(0,-2),
(-1,-2),(-3,-2),(3,-1),(2,-2),(1,-2),(0,-2),(-1,-2),(-2,-2),
(-3,-1),(-3,0),(-3,1),(-3,2),(0,0),2,8,(9,9),1,9,(-4,0),(0,0),2,
8,(12,-12),1,2,14,8,(-9,-9),0
*00418,30,ˆ
2,14,8,(-11,-21),2,8,(4,21),1,9,(0,-21),(14,21),(0,-21),(0,0),2,
8,(4,0),1,2,14,8,(-11,-9),0
*00419,48,‰
2,14,8,(-11,-21),2,8,(4,21),1,9,(0,-21),(14,21),(0,-21),(0,0),2,
8,(-11,26),1,9,(1,-1),(2,-1),(2,0),(2,1),(1,1),(0,0),2,8,(7,-26),
1,2,14,8,(-11,-9),0
*0041A,46,Š
2,14,8,(-10,-21),2,8,(18,0),1,9,(-9,12),(0,0),2,8,(9,9),1,9,
(-14,-14),(0,0),2,8,(0,14),1,9,(0,-21),(0,0),2,8,(16,0),1,2,
14,8,(-10,-9),0
*0041B,36,‹
2,14,8,(-10,-21),2,8,(16,0),1,9,(0,21),(-11,0),(0,-17),(-1,-2),
(-1,-1),(-2,-1),(0,0),2,8,(19,0),1,2,14,8,(-10,-9),0
*0041C,32,Œ
2,14,8,(-12,-21),2,8,(20,0),1,9,(0,21),(-8,-15),(-8,15),(0,-21),
(0,0),2,8,(20,0),1,2,14,8,(-12,-9),0
*0041D,46,_
2,14,8,(-11,-21),2,8,(4,21),1,9,(0,-21),(0,0),2,8,(0,11),1,9,
(14,0),(0,0),2,8,(0,-11),1,9,(0,21),(0,0),2,8,(4,-21),1,2,
14,8,(-11,-9),0
*0041E,64,_
2,14,8,(-11,-21),2,8,(9,21),1,9,(4,0),(2,-1),(2,-2),(1,-2),
(1,-3),(0,-5),(-1,-3),(-1,-2),(-2,-2),(-2,-1),(-4,0),(-2,1),
(-2,2),(-1,2),(-1,3),(0,5),(1,3),(1,2),(2,2),(2,1),(0,0),2,
8,(13,-21),1,2,14,8,(-11,-9),0
*0041F,30,_
2,14,8,(-11,-21),2,8,(4,0),1,9,(0,21),(14,0),(0,-21),(0,0),2,
8,(4,0),1,2,14,8,(-11,-9),0
*00420,44,_
2,14,8,(-10,-21),2,8,(4,0),1,9,(0,21),(9,0),(3,-1),(1,-1),(1,-2),
(0,-3),(-1,-2),(-1,-1),(-3,-1),(-9,0),(0,0),2,8,(16,-10),1,2,
14,8,(-10,-9),0
*00421,62,'
2,14,8,(-10,-21),2,8,(18,16),1,9,(-1,2),(-1,1),(-1,1),(-2,1),
(-4,0),(-2,-1),(-1,-1),(-1,-1),(-1,-2),(-1,-3),(0,-5),(1,-3),
(1,-2),(2,-2),(2,-1),(4,0),(2,1),(2,2),(1,2),(0,0),2,8,(2,-5),1,
2,14,8,(-10,-9),0
*00422,36,'
2,14,8,(-8,-21),2,8,(8,21),1,9,(0,-21),(0,0),2,8,(-7,21),1,9,
(14,0),(0,0),2,8,(1,-21),1,2,14,8,(-8,-9),0
*00423,44,“
2,14,8,(-8,-21),2,8,(15,21),1,9,(-7,-17),(-1,-2),(-1,-1),(-2,-1),
(-1,0),(0,0),2,8,(-2,21),1,9,(7,-17),(0,0),2,8,(8,-4),1,2,
14,8,(-8,-9),0
*00424,74,”
2,14,8,(-13,-21),2,8,(11,19),1,9,(4,0),(3,-1),(2,-1),(2,-2),
(1,-2),(0,-4),(-1,-2),(-2,-2),(-2,-1),(-3,-1),(-4,0),(-3,1),
(-2,1),(-2,2),(-1,2),(0,4),(1,2),(2,2),(2,1),(3,1),(0,0),2,
8,(2,2),1,9,(0,-21),(0,0),2,8,(13,0),1,2,14,8,(-13,-9),0
*00425,36,•
2,14,8,(-8,-21),2,8,(15,21),1,9,(-14,-21),(0,0),2,8,(0,21),1,9,
(14,-21),(0,0),2,8,(1,0),1,2,14,8,(-8,-9),0
*00426,40,-
2,14,8,(-11,-21),2,8,(4,21),1,9,(0,-21),(16,0),(0,-4),(0,0),2,
8,(-2,25),1,9,(0,-21),(0,0),2,8,(4,0),1,2,14,8,(-11,-13),0
*00427,44,—
2,14,8,(-10,-21),2,8,(3,21),1,9,(0,-8),(1,-3),(1,-1),(3,-1),
(9,0),(0,0),2,8,(0,13),1,9,(0,-21),(0,0),2,8,(4,0),1,2,
14,8,(-11,-9),0
*00428,40,˜
2,14,8,(-14,-21),2,8,(4,21),1,9,(0,-21),(21,0),(0,21),(0,0),2,
8,(-10,0),1,9,(0,-21),(0,0),2,8,(14,0),1,2,14,8,(-15,-9),0
*00429,50,™
2,14,8,(-14,-21),2,8,(4,21),1,9,(0,-21),(23,0),(0,-4),(0,0),2,
8,(-12,25),1,9,(0,-21),(0,0),2,8,(10,21),1,9,(0,-21),(0,0),2,
8,(4,0),1,2,14,8,(-15,-13),0
*0042A,48,š
2,14,8,(-10,-21),2,8,(1,21),1,9,(4,0),(0,-21),(8,0),(2,0),(2,1),
(1,1),(1,2),(0,4),(-1,2),(-1,1),(-2,1),(-10,0),(0,0),2,
8,(16,-12),1,2,14,8,(-11,-9),0
*0042B,54,›
2,14,8,(-12,-21),2,8,(4,21),1,9,(0,-21),(9,0),(2,1),(1,1),(1,2),
(0,4),(-1,2),(-1,1),(-2,1),(-9,0),(0,0),2,8,(16,9),1,9,(0,-21),
(0,0),2,8,(4,0),1,2,14,8,(-12,-9),0
*0042C,44,œ
2,14,8,(-10,-21),2,8,(4,21),1,9,(0,-21),(10,0),(2,1),(1,1),(1,2),
(0,4),(-1,2),(-1,1),(-2,1),(-10,0),(0,0),2,8,(16,-12),1,2,
14,8,(-10,-9),0
*0042D,64,_
2,14,8,(-9,-21),2,8,(6,11),1,9,(10,0),(0,0),2,8,(-14,7),1,9,
(2,2),(2,1),(4,0),(2,-1),(2,-2),(1,-2),(1,-3),(0,-5),(-1,-3),
(-1,-2),(-2,-2),(-2,-1),(-4,0),(-2,1),(-2,2),(0,0),2,8,(17,-3),1,
2,14,8,(-10,-9),0
*0042E,76,_
2,14,8,(-13,-21),2,8,(14,21),1,9,(4,0),(2,-1),(2,-3),(1,-4),
(0,-5),(-1,-4),(-2,-3),(-2,-1),(-4,0),(-2,1),(-2,3),(-1,4),(0,5),
(1,4),(2,3),(2,1),(0,0),2,8,(-5,-10),1,9,(-5,0),(0,0),2,8,(0,10),
1,9,(0,-21),(0,0),2,8,(22,0),1,2,14,8,(-13,-9),0
*0042F,54,Ÿ
2,14,8,(-10,-21),2,8,(2,0),1,9,(7,11),(0,0),2,8,(7,-11),1,9,
(0,21),(-9,0),(-3,-1),(-1,-1),(-1,-2),(0,-2),(1,-2),(1,-1),
(3,-1),(9,0),(0,0),2,8,(4,-11),1,2,14,8,(-10,-9),0
*00430,62,
2,14,8,(-9,-14),2,8,(15,3),1,9,(-2,-2),(-2,-1),(-3,0),(-2,1),
(-1,1),(-1,1),(-1,3),(0,2),(1,3),(2,2),(2,1),(3,0),(2,-1),(2,-2),
(0,0),2,8,(0,3),1,9,(0,-14),(0,0),2,8,(4,0),1,2,14,8,(-10,-9),0
*00431,64,
2,14,8,(-9,-21),2,8,(14,21),1,9,(-2,-1),(-5,-1),(-2,-1),(-1,-2),
(0,-12),(1,-2),(1,-1),(2,-1),(3,0),(2,1),(2,2),(1,3),(0,2),
(-1,3),(-1,1),(-1,1),(-2,1),(-3,0),(-2,-1),(-2,-2),(0,0),2,
8,(15,-11),1,2,14,8,(-10,-9),0
*00432,68,
2,14,8,(-9,-21),2,8,(4,11),1,9,(2,2),(2,1),(3,2),(1,2),(-1,2),
(-1,1),(-3,0),(-2,-1),(-1,-1),(0,-15),(1,-2),(1,-1),(2,-1),(3,0),
(2,1),(2,2),(1,3),(0,2),(-1,3),(-2,2),(-2,1),(-3,0),(0,0),2,
8,(11,-14),1,2,14,8,(-10,-9),0
*00433,56,
2,14,8,(-8,-14),2,8,(3,11),1,9,(1,2),(3,1),(3,0),(3,-1),(1,-2),
(-1,-2),(-2,-1),(-5,-1),(-2,-1),(-1,-2),(0,-1),(1,-2),(3,-1),
(3,0),(3,1),(1,2),(0,0),2,8,(3,-3),1,2,14,8,(-9,-9),0
*00434,72,
2,14,8,(-9,-14),2,8,(15,11),1,9,(-1,1),(-1,1),(-2,1),(-3,0),
(-2,-1),(-2,-2),(-1,-3),(0,-2),(1,-3),(2,-2),(2,-1),(3,0),(2,1),
(2,2),(0,0),2,8,(0,11),1,9,(0,-16),(-1,-3),(-1,-1),(-2,-1),
(-3,0),(-2,1),(0,0),2,8,(13,6),1,2,14,8,(-10,-16),0
*00435,56,
2,14,8,(-9,-14),2,8,(3,8),1,9,(12,0),(0,2),(-1,2),(-1,1),(-2,1),
(-3,0),(-2,-1),(-2,-2),(-1,-3),(0,-2),(1,-3),(2,-2),(2,-1),(3,0),
(2,1),(2,2),(0,0),2,8,(3,-3),1,2,14,8,(-9,-9),0
*00436,58,
2,14,8,(-11,-14),2,8,(1,0),1,9,(7,8),(0,0),2,8,(12,6),1,9,
(-9,-9),(-9,9),(0,0),2,8,(9,0),1,9,(0,-14),(0,0),2,8,(3,8),1,9,
(7,-8),(0,0),2,8,(1,0),1,2,14,8,(-11,-9),0
*00437,62,
2,14,8,(-7,-14),2,8,(8,8),1,9,(2,-1),(1,-1),(1,-2),(-1,-2),
(-1,-1),(-2,-1),(-4,0),(-3,1),(0,0),2,8,(0,12),1,9,(3,1),(3,0),
(3,-1),(1,-2),(-1,-2),(-2,-1),(-3,0),(0,0),2,8,(9,-8),1,2,
14,8,(-7,-9),0
*00438,46,
2,14,8,(-9,-14),2,8,(4,14),1,9,(0,-10),(1,-3),(2,-1),(3,0),(2,1),
(3,3),(0,0),2,8,(0,10),1,9,(0,-14),(0,0),2,8,(4,0),1,2,
14,8,(-10,-9),0
*00439,64,
2,14,8,(-9,-14),2,8,(4,14),1,9,(0,-10),(1,-3),(2,-1),(3,0),(2,1),
(3,3),(0,0),2,8,(0,10),1,9,(0,-14),(0,0),2,8,(-9,18),1,9,(1,-1),
(2,-1),(2,0),(2,1),(1,1),(0,0),2,8,(5,-18),1,2,14,8,(-10,-9),0
*0043A,46,
2,14,8,(-8,-14),2,8,(4,14),1,9,(0,-14),(0,0),2,8,(4,8),1,9,
(7,-8),(0,0),2,8,(-1,14),1,9,(-10,-10),(0,0),2,8,(12,-4),1,2,
14,8,(-8,-9),0
*0043B,44,
2,14,8,(-9,-14),2,8,(14,14),1,9,(-6,0),(0,-10),(-1,-3),(-2,-1),
(-2,0),(0,0),2,8,(11,14),1,9,(0,-14),(0,0),2,8,(4,0),1,2,
14,8,(-9,-9),0
*0043C,32,
2,14,8,(-11,-14),2,8,(18,0),1,9,(0,14),(-7,-11),(-7,11),(0,-14),
(0,0),2,8,(18,0),1,2,14,8,(-11,-9),0
*0043D,46,-
2,14,8,(-9,-14),2,8,(4,7),1,9,(11,0),(0,0),2,8,(0,7),1,9,(0,-14),
(0,0),2,8,(-11,14),1,9,(0,-14),(0,0),2,8,(15,0),1,2,
14,8,(-10,-9),0
*0043E,56,
2,14,8,(-9,-14),2,8,(8,14),1,9,(3,0),(2,-1),(2,-2),(1,-3),(0,-2),
(-1,-3),(-2,-2),(-2,-1),(-3,0),(-2,1),(-2,2),(-1,3),(0,2),(1,3),
(2,2),(2,1),(0,0),2,8,(11,-14),1,2,14,8,(-10,-9),0
*0043F,46,
2,14,8,(-9,-14),2,8,(4,14),1,9,(0,-14),(0,0),2,8,(0,10),1,9,
(3,3),(2,1),(3,0),(2,-1),(1,-2),(0,-11),(0,0),2,8,(4,0),1,2,
14,8,(-10,-9),0
*00440,60,
2,14,8,(-9,-14),2,8,(4,14),1,9,(0,-21),(0,0),2,8,(0,18),1,9,
(2,2),(2,1),(3,0),(2,-1),(2,-2),(1,-3),(0,-2),(-1,-3),(-2,-2),
(-2,-1),(-3,0),(-2,1),(-2,2),(0,0),2,8,(15,-3),1,2,
14,8,(-10,-16),0
*00441,50,
2,14,8,(-8,-14),2,8,(15,11),1,9,(-2,2),(-2,1),(-3,0),(-2,-1),
(-2,-2),(-1,-3),(0,-2),(1,-3),(2,-2),(2,-1),(3,0),(2,1),(2,2),
(0,0),2,8,(2,-3),1,2,14,8,(-9,-9),0
*00442,66,
2,14,8,(-14,-14),2,8,(4,14),1,9,(0,-14),(0,0),2,8,(0,10),1,9,
(3,3),(2,1),(2,0),(2,-1),(1,-3),(0,-10),(0,0),2,8,(0,10),1,9,
(3,3),(2,1),(2,0),(2,-1),(1,-3),(0,-10),(0,0),2,8,(4,0),1,2,
14,8,(-14,-9),0
*00443,44,
2,14,8,(-7,-14),2,8,(1,14),1,9,(6,-14),(0,0),2,8,(6,14),1,9,
(-6,-14),(-2,-4),(-2,-2),(-2,-1),(-1,0),(0,0),2,8,(14,7),1,2,
14,8,(-7,-16),0
*00444,66,
2,14,8,(-11,-14),2,8,(14,14),1,9,(-6,0),(-2,-1),(-2,-2),(-1,-3),
(0,-2),(1,-3),(2,-2),(2,-1),(6,0),(2,1),(2,2),(1,3),(0,2),(-1,3),
(-2,2),(-2,1),(0,0),2,8,(-3,0),1,9,(0,-21),(0,0),2,8,(11,7),1,2,
14,8,(-11,-16),0
*00445,36,
2,14,8,(-6,-14),2,8,(1,14),1,9,(11,-14),(0,0),2,8,(0,14),1,9,
(-11,-14),(0,0),2,8,(12,0),1,2,14,8,(-7,-9),0
*00446,50,
2,14,8,(-9,-14),2,8,(4,14),1,9,(0,-10),(1,-3),(2,-1),(3,0),(2,1),
(3,3),(0,0),2,8,(0,10),1,9,(0,-14),(2,0),(0,-3),(0,0),2,8,(2,3),
1,2,14,8,(-10,-12),0
*00447,46,
2,14,8,(-9,-14),2,8,(3,14),1,9,(0,-5),(1,-3),(2,-1),(3,0),(2,1),
(3,3),(0,0),2,8,(0,5),1,9,(0,-14),(0,0),2,8,(4,0),1,2,
14,8,(-9,-9),0
*00448,66,
2,14,8,(-14,-14),2,8,(24,0),1,9,(0,14),(0,0),2,8,(0,-10),1,9,
(-3,-3),(-2,-1),(-2,0),(-2,1),(-1,3),(0,10),(0,0),2,8,(0,-10),1,
9,(-3,-3),(-2,-1),(-2,0),(-2,1),(-1,3),(0,10),(0,0),2,8,(24,-14),
1,2,14,8,(-14,-9),0
*00449,70,
2,14,8,(-14,-14),2,8,(14,4),1,9,(-3,-3),(-2,-1),(-2,0),(-2,1),
(-1,3),(0,10),(0,0),2,8,(20,-10),1,9,(-3,-3),(-2,-1),(-2,0),
(-2,1),(-1,3),(0,10),(0,0),2,8,(10,0),1,9,(0,-14),(2,0),(0,-3),
(0,0),2,8,(2,3),1,2,14,8,(-14,-12),0
*0044A,64,
2,14,8,(-9,-14),2,8,(4,8),1,9,(1,1),(2,1),(3,0),(1,0),(2,-1),
(1,-1),(1,-2),(0,-2),(-1,-2),(-1,-1),(-2,-1),(-4,0),(-2,1),
(-1,1),(0,0),2,8,(-3,12),1,9,(3,0),(0,-14),(0,0),2,8,(14,0),1,2,
14,8,(-9,-9),0
*0044B,72,
2,14,8,(-10,-14),2,8,(4,8),1,9,(1,1),(2,1),(3,0),(1,0),(2,-1),
(1,-1),(1,-2),(0,-2),(-1,-2),(-1,-1),(-2,-1),(-4,0),(-2,1),
(-1,1),(0,0),2,8,(0,12),1,9,(0,-14),(0,0),2,8,(13,14),1,9,
(0,-14),(0,0),2,8,(4,0),1,2,14,8,(-11,-9),0
*0044C,62,
2,14,8,(-9,-14),2,8,(4,8),1,9,(1,1),(2,1),(3,0),(1,0),(2,-1),
(1,-1),(1,-2),(0,-2),(-1,-2),(-1,-1),(-2,-1),(-4,0),(-2,1),
(-1,1),(0,0),2,8,(0,12),1,9,(0,-14),(0,0),2,8,(14,0),1,2,
14,8,(-9,-9),0
*0044D,60,
2,14,8,(-8,-14),2,8,(2,11),1,9,(2,2),(2,1),(3,0),(2,-1),(2,-2),
(1,-3),(0,-2),(-1,-3),(-2,-2),(-2,-1),(-3,0),(-2,1),(-2,2),(0,0),
2,8,(12,4),1,9,(-6,0),(0,0),2,8,(9,-7),1,2,14,8,(-9,-9),0
*0044E,70,
2,14,8,(-12,-14),2,8,(4,14),1,9,(0,-14),(0,0),2,8,(0,7),1,9,
(5,0),(0,1),(1,3),(2,2),(2,1),(2,0),(2,-1),(2,-2),(1,-3),(0,-2),
(-1,-3),(-2,-2),(-2,-1),(-2,0),(-2,1),(-2,2),(-1,3),(0,1),(0,0),
2,8,(15,-7),1,2,14,8,(-12,-9),0
*0044F,54,
2,14,8,(-8,-14),2,8,(3,0),1,9,(4,5),(0,0),2,8,(6,-5),1,9,(0,14),
(-6,0),(-2,-1),(-1,-1),(-1,-2),(0,-1),(1,-2),(1,-1),(2,-1),(6,0),
(0,0),2,8,(4,-5),1,2,14,8,(-9,-9),0
*020A0,4,keuroRef2
7,0020AC,0
*020A7,49,kpes
2,14,8,(-11,-21),14,5,030,1,8,(0,21),050,02F,01E,02D,05C,02B,01A,
029,058,2,8,(12,13),1,8,(0,-18),02D,02F,010,2,8,(-6,14),1,060,2,
8,(3,-14),14,6,14,8,(11,-9),0
*020AC,45,keuro
2,14,8,(-10,-21),8,(2,10),5,1,014,00A,(9,-043),2,6,5,1,01C,00A,(9,043),
2,6,8,(-1,2),5,1,8,(13,0),2,6,04C,1,0B0,2,08C,080,14,8,(-10,-9),0
*02126,53,komega
2,14,8,(-11,-21),14,5,8,(3,1),1,01E,040,014,036,025,8,(-1,3),044,
8,(1,3),023,022,021,040,02F,02E,02D,8,(1,-3),04C,8,(-1,-3),02B,
03A,01C,040,012,2,8,(3,-1),14,6,14,8,(11,-9),0
*02205,64,kdiam
2,14,3,2,14,8,(-19,-40),14,4,2,14,5,8,(8,17),1,029,02A,8,(-1,-3),
02C,8,(1,-3),02E,02F,030,021,022,8,(1,3),024,8,(-1,3),026,027,
038,2,061,1,8,(-9,-20),2,8,(14,0),14,6,14,3,2,14,8,(19,-18),14,4,
2,0
*0221E,45,kinfin
2,14,8,(-11,-14),14,5,8,(11,11),1,025,027,028,029,02B,01C,02D,
02F,020,021,023,014,023,021,020,02F,02D,01C,02B,029,028,027,025,
2,8,(11,-10),14,6,14,8,(11,-9),0
*02264,36,kleq
2,14,8,(-13,-21),14,5,8,(22,21),1,8,(-18,-9),8,(18,-9),2,
8,(-18,-2),1,8,(18,0),2,8,(4,-1),14,6,14,8,(13,-9),0
*02302,25,ktria
2,14,8,(-10,-21),14,5,040,1,0C0,084,066,06A,08C,2,8,(16,0),14,6,
14,8,(10,-9),0


확장된 Simplex Roman (요약 참조)

문자 글꼴 설명
확장된 Simplex Roman
UNICODE를 위한 확장된 표준 글꼴
AutoCAD 2008 사용자화 안내서 > 쉐이프 및 쉐이프 글꼴 > 쉐이프 정의 파일 작성 > 예제 파일 > 확장된 Simplex Roman >
확장된 Simplex Roman
개념 요약 참조

명령

LOAD

쉐이프를 SHAPE 명령에 사용할 수 있게 만듭니다.

SHAPE

LOAD를 사용하여 로드된 쉐이프 파일의 쉐이프를 삽입합니다.

시스템 변수

항목이 없습니다.

유틸리티

항목이 없습니다.

명령 수정자

항목이 없습니다.


UNICODE를 위한 확장된 표준 글꼴 (개념)

확장된 Simplex Roman
예제 파일
큰 글꼴 설명
AutoCAD 2008 사용자화 안내서 > 쉐이프 및 쉐이프 글꼴 > 쉐이프 정의 파일 작성 > 예제 파일 >
UNICODE를 위한 확장된 표준 글꼴
개념 요약 참조

;;
;; txt.shp - Extended Standard Font for UNICODE
;;
;; Copyright 1997 by Autodesk, Inc.
;;
;; Permission to use, copy, modify, and distribute this software for
;; any purpose and without fee is hereby granted, provided that the
;; above copyright notice appears in all copies and that the restricted
;; rights notice below appear in all supporting documentation.
;;
;; Use, duplication, or disclosure by the U.S. Government is subject
;; to restrictions set forth in FAR 52.227-19 (Commercial Computer
;; Software - Restricted Rights) and DFAR 252.227-7013(c)(1)(ii)
;; (Rights in Technical Data and Computer Software), as applicable.
;;
*UNIFONT,6,TXT Copyright 1997 by Autodesk, Inc.
6,2,2,0,0,0
*0000A,7,lf
2,0AC,14,8,(9,10),0
*00020,7,spc
2,060,14,8,(-6,-8),0
*00021,17,kexc
2,14,06C,1,014,2,014,1,044,2,020,06C,14,8,(-2,-3),0
*00022,20,kdblqt
2,14,8,(-1,-6),044,1,023,2,010,1,02B,2,04C,030,14,8,(-3,1),0
*00023,27,kns
2,14,8,(-2,-6),024,1,040,2,024,1,048,2,023,1,06C,2,020,1,064,2,
06D,14,8,(-4,-3),0
*00024,25,kds
2,14,8,(-2,-6),014,1,030,012,016,028,016,012,030,2,027,1,06C,2,
040,14,8,(-4,-3),0
*00025,31,kpc
2,14,8,(-2,-6),064,1,01C,010,014,018,2,040,1,8,(-4,-6),2,040,1,
018,014,010,01C,2,020,14,8,(-4,-3),0
*00026,24,kand
2,14,8,(-2,-6),041,1,02A,018,016,014,022,014,016,01A,01C,04E,2,
020,14,8,(-4,-3),0
*00027,28,kapos
2,14,3,2,14,8,(-1,-12),14,4,2,044,1,023,2,06C,020,14,3,2,
14,8,(-5,2),14,4,2,0
*00028,16,klp
2,14,8,(-1,-6),064,020,1,02A,02C,02E,2,020,14,03A,0
*00029,15,krp
2,14,8,(-1,-6),064,1,02E,02C,02A,2,040,14,03A,0
*0002A,27,kas
2,14,8,(-2,-5),021,1,044,2,02E,1,048,2,041,1,04A,2,044,1,04E,2,
02F,14,8,(-4,-3),0
*0002B,19,kpls
2,14,8,(-2,-5),021,1,044,2,02E,1,048,2,06F,14,8,(-4,-3),0
*0002C,28,kcma
2,14,3,2,14,02B,14,4,2,014,010,1,01C,01A,2,012,020,14,3,2,
14,8,(-3,-8),14,4,2,0
*0002D,14,ksub
2,14,8,(-2,-3),034,1,040,2,020,03C,14,048,0
*0002E,12,kper
2,14,01C,1,014,2,02F,14,8,(-2,-3),0
*0002F,17,kdiv
2,14,8,(-2,-6),1,8,(4,6),2,020,06C,14,8,(-4,-3),0
*00030,34,n0
2,14,3,2,14,8,(-3,-12),14,4,2,010,1,016,044,012,010,01E,04C,01A,
018,2,040,14,3,2,14,8,(-7,-6),14,4,2,0
*00031,18,n1
2,14,8,(-1,-6),054,1,012,06C,2,018,1,020,2,020,14,03A,0
*00032,23,n2
2,14,8,(-2,-6),054,1,012,020,01E,01C,01A,028,01A,02C,040,2,020,
14,8,(-4,-3),0
*00033,29,n3
2,14,8,(-2,-6),054,1,012,020,01E,01C,01A,018,2,010,1,01E,01C,01A,
028,016,2,01C,060,14,8,(-4,-3),0
*00034,19,n4
2,14,8,(-2,-6),041,1,048,8,(3,4),06C,2,030,14,8,(-4,-3),0
*00035,23,n5
2,14,8,(-2,-6),014,1,01E,020,012,024,016,038,024,040,2,020,06C,
14,8,(-4,-3),0
*00036,24,n6
2,14,8,(-2,-6),034,1,030,01E,01C,01A,028,016,034,022,010,2,030,
06C,14,8,(-4,-3),0
*00037,16,n7
2,14,8,(-2,-6),064,1,040,06B,2,050,14,8,(-4,-3),0
*00038,32,n8
2,14,8,(-2,-6),010,1,016,014,012,020,012,014,016,028,01A,01C,01E,
2,020,1,01E,01C,01A,028,2,050,14,8,(-4,-3),0
*00039,24,n9
2,14,8,(-2,-6),010,1,010,022,034,016,028,01A,01C,01E,030,2,020,
03C,14,8,(-4,-3),0
*0003A,17,kcol
2,14,04C,044,1,01C,2,01C,1,01C,2,02F,14,8,(-2,-3),0
*0003B,34,ksmc
2,14,3,2,14,8,(-1,-8),14,4,2,010,044,1,01C,2,01C,1,02C,01A,2,012,
020,14,3,2,14,8,(-5,-8),14,4,2,0
*0003C,29,klt2
2,14,3,2,14,8,(-3,-12),14,4,2,064,030,1,03A,03E,2,020,14,3,2,
14,8,(-5,-6),14,4,2,0
*0003D,18,keq
2,14,04B,044,1,040,2,02C,1,048,2,060,02C,14,8,(-4,-1),0
*0003E,28,kgt2
2,14,3,2,14,8,(-3,-12),14,4,2,064,1,03E,03A,2,050,14,3,2,
14,8,(-7,-6),14,4,2,0
*0003F,36,kqm
2,14,3,2,14,8,(-3,-12),14,4,2,054,1,012,010,01E,01C,01A,01C,2,
01C,1,01C,2,030,14,3,2,14,8,(-7,-6),14,4,2,0
*00040,28,kea
2,14,8,(-2,-6),032,1,01A,018,014,012,010,02C,012,024,016,028,01A,
04C,01E,030,2,020,14,8,(-4,-3),0
*00041,21,uca2
2,14,8,(-2,-6),1,024,043,04D,02C,2,047,1,040,2,02E,14,8,(-4,-3),0
*00042,29,ucb
2,14,8,(-2,-6),1,030,012,014,016,028,2,020,1,012,014,016,038,2,
010,1,06C,2,050,14,8,(-4,-3),0
*00043,23,ucc
2,14,8,(-2,-6),040,014,1,01A,028,016,044,012,020,01E,2,02E,03C,
14,8,(-4,-3),0
*00044,22,ucd
2,14,8,(-2,-6),1,030,012,044,016,038,2,010,1,06C,2,050,
14,8,(-4,-3),0
*00045,25,uce
2,14,8,(-2,-6),1,064,040,2,048,03C,1,020,2,028,03C,1,040,2,020,
14,8,(-4,-3),0
*00046,21,ucf
2,14,8,(-2,-6),1,064,040,2,048,03C,1,020,2,03C,040,14,8,(-4,-3),0
*00047,22,ucg
2,14,8,(-2,-6),032,1,010,03C,038,016,044,012,030,2,020,06C,
14,8,(-4,-3),0
*00048,22,uch
2,14,8,(-2,-6),1,064,2,03C,1,040,2,034,1,06C,2,020,14,8,(-4,-3),0
*00049,21,uci
2,14,8,(-1,-6),064,1,020,2,018,1,06C,2,018,1,020,2,020,14,03A,0
*0004A,19,ucj
2,14,8,(-2,-6),014,1,01E,020,012,054,2,020,06C,14,8,(-4,-3),0
*0004B,23,uck
2,14,8,(-2,-6),1,064,2,040,1,03A,018,2,010,1,03E,2,020,
14,8,(-4,-3),0
*0004C,16,ucl
2,14,8,(-2,-6),064,1,06C,040,2,020,14,8,(-4,-3),0
*0004D,17,ucm
2,14,8,(-2,-6),1,064,04D,043,06C,2,020,14,8,(-4,-3),0
*0004E,19,ucn
2,14,8,(-2,-6),1,064,8,(4,-6),064,2,06C,020,14,8,(-4,-3),0
*0004F,17,uco
2,14,8,(-2,-6),1,064,040,06C,048,2,060,14,8,(-4,-3),0
*00050,19,ucp
2,14,8,(-2,-6),1,064,030,01E,01C,01A,038,2,06F,14,8,(-4,-3),0
*00051,25,ucq
2,14,8,(-2,-6),022,1,01E,01A,018,016,044,012,020,01E,03C,01A,01E,
2,020,14,8,(-4,-3),0
*00052,23,ucr
2,14,8,(-2,-6),1,064,030,01E,01C,01A,038,2,010,1,03E,2,020,
14,8,(-4,-3),0
*00053,22,ucs
2,14,8,(-2,-6),014,1,01E,020,012,046,012,020,01E,2,020,05C,
14,8,(-4,-3),0
*00054,19,uct
2,14,8,(-2,-6),064,1,040,2,028,1,06C,2,040,14,8,(-4,-3),0
*00055,20,ucu
2,14,8,(-2,-6),064,1,05C,01E,020,012,054,2,020,06C,14,8,(-4,-3),0
*00056,15,ucv
2,14,06B,064,1,06D,063,2,020,06C,14,8,(-5,-3),0
*00057,24,ucw
2,14,06B,064,1,9,(2,-6),(1,3),(1,-3),(2,6),(0,0),2,020,06C,
14,8,(-5,-3),0
*00058,22,ucx
2,14,8,(-2,-6),1,8,(4,6),2,048,1,8,(4,-6),2,020,14,8,(-4,-3),0
*00059,25,ucy
2,14,8,(-2,-6),064,1,8,(2,-3),03C,2,034,1,8,(2,3),2,020,06C,
14,8,(-4,-3),0
*0005A,19,ucz
2,14,8,(-2,-6),064,1,040,8,(-4,-6),040,2,020,14,8,(-4,-3),0
*0005B,17,klb
2,14,8,(-1,-6),1,064,020,2,06C,1,028,2,040,14,03A,0
*0005C,17,kbkslsh
2,14,8,(-2,-6),064,1,8,(4,-6),2,020,14,8,(-4,-3),0
*0005D,15,krb
2,14,8,(-1,-6),064,1,020,06C,028,2,040,14,03A,0
*0005E,16,kcaret2
2,14,8,(-2,-6),044,1,022,02E,2,04D,14,8,(-4,1),0
*0005F,11,kundrl
2,14,028,01C,1,040,2,021,14,04A,0
*00060,27,krvap
2,14,3,2,14,8,(-1,-12),14,4,2,064,1,02D,2,04D,14,3,2,14,8,(-5,2),
14,4,2,0
*00061,24,lca
2,14,04B,020,1,018,016,024,012,010,01E,02C,01A,2,012,1,01E,2,020,
14,8,(-4,-3),0
*00062,25,lcb
2,14,8,(-2,-6),1,064,2,04C,1,022,010,01E,02C,01A,018,026,2,02C,
060,14,8,(-4,-3),0
*00063,17,lcc
2,14,04B,042,1,038,01A,02C,01E,030,2,020,14,8,(-4,-3),0
*00064,25,lcd
2,14,8,(-2,-6),041,1,02A,018,016,024,012,010,02E,2,044,1,06C,2,
020,14,8,(-4,-3),0
*00065,20,lce
2,14,04B,024,1,030,012,016,028,01A,02C,01E,020,2,030,
14,8,(-4,-3),0
*00066,22,lcf
2,14,8,(-2,-6),034,1,030,2,023,1,016,018,01A,05C,2,050,
14,8,(-4,-3),0
*00067,22,lcg
2,14,04B,01C,1,01E,020,012,044,016,028,01A,02C,01E,030,2,020,
14,8,(-4,-5),0
*00068,21,lch
2,14,8,(-2,-6),1,064,2,04C,1,022,010,01E,03C,2,020,14,8,(-4,-3),0
*00069,17,lci
2,14,06C,1,044,2,014,1,014,2,020,06C,14,8,(-2,-3),0
*0006A,35,lcj
2,14,3,2,14,8,(-3,-12),14,4,2,01C,1,01E,010,012,054,2,014,1,014,
2,020,06C,14,3,2,14,8,(-7,-10),14,4,2,0
*0006B,23,lck
2,14,8,(-2,-6),1,064,2,04C,1,020,022,2,02A,1,02E,2,020,
14,8,(-4,-3),0
*0006C,28,lcl2
2,14,3,2,14,8,(-1,-12),14,4,2,064,1,05C,01E,2,020,14,3,2,
14,8,(-5,-6),14,4,2,0
*0006D,24,lcm
2,14,04B,1,044,2,01C,1,012,01E,01C,2,014,1,012,01E,03C,2,020,
14,8,(-4,-3),0
*0006E,21,lcn
2,14,8,(-2,-6),1,044,2,02C,1,022,010,01E,03C,2,020,14,8,(-4,-3),0
*0006F,20,lco
2,14,04B,030,1,028,016,024,012,020,01E,02C,01A,2,030,
14,8,(-4,-3),0
*00070,22,lcp
2,14,04B,02C,1,064,2,01C,1,012,020,01E,02C,01A,038,2,060,
14,8,(-4,-5),0,
*00071,22,lcq
2,14,04B,04F,1,064,2,01C,1,016,028,01A,02C,01E,030,2,020,
14,8,(-4,-5),0,
*00072,19,lcr
2,14,04B,1,044,2,02C,1,022,010,01E,2,020,03C,14,8,(-4,-3),0
*00073,18,lcs
2,14,04B,1,030,012,016,028,016,012,030,2,04D,14,8,(-4,-3),0
*00074,21,lct
2,14,8,(-2,-6),044,1,040,2,026,1,05C,01E,012,2,02F,14,8,(-4,-3),0
*00075,20,lcu
2,14,04B,044,1,03C,01E,010,022,2,024,1,04C,2,020,14,8,(-4,-3),0
*00076,14,lcv
2,14,04B,044,1,04D,043,2,04D,14,8,(-4,-3),0
*00077,23,lcw
2,14,04B,044,1,9,(1,-4),(1,4),(1,-4),(1,4),(0,0),2,04D,
14,8,(-4,-3),0
*00078,16,lcx
2,14,04B,1,042,2,048,1,04E,2,020,14,8,(-4,-3),0
*00079,19,lcy
2,14,04B,044,1,04D,2,043,1,06B,018,2,024,060,14,8,(-4,-5),0
*0007A,15,lcz
2,14,04B,044,1,040,04A,040,2,020,14,8,(-4,-3),0
*0007B,19,klbr
2,14,8,(-1,-6),064,020,1,01A,01C,01A,01E,01C,01E,2,020,14,03A,0
*0007C,13,kvbar
2,14,06C,1,064,2,06C,020,14,8,(-2,-3),0
*0007D,18,krbr
2,14,8,(-1,-6),1,012,014,012,016,014,016,2,06C,040,14,03A,0
*0007E,15,ktlde
2,14,04B,034,1,012,02F,012,2,04D,14,8,(-4,-2),0
*00080,4,keuroRef
7,020AC,0
*000A0,7,NoBrkSpc
2,060,14,8,(-6,-8),0
*000A1,18,kiexc
2,14,06C,1,044,2,014,1,014,2,8,(2,-6),14,8,(-2,-3),0
*000A2,23,kcent
2,14,8,(-2,-5),01E,1,8,(2,6),2,01E,1,038,01A,02C,01E,030,2,020,
14,04A,0,
*000A3,23,kpound
2,14,8,(-2,-6),040,1,048,012,044,012,01E,2,02B,1,028,2,06F,
14,8,(-4,-3),0
*000A5,34,kyen
2,14,8,(-2,-6),064,1,8,(2,-3),03C,2,025,1,020,2,027,1,020,2,018,
1,8,(2,3),2,8,(2,-6),14,8,(-4,-3),0
*000A7,45,kpar
2,14,3,2,14,8,(-3,-12),14,4,2,014,1,01E,010,012,016,018,016,012,
2,021,1,016,018,01A,01E,010,01E,01A,2,8,(3,-2),14,3,2,
14,8,(-7,-6),14,4,2,0
*000AA,36,lcau
2,14,8,(-1,-6),2,3,2,8,3,9,1,01A,018,016,024,012,010,01E,02C,01E,
2,049,1,040,2,4,2,8,2,-3,14,8,(-3,1),0
*000AB,21,kfrew
2,14,8,(-2,-5),021,1,026,022,2,020,1,02A,02E,2,02F,14,8,(-4,-2),0
*000B0,19,kdeg
2,14,8,(-1,-6),054,1,012,01E,01A,016,2,05C,040,14,8,(-3,2),0
*000B1,23,kpls-min
2,14,8,(-2,-6),014,1,040,2,027,1,044,2,02A,1,040,2,04D,
14,8,(-4,-2),0
*000B5,24,kmicro
2,14,04B,02C,1,8,(1,6),1,03C,01E,010,023,2,024,1,04C,2,020,
14,8,(-4,-5),0
*000BA,35,lcou
2,14,8,(-1,-6),3,2,2,8,3,12,1,028,01A,02C,01E,020,012,024,016,2,
06B,1,040,2,4,2,8,2,-3,14,8,(-3,1),0
*000BB,22,kffrw
2,14,8,(-2,-5),014,1,022,026,2,020,1,02E,02A,2,040,01C,
14,8,(-4,-2),0
*000BC,41,kquart
2,3,2,14,8,(-5,-12),1,8,(10,12),2,8,(-8,-6),1,064,01A,2,05C,1,
020,2,8,(6,-4),1,048,8,(3,4),06C,2,060,14,8,(-9,-6),4,2,0
*000BD,45,khalf
2,3,2,14,8,(-5,-12),1,8,(10,12),2,8,(-8,-6),1,064,01A,2,05C,1,
020,2,8,(3,-1),1,012,020,01E,01C,01A,028,01A,02C,040,2,040,
14,8,(-9,-6),4,2,0
*000BF,32,kiqm
2,3,2,14,8,(-3,-12),8,(6,2),1,02A,028,026,024,022,024,2,024,1,
024,2,8,(8,-12),14,8,(-7,-6),4,2,0
*000C0,31,uc^
2,14,8,(-2,-6),1,024,022,02E,02C,2,8,(-4,1),1,040,2,8,(-2,4),1,
027,2,8,(6,-6),14,8,(-4,-3),0
*000C1,31,uc^
2,14,8,(-2,-6),1,024,022,02E,02C,2,8,(-4,1),1,040,2,8,(-2,4),1,
021,2,8,(2,-6),14,8,(-4,-3),0
*000C2,32,uc^
2,14,8,(-2,-6),1,024,022,02E,02C,2,8,(-4,1),1,040,2,8,(-4,3),1,
022,02E,2,8,(2,-4),14,8,(-4,-3),0
*000C3,33,uc^
2,14,8,(-2,-6),1,024,022,02E,02C,2,8,(-4,1),1,040,2,8,(-4,4),1,
012,02F,012,2,8,(2,-6),14,8,(-4,-3),0
*000C4,32,uc„
2,14,8,(-2,-6),1,024,043,2,029,1,014,2,040,1,01C,2,027,1,04D,02C,
2,047,1,040,2,02E,14,8,(-4,-3),0
*000C5,25,uc^
2,14,8,(-2,-6),1,024,032,016,01A,03E,02C,2,8,(-4,1),1,040,2,02F,
14,8,(-4,-3),0
*000C6,33,uc^
2,14,8,(-2,-6),1,034,8,(2,3),020,2,8,(-2,-3),1,020,2,03C,1,028,
064,2,04B,1,020,2,04F,14,8,(-4,-3),0
*000C7,29,uc‡
2,14,8,(-2,-6),02E,1,010,014,018,014,2,021,1,01A,028,016,044,012,
020,01E,2,02E,03C,14,8,(-4,-5),0
*000C8,28,uc^
2,14,8,(-2,-6),1,044,040,2,016,1,027,2,04C,018,1,020,2,02A,1,040,
2,020,14,8,(-4,-3),0
*000C9,28,uc^
2,14,8,(-2,-6),1,044,040,2,025,1,029,2,03C,018,1,020,2,02A,1,040,
2,020,14,8,(-4,-3),0
*000CA,29,uc^
2,14,8,(-2,-6),1,044,040,2,016,1,016,01A,2,03C,018,1,020,2,02A,1,
040,2,020,14,8,(-4,-3),0
*000CB,32,uc^
2,14,8,(-2,-6),1,044,040,2,016,1,014,2,028,1,01C,2,03C,018,1,020,
2,02A,1,040,2,020,14,8,(-4,-3),0
*000CC,25,uc^
2,14,8,(-1,-6),044,1,020,2,014,1,027,2,02D,1,04C,2,018,1,020,2,
020,14,03A,0
*000CD,25,uc^
2,14,8,(-1,-6),044,1,020,2,024,1,029,2,01E,1,04C,2,018,1,020,2,
020,14,03A,0
*000CE,26,uc^
2,14,8,(-1,-6),044,1,020,2,014,1,016,01A,2,01E,1,04C,2,018,1,020,
2,020,14,03A,0
*000CF,29,uc^
2,14,8,(-1,-6),044,1,020,2,014,1,014,2,028,1,01C,2,01E,1,04C,2,
018,1,020,2,020,14,03A,0
*000D0,25,uc
2,14,8,(-2,-6),1,064,030,01E,04C,01A,038,2,024,015,1,020,2,01D,
04F,14,8,(-4,-3),0
*000D1,25,uc
2,14,8,(-2,-6),1,044,04E,044,2,048,014,1,012,02F,012,2,8,(2,-6),
14,8,(-4,-3),0
*000D2,25,uc^
2,14,8,(-2,-6),1,044,040,2,016,1,027,2,02C,030,1,04C,048,2,060,
14,8,(-4,-3),0
*000D3,25,uc^
2,14,8,(-2,-6),1,044,040,2,025,1,029,2,01C,030,1,04C,048,2,060,
14,8,(-4,-3),0
*000D4,26,uc^
2,14,8,(-2,-6),1,044,040,2,016,1,016,01A,2,01C,030,1,04C,048,2,
060,14,8,(-4,-3),0
*000D5,27,uc^
2,14,8,(-2,-6),1,044,040,2,024,1,01A,027,01A,2,01C,040,1,04C,048,
2,060,14,8,(-4,-3),0
*000D6,31,uc^
2,14,8,(-2,-6),1,044,2,012,1,014,2,02B,1,040,2,016,1,014,2,02D,1,
04C,048,2,060,14,8,(-4,-3),0
*000D8,29,ucd”
2,14,8,(-2,-6),1,8,(4,6),2,018,1,01E,04C,01A,028,016,044,012,020,
2,8,(3,-6),14,8,(-4,-3),0
*000D9,24,uc^
2,14,8,(-2,-6),064,1,05C,01E,020,012,054,2,01A,1,027,2,050,06C,
14,8,(-4,-3),0
*000DA,24,uc^
2,14,8,(-2,-6),064,1,05C,01E,020,012,054,2,018,1,029,2,050,05C,
14,8,(-4,-3),0
*000DB,25,uc^
2,14,8,(-2,-6),064,1,05C,01E,020,012,054,2,01A,1,016,01A,2,050,
05C,14,8,(-4,-3),0
*000DC,27,uc^
2,14,8,(-2,-6),064,1,05C,01E,020,012,054,2,01A,1,014,2,028,1,01C,
2,05E,14,8,(-4,-3),0
*000DD,25,uc^
2,14,8,(-2,-6),044,1,02E,02C,2,024,1,022,2,025,1,029,2,050,05C,
14,8,(-4,-3),0
*000DE,27,lc
2,14,8,(-2,-6),02C,1,084,2,03C,1,012,020,01E,02C,01A,028,016,2,
8,(6,-1),14,8,(-4,-5),0
*000DF,24,kgers
2,14,8,(-2,-6),1,012,044,012,010,01E,01C,01A,01E,01C,01A,018,2,
040,14,8,(-4,-3),0
*000E0,39,lc…
2,14,8,(-2,-6),020,1,018,016,024,012,010,01E,02C,01A,2,012,1,01E,
2,2,3,2,8,(-3,10),1,047,2,8,(11,-12),4,2,14,8,(-4,-3),0
*000E1,39,lc
2,14,8,(-2,-6),020,1,018,016,024,012,010,01E,02C,01A,2,012,1,01E,
2,2,3,2,8,(-3,12),1,049,2,8,(11,-10),4,2,14,8,(-4,-3),0
*000E2,40,lcƒ
2,14,8,(-2,-6),020,1,018,016,024,012,010,01E,02C,01A,2,012,1,01E,
2,2,3,2,8,(-3,10),1,026,02A,2,8,(11,-10),4,2,14,8,(-4,-3),0
*000E3,40,lcƒ
2,14,8,(-2,-6),020,1,018,016,024,012,010,01E,02C,01A,2,012,1,01E,
2,3,2,8,(-7,10),1,012,02F,012,2,8,(7,-11),4,2,14,8,(-4,-3),0
*000E4,37,lc„
2,14,8,(-2,-6),020,1,018,016,024,2,034,1,01C,2,030,1,014,2,03A,1,
012,010,01E,02C,01A,2,012,1,01E,2,020,14,8,(-4,-3),0
*000E5,38,lc†
2,14,8,(-2,-6),3,2,8,(3,8),1,022,026,02A,02E,2,8,(3,-6),4,2,1,
01A,018,016,024,012,010,01E,02C,01E,2,020,14,8,(-4,-3),0
*000E6,30,lc
2,14,04B,021,1,01A,016,024,012,01E,03C,2,034,1,012,01E,01C,028,2,
01C,1,01E,010,2,020,14,8,(-4,-3),0
*000E7,24,lc‡
2,14,04B,042,1,038,01A,02C,01E,030,2,028,1,01C,010,01C,018,2,041,
14,8,(-4,-5),0
*000E8,27,lcŠ
2,14,8,(-2,-6),024,1,030,012,016,028,01A,02C,01E,020,2,054,1,027,
2,050,06C,14,8,(-4,-3),0
*000E9,26,lc‚
2,14,8,(-2,-6),024,1,030,012,016,028,01A,02C,01E,020,2,064,1,029,
2,05E,14,8,(-4,-3),0
*000EA,27,lcˆ
2,14,8,(-2,-6),024,1,030,012,016,028,01A,02C,01E,020,2,054,1,016,
01A,2,05E,14,8,(-4,-3),0
*000EB,31,lc‰
2,14,8,(-2,-6),024,1,030,012,016,028,01A,02C,01E,020,2,064,010,1,
01C,2,048,1,014,2,06E,14,8,(-4,-3),0
*000EC,18,lc_
2,14,8,(-1,-6),010,1,044,2,025,1,02F,2,020,05C,14,03A,0
*000ED,18,lc
2,14,8,(-1,-6),010,1,044,2,016,1,021,2,020,06C,14,03A,0
*000EE,19,lcŒ
2,14,8,(-1,-6),010,1,044,2,016,1,012,01E,2,020,05C,14,03A,0
*000EF,22,lc‹
2,14,8,(-1,-6),010,1,044,2,016,1,014,2,020,1,01C,2,020,05C,
14,03A,0
*000F0,30,lc
2,14,8,(-2,-6),8,(3,4),1,028,01A,02C,01E,020,012,024,036,2,01C,1,
021,2,8,(3,-6),14,8,(-4,-3),0
*000F1,27,lc
2,14,8,(-2,-6),1,044,2,014,1,012,02F,012,2,04A,1,022,010,01E,03C,
2,020,14,8,(-4,-3),0
*000F2,27,lc•
2,14,8,(-2,-6),030,1,028,016,024,012,020,01E,02C,01A,2,054,1,027,
2,050,06C,14,8,(-4,-3),0
*000F3,26,lc
2,14,8,(-2,-6),030,1,028,016,024,012,020,01E,02C,01A,2,064,1,029,
2,05E,14,8,(-4,-3),0
*000F4,27,lc“
2,14,8,(-2,-6),030,1,028,016,024,012,020,01E,02C,01A,2,054,1,016,
01A,2,05E,14,8,(-4,-3),0
*000F5,32,lc^
2,14,8,(-2,-6),030,1,028,016,024,012,020,01E,02C,01A,2,8,(-3,5),
1,012,02F,012,2,8,(2,-6),14,8,(-4,-3),0
*000F6,35,lc”
2,14,8,(-2,-6),030,1,028,016,024,2,034,1,01C,2,040,1,014,2,
8,(-4,-3),1,012,020,01E,02C,01A,2,030,14,8,(-4,-3),0
*000F7,23,kto
2,14,8,(-2,-5),021,1,014,2,021,1,048,2,022,1,01C,2,04E,
14,8,(-4,-2),0
*000F8,24,lcd”
2,14,04B,010,1,020,012,024,016,028,01A,02C,01E,2,018,1,042,2,04D,
14,8,(-4,-3),0
*000F9,27,lc—
2,14,8,(-2,-6),044,1,03C,01E,010,022,2,038,044,1,02F,2,01E,1,04C,
2,020,14,8,(-4,-3),0
*000FA,26,lc
2,14,8,(-2,-6),044,1,03C,01E,010,022,2,036,1,021,2,02D,1,04C,2,
020,14,8,(-4,-3),0
*000FB,27,lc-
2,14,8,(-2,-6),044,1,03C,01E,010,022,2,036,1,012,01E,2,01E,1,04C,
2,020,14,8,(-4,-3),0
*000FC,32,lc_
2,14,8,(-2,-6),064,010,1,01C,2,01A,1,03C,01E,010,022,2,044,018,1,
01C,2,01E,1,04C,2,020,14,8,(-4,-3),0
*000FD,27,lc^
2,14,8,(-2,-6),044,1,04D,2,8,(-1,5),1,021,2,02D,1,06B,018,2,024,
060,14,8,(-4,-3),0
*000FE,25,uc
2,14,8,(-2,-6),1,064,2,01E,019,1,030,01E,01C,01A,038,2,01F,01C,
050,14,8,(-4,-3),0
*000FF,30,lc˜
2,14,8,(-2,-6),044,1,04D,2,054,018,1,014,2,020,1,01C,2,01E,1,06B,
018,2,024,060,14,8,(-4,-5),0
*00104,26,c164
2,14,8,(-2,-6),1,024,043,04D,02C,2,047,1,040,2,02C,1,01A,01E,2,
022,14,8,(-4,-3),0
*00105,30,c165
2,14,04B,020,1,018,016,024,012,010,01E,02C,01A,2,012,1,01E,3,2,
01A,01E,4,2,2,021,14,8,(-4,-3),0
*00106,28,c143
2,14,8,(-2,-6),040,014,1,01A,028,016,044,012,020,01E,2,038,024,1,
021,2,08C,030,14,8,(-4,-3),0
*00107,30,c134
2,14,04B,042,1,038,01A,02C,01E,030,2,3,2,8,(-5,10),1,021,2,029,
8,(9,-10),4,2,14,8,(-4,-3),0
*0010C,31,c172
2,14,8,(-2,-8),040,014,1,01A,028,016,044,012,020,01E,2,026,1,012,
2,01A,1,016,2,050,08C,14,8,(-4,-3),0
*0010D,29,c159
2,14,8,(-2,-6),042,1,038,01A,02C,01E,030,2,028,054,1,012,2,01A,1,
016,2,050,06C,14,8,(-4,-3),0
*0010E,32,c210
2,14,8,(-2,-8),1,030,012,044,016,038,2,010,1,06C,2,010,074,1,012,
2,01A,1,016,2,050,08C,14,8,(-4,-3),0
*0010F,31,c212
2,14,8,(-2,-6),041,1,02A,018,016,024,012,010,02E,2,044,1,06C,2,
020,064,1,01A,2,010,05C,14,8,(-4,-3),0
*00118,28,c168
2,14,8,(-2,-6),1,064,040,2,048,03C,1,020,2,028,03C,1,040,1,01A,
01E,2,022,14,8,(-4,-3),0
*00119,27,c169
2,14,04B,024,1,030,012,016,028,01A,02C,01E,020,3,2,01A,01E,4,2,2,
014,030,14,8,(-4,-3),0
*0011A,35,c183
2,14,8,(-2,-8),1,064,040,2,048,03C,1,020,2,028,03C,1,040,2,028,
074,1,012,2,01A,1,016,2,050,08C,14,8,(-4,-3),0
*0011B,32,c216
2,14,8,(-2,-6),024,1,030,012,016,028,01A,02C,01E,020,2,018,054,1,
012,2,01A,1,016,2,050,06C,14,8,(-4,-3),0
*00141,29,c157
2,14,8,(-2,-6),064,1,06C,040,2,048,034,1,3,2,8,(4,5),2,8,(8,-11),
4,2,14,8,(-4,-3),0
*00142,47,c136
2,14,3,2,14,8,(-1,-12),14,4,2,064,3,2,010,4,2,1,05C,01E,2,3,2,
8,(-3,5),1,8,(3,4),2,8,(4,-9),4,2,14,3,2,14,8,(-5,-6),14,4,2,0
*00143,24,c227
2,14,8,(-2,-6),1,064,8,(4,-6),064,2,038,014,1,021,2,08C,030,
14,8,(-4,-3),0
*00144,42,c228
2,14,3,2,14,8,(-3,-8),14,4,2,1,044,2,01C,1,012,010,01E,03C,2,
8,(-2,5),1,011,2,019,8,(4,-5),14,3,2,14,8,(-7,-6),14,4,2,0
*00147,27,c213
2,14,8,(-2,-8),1,064,8,(4,-6),064,2,027,1,012,2,01A,1,016,2,050,
08C,14,8,(-4,-3),0
*00148,29,c229
2,14,8,(-2,-6),1,044,2,01C,1,012,010,01E,03C,2,018,054,1,012,2,
01A,1,016,2,040,06C,14,03A,0
*00150,27,c138
2,14,8,(-2,-6),1,064,040,06C,048,2,074,010,1,03C,2,020,1,034,2,
07C,030,14,8,(-4,-3),0
*00151,29,c139
2,14,04B,030,1,028,016,024,012,020,01E,02C,01A,2,074,1,02C,2,028,
1,024,2,07C,050,14,8,(-4,-3),0
*00158,33,c252
2,14,8,(-2,-8),1,064,030,01E,01C,01A,038,2,010,1,03E,2,028,074,1,
012,2,01A,1,016,2,050,08C,14,8,(-4,-3),0
*00159,29,c253
2,14,8,(-2,-6),1,044,2,02C,1,022,010,01E,2,026,1,012,2,01A,1,016,
2,050,06C,14,8,(-4,-3),0
*0015A,27,c151
2,14,8,(-2,-6),014,1,01E,020,012,046,012,020,01E,2,024,038,1,021,
2,08C,030,14,8,(-4,-3),0
*0015B,31,c152
2,14,04B,1,030,012,016,028,016,012,030,2,3,2,8,(-5,2),1,021,2,
029,8,(9,-10),4,2,14,8,(-4,-3),0
*00160,30,c230
2,14,8,(-2,-8),014,1,01E,020,012,046,012,020,01E,2,026,1,012,2,
01A,1,016,2,050,08C,14,8,(-4,-3),0
*00161,29,c231
2,14,8,(-2,-6),1,030,012,016,028,016,012,030,2,027,1,012,2,01A,1,
016,2,050,06C,14,8,(-4,-3),0
*00164,28,c155
2,14,8,(-2,-8),064,1,040,2,028,1,06C,2,074,1,012,2,01A,1,016,2,
050,08C,14,8,(-4,-3),0
*00165,26,c156
2,14,8,(-2,-6),044,1,040,2,026,1,05C,01E,012,2,054,1,01A,2,030,
05C,14,8,(-4,-3),0
*0016E,27,c222
2,14,8,(-2,-9),064,1,05C,01E,020,012,054,2,027,1,012,016,01A,01E,
2,040,07C,14,8,(-4,-3),0
*0016F,31,c133
2,14,8,(-2,-7),044,1,03C,01E,010,022,2,024,1,04C,2,028,054,1,012,
016,01A,01E,2,040,05C,14,8,(-4,-3),0
*00170,28,c235
2,14,8,(-2,-6),064,1,05C,01E,020,012,054,2,016,1,03C,2,028,1,034,
2,07C,050,14,8,(-4,-3),0
*00171,30,uue
2,14,04B,044,1,03C,01E,010,022,2,024,1,04C,2,074,018,1,02C,2,028,
1,024,2,07C,050,14,8,(-4,-3),0
*00179,25,c141
2,14,8,(-2,-6),064,1,040,8,(-4,-6),040,2,038,074,1,021,2,08C,030,
14,8,(-4,-3),0
*0017A,28,c171
2,14,04B,044,1,040,04A,040,2,3,2,8,(-5,10),1,021,2,029,8,(9,-10),
4,2,14,8,(-4,-3),0
*0017B,32,c189
2,14,8,(-2,-6),064,1,040,8,(-4,-6),040,2,084,028,1,3,4,01A,01E,
012,016,4,4,2,040,08C,14,8,(-4,-3),0
*0017C,34,c190
2,14,04B,044,1,040,04A,040,2,3,2,8,(-4,11),3,4,1,01A,01E,012,016,
4,4,2,8,(8,-11),4,2,14,8,(-4,-3),0
*0017D,29,c166
2,14,8,(-2,-8),064,1,040,8,(-4,-6),040,2,028,074,1,012,2,01A,1,
016,2,050,08C,14,8,(-4,-3),0
*0017E,27,c167
2,14,8,(-2,-6),044,1,040,04A,040,2,028,054,1,012,2,01A,1,016,2,
050,06C,14,8,(-4,-3),0
*00410,21,ucra
2,14,8,(-2,-6),1,024,043,04D,02C,2,047,1,040,2,02E,14,8,(-4,-3),0
*00411,24,ucrb
2,14,8,(-2,-6),1,064,030,01C,014,038,03C,030,01E,01C,01A,038,2,
060,14,8,(-4,-3),0
*00412,29,ucrv
2,14,8,(-2,-6),1,030,012,014,016,028,2,020,1,012,014,016,038,2,
010,1,06C,2,050,14,8,(-4,-3),0
*00413,17,ucrg
2,14,8,(-2,-6),1,064,040,01C,2,05C,020,14,8,(-4,-3),0
*00414,23,ucrd
2,14,8,(-2,-6),01C,1,014,050,064,028,04B,02C,050,01C,2,014,020,
14,8,(-6,-3),0
*00415,25,ucre
2,14,8,(-2,-6),1,064,040,2,048,03C,1,020,2,028,03C,1,040,2,020,
14,8,(-4,-3),0
*00416,22,ucr!
2,14,8,(-2,-6),062,2,038,1,06C,2,038,064,1,06E,2,020,
14,8,(-6,-3),0
*00417,27,ucr!
2,14,8,(-2,-6),014,1,01E,020,012,014,016,018,010,012,014,016,028,
01A,2,060,05C,14,8,(-4,-3),0
*00418,20,ucri
2,14,8,(-2,-6),1,042,04C,064,2,048,1,06C,2,060,14,8,(-4,-3),0
*00419,24,ucrikr
2,14,8,(-2,-6),1,042,04C,064,2,018,1,028,2,018,1,06C,2,060,
14,8,(-4,-3),0
*0041A,23,ucrk
2,14,8,(-2,-6),1,064,2,040,1,03A,018,2,010,1,03E,2,020,
14,8,(-4,-3),0
*0041B,17,ukrl
2,14,8,(-2,-6),1,010,063,010,06C,2,020,14,8,(-5,-3),0
*0041C,17,ucrm
2,14,8,(-2,-6),1,064,04D,043,06C,2,020,14,8,(-4,-3),0
*0041D,22,ucrn
2,14,8,(-2,-6),1,064,2,03C,1,040,2,034,1,06C,2,020,14,8,(-4,-3),0
*0041E,23,ucro
2,14,8,(-2,-6),014,1,044,012,020,01E,04C,01A,028,016,2,060,01C,
14,8,(-4,-3),0
*0041F,16,ucrp
2,14,8,(-2,-6),1,064,040,06C,2,020,14,8,(-4,-3),0
*00420,19,ucrr
2,14,8,(-2,-6),1,064,030,01E,01C,01A,038,2,06F,14,8,(-4,-3),0
*00421,23,ucrs
2,14,8,(-2,-6),040,014,1,01A,028,016,044,012,020,01E,2,02E,03C,
14,8,(-4,-3),0
*00422,19,ucrt
2,14,8,(-2,-6),064,1,040,2,028,1,06C,2,040,14,8,(-4,-3),0
*00423,23,ucru
2,14,8,(-2,-6),014,1,01E,020,012,054,04C,038,016,034,2,060,06C,
14,8,(-4,-3),0
*00424,25,ucrf
2,14,8,(-2,-6),020,1,064,018,01A,02C,01E,020,012,024,016,018,2,
040,06C,14,8,(-4,-3),0
*00425,22,ucrx
2,14,8,(-2,-6),1,8,(4,6),2,048,1,8,(4,-6),2,020,14,8,(-4,-3),0
*00426,21,ucr!
2,14,8,(-2,-6),1,064,06C,040,064,06C,010,01C,2,014,020,
14,8,(-5,-3),0
*00427,19,ucrch
2,14,8,(-2,-6),064,1,03C,01E,030,044,06C,2,020,14,8,(-4,-3),0
*00428,21,ucrsh
2,14,8,(-2,-6),1,064,06C,030,044,04C,030,064,06C,2,020,
14,8,(-6,-3),0
*00429,24,ucr!
2,14,8,(-2,-6),1,064,06C,030,044,04C,030,064,06C,010,01C,014,2,
020,14,8,(-7,-3),0
*0042A,23,ucr'
2,14,8,(-2,-6),054,1,014,010,06C,030,012,014,016,038,2,060,03C,
14,8,(-5,-3),0
*0042B,24,ucrs
2,14,8,(-2,-6),1,030,012,014,016,038,03C,064,2,050,1,06C,2,020,
14,8,(-5,-3),0
*0042C,21,ucr]
2,14,8,(-2,-6),1,030,012,014,016,038,03C,064,2,060,06C,
14,8,(-4,-3),0
*0042D,25,ucr'
2,14,8,(-2,-6),014,1,01E,020,012,024,028,020,024,016,028,01A,2,
060,05C,14,8,(-4,-3),00,
*0042E,26,ucr!
2,14,8,(-2,-6),1,064,03C,010,024,012,010,01E,04C,01A,018,016,024,
2,050,03C,14,8,(-4,-3),0
*0042F,22,ucrya
2,14,8,(-2,-6),1,022,020,044,038,01A,02C,01E,030,02C,2,020,
14,8,(-4,-3),0
*00430,25,lcra
2,14,8,(-2,-6),014,1,024,012,020,01E,014,04C,014,01A,028,016,2,
060,01C,14,8,(-4,-3),0
*00431,22,lcrb
2,14,8,(-2,-6),044,030,1,038,04C,030,012,016,038,2,02C,060,
14,8,(-4,-3),0
*00432,24,lcrv
2,14,8,(-2,-6),1,044,020,10,(1,-36),028,030,10,(1,-36),038,2,060,
14,8,(-4,-3),0
*00433,16,lcrg
2,14,8,(-2,-6),1,044,030,2,04C,020,14,8,(-3,-3),0
*00434,24,lcrd
2,14,8,(-2,-6),01C,1,014,010,034,012,010,04C,028,030,01C,2,014,
020,14,8,(-4,-3),00,
*00435,20,lcre
2,14,04B,024,1,030,012,016,028,01A,02C,01E,020,2,030,
14,8,(-4,-3),0
*00436,23,lcrg
2,14,8,(-2,-6),1,042,2,048,1,04E,2,028,1,044,2,040,04C,
14,8,(-4,-3),0
*00437,25,lcrz
2,14,8,(-2,-6),034,1,012,020,01E,01A,018,010,01E,01A,028,016,2,
060,01C,14,8,(-4,-3),0
*00438,17,lcri
2,14,8,(-2,-6),044,1,04C,042,04C,2,020,14,8,(-4,-3),0
*00439,23,lcrii
2,14,8,(-2,-6),044,1,04C,042,04C,2,044,018,1,028,2,050,04C,
14,8,(-4,-3),0
*0043A,19,lcrk
2,14,8,(-2,-6),1,044,02C,020,022,02A,02E,2,020,14,8,(-4,-3),0
*0043B,16,lcrl
2,14,8,(-2,-6),1,043,020,04C,2,020,14,8,(-4,-3),0
*0043C,17,lcrm
2,14,8,(-2,-6),1,044,02E,022,04C,2,020,14,8,(-4,-3),0
*0043D,18,lcrn
2,14,8,(-2,-6),1,044,02C,040,024,04C,2,020,14,8,(-4,-3),0
*0043E,25,lcro
2,14,04B,14,8,(0,-2),014,1,024,012,020,01E,02C,01A,028,016,2,060,
01C,14,8,(-4,-3),0
*0043F,16,lcrp
2,14,8,(-2,-6),1,044,040,04C,2,020,14,8,(-4,-3),0
*00440,20,lcrr
2,14,8,(-2,-6),1,044,030,01E,01C,01A,038,2,060,01C,14,8,(-4,-3),0
*00441,23,lcrs
2,14,8,(-2,-6),040,014,1,01A,028,016,024,012,020,01E,2,020,03C,
14,8,(-4,-3),0
*00442,18,lcrt
2,14,8,(-2,-6),020,1,044,028,040,2,020,04C,14,8,(-4,-3),0
*00443,22,lcru
2,14,8,(-2,-6),014,1,01E,020,012,034,02C,028,026,2,060,04C,
14,8,(-4,-3),0
*00444,25,lcrf
2,14,8,(-2,-6),020,1,044,018,01A,01C,01E,020,012,014,016,018,2,
040,04C,14,8,(-4,-3),0
*00445,20,lcrh
2,14,04B,14,8,(0,-2),1,042,2,048,1,04E,2,020,14,8,(-4,-3),0
*00446,21,lcrc
2,14,8,(-2,-6),044,1,04C,030,044,04C,010,01C,2,014,020,
14,8,(-4,-3),0
*00447,18,lcrch
2,14,8,(-2,-6),044,1,03C,030,034,04C,2,020,14,8,(-3,-3),0
*00448,21,lcrsh
2,14,8,(-2,-6),1,044,04C,020,024,02C,020,044,2,04C,020,
14,8,(-4,-3),0
*00449,24,lcrshch
2,14,8,(-2,-6),1,044,04C,020,024,02C,020,044,04C,010,01C,2,014,
020,14,8,(-5,-3),0
*0044A,21,lcrtvznak
2,14,8,(-2,-6),044,1,010,04C,020,012,016,028,2,050,02C,
14,8,(-4,-3),0
*0044B,24,lcryyy
2,14,8,(-2,-6),1,044,02C,020,01E,01A,028,2,040,1,044,2,04C,020,
14,8,(-4,-3),0
*0044C,19,lcrmznak
2,14,8,(-2,-6),1,044,02C,020,01E,01A,028,2,050,14,8,(-3,-3),0
*0044D,25,lcreee
2,14,8,(-2,-6),014,1,01E,020,012,014,028,020,014,016,028,01A,2,
060,03C,14,8,(-4,-3),0
*0044E,26,lcryu
2,14,8,(-2,-6),1,044,02C,010,014,012,010,01E,02C,01A,018,016,014,
2,050,02C,14,8,(-4,-3),0
*0044F,22,lcrya
2,14,8,(-2,-6),1,022,018,016,012,030,02C,028,020,02C,2,020,
14,8,(-4,-3),0
*020A0,4,keuroRef2
7,0020AC,0
*020A7,32,kpes
2,14,06B,14,010,1,064,020,01E,01C,01A,028,2,8,(4,3),1,05C,01E,
012,2,025,1,028,2,03E,020,14,8,(-6,-3),0
*020AC,45,keuro
3,2,2,14,8,(-4,-12),080,024,1,01C,01A,048,026,044,5,044,022,040,01E,01C
6,2,8,(-1,-1),5,1,050,6,2,024,1,060,2,8,(6,-7),14,8,(-8,-6),4,2,0
*02126,24,komega
2,14,8,(-2,-6),1,010,014,025,024,012,020,01E,02C,02B,01C,010,2,
020,14,8,(-4,-3),0
*02205,28,kdiam
2,14,8,(-2,-6),012,1,016,024,012,020,01E,02C,01A,028,2,01B,1,063,
2,010,03D,03C,14,8,(-4,-3),0
*0221E,18,kinfin
2,14,04B,034,1,01E,022,01E,01A,026,01A,2,06F,14,8,(-4,-1),0
*02264,20,kleq
2,14,8,(-2,-6),014,1,040,2,054,1,049,04F,2,02E,14,8,(-4,-2),0
*02302,16,ktri
2,14,04B,1,024,022,02E,02C,048,2,060,14,8,(-4,-3),0


UNICODE를 위한 확장된 표준 글꼴 (요약 참조)

확장된 Simplex Roman
UNICODE를 위한 확장된 표준 글꼴
큰 글꼴 정의
AutoCAD 2008 사용자화 안내서 > 쉐이프 및 쉐이프 글꼴 > 쉐이프 정의 파일 작성 > 예제 파일 > UNICODE를 위한 확장된 표준 글꼴 >
UNICODE를 위한 확장된 표준 글꼴
개념 요약 참조

명령

LOAD

쉐이프를 SHAPE 명령에 사용할 수 있게 만듭니다.

SHAPE

LOAD를 사용하여 로드된 쉐이프 파일의 쉐이프를 삽입합니다.

시스템 변수

항목이 없습니다.

유틸리티

항목이 없습니다.

명령 수정자

항목이 없습니다.


큰 글꼴 설명

UNICODE를 위한 확장된 표준 글꼴
쉐이프 정의 파일 작성
큰 글꼴 정의
AutoCAD 2008 사용자화 안내서 > 쉐이프 및 쉐이프 글꼴 > 쉐이프 정의 파일 작성 >
큰 글꼴 설명

일본어 같은 일부 언어에서는 수천 가지의 비 ASCII 문자 글꼴을 사용합니다. 도면에 이러한 문자를 포함하기 위해 AutoCAD는 큰 글꼴 파일이라는 쉐이프 정의 파일의 특수 양식을 지원합니다.

일본어 같은 일부 언어에서는 수천 가지의 비 ASCII 문자 글꼴을 사용합니다. 도면에 이러한 문자를 포함하기 위해 AutoCAD는 큰 글꼴 파일이라는 쉐이프 정의 파일의 특수 양식을 지원합니다.

이 단원의 항목

  • 큰 글꼴 정의

    큰 글꼴 파일의 첫 번째 행에서 특수 코드는 2바이트 16진수 코드를 읽는 방법을 지정합니다.

  • 확장된 큰 글꼴 파일 정의

    복합 간지 문자의 크기를 줄이기 위해 확장된 큰 글꼴 파일을 정의할 수 있습니다. 확장된 큰 글꼴은 하위 쉐이프 코드를 사용하며, 이 코드의 바로 뒤에는 0이 옵니다.

  • 도면에서 큰 글꼴 문자 사용

    도면 문자에 큰 글꼴을 사용하려면 문자 스타일을 설정한 다음, 큰 글꼴 파일의 이름을 지정하십시오.

  • 큰 글꼴을 사용하여 글꼴 확장

    문자열에 특수 기호를 포함하려면 표준 문자 글꼴을 확장하는 대신 큰 글꼴을 사용하면 됩니다.


큰 글꼴 정의 (개념)

큰 글꼴 설명
큰 글꼴 설명
확장된 큰 글꼴 파일 정의
AutoCAD 2008 사용자화 안내서 > 쉐이프 및 쉐이프 글꼴 > 쉐이프 정의 파일 작성 > 큰 글꼴 설명 >
큰 글꼴 정의
개념 요약 참조

큰 글꼴 파일의 첫 번째 행에서 특수 코드는 2바이트 16진수 코드를 읽는 방법을 지정합니다.

문자 수가 수백 혹은 수천 개에 달한다면 이러한 글꼴은 최대 256자의 ASCII 세트를 포함하는 글꼴과는 다르게 처리해야 합니다. 파일을 검색하는 데 더 복잡한 기술을 사용하는 것 외에도 AutoCAD에는 2바이트 코드뿐만 아니라 1바이트 코드를 포함한 문자를 나타내는 방법이 필요합니다. 두 상황 모두 큰 글꼴 파일의 시작 부분에 특수 코드를 사용함으로써 처리됩니다.

큰 글꼴 쉐이프 정의 파일의 첫 번째 행은 다음과 같아야 합니다.

*BIGFONT nchars,nranges,b1,e1,b2,e2,...

여기에서 nchars는 이 세트의 대략적인 문자 정의 개수이며, 만일 10% 이상 벗어나면 속도나 파일 크기에 문제가 발생합니다. 행의 나머지는 2바이트 코드의 시작을 의미하는 특수 문자 코드(escape 코드)의 이름을 지정하는 데 사용할 수 있습니다. 예를 들어, 일본어 시스템에서 간지 문자는 범위 90-AF나 E0-FF의 16진수 코드로 시작됩니다. 운영 체제는 이러한 코드 중 하나를 발견하면 그 다음 바이트를 읽고, 2바이트를 하나의 간지 문자에 대한 코드로 결합합니다. *BIGFONT 행에서 nranges는 escape 코드로 사용되는 연속 숫자 범위를 나타내고 b1, e1, b2, e2 등은 각 범위의 시작 코드와 끝 코드를 정의합니다. 따라서 일본어 큰 글꼴 파일의 헤더는 다음과 같습니다.

*BIGFONT 4000,2,090,0AF,0E0,0FF

*BIGFONT 행 다음의 글꼴 정의는 문자 코드(쉐이프 번호)가 최대 65535 값을 가질 수 있다는 점을 제외하면 일반 AutoCAD 문자 글꼴과 같습니다.


큰 글꼴 정의 (요약 참조)

UNICODE를 위한 확장된 표준 글꼴
큰 글꼴 정의
확장된 큰 글꼴 파일 정의
AutoCAD 2008 사용자화 안내서 > 쉐이프 및 쉐이프 글꼴 > 쉐이프 정의 파일 작성 > 큰 글꼴 설명 > 큰 글꼴 정의 >
큰 글꼴 정의
개념 요약 참조

명령

LOAD

쉐이프를 SHAPE 명령에 사용할 수 있게 만듭니다.

SHAPE

LOAD를 사용하여 로드된 쉐이프 파일의 쉐이프를 삽입합니다.

시스템 변수

항목이 없습니다.

유틸리티

항목이 없습니다.

명령 수정자

항목이 없습니다.


확장된 큰 글꼴 파일 정의 (개념)

큰 글꼴 정의
큰 글꼴 설명
도면에서 큰 글꼴 문자 사용
AutoCAD 2008 사용자화 안내서 > 쉐이프 및 쉐이프 글꼴 > 쉐이프 정의 파일 작성 > 큰 글꼴 설명 >
확장된 큰 글꼴 파일 정의
개념 요약 참조

복합 간지 문자의 크기를 줄이기 위해 확장된 큰 글꼴 파일을 정의할 수 있습니다. 확장된 큰 글꼴은 하위 쉐이프 코드를 사용하며, 이 코드의 바로 뒤에는 0이 옵니다.

확장된 큰 글꼴 파일의 첫 번째 행은 일반적인 큰 글꼴 파일의 경우와 동일합니다. 다음은 파일의 나머지 행에 대한 형식입니다.

*0,5,font-name
character-height, 0, modes, character-width,0
            .
            .
            .
*shape-number,defbytes,shape-name
            .
code, 0,primitive#,basepoint-x,basepoint-y,width,height
            .
            .
code,0,primitive#,basepoint-x,basepoint-y,width,height,
            .
terminator

다음 리스트에서는 큰 글꼴 정의 파일의 필드에 대해 설명합니다.

character height

character width와 함께 글꼴 문자를 정의하는 단위의 개수를 표시하는 데 사용됩니다.

character width

character height와 함께 글꼴 문자를 정의하는 단위의 개수를 표시하는 데 사용됩니다. character-height 및 character-width 값은 글꼴의 기본체를 축척하는 데 사용됩니다. 이 문맥에서 기본체는 2차원 공간에서 기하학적으로 회전한 글꼴의 점, 행, 다각형 또는 문자열입니다. 간지 문자는 서로 다른 축척과 결합에 반복적으로 사용되는 여러 개의 기본체로 이루어져 있습니다.

모드

modes 바이트는 가로 방향 글꼴의 경우 0이고, 양방향(가로나 세로) 글꼴의 경우 2여야 합니다. 특수 00E(14) 명령 코드는 modes가 2로 설정되어 있을 경우에만 사용할 수 있습니다.

shape-number

문자 코드

defbytes

바이트 크기. 항상 16진수 또는 10진수와 16진수 코드의 조합으로 이루어진 2바이트입니다.

shape-name

문자 이름

코드에

쉐이프 설명 특수 코드. 하위 쉐이프 기능을 사용할 수 있도록 항상 7로 지정됩니다.

primitive#

하위 쉐이프 번호에 대한 참조. 항상 2입니다.

basepoint-x

기본체의 X 원점

basepoint-y

기본체의 Y 원점

폭

기본체의 폭에 대한 축척

높이

기본체의 높이에 대한 축척

terminator

쉐이프 정의의 파일 끝 지시자. 항상 0입니다.

축척 비율에 도달하기 위해 AutoCAD는 기본체를 제곱 단위로 계산한 다음 이 값을 높이 및 폭과 곱하여 문자의 쉐이프를 얻습니다. 큰 글꼴 쉐이프 정의 파일의 문자 코드(쉐이프 번호)에는 최대 65535개의 값이 있을 수 있습니다. 다음 표는 확장 큰 글꼴 파일의 필드를 보여 줍니다.

변수 | 값 | 바이트 크기 | 설명
shape-number | xxxx | 2바이트 | 문자 코드
code | 7,0 | 2바이트 | 확장된 글꼴 정의
primitive# | xxxx | 2바이트 | 하위 쉐이프 참조
basepoint-x |  | 1바이트 | 기본체의 X 원점
basepoint-y |  | 1바이트 | 기본체의 Y 원점
width |  | 1바이트 | 기본체 폭의 축척
height |  | 1바이트 | 기본체 높이의 축척
terminator | 0 | 1바이트 | 쉐이프 정의의 끝

다음 그림은 간지 문자와 같은 확장 큰 글꼴을 디자인하는 데 사용할 수 있는 16 x 16 점 매트릭스의 예제이니다. 이 예제에서 각 점 사이의 거리는 한 단위입니다. 콜아웃은 제곱 단위를 가리킵니다.

다음 그림은 간지 문자의 예제입니다. 각 문자는 앞의 그림에 표시된 것과 유사하게, M×N 행렬(행렬이 반드시 제곱일 필요는 없음)를 차지합니다. 각 그림 위에 있는 숫자는 연관된 쉐이프 번호입니다.

다음 그림은 간지 기본체를 보여 줍니다.

주모든 글꼴이 정사각형 행렬로 정의되는 것은 아니며, 일부 글꼴은 직사각형 행렬로 정의됩니다.

예제: 확장 큰 글꼴에 대한 쉐이프 정의 파일

*BIGFONT 50,1,080,09e
*0,5,Extended Font
15,0,2,15,0
*08D91,31,unspecified
2,0e,8,-7,-15,
7,0,08cfb,0,0,16,16,7,0,08bca,2,3,12,9,
2,8,18,0,2,0e,8,-11,-3,0
*08CD8,31,unspecified
2,0e,8,-7,-15,
7,0,08be0,0,0,8,16,7,0,08cc3,8,0,8,16,
2,8,18,0,2,0e,8,-11,-3,0
*08ADF,31,unspecified
2,0e,8,-7,-15,
7,0,089a4,0,0,8,16,7,0,08cb3,8,0,8,16,
2,8,18,0,2,0e,8,-11,-3,0
*08CE8,39,unspecified
2,0e,8,-7,-15,
7,0,089a4,0,1,5,14,7,0,08cc3,5,2,5,14,7,0,08c8e,9,0,7,
16,2,8,18,0,2,0e,8,-11,-3,0
*089A4,39,primitive
2,0e,8,-7,-15,2,8,1,14,1,0c0,
2,8,-11,-6,1,0a0,2,8,-12,-7,1,
0e0,2,8,-7,13,1,0dc,2,8,11,-1,
2,0e,8,-11,-3,0
*08BCA,41,primitive
2,0e,8,-7,-15,2,8,1,14,1,0c0,
2,8,-11,-6,1,0a0,2,8,-12,-8,1,
0e0,2,0e5,1,0ec,2,063,1,8,
2,-3,2,06f,2,0e,8,-11,-3,0
*08BE0,81,primitive
2,0e,8,-7,-15,2,8,3,9,1,080,
2,8,-10,-4,1,0c0,2,8,-13,-5,1,
0e0,2,8,-7,9,1,09c,2,8,-1,14,
1,8,-6,-5,2,8,8,5,1,8,6,-5,
2,8,-11,-6,1,8,1,-3,2,8,7,3,
1,8,-1,-3,2,8,-3,15,1,01a,2,
012,1,01e,2,8,10,-14,2,0e,8,
-11,-3,0
*08C8E,44,primitive
2,0e,8,-7,-15,2,8,3,15,1,090,0fc,038,
2,8,-6,11,1,090,2,8,-9,-5,1,
090,2,096,1,0ac,8,-1,-3,01a,01a,2,8,
18,0,2,0e,8,-11,-3,0
*08CB3,61,primitive
2,0e,8,-7,-15,2,042,1,02b,02a,018,2,
0d0,1,012,034,2,069,1,01e,040,2,8,
-8,6,1,02b,2,8,4,5,1,08c,2,8,
-3,8,1,03c,2,8,-5,3,1,0e0,2,8,
-12,5,1,0a0,2,8,6,-14,2,0e,8,
-11,-3,0
*08CC3,34,primitive
2,0e,8,-7,-15,2,0c1,1,06c,0a8,064,0a0,2,8,
-5,9,1,09c,2,8,-7,5,1,0e0,2,8,
4,-11,2,0e,8,-11,-3,0
*08CFB,22,primitive
2,0e,8,-7,-15,2,0d2,1,0cc,0c8,0c4,0c0,2,8,
5,-13,2,0e,8,-11,-3,0


확장된 큰 글꼴 파일 정의 (요약 참조)

큰 글꼴 정의
확장된 큰 글꼴 파일 정의
도면에서 큰 글꼴 문자 사용
AutoCAD 2008 사용자화 안내서 > 쉐이프 및 쉐이프 글꼴 > 쉐이프 정의 파일 작성 > 큰 글꼴 설명 > 확장된 큰 글꼴 파일 정의 >
확장된 큰 글꼴 파일 정의
개념 요약 참조

명령

COMPILE

쉐이프 파일과 PostScript 글꼴 파일을 SHX 파일로 컴파일합니다.

LOAD

쉐이프를 SHAPE 명령에 사용할 수 있게 만듭니다.

SHAPE

LOAD를 사용하여 로드된 쉐이프 파일의 쉐이프를 삽입합니다.

시스템 변수

항목이 없습니다.

유틸리티

항목이 없습니다.

명령 수정자

항목이 없습니다.


도면에서 큰 글꼴 문자 사용 (개념)

확장된 큰 글꼴 파일 정의
큰 글꼴 설명
큰 글꼴을 사용하여 글꼴 확장
AutoCAD 2008 사용자화 안내서 > 쉐이프 및 쉐이프 글꼴 > 쉐이프 정의 파일 작성 > 큰 글꼴 설명 >
도면에서 큰 글꼴 문자 사용
개념 요약 참조

도면 문자에 큰 글꼴을 사용하려면 문자 스타일을 설정한 다음, 큰 글꼴 파일의 이름을 지정하십시오.

도면 문자에 큰 글꼴을 사용하려면 STYLE 명령을 사용하여 문자 스타일을 설정한 다음 큰 글꼴 파일의 이름을 지정해야 합니다. 같은 문자 스타일에 보통 ASCII 글꼴도 사용할 수 있습니다. 이 경우, 쉼표로 구분하여 두 개의 파일 이름만 입력하십시오. 다음 예제는 STYLE 명령의 명령행 버전을 사용합니다. 문자 스타일 대화상자에서 큰 글꼴을 사용 가능하게 하려면 큰 글꼴 사용 옵션을 선택하십시오.

명령: - style

문자 스타일의 이름 입력 또는 [?] <현재>: style_name

전체 글꼴 이름 또는 글꼴 파일 이름 지정(TTF 또는 SHX): txt,greek

AutoCAD에서는 첫 번째 이름은 보통 글꼴이고 두 번째 이름은 큰 글꼴이라고 가정합니다.

이름을 하나만 입력할 경우 AutoCAD는 보통 글꼴이라고 가정하고 연관된 큰 글꼴을 제거합니다.

다음 테이블에서와 같이 글꼴 파일 이름을 지정할 때 앞이나 뒤에 쉼표를 사용하여 다른 글꼴에 영향을 주지 않고 하나의 글꼴을 변경할 수 있습니다.

입력 | 결과
normal, big | 보통 글꼴과 큰 글꼴 모두 지정됨
normal, | 보통 글꼴만(큰 글꼴은 변경되지 않음)
,big | 큰 글꼴만(보통 글꼴은 변경되지 않음)
normal | 보통 글꼴만(필요에 따라 큰 글꼴이 제거됨)
ENTER(null 응답) | 변경되지 않음

STYLE 명령을 사용하여 스타일을 나열하거나 기존 스타일을 수정할 때 AutoCAD는 보통 글꼴 파일, 쉼표 및 큰 글꼴 파일을 표시합니다. 스타일에 큰 글꼴 파일만 있으면 선행 쉼표와 함께 표시됩니다(,greek).

문자열의 각 문자에 대해 AutoCAD는 큰 글꼴 파일을 먼저 검색합니다. 여기서 문자를 찾지 못하면 보통 글꼴 파일을 검색합니다.


도면에서 큰 글꼴 문자 사용 (요약 참조)

확장된 큰 글꼴 파일 정의
도면에서 큰 글꼴 문자 사용
큰 글꼴을 사용하여 글꼴 확장
AutoCAD 2008 사용자화 안내서 > 쉐이프 및 쉐이프 글꼴 > 쉐이프 정의 파일 작성 > 큰 글꼴 설명 > 도면에서 큰 글꼴 문자 사용 >
도면에서 큰 글꼴 문자 사용
개념 요약 참조

명령

STYLE

명명된 문자 스타일을 작성, 수정 또는 설정합니다.

시스템 변수

항목이 없습니다.

유틸리티

항목이 없습니다.

명령 수정자

항목이 없습니다.


큰 글꼴을 사용하여 글꼴 확장 (개념)

도면에서 큰 글꼴 문자 사용
큰 글꼴 설명
유니코드 글꼴 설명
AutoCAD 2008 사용자화 안내서 > 쉐이프 및 쉐이프 글꼴 > 쉐이프 정의 파일 작성 > 큰 글꼴 설명 >
큰 글꼴을 사용하여 글꼴 확장
개념 요약 참조

문자열에 특수 기호를 포함하려면 표준 문자 글꼴을 확장하는 대신 큰 글꼴을 사용하면 됩니다.

일부 제도에서는 문자열에 많은 특수 기호가 사용될 수 있습니다. AutoCAD 표준 문자 글꼴을 확장하여 특수 기호를 포함할 수 있습니다. 그러나 표준 문자 글꼴을 확장하는 데에는 여러 가지 제한이 있습니다.

  • 쉐이프 수는 글꼴 파일당 255개입니다.
  • 표준 문자 세트는 사용 가능한 쉐이프 수의 거의 절반을 사용합니다. 코드 1~9, 11~31, 130~255만 사용할 수 있습니다.
  • 다중 문자 글꼴의 경우에는 각 글꼴의 기호 정의를 복제해야 합니다.
  • 특수 기호는 %%nnn의 형식으로 입력해야 합니다(nnn은 기호의 쉐이프 번호).

큰 글꼴 메커니즘은 이러한 문제를 방지합니다. 틸드(˜) 또는 수직 막대(|)와 같은 잘 사용하지 않는 문자를 하나 이상 이스케이프 코드로 선택하고 다음 문자를 사용하여 해당 특수 기호를 선택할 수 있습니다. 예를 들어, 다음과 같은 큰 글꼴 파일을 사용하여 수직 막대(|, ASCII 코드 124)를 입력한 다음 그에 대응하는 로마 문자를 입력하는 방식으로 그리스 문자를 그릴 수 있습니다. 각 문자의 첫 번째 바이트가 124이므로 문자 코드는 124 x 256 또는 31744로 기울어집니다.

*BIGFONT 60,1,124,124
*0,4,Greek
above, below, modes, 0
*31809,n,uca
. . . "|A"에 의해 대문자 알파 정의가 호출됩니다.
*31810,n,ucb
. . . "|B"에 의해 대문자 베타 정의가 호출됩니다.
*31841,n,lca
. . . "|a"에 의해 소문자 알파 정의가 호출됩니다.
*31842,n,lcb
. . . "|b"에 의해 소문자 베타 정의가 호출됩니다.
*31868,n,vbar
. . . "||"에 의해 세로 막대 정의가 호출됩니다.
. . .


큰 글꼴을 사용하여 글꼴 확장 (요약 참조)

도면에서 큰 글꼴 문자 사용
큰 글꼴을 사용하여 글꼴 확장
유니코드 글꼴 설명
AutoCAD 2008 사용자화 안내서 > 쉐이프 및 쉐이프 글꼴 > 쉐이프 정의 파일 작성 > 큰 글꼴 설명 > 큰 글꼴을 사용하여 글꼴 확장 >
큰 글꼴을 사용하여 글꼴 확장
개념 요약 참조

명령

COMPILE

쉐이프 파일과 PostScript 글꼴 파일을 SHX 파일로 컴파일합니다.

LOAD

쉐이프를 SHAPE 명령에 사용할 수 있게 만듭니다.

SHAPE

LOAD를 사용하여 로드된 쉐이프 파일의 쉐이프를 삽입합니다.

시스템 변수

항목이 없습니다.

유틸리티

항목이 없습니다.

명령 수정자

항목이 없습니다.


유니코드 글꼴 설명 (개념)

큰 글꼴을 사용하여 글꼴 확장
쉐이프 정의 파일 작성
SHX 파일의 위 첨자 및 아래 첨자
AutoCAD 2008 사용자화 안내서 > 쉐이프 및 쉐이프 글꼴 > 쉐이프 정의 파일 작성 >
유니코드 글꼴 설명
개념 요약 참조

큰 문자 세트로 인해 하나의 유니코드 글꼴이 모든 언어와 플랫폼을 지원할 수 있습니다. 유니코드 쉐이프 정의 파일은 실제로 일반 AutoCAD 쉐이프 정의 파일과 형식과 구문이 동일합니다.

다음 코드에서 나타나는 것처럼 주요한 차이점은 글꼴 헤더 구문에 있습니다.

*UNIFONT,6,font-name
above,below,modes,encoding,type,0

font-name, above, below 및 modes 매개변수는 일반 글꼴에서와 같습니다. 나머지 두 매개변수는 다음과 같이 정의됩니다.

encoding

글꼴 부호화. 다음 정수 값 중 하나를 사용합니다.

0 유니코드

1 팩 다중바이트 1

2 쉐이프 파일

type

글꼴 포함 정보. 글꼴 라이센스가 있는지 여부를 지정합니다. 라이센스가 있는 글꼴은 수정하거나 교체할 수 없습니다. 비트 코드화된 값은 추가할 수 있습니다.

0 글꼴을 포함할 수 있습니다.

1 글꼴을 포함할 수 없습니다.

2 포함 글꼴이 읽기 전용입니다.

중요한 또 다른 차이점은 코드 7 하위 쉐이프 참조의 처리 방법입니다. 쉐이프 정의에 코드 7 하위하위 쉐이프 쉐이프 참조가 포함되어 있으면 코드 7 뒤에 오는 데이터는 2바이트 값으로 해석됩니다. 이 값은 쉐이프 설명 헤더의 전체 데이터 바이트 수(defbytes)에 영향을 줍니다. 예를 들어, 다음 쉐이프 설명은 romans.shp 파일에서 찾을 수 있습니다.

*00080,4,keuroRef
7,020AC,0

헤더의 두 번째 필드는 쉐이프 설명에 사용된 총 바이트 수를 나타냅니다. 유니코드 글꼴 설명에 익숙하지 않은 경우 보통 4바이트가 아닌 3바이트를 사용하는 경향이 있지만, 그러면 SHP 파일을 컴파일할 때 오류가 발생할 수 있습니다. 이러한 현상은 참조할 쉐이프 번호가 2바이트 범위(255 미만)에 있지 않은 경우에도 나타납니다. 이 값에 대해 컴파일러는 항상 2바이트를 사용하기 때문에 헤더에 이를 지정해 놓아야 합니다.

유니코드 글꼴 쉐이프 정의와 보통 쉐이프 정의 사이의 유일한 차이점은 쉐이프 번호에 있습니다. AutoCAD에서 제공하는 유니코드 쉐이프 정의는 10진수 값과 반대로 16진수 쉐이프 번호를 사용합니다. 16진수 번호는 필수는 아니지만, 16진수 번호를 사용하면 \U+ 조정 문자 값과 함께 쉐이프 번호를 상호 참조하기 쉽습니다.


유니코드 글꼴 설명 (요약 참조)

큰 글꼴을 사용하여 글꼴 확장
유니코드 글꼴 설명
SHX 파일의 위 첨자 및 아래 첨자
AutoCAD 2008 사용자화 안내서 > 쉐이프 및 쉐이프 글꼴 > 쉐이프 정의 파일 작성 > 유니코드 글꼴 설명 >
유니코드 글꼴 설명
개념 요약 참조

명령

LOAD

쉐이프를 SHAPE 명령에 사용할 수 있게 만듭니다.

SHAPE

LOAD를 사용하여 로드된 쉐이프 파일의 쉐이프를 삽입합니다.

시스템 변수

항목이 없습니다.

유틸리티

항목이 없습니다.

명령 수정자

항목이 없습니다.


SHX 파일의 위 첨자 및 아래 첨자 (개념)

유니코드 글꼴 설명
쉐이프 정의 파일 작성
AutoCAD 2008 사용자화 안내서 > 쉐이프 및 쉐이프 글꼴 > 쉐이프 정의 파일 작성 >
SHX 파일의 위 첨자 및 아래 첨자
개념 절차 요약 참조

쉐이프 정의 파일을 수정하여 위 첨자와 아래 첨자가 표시되도록 기능을 향상시킬 수 있습니다.

AutoCAD SHX 글꼴은 윗 첨자 및 아래 첨자 기능을 제한했습니다. 그러나 비교적 쉽게 쉐이프 정의 파일을 수정하여 위 첨자와 아래 첨자 기능을 향상시킬 수 있습니다.

위 첨자와 아래 첨자의 작성은 두 단계를 거쳐 수행됩니다. 우선 화면에서 벡터별로 문자를 작성하는 “가상 펜”을 위나 아래로 이동한 다음, 글꼴 “축척”을 줄여야 합니다. 또한 반전 프로세스를 수행하여 보통 글꼴로 복귀해야 합니다. 글꼴은 네 개의 새로운 키를 인식해야 합니다. 두 개는 위 첨자에 대한 것이고 두 개는 아래 첨자에 대한 것입니다. 기존 글꼴 정의가 변경되지 않도록 키보드의 숫자 키패드를 사용하여 이러한 정의에 접근할 수 있습니다.


SHX 파일의 위 첨자 및 아래 첨자 (절차)

쉐이프 정의 파일 작성
상위 단계로
AutoCAD 2008 사용자화 안내서 > 쉐이프 및 쉐이프 글꼴 > 쉐이프 정의 파일 작성 > SHX 파일의 위 첨자 및 아래 첨자 >
SHX 파일의 위 첨자 및 아래 첨자
개념 절차 요약 참조

글꼴에 위 첨자와 아래 첨자 정의를 추가하려면

AutoCAD 글꼴에 유사한 방법이 적용되지만, 이 예제 절차는 AutoCAD Romans 글꼴 파일에 기반한 것입니다. 이 절차는 글꼴에 super_on, super_off, sub_on 및 sub_off의 네 가지 새로운 쉐이프 정의를 추가합니다. 이 정의는 다음에 오는 문자의 위치 및 크기를 조정합니다. 작업을 단순하게 하기 위해 이 예제에서는 왼쪽/오른쪽 대괄호 문자([와 ]) 및 왼쪽/오른쪽 중괄호 문자({와 })를 새로운 문자로 대체합니다. 다른 문자를 대체하거나 확장 범위(ASCII 코드 128~256)의 쉐이프 번호를 사용할 수 있습니다. 확장된 쉐이프 번호를 사용하는 경우, 새로운 문자를 배치하는 데 %%nnn 메서드(nnn은 문자의 ASCII 값임)를 사용해야 합니다.

  1. ASCII 문자 편집기로 SHP 파일을 편집합니다.
  2. 대체할 문자의 쉐이프 정의를 검색합니다. 이러한 정의에 주석을 붙여서 새 정의를 작성할 경우, 쉐이프 정의의 각 행 앞에 세미콜론을 삽입합니다. 쉐이프 정의는 여러 행에 걸쳐 계속될 수 있습니다.

    왼쪽 및 오른쪽 대괄호 문자의 ASCII 값은 91과 93(유니코드 글꼴인 경우, 05B와 05D 16진수 값)입니다. 왼쪽 및 오른쪽 중괄호 문자의 ASCII 값은 123과 125(07B 및 07D 16진수)입니다.

  3. 첫 번째 값과 두 번째 값을 정의의 두 번째 행에 추가하고, 다음 보기와 같이 전체를 2로 나눕니다.
    *UNIFONT,6,Extended Simplex Roman for UNICODE
    21,7,2,0 21 + 7 = 28, then 28 / 2 = 14. 이 숫자는 나중에 사용됩니다.
  4. 다음 행을 SHP 파일의 끝에 추가합니다.
    *91,8,super_on
    2,8,(0,14),003,2,1,0
    *93,8,super_off
    2,004,2,8,(0,-14),1,0
    *123,8,sub_on
    2,8,(0,-14),003,2,1,0
    *125,8,sub_off
    2,004,2,8,(0,14),1,0

    선행 행에서 14와 –14 값을 보십시오. 이 값들은 가상 펜에 대한 Y축 간격띄우기 값입니다. 값 14는 이 글꼴에 대한 최대 문자 높이의 절반으로, 위 첨자와 아래 첨자의 정확한 근사치입니다. 각 글꼴 파일마다 이 값을 계산해야 하지만 원하는 방식으로 수정도 가능합니다.

  5. 파일을 저장합니다.
  6. COMPILE 명령을 사용하여 SHP 파일을 컴파일합니다.

    쉐이프가 컴파일되고 적절한 스타일이 정의되면 [, ], { 및 } 문자를 입력하여 새 펜 업 및 펜 다운 명령에 접근할 수 있니다. [ 문자는 위 첨자를 시작하고 ] 문자는 위 첨자에서 보통 형태로 복귀합니다. { 문자는 아래 첨자를 시작하고 } 문자는 아래 첨자에서 보통 형태로 복귀합니다.


SHX 파일의 위 첨자 및 아래 첨자 (요약 참조)

유니코드 글꼴 설명
SHX 파일의 위 첨자 및 아래 첨자
AutoCAD 2008 사용자화 안내서 > 쉐이프 및 쉐이프 글꼴 > 쉐이프 정의 파일 작성 > SHX 파일의 위 첨자 및 아래 첨자 >
SHX 파일의 위 첨자 및 아래 첨자
개념 절차 요약 참조

명령

COMPILE

쉐이프 파일과 PostScript 글꼴 파일을 SHX 파일로 컴파일합니다.

LOAD

쉐이프를 SHAPE 명령에 사용할 수 있게 만듭니다.

SHAPE

LOAD를 사용하여 로드된 쉐이프 파일의 쉐이프를 삽입합니다.

시스템 변수

항목이 없습니다.

유틸리티

항목이 없습니다.

명령 수정자

항목이 없습니다.


의견 내보내기

의견이 있으시면 이 양식을 사용해서 문서 담당 부서인 Autodesk Technical Publications 그룹으로 보내주십시오.

항목 제목 및 위치 (편집하지 마십시오.):
이름(선택사항):
         전자 우편(선택사항):
설명:

주: 이 양식은 피드백이나 기술적 지원을 받는 용도로 작성되는 것은 아닙니다. 여러분께서 보내주신 정보는 앞으로 문서를 업데이트하는 데 사용됩니다. 감사합니다!