MagicEnglish Plus : 제품개요

■ MagicEnglish Plus

MagicEnglish Plus는 자연스러운 합성음을 자랑하는 ㈜보이스웨어의 한국어 및 영어 음성합성기인 VoiceText™를 응용하여 Text문서나 웹페이지를 음성합성음으로 청취하거나 음성파일 (*.wma 또는 *.wav)로 저장이 가능한 응용 프로그램입니다.

제작된 음성파일은 개별적으로 파일형식 변환 프로그램(Freeware 또는 Shareware)을 이용, MP3 파일로 변환하여 휴대용 MP3 Player에서 사용 가능하며, 합성음 제작기능 외에 개인 단어장 합성기능, 영한사전 찾기의 교육적 부가기능을 갖춘 응용 프로그램입니다.

● 제품 주요특징

  • 2개 언어 합성음 (한국어, 영어)
  • 문서편집 및 웹브라우징 (일반문서, 인터넷 페이지 지원)
  • 합성음 파일 저장 (*.wma 또는 *.wav) : Windows Media™ Technologies 지원
  • 학습부가 기능 - 단어장, 영한사전
  • 사용자 발음사전

● 사용 시스템 환경

운영체제 (OS) | Microsoft Windows 98/98SE/ME/NT4.0/2000/XP
CPU | Pentium II급 233MHz 이상
메모리 (RAM) | 64MB 이상
하드디스크 (HDD) | 여유공간 700MB 이상
기타 | Internet Explorer 5.5 이상, Windows NT4.0 이외의 OS인 경우 - Windows Media Player 7.1 이상 Windows NT4.0인 경우 - Windows Media Player 6.4 - Windows Media Encoder 7

※ MagicEnglish Plus은 ㈜보이스웨어에 저작권이 있는 프로그램입니다.
MagicEnglish Plus 자체 또는 이 프로그램을 활용한 산출물 (WMA, WAV파일 또는 기타 변형파일 등)을 상업적인 용도나 비개인적 용도로 사용해서는 안되며, 비상업적인 용도나 개인적인 용도로만 사용해야 합니다.
이를 위반할 경우 귀하는 컴퓨터프로그램보호법에 의하여 법적인 처벌을 받을 수 있습니다.

※ Windows Media is a trademark of Microsoft Corporation
※ MagicEnglish Plus에 포함된 영문기사 Text는 ㈜코리아헤럴드에서 발췌하여 제공합니다.


MagicEnglish Plus : 메인화면

■ 메인화면
 MagicEnglish Plus의 화면은 최상단의 모드변경 (문서 모드, 웹 모드)버튼과 실행 버튼(사전, 단어장, 환경설정), 그 아래 각 모드내 실행버튼과 최하단의 음성합성 버튼들로 구성되어 있습니다.

① 문서 모드
일반 Text 문서를 새로 작성하거나 기존에 작성된 문서를 열어 청취하거나 합성음 파일로 저장할 수 있습니다.
단, 편집하는 문서나 여는 문서는 Windows NT 4.0/2000/XP의 경우는 5MB, Windows 98/98SE/ME의 경우는 50KB를 초과할 수 없습니다.
☞ 자세히

② 웹 모드
웹 페이지 상의 내용을 합성음으로 청취하거나 합성음 파일로 저장할 수 있습니다.
☞ 자세히

③ 사전
영한사전을 실행합니다. 별도의 창이 뜨게 되며 영어단어를 검색하거나 단어발음을 청취할 수 있습니다.
☞ 자세히

④ 단어장
사용자 단어장을 실행합니다. 별도의 창이 뜨게 되며 사용자가 간단하게 품사, 뜻, 예문 등을 정리할 수 있으며 정리된 단어장을 영어와 한국어 합성기로 읽어주는 합성음 파일을 제작할 수 있습니다.
☞ 자세히

⑤ 환경설정
MagicEnglish Plus 프로그램의 환경을 설정합니다. 합성기 설정, 음성파일 형식, 시작 URL, 단어장 파일 지정, 단어 합성요소 선택이 가능합니다.
☞ 자세히

⑥ 프로그램 정보
MagicEnglish Plus 프로그램의 정보를 출력합니다.

⑦ 음성합성 메뉴
문서 모드 및 웹 모드에서 사용되는 음성합성 기능에 필요한 실행메뉴입니다.
☞ 자세히


MagicEnglish Plus : 음성합성 메뉴

■ 음성합성 메뉴
음성합성 메뉴는 문서 모드, 웹 모드 상태에서 모두 동일하며 합성기의 주요기능을 수행합니다.

① 듣기
현재 문서의 내용을 합성음으로 청취합니다. 마우스로 특정 블럭을 선택하고 듣기를 실행하면 선택된 부분만 청취할 수 있습니다.

② 중지
듣기 진행중인 합성음의 재생을 완전히 중지합니다.

③ 일시중지
듣기 진행중인 합성음의 재생을 일시적으로 중지합니다.

④ 계속
일시중지 상태에서 계속 합성음을 청취합니다.

⑤ 합성저장
현재 문서의 내용을 합성음 파일 (*.wma 또는 *.wav)로 저장합니다.
합성음 파일형식은 환경설정에서 지정할 수 있습니다.
또한, 한번에 실행 가능한 합성저장크기는 Windows 98/98SE/ME에서는 50KB, Windows NT 4.0/2000/XP에서는 100KB로 제한되어 있습니다.

⑥ 사용자 발음
현재 합성기의 사용자 단어 발음을 설정합니다. (한국어, 영어 각각 별도)
현재 언어모드의 선택에 따라 각 언어별 사용자 발음설정이 가능합니다.

  • 발음 지정항목 : 사용자 발음 단어의 목록입니다.
  • 원본단어: 변경할 대상이 되는 원본단어입니다.
  • 변환발음: 변환될 발음입니다.
  • 테스트: 발음을 테스트합니다.
  • 단어추가: 사용자 발음단어 항목을 추가합니다.
  • 단어수정: 사용자 발음단어 항목을 수정합니다.
  • 단어삭제: 사용자 발음단어를 삭제합니다.
  • 확인: 현상태로 저장하고 사용자발음을 종료합니다. 확인시에는 합성정보가 다시 로드됩니다.
  • 취소: 현 변경상태의 변경을 취소하고 종료합니다.
⑦ 사전검색
영한사전에서 입력한 단어를 검색합니다.

⑧ 한국어ㆍ영어
언어의 종류를 선택합니다. (동시에 2개 언어 합성음 청취는 불가)
한국어 언어모드 선택 시에는 영어가 정확히 발음되지 않을 수 있으며, 사용자 발음 설정으로 조절해야 합니다. 영어 언어모드 선택 시에는 한글은 모두 무시됩니다.


MagicEnglish Plus : 문서 모드

■ 문서 모드
일반 Text 파일문서를 불러들여 합성기로 청취할 수 있으며, 합성음은 한국어, 영어 각각 1개의 여성음을 지원합니다. 지원 파일형식 일반 Text파일 형식 (*.txt)입니다. 편집 및 열기가 가능한 Text의 파일크기는 Windows NT 4.0/2000/XP인 경우는 5MB 이고, Windows 98/98SE/ME의 경우는 50KB입니다.

① 새문서
새로운 문서를 생성합니다.

② 열기
기존의 저장된 문서를 불러옵니다. 열기가 가능한 파일형식은 일반 Text 파일입니다.
크기제한은 Windows NT 4.0/2000/XP인 경우는 5MB 이며 Windows 98/98SE/Me의 경우는 50KB입니다.

③ 저장
현재 화면의 문서를 같은 이름으로 저장합니다. 저장 파일 형식은 일반 Text 파일입니다. (*.txt)

④ 다른 이름으로 저장
현재 화면의 문서를 다른 파일명으로 저장합니다.


MagicEnglish Plus : 웹 모드

■ 웹 모드
 웹페이지의 Text 내용을 합성음으로 청취 또는 합성음 파일로 저장이 가능합니다. Internet Explorer의 기본메뉴와 동일한 방식으로 사용할 수 있는 간편 웹브라우저입니다.

① 뒤로
뒤 페이지로 이동합니다.

② 앞으로
앞 페이지로 이동합니다.

③ 중지
웹페이지 이동을 중지합니다.

④ 새로고침
현재 웹페이지의 내용을 갱신합니다.

⑤ 홈으로
환경설정에서 지정된 시작 홈페이지로 이동합니다.

⑥ 이동
사용자가 입력한 웹페이지 주소로 이동합니다.

⑦ 즐겨찾기
Internet Explorer에서 등록된 즐겨찾기 목록을 보여줍니다. 목록에서 URL 주소 항목을 선택하시면 자동으로 이동합니다.
URL의 수정 또는 추가는 MagicEnglish에서는 불가하며 Internet Explorer에서 가능합니다.

※ 기타 웹브라우저의 네트워크 설정은 Internet Explorer의 설정을 따릅니다.
※ 웹페이지에 따라 스크립트를 사용하는 곳에서는 스크립트의 오류 등으로 인하여 브라우저가 오작동 하는 경우가 있으며, 메인창과 별도로 뜨게되는 새창에서는 MagicEnglish가 작동하지 않습니다.


MagicEnglish Plus : 사전

■ 사전
영한사전을 실행합니다. 하단의 합성메뉴에서 검색내용을 입력하고 Enter키를 누르거나 검색버튼을 눌러 실행할 수도 있으며 문서모드에서 영어단어를 더블클릭해서 사전검색을 실행할 수 있습니다.

① 검색
입력된 영어단어를 영한사전에서 검색합니다.

② 발음청취
현재 찾아진 단어의 발음을 영어합성음으로 청취합니다.

③ 단어장에 추가
현재 사전에 표시된 단어를 단어장에 추가합니다. (스펠링만 추가됨)


MagicEnglish Plus : 단어장

■ 단어장
검색한 단어를 개인적으로 정리하여 합성음으로 저장할 수 있도록 구성된 사용자 영어 단어장입니다.
1개의 단어장 파일에는 중복된 단어를 포함하여 총 200개의 단어를 정리할 수 있으며, 각 단어장내의 항목들은 [TAB]으로 구분된 일반 Text파일로 메모장에서도 편집이 가능합니다.

① 청취
단어장을 단어발음, 스펠링, 품사, 뜻, 예문을 합성음으로 청취합니다. 청취할 합성요소는 환경설정에서 선택할 수 있습니다. 단어, 스펠링, 예문은 영어합성기로 품사와 뜻은 한국어 합성기로 읽어줍니다.
단어 한 개가 선택되어 있을 경우는 1개 단어만 읽어주며 아무것도 선택이 되어 있지 않을 경우에는 단어장내의 모든 단어를 읽어줍니다.

② 멈춤
청취중인 단어장 합성음의 재생을 중지합니다.

③ 합성저장
선택한 단어를 합성음으로 저장합니다. 선택된 단어가 없을 경우는 단어장내의 모든 단어를 합성음으로 저장합니다.
저장내용은 청취내용과 동일합니다.

④ 추가
새로운 단어를 단어장에 추가합니다. 추가시 단어입력은 필수이며 품사, 뜻, 예문의 나머지 항목의 입력은 사용자가 자유롭게 편집하여 작성하여야 합니다. 단어장에는 중복된 단어를 포함하여 최대 200개의 단어를 정리할 수 있습니다.

⑤ 수정
현재 선택된 단어의 내용을 수정합니다.

⑥ 삭제
현재 선택된 단어를 단어장에서 삭제합니다.


MagicEnglish Plus : 환경설정

■ 환경설정
MagicEnglish Plus의 사용에 필요한 프로그램 환경을 설정합니다.

① 합성기능
Speed : 합성음의 재생속도를 설정합니다. 중간이 정상속도입니다.
Pitch : 합성음의 높이를 설정합니다.
반복횟수 : 합성음의 재생횟수를 설정합니다. (1~10회)
시작언어 : 프로그램 시작시 기본 언어를 설정합니다.

② 음성파일 형식
저장되는 음성파일 형식을 설정합니다. WAV와 WMA의 두가지 방식이 가능하며 WMA를 선택시에는 인코딩 음질에 따라 8가지의 인코딩 방식을 지원합니다.

③ 단어장
단어장 파일: 단어장 파일의 파일명과 경로를 지정합니다.
합성요소: 단어장을 합성음으로 재생 또는 저장할 때 합성할 요소를 설정합니다. 단어는 기본 선택이며 스펠링, 품사, 뜻, 예문 중 선별하여 합성할 요소의 선택이 가능합니다.

④ 기타
편집창 글꼴 : 편집창의 글꼴을 선택합니다.
시작 URL : 인터넷 시작 주소를 지정합니다.
웹페이지 읽기길이 지정 : 웹모드에서 지정된 길이 이하의 글자는 읽지 않습니다. 길이의 지정은 Byte수 (한국어 1글자는 2 Bytes이며 영문 1글자는 1 Byte입니다.)로 지정합니다.

⑤ 고객정보등록
인터넷을 통해 정품의 사용자 정보를 등록합니다.
고객등록을 해주시면 향후 A/S, 신제품 안내 및 할인정보 등을 접수하실 수 있으므로 반드시 정품등록을 하여주시기 바랍니다.

※ 참고: WMA 지원 인코딩 방식
WMA 지원 인코딩 형식명 | 음질 순위
낮은 비트 전송률 음성 지향 컨텐트 오디오(6.5Kbps) | 8
전화 접속 모뎀을 위한 FM 라디오 품질 오디오(28.8Kbps 모노) | 7
전화 접속 모뎀을 위한 FM 라디오 품질 오디오(28.8Kbps 스테레오) | 6
전화 접속 모뎀용 오디오(56Kbps 스테레오) | 5
단일 채널 ISDN용 오디오(64Kbps 스테레오) | 4
CD 품질에 가까운 오디오(64Kbps 스테레오) | 3
CD 품질 오디오(96Kbps 스테레오) | 2
최상위 품질 오디오(128Kbps 스테레오) | 1


MagicEnglish Plus : 단어장 활용방법

■ 단어장 활용방법
 MagicEnglish Plus의 단어장은 영어학습을 위한 부가기능으로 사용자가 필요한 영어 암기단어 목록을 작성하여 관리 또는 합성음으로 청취하거나 저장할 수 있습니다.

◆ 단어장 단어 관리
단어장에 단어를 추가하기 위해서는 단어장에서 "추가" 버튼을 누르거나, 사전에서 검색한 후 "단어장에 추가" 버튼을 누르면 단어장 편집화면에서 입력하여 추가할 수 있습니다. 현재 단어장의 단어를 수정 또는 삭제하고자 할 경우에는 해당단어를 선택한 후 "수정" 버튼을 눌러 수정하고 "삭제" 버튼으로 삭제합니다.
단어장에는 중복된 단어를 포함하여 총 200개의 단어를 관리할 수 있습니다.
단어장 목록은 각 항목별(단어, 품사, 뜻, 예문)로 오름차순 또는 내림차순으로 정렬이 가능하며 단어장 파일의 파일명과 경로는 "환경설정"을 통해 지정할 수 있습니다.

◆ 단어장 합성음 청취 및 저장
작성된 합성음은 청취버튼을 눌러 순차적으로 청취할 수 있습니다.
단어와 예문은 영어합성기로, 품사와 뜻은 한국어 합성기로 자동으로 선택하여 읽어주며 읽어줄 항목(단어, 스펠링, 품사, 뜻, 예문)에 대한 선택은 "환경설정"에서 체크박스를 통해 사용자가 선택할 수 있습니다.
부분 선택 후 "청취" 또는 "합성저장" 버튼을 누르면 선택된 단어만 청취 또는 합성음으로 저장할 수 있으며, 아무것도 선택되지 않았을 경우에는 단어장내의 모든 단어를 듣거나 또는 합성음으로 저장합니다.

※ 동일한 영어단어를 단어장내에 여러개 입력할 수 있습니다.
※ 단어장 파일은 1개 이상 작성할 수 있으며 단어장 파일 (*.vnt)은 일반 Text 편집기로도 편집이 가능합니다. 단, 각 단어장내의 각 항목은 [TAB]으로, 각 단어는 [Enter]로 구분되어 있습니다.


MagicEnglish Plus : 사용자 발음 설정

■ 사용자 발음 설정
사용자가 원하는 대로 지정된 단어를 발음하도록 지정하고자 할 경우는 하단의 "사용자 발음" 버튼을 눌러 사용자가 임의로 설정할 수 있습니다.
각 언어별 (한국어, 영어)로 사용자 발음을 설정하므로 언어선택 버튼을 확인 후에 원하는 언어에 대한 사용자 발음을 설정하십시오.
 ※ 예: 모든 문서에서 "1/4분기"를 "일사분기"로 읽도록 지정할 수 있습니다.

◆ 화면설명
① 단어항목 : 사용자 발음이 지정되어 있는 원본단어 목록입니다.
② 원본단어 : 지정할 대상이 되는 원본단어 입니다.
③ 변환발음 : 변환되어 발음하게 되는 내용입니다.
④ 단어추가 : 단어목록에 새로운 사용자 발음 항목을 추가합니다.
⑤ 단어수정 : 선택된 항목을 수정합니다.
⑥ 단어삭제 : 선택된 항목을 삭제합니다.
⑦ 테스트 : 현재 선택된 항목을 합성음으로 청취합니다.
⑧ 확인/취소 : 확인시에는 현재 목록을 저장하고 해당 언어 합성기 정보를 다시 로드하게 되며, 취소시에는 변경사항은 모두 취소됩니다.

◆ 설정 예
① 원본단어: "1/4분기", 변환발음: "일사분기"
② 위와 같이 설정시에 모든 문서내의 "1/4분기"란 단어를 "일사분기"라고 발음합니다.
※ 대소문자를 구별하므로 "Email", "eMail", "email"과 같은 단어들은 각각 추가로 설정해 주어야 합니다.


MagicEnglish Plus : 합성음 듣기 및 저장

■ 합성음 듣기 및 저장
MagicEnglish Plus는 일반 Text 문서 또는 웹페이지의 한국어 또는 영어 내용을 자연스러운 합성음으로 청취하거나 파일로 저장할 수 있습니다.
MagicEnglish Plus는 보이스웨어의 합성음 VoiceText 수진(한국어)와 VoiceText Kate(영어)의 음색을 담고 있습니다.

◆ 일반문서
① "문서" 버튼을 눌러 문서 모드로 전환합니다.
② "새문서" 버튼을 눌러 새로운 문서를 편집하여 작성하거나 기존의 작성된 Text문서를 "열기" 버튼을 눌러 불러옵니다.
③ 하단의 언어선택버튼으로 청취하고자 하는 언어를 선택한 후에 하단의 합성메뉴 버튼을 이용하여 문서의 내용을 청취합니다.
④ 전체문서의 내용중 선택 블럭을 지정하고 "듣기" 버튼을 클릭하면 부분읽기가 가능합니다.
⑤ 청취한 문서를 파일로 저장하고자 할 경우는 하단의 "합성저장" 버튼을 클릭하여 파일로 저장할 수 있습니다.
⑥ 반복 청취를 원할 경우에는 상단의 "환경설정" 버튼을 클릭한 후 합성기능에서 반복횟수를 지정하십시오.

※ 문서의 합성음 청취 중에는 화면이 회색으로 변하며 편집이 불가능합니다.

◆ 웹 페이지
① "웹" 버튼을 눌러 웹 모드로 전환합니다.
② 이동할 주소를 주소란에 입력후 [Enter]키 또는 "이동" 버튼을 클릭합니다.
③ 하단의 언어선택버튼으로 청취하고자 하는 언어를 선택한 후에 합성메뉴를 이용하여 웹페이지의 내용을 청취합니다.
④ 전체내용중 선택 블럭을 지정하고 "듣기" 버튼을 클릭하면 부분읽기가 가능합니다.
⑤ 청취한 문서를 파일로 저장하고자 할 경우는 하단의 "합성저장" 버튼을 클릭하여 파일로 저장할 수 있습니다.
⑥ 반복 청취 또는 반복음 저장을 원할 경우에는 상단의 "환경설정" 버튼을 클릭한 후 합성기능에서 반복횟수를 지정하십시오.

※ 웹 페이지의 내용 중 환경설정에서 지정한 Byte수 이하의 Text는 읽지 않도록 설정되어 있습니다.


MagicEnglish Plus : MP3 파일 형식 변환

■ MP3 파일 형식 변환
MagicEnglish Plus는 WMA나 WAV 파일 형식으로만 저장이 가능하며 자체에는 MP3 인코딩 기능이 탑재되어 있지 않습니다.
제작된 합성음(*.WMA 또는 *.WAV 파일)을 MP3 형식으로 변환하시려면 별도의 응용 프로그램(프리웨어 또는 쉐어웨어)을 사용하셔야 합니다. 변환하시면 합성음을 MP3 Player에서도 청취가 가능합니다.
(일부 MP3 Player는 WMA 파일방식을 지원하므로 해당 MP3 Player 제작사에 확인하십시오.)

◆ 좋은 음질의 MP3 파일을 제작하기 위해서는 WAV 파일을 MP3로 변환하여 사용하시기 바랍니다.

* MP3 Encoding이 가능한 Freeware
제품명 | 제작사 | 홈페이지
CDex | Albert L Faber | www.cdex.n3.net
FreeRIP MP3 | MG Shareware | www.mgshareware.com
WAV to MP3 Encoder | Mthree Development | www.mthreedev.com

* MP3 Encoding이 가능한 Shareware
제품명 | 제작사 | 홈페이지
Advanced WMA Workshop | Litex Media | www.litexmedia.com
MP3 To Wave Maker Plus | PG Star | www.pgstar.com

※ 인코딩 방법에 관해서는 각 응용 프로그램의 도움말을 참고하세요.


MagicEnglish Plus : 합성음 발음규칙 (한국어)

■ 합성음 발음규칙 (한국어)
MagicEnglish Plus는 문장을 적절히 읽기 위하여 아래와 같은 합성음 발음규칙을 적용하고 있습니다.
자연스러운 합성음을 재생하기 위해서는 본 규칙을 이용하여 문장을 작성하시면 도움이 됩니다.
* 사용자가 임의의 발음규칙을 사용자 발음을 통해 지정해 놓은 경우에는 먼저 사용자 발음규칙을 따르게 됩니다.

구분 | 문형 | 설명 | 예문
문자 | 한글 | KSC-5601 코드의 한글과 MS에서 제안한 확장 완성형 코드를 지원합니다. Unicode는 지원하지 않습니다. |
 | 한자 | KSC-5601 코드표의 한자에 한하여 한글로 소리나는 대로 발음 | 漢子
 | 영어 | 앞의 대문자 2자로 시작하는 영어문자는 모두 낱자로 읽으며, 소문자는 자체 등록된 영한단어 (약 1천단어)의 경우 한글 발음열로 발음하며 기타의 경우 영어발음규칙에 따라 한글문자열로 변환하여 발음합니다. | SC2001 apple
 | 마침표 (.) | 문장의 종결을 나타냅니다. 약 0.7초간 정지합니다. 그러나 E-mail주소에서 사용될 경우에는 "쩜"이라 발음합니다. |
 | 쉼표 (,) 세미콜론(;) | 독립된 절, 구를 연결하거나 연속된 요소를 나열해서 나타냅니다. 약 0.2초간 정지합니다. | 하나, 둘, 셋, 넷. 참가멤버는 다음과 같다; 지혜, 은주, 민호.
 | @ | @ 는 email 주소에서 사용되며 "에트"로 읽습니다. | abc@dom.com 에이비씨 에트 디오엠 닷 컴
 | % | %는 바로 앞에 숫자가 있을 경우만 "퍼센트"로 읽습니다. | 100%
 | 물음표 (?) | 의문문장의 종결을 나타냅니다. 의문사가 포함된 문장을 제외하고 모든 문장에서 올림조의 억양으로 읽습니다. | 누구세요?
 | 기타 특수기호 | 콜론(:), 하이픈(-), 괄호 ([], {},()), 느낌표 (!), 인용부호 (" "), 슬래시 (/)등의 기타 특수기호의 경우는 본 발음처리 규정에서 특수한 규칙이 적용되지 않는 한 무시됩니다. | !@#$%^&*()~<>/등은 무시함
 | URL | Dot (.)이 두개 이상이거나 "http://", "ftp://", "mailto://"로 시작되야 하며 그 자체는 읽지 않습니다.URL의 내용 중 사전에 등록되어 있는 단어는 발음나는 대로 읽습니다. | http://www.donga.co.kr (떠블류 떠블류 떠블류 쩜 디오엔지에이 쩜 씨오 쩜 케이 알) www.voiceware.net (떠블류 떠블류 떠블류 쩜 보이스웨어 쩜 네이티)
숫자 | 기수 | 최대 15자리까지 숫자 단위로 읽으며 그 이상은 낱자로 읽습니다. 도트가 있으면 소수점으로 인식하여 읽습니다. | 999,999,999,999,999 0.99 (영점구구)
 | 서수 | 특정단위를 나타내는 단어앞의 숫자는 서수로 읽습니다. 곡, 잔, 살, 돈, 명, 장, 개, 시, 자, 도, 되, 곳, 근, 권, 벌, 병, 채, 골, 자루, 다스, 봉지, 숟갈, 박스, 송이, 그루, 번째, 개월, 마리, 가지, 군데, 경기, st, nd, rd, th | 1그루 (한그루) 1송이 (한송이)
 | 가감승제 (+,-,*,/) | 숫자+"+,-,*,/"+숫자에서는 각각 프러스, 마이너스, 곱하기, 나누기로 읽습니다. 단 -는 앞에 " "(스페이스를 붙여야 합니다.) 숫자=숫자는 "이퀄"로 읽습니다. 숫자앞의 -는 "마이너스"로 읽습니다. | 3+1 (삼 플러스 일) 3 -1 (삼 마이너스 일) 2+1=3 (이 플러스 일 이퀄 삼) -10 (마이너스 십)
 | 전화번호 | 숫자-숫자와 같이 대쉬(-)로 연결된 숫자 구조를 갖은 경우는 "에"로 읽습니다. | 011-123-4567 (공일일에 일이삼에 사오육칠)
 | 단위 | 아래와 같은 단어는 숫자와 함께 연결될 때 해당 단위단어로 읽습니다. m(미터), km(키로미터), mm(미리미터), ml(미리리터), l(리터), g(그램), kg(키로그램), mg(미리그램), cr(캐럿), "(인치), ℃(섭씨), ℉(화씨), ㎕(마이크로 리터), ㎖((미리 리터), ㎗(데시 리터), ℓ(리터), ㎘(키로 리터), ㏄(씨씨), ㎣(세제곱 미리 미터), ㎤(세제곱 센티 미터), ㎥(세제곱 미터), ㎦(세제곱 키로 미터), ㎜(미리 미터), ㎝(센티 미터), ㎞(키로 미터), ㎟(제곱 미리 미터), ㎠(제곱 센티 미터), ㎡(제곱 미터), ㎢(제곱 킬로 미터), ㏊(헥타), ㎍(마이크로 그램), ㎎(미리 그램), ㎏(키로 그램), ㏏(키로 톤), ㎈(칼로리), ㎉(키로 칼로리), ㏈(데시벨), ㎳(미리 세컨드), ㎾(키로 와트), ㎐(헤르츠), ㎑(키로 헤르츠), ㎒(메가 헤르츠), ㎓(기가 헤르츠) | 10km (십키로미터) 20㏈ (이십데시벨)
 | 날짜 | YY[YY]/MM/DD (MM는 0M이 될 수도 있음) | 99/12/22 (99년 12월 22일) 2001/01/01 (2000년 1월 1일)
 | 시간 | 숫자+":"+숫자[+PM/P.M./AM/A.M.] 숫자+":"+00 | 07:25 PM (7시 25분 PM) 07:00 (7시)
 | 통화 | 통화단위+숫자(최대 15자리)[+"."+2자리 숫자] 구조로 통화단위는 $, \,￥,￡를 지원합니다. | $100 (100달러) $12.99 (12달러 99센트) \20 (20원) \100.30 (100원 30전)


MagicEnglish Plus : 합성음 발음규칙 (영어)

■ 합성음 발음규칙 (영어)
MagicEnglish Plus는 문장을 적절히 읽기 위하여 아래와 같은 합성음 발음규칙을 적용하고 있습니다.
자연스러운 합성음을 재생하기 위해서는 본 규칙을 이용하여 문장을 작성하시면 도움이 됩니다.
* 사용자가 임의의 발음규칙을 사용자 발음을 통해 지정해 놓은 경우에는 먼저 사용자 발음규칙을 따르게 됩니다.

구분 | 문형 | 설명 |  | 예문
Character | Period ( . ) | 문장의 종결을 나타냅니다. 약 0.7초간 정지합니다. 그러나 E-mail주소에서 사용될 경우에는 Period는 "dot"이라 발음합니다. |  | This is Magic English.
 | Colon ( : ) |  |  | You may write like this: "Hello!"
 | Comma ( , ) | 독립된 절, 구를 연결하거나 연속된 요소를 나열해서 나타냅니다. 약 0.2초간 정지합니다. |  | One, two, three and four.
 | Semicolon ( ; ) |  |  | No one applied for the position; the job was too difficult.
 | Apostrophe ( ' ) | 소유격이나, 특정문자의 생략 또는 복수를 나타냅니다. 본 기호를 포함한 문자는 발음나는 대로 읽습니다. |  | I'll, he's, Tom's, 100s'
 | Hyphen ( - ) | 복합어를 만들거나 날짜를 표현합니다. 복합어의 경우 소리나는 대로 읽습니다. |  | brother-in-law, 6-year-old
 | Question Marks (?) | 의문문장의 종결을 나타냅니다. 의문사가 포함된 문장을 제외하고 모든 문장에서 올림조의 억양으로 읽습니다. |  | Do you know? (c.f. What is this? : 의문사)
 | Other Special Characters | Bracket ([]), Dash (-), Exclamation Mark (!), Parenthesis (), Quotation Mark (""), Slash (/)의 경우는 본 전처리 규정에서 특수한 기호를 표시하지 않는 한 무시됩니다. |  |
 | @ | @ 는 email 주소에서 사용되며 "at"으로 읽습니다. |  | abc@voiceware.co.kr
 | % | % 는 "percent"로 읽습니다. |  | 100%
 | Abbreviation | Days | Mon. Tue. Tues. Wed. Thu. Thurs. Thurs. Fri. Sat. Sun. | Mon. = Monday ("." 는 생략가능하며 대소문자 구분)
 |  | Months | Jan. Feb. Mar. Apr. May. Jun. Jul. Aug. Sept. Sep. Oct. Nov. Dec. | Jan. = January ("." 는 생략가능하며 대소문자 구분)
 |  | Address & Thoroughfares | Bldg. Co. Dept. Hq. Inc. Ltd. Univ. aly. av. ave. blvd. cir. crk. ct. ctr. cyn. dr. expy. fwy. hwy. jct. ln. mt. mtn. pk. pkwy. pky. pl. plz. rd. sq. st. ter. terr. tpke. tr. wy. xing. | Bldg.= Building ("." 는 생략가능하며 대소문자 구분)
 |  | Titles | Dr. Jr. Ms. Mr. Mrs. St. gen. gov. mgr. rev. secy. sr. | Mr. Kim ("." 는 생략가능하며 대소문자 구분, 단 Dr. St.는 "." 생략불가)
 |  | Weights & Measures | cm. mg. ft. gal. gm. hr. hrs. hz. | 12 cm ("." 는 생략가능하며 대소문자 구분) 선행하는 Cardinal Number에 따라 단수 또는 복수로 읽음
 |  | Miscellaneous | bc. cf. cu. ea. eg. etc. ext. fig. gov't. ie. misc. No. ppd. pm. vol. vs. | Tom vs. Jerry ("." 는 생략가능하며 대소문자 구분)
 | Others | URL | "http://www." 또는 "www."으로 시작하는 인터넷 URL은 대문자로 변환 후 낱자로 읽습니다. 단, 단어로 발음이 가능할 경우는 단어로 발음 |
Numeric | Cardinal Numbers | 최대 15자리까지, 소수점 20번째 자리까지 읽습니다. |  | 999,999,999,999,999 0.999999999999999
 | Ordinal Numbers | 숫자+"st/nd/rd/th" |  | 1st, 2nd, 3rd, 4th, 250th
 | Phone Numbers | (숫자)+<공백>+숫자+"-"+숫자 |  | (02) 3016-8500
 |  | 숫자+"-"+숫자+"-"+숫자 |  | 011-123-4567
 |  | "+"+숫자+"-"+숫자+"-"+숫자 |  | +82-2-123-4567
 | Date | YYYY/MM/DD (MM는 0M이 될수도 있슴) |  | 2001/08/23
 |  | MM/DD/YYYY (YYYY는 1101~9999 가능 ) |  | 08/23/YYYY
 |  | 월+<공백>+DD,+<공백> YYYY |  | Aug 23, 2001
 | Time | 숫자+":"+숫자+PM/P.M./AM/A.M. |  | 07:25 PM
 |  | 숫자+":"+00 |  | 07:00 (Seven o'clock)
 | Currency | "$"+기수 (최대 15자리) |  | $100, $12,345,678
 |  | "$"+기수 (최대 15자리)+"."+ 숫자 |  | $12.99
 |  | "$"+<공백>+기수 (최대 15자리) |  | $ 1 ("Dollar one"으로 발음)
 |  | "$"+숫자+"."+숫자+<공백>+ "trillion/billion/million/thousand" |  | $1.5 million


MagicEnglish Plus : 설치 및 제거

■ 설치 및 제거

◆ 1. 프로그램 설치
① MagicEnglish Plus CD를 CD-ROM 드라이브에 넣습니다.
② 자동으로 설치마법사가 실행되며 자동으로 실행이 안될 경우는 Setup.exe를 실행시켜 설치프로그램을 시작합니다.
③ "다음(N)"을 클릭합니다.
④ 사용자 동의서를 잘 읽어보시고 동의서에 "예" 버튼을 클릭합니다.
⑤ 설치할 대상폴더를 "찾아보기(R)"을 선택하여 지정하고 "다음(N)" 을 클릭합니다.
⑥ 제품에 동봉된 20자리 CD-Key를 입력하고 "확인" 버튼을 클릭합니다.
⑦ 설치 마법사 프로그램이 자동으로 프로그램을 설치합니다.

MagicEnglish Plus의 설치가 끝나면 Windows Media Player의 설치과정을 수행합니다.
⑧ Windows Media Player 7.1 또는 상위버전의 설치여부를 확인합니다.
설치되어 있으면 "예(Y)"를 클릭하고 다음화면에서 "완료" 버튼을 눌러 컴퓨터를 재시작 하십시오.
설치되어 있지 않을 경우에는 "아니오(N)"를 클릭하여 Windows Media Player 설치 단계로 넘어갑니다.
⑨ Windows Media Player 설치여부를 묻는 화면에서 "예"를 선택하고 설치합니다.
"아니오(N)"를 선택하여 Windows Media Player가 설치되지 않으면 프로그램을 정상적으로 실행할 수 없습니다.
정상적인 프로그램 실행을 위해서는 추후에 반드시 Windows Media Player를 설치하여 주십시오.

※ 추후 Windows Media Player를 설치하시려면, MagicEnglish Plus 설치 CD의 Windows Media Player 폴더에 포함되어 있는 mediaplayer71.exe를 실행하십시오.
※ 프로그램의 실행은 바탕화면의 MagicEnglish Plus 아이콘을 더블클릭 하거나 시작>프로그램>MagicEnglish Plus에서 MagicEnglish Plus를 선택하십시오.

※ NT 4.0에서 설치시 유의사항
본 제품에서 사용되는 Microsoft사의 Windows Media Player 7.1이 NT 4.0을 지원하지 않으므로 NT에서 설치후 MagicEnglish 프로그램 실행이 정상적으로 작동치 않을 경우는 다음의 순서대로 서비스팩과 구버전의 Windows Media Player등을 설치하면 정상적으로 사용하실 수 있습니다.

① NT 서비스팩 3.0 이상의 버전 (최신 Service Pack 6.0 사용 권장) 인지 확인
3.0이상의 서비스팩이 설치되지 않았을 경우는 아래의 Link에서 서비스팩을 다운 받으십시오.
http://www.microsoft.com/korea/ntserver/nts/downloads/recommended/SP6/allSP6.asp

② Windows Media Player 6.4 for NT
아래 Link로 이동후 Windows 95 및 NT 4용 Player 6.4를 다운받아 설치합니다.
http://www.microsoft.com/korea/download/default.asp#section7

③ Windows Media Encoder 7.1
같은 페이지 (상기 Link)에서 Windows Media 인코더 7.1를 다운받아 설치합니다.

상기 순서대로 관련 응용프로그램을 설치하시고 MagicEnglish Plus를 사용하시면 문제없이 작동됩니다.

◆ 2. 프로그램 제거
① 제어판의 "프로그램 추가/삭제" 또는 시작>프로그램>MagicEnglish Plus폴더에서 "MagicEnglish Plus 제거"를 실행합니다.
② 제거여부를 묻는 화면에서 "확인"를 선택하면 관련 프로그램 및 폴더가 자동으로 삭제됩니다.


MagicEnglish Plus : 문제 해결

■ 문제 해결

문제점

점검내용 및 해결방법
CD-ROM에서 자동으로 설치가 안될 경우 | CD를 CD-ROM 드라이브에 넣은 뒤 자동으로 프로그램 설치가 안될 경우에는 탐색기에서 CD-ROM 드라이브를 선택한 후 "setup.exe"를 실행시켜 주십시오.
CD-Key의 문제로 제품 설치가 안될 경우 본 제품에 동봉된 CD-Key를 입력하지 않으면 제품설치가 정상적으로 되지 않습니다.
정품을 구입하였으며 동봉된 CD-Key를 입력하여도 설치가 안될 경우에는 support@voiceware.co.kr로 연락해 주시기 바랍니다.
(제품과 동봉된 고객등록카드를 작성하여 접수하여 고객등록이 되어 있어야 고객지원을 받으실 수 있습니다.)
NT 4.0에서 제품설치후 MagicEnglish 실행시 에러가 날 경우 본 제품에서 사용되는 Microsoft사의 Windows Media Player 7.1이 NT 4.0을 지원하지 않으므로 NT에서 설치후 MagicEnglish 프로그램 실행이 정상적으로 작동치 않을 경우는 다음의 순서대로 서비스팩과 구버전의 Windows Media Player등을 설치하면 정상적으로 사용하실 수 있습니다.

1. NT 서비스팩 3.0 이상의 버전 (최신 Service Pack 6.0 사용 권장) 인지 확인
3.0이상의 서비스팩이 설치되지 않았을 경우는 아래의 Link에서 서비스팩을 다운 받으십시오.
http://www.microsoft.com/korea/ntserver/nts/downloads/recommended/SP6/allSP6.asp

2. Windows Media Player 6.4 for NT
아래 Link로 이동후 Windows 95 및 NT 4용 Player 6.4를 다운받아 설치합니다.
http://www.microsoft.com/korea/download/default.asp#section7

3. Windows Media Encoder 7.1
같은 페이지 (상기 Link)에서 Windows Media 인코더 7.1를 다운받아 설치합니다.

상기 순서대로 관련 응용프로그램을 설치하시고 MagicEnglish Plus를 사용하시면 문제없이 작동됩니다.
제작된 WMV 또는 WAV 파일을 MP3 파일로 변환 하는 방법은? 제작된 합성음은 두 가지 파일형식(*.wma 또는 *.wav)으로 저장이 가능합니다.
제작된 합성음을 MP3 형식으로 변환하시려면 별도의 응용 프로그램(프리웨어 또는 쉐어웨어)을 사용하셔야 합니다. 변환하시면 합성음을 MP3 Player에서도 청취가 가능합니다.

◆ 좋은 음질의 MP3 파일을 제작하기 위해서는 WAV 파일을 MP3로 변환하여 사용하시기 바랍니다.

* MP3 Encoding이 가능한 Freeware
제품명 | 제작사 | 홈페이지
CDex | Albert L Faber | www.cdex.n3.net
FreeRIP MP3 | MG Shareware | www.mgshareware.com
WAV to MP3 Encoder | Mthree Development | www.mthreedev.com

* MP3 Encoding이 가능한 Shareware
제품명 | 제작사 | 홈페이지
Advanced WMA Workshop | Litex Media | www.litexmedia.com
MP3 To Wave Maker Plus | PG Star | www.pgstar.com

※ 인코딩 방법에 관해서는 각 응용 프로그램의 도움말을 참고하세요.
합성음이 안 들리는 경우 1. 사운드 카드의 설정을 확인하십시오.
사운드 카드의 재생제어판을 열어 재생제어 부분이나 웨이브가 "음소거"로 선택되어 있는지 확인합니다. 음소거가 선택되어 있을 경우는 선택을 풀어주십시오.
또는 재생제어나 웨이브의 재생볼륨이 너무 작게 설정되어 있으면 볼륨을 높여주십시오.

2. 언어모드 (한국어/영어)를 확인하십시오.
영어모드로 선택된 경우에 한글 내용을 "듣기" 버튼으로 누르면 아무런 합성음이 나오지 않습니다. 영어모드에서는 한글은 모두 무시됩니다.
문서파일이 열리지 않는 경우 열고자 하는 문서가 일반 Text 형식인지와 파일크기를 확인합니다.
다른 형식의 파일은 열수가 없습니다. 다른 형식의 파일 (예: doc, hwp 등)인 경우에는 Text 파일로 변환한 후에 사용하십시오.
또한 Windows 98/98SE/Me의 경우에는 50KB 이상의 파일을 열수 없으며 Windows NT 4.0/2000/XP인 경우에는 5MB이상의 파일을 열수 없습니다.
문서가 편집이 안 되는 경우 문서의 총 크기가 Windows NT 4.0/2000/XP인 경우는 5MB 이상이 되는 파일, Windows 98/98SE/Me인 경우에는 50KB 이상의 파일을 편집하실 수 없습니다. 그 이상의 문서의 편집은 별도의 파일을 새문서로 작성하거나 타 편집기를 사용하시기 바랍니다.

MagicEnglish Plus에서는 음성합성파일 저장 중 생성되는 음성파일의 크기로 인하여 Windows NT 4.0/2000/XP에서는 5MB, Windows 98/98SE/ME에서는 50KB이상의 문서는 사용하실 수 없습니다.
영한사전의 발음기호가 깨져서 보이는 경우 1. 설치 후 시스템 재부팅 확인
MagicEnglish Plus의 사전에서 사용되는 발음기호 폰트가 로드되지 않았을 경우입니다.
최초 MagicEnglish Plus를 설치한 후에 컴퓨터를 재부팅하지 않았을 경우에는 재부팅 한 후에 다시 확인해 보십시오.

2. Internet Explorer의 설정확인
Internet Explorer를 실행한 후 상단 메뉴에서 "도구>인터넷 옵션>사용자 서식"을 차례로 눌러 "웹페이지에 지정된 글꼴 스타일 무시"나 "웹 페이지에 지정된 글꼴 크기 무시"가 선택되어 있는 지 확인하십시오. 선택되어 있을 경우에는 체크를 모두 제거한 후 확인을 눌러 MagicEnglish Plus를 재실행 하십시오.
있는 그대로 합성기가 읽지 않을 경우 1. 사용자 발음지정 확인
합성기의 사용자 발음을 지정해 놓은 경우에는 사용자 발음을 설정한 대로 읽어줍니다.
이상하게 읽는 부분이 사용자 발음 설정내용에 포함되어 있는지 확인하십시오.

2. 웹 모드에서의 이상 읽기 현상
웹페이지에서는 환경설정에서 설정한 크기 (글자수가 아닌 Byte수로 지정함)만큼 읽지 않도록 되어 있습니다. 따라서 페이지내의 내용과 합성기가 읽어주는 내용이 상이할 수 있습니다.

3. 언어모드의 확인
영어모드에서는 한국어 내용은 모두 무시됩니다. 한국어에서 영어단어는 자연스럽게 읽지 못하며 사용자 발음 설정으로 변경해서 사용해야 합니다.
단어장에서 읽을 내용 (품사, 뜻, 예문)을 읽지 않는 경우 | 환경설정의 단어장관련 내용 중 최하단의 "합성할 요소"에 원하는 항목이 선택되어 있는 지 확인하십시오.
합성저장이 실행되지 않을 경우 1. 합성저장할 Text의 크기제한 확인
한꺼번에 합성저장이 가능한 Text의 크기는 Windows NT4.0/2000/XP에서는 100KB로 제한되어 있으며, Windows 98/98SE/ME에서는 50KB로 제한되어있습니다.
각 제한된 크기이하의 Text를 부분선택 하시거나 여러개의 파일로 나눠서 합성저장하시기 바랍니다.

2. 언어모드의 확인
영어모드에서는 한국어 내용은 모두 무시됩니다. 한글문서에서 영어로 선택하시고 합성저장을 한 경우에는 합성음이 저장되지 않습니다.
WMA 파일형식으로 음성파일을 저장할 수 없거나 제작된 WMA 파일을 재생할 수 없는 경우 사용자 컴퓨터에 Microsoft사의 Windows Media Player 7.1 또는 상위버전이 설치되어 있는지 확인하십시오.
사용자 컴퓨터에 설치되어 있지 않은 경우는 설치 CD에 포함되어 있는 mediaplayer71.exe 또는 마이크로소프트사 홈페이지 (www.microsoft.com/korea/windows/windowsmedia)에서 최신버전(7.1 또는 상위버전)의 Windows Media Player를 다시 설치하여 주십시오.

WinNT인 경우는 Windows Media Player 6.4와 Windows Media Encoder 7이 설치되어있어야 합니다. 설치시디의 Window Media폴더를 통해서 설치하실수 있습니다.
"wmvcore.dll을 찾을수 없습니다" 란 에러메시지가 나올 경우 사용자 컴퓨터에 Microsoft사의 Windows Media Player 7.1 또는 상위버전이 설치되어 있는지 확인하십시오.
본 에러메시지를 받았을 경우는 하위버전의 Windows Media Player가 설치되어 있는 경우입니다.
사용자 컴퓨터에 설치되어 있지 않은 경우는 설치 CD에 포함되어 있는 mediaplayer71.exe 또는 마이크로소프트사 홈페이지 (www.microsoft.com/korea/windows/windowsmedia)에서 최신버전(7.1 또는 상위버전)의 Windows Media Player를 다시 설치하여 주십시오.

WinNT인 경우는 Windows Media Player 6.4와 Windows Media Encoder 7이 설치되어있어야 합니다. 설치시디의 Window Media폴더를 통해서 설치하실수 있습니다
저장된 합성음의 음질이 좋지 않을 경우 환경설정의 음성파일 저장 형식을 변경하십시오. WAV형식은 1가지 방식이며, WMA파일 형식은 총 8가지의 인코딩 방식을 지원합니다.
테이블의 아래쪽으로 갈수록 음질이 좋아지지만 파일 크기가 커지는 단점이 있습니다.
WMA 지원 인코딩 형식명 | 음질 순위
낮은 비트 전송률 음성 지향 컨텐트 오디오(6.5Kbps) | 8
전화 접속 모뎀을 위한 FM 라디오 품질 오디오(28.8Kbps 모노) | 7
전화 접속 모뎀을 위한 FM 라디오 품질 오디오(28.8Kbps 스테레오) | 6
전화 접속 모뎀용 오디오(56Kbps 스테레오) | 5
단일 채널 ISDN용 오디오(64Kbps 스테레오) | 4
CD 품질에 가까운 오디오(64Kbps 스테레오) | 3
CD 품질 오디오(96Kbps 스테레오) | 2
최상위 품질 오디오(128Kbps 스테레오) | 1